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Introduction
LiDAR360 is a powerful LiDAR point cloud data processing and analysis platform which can
simultaneously process more than 300G point cloud data with more than 10 advanced point cloud data
processing algorithms. The platform includes a wealth of editing tools and automatic navigation tape
splicing capabilities for the terrain, forestry, mining and power industries (see LiPowerline software).

The Terrain module is a suite of GIS tools used primarily for the generation of industry-standard
topographic products. Our point cloud filtering algorithm can precisely extract ground points under
complex landscapes and therefore improve the terrain surveying accuracy. The module can also fuse
point cloud and image to produce real projective image and other products.

The Forestry module brings important technological innovations to forest inventory and analysis. The
parameters of tree height, DBH and crown diameter can be obtained by individual tree segmentation
algorithm. A range of regression models for predicting forest structures from LiDAR variables are also
provided.

Specifically, LiDAR360 has the following modules:

Strip Alignment: — Point clouds from overlapped strips can be automatically aligned based on strict
geometric model. The software can display aligned strips in real-time and generate aligned point
clouds with high accuracy. In addition, the software provides a range of data quality inspection and
analysis tools to ensure data accuracy.

Data Management: — LiDAR360 provides management tools for point cloud and raster data, which
include format conversion, point cloud de-noising, normalization, raster band calculation and so on.

Statistics — Statistical analysis of point clouds based on points, point density, Z value, etc., and
evaluate data quality.

Classification — LiDAR360 provides a variety of classification functions, including ground point
classification, model key points classification, selection area ground point classification, machine
learning model classification (can efficiently separate buildings, vegetation, street lights and other
general categories), deep learning model classification, custom deep learning classification, etc.

Vector Editing — Vector editing function completes the vectorization part of the digital line drawing
process. Relying on the excellent display effect of point cloud, it provides a high-contrast base map,
which can clearly distinguish the contouring of ground objects such as houses, vegetation areas,
roads, street lamps, water areas and bridges to assist the vectorization of ground objects. At the
same time, vector results can be edited, checked and drawn by combining image or model data. A
variety of semi-automatic and manual vector chemical tools can be provided to facilitate the
acquisition of two-dimensional and three-dimensional vectorization results.

Terrain — LiDAR360 generates useful terrain and forest information by generating digital elevation
models, digital surface models and canopy height models; the provided section analysis tools can
generate cross-section products; It can also generate contour line, mountain shadow, slope, slope
direction, roughness and other products. At the same time, it also provides the model data editing
function.



ALS Forest — Based on ALS (Airborne Laser Scanning) data, the module can extract a series of
forestry parameters (such as height quantile, leaf area index, canopy density, etc.), segment
individual trees and extract their parameters (including tree position, tree height, DBH, CBH, crown
width, etc.), and use multiple regression analysis functions of the software combining with ground
survey data to invert functional parameters such as forest biomass and stock.

TLS Forest — Based on TLS (Terrestrial Laser Scanning) or backpack lidar point cloud data, it can
extract DBH (Diameter at Breast Height) and the number of trees with batch processing, segment
individual tree and calculate parameters of them (position, height, DBH, etc.), measure and edit
individual tree attributes.

Geology — Extraction of terrain features, geological structure surface features, etc. based on airborne
lidar point cloud data.

Mine - Based on LiDAR point cloud data, it can build underground roadway 3D model construction,
closed model volume measurement, volume change analysis, and open-pit mine slope line extraction,
etc.

Building Modeling - Providing a set of airborne point cloud data 3D vectorization construction tools.
The 3D building model can be automatically constructed by using 2D base map, which preserves the
topological structure of the building model, and provides a series of surface editing and edge editing
tools. The model is at LOD2 level according to the model level description.

Power Line — A clearance distance analysis report can be obtained based on airborne LiDAR point
cloud data, including calibration tower, data classification, and danger point detection.

LiDAR360 Versions

Modules Free Version Full Version

Data Visualization √ √

Mass Data Support √ √

Data Management 7-Day Free Trial √

Strip Alignment 7-Day Free Trial √

Statistics 7-Day Free Trial √

Classify 7-Day Free Trial √

Terrain 7-Day Free Trial √

Vector Editing 7-Day Free Trial √

ALS Forest 7-Day Free Trial √

TLS Forest 7-Day Free Trial √

Geology 7-Day Free Trial √

Mine 7-Day Free Trial √

Building Modeling 7-Day Free Trial √

Power Line - √



Get Started
Please refer to Installation and License to install LiDAR360 software. Please refer to the User Guide to
use the software.



Installation
Download the latest version of LiDAR360 Suite from the GreenValley International official website before
installation.

System Requirements

RAM: at least 8 GB or more.
Central Processing Unit (CPU): Intel® Core™ i5/i7; Dual-core processor.
Display adapter: NVIDIA graphics above GTX 970, video memory no less than 4GB.
Operating system: Microsoft Windows 7 (64-bit), Microsoft Windows 8 (64-bit), Microsoft Windows
10 (64-bit), Microsoft Windows 11 (64-bit), Microsoft Windows Server 2012 and higher.

Note: Please enable high-performance graphics mode for running the software.

Note: For "use shaders to render the point cloud color strategy","Mesh Editor", "Building Model
Display", etc. you will need a display adapter that supports at least 4.6 OpenGL and glsl versions and
at least 4GB of video memory.

Setup

1. Run the LiDAR360 Suite Setup Wizard.
2. Click "Next" button in the Welcome Interface.
3. Click "I Agree" button to continue if you accept the License Agreement.
4. Choose the installation path (or use default path), then click "Install" button.
5. Click "Finish" button after installation.

License Manager

There are two licensing approaches to activate LiDAR360, by license dongle or license code. A hard lock
license provides a USB flash drive, and a soft lock license provides an authorization code. For license
dongle, users must not format, delete, or copy the license dongle.

1) License dongle

Properly insert a license dongle to USB port to activate LiDAR360.

2) License code

License code would be generated based on activation information given by LiDAR360 users. After
purchasing a license code, please follow the following steps to activate LiDAR360.

1.Run the software LiDAR360.

2.Click File > Activate License, the License Manager window will pop up.

3.Fill in your name and company name, select the modules you want to activate, and then click “Copy”.

4.Email the copied information to info@lidar360.com.

mailto:info@lidar360.com


5.There are two licensing modes: single use licensing and concurrent use licensing.

Single Use Licensing

Activation/Update

Online activation/update: When connecting to the Internet, under the “Single Use Licensing” tab,
enter the authorization key, select “Online”, and click “Activate” to activate or update, or you can
select the authorization code in the Key list, right-click the right mouse button, and choose
“Activate key” from the displayed menu. Under “General Information” page, you may also check
the expiration date for each individual module. If you need to set up proxy to connect to the
Internet, click  to use proxy and to set up the address, port, user name, and password.

Offline activation/Update: Enter the authorization code, select Offline, click “Generate Request
File” button to generate the request file (.req). Use a computer that can connect to the Internet to
browse to https://user.bitanswer.cn, enter the authorization key to log in, click “Offline Update”,
upload the request file (.req), and download the generated upgrade file (.upd). On the license
management interface, click “Apply License File”.

https://user.bitanswer.cn


Revoke

To unbind an activation key from a computer, user could revoke the activation key online or
offline. After the authorization key is revoked, it can be reused on the same computer or a
different one.

Online Revoke: In “Single Use Licensing” tab, enter the authorization key, select “Online”, and
click “Revoke” to revoke the key. If you need to set up proxy to connect to the Internet, click 
to use proxy and to set up the address, port, user name, and password.

Offline Revoke: Enter the authorization code, select “Offline”, click “Generate Revoke File” button
to generate the revoke request file (.req). Use a computer that can connect to the Internet to
browse to https: //user.bitanswer.cn, enter the authorization key to log in, click “Update Offline”,
upload the request file (.req), and download the generated upgrade file (.upd); On the license
management interface, click “Apply License File”.



Delete

To delete authorization information from the computer, right-click on the authorization key and
select “Delete Key”. After being deleted, the same activation key can only be used on the same
computer.

Concurrent Use Licensing

Install the Group authorization service tool on the group server on the LAN and add the Group service
extension module. Activate the authorization code online or offline in the Group authorization
management center. Other users on the LAN enter the server IP address on the license activation
page. The default port number is 8273. Click Apply.



6.Click the  button on the top right corner of License Manager interface to view the license manager
user guide.

Note: If any of the software instance is being opened while updating the license, please restart the
software.

Note: If an user would like to move a key from one computer to another, he/she should revoke first,
then activate on the other. If the license code has been deleted, the user should reactivate on the
same computer first, then revoke and activate this key on the other computer.

Note: Please contact info@lidar360.com to make an inquiry and purchase a license key to activate
LiDAR360.

Languages

Currently, the supported languages are English, Chinese, French, and Japanese. The user can change
the menu language in the following way:

1. Click Ribbon Toolbar in the upper right and click Display Setting > Language >
English/Chinese/French/Japanese* in the menu bar.

2. Click “Yes” in the pop-up to restart the software immediately, or click Cancel and restart later. If
“Cancel” is selected, the software does not restart and will be displayed in the selected language the
next time the software is started.

Use shaders to render the point cloud color strategy

Currently, the software provides the option of using shaders to render the color strategy of point cloud.
Users can choose according to their needs. The selection steps are as follows:

1. Click Ribbon Toolbar in the upper right and click Display Setting > Rendering > Use shaders to render
color strategy

mailto:info@lidar360.com


2. Click “Yes”, you will be prompted whether to restart the software. You can complete the switch of the
color strategy of the rendering point cloud if you restart. If “Cancel” is selected, the software does not
restart and will be rendered with the preset color policy the next time the software is started.

3. "Use shaders to render color strategy" refers to that the same point cloud can be displayed in different
Windows according to different color strategies, and the rendering adopts the programmable pipeline
shader technology.



Tool Reference
This chapter describes the usage of menu bar, toolbar, project management windows and toolbox of
LiDAR360 in detail.

Start Page

Toolbar

Quick Toolbar

Ribbon Toolbar

Project Manager Window

Ribbon Tab

File

Tools

Preprocessing

Classification

Terrain

ALS Forest

TLS Forest

Power Line

Mine

3D Building

Display

Profile Editor

Profile View

ToolBox

Strip alignment

Data Management

Statistics

Classification

Terrain

Vector editing

ALS Forest



TLS Forest

Mine

Building modeling

Power Line

Geological Analysis



Start Page
Start page is shown as figure below:

Start page can be closed by the close button. Also, users can set Start or Close Start page by checking
the box in [Display]->[Show/Hide]->[Start Page].

What's New

What's New shows the new features in the new version.
Start includes:New Project, Open Project, Add Data

Recent Files

Recent files is shown here. Users can left-click and add the file into viewer. If there is no current viewer, a
viewer will be created and the data will be added to it.

Resources

Resources includes：Visit Company Website, Quick Start, Submit An Enhancement, Submit A BUG,
Check for Updates, Projection Datum Grid, About.



Toolbar
This chapter aims to introduce ToolBar of LiDAR360.The toolbar is at left-side by default, including
Colorbar, Viewing and Setting.

Color Tools

Viewing Tools

Setting Tools



Color Tools
With tools in this section, LiDAR360 allows you to visualize vast amounts of point cloud or DEM using the
best data representations for your analysis. You can change the coloration of the point cloud displaying by
classification. You can also enhance the render effect using visualization tools such as EDL, PCV and
Glass which are intuitive and helpful for quality check.

View Mode

EDL

Real-time Contour

Glass



View Point Cloud Display

Steps

1. Select the window to set the point cloud data display mode.
2. Select the display mode to be set: Currently, there are nearly 20 supported display modes, including

display by elevation, display by intensity, display by category, display by RGB, display by GPS time,
display by tree ID, and mixed display.

3. Set the parameters according to the selected mode. The selected window will update and display the
color of the point cloud data according to the set parameters.

The following image shows the rendering by tree ID:

Function Description：Display or hide the point cloud display mode setting interface, as shown
in the figure.



Display by RGB

1. Select the window to set the display mode.
2. Choose the type of point cloud.
3. Select "Display by RGB" to show the point cloud according to its RGB properties.
4. Click on the color selection button and a pop-up window will appear for selecting colors. Set up your

desired color in this window or click on "Pick Screen Color" button, then click on a pixel in the point
cloud window that you want to pick (for example ground color). Click "OK" when finished with color
selection.

5. Check "Certain color display", which will bring up a buffer setting interface where you can choose to
display only points with selected colors (for example, only showing ground points).

6. Modify buffer values to adjust allowed range of displayed colors. The left image below shows display
by RGB while right image shows specified color rendering.

Vector Display

Vector supports four modes: elevation, file, contour, and layer.

Contour display is only effective for shp format files generated from contour lines created using point
clouds.



Display by EDL

Steps

1. Click the window that loads point cloud data with the left mouse button and set it as the active
window.

2. Click the button  on the toolbar. The visual effects of the point cloud data in the scene will be
improved with EDL mode. The following picture shows the comparison before and after using EDL
display mode.

Note: This tool only works with point cloud data.

Brief: This tool is used to display the point cloud data and enhance the visual effects of the
contour features using the Eye Dome Lighting (EDL) mode. EDL is a shading technique that
works with other display mode (e.g. display by height, display by intensity) to improve the depth
perception in 3D point cloud visualization.



Real-time Contours
Brief：Enables real-time contour effects on point clouds and model data within the window.

After clicking this function, you can enable or disable the real-time contour line effect on the point cloud
and model data in the current window. The following figure shows the effect of enabling real-time contour
lines:

Contour parameter settings refer to Display Settings > Render Settings > Real time Contour Settings.

Note: Real-time contour line effects can be superimposed with other display effects, and are effective
for point clouds and model data.



Glass Shader
Brief: With the glass shader point cloud object appears translucent.

This effect can be enabled/disabled for individual display window. An example is shown as follows.

Note: The Glass Shader is only applicable to point cloud data.



Viewing Tools
Set current active window to some view.

Note: The above function is only for 3D display view; this function does not reset the center position
of the viewpoint, if you want to reset to the default viewpoint, please click Global Display .

Top View: Set the camera position to view the top view, that is, view from +z to -z direction
Three-dimensional data, the plane is the xy plane.

Botton View: Set the camera position to view the bottom view, that is, view from -z to +z direction
Three-dimensional data, the plane is the xy plane.

Left View: Set the camera position to view the left view, that is, view from -x to +x direction
Three-dimensional data, the plane is the yz plane.

Right View: Set the camera position to the right view, that is, view from +x to -x direction Three-
dimensional data, the plane is the yz plane.

Front View: Set the camera position to the front view, that is, view from -y to +y direction Three-
dimensional data, the plane is the xz plane.

Back View: Set the camera position to back view, that is, view from +y to -y direction Three-
dimensional data, the plane is the xz plane.

Front Isometric View: Set the camera position to 45° front tilt in xy.

Back Isometirc View: Set the camera position to 45° backward in the xy plane.

Set Projection Mode: Change the projection mode of the view, the view supports two projection
modes: orthogonal and perspective . View only for 3D display. Shortcut key: F3



Setting Tools
Basic settings for viewers.

Full Extent

Cross Selection

Configure Point Size and Type

Options

As 2D

As 3D

New Window

Profile View



Full Extent

Steps

1. Click the window that contains data with the left mouse button and set it as the active window.
2. Click the button  on the toolbar. All the data in the active window will be scaled automatically to

cover the entire window, as shown below.

Note: When there are multiple windows, this tool only works on the active window.

Brief: This tool is applicable to all data types supported by LiDAR360. It makes all the data cover
the entire window in top view and provides full view of all the data.



Cross Selection

Steps

1. Click this button to open the dialog shown below:

2. The buttons of translation, rotation, and scale ratio control the translation, rotation, and scale ratio of
the ROI.

3. Click button  to stop the editing of the ROI and return to the normal interactive user-interface.
4. Click button  to reset ROI.
5. Click button  to export point cloud inside the ROI to a new LiData File.
6. Click button  to exit cross selection.
7. The whole display effect is shown below. Drag any face of the ROI to translate it. And the dragged

face will be highlighted. Drag the red, green, or blue track circle to rotate the ROI about the X, Y, or Z
axis. The dragged track circle will be highlighted. Drag the green square to rescale the ROI. The
dragged square will be highlighted.

Brief: Cross select partial point cloud using ROI. The boundary and the rotation angles of the ROI
can be entered in the user-interface, or interactively changed by using the mouse. This function
can be used for flood analysis and other applications.



Settings

Hot Key: Not applicable.
Prerequisite: Current viewer contains point cloud.
Translation: Switch of using mouse to translate the ROI.
Scale: Switch of using mouse to rescale the ROI.
Rotation: Switch of using mouse to rotate the ROI.
Boundary of ROI: Precisely control the max. and min. value in X, Y, and Z direction of the ROI.
Rotation angles of ROI: Control the rotation angles of the ROI in X, Y, and Z axis.

Note: This function is for all point clouds in the current viewer.



Configure Point Size and Type

Steps

1. Click this button to open the dialog shown as below:

2. Configure point size and type.

Settings

Circular Points: Determine point type. If checked, point will be rendered as circle, otherwise, point
will be rendered as square.
Fixed Size: If checked, point size would be fixed. User can adjust point size using the slider below
(range 0-50 pixels).
Point Autosize: If checked, point size is auto changing based on the depth of the viewer.

Note: This function is global. If user wants to configure a single point cloud, just right-click it, select
Configure Point Size and Type from the context menu.

Brief: Configure point size and type.



As 2D

Steps

1. After clicking this button, current active window will switch to 2D mode, as shown below:

2. When the display mode of the window is switched to 2D, rotation angle setting slider will be displayed
in the status bar. Drag the slider to change the rotation angle of that window. The range of the rotation
angle is [0°, 360°). Clockwise rotation angle is positive. See details below:

Note: If current active window contains raster data, it can only be set to 2D mode. After removing
raster data, it can be set to 3D mode.

Brief: Switch current active window to 2D mode.



Profile View

The use of LiDAR data to produce high-precision terrain products requires manual inspection of the
results of automatic classification. In this case, profile viewing tools are required. LiDAR360 provides
profile view function starting from V5.0 version, which can complete classification inspection more
efficiently.

Draw Profile

Profile Viewer Tool

Profile and Measurement Tools

When the profile is turned on, the point cloud window does not support the measurement function. The
profile window supports single-point selection, multi-point selection, length measurement, angle
measurement, slope measurement, and height measurement.

Section Window and Strip Alignment

In the track stitching function, we need to view the data position difference between different flight belts
caused by the set-up angle error in the profile window.

The above picture can clearly see the relative position of the point cloud before splicing.

Description: The section editing function allows the user to display the point cloud data of any
rectangular area in the main window in the section window, which is convenient for the user to
view, measure, and modify the class.



During the splicing process, you can view the splicing effect of different parameters in real time through
the section window:

After ensuring that it is correct, the point cloud can be transformed according to the current parameters
and written directly to the disk.

Profile View and Strip Alignment

The measurement tools of the profile window can also assist in the error estimation of the pitch, roll and
heading angles in Strip Alignment function. Please refer to Strip Alignment for more details.

Profile View and ALS Editor

When the ALS Editor toolbar is opened, the host window will be set to 2D view. The Profile tool can help
to check whether the seed points positions are accurate in 3D. Please refer to ALS Editor for more details.

Note： ALS Editor has its own profile tools.

Profile View and TLS Editor

When the TLS Editor toolbar is opened, the host window will be set to 2D view. The Profile tool can help to
check whether the seed points positions are accurate in 3D. Please refer to TLS Editor for more details.

Note： TLS Editor has its own profile tools.



Quick ToolBar
Quick Toolbar is at the upper-left corner of interface, includes: Add and Merge Point Cloud Data

Add Data, Delete Data, Export Data, Open Project, New Project, Save Project, Save As。



Add Data

LiDAR360 supports point cloud data formats including LiData (*.LiDataProprietary LiData File), LAS
(*.las,*.laz), ASCII (*.txt, *.asc, *.neu, *.xyz, *.pts, *.csv), PLY (*.ply), E57(*.e57), PCD(*.pcd).LiData is a
customized point cloud data format. All analysis and processing operations related to point clouds are
based on this format. After importing point cloud data in LAS, ASCII, PLY, E57, PCD and other formats
into the software, the corresponding LiData format will be automatically generated.

When loading data for the first time, data will be converted into LiData format which can support efficient
browsing and processing of massive data according to the pop-up loading interface and different
requirements of users.

ClickFile->Data->Add Data (in addition, you can also click ) to bring up the Add Data interface.

Add LAS Data

1. Select the LAS file to be loaded, the first load will bring up the screen shown in the following figure.
The top of the screen shows the path of the LAS data to be opened. The Header tab describes the
information about the LAS header file.Contains the LAS data version number, source ID, system
identifier, generating software, file creation date, file header size......From the start of the file to the
first point data record the number of bytes of the first field, the number of variable length records, the
point data format ID, the number of point data records, whether to compress, the number of points of
each echo count, X/Y/Z scale factor, X/Y/Z offset, the minimum X/Y/Z coordinates, the maximum
X/Y/Z coordinates and other information.

Functional Description: Data types supported by LiDAR360 include point cloud, raster, vector,
table, model, trajectory and aerotriangulation project.



2. Thinning The option tab allows you to thin the point cloud when it is opened. Thinning supports two
modes. Spatial thinning and voxel thinning.

Take one point at n Point (default "1"): Import one point every n points.
Voxel Sampling: The voxel thinning method reduces the point cloud density by removing some
points that are close to each other or within a grid cell of a given size. Firstly, the mesh is refined
based on 3D gird, and then a point in the grid is retained with the corresponding strategy.
Voxel size (default: 0.05): Grid cell size for voxel sampling.
Keep (default: "first point"): Used to determine how the algorithm preserves points entering the
grid. See the table below for methods and descriptions.

Reserve the point policy description

First point The first point to enter the voxel is reserved

Highest point The highest point in the voxel is reserved

Lowest point The lowest point in the voxel is reserved

Median Z Point Points in the grid whose Z value is in the middle position are reserved

Average Point The average point is the average of all the points in the voxel

Voxel Center point Keep the center of the voxel, not the point cloud

Highest Intensity The most reflective points in the voxel will be retained

Lowest Intensity The least reflective points in the voxel will be retained

Max GPS Time The latest point in the voxel is reserved

Min GPS time The earliest point in the voxel is reserved

1. Attribute selection. Select attributes and additional attributes of LAS data. By default, all properties of
LAS data are imported.

2. Select a coordinate system or coordinate conversion. You can define coordinate system for point
cloud data, or do re-projection or custom coordinate transformation. The corresponding coordinate
system can be quickly found by inputing the keywords of coordinate system, or click the drop-down



menu of add coordinate system button and import coordinate system from WKT or PRJ. Refer to
Reprojection.

3. Projection transformation.

Source coordinate system. If the user only selects the "source" coordinate system, the "source
coordinate system" will be defined by the imported point cloud and overwrite the existing
coordinate system of the Las file. Similar to the function "Define Projection".
Target coordinate system. If the user has selected the "source" coordinate system, the "target
projection" can also be selected to complete the reprojection operation. When the user selects
the target coordinate system, the "source" coordinate system must be selected.

4. Coordinate Conversion.

Users can define and apply coordinate conversion relationships such as seven-parameter, four-
parameter, 3D affine conversion, XYMultiply, and linear conversion to point clouds. Refer to
creating a transformation relationship.

5. ClickApplyto import the selected LAS data into the software using the current settings, and start to
load the point cloud. If you selectApply All, this setting will also be adopted for other LAS data that
you imported before closing the software, and the dialog box for opening LAS data will not pop up
again.

Import TXT File

1. Select the TXT file to be loaded, and the interface as shown in the following figure will pop up:



The data path to be opened is displayed at the file name, and if there is a header in the data, the
header line is highlighted in red. Open the additional attribute page, check the required additional
attribute information, double-click the column name of "Attribute name" to edit the additional attribute
name, and select the data type of the additional attribute. Currently, only Integer and real data types
are supported for ASCII data.

1. Delimiter. In general, the software can automatically identify the Separator of a file and the user can
select the corresponding Separator in the separator column.

2. Skip data: File headers and other unwanted data can be ignored by skipping line X on the Skip lines.

3. Data selection: The software will select the column where X, Y and Z are located by default. The user
can click the drop-down button above each column to select the corresponding attribute of the data in
each column. Select Ignore to ignore the column data, which can be imported as an additional
attribute.

4. Click the additional attributes page and select the additional attributes to be imported. The attributes
can be renamed. Double-click the corresponding attribute name in the "Attribute name" column for
modification. The types of additional attributes support integers and reals.

5. Thinning Refer to "thinning" in LAS Data.
6. For coordinate system and coordinate conversion options, see "Select Coordinate System or

Coordinate Conversion” in Add LAS Data.



Import CSV File

1. Select CSV data to load and the interface as shown in the following figure will pop up:

CSV data can be optionally opened as a table or a point cloud.

2. In general, if the CSV file is generated by tree segmentation, you are advised to open it as a table.
The data type can be points or circles. If you select the point mode, specify the columns
corresponding to X, Y, and Z. If you choose to display in a circle, in addition to X, Y, and Z, you also
need to specify the columns corresponding to the diameter of the circle:

3. The Display label’s check box determines whether to display labels of each point or circle in the
software. If you select display labels, specify columns corresponding to the labels, for example, ID of
the segmented tree. If you select open as a point cloud, it will pop up the same page as that displayed
for opening TXT data. For details, see the description of adding TXT data.

Import PLY File

1. Select CSV file to load and the interface as shown in the following figure will pop up:



2. Specify the attributes corresponding to the X, Y, and Z coordinates.

3. Select the corresponding fields if there is Intensity information, and select the attributes corresponding
to R, G, and B if there is color information. If not, select None.

4. Click the additional attributes page. If the PLY file has Normal X,Normal Y. Then you can import the
Normal information as an additional attribute, and other additional attributes are displayed in the list.
Choose the selected information to generate related additional attributes.

5. For coordinate system and coordinate conversion options, see "Select Coordinate System or
Coordinate Conversion” in Add LAS Data

6. Thinning Refer to "Thinning" in LAS Data.
7. After setting, clickApply.

Import E57 File



1. Select the E57 file to be loaded.When loading for the first time, the interface as shown in the following
figure will pop up. The top of the interface displays the path of E57 data to be opened. The Header
tab describes the E57 header file information, including the name of the scanned data node of E57
data, the version number, the XYZ scaling factor, the offset, and the surrounding box information.

2. In Option tab, you can select to thin the point cloud when it is opened and open all points by default.
You can also select the attributes of E57 data and additional attributes and import all attributes of E57
data by default.

3. For coordinate system and coordinate conversion options, see "Select Coordinate System or
Coordinate Conversion” in Add LAS Data

4. Thinning Refer to "Thinning" in LAS Data.



5. ClickApplyIndicates that the selected E57 data is imported to the software using the current settings,
and loading the point cloud . If you chooseApply All, this setting is adopted for all data opened this
time. The E57 data opening dialog box will not pop up again until E57 data is opened again.

Import PCD File

LiDar360 supports the reading of several PCD fixed fields:

The PCD field corresponds to the attributes read into 360

x/y/z x/y/z

normal_x Additional attribute - The x-component of Normals

normal_y Additional attribute - The y-component of Normals

normal_z Additional attribute - The z-component of Normals

intensity Intensity values

rgb r, g, b components of rgb point cloud

1. Select the PCD file to be loaded. The interface shown in the following figure will pop up when the
PCD file is loaded for the first time.

2. In Option tab, you can select to thin the point cloud when it is opened, and open all points by default.
You can also select the attributes of PCD data and additional attributes, and import all attributes of
PCD data by default.



3. For coordinate system and coordinate conversion options, see "Select Coordinate System or
Coordinate Conversion” in Add LAS Data

4. Thinning Refer to "Thinning" in LAS Data.

Import Raster File

Raster file is a data form that divides the space into regular grids, each grid is called a cell, and assigns
corresponding attribute values to each cell to represent the entity. In its simplest form, a raster consists of
a matrix of cells (pixels) organized into rows and columns (grid) where each cell contains a value
representing information. The position of each cell (pixel) is defined by its row number, and the entity
position represented is implicit in the raster row position. Because of this, it is often easy to write efficient
code quickly while doing data analysis.

1. Click File > Data > Add Data.

2. Select the raster data to be loaded and click open.

Import Vector File

Vector data can be represented in its original resolution and form, graphical output is often more aesthetic
(compared to traditional map representation), it doesn’t require data conversion, and can maintain
accurate geographic location. .shp, .dxf, and.kml formats are supported.

1. Click File > Data > Add Data.

2. Select the vector data to be loaded andclick open.

Import Model File

LiDAR360 support Model data formats including Model (*.LiModel,*.LiTin,*.LiBIM,*.LiTree), OSG
data(*.osgb,*.ive,*.desc,*.obj), DXF File (*.dxf), among which LiModel file generates regular triangulation
model according to DEM or DSM, saves regular grid dot, organizes and stores regular triangulation model
in blocks according to quad-tree, and can also superimpose DOM texture information on it. LiTin fileis an



irregular 2.5D triangulation model generated according to the point cloud. It is colored according to the
elevation, and the light and shadow effects are used to improve the display effect. It can be flat, delete,
add vertexes, increase the fracture line and other editing, improve the quality of contour generated
according to it. LiBIM is a building model based on the point cloud. LiTree is a tree model filegenerated
based on individual tree information.

1. Click File > Data > Add Data.

2. Select the model data to be loaded andclick open.

Note: LiDAR360 supports drag and drop to add data. If it doesn't work, clickhereto see more.

Import Trajectory File

Currently, LiDAR360 supports three types of trajectory files（*.traj、*.pos、*.out）。

For traj and pos formats, the fields to be set, including field order, skip lines, and delimiter. In the fields,
the required fields include GPS time, longitude and latitude (or GridX, GridY), height, Roll angle, Pitch
angle, and Heading angle. For the *.out format, no fields need to be selected.

If the GPS time of the input point cloud data is SOW(seconds of aweek), it needs to be converted to GPS
Time. The acquisition date of the input data calculates the GPS week number internally, firstly calculates
the GPS standard time, and then subtracts 109 from the GPS Coordinated Universal Time.

When the longitude and latitude fields are set but the GridX and GridY fields are not set, the coordinate
system to be converted needs to be set on the coordinate system selection page. The recommended
default coordinate system is the corresponding WGS 84 UTM projection coordinate system for the
longitude. If set at the same time, the GridX and GridY will be used directly as the projection coordinate

https://answers.microsoft.com/en-us/windows/forum/windows_10-files/how-to-fix-drag-and-drop-in-windows-10/0ea16377-dfcf-4a28-9e38-c35f4113202b?page=13&auth=1


values without projection transformation. The out format trajectory file only contains longitude and latitude
information, so a coordinate system also needs to be set. The method for setting the coordinate system
can refer to the Define Projection page.

Import aerotriangulation Result

The aerial triangulation results in LiDAR360 contain both interior and exterior orientation elements of the
images, and some formats also contain tie point information. LiDAR360 currently supports several formats
for aerial triangulation results, including internal formats (.LiAep), LiMapper projects (.limap),
LiGeoreference projects containing images (.ligeo), BlocksExchange xml format (.xml), Pix4d projects
(.p4d), and Inpho projects (.prj). When a format other than the internal image project is selected, it will be
converted to the internal image project (*.LiAep) for use in other functions.

Note:LiDAR360 supports adding this type of data directly by drag and drop. If dragging and dropping
does not work, click here to see more.

https://answers.microsoft.com/en-us/windows/forum/windows_10-files/how-to-fix-drag-and-drop-in-windows-10/0ea16377-dfcf-4a28-9e38-c35f4113202b?page=13&auth=1


Add and Merge Point Cloud Data

Steps

1. Click tool botton  to open the Add and Merge Data window.

Bounding boxes of point clouds are displayed in the left area. Bounding box of the selected point
cloud is highlighted in red.

2. Select LAS or LiData as your data type.

3. Click  to add LAS/LiData file(s).

4. Click  to remove LAS/LiData file(s).

5. Click  to remove all file(s).

Brief: Merge two or more point clouds in LAS/LAZ or LiData format to one single point cloud in
LiData format.



Delete Data

Steps

1. Select the data item you want to remove in the tree widget to active the Remove button .

2. Click  .

Note: In some cases, it is not allowed to remove data from LiDAR360 when it is busy running some
critical functions.

Brief: Remove data.



Export Data

Steps

1. Select the point cloud data you want to export in the tree widget on the left.

2. Move the mouse to that item and right click.

3. Click Export to show the Export Point Cloud window.

4. Input file path and name:

5. Set file type:

6. Click Save .

Brief: As described in Import section, you can easily move data into and out of LiDAR360. You
can currently export point clouds from LiData to many other formats (LAS/LAZ, TXT, PLY, ASC,
NEU, XYZ, PTS, CSV etc.).



New Project

Steps

1. Click File > New Project.

That gives you a blank project to work on.

Brief: Create a new LiDAR360 project.



Ribbon Toolbar
Ribbon Toolbar is at the upper-right corner of interface, includes:Batch Processing, Help documents,
Advanced mode, Basic mode, Display Optionand Options. Options includes Theme, Title Group
Visible,Help, Quick Start, FAQ, Visit Company Website, Submit A BUG, Submit An Enhancement, and
Check for Updates.

Advanced and Basic modes are available for Terrain, ALS and TLS modules. Advanced mode provides all
related tools regarding to each application. Users can decide which tool to use on their demands, based
on different datasets. While Basic mode provides a fast way of analyzing. After setting all parameters and
click "Run", data can be batch processed and saved to specified output path.



Batch Processing

Functional Description

In view of point cloud data to realize multi-data, multi-function, multi-thread streamlining batch processing
operations, support the las and LiData type data, and provides two types of calling methods, these are
dialog box and command line call batch processing function, the dialog calling batch processing function
provides the operating sequence and parameters are saved in the function,in order to facilitate the use of
other data. The following steps are described the calling method:

Structured Tool

1. After clicking the following interface pops up. The file list lists all the point cloud data in the system.
The functions that support point cloud batch processing operations are listed in the left list of
functions, and the list on the right shows the function sequence of the batch processing operations.

2. Click the  on the right side of file list to select point clouds to be batch processing; Click the 
button to clear the file list; Click the  button to remove selected point clouds (.las or .LiData type).

3. Double click the function in the left list (or select this function and click the  button) and the function
Parameters Settings interface will pop up. After Parameters Settings are completed, it will be
displayed in the right list.



4. (Optional) Double click the function in the right list (or select this function and click the  button) to
modify the parameters.

5. (Optional) Select a function in the execution sequence, then click the or  button to adjust the
order of execution.

6. (Optional) Click the  button to clear the execution sequence.
7. (Optional) Click the  button to save the execution sequence and corresponding parameters to file

(.LiProcessList).
8. (Optional) Click the  button to load execution sequence and corresponding parameters from

file(.LiProcessList).
9. Set the number of threads for multi-thread batch processing in the thread number box (default 4). If

the number of threads is set to 1, a single thread processing will be performed.
10. Set output path and click execute button, and the batch processing operations are processed in the

order of the function list, and all intermediate results from this process are saved to the output path.

Note: This tool is only applicable to point cloud data (.las or .LiData type). Some functions
without parameters(e.g., PCV, Normalization by Ground Class) can be added directly and; A
function that requires input raster data as an input parameter, and ensure the sequence of
function operation (generating raster data first). If DEM is required for normalization function,
DEM function should be put before normalized function.

11. You can enter a function name in the searching for quick search. Please note the software language
version.

Invoke batch processing by CMD

1. Open the cmd.exe command line window, drag LiBatch.exe from the installation directory of
LiDAR360 software into the command line window, or enter the installation directory layer by layer to
invoke LiBatch.exe, and click Enter, software information, common command line commands and a
list of command-line callable batch functions (in English and Chinese) will appear.

2. The command line supports the invocation of json files, the data and functions recorded in a json file
can be executed in order by inputting -jsonFile plus the file name of json, and the final result is saved
in the output folder json files can be generated using the interface batch processing or modified
manually. But users must keep in strict accordance with the format of relevant parameters to avoid
any parsing errors. For the list of Plugin ID and Action ID used to perform specific functions in the json
file, refer to the appendixID List of Json Callable Functions for Batch Processing.

 >> -jsonFile BatchProcessList.LiProcessList 



3. In addition, according to the information prompt, you can enter the specific data file after -i as the
input data (full path required). When inputting multiple files, users can enter -i plus multiple files
separated by spaces, or -ifolder plus data type for filtering (.las or .LiData), default is LiData. It is
worth noticing that users must ensure there is no space in the input file path, otherwise a parsing
error will be raised. In fact, all parameter commands and specific parameters must be separated by
spaces.

 >> Outlier_Rmovel -ifolder ..\data\ las 

4. Users can use -o command to set a folder path, instead of a specific file path. If users do not set this
parameter, the output file will be saved in the same directory as the input file by default. Users can
use -threadNum command to set the number of threads. Before calling a function, users can enter -h,
-H, -help or -or any command to view the parameter instructions of the specific function. Command
format: command name (case sensitive) -----parameter introduction. To run a function without setting
any parameters, users can use the command -default/-DEFAULT, or leave it blank.

Outlier_Rmovel -h

5. Only one function can be called at each time. Taking outliers removal as an example, the valid input
will be Outlier_Removal. The exact function name must appear in the parameter list. Input -i plus file
name and hit "enter" button to run outliers removal to the input file, using default parameters, and
save the output in the same folder as the input.

 >> Outlier_Rmovel -i ..\data\*.LiData 

6. In the classification module, see classify ground points as an example: Input classify ground points -
h, window appears classify ground points function related command line help. For classification
function, - fc is starting category, according to category list behind input corresponding to the category
of digital by commas, if you do not input this order, it is starting category for all classes,- tc refers to
target classification, we can input the corresponding category number.

 >> Classify_ Ground_ Points -h 

7. The meanings of the following command lines are: Run the function to classify ground points, in 8
threads, input file path..\input*.LiData, output file folder..\output\ (for classification there will not be an
output file generated, however, the input point cloud data will be classified), class origins 1
(unclassified), 2 (ground point), 3 (low vegetation), aimed class ground points, iteration angle 25
degrees, iteration distance 1.2 meters, other unspecified parameters as default.

 >> Classify_ Ground_ Points -threadNum 8 -i ..\input\*.LiData -o ..\output\ -fc 1,2,3 -tc 2 -ia 25 -id 1.2 



Options

Steps

1. Click this function, the interface will show the following figure. System setting includes UI style setting
and language setting. Styles can be selected. The included styles are scenic style, blue style, white
style, dark gray style. Languages include English, Chinese, French, etc.

2. "Viewer Settings" option settings include all views’ model display light settings, background colors,
display settings of points in the point cloud, and label attributes in the software. The model display
light setting can only be applied to the model files (such as LiModel, LiTin, OSGB, etc.), and the
position of the light source can be changed.

Functional Description: Functions include software system settings, viewer settings, rendering,
category priority settings, shortcuts, measurement settings. Class priority list under the class
settings sets the priority of the classes in the profile, and will be displayed in order on the
classification interface and the profile view. Shortcut info includes shortcut keys for the commonly
used functions of the system.



3. The Rendering option includes real-time contour settings.
Users can set the starting altitude, equal spacing, contour drawing thickness, and drawing color of the
first curve and gauge curve, etc. "Use shader to render color strategy" check box sets whether to use
shader to render color strategy of point cloud. Shader to render color strategy refers to that the same
point cloud can be displayed in different windows according to different color strategies. The
rendering adopts programmable pipeline shader technology. 4.“Class Settings” option defines the
default categories in the software.

4. “Shortcut” option allows users to customize shortcut keys. For details, refer to shortcut for setting
method.

5. Click the "Measurement Setting" option, the interface changes as shown in the figure below.

If the default source unit and target unit are the same, the measurement result will be displayed as
the result of the corresponding unit. If the source unit is inconsistent with the target unit, the result will
be multiplied by the Scale of the source unit and the target unit during measurement, and the
displayed unit will be the actual target unit.

6. Click the "Concurrency Setting" option, the interface changes as shown in the figure below.

Here you can set the concurrency parameters used by some operations of the program. "Use
Concurrency" check-box is used to set whether to use concurrency or not.The functions that currently



make use concurrency parameters include noise elimination, noise filtering, and point cloud
smoothing. "Maximum Number of Concurrency" is used to set the number of threads during
computation. "Maximum Percentage of Memory Usage" is used to set the maximum percent of
computer's physical memory.

7. Click the "Forestry settings" option, the interface changes as shown in the figure below.

Here, the control of individual tree segmentation, attribute statistics output and tree model
management in forestry module can be set.

Individual Tree Segmentation:
Tree Orientation (ALS): This is used to set the type of "Tree Orientation" used in the
airborne forestry individual tree segmentation or attribute statistics output. The options
include: "Tree Top" and "Tree Center of Gravity".
Tree Orientation (TLS): This is used to set the type of "Tree Orientation" used in the output
results of TLS Forest. The options include: "Tree Top", "Tree Center of Gravity" and "DBH
Position".
Calculation Type of Crown Diameter: This is used to set the calculation method of "Crown
Diameter" in the result. The options include "Mean Method", "Circular Regression", and
"Elliptical Regression".

- The calculation formula of crown diameter with "Mean Method" is "crown diameter = (north-sou
th crown diameter + east-west crown diameter)/2”.
- The calculation formula of "circular regression method" is "crown diameter = 2 sqrt (canopy 
projected area / PI)".
- The calculation formula of "ellipse regression method" is "crown diameter = sqrt (north-sout
h crown diameter east-west crown diameter)”.

Decimal places: This is used to set the number of decimal places reserved for the value in
the output result.

Attribute statistics output result setting:
Extra Item Output: This is used to set whether to output "North-South Crown Diameter" and
"East-West Crown Diameter" in the result.



Tree Model Settings:
Tree model: Select a tree model to update or delete or a new model from the drop-down list.
Model Name: Set the name of the model to be added, which appears in the tree model
drop-down box when the new model is selected.
Image File: Picture file to be used when setting up the medium view display of this model.
When the view point is far away from the tree, the tree will use the picture to display in the
form of a cross rectangular map.
Model File: Fine model file used to set the close-up display of the model. When the view
point is close to the tree, the model is used for fine display of the tree. Note: The Y direction
of the model is the direction of the tree height, and the origin of the model is at the root neck
of the tree.
Remove: Remove the currently selected tree model.
Add/Update: Add the current tree model. If a tree model with the same name exists, the tree
model will be updated.

8. Click Restore Default to restore the system default value.

9. The keyboard shortcut P can be used to adjust the position of the light source.



Shortcut

STEP

1. Click the lower tab and select the module whose shortcut needs to be modified.
2. Find the function to be modified, double-click the edit box on the right, enter the edit mode and enter

the shortcut key.
Note: If the set shortcut keys conflict with other shortcut keys, a prompt box will pop up, and the
modification will be restored, which needs to be reset. Note: There are some general shortcut
keys, such as undo, redo, etc. The program does not support modifying these shortcut keys.
You can use one or more of the three keys Ctrl, Alt, and Shift to form key combinations with
other keys.

3. Click the mouse to select a row, and click the Clear Current button to clear the current selection
shortcut.

4. The Clear All button can clear the shortcut keys of all functions on the current page.
5. The Reset Modification button can reset the modified shortcut keys of all pages to the unmodified

state.
6. The Restore Default button can restore the button shortcut keys of all pages to the default state of

the software.
7. After the modification is completed, click OK, and the modified shortcut key will be saved and take

effect.

Function description: Set the shortcut keys for each function of the software.



Project Management Window
The data list in the project is managed by layers and windows separately.

Layer Management

Point Cloud

Raster

Vector

Table

Model

Window Management

Note: The data loaded into the project can be displayed in single/multiple window(s), or not displayed
at all. Please drag data to a certain window for display.



Layer Management

Functional Overview

Layer management manages the data in the software by group, including: point cloud, raster, vector,
table, model, among which:

Point cloud data types include: LiData File (*.LiData Proprietary LiData File), LAS cloud (*.las, *.laz),
ASCII Cloud (*.txt, *.asc, *.neu,*.xyz,*.pts,*.csv), E57 Cloud (*.e57), PLY cloud (*.ply);
Raster data types include: Image (*.tif,*.jpg);
Vector Data types include: Vector (*.shp,*.dxf,*.kml);
Table data types include: Table (*.csv);
Model data types include: Model (*.LiModelProprietary Model File, *.LiTin Proprietary TIN File,
*.LiBIM,*.LiTree), OSG Data (*.osgb, *.ive, *.desc, *.obj);

The functions include the whole software system (all Windows) data removal, implicit control and so on.
You can control the display and hiding of data in the entire software by selecting the check box of the data
node, and drag the data in the data node to different Windows for display. The right-click menu of a data
node is mainly used to query, display, collect statistics, export, and remove data. Different data types
(including point clouds, rasters, vectors, tables, models, etc.) have different right-click menus.

Click the button  (the red box in the figure below) to display the layer list as shown below:



Context Menu

Right-click the data to open the corresponding management menu.

Layer management - Point Cloud
Layer management - Raster
Layer management - Vector
Layer management - Table
Layer management - Model

Note: The right button menu of layer management tree is effective on all windows with the specified
data loaded; while the right-click menu of window management tree is only effective on specified data
in the specified window.



Point CLoud Context Menu

Summary

The context menus are used to for data import, removal, query, display, statistics, export, etc.

Data Type Context Menu

The user can open this menu by right clicking the point cloud data type.

Import Data: The point cloud data formats supported by LiDAR360 include LiData (*.LiData), LAS
(*.las, *.laz), ASCII (*.txt, *.asc, *.neu, *.xyz , *.pts, *.csv), PLY (*. ply), and E57 (*.e57). The LiData is
the proprietary point cloud data format, on which the point cloud processing are based. Other
imported formats of LAS, ASCII and PLY will be converted to LiData for subsequent processing. This
function is the same as the tool  Add Data.
Remove All: Remove all the point cloud data from the project.

Data Context Menu

The user can open this menu by right clicking a point cloud data object.

Info: View the basic information of the point cloud, including the path of the data, the coordinate
information, the minimum and maximum values of X, Y, and Z coordinates, the average and standard
deviation of Z, the minimum and maximum GPS time, the minimum, maximum, and average intensity
Value and standard deviation, point cloud bounding box, total points, point cloud category statistics
and echo frequency statistics. If additional attribute information is included, the maximum, minimum
and type of each additional attribute will be displayed. as the picture shows. Click the "Export" button
to export the basic point cloud information as a txt file.



Open Containing Folder: Open the folder.

Rename: Rename the file.

Display: Set the display mode of a single point cloud file. LiDAR360 supports up to 20 display modes
for a single point cloud file, including display by elevation, display by intensity, display by category,
display by RGB, display by back Wave count display, GPS time display, tree ID display, route edge
display, echo count display, point source ID display, scan angle display, scan direction display, user
data display, scan channel display , Display by near-infrared, display by selected color, display by
mixed display, display by combination display mode, display by additional attribute, display additional
attribute by RGB, etc. Several display mode setting methods are described in detail below.

Display by Elevation: The interface as shown in the figure will pop up, and you can stretch by the
minimum and maximum values or standard deviation to improve the display effect. When stretching
according to the minimum and maximum values, you can set whether to display or hide the data
outside the range of the minimum and maximum values.



"Recalculate the histogram" is used to count and generate a histogram of all the points' elevation.
When opening this function, the histogram of sampled points' elevation is displayed by default, and
the histogram may be inaccurate. The recalculate the histogram function can take all the points'
elevation into account, and generate an accurate histogram.

The curve can be saved in pdf files. Click the button "Save Curve" to pop up the following interface.
Set the width, height, resolution, output path of the curve and click "OK" button to save the curve to
local disk.

Display by Additional Attributes：The following window will popup.

1.(Option) Select the attribute needs to set the color from the attribute drop-down list.

2.(Option) Select the index of the attribute needs to modify from the scalar index drop-down list box.

3.(Option)Select a random color and set the number of colors to be configured in the Number of
Colors box.

4.(Option) Select a color bar from the color bar drop-down list.

5.Set the display range of the additional attribute through the minimum and maximum values (click
Default to restore the maximum and minimum values calculated by the corresponding index of the
attribute), click the Apply button, and the final display effect is shown in the following figure.



Zoom to Layer: Calculate the bounding box of the current point cloud data. All the windows, in which
the data object is loaded, will show full extent of the bounding box.

Restatistics: Recalculate the Mean Z, Std Z, Mean Intensity and Std Intensity of point cloud data.
This function is used to repair older versions of LiData which may contain incomplete information.

Export: Export the point cloud data to LAS (*.las, *.laz), ASCII (*.txt, *.asc, *.neu, *.xyz, *.pts, *.csv),
PLY (*.ply), and E57 (*.e57) format. The supported LAS version for export are 1.2,1.3,1.4, and the
default version is 1.4. This function is the same as the tool  Export.
PCV: Process the point cloud data with PCV to improve the visual effects.
Point Size: The point size of each point cloud data object can be set separately or set uniformly
according to the global settings. The shape of points can be set to circle or square. The interface is
shown as follows.

For global point size settings, see the usage of the tool  Configure Point Size.
Point Brightness: Set the brightness of a single point cloud data or all the point cloud data, as shown
below:

To set the brightness of all point cloud data, users can click the  icon in the settings tool bar. For
more details, please refer to Display Options.

Remove: Remove the selected point cloud data from the current project. This function is the same as
the tool  Remove.

Settings

Display by Height:



Color Bar: The colorbar supports several uniformly varying color intervals for color mapping.
Stretch: The stretch methods of the histogram.

Minimum and Maximum (Default): Apply a linear stretch based on the minimum and
maximum pixel values, with the minimum and maximum pixel values as the endpoints for the
histogram. For example, the minimum and maximum pixel values of the image could be
2488 and 2656 respectively. The values can be stretched linearly between 0 and 255.
Distributing pixel values over the entire histogram range, the brightness and contrast of the
image are increased and features in the image are easier to distinguish.
Std deviation: Apply a linear stretch between the pixel values defined by the std deviation
(n) value. For example, the minimum and maximum pixel values of the image could be 2488
and 2656 respectively. If the value of standard deviation (n) is defined as 2, then the values
beyond 2 standard deviation become 0 or 255, the remaining values stretch between 0 and
255.

Display by Intensity:
Stretch: The stretch methods of the histogram.

Minimum and Maximum (Default): Apply a linear stretch based on the minimum and
maximum pixel values, with the minimum and maximum pixel values as the endpoints for the
histogram. For example, the minimum and maximum pixel values of the image could be
2488 and 2656 respectively. The values can be stretched linearly between 0 and 255.
Distributing pixel values over the entire histogram range, the brightness and contrast of the
image are increased and features in the image are easier to distinguish.
Std deviation: Apply a linear stretch between the pixel values defined by the std deviation
(n) value. For example, the minimum and maximum pixel values of the image could be 2488
and 2656 respectively. If the value of standard deviation (n) is defined as 2, then the values
beyond 2 standard deviation become 0 or 255, the remaining values stretch between 0 and
255.

Save Curve:
Width: The width of the saved curve.
Height: The height of the saved curve.
Resolution: The resolution of the saved curve.
Output path: The output path of the saved curve.

Point Size:
Circular Points (Optional): Set the shape of the point to circle or square.
Specified set (Optional): Set the point size of the specified point cloud data separately.
Use global set (Optional): Set the point size of the specified point cloud data with global
settings.

Note：Except the import data function, other right-click menu functions work on all viewers loaded
with the point cloud.



Raster Context Menu

Summary

The context menus are used to for data import, removal, query, display, etc.

Data Type Context Menu

The user can open this menu by right clicking the raster data type.

Import Data: The raster data formats supported by LiDAR360 include TIF and JPG. The function is
the same as the tool  Add Data.
Remove All: Remove all the raster data from the project.

Data Context Menu

The user can open this menu by right clicking a raster data object.

Info: View the basic information of raster data, including file path, description, X size, Y size, bands
count, pixel size, invalid value of each band, projection, etc. The interface is shown below.

Open Containing Folder: Open the folder.

Histogram: View the histogram of the raster data, where the values of each band can be stretched
separately. The raster data is displayed in gray color bar by default. Select an appropriate color bar in
the combo box. Click the button "Apply", the raster data in the scene will be rendered according to the
above settings, as shown below.



Select the stretch method and generate the corresponding histogram, as shown below.

The button "Default" is used to restore the default settings. The button "Recompute Histogram" is
used to calculate all the pixel values of the raster data again. The sampling points are 250000 by
default. When the pixel size of the raster data exceeds the value, the statistical results may be
inaccurate, then this button is needed. The histogram can be saved in *.pdf format. Click the button
"Save Histogram" to pop up the following interface. Set the width, height, resolution, output path of
the histogram and click "OK" button to save the result to local disk.

Zoom to Layer: Calculate the bounding box of the current raster data. All the windows, in which the
data object is loaded, will show full extent of the bounding box.

Zoom to Native Resolution (100%): Display the raster data in 1:1 ratio according to the resolution of



the raster data.
Remove: Remove the selected raster data from the current project. This function is the same as the
tool  Remove.

Settings

Histogram:
Stretch: The stretch methods of the histogram.

Minimum and Maximum (Default): Apply a linear stretch based on the minimum and
maximum pixel values, with the minimum and maximum pixel values as the endpoints for the
histogram. For example, the minimum and maximum pixel values of the image could be
2488 and 2656 respectively. The values can be stretched linearly between 0 and 255.
Distributing pixel values over the entire histogram range, the brightness and contrast of the
image are increased and features in the image are easier to distinguish.
Percent Clip: Apply a linear stretch between the pixel values defined by percent clip
minimum and percent clip maximum. For example, the minimum and maximum pixel values
of the image could be 2488 and 2656 respectively. Percent clip minimum and percent clip
maximum values are 0.02 and 0.98, values less than 0.02 mean the values between 2488
and 2492, values more than 0.98 mean the values between 2652 and 2656, values between
2488 and 2492 become 0, values between 2652 and 2656 become 255, the remaining
values are between 0 and 255.
Std deviation: Apply a linear stretch between the pixel values defined by the std deviation
(n) value. For example, the minimum and maximum pixel values of the image could be 2488
and 2656 respectively. If the value of standard deviation (n) is defined as 2, then the values
beyond 2 standard deviation become 0 or 255, the remaining values stretch between 0 and
255.
Histogram Equalization: Apply a non-linear stretch between the pixel values, redistribute
the pixel values so that the pixel values in a certain range is approximately equal. This
method works well when there are a lot of pixel values that are closely grouped together.

Color Bar: The colorbar supports several uniformly varying color intervals for color mapping.
BandList: Select a band from the band list to draw the histogram.
Show all bands (Optional): Whether to show all bands.

Save Curve:
Width: The width of the saved curve.
Height: The height of the saved curve.
Resolution: The resolution of the saved curve.
Output path: The output path of the saved curve.



Vector Context Menu

Summary

The right-click menu of vector data in the layer management tree mainly includes import and removal of
vector data, as well as information display for a single vector data, opening the attribute sheet, scaling to
layers, display by elevation, display by selected color, and remove.

Data Type Context Menu

Input Data: Import data format of vector data should be .gbkg, .shp, .dxf or .kml format. This function
is basically the same with the function , see Add Data. Import LiDAR360 from contour generated by
point cloud as shown in the figure:

Unit Conversion: When importing DXF format files, unit conversion is supported. The current unit
(unit recorded in the file) can be converted to the target unit for import.

Remove All: Remove all vector data from the software.

Data Context Menu

Info: View the basic information of vector file, including file path, elements count and bounding box.

Open Containing Folder: Open the folder.



Rename: Rename the file.

Open Attribute Table: This function displays the attribute table information of .shp or .gpkg format,
and the result is shown as follows.

This function supports adding, deleting, viewing, modifying attribute values, and exporting attribute
fields.

Clicking on a row or cell in the attribute table will highlight the corresponding data in the view, as
shown in the image.

Double-clicking on a row header in the attribute table will locate the data double-clicked in the view.

Zoom to Layer: Calculates the bounding box of the current vector data and displays all windows
containing this data within that bounding box for a global view.

Line Width Setting: The line width of an individual vector file can be set individually or using global
line width settings, as shown in the image.



Display by Elevation: Maps the elevation attribute of vector data to a uniformly changing color
range.

Display by Selected Color: Displays vector data in a fixed color.

Remove: Removes the selected vector data from the software.

Save: Provides a save function for files in vector editing.

Note: Except for the import data and remove all functions, all other right-click menu functions apply to
all windows that have loaded this vector data.



Tables Context Menu

Functional Overview

The right button menu of table data in the layer management tree mainly includes import and export table
data, it also contains display information, display settings, zoom to layer, display by selected color, display
by height, recalculate the statistics, export, and other operations for single model data.

Data Type Context Menu

Import Data: The import data format is CSV（* .csv）. If click this function, pop-up the dialog, select
data type as "Point" or "Circle", and set the specified field X, Y, Z, Diameter (if the data type is circle),
and check whether to show labels.

Select data type as "Point", the table file displayed as below:



Select data type as "Circle", the table file displayed as below:

Remove All: Remove all table files from LiDAR360.

Data Context Menu

Info: View the table's basic information, including path, the number of elements, the minimum and the
maximum of X, Y, Z values.



Open Containing Folder: Open the folder.

Rename: Rename the file.
Attribute Table: Display the contents of the table. As shown in the following figure, double click
specific row, the window will go to the position.

Single-click the row or the cell in the attribute table, the corresponding data will be highlighted as
shown in the following picture:



Double-click the button in front of the row in the attribute table, it will zoom to the corresponding
data, as shown in the following picture:

Zoom to Layer: Calculates the bounding box of the current table data, and all windows that contains
this file will display globally in this bounding box range.

Display by Selected: Display the table data by selected color, as shown in the following picture:



Display by Height: Correspond the elevation information of the table data to a uniformly changing
color band. And display the table data on the screen as shown below:



Remove: Remove the selected file from LiDAR360.

Note: Except "Import Data", the other function in context menu work on all windows that contains this
table file.



Model Context Menu

Functional Overview

The right-click menu of model data in the layer management tree mainly includes import and export table
data, it also contains information, display setting, zoom to layer, restatistics, export for single model data.

Data Type Context Menu

Import Data: The model formats that LiDAR360 supported include: (*.LiTin, *.LiModel, *.LiBIM,
*.LiTree), OSG data (*.osgb, *.ive, *.desc, *.obj), among which the LiTIN format and LiModel format
are LiDAR360 defined model format. This function is the same with the function , see Add Data.
Remove All: Remove All: Remove all model files from LiDAR360.

Data Context Menu

Info: View the basic information of model file, including the path, resolution, the minimum and
maximum of X, Y, Z. This function just applies to LiTin and LiModel file.

Table Attribute: This function is only applicable to LiBIM files, displaying the attribute information of
LiBIM model data. It supports adding, deleting, viewing, querying by attribute fields and modifying
attribute values.

When clicking on a row or cell in the attribute table, the corresponding data in the view will be highlighted
as shown in the picture.



Double-clicking on the header of a row in the attribute table will locate the position of the double-clicked
data in the view.

Open Containing Folder: Open the folder.

Rename: Rename the file.

View Mode: Set the model file's display mode, including display by elevation, display by texture,
display by light. If "Display by Elevation" is selected, the color bar selection dialog will be popped up,
and the display effect is as below:



The user can Convert to Texture LiModel. An example of "Display by Texture" is shown below:

If "Display by Lighting" is selected, the color bar selection dialog will be popped up, and the display
effect is as below:



Zoom to Layer: Calculate the bounding box of the current model data, and all windows that contains
this file will display globally in this bounding box range.
ReStatistics: Recalculate basic information such as Min X, Y, Z and Max X, Y, Z. In general, if you
edit the LiModel data, such as smooth height or repair height, you can use the Restatistics function.
Export: This function only applies to LiModel file, and the export format is TIF. In General, after 3D
visualization editing of LiModel and LiTIN generated by DEM, it is necessary to convert the editing
files to TIF format file.
Remove: Remove the selected model data from viewer window or project.

Note: Except "Import Data", other functions in context menu work on all windows that contains this model
file.



Trajectory

Functional Overview

The right-click menu for trajectory data in the layer management tree mainly includes importing and
removing trajectory data, as well as operations such as displaying information, renaming, zooming to the
layer, opening the containing folder, and removing individual trajectory data.

Right-Click Menu for Data Types

Import Data: LiDAR360 supports trajectory data formats including *.out, *.pos, *.traj etc., where *.pos
and *.traj are software-defined custom trajectory data formats.

Remove All: Remove all trajectory data from the software.

Right-Click Menu for Individual Trajectory Data

Information: View basic information about a trajectory including start time, end time,
maximum/minimum longitude and latitude values and maximum/minimum height values.

Open Containing Folder: This function opens the directory where the file is located.

Rename: Rename selected files.

Zoom to Layer: Calculate bounding box of current track data and display all windows that open this
dataset globally within this bounding box range.

Remove: Remove selected track data from software.



AEP Project

Functional Overview

The right-click menu for airborne LiDAR project data in the layer management tree mainly includes
importing and removing airborne LiDAR project data, as well as operations such as displaying information,
opening the containing folder, and removing individual airborne LiDAR project data.

Right-Click Menu for Data Types

Import Data: The supported formats of airborne LiDAR project data in LiDAR360 include *.liaep,
*.ligeo, *.limap, *.p4d, *.prj. Among them,*.liaep,*.ligeo,* .limap are software-defined formats.

Remove All: Remove all airborne LiDAR project data from the software.

Right-Click Menu for Individual Airborne LiDAR Project Data

Information: View basic information about the airborne LiDAR project including image count,
connection point count and coordinate system information.

Open Containing Folder: This function opens the directory where the file is located.

Remove: Remove selected individual airborne LIDAR project data from the software.

An individual aerial survey contains several photo groups and a connection point set. Photo groups
support functions such as viewing group information and source image metadata.

View Photo Group Information: View basic information about a specified camera group in an aerial
survey including number of images contained within that group , principal point coordinates,focal
length,camera interior orientation elements etc..

-View Metadata of Images in Photo Group:: View metadata information of all images included in a
specified camera group within an aerial survey including name of each image ,projection center rotation
angle etc..

Connection point sets support functionality to view their associated points' basic details.

-View Connection Point Set Information: View basic information about all points contained within a
connection point set including coordinates and reprojection error.



Window Management

Summary

The project windows manage all windows(i.e. viewers) and data in windows. The user can remove data
from window, edit display order by dragging data node, show/hide data in specified window by
checking/unchecking the box before window/data node. The context menu(i.e. right-click menu) of data
node, which differs depending on data types, is mainly used for data query, display, statistics, export, and
removal, etc. These functions are effective on specified window.

Click the  button to show the project windows as follows:

Context Menu

Open the context menu by right clicking window or data.

Window Context Menu

Remove All: Remove all data from the selected window.



Data Context Menu

Point Cloud Data Context Menu: Same as the context menu of point cloud data in layer tree.
Raster Data Context Menu: Same as the context menu of raster data in layer tree.
Vector Data Context Menu: Same as the context menu of vector data in layer tree.
Table Data Context Menu: Same as the context menu of table data in layer tree.
Model Data Context Menu: Same as the context menu of model data in layer tree.

Note: The context menu of window management is only effective on specified window, while the
context menu of layer management is effective on all windows.



File
File page includes： Add Data, Project( New Project, Open Project, Save Project, Project Save as,
Close),

Batch Processing, Display Option, Activate License, About and Exit。



Tools

Preprocessing

Classification

Vector editing

Terrain

ALS Forest

TLS Forest

Power Line

Mine

3D Buildings

Display

Profile Editor

Profile View



Tools
This module includes Measurement,Clipping and Data Management.

Measurement

Clipping

DataManagement



Measure Tools
The measure tools are used to measure geometric information about the data.

Pick Point

Multi Pick Point

Density Measurement

Length Measurement

Area Measurement

Angle Measurement

Height Measurement

Gradient Measurement

Volume Measurement

Profile View



Pick Point

Steps

1. Click a valid point in the scene and a label that displays the point attributes will pop up. If the point
belongs to point cloud data, then the label will show the position, intensity, return number,
classification and GPS time, as is shown below. If the point belongs to raster data, then the label will
show the position, stretched RGB value and pixel value.

Click the right mouse button, two context menus will pop up. The menu "Clear Measure" is used to
clear the selection result. The menu "Quit Measure" is used to exit the pick point function.

Note: This tool only works with point cloud data, raster data and model data. It's available in the
profile window too. Only if it is specified to do so, will the additional attributes be displayed.

Brief: This tool is applicable to point cloud data, raster data and model data. For point cloud data,
the attributes that can be queried contain position, intensity, return number, classification and
GPS time. For raster data, the attributes that can be queried contain position, stretched RGB
value and pixel value.



Multi Pick Point

Steps

1. Left-click the points in the scene and the selection results are marked by labels. At the same time, a
table that contains the attributes of the selection points will pop up, shown as follows. The attributes of
point cloud data shown in the table contain index, position (XYZ), classification, return number, GPS
time and intensity. The attributes of raster data shown in the table contain index, position (XY) and
band value. The total number of the points is updated real-time above the table.

2. The "point size" is used to set the point size of the marker in the scene. The "start index" is used to
set the start index of the selected points.

3. Select a row of the table by left-clicking and click the button  to delete the point.
4. After clicking the "Start Editing" button, the attribute values can be changed by double-clicking the

cells in the added attribute columns, and typing in the new values.

5. After clicking the "Add Attribute" button, the following dialog will pop-up. Currently, it is supported for
the following types of custom attributes: integer, float, text, date, and enum. After click "ok" button, the
added field will be displayed in the attributes table.

6. The "Remove Attribute" button is not available when there is no custom attributes added. After adding
custom attributes, the custom attributes can be removed by clicking "Remove Attribute" button (only
the custom attributes can be removed).

Brief: This tool is applicable to point cloud data, raster data and model data. For point cloud data,
the attributes that can be queried contain position, intensity, return number, classification and
GPS time. For raster data, the attributes that can be queried contain position, stretched RGB
value and pixel value. Different from the pick point tool, this tool allows querying multiple points at
the same time, and the selection set can be exported in txt, asc, neu, xyz, pts, or csv file.



7. The selection set can be exported as txt, asc, neu, xyz, pts, or csv file. Click the drop-down menu 
to pop up "Select Format" dialog, as shown below. If the selected points belong to raster data, then
the menu "Save 2D points" is available. If the selected points belong to 3D data, then the menu "Save
3D points" is available. If the selected points contain 2D data and 3D data, then the menu "Save all
points" is available.

8. Click  to pop up the export dialog. Input the output path, and check the attributes that need
to be exported. Click "OK" to complete the export. Click "Cancel" to cancel the export.

9. If the selected points have not been saved before quiting this tool, a message box will pop up as
follows. Click "Save" to save the points. Click "Discard" to cancel the selections.

Settings

X: X component of the coordinate.
Y: Y component of the coordinate.
Z: Z component of the coordinate.
Classification: The class attribute of point cloud data.
Return: The return number attribute of point cloud data.
Time: The GPS time attribute of point cloud data.
Intensity: The intensity attribute of point cloud data.
Index: The index of select point.
BandValue: The band value of raster data.
Output Path: The path of the output file.

Note: This tool only works with point cloud data, raster data and model data. If the center of rotation
needs to be changed, hold down the the Ctrl key and select the center of rotation with the left mouse
button. This tool is available in the profile window too.



Length Measurement

Steps

1. Left-click at least two points in the scene and the corresponding polyline will be rendered real-time.
The measurement result is displayed in a label as follows. Double-clicking the last point will stop the
measurement process, and the distance value will continue to be displayed in the label.

Note: This tool only works with point cloud data, raster data and model data. The "Back One Point" is
only available before the measurement is stopped. This tool is available in the profile window, too.

Brief: This tool is applicable to point cloud data, raster data and model data, which calculates the
distance between two consecutive points.



Area Measurement

Steps

1. Left-click at least three points in the scene and the corresponding polygon area will be rendered real-
time. The measurement result is displayed in a label as follows. Double-clicking the last point will stop
the measurement process, and the measurement result will continue to be displayed in the label.

Right-click to go back to the previous point during the measurement.

Note: This tool only works under orthogonal projection. The "Back One Point" is only available before
the measurement is stopped.

Brief: This tool is applicable to all data types supported by LiDAR360, which calculates the
projected area within the polygon region. Current window will switch to Orthogonal Projection
automatically for 3D data.



Angle Measurement

Steps

1. Select the first point of angle measurement by left-clicking. 2. Select the second point of angle
measurement by left-clicking. 3. Select the third point of angle measurement by double-clicking. The
projection angle of the three points on the horizontal plane will be rendered in the scene and the
measurement result is displayed in a label as follows.

Note: This tool only works with point cloud data, raster data and model data. The "Back One Point" is
only available before the measurement is stopped. The tool is available in the profile window too.

Brief: This tool is applicable to point cloud data, raster data and model data, which calculates the
angle created by the three picked points in 3D view and calculates the projection angle of three
points on the horizontal plane in 2D view.



Height Measurement

Steps

1. Select the reference point of height measurement by left-clicking.
2. Select the measurement point by double-clicking. The relative height difference between the

reference point and the measurement point will be rendered in the scene and the measurement result
is displayed in a label as follows.

Right-click to go back to the previous point during the measurement.

Note: This tool only works with point cloud data and model data. The "Back One Point" is only
available before the measurement is stopped. The tool is available in the profile window too.

Brief: This tool is applicable to point cloud data and model data, which calculates the relative
height difference between two points.



Gradient Measurement

Steps

1. Click the single point of the data with the left mouse button and select the reference point for angle
measurement. 2. Double-click the left mouse button to determine the measurement point, and the
measurement ends. The measurement angle is drawn in real time in the scene, and the measurement
result is displayed in the form of a label in real time (as shown).

Note: This function is only for the angle measurement of point cloud data, raster data, and model
data. This function can also be used in the profile window. The undo function can only be used before
double-clicking the mouse.

Description: Gradient measurement can be used to measure the gradient on point cloud, raster,
or model data. Users can click the mouse to pick the measurement points interactively to
measure the vertical angle of the line formed by the selected two points, or the angle between the
line formed by the selected two points and the horizon plane.



Volume Measurement

Summary

Usage

Click Tool > Measurement > Volume Measurement/Select the file for volume measurement

1. After clicking this tool, the options of volume measurement methods will pop up. If volume
measurement is selected, users need to select the measurement area by clicking mouse; if
measurement area is defined by file, users can load the file with measurement area information to
measure the volume of the target object. It is suggested to adjust the window to top view before the
tool is used.

2. (Optional) Select at least three points to generate the reference plane for volume calculation by left-
clicking. Select the last point by double-clicking. The border of the selected region will be rendered in
red and the dialog "Volume Measurement" will pop up.

3. (Optional) Select .shp、 .dxf or .gpkg file which defines the boundary of the measurement area
(supporting defining the measurement area with polygon or closed polyline)

4. Set the cell size.
5. Set the reference plane of volume measurement. The options include minimum value, polygonal

Functional Description: This tool is applicable to point cloud data and model data. This tool
calculates filling, cutting and total amount relative to a reference height. The measurement area
can be selected either by interactively selecting polygon vertices or by inputting the vector file of
the polygons. It's commonly used in volume measurement of coal pile and hull.



plane, customizing, three-point plane and plane fitting. And the plane parameters will be displayed
after the reference plane is determined.

6. Set the data source for volume measurement. The data source type includes the loaded point and all
points.

7. Click the "Compute" button to generate the measurement result, including Projected area, surface
area, cut volume, and fill volume. The corresponding volume will be rendered in the scene, as shown
below.

8. Click the "Export" button to export the result in *.pdf format.

Settings

Select Method: Two volume measurement methods, TIN method and grid method, are currently
supported. The TIN method is superior to the grid method in computational accuracy, but not as
efficient as the grid method.
Cell Size: The grid size affects the size of the final displayed cylinder, and also affects the accuracy
of the grid method, but not the accuracy of the TIN method. It defines the smallest unit size for
calculation. The smaller the value is, the more accurate the calculation is.
Datum Method: It defines the reference plane to calculate filling and cutting.

Minimum (Default): Use the minimum Z height of the selected points as the height of the
reference plane.
Plane by polygon: Fit the best plane according to the selected area boundary points.
Custom: This value is entered or clicked by the user as the datum height value for volume
measurement.
Plane by Three Points: Click on three points to determine a plane.
Point Cloud Fitting: Fit the best plane according to the selected points and the radius of the
fitting area.

Data Source: Specify the points used to calculate the volume. The efficiency is high while the
accuracy is low.

from Loaded (Default): Use the points in the loaded into the scene in the specified area. The
speed is relatively fast, and the change of data loading in the scene has an impact on the



calculation results.
from File: Use the points in all the point cloud files in the specified area. The efficiency is low
while the accuracy is high.

Note: This tool only works with point cloud data and model data in 3D view.



Volume of Closed Model

Functions Overview

Calculate the volume of a closed model and display the results on the interface. If the model is not closed,
the calculation cannot be performed and a prompt dialog box will pop up. This function needs to ensure
that the connection order of each triangle in the model is all counterclockwise or all clockwise, otherwise
the volume value cannot be calculated correctly.

Usage

Click Mine > Volume of closed model.

Parameter settings

Select the ojb model file：Import model file. file format：*.obj。
Volume of closed model: The volume of the returned closed model is shown here.



Density Measurement

Steps

1. Active window is adjusted to orthogonal projection automatically when this tool is started. Then the
dialog "Density" pops up.

2. If the option "Width" is checked, the width value can be manually input, and the height value will be
set to the same as the width value, then the area value will be decided by "Width" and "Height". The
measurement region can be selected by left-clicking.

3. If the option "Width" is unchecked, the width value and the height value will be decided by the size of
the rectangle that is drawn interactively by left-clicking the upper left corner and the lower right corner.
The area value will be decided by "Width" and "Height". The rectangle will be rendered in the scene
and the measurement result (number of total points and point density) is displayed in a label as
follows.

Settings

Width: It defines the width of the reference rectangle.
Height: It defines the height of the reference rectangle.
Area: It defines the area of the reference rectangle.

Note: This tool only works with point cloud data and model data under orthogonal projection.

Brief: Point density is an important metric to measure the quality of point cloud data. The average
number of points per square meter can be counted with this tool.



Selection Toolbar
Select and save point clouds in interest area.

Select and Clip

Cross Selection

Clip by Circle

Clip by Rectangle

Clip by Polygon



Polygon Selection

Steps

1. Click the function button, which is in the box selected state, to activate the function.
2. Add polygonal vertices by left click. Select the vertex position of the polygon, the program will

automatically form a closed polygon, as shown in the figure.

3. If the vertex position of the polygon is incorrectly selected, you can right-click the vertex selected last
time to cancel the operation for several consecutive times.

4. Double-click the last vertex position to end vertex selection, identify the point cloud in the selected
polygon area and highlight (red).

5. After one selection is over, another selection can be made on the basis of the first selection.
6. Each selection area will be selected according to the state of Inverse Selection to add or subtract the

selection area.
Note: This function is only applicable to point cloud data.

Functional Description: Select point cloud data in polygon area. (Shortcut key: Shift+P)



Rectangle Selection

Steps

1. Click the function button, which is in the box selected state, to activate the function.
2. Add the first vertex by left click. Then move cursor to adjust rectangle size.
3. Delete the first vertex by right click, if it's unwanted. Go back to Step 2 and select again.
4. Double-click the circular boundary point to end the selection, and identify the point cloud in the

selected area to highlight (in red), as shown in the figure.

5. After one selection is over, another selection can be made on the basis of the first selection.
6. Each selection area will be selected according to the state of Inverse Selection to add or subtract the

selection area.
Note: This function is only applicable to point cloud data.

Functional Description: Select point cloud data in rectangle area. (Shortcut key: Shift+R)



Sphere Selection

Steps

1. Click the function button, which is in the box selected state, to activate the function.
2. Add the center point of sphere by left click. Then move cursor to adjust radius.

3. Delete the center point by right click, if it's unwanted. Go back to Step 2 and re-select the center
point. 4.Left double click to confirm the radius. The selected points in the sphere are highlighted (in
red).

4. After the first selection, you can select again on the basis of the first selection, as shown in the figure.
5. Each selection area will be selected according to the state of Inverse Selection to add or subtract the

selection area.
Note: This function is only applicable to point cloud data.

Functional Description: Select point cloud data in sphere. (Shortcut key: Shift+S)



Circle Selection

Steps

1. Click the function button, which is in the box selected state, to activate the function.
2. Click to select the center of the circle. Move the mouse, and the position of mouse will be recognized

as the boundary of the circle. And the circle will be preview in the window.
3. Right-click to cancel the circle center selection. Go back to the second step and choose the circle

center again.
4. Double-click the circular boundary point to end the selection, and identify the point cloud in the

selected area to highlight (in red).
5. After one selection is over, another selection can be made on the basis of the first selection.
6. Each selection area will be selected according to the state of Inverse Selection to add or subtract the

selection area.

Note: This function is only applicable to point cloud data.

Functional Description: Select point cloud data in circle area. (Shortcut key: Shift+C)



Lasso Selection

Steps

1. Click the function button, which is in the box selected state, to activate the function.
2. Left-click in the window to select the starting position of the lasso, move the mouse, and the mouse

position will be used as the boundary of the lasso to form a closed area.
3. Right-click to cancel the selection. Go back to the second step and choose the starting point of ROI

again.
4. Double-click to end the boundary selection. The selected points in that area are highlighted.

5. After one selection is over, another selection can be made on the basis of the first selection.
6. Each selection area will be selected according to the state of Inverse Selection to add or subtract the

selection area.

Note: This function is only applicable to point cloud data.

Functional Description: Select point cloud data with a Lasso tool. (Shortcut key: Shift+L)



Subtract Selection

Steps

1. This function does not work by itself. It can only be activated when a selection tool (Polygon
Selection, Rectangle Selection, Sphere Selection, Circle Selection, Lasso Selection) is active.

2. If the button is not selected, the Add Selection is active. The area selected by the current selection
tool will be added as part of the selection area, as shown in the figure.

Functional Description: Applicable to the current selection tool, it represents the current
selection state, and controls whether the selected area is selected plus or minus. And the function
applies to Polygon Selection, Rectangle Selection , Sphere Selection, Circle Selection, Lasso
Selection. (Shortcut key: Shift + D)





3. When the button is selected, the Subtract Selection is active. The common part obtained by
subtracting the current newly selected area from the the selected area will be taken as the final
selection result.

3.1 Select an initial selection area in the selected state.

3.2 Select the subtraction function, and select polygons and spheres in the subtraction mode.
The selected area will be subtracted from the original area, as shown in the figure.





Parameters Settings

Shortcut key: **Ctrl + z**, and the result of previous selection is canceled.

Note: This function is only applicable to point cloud data.



Cancel Selection

Steps

1. Click this button after selections(Polygon Selection, Rectangle Selection, Sphere Selection) or cut
operations(In Cut, Out Cut). All the selections and cut operations will be cancelled.

Note: This function is only applicable to point cloud data.

Brief: Cancel all the selections and cut operations.



In Cut

Steps

1. Perform area selection first, refer to selection tools ([Polygon Selection] (PolygonSelection.md),
Rectangle Selection, [Sphere Selection] (SphereSelection.md), etc.) and [Inverse Selection]
(SubtractSelection.md) ) to form the desired selection area.

2. Click the In Cut Button. The result is shown in the following figure.

3. After one cropping, the cropped point cloud can be selected multiple times ( Polygon Selection,
Rectangular selection, spherical selection, etc.) and clipping ( OutCut) work. Shortcut Key: Ctrl + Z
to undo the cut operation. The corresponding selection is also canceled.

Note: This function is only applicable to point cloud data.

Functional Description: According to the currently selected area, all point cloud data in the
window will be cropped. The point cloud in the selected area is selected, and the point cloud
outside the area is hidden. (Shortcut key: Shift+X)



Out Cut

Steps

1. Perform area selection first, refer to selection tools (Polygon Selection, Rectangle Selection, Sphere
Selection and Inverse Selection etc.) to form the desired selection area.

2. Click the Out Cut Button. The result is shown in the following figure.

3. You can repeat this function several times to get the result you need after one cut (Polygon Selection,
Rectangle Selection, Sphere Selection, etc.) and clipping (including In Cut) work.

Parameters Settings

Shortcut Key: Ctrl + Z to undo the cut operation. The corresponding selection is also canceled.

Note: This function is only applicable to point cloud data.

Functional Description: According to the currently selected area, all point cloud data in the
window will be cropped, Select the point cloud in the area and hide the point cloud outside the
area. (Shortcut key: Ctrl+Shift+X)



Save Cut Results

Functional Overview

Usage

1. The cutting operation is carried out first to form the cutting result, refer to In Cut and Out Cut.
2. This function will be activated If the result of cutting is available. Click this function to pop up the save

setting interface, as shown in the picture.

3. Select source point cloud files that you want to participate in the Cut Save.
4. Select whether to combine all the cut point clouds and save them to one point cloud file.
5. Select a directory to save the cut file.New file names are created based on the source file names and

system time,the naming rule is "SourceFileName_CutResult_SystemTime.LiData".
6. After saving, the system will automatically cancel the original Select and Clip operations, and ask the

user whether to add the Clip saving data to the current project. The user can select yes or no as
required.

7. After saving, the original selection and cropping operations will be automatically cancelled, and the
user will be asked whether to add the cropped data to the current project. The user can choose yes or
no according to their needs. If they choose yes, the corresponding cropped file will be loaded into the
project.

Functional Description: Save results after cut operation as new point cloud files.



Clip by Circle

Summary

Clip by circle tool extracts the point cloud data within user-defined circle(s), and the extracted points can
be saved in one or multiple files.

Usage

Click Data Management > Clip > Clip by Circle

Settings

Input Data: Input one or more point cloud data files. File Format: *.LiData.
X Coordinate (m): Enter the X coordinate of the circle center.
Y Coordinate (m): Enter the Y coordinate of the circle center.
Radius (m): Enter the radius of the circle.
Ignore Different Additional Attributes: When inputs are several point cloud files, and this option is
checked, only the same additional attributes of the point cloud files will be merged. If this option is
unchecked, and there are some different attributes in the additional attribute tables, the mergence of
different point cloud files cannot be done.
Generate a File: Extract all the point cloud data within 2D circle(s) to one file.
Generate Multiple Files: Extract the point cloud data within each circle and save them to one
individual file. The file is named by its center and radius by default.

：After clicking this button, users will be able to draw circle in the current window. Single-click to
choose the center of the circle, and drag the mouse to change the size of the circle. Double-click to
end the selection. The coordiantes of the center of circle and the radius of the circle will be displayed
in the window.

: Click this button to add the coordinates and radius of a circle to the processing list. Perform the
same operation to add multiple clipping circles.

: Click this button to load external data files. The file format refers to the Clip Range File Format in
the appendix.



: Click this button to remove the selected row(s) in the processing list.
Output path: The generated file will be saved in this output path.



Clip by Rectangle

Functional Overview

Clip by rectangle tool extracts the point cloud data within user-defined rectangular(s), and the extracted
points can be saved in one or multiple files.

Usage

Click Data Management > Clip > Clip by Rectangle

Parameters Settings

Input Point cloud data: Input one or more point cloud data files. File format: *.LiData.
Center Point: Determine the rectangular box according to a selected point and area width.
Two Points: Determine a rectangular box according to two selected points.

 Select Region: After clicking this button, users will be able to draw rectangle in the current
window. If a single point is selected, click to select a position in the view with the mouse, and the
rectangle box information can be determined and displayed according to the area width parameter. If
two points are selected, after clicking to select a position in the view with the mouse, drag the mouse
to display the real-time rectangle box. Double click the mouse to end the rectangle selection, and the
position information of the rectangle box will be displayed in the function interface.
Y Maximum (m): Enter the maximum Y coordinate of the rectangle.
Y Minimum (m): Enter the minimum Y coordinate of the rectangle.
X Minimum (m): Enter the minimum X coordinate of the rectangle.
X Maximum (m): Enter the maximum X coordinate of the rectangle.
Ignore Different Additional Attributes: When inputs are several point cloud files, and this option is
checked, only the same additional attribute tables can be merged, and the mergence of different point
cloud files cannot be done.
Generate a File: Extract all the point cloud data within the rectangle to a file.
Generate Multiple Files: Extract the point cloud data within each rectangle and save them to one file.



The file is named by the rectangle's lower left corner coordinate and the rectangle's width and height
by default.

: Click this button to add the entered rectangle range to the processing list. Perform the same
operation to add multiple clipping regions.

: Click this button to load external data files. The file format refers to the Clip Range File Format in
the appendix.

: Click this button to remove the selected row(s) in the processing list.
Output path: The path of the clipped output file after the function is executed.



Clip by Polygon

Summary

Clip by polygon tool extracts the point cloud data within a user-defined polygon vector file, and the
extracted points will be saved in one or several files.

Usage

Click Data Management > Clip > Clip by Polygon

Settings

Input Data: Select one or more point cloud data files. File Format: *.LiData.
Interactive Polygon: Click  to start to create the polygon. Click in the viewer to select the nodes

and double-click to end selecting. After this, the polygon will be added to the polygon list. Click  to
delete the polygon in the list.
Use Vector File: User can select the Vector File loaded into LiDAR360 software from the drop-down
menu, or select  button to load an external vector data file.
Ignore Different Additional Attributes: When inputs are several point cloud files, and this option is
checked, only the same additional attributes of the point cloud files will be merged. If this option is
unchecked, and there are some different attributes in the additional attribute tables, the mergence of
different point cloud files cannot be done.
Generate Single File: When users choose to export a single file, the point cloud will be clipped by all
polygons in the vector data. All results will be saved in one file.
Generate Multiple Files: When users choose to export single file, the point cloud will be clipped by
all polygons in the vector data. The point cloud in each polygon unit will be saved as one file.
Using Shp File Attribute Naming: Available when Generate Multiple Files is selected and the
vector data contains attribute tables. The user can select the corresponding attribute value as the file
name. When the attribute value does not exist, the files are automatically named in numerical order.
Output Path: The output folder path, after the function is executed, a new cropped file will be



generated.



Data Management
Data management includes Point Cloud Conversion, Raster Conversion, Model Conversion, Vector
Conversion and Other Point Cloud Tools.

Extract

Extract includes:

Extract by Class, Extract by Elevation, Extract by Intensity, Extract by Return, Extract by Time, Extract by
Segment.

Point Cloud Conversion

Point Cloud Conversion includes Convert LiData to LiData, Convert to ASCII, Convert to TIFF, Convert to
Shp, Convert to DXF,

Convert to Las, Convert to E57, Convert LAS to LiData.

Raster Conversion

Raster Conversion includes: Convert TIFF to LiModel, Convert to Texture LiModel, Convert TIFF to
LiData, Convert TIFF to ASCII.

Model Conversion

Model Conversion includes: Convert LiModel to TIFF, Convert LiTIN to DXF, Convert LiModel to TIFF,
Convert LiBIM to OBJ, Convert LiBIM to FBX, Convert LiBIM to CityJson,

Vector Conversion

Vector Conversion includes: Convert Shape to KML, Convert KML to Shape.

Other Point Cloud Tools

Other Point Cloud Tools include: Denormalization, Remove Outliers, Resampling, Tile by Range, Tile by
Point Number, Merge, Extract Point Cloud Boundary,

Extract Color from Image, Noise Filter, PCV, Subdivision, Transform GPS Time, Define Projection,
Reprojection, Smooth Points.

Model Tools



Model Tools currently include LiBIM merge LiBIM Merge.



Preprocessing
Preprocessing page includes: Calibration, Adjustment, Multiple adjustment, Classify Ground Points,
Control Point Report, Quality Inspection, Projections and Transformations.

Quality Inspection

Quality Inspection includes: Trajectory Quality Analysis, Elevation Difference Inspection, Strip Overlap
Analysis, Density Quality Inspection.

Projections

Projections include: Define Projection, Reprojection, Coordinate Conversion, Convert Projection Elevation,
Elevation Adjustment, Transformations Calculation, Geoid Surface Fitting, Convert ASCII to BLH.

Transformation

Transformation includes: ICP Regression, Manual Registration, Manual Rotation and Translation



Classification
Classification module is shown as figure below:

Classificaiton Tools includes： Classify by Attribute, Classify Ground Points, Extract Median Ground
Points, Classify Air Points, Classify by Height Above Ground, Classify Model Key Points.

Other Classify includes： Classify Low Points, Classify Below Surface Points, Classify Isolated Points,

Classify Noise Points, Classify by Min Elevation Difference, Classify Closeby Points,

Classify Buildings, Classify by Trained ML Model；

Classification Editor includes:Classify Ground by Selected, Classify by Interactive Editing。



Vector Editor
The vector editing function realizes the editing, modification and storage of vector objects, completing the
vectorization part of the digital line drawing process. Based on point cloud, model and image data, it
provides excellent display effect based on high contrast provided by point cloud, which can clearly
distinguish buildings, vegetation areas, roads, street lamps, water bodies, bridges and other features. It
generates vectorized results in formats such as SHP and DXF and supports integration with third-party
software such as ArcGIS and AutoCAD.

By providing basic entity elements such as points, lines, polylines, rectangles, and polygons, the main key
terrain vectorization is completed. The above-mentioned terrain entity elements are managed using a
layer-based approach.

The vector object export function is provided to integrate the vectorization results into a DXF file for input
into other mapping software. This can be symbolized and edited to output surveying and mapping results
that comply with various standards.

Note: In order to make the terrain categories clearer and more distinguishable, PCV processing can be
performed on point cloud data before vectorization. The left image in the figure below shows point cloud
elevation + EDL display while the right image shows mixed display after PCV processing.

Usage

Click vector editor toolbar, which includes the following functions:

Editor



Entity Vectorization

Element Extraction

Basic Function

Profile

ElevationFilter

Z Mode

Linked Viewer

Entity Modify

Entity Selection

Entity Snapper

Layer Management

Reference Plane

Show Vertices



Editor

Control the start and end of Vector Editing, and support to edit one vector object at a time. The vector
objects that can be edited include: select vector files for editing, sketch editing and new file editing.

Select Vector File

Click Editor>Select vector file

The interface for selecting vector object data pops up. The vector object data that has been loaded into
the editing window will appear in the selection list. Select the data to be edited.

If there is no vector data in the edit window, a dialog box is displayed to select vector data and load the
data from disk for editing.

After starting editing, other functions of the vector editing toolbar will be activated.

During the editing process, the edited vector data cannot be removed from the editing window.

New Temporary Scratch Vector

Click Editor > New Temporary Scratch Vector

A temporary editing panel is constructed in the editing window, vector editing can be carried out, and the
edited vector data is loaded into the directory tree as a temporary object in the window.

After starting editing, other functions of the vector editing toolbar will be activated.

During the editing process, the edited vector data cannot be removed from the editing window.

New Vector File Edit

Click Editor> New Vector File Edit

The file selection interface pops up, and the corresponding vector data file (supports dxf or shp format) is
generated according to the path selected by the user, and the vector data file is loaded into the editing
window to open the editing of the vector data.

After starting editing, other functions of the vector editing toolbar will be activated.

During the editing process, the edited vector data cannot be removed from the editing window.

Save
Functional Description: Click*editor>save*. If the sketch is not saved, the Save File interface
will pop up, otherwise it will be saved to the original file.



Select the coverage, file type and path to save, and click OK to save the coverage to the corresponding
path.

Note: 1. If the suffix of the saved file is shp, the corresponding directory name will be created under
the directory name_coverage name_points.shp file or the directory name_coverage name_lines.shp
file

End Edit

Click Editor > End Edit

After ending editing, a prompt box will pop up to save the editing results. After the user makes a selection
as required," the editing function is exited, and Vector Editing functions module will be grayed out.



Entity Vectorization

Entity vectorization, including vectorization of point, line and polygon entities, also provides specific editing
functions for polylines and polygons respectively.

Note: Point layers can only add point objects, not line, circle, polyline and polygon objects. Line layers
cannot add point entities, only line, polyline, and polygon objects.

Point

1. Click the left mouse button to select the point entity position.
2. Repeat step 1 to draw the next point entity.
3. Click the right mouse button to end drawing the point entity.

Two-point polyline

1. Click the left mouse button to select the starting point of the line segment entity, or right-click to end
the drawing of the line segment entity.

2. Click the left mouse button to select the end point of the line segment entity, or right-click to go to
Step 1.

3. Click the right mouse button to end drawing the line segment entity.

Polylines

1. Click the left mouse button to select a point, or click the right mouse button to exit drawing a polyline.
2. Repeat step 1 to add a point, or click the right mouse button to end the current polyline drawing. If you

want to close, click the close button, and repeat step 1 to start a new polyline drawing.
3. Click the right mouse button to exit drawing the polyline.

B-Style Curves

1. Click the left mouse button to select the point, or click the right mouse button to quit drawing the B-
style curve.

2. Repeat step 1 to add points, or right-click to end the drawing of the current B-style curve, if you want

Draw the entity point by clicking the left mouse button. The operation steps are as follows.

Draw a line segment entity, click the left mouse button to draw the start point of the line segment
entity. The operation steps are as follows.

Draw polylines interactively with the mouse.

Draw B-style curves interactively with the mouse.



to close, click the close button, and repeat step 1 to start the drawing of a new B-style curve.
3. Click the right mouse button to exit drawing the B-style curve.

Bezier Curve

1. Click the left mouse button to select the point, or click the right mouse button to quit drawing the
Bezier curve.

2. Repeat step 1 to add points, or click the right mouse button to end the drawing of the current Bezier
curve, if you want to close, click the close button, and repeat step 1 to start the drawing of a new
Bezier curve.

3. Click the right mouse button to exit drawing Bezier curves.

Circle

1. Click the left mouse button to select the center of the circle, or click the right mouse button to exit the
circle drawing.

2. Double-click the left mouse button to select a point in the circle, or right-click to go to Step 1.
3. Click the right mouse button to exit drawing the circle.

Two-point circle

1. Click the left mouse button to select an endpoint on the diameter of the circle, or click the right mouse
button to exit the two-point circle.

2. Double-click the left mouse button to select another end point on the circle diameter, or right-click to
go back to Step 1.

3. Click the right mouse button to exit the two-point circle.

Three-point circle

1. Click the left mouse button to select a point on the circle, or click the right mouse button to exit the
three-point circle.

2. Click the left mouse button to select the second point in the circle, or right-click to go to Step 1.
3. Double-click the left mouse button to select the third point in the circle, or right-click to go to Step 2.
4. Click the right mouse button to exit the three-point circle.

Draw a Bezier curve interactively with the mouse.

Draw a circle interactively with the mouse.

Draw a circle interactively with the mouse.

Draw a circle interactively with the mouse.



Three-point circular arc

1. Click the left mouse button to select the first point on the arc, or click the right mouse button to exit the
three-point circular arc.

2. Click the left mouse button to select the second point on the arc, or click the left mouse button to go to
Step 1.

3. Double-click the left mouse button to select the third point on the arc, or click to go to Step 2.
4. Click the right mouse button to exit the three-point circle arc.

Three-point rectangle

1. Click the left mouse button to select a point, or click the right mouse button to exit drawing the
rectangle.

2. Repeat step 1 to add points, click three points to end the current drawing, repeat step 1 to start a new
rectangle drawing.

Draw polygon

1. Click the left mouse button to select a point, or click the right mouse button to exit drawing polygons.
2. Repeat step 1 to add points, or click the right mouse button to end the current polygon drawing,

repeat step 1 to start a new polygon drawing.
3. Click the right mouse button to exit drawing polygons.

Text

1. Click the text button to open the text setting parameters panel and set the parameters.
2. Left-click with the mouse to confirm the position of the text annotation, or right-click with the mouse to

exit drawing the text annotation.

Parameters

Texts: Set the content of the text annotation to be added.
Rotation(angle): The rotation angle for drawing the text, in a counterclockwise direction.
Height: The height for drawing the text.

Add node

Draw the arc interactively with the mouse.

Draw a rectangle interactively with the mouse.

Provide a way to draw polygons and provide editing functions for adding and deleting nodes.

Add text annotation.

Interactively edit the polygon with the mouse and add nodes.



1. Click the left mouse button to select the polyline or polygon entity to be edited, or click the right
mouse button to exit edit polygon.

2. Left-click a polyline or polygon entity location to add a node at that location, or right-click to end the
current edit and repeat the steps to start a new edit.

3. Click the right mouse button to exit adding nodes.

Append node

1. Click the left mouse button to select the polyline entity to be edited, or click the right mouse button to
exit editing. 2 Click the left mouse button to select the point, and judge the insertion position of the
point according to the distance. If it is closer to the starting point, add a point before the starting point,
otherwise add a point after the ending point, or click the right mouse button to end the polyline editing,
and repeat the steps begin a new polyline edit.

2. In the attributes panel on the right, select the type of line segment to be added (polyline, B-style
curve, Bezier curve). The default is polyline, and you can switch between the three by left-clicking the
mouse.

3. Click the right mouse button to exit the append node.

Delete node

1. Click the left mouse button to select the multi-line or polygon entity to be edited, or click the right
mouse button to exit editing.

2. Click the left mouse button on the polygon entity node to delete the node, or click the right mouse
button to end the current edit, and repeat the steps to start a new edit.

3. Click the right mouse button to exit the delete point.

Break in line

1. Click the left mouse button to select the polyline, B-style curve or Bezier curve to be edited, or click
the right mouse button to exit editing.

2. Click the left mouse button to select the first intersection point on the polyline, or click the right mouse
button to end the current edit, and repeat step one to start a new edit.

3. Click the left mouse button to select the second intersection point on the polyline to complete the
interruption, or click the right mouse button to go back and select the first intersection point.

Interactively edit the polygon with the mouse and add nodes.

Interactively edit polylines, B-style curves or Bezier curves with the mouse, adding nodes at the
beginning and end.

Edit the polygon interactively with the mouse and delete nodes.

Interactively edit polygons with the mouse, breaking lines.



4. Click the right mouse button to exit the break line.

Break at Point

1. Click the left mouse button to select the polyline, B-style curve or Bezier curve to be edited, or click
the right mouse button to exit editing.

2. Click the left mouse button to select an intersection point on the polyline, or click the right mouse
button to end the current edit, and repeat step one to start a new edit.

3. Click the right mouse button to exit the break at point.

Merge Polylines

1. Click the left button of the mouse to continuously select multiple non-closed vector lines (polyline, B-
style curve or Bezier curve), and click the merge function to merge the selected vector lines.

2. After clicking the merge function, click the left mouse button to continuously select the vector lines to
be merged, and click the right mouse button to merge the selected multiple vector lines.

3. Click the left mouse button to select a vector line, click the right mouse button to select another vector
line, and click the left mouse button to select another vector line to complete the merging.

4. Click the right mouse button to exit the merge.

Join Polylines

1. Click the left mouse button to select the starting point or endpoint of the first vector line to be spliced,
and right-click to exit. 2. Click the left mouse button to select the starting point or endpoint of the second
vector line to be spliced and complete the splicing with the first vector line. #### Intersect Polylines ####

1. Click the left mouse button to select the first vector line for intersection, or click the right mouse button
to exit editing.

2. Click the left mouse button to select the second vector line for intersection, or click the right mouse
button to go back to step 1.

3. Select the desired intersection point to complete the operation.

Trim Segments

Edit polygons interactively with the mouse, breaking at points.

Interactively edit polygons with mouse, merge.

Edit multiple lines interactively with the mouse and splice them.

To intersect multiple lines through mouse interaction.

Editing and trimming polygons through mouse interaction.



1. Click the left mouse button to select a polyline, rectangle or closed polyline as the reference line, or
click the right mouse button to exit editing.

2. After selecting a reference line, click the left mouse button to continue selecting reference lines, or
click the right mouse button to prepare for selecting vector lines to trim.

3. After entering the state of selecting vector lines to trim, click the left mouse button to select the vector
line that needs trimming. The selected vector line will be deleted based on its intersection with the
reference line.

4. Clicking the right mouse button allows you to go back and reselect a reference line; clicking it again
exits trimming.

Note: The intersection point used for trimming judgment is on xy plane and has nothing to do with
elevation of vectors.

Reshaping

1. Click the left mouse button to select the multi-line or polygon entity to be edited, or click the right
mouse button to exit editing.

2. Pick up points in the scene.
3. Select the line segment type of shaping (multi-segment line, B-style curve, Bezier curve) in the right

attribute panel. The default is multi-segment line, and you can switch between the three by clicking
the left mouse button.

4. Double-click on the polygon or it’s edge to end the current edit.
5. The non-closed polyline directly replaces the part between the first intersection point and the last

intersection point with the newly drawn line segment. The closed polyline will retain the new two
closed polylines.You need to click the left mouse button to select a closed polyline to be deleted.

Cut Polygons

1. Click the left mouse button to select the closed polyline or polygon entity to be edited, or click the right
mouse button to exit editing.

2. Pick points within a polyline or polygon area
3. Double-click on the polyline or polygon boundary to end the current edit.

Geometric Buffer

1. Click to start the geometric buffer, click the apply button on the parameter interface, and generate a
buffer zone vector for the selected vectors to the currently selected layer based on the buffer zone

By constructing sketch shaping lines or surfaces on selected elements. The element takes the
shape of the sketch connected from the first intersection of the sketch and the element to the last
intersection.

Split the selected faces according to the drawn line.

Generate a buffer zone for the selected vectors.



size.

Parameter Settings

Distance： The size of buffer。
Endcap Style： Endcap styles including Round, Mitre, and square。
Join Style： Join Style including Round, Mitre, and Bevel。
Buffer line single side：Single-sided buffer is divided into left and right sides and applies only to line
segments. The layers generated for line segments remain consistent with the original line segments.

Line smoothing simplification

1. Click the Line Smoothing Simplification button, the parameter interface will pop up, and set the
parameters.

2. Select the vector line object and click Execute.

Parameters Settings

Enable smoothing: Whether to use smoothing.
Smoothing Distance: This parameter is valid when smoothing is enabled. Specifies the average
distance between two adjacent points after smoothing.
Enable Simplification: Whether to enable Simplification.
Simplified Distance: Specifies the maximum distance deviation from points to lines to keep. As the
distance gets smaller, the more points are kept, and the fewer points are removed from the line.

Smooth or simplify the polyline.



Element Extraction

The Element Extraction module is used to extract element in the scene. The module provides intersection
drawing line, Semi-automatic building contour vectorization and road ridge vectorization. The vectorized
objects of this module are buildings or roads. When starting any function of this module, if there is no layer
currently, the software will automatically add a layer. will be stored on the layer.

Vectorized buildings with Draw by Intersection

                      
                   

                
                 

                 
               

                   
                 

                  
                  

           
                

                
                  

             
             

             
                

                 
                

               
          
              

                 

Start the function of vectorized buildings with Draw by Intersection

Start the function of semi-automatic building outline vectorization

                   

                   
             

                  

  

              
                 

     

1.  Click  the  left  mouse  button  to  select  two  points  on  one  side  of  the  building  in  tum.
2.C lick  the  left  mouse  button  to  select  two  points  on  the  other  side  of  the  building  in  turn.
3.T he  two  selected  edges  will  automatically  extend  to  meet  the  intersection  point.
4.(  Optional)  Right-dick  the  mouse  to  pop  up  a  right-click  menu,  and  select  Close  Polyline,  Back  Point,  or 
End  Current.
5.( Optional)  Click  the  back  button  on  the  toolbar  to  back  the  selected  vertex.
6.(  Optional)  Click  the  tool  bar  close  button  to  automatically  close  the  current  polyline  and  end  the  drawing
of  the  current  intersection  drawing  method.

Extract Building Footprint

             

               
              

                 
                 

 

               
                  

                
                  

            
               

               
                 

                 

                 
              

            

                

1.C lick  the  left  mouse  button  to  select  the  area  to  be  extracted.
2.D ouble-click  to  end  the  area  selection  and  automatically  extract  the  outline  of  the  selected  area.
3.T he  outline  is  vectorized  into  a  polyline  and  added  to  the  building  layer.
4.( Optional)  Click  the  back  button  on  the  toolbar  to  back  out  the  outline  extracted  last  time.
5.(  Optional)  Click  the  redo  button  on  the  toolbar  to  re-add  the  outline  of  the  last  rollback.
Parameters:
     From Class:  This  parameter  defines  the  type  of  volume  measurement  data  source.
     From  File  (default):  Use  the  points  in  the  specified  point  cloud  file  within  the  range.  It  is  relatively  slow  
but provides  stable  calculation  results.
     From  Loaded:  Use  the  points  loaded  into  the  scene  within  the  specified  range.  It  is  relatively  fast,  but 
changes  in  data  loading  in  the  scene  will  affect  calculation  results.
     Dividing  Roof  Layer(default  disable):  When  enabled,  it  performs  roof  segmentation  clustering  for  
selected area  buildings  and  extracts  boundaries  for  roofs  at  different  heights.  When  disabled,  it  extracts  
overall boundaries.
     Min  Area  (square  meters)**:  The  minimum  area  to  extract  from  a  region.Boundaries  smaller  than  this  
size will  be  discarded.
     Inner  (default  disable)  :  Whether  to  extract  inner  boundaries  for  point  clouds  with  holes  on  roofs  or  
not.
     Outer  (default  disable):  Whether  to  extract  outer  boundaries  and  save  them  as  external  edges  of  roofs
or not.
     Regularization  (default  enable):Whether  to  perform  regularization  or  not.  After  enabling  this  function,
simplify  and  regularize  extracted  boundaries  accordingly.
     Angle  Tolerance  (degrees):Effective  after  regularization  is  enabled;  sets  an  angle  threshold  for 
regularization  which  is  set  between15°  -  30°  degrees  by  default.  Larger  values  result  in extract building 
footprint.



Regularization: Whether to perform regularization or not. After enabling this function, simplify and
regularize extracted boundaries accordingly.

Angle Tolerance: Effective after regularization is enabled; sets an angle threshold for regularization
which is set between 15° - 30° degrees by default. Larger values result in fewer sharp corners on
edges.

Road Ridge Vectorization

                   
             

                 
                

  
                 
               
                 

 

                 
                

                   
  

                  
             

                  
     

Enable semi-automatic Road Ridge vectorization function

  

                

               
     

Extract Building Footprint from Mesh

                   

               

                 

                  

    

                 

               

                  

  

                  
                

                    
  

                  

             

                  

     

Parameters:

Min  Area:  The  minimum  area  to  extract  from  a  region.  Boundaries  smaller  than  this  size  will  be
discarded.

                Click  extract  building  footprint  from  mesh  button.  A  parameter  dialog  box fewer  sharp  corners  
on  edges.

1.  Click  the  left  mouse  button  for  the  first  time  to  determine  the  location  of  the  search  box.  It  is
  appropriate  to  select  the  location  close  to  the  middle  of  the  curb  stone  facade.

2.  When  an  intersecting  ridge  appears,  click  the  mouse  to  extract  the  ridge.  Click  the  left  mouse  button
  for  the  second  time  to  determine  the  search  direction,  specify  the  forward  direction  of  the  curb,  and
  start  execution  wait.

3.  Automatically  extracts  the  upper  and  lower  edges  of  the  kerb  and  adds  them  to  the  current  layer.
4.  (Optional)  Click  the  back  button  on  the  toolbar  to  back  out  the  last  extracted  ridge.

  5.  (Optional)  Click  the  redo  button  on  the  toolbar  to  re-add  the  retreat  of  the  last  ridge  extraction.

Parameters：

Length(m):  The  length  of  search  box,  with  default  of  0.5  m.  The  larger  the  value,  the  faster  the 
search  speed,  but  too  large  a  value  will  span  two  sections  of  roads  that  are  not  connected.
Width(m):  The  width  of  search  box,  with  default  of  0.2  m.  It  can  cover  the  kerb  area,  and  should  not 
be  too  large.
Height(m):  The  height  of  search  box.  Set  it  according  to  the  height  of  the  road  ridge  to  be  extracted,
slightly  larger  than  the  road  ridge,  and  adjust  it  through  the  height  indicator  line.
Angle  threshold  (degree):  the  degree  of  curvature  on  the  strike  of  the  kerb.  For  the  curve  of  the  arc
road,  the  default  value  is  30°.



Basic Function

Vector Editor provides a variety of basic functions, such as Vertex Editing, Attribute Query, Undo, Redo,
Delete entity, Zooming, and Setting.

Undo

Redo

Delete Entity

Attribute Query

Undo the last edit.

Redo the last edit.

You need to first select the entities which need to be deleted, and then perform the delete
operation.

You can query entity geometry attribute. Users can use the left mouse button to select the entity,
which make the geometry attribute of the entity displayed in the pop-up dialog, as shown below.



Setting
Configure various parameters for vector measurement.



Show Crossing Line: This parameter defines whether to display the cross wire in the screen center
or not.

Yes(default): Show.
No: Hide.

Double Click Mouse's Left Button to Finish Editing：This parameter defines whether the current
editing can be ended when double click the left mouse button.

Yes: Double click Mouse's left button to finish editing.
No(default): Single click Mouse's right button to finish editing.

Show Context Menu: This parameter determines whether to show context menu using right click.

Yes(default): Show.
No: Hide.

Capture Distance (15px): Capture the distance.

Shortcut：Shortcut settings.



Profile Editor

Profile can help with vector editing.

Click

Note:
1.The vector elements by drawing are automatically restricted to the center plane of the section.
2.When modifying vertex or moving vector object in the profile window, only the height value of the
vertex or vector object is changed.

Open Profile viewer.Details please refer toProfileTools



Filter by Elevation

Description

After setting the center position and the buffer, the filtered point set is displayed in the scene. The Z value
range of the points displayed after elevation filtering are all within the buffer zone with the position as the
value center.

Parameters

Position：Show middle Z value.
Buffer：Buffer size around Z value.
Show Plane：Whether to show the plane or not.
Transparency：Set the transparentcy, range from 0 to 99.
Color：Color settings.

The elevation filter is an auxiliary function of vector editing, it can filter out the interference points.



Linked Viewer

Description

The linked viewer is an auxiliary function of vector editing. It loads other types of data in the same area,
such as TIN data, Raster data for auxiliary editing. Editing such as drawing lines, drawing points, and
building boundary extraction can be done in a linked viewer.

Parameters

Linked Viewer：The viewer list contains all the viewers currently opened by the software, select the
associated viewer for auxiliary editing.



Entity Modify

Entity provides many basic functions, such as shift/copy, rotate and scale.

Shift/Copy

Copying entities to one copy or multiple copies, which can create the same entities in different locations.
In addition, multiple entities can be created with the same offset increment by this function. The steps are
shown below.

1. Select the entities that you want to copy.
2. Click copy and click the left mouse button to select the base position.
3. Left-click the mouse to select the location where you want to move, the pop-up dialog box will be

displayed.

Settings

Delete Original: Remove the original entity and keep the moved entity.
Keep Original: Keep both the original entity and the moved entity.
Multiple Copies: Keep the original entity, copy multiple entities, set the number of copies, and the
multiple entities will be shifted with the same offset increment.

Rotate

Rotate entities to get one copy or multiple copies at different rotation angles. In addition, multiple entities
can be created with the same angle increment. The steps are shown below.

1. Select the entities that you want to rotate.
2. Click rotate and click the left mouse button to select the position of rotation center.
3. Left-click the mouse to determine the final angle position of the rotation, the pop-up dialog box will be

displayed.

Settings

Delete Original: Remove the original entity and keep the rotated entity.



Keep Original: Keep both the original entity and the rotated entity.
Multiple Copies: Keep the original entity, copy multiple entities, set the number of copies, and the
multiple entities will be rotated with the same angle increment.
Angle（°）: Set the angle value of rotation.

Scale

Scale entities to get one copy or multiple copies at different scales in different locations. The steps are
shown below.

1. Select the entities that you want to scale.
2. Click copy and left-click the mouse to select the zoom center position, the pop-up dialog box will be

displayed.

Settings

Delete Original: Remove the original entity and keep the scaled entity.
Keep Original: Keep both the original entity and the scaled entity.
Multiple Copies: Keep the original entity, copy multiple entities, set the number of copies, and the
multiple entities will be scaled with the same scale increment.
Isotropic Scaling: This parameter defines the scaling of the X and Y directions, separately. If
checked, the scaling of X，Y and Z directions are the same.

X: Set the scaling of the X direction.
Y: Set the scaling of the Y direction.
Z: Set the scaling of the Y direction.

Polygon Boolean Operations

Generate a new polygon based on the union, intersection, or difference operations between two polygons.
Follow these steps:

1. Left-click to select one polygon; right-click to deselect.
2. Left-click on another polygon, and the boolean operation will automatically generate a new polygon

entity. Parameter settings:

3. Intersection: The common area between the first and second selected polygons.

4. Union: The area belonging to either the first or the second polygon.
5. Subtraction: The area belonging only to the first polygon and not to the second polygon.
6. Symmetric Subtraction: The area belonging either to the first polygon or the second polygon, but

not both.



Entity Snap

Vector Editor provides a variety of snapper operations, The function can control the point location clicked
by the mouse, which can improve accuracy of vectorization.

Snap on Endpoint

Snap on Entity

Snap Center

Snap Middle

Snap Intersection

Restrict Orthogonal

Snap Point Cloud

Snap Model

Snap startpoints and endpoints, such as starting point and ending point of one line.

Select the closed point of entity, snapping can move along the entity.

Snap the center of the entity, such as the center of a circle.

Snap middle points of an entity, such as the midpoint of the line segment.

Snap intersecting points of multiple entities, such as the intersection of two lines.

After selecting a current point, the subsequent selected points can only move in the orthogonal
direction (vertical or horizontal direction) of the current point.

Snap points on the point cloud, this snap is suitable for drawing corners of house etc.



Snap the closest point of model.



Layer Management

Description：Vector editing is managed with layers, which means a file is treated as a layer. Clicking the
triangle button of the "File" will show the drop-down menu, including the "New File", "Open File", "Save
File", "Remove File" and "Export File" functions.

Add Layer

Click Layer>Right-Click Menu>Add Layer, and the "Create New Layer" dialog box will pop up.

1. Choose from the dropdown list of layer names, including: control points, buildings, railways,
highways, other roads, bridges, water bodies, administrative boundaries, farmland, orchards, forests,
grasslands, other vegetation, or directly enter the layer name, as shown below:

2. Click on the layer color to select a layer color.

3. Set the point size and line width, ranging from 1 to 10 pixels.

Save All Layers

Click the "Remove All/Current Layer" function to pop up a dialog box:

Select the file type and path to save, click OK, and save the layer to the corresponding path. Note: If the
saved file extension is shp, a directory named after the layer name with _points.shp or _lines.shp will be
created in the directory. #### Remove All/Current Layers #### Right click *Layer>Remove All Layers*:

Click "Yes" to save all/current layers and remove all/current layers;
Click "No" to not save all/current layers and remove layers;
Click "Cancel" to exit the current remove all/current layer operation.



Show/Hide

Shows or hides the elements drawn by the current layer.



Reference Plane

Description

The reference plane is a drawing plane set in the main window of the vector editing module. When
drawing lines, rectangles, and polygons, the reference plane setting interface automatically pop up. When
drawing vector objects in the main window and the associated window, they are limited to the reference
plane.

Parameters

Height Source：The reference plane is a horizontal plane, and the corresponding height can be set
of multiple sources:

Customize：Users can customize the height by manually entering.

Min Z：Take minimum Z of point cloud as height.

Middle Z：Take middle Z of point cloud as height.

Max Z：Take maximum Z of point cloud as height.

Elevation Filter：Height refer to the center position value in Elevation Filter.

Plane Height：Show plane height.

Show Reference Plane：Whether to show reference plane or not.
Transparency：Transparency setting of reference plane.
Color：Color setting of reference plane.



Show Vertices

Functional Overview

Whether to display the vertices of the polyline, which makes it easier for users to edit entities when turned
on.



Terrain
Terrain module has two modes: Basic and Advanced. Click the button at upper-right corner to select
mode.Basic mode provides one-click processing for terrain products generation.

Advanced

Tools of Advanced mode is shown as figure below:

Preprocessing includes： Subsampling, Remove Outliers, Classify Groud Points, Smooth Points

Based on Point Cloud includes： DEM, DSM, Point Cloud to Contour, Generate TIN

Based on Raster includes： Hillshade, Slope, Roughness, Aspect

Based on TIN includes： TIN to Contour, TIN to DEM

Terrain Conversion includes： Convert TIFF to LiModel, Convert to Texture LiModel, Convert LiModel to
TIFF

Analysis Tools includes: Deviation Analysis, Change Detection Construction Progress Analysis

Model Editor includes： LiModel Editor, LiTin Editor

Other tools include: Section Analysis, Query Dip and Strike, Profile Editor

Basic

Tools of Basic mode is shown as figure below:

Click "Run" and a dialog will pop up. Click "File Selected" and select the point cloud file to be processed.
Then, go to Parameter tab and set parameters for functions. After that, click "OK" and batch process the
data, results will be saved to the specified Output Path.

Other tools include: Section Analysis, Vector Editor, Query Dip and Strike, Profile Editor.



ALSForest
ALS Forest module provides two modes:Basic and Advanced.

Advanced

Advanced mode is showed as figure below:

ALS Preprocessing includes：Subsampling, Remove Outliers, Classify Ground Points, DEM, DSM, CHM,
Normalize( Normalize by DEM, Normalize by Ground Points)

ALS Tools includes: Calculate Forest Metrics by Grid

Regression Analysis:Linear Regression, Support Vector Machine, Fast Artificial Neural Network

Random Forest Regression, Run Existing Regression Model

Segmentation:Point Cloud Segmentation, Generate Seeds by Layer Stacking, Generate Seeds by CHM

Point Cloud Segmentation from Seed Points, CHM Segmentation

ALS Tools: Clear Tree ID, Extract by Tree ID, Statistic Individual Tree Attributes Denormalization

ALS Forest Editor includes:ALS Seed Point Editor, Profile Editor

Basic

Basic mode is showed as figure below:

Click"Run", and a window pop up as figure below. Click "File selected" tab and select the point cloud
file.Then, click "Parameter" tab and set parameters for each function. Click "OK" and the functions will
batch process. Result data will be saved under "Output Path".



ALS Tools includes:Clear Tree ID, Extract by TreeID, Statistic Individual Tree Attributes), Denormalization

ALS Forest Editor includes:ALS Seed Point Editor, Profile Editor



TLSForest
TLS Forest module has two modes: Basic and Advanced. Click the button at upper-right corner to select
mode.Basic mode provides one-click processing for TLS analysis.

Advanced

Tools of Advanced mode is shown as figure below:

Preprocessing includes： Subsampling, Removal Outliers, Classify Ground Points, Normalization(
Normalization, Normalization by Ground Points)

TLS Tools include: Leaf Area Index

Segmentation: Point Cloud Segmentation， Point Cloud Segmentation from Seed Points

Tree Attribute: Statistic Individual Tree Attributes， Increase Individual Tree Attributes

Other ALS Tools: Clear Tree ID， Extract by Tree ID， Denormalization

TLS Forest Editor includes： DBH Measure， Tree Species Identification TLS Seed Point Editor，
Individual Tree Editor， Profile Editor

Basic

Tools of Basic mode is shown as figure below:

Click "Run" and a dialog will pop up. Click "File Selected" and select the point cloud file to be processed.
Then, go to Parameter tab and set parameters for functions. After that, click "OK" and batch process the
data, results will be saved to the specified Output Path.

TLS Tools include: Clear Tree ID， Extract by TreeID



TLS Forest Editor includes: DBH Measure， Tree Species Identification TLS Seed Point Editor，
Individual Tree Editor， Profile Editor



Power Line
Powerline page is shown as figure below:

Tools include: Setting, Mark Tower, Classify, Danger Points, Clear User Data, Profile Editor



Mine
Mine module provides tools related to mines.

Preprocessing

Preprocessing functions include:

Smooth Points, Resampling, Remove Outliers, Classify Ground Points, DEM, Point Cloud to Contour,

Open-pit Mine

Open-pit Mine includes the following functions:

Generate TIN, Smooth Meshes, Slope Line Extraction.

Analysis

Analysis includes the following functions:

Volume change analysis, Deviation Analysis, Change Detection, Section Analysis,

Tunnel

Tunnel includes the following functions:

Extract tunnel points, Compute Normal Vectors, Triangulation modeling, Poisson modeling.

basic mode

Functions of basic mode are shown as figure below:

Click “Run", the dialog will pop up as shown in the picture below. Click "File Selected" and select the point
cloud file to be processed; go to Parameter tab and set parameters for functions. After that, click "OK" and
batch process the data, results will be saved to the specified Output Path. For corresponding parameters
and Settings, refer to the corresponding function documents.



Building Modeling
The function of Building Modeling realizes automatic extraction of building model based on classification
point cloud, manual editing and storage of automatically extracted model results. In the process of building
model editing, the point cloud and image data are used as the background, and the real-time preview
effect of the building model is used as the auxiliary, the building model is constructed by manually editing
the two-dimensional vectorization object of the building model quickly and accurately. At the same time,
the results of building model support the generation of OBJ, FBX, CityJSON format for third-party software
interconnection.

Modeling Process

Extract Building Footprint

Subsampling

Remove Outliers

Classify Ground Points

Classify by Deep Learning

DSM

DOM

Building Model Registration

Auto Create Buildings

Project Textures form Photos

Attributes Caculate

Building Editor

Matched Photos Editor

Materials Editor



Display
This chapter explains usages of different modules and functions on Display page, includes Display and
Record, Viewers and Operations.

Display and Record

Viewers

Operations



Display and Record
Display menu of the software.

Render to Image

Camera Roam

Save to Video

Background Grid

Camera Setting

Display Solid Model

Display Wireframe

Display Vertices



Render to Image
Functional Description: This tool can render the current view as an image file (*.bmp format is
supported). The way of scaling to equal proportions based on the window size and from width to height is
supported to generate larger than the current window size of the image. Settings to select whether to
scale features is supported, and if window size scaling ratio is greater than 1, and no feature is scaled, a
more detailed picture than the window display effect can be obtained.

Steps

1. Adjust the 3D view to get the scene you want to render.
2. Click Menu > Display > Render to ImageUse this function, the pop-up interface is as follows.

3. (Optional) Set the zoom factor.
4. (Optional) According to demand to choose check or won’t check the "Don't scale features (points

size)”.
5. (Optional) Set the output path.
6. Click "OK" to get the rendered image.

Parameters Settings

Shortcut Keys: None
Input Function: Current active window.
Zoom: This parameter defines how many times the rendered image size can be enlarged based on
the original window size.
Size: This parameter does not support the setting. The size of the output image is calculated in real
time based on the zoom factor, and the size is displayed in parentheses. When the actual size is too
large to be supported by the running environment, the output picture will fail and a prompt will be
given in the output window.
Don't scale features (points size): By default unchecked. At this time, the output picture quality is
the same as the original window, and no more detailed content will be obtained. When the scaling
ratio is 1, this parameter has no effect. When the zoom ratio is greater than 1 and this function is
selected, the pixel size occupied by each point in the point cloud is the same as the pixel size
occupied by the window. When the picture size is larger than the window, the details of the point
cloud seen in the picture are clearer, and the picture with finer display effect than the window is
obtained.
Output path: Set the image output path. Note: When EDL is on, Render to File tool supports adding
the EDL effects to the results.



Capture Image

Steps

1. Clicking this button, and click "OK" in the pop-up to save the file with the default file name the same
as the window name.

Functional Description: Save the view in current window as a JPG file.



Capture Image

Steps

1. Click this button, open save file dialog, default file name is window name, click "OK" to save file.

Brief: Save the view in current window as a JPG file.



Camera Roam
Brief: This function can control the scene camera to navigate through a roam path. Two types of roam
path are supported including roam path based on viewport and roam path based on POS file. This
function can also generate immersive video if cooperated with Save to Video function.

Steps

1. Click Display > Camera Roam to open Camera Roam Set dialog as bellow.

2. Choose mode as desired(Select "Roam by Viewports" or "Roam by Pos Path").

2.1 Roam by Viewports
Speed: Set the speed of Roam by Viewports.

Add Key Frame：Click this button to add current viewport as a key frame.
Delete Key Frame: Click this button to delete a key frame.
Load Key Frames from File: Click this button to import a key frame file.
Save Key Frames to File: Click this button to export all key frames to file.
Delete All Key Frames: Click this button to delete all key frames.

Select a key frame in the list: Scene camera will be adjusted to this key frame.
2.2 Roam by POS File

Check or uncheck "Show Path" as desired.
Set the Path Width, which will be activated when "Show Path" is checked.
Click Settings to open the following dialog.



Select a POS File: txt format only, each line of the file represents a key frame. The first three
columns are assumed to be XYZ. Column delimiters include comma, semicolon and space.
Set parameters: Including offset, time step, yaw, pitch, roll.
Click "Ok" to end the roam path setting.

3. Click "Start Roam" to begin roam through current path. After finished, the following dialog will show.

4. (Optional) Click "Pause/Continue" to control the pause and resume of roaming.
5. Click "Stop" to exit this roam tour.
6. Click "Cancel" to exit this function.

Settings

Input: Viewport of current window or POS file.
Settings of Roam by POS file：

Path Width: Non negative integer only, defines the line width of POS trajectory in the viewer.
X/Y/Z Offset：The default value will be the offset of scene coordinate to the world coordinate
system, as POS data is in the world coordinate system.
Time Step: real number larger than 0.01 only, defines the time interval between key frames. The
smaller this value is, the slower the roaming speed is.
Yaw/Pitch/Roll：Local roam coordinate is defined that the orign is key frame center, the Y axis
points to the motion direction, the X axis is defined based on Y axis and world coordinate Z axis
using right-hand coordinate system principle, the Z axis is defined based on X axis and Y axis
using right-hand coordinate system principle. By default, the roam camera is towards -Z, the right
of camera is +X, the upper of camera is +Y. Yaw means spinning around +Z. Pitch means
spinning around +X. Roll means spinning around +Y.



Save To Video
Brief: Record the current window screen and save as video (mp4 and avi formats are supported).

Steps

1. Click Display > Save To Video, an interface will show as follows.

2. Set the frame rate(default is 25 frame per second).
3. Set the bit rate.
4. Set the output path of video.
5. Click "OK". The following interface is shown on the left-top corner of the current window.

6. Change the camera to get the scene which you want to record.
7. Click "Stop" or "Start"

Stop：Pause the current record.
Start：Recover the record.

8. Click "End" to finish recording. The video will be saved.

Settings

Input: the scene of the window for record.
Frame Rate: The frequency (rate) at which consecutive images called frames appear on a display.
Bit Rate: Refers to the number of bits used per unit of playback time to represent the video. Lower bit
rate may result in lower resolution of the picture and has mosaics on the picture, and however the
higher bit rate may lead a larger video file. The default bit rate is automatically adjusted according to
the system resolution.
Output path: The file path to which the video will be saved.

Note: When EDL is on, Save to Video tool supports adding the EDL effects to the results.



Background Grid
Summary：This tool can be used to display the 3D grid in the viewer window. When there are multiple
point clouds in the window and the distance between the point clouds is short, the grid range of all point
clouds is calculated and displayed. When there are multiple grids in the window and the point cloud is far
away, the grid range of the point cloud within the display range of the current window is calculated and
displayed.

Steps

1. Click Display > Background Grid to use this function.

Settings

Function Summary：Set the display or hide of grid plane (XY plane, XZ plane, YZ plane), display or hide
of grid label, grid line style, line color, and font color.

Grid Plane (XY Plane, XZ Plane, YZ Plane) Display or Hide (Default is Display All): Check or
uncheck the checkboxes in front of the three planes to change the display status of the corresponding
planes.
Grid Label Display or Hide (Default is Display): Check or uncheck the checkbox before the text to
change the display status of the label.
Line Style (Default is Solid Line): Click , select the grid line style (solid or dot).
Line Color (Default is White): Click , a color selection interface will pop up, and one
of these colors can be selected as the color of the line.
Font Color (Default is Red): Click , a color selection interface will pop up, and one
of these colors can be selected as the color of the font.
Axis Setting (X-Axis, Y-Axis, Z-Axis) Cell Size (Default is "50"): Click , the value will
increase or decrease in steps of 10. User can also directly enter a specific value. The cell size of the



Y-axis and Z-axis can be set to be the same as the X-axis, so that there is no need to set the cell size
of the Y-axis and Z-axis separately.



Camera Setting

Steps

1. After clicking this button, the dialog shown below would pop up:

2. Adjust camera rotation using sliders.

Settings

Prerequisite: Current active window must be in 3D mode.
Current mode: Show projection type of current active window, including perspective projection and
orthogonal projection.
X: Camera rotation around X axis.
Y: Camera rotation around Y axis.
Z: Camera rotation around Z axis.
Camera/Eye Center: Non-editable, computed using rotation.
Field of view: Field of view, default 30 degree.
Distance: Distance to viewpoint. Non-editable.

Brief:Camera settings for current active 3D window.



Display Solid Model

Steps

1. Click this function, the models in the current active window will display in model, as shown in the
figure below:

Settings

Shortcut key：Press the "W" key to switch the display mode between model, triangle and point.

Note: The model types for this function includes LiTIN, LiModel, IVE and other model types.

Brief：Set model files in the current window to display in model type.



Display Wireframe

Steps

1. Click this button, the models in current active window will display as triangle mesh, as shown in the
figure below:

Settings

Shortcut key：Press the "W" key to switch the display mode between model, triangle and point.

Note: The model types for this function includes LiTIN, LiModel, IVE and other model types.

Brief: Switch display mode of models in current window to triangle mesh mode.



Display Vertices

Steps

1. Click this button, the models in current active window will display as points, as shown in the figure
below:

Settings

Shortcut key：Press the "W" key to switch the display mode between model, triangle and point.

Note: The model types for this function includes LiTIN, LiModel, IVE and other model types.

Brief: Switch display mode of models in current window to point mode.



Viewers
This menu provides operations to create, close and arrange windows.

New Viewer

Close Active Viewer

Close All Viewers

Viewers Layout

Tile Viewers

Tab Viewers



New Window
Brief：Create new window in the current project.

Steps

1. Click the menu Viewers > Add Window. The result is as follows.

Shortcut Key：Ctrl+F3



Close Active Viewer
Brief: Close the active window in the current project.

Steps

1. Click the menu Viewers > Close. The active window will be closed.

Shortcut Key：Ctrl+F4



Close All
Brief: Close all windows in the current project.

Steps

1. Click the menu Viewers > Close All. All windows are closed.



Viewer Layout
Tile Windows

Tab Viewers



Tile Windows
Brief: Rearrange all the viewers in tiled fashion.

Steps

1. Click the menu Viewers > Viewers Layout> Tile Windows. The result is as follows.

Note: This function needs at least one window in the current project.



Tab Viewers
Brief: Rearrange all the viewers in tab fashion.

Steps

1. Click the menu Viewers > Viewers Layout> Tab Viewers. The result is as follows.

Note: This function needs at least one window in the current project.



Operations
Window Linkage

Rolling Screen

Go To



Window Linkage

Steps

1. Click this button to open the dialog shown below:

2. The windows list contains all windows in LiDAR360, double-click a window that needed to linkage, or
select the window then click button  to add the window. Also, user can click button 
to add all windows to linkage windows list. The linkage windows list all windows under linkage,
double-click a window to remove, or select the windows and then click button  to remove.
Also, user can click button  to remove all linkage windows.

3. If "Cross Line" is checked, cross line will be displayed in the linkage windows. The following figure
shows if the cross line is checked:

Note: If the current window contains raster data, it will be displayed in 2D. If the linkage windows
contain 3D window and 2D window, the windows will be displayed in 2D mode.

Brief: Enable windows linkage of multiple viewers.



Rolling Screen

Steps

1. Click this button to open the dialog shown below:

2. Current files list contains files in current viewer. Double-click a file that needs to be added to rolling
screen, or select files and then click , or click button  to add all files to rolling
screen files. The rolling screen files list contains files in rolling screen, double-click a file to remove, or
select files and then click button  to remove, or click button  to remove all files.

3. Click "OK". In the viewer, press the "Shift" button on the keyboard then drag. The window is shown
below:

Settings

Prerequisite: An active viewer.

Note: This function cannot be apply to the profile window. Click this button again to exit.

Brief: Enable rolling screen for current viewer.



Go To

Steps

1. Click the window that contains data with the left mouse button and set it as the active window.
2. Click the button  on the toolbar and the mouse pointer turns to . Select a particular point in the

scene. The attributes of this point will be shown in a label. At the same time, the "Go To" dialog pops
up, as shown below.

3. If "Pick Point" is checked, the focus point is selected by mouse click. Otherwise, the coordinates of
the focus point are selected by manual input.

4. Set the time to go to the selected point.
5. Click the "OK" button. The label will disappear, and a red dot will start to flash.
6. When it is focused to the selected point, the red dot disappear, as shown below.

Settings

X: X component of the coordinate.
Y: Y component of the coordinate.
Z: Z component of the coordinate.

Brief: This tool is applicable to point cloud data, raster data and model data. It's used to focus to
the selected point.



Time: Time to go to the selected point.
Pick Point (Optional): If "Pick Point" is checked, the focus point is selected by mouse clicking.

Note: When there are multiple windows, this tool only works on the active window.



Profile Editing

The use of LiDAR data to produce high-precision terrain products requires manual inspection and
correction of the results of automatic classification. In this case, it is necessary to use the profile editing
and classification tools. LiDAR360 has provided memory editing and external memory editing starting from
V3.1, and multiple viewers can select the classification mode at the same time. The profile editing tool of
LiDAR360 provides a series of editing tools, and supports shortcut key operations. With shortcut keys and
mouse operations, users can not only switch between different tools for classification operations more
conveniently, but also perform classification inspections and corrections more efficiently.

Block Editing Tool

Draw Profile

Profile Vector Tools

TIN Tools

DEM Preview Tool

Select Tools

Simulate Terrain Points

Classify Panel

Profile Viewer Tool

Breakline Tool

Profile and TIN Tools

TIN tool is to build triangular model in real time, you can use check editing effects.

Note: You can use shortcut P on keyboard to adjust light, which can improve the display effect.

Please refer to TIN Tools for detailed information.

Profile and Measurement Tools

When the profile is turned on, the point cloud viewer and TIN viewer do not support measurement
functions. The profile viewer supports single-point selection, multi-point selection, length measurement,
angle measurement, slope measurement, and height measurement.

Description：Users can draw a buffer on point cloud in 3D viewer and check correspongding
profile in profile viewer. It can help with data check, measurement and classification.



Profile and Boresight Correction

When using boresight correctio, we need to check mismatch issue between trajectory segments in profile
viewer.

The above figure is the relative position before boresight correction.

During the correction, you can check real-time correction performance in profile viewer:

You can confirm and apply the correction parameters to the point cloud. It can be directly overwrite the
previous point cloud data.

Besides, the measurement tools in profile viewer can help to evaluate Pith, Roll and Heading. Please refer
to Strip Alignment for detailed information.

Profile and ALS Editor

When activate the ALS Editor, the main viewer will switch to 2D viewer. You can use profile viewer to
check if seed points are correct in 3D view. Click Profile Tool to open profile viewer. Select a polygon area
in point cloud viewer, and corresponding point cloud will appear in the profile viewer. Then, you can zoom
or rotate in profile viewer to check seed points.



Note：Profile in ALS Editor doesn't have the same profile tool bar as general profile tool.

Profile and TLS Editor

When activate the TLS Editor, the main viewer will switch to 2D viewer. You can use profile viewer to
check if seed points are correct in 3D view. Click Profile Tool to open profile viewer. Select a polygon area
in point cloud viewer, and corresponding point cloud will appear in the profile viewer. Then, you can zoom
or rotate in profile viewer to check seed points.

Note：Profile in TLS Editor doesn't have the same profile tool bar as general profile tool.



Block Editing Tool
Block editing tool allows users to split the LiData into several tiles, and inspect and edit each block
separately. After starting editing, software will determine the range of each memory data block according
to the partitioning mode selected by the user and the related parameter Settings, and load all the point
cloud data in the current data block for further editing. Users cancreate TIN modelfor the current memory
point cloud to assist further classification work.

 

Icon Description Shortcut keys

Start block editing, split the data into tiles.

Inspect and edit them separately Ctrl+Z

Redo Ctrl+Y

Save Ctrl+Shift+S

Settings

Shortcut keys Settings

Block Move Left Alt+←

Block Move Right Alt+→

Block Move Up Alt+↑

Block Move Down Alt+↓

Choose Block

Choose Blocks by Rectangle

Display/Hide the Text

Edit Toolbar

Tile

Note: It is recommended that approximate 1500k points are in each block in average when setting the
width of each grid.

Functional Description: Clicking on the tile button, the window of "grid setting" will pop-up.
Users can select one of the three blocking methods of "Block by Width", "Split by Width" and
"Block by Polygon" according to the window prompts to set the relevant parameters. Click OK,
and the software will display all the point cloud data in the grid block.



Cancel

Note: In each profile editing, the undo and redo functions can only return results within 20 steps
before the current result.

Redo

Note: In each profile editing, the undo and redo functions can only return results within 20 steps
before the current result.

Save

Settings

Save automatically when switching memory blocks: This parameter is used for memory mode
editing. If this option is checked, the software will automatically save the edit when users change the
editing block to another one.

Functional Description: This function allows users to redo the undone steps. This function will
be disabled after saving the data. Support operations in big data mode and memory mode

Description: This function allows users to redo the undone steps. This function will be disabled
after saving the data. Currently, the big data mode is not supported.

Functional Description: Save the modified data to the corresponding LiData file.

Functional Description: Profile editing supports automatic saving mode when users switch
memory data blocks.



Shortcut keys Settings
After clicking this function, users can set Shortcut keys for part of the functions in profile editing. After
clicking this function, the popup window is shown as follows:

The platform page is a shortcut that is already used by the platform function, and the profile cannot use
these shortcuts. All the editable operations for the profile are listed in the profile window. Click Shortcut
keys column, and press the key on the keyboard to set , and then click OK to finish the setting.

Block Change Toolbar
Block Change Toolbar is active only when the data is split into tiles.

Block Move Left

Block Move Right

Functional Description: In the grid combination table displayed in the window, the data in the
left grid of the current data block is displayed for data editing.

Functional Description: In the grid combination table displayed in the window, the data in the
right grid of the current data block is displayed for data editing.



Block Move Up

Block Move Down

Choose Block

Choose Blocks by Rectangle

Display/Hide Blocks

Functional Description: In the grid combination table displayed in the window, the data in up
grid of the current data block is displayed for data editing.

Functional Description: In the grid combination table displayed in the window, the data in down
grid of the current data block is displayed for data editing.

Functional Description: This tool is effective in memory editing mode. Click this button, users
can click any grid in the main view window or TIN window for data display, viewing and edit.

Functional Description: This tool is effective in the memory editing mode. Click this button, and
users can select multiple grid blocks in the main view window or TIN window to view and edit the
data by pulling a rectangle.

Functional Description: This tool is effective in memory editing mode, click the button, users can
switch to Display/Hide the number corresponding to the blocks.



Draw Profile

Icon Description Hot Key

Start Profile Editing Tool Alt+S

Move Profile

Rotate Profile Area X or ← →

Expant Profile Area

Move up Profile ↑

Move down Profile ↓

Profile Tool

Buffer

Description: Click the triangle icon right to the profile icon, and then click the buffer settings button, the
buffer settings window will popup. This function can help users to fix the size of the buffer area.

Move Profile

Description: Used to create a profile view of a certain area when select an area in the main
window or TIN window.

Description: When the move profile tool is activated, move the mouse to the profile area and
drag it. The profile area can be moved with the mouse. If the mouse drag outside the profile area,



Rotate

Expand

Move Up the Profile

Move Down the Profile

drag it. The profile area can be moved with the mouse. If the mouse drag outside the profile area,
it will not be moved with the mouse.

Description: Support to rotate the profile area based on the angle that users enter in the rotate
settings window. Click the triangle next to the icon and click the rotate settings button, the rotate
settings window will popup.

Description: Used to expand the width of profile area by the entered number. If the entered
number is negative, the profile area will be reduced.

Description: Used to move up the current profile to create a new profile with the same size and
right above the current profile.

Description: Used to move down the current profile to create a new profile with the same size
and right below the current profile. Click the triangle next to the icon and click the step length
settings button, the step length settings window will popup. If the checkbox in front of the step
length tag is checked, the step length will be fixed as 1.5 times step length and cannot be
changed. If the checkbox is unchecked, users can change the step length based on their needs.



Breakline Tool
Description: The breakline tool supports users to draw, import and store point cloud breaklines. Based on
the excellent display effect of point clouds and terrain models, it can clearly draw water bodies, steep
slopes, rivers, roads and other breakline elements with high contrast. On the basis of drawing breaklines,
using the drawn breaklines to assist [Tin Tool](TINTools.md) in adding breaklines for terrain editing and
point cloud classification processing. After enabling memory point cloud editing, you can activate the edit
tool for breaklines and correspondingly generate a broken line object loaded into the directory tree and
participate in various windows for editing. The broken line editing tool includes sub-function modules such
as broken line importation, broken line drawing, utility tools, broken line selection, entity capture and layer
management.

Add Breakline

Draw Vectors

Supports drawing of multi-segment lines or polygons as breakpoints. For specific operations please refer
to Vector Editor Entity Vectorization for multi-segment lines or polygon drawings.

Utility Tools

Supports deletion of breakpoints and attribute queries. For specific operations please refer to Vector
Editor Basic Functions.

Snap

Supports capturing existing breakpoints or points clouds during breakpoint drawing process. For specific
operations please refer to Vector Editor Entity Snapper.

Layer Management

Allows addition of layers or modification of layer attributes. For specific operations please refer to Vector
Editor Layer Management.

Storage

When exiting the classification editing function, users will be prompted whether to save the modified
breakpoint file. Click "Yes" to store and "No" to cancel storage.

Users can also use the layer management tool for breakline storage.

Importing breaks lines from previously edited and stored files.



Breakline Tools
The section editing breakline tool is mainly for point cloud classification and section TIN editing, mainly to
solve the problem of missing terrain features (such as ridges, rivers or other feature lines that want to be
saved in TIN) caused by the direct construction of TIN from laser point clouds .

The breakline tool belongs to the section editing module. Activate the section editing module, click "Start
Editing" on the menu bar, and execute the "TIN" to generate this function. The source of the breakline can
be drawn by the user or imported externally.

 

Add Breakline

The user draws a breakline. Currently, there are mainly three ways to add breaklines: single breakline,
closed area breakline (such as lake) and regional breakline between two lines (such as river).

Usage

(1) Click "Add BreakLine"in the menu bar , and a dialog box will pop up:

(2) Switch the type option to the type to be added;

(3) In the dialog box, click "Draw Polyline" or the toolbar to enable the drawing function, and draw a
polyline on the triangle net (same as the vector editing module to draw a polyline, left click to add a point
to the polyline, double click to end the drawing, right click to pop up a menu Choose to close and finish
drawing);



(4) Click the "Select" button in the dialog box or toolbar to enable the selection function, and select the
polyline corresponding to the type in the scene;

(5) Set the corresponding parameters and click the "Add" button in the dialog box to complete the addition.

Single break line

Mainly deal with ridges, roadsides and other types of breaklines. Select a polyline in the scene (only one
can be selected at a time);

 

Settings

Breakline type: Divided into two types: soft and hard. The result point of the soft breakline type is on
the triangular network, and the result point of the hard breakline is on the polyline;
Add to layer: The result of the breakline is saved to the corresponding layer;
Unified elevation: Only effective below the hard break line. If unified elevation is activated, the result
line will be projected to the specified elevation plane. The default is the elevation of the last point of
the polyline, which can be set by manually inputting or clicking the "select point" button and or
selecting the point model. Right-click to exit the point selection mode.

Closed area breakline



Such as the lake breakline. Select a closed polyline in the scene (only one can be selected at a time);

 

Parameters Settings

Add to layer: The result of the breakline is saved to the corresponding layer;
Initial category: The category of the point cloud in the area of the breakline to be processed,
generally the network type or all selections;
Target category: classify the point cloud within the selected breakline as the target category;
Elevation setting: If the elevation setting is activated, the result line will be projected to the elevation
plane, and the default is the elevation of the last point of the polyline. You can manually enter the
setting or dick the "select point" button or select the point model to set it, right click can exit the point
selection mode
Automatic Elevation Type: Planar (for features like buildings and rivers), Progressive (for features
like rivers and roads).
Automatic Elevation Method: Mean, Maximum, Minimum, Percentile.
Elevation Values: Elevation values can be determined automatically by enabling automatic elevation
calculation, entered manually, or set by clicking the "Select Point" button or using a point selection
model. You can exit point selection mode by right-clicking.

Two break line area



Such as the area between the two banks of a river. Select two non-closed polylines in the scene;

 

Parameters Settings

Add to Layer: Set the layer where the breakline will be placed after adding.
Source category: The source category of the point cloud corresponding to the breakline to be
processed, generally the network type.
Target category: Divide the point cloud within the range of the breakline into this setting category.
Elevation setting: Whether to enable the elevation setting. If the elevation setting is enabled, the two
polylines will be adjusted incrementally according to the start and end elevations. The default is the
start elevation value of the first polyline drawn, which can be set manually or click the "select point"
button or select the point model to set, right click to exit the point selection mode.
Starting elevation value: Starting elevation.
End elevation value: End elevation value.

Delete breakline

Delete the specified breakline in the scene. Click the "Select" button in the Add BreakLine dialog box or
toolbar to enable the selection function, select a vector line in the scene, and click the "Delete” button in

the toolbar to delete the vector line and related operations.



Import breaklines

Support for importing vector files. By activating the "Import Breakline" button, select the file to import,
and select the polyline to add the breakline by adding the polyline function.



Simulate Terrain Point

Summary

The terrain point simulation tool mainly solves the phenomenon of missing terrain points in mountainous
areas caused by dense vegetation occlusion, and simulates the real mountainous terrain triangular mesh
by predicting the terrain of the missing points.

Usage

The terrain point estimation function belongs to the profile editing module. Activate the profile editing
module -> click "Start Editing" -> execute "TIN" to generate this function. Click the terrain point estimation,
and the parameter dialog box will pop up; select the profile tool, draw the profile of the simulated terrain
point area, select the measurement tool in the profile window, and measure the height of the occluded
vegetation; set the parameters in the parameter dialog box, click the select button (left mouse button Add
a point, right-click to go back, double-click OK) to select the simulation area.

Settings

By Reference Trees: Simulate based on high points in the terrain coverage.

Referenced Tree Height: Approximate height of obstructing vegetation measured from profiles.
Sampling Interval: Average spacing between simulated points.
Smoothing Iterations: Number of iterations for smoothing ground points in the simulation; a
larger value results in smoother simulated areas.

By Neighbor Ground Points: Simulate based on neighboring ground points in the area to be
simulated, and the selection should cover the neighboring region.

Sampling Interval: Average spacing between simulated points.
Smoothing Iterations: Number of iterations for smoothing ground points in the simulation; a
larger value results in smoother simulated areas.

Delete Simulated Points

Deletes the specified set of simulated terrain points in the scene.



Usage

Click the "Select" button in the toolbar to enable the selection function, select the simulated terrain point

set in the scene, and click "Delete" in the toolbar  button deletes the point set.



DEM Preview Tool
The DEM preview tool mainly checks the constructed TIN by constructing a temporary DEM of the local
point cloud.

Activate the section editing module, click "Start Editing" in the menu bar, and this function is available after
"TIN" is generated.

Draw polygon area

User-drawn polygon boxes to select the point cloud used to generate the temporary DEM.

Usage

(1) Click "DEM Preview" in the menu bar , a dialog box will pop up:

(2) Draw a polygon in the section window or TIN window, double-click the mouse button to end the
drawing; right click to cancel and redraw. After double-clicking, the DEM will be displayed overlaid with the
point cloud.

Parameter Settings

Scale (default 1:500): Supports four large scales from 1:500 to 1:5000.
Grid size (meters) (default "2"): The resolution at which the DEM is generated.



TIN Tools
TIN tool can be used to build a triangulation network model. When users edit point cloud categories, the
triangulation network will change in real time, so as to assist users to view the editing effect. To speed up
editing, TIN can be built in blocks with width values, and different blocks can be displayed by moving up,
down, left, and right while editing, as well as selected blocks. In fact, it is to browse and edit the data in
memoryLiTin,including adding and deleting points.

Create TIN Model

ClickTINand open setting window, as shown below:

Parameters setting：

Initial Class：User needs to specify the initial category. For example, ground points can be selected
to construct a triangulation model to help edit the classification of ground points.
Create a new window：Whether to create a window.

Yes（default）：Create a new window to display TIN。

No：Display the TIN in main window.

After completing the TIN creation of the memory point cloud block,the TIN object will be added to the main
object tree control on the left side of the software for unified management. At this moment, the TIN objects
on the directory tree can be renamed, displayed by category, displayed by elevation, and deleted through
the right-click menu.

Clear TIN Model

Clear TIN button is available after the generate TIN operation is performed. If you want to display TIN
mode in a new window, click "Clear TIN" to close the new window. If you want to display TIN mode in the
main window, click "Clear TIN" to clear TIN in the main window

Display by Height

Display TIN model by height.



Display by Classification

Display TIN model by classification.



Select Tool
Select tool supports to choose arbitrarily in the main window, TIN window, and profile window. After
selecting the area, it will be classified by the selected method in the classify panel.

Icon Description Hot Key

Polygon Select Shift+P

Rectangle Select Shift+R

Circle Select Shift+C

Above the Polyline Select L

Below the Polyline Select Shift+L

Lasso Select Ctrl+Shift+L

Circular Brush Select Shift+F

Detect Plane Ctrl+Shift+D

Switch Selecting Tool Shift+Q

The meanings of the parameters of circular select tool and detect plane are listed as below:

Circular Brush

Selection Radius: By setting the radius in pixel of the circular brush, control the size of selecting
area.

Detect Plane

Detect plane tool performs the plane growth algorithm by fitting a plane with the points in a selected circle
to detect the points within the same plane.

Tolerance (meter): The threshold of the distance from the point to be detected to the fitting plane in
the selected area. This threshold is aimed to control the thickness of the detected plane.
Range (pixel): The range of the points used to generate the initial fitting plane. Users should control
the range to ensure that the points are in the same plane.
Step Length: The step length of the outward extension of the plane detection.



Classification Panel
The classification method panel supports the following filtering operations: seven ground point filtering
methods, TIN Filter、Conicoid Filter、Slope Filter、Extract Median Ground Points、Air Points Filter、
Building Filter、Steep Terrain Filter. The above seven filtering methods are only available when the
memory mode is enabled.

Ground Point Filtering

The current version includes four ground point filtering methods: Tin filter  , Conicoid filter  , slope
filter  , median filter . After enabling the memory point cloud block editing state, users can click on
the corresponding icon to open the corresponding filtering method.

Noise Filtering

Noise filtering  is used to separate noise points from memory point clouds.

Building Filtering

Building Filtering is used to extract building points from memory point clouds.

Steep Terrain Filter

Steep terrain filter  is used to extract ground points in steep terrain from memory point clouds.



Profile Viewer Tool
By default, profile view shows the front view of selected rectangle area. Users can change the view mode
in the drop-down menu .

Icon Description Hot Key

Front View

Rear View

Left View

Right View

Rotate Scene R

Measuring Tools

Grid



Associated Windows

Function Overview

With the "Associated Windows" function, users can load various attribute data such as DOM and models
supported by the platform into a new window, and link it with the point cloud window in the classification
editor to assist in classification operations.

Window Settings

Associated Windows: The associated windows list contains all windows opened after opening the
classification editor. Select the window to be associated for assisted editing.



Strip Alignment
Airborne LiDAR measurement system is influenced by various error sources, of which the systematic
errors (the largest error source) cause the systematic deviation of laser footprint coordinates. Mounting of
LiDAR measurement system requires the axis of the scanning reference coordinate system and inertial
platform reference coordinate system to be parallel. However, while mounting of system, it is not
guaranteed that they are parallel, resulting in the so-called systematic boresight error. In the Strip
Alignment module, airborne LiDAR point clouds of overlapping strips can be aligned through boresight
calibration.

Boresight

Boresight Error Calculation

Trajectory Adjustment

Control Point Report

Trajectory Quality Analysis

Elevation Difference Inspection

Strip Overlap Analysis

Density Quality Analysis



Boresight

Functional Overview

Brief: In the Boresight module, airborne LiDAR point clouds of overlapping strips can be aligned through
boresight calibration. This module includes the following functions: loading/deleting/splitting trajectories,
cutting point cloud according to trajectories, matching trajectory and point cloud, transforming point cloud
based on boresight calibration parameters, eliminating point cloud redundancy (cut overlap), etc.

Usage

1. Open boresight module. Click ToolBox > Strip Alignment > Boresight or Preprocessing > Boresight,
and the corresponding toolbox and Trajectories List Widget is shown as follows.

2.  Open Trajectory Files: After clicking this button, an interface pops up to ask you to set the
workspace.

Set the workspace and a dialog for adding trajectories will be shown as follows.



LiDAR360 supports two formats of trajectory files: POS(*.pos) (text format file) and SBET(*.out)]
(binary format file).

POS File Example 1: If the POS file does not contain GridX and GridY information, the user has to
specify following headers (GPS time, longitude, latitude, height, roll angle, pitch angle and yaw angle)
for data columns. An example is shown as follows.

It is required to select the correct projection coordinate system as the following picture.



POS File Example 2: If the POS file contains GridX and GridY information, the user has to specify
following headers (GPS time, longitude, latitude, height, roll angle, pitch angle, yaw angle, GridX and
GridY) for data columns. An example is shown as follows.

If the information of GridX or GridY is not correct, the POS File Example 1 can be used.
For both of the two examples, click "Apply" to make the current settings apply on current trajectory
file, and all the trajectory files will be affected by the current settings if you click "Apply all".

The information of added trajectories will be shown in Trajectories List Widget. (Optional) Click
to set the workspace.

3.  Pick Point: Left click a certain point in the trajectory and the information of this point will be
displayed.



4. Segment Select

4.1 Auto Split Trajectory

Click the Automatic Trajectory Line Splitting  button to open the automatic splitting parameter
setting dialog box.

Set the parameters and click OK to start automatic splitting.
Parameter Settings
Maximum Heading Change: The change in heading angle of the automatically cut trajectory
segment does not exceed the set value.
Minimum Length: The minimum length of the automatically cut trajectory segment is not less than
the set value.
Minimum Duration: The duration of the automatically cut trajectory segment is not less than the set
value.

4.2 Select by Polygon

Click  Draw Polygon button.
Left click to make an user-defined polygon in the view.
Click Select by Polygon button, to select segment in the area of user-defined polygon.



4.3 Select by Bursh

Click  Select on Trajectory button.
Left click to select the starting point in the trajectory.
Along the trajectory, select the ending point, the trajectory between the starting point and the
ending point will be selected.

4.4 Select by Trajectory Graph

Click  Select on Graph button, the trajectory graph will pop up.

(Optional) Select an trajectory in trajectory combox, the selcted segment of the trajectory and the
trajectory will be shown in the graph.
(Optional) Select an attribute. Users can select different display mode, including display by
height, display by quality factory, display by roll, display by pitch, display by heading and display
by velocity.
Select both Start Time and End Time via scrollbars.
Click to add a new segment.
(Optional) Change display range. All the trajectory information at any time will be displayed in
trajectory graph as a default. Scroll up and down of mouse wheel to zoom in and out the graph,
click to restore the default display.

All the selected segment will be shown in Trajectories List Widget.

 Split Trajectories: Click this button to split the source trajectories by selected segments. New
generated trajectories will be stored as POS file format in the workspace and named by the GPS
starting and ending times of the trajectory. An example of new file name is
"GPSStartTime_GPSEndTime.POS". The effect of cutting is shown as follows.

 Cut Point Cloud Based on Trajectories.



6.1 Click the button to pop up a dialog.

Select the point cloud data files to be cut. Check the “Cut by Trajectories' Buffer”and set the
Buffer parameter as desired.

6.2 Click "OK". LiDAR360 will cut the point cloud by the trajectories and show the process speed
accordingly. The cutting results will be saved and the name of the point cloud is identical to the
corresponding POS file. A dialog pops up to ask the user whether to load the results or not.

 Match Point Cloud and Trajectory: Click this button, the point cloud data and the corresponding
trajectory will be displayed in the same color.

 Calibration: Click this button to pop up a dalog.



8.1 This function is applied to correct the Boresight Error, which can be calculated automatically
(Automatic Alignment) or input manually (Manual Alignment).

Automatic Alignment:
Select the boresight error you want to correct, and set the Translation TOL and Rotation TOL.
Click "Calculate" to generate the boresight error automatically and the result will be shown in the
"Boresight Correction" part of the interface. Click "Clear Matching" to delete the matching
information. After modifying relevant parameters, users can calculate the alignment parameters
again. After the calculation of automatic alignment, LiDAR360 will figure out the Alignment
Quality. The Alignment Quality will be shown in the "Alignment Quality" tab page. Click "Export"
button to save the alignment quality information, and Click "Generate Report" button to generate
the automatic alignment quality report. (Theory of correction based on automatic adjustment.)

Manual Alignment:



Adjust the boresight error manually. (Theory of correction based on manual measurement.)

Click "Apply" and the transformation of error correction will be applied on the selected Transform
Type.

8.2 For both automatic and manual method, correction result can be checked in the profile
window.

Before transformation

After transformation
8.3 Buttons on the right of the "Boresight correction" provide the following operations: "loading
from file", "saving to a file" and "cleaning".

8.4 If the alignment effect is satisfied, you can switch Transform Type from the "Loaded Point
Cloud" to "Selected Point Cloud Files". Click "Apply" to finish the transformation.



 Cut Overlap: Click this button to set the Cut Overlap Parameters. Click "OK" button, then the
redundant points between the overlapped trajectories will be classified or deleted.

Show Single Trajectory

Select a trajectory in the Trajectories List Widget, right click to pop up the Context Menu.
Click the Show Single Trajectory button, the color of the selected trajectory will be changed
gradually, and then the trajecotry will twinkle several times.

Delete Trajectories or Segments.



Select the trajectories or segments in the Trajectories List Widget, right click to pop up the
Context Menu.
Click the Delete button and the selected trajectories and segments will be removed.

Show/Hide Trajectory or Segment Check/Uncheck the checkbox of the trajectory or segment in the
Trajectories List Widget will Show/Hide the trajctory or segment.

Trajectory Display the software supports muti-display modes: 13.1 Display by Time(Default)

Click button, the trajectory will be displayed in different color according to acquisition time,
users can select the color bar in a pop-up window.

13.2 Display by Height

Click button, the trajectory will be displayed in different color according to height information,
users can select the color bar in a pop-up window.

13.3 Display by Quality

Click button, the trajectory will be displayed in different color according to quality information,
users can select the color bar in a pop-up window.

13.4 Display by Specific Color

Click button, the trajectory will be displayed in specific color according to user-defined color,
users can select the color in a pop-up window.

13.5 Show selected segments

Check button, the unsegmented area will be hide, and only selected segment part will display.

Parameters Settings

Parameters of Cutting point cloud based on Trajectories
Buffer: The remaining distance in both sides of trajectory while cutting.

Parameters of Transform
Boresight Error

ΔX/ΔY/ΔZ: Correction parameters of boresight offset error.
ΔRoll/ΔPitch/ΔHeading: Correction parameters of boresight pose error.

Automatic Alignment: It matches corresponding points between strips automatically and
calculates optimal correction value of boresight error via adjustment.

Translation TOL: The maximum translation tolerance of ΔX, ΔY, ΔZ. The default value is
0.05 m.
Rotation TOL: The maximum rotation tolerance of ΔRoll, ΔPitch, ΔHeading. The default
value is 5°.
Options: Users can decide whether the 3 translations and 3 rotations are involved in
adjustment to calculate correction values. For most aerial data, it is not recommended to
correct ΔZ. In default state, all the rotations are selected while all the translations are
unselected.

Alignment Quality: After automatic alignment calculation, LiDAR360 will figure out the alignment
quality and show the result in the alignment quality result tab.

Min Error: Minimum error of matched corresponding points.
Max Error: Maximum error of matched corresponding points.
RMSE: RSE error of matched corresponding points.



Transform Type:
Loaded Point Cloud: The loaded point cloud which is matched with trajectory in LiDAR360.
When the transformation is applied, the corresponding point cloud is modified and the
transformation effect can be shown in real-time. When boresight module exits, relevant
transformation is eliminated without saving.
Selected Point Cloud Files: In this type, the file list area on the interface will be activated,
users can choose which point cloud file(s) will participate in the transformation. Then the
results will be saved to the file. It doesn't loss the information even though the boresight
module exits.

Parameters of Cut Overlap:
Type:

Classify: Classify points into target category and save the result in the original point cloud
file.
Delete: Classify points into target category and then delete them from initial point cloud data
(Note: If the input point cloud contains points of target category, they will also be removed).

From Class: Point cloud target category.
Edge: Grid unit size (length) of overlapping area. This parameter is used to rasterize the point
cloud data of the overlapped area.
Density: Smallest point density of grid unit. If the point density is smaller than the defined
threshold, these points will not be classified to redundant points.
By Angle with Trajectory: Angle between point cloud and trajectory. If this angle is larger than
the threshold, the point cloud will be classified to redundant points.
By Scan Angle: If scanning angle is larger than the threshold, point cloud will be classified to
redundant points. (Note: this function can only be used when scanning angle is recorded by point
cloud.)

Note:
1. The matching principle of a point cloud file and a trajectory is that: Each GPS time of all the points
in the point cloud is inside the trajectory's GPS time span.
2. In most cases, the effect from X,Y or Z is tiny, while the ground control points are needed for
higher precision of Z value. Therefore, only Roll, Pitch and Heading are selected to take apart in the
adjusting by default.
3. The result may not satisfy if accuracy of the POS data file is not enough, and users can make an
manual alignment based on the result.
4. For Overlapped function, at least two pairs of matched point cloud and trajectories are needed.



Boresight Error Calculation
The boresight error between laser scanner coordinate system and GNSS/INS coordinate system is
the largest systematic error source of airborne LiDAR. The laser footprint error caused by the boresight
error also depends on flight height and scanning angle.

LiDAR360 provides two approaches to eliminate the boresight error:

1. Correction based on manual measurement
2. Correction based on automatic adjustment

The principles of them are described as follows.

Manual Correction

Firstly, datasets for calibration need to be acquired during perpendicular and round flights (e.g., 4 flights:
from east to west, from west to east, from north to south, from south to north). After data acquisition the
boresight angle errors can be retrieved using the Stepwise Geometric Method(Zhang et al., 2010), which
is based on measurements of overlapping laser footprints of regular objects (e.g., playground, building).
Compared to angle errors, the translation errors are of less importance and hence omitted in the manual
correction.

ΔRoll

Error of Roll angle leads to an oblique result of horizontal ground, which is shown in the following figure.
The planar position of scanned object is shifted along scanline (perpendicular to flight direction).

Please measure the following parameters in the data acquired during round flights of same height.

Start a Profile Window perpendicular to the flight direction. Then measure the height difference ∆ℎ of
quasi-homologous objects in two strips.
Measure the horizontal distance r between the object and centerline of two strips in 2D-View Window.

The formula to calculate the Roll angle error is as follows:

ΔPitch



The position of scanned object is shifted along scanline due to Pitch angle error. The following figure
shows the affected laser footprints.

Please measure the following parameters in the data acquired during round flights.

Start a Profile Window along the flight direction. Then measure the distance D between centers of
homologous objects along the flight direction.
Estimate the average flight height H based on trajectory and object heights. The heights of round
flights should be roughly equal.

The formula to calculate the Pitch angle error is as follows:

ΔHeading

Error of Heading angle leads to object shifting and distortion. The following figure shows the erroneous
result.

Please display data acquired during round flights in 2D-View Window.

Measure the average distance S between centers of homologous objects in two strips.
Measure the distance D between two strips.



The formula to calculate the Heading angle error is as follows:

Automatic Correction

While the manual correction relies on well-trained operators, the automatic correction can reduce manual
work significantly. Based on datasets with regular objects, the automatic process can replace manual
correction and achieve equivalent or even better accuracy.

The algorithm is capable of correcting not only the angle errors, but also the translation errors. Users have
the flexibility to check/uncheck every correction parameter. By default, the software only calculates the
angle errors, because they have the largest weights. The principle of the algorithm is as follows:

1. Extract feature points and their normals in overlapping strips. Please refer to (Glira et al., 2015).
2. Match the feature points to get corresponding pairs.
3. Construct the correction model and calculate the distances of paired points along their normal.
4. Minimize the corresponding distances using least-square method, and get the correction parameters.

    @inproceedings{
        author={Zhang Xiaohong, Forsberg Rene},
        title={Retrieval of Airborne Lidar Misalignments Based on the Stepwise Geometric Method},
        booktitle={Survey Review 42(316):176-192 April 2010},
        year={2010},
    }

    @inproceedings{
        author={Philipp Glira, Norbert Pfeifer, Christan Briese and Camillo Ressl},
        title={A Correspondence Framework for ALS Strip Adjustments based on Variants of the ICP Algorithm},
        booktitle={PFG Photogrammetrie, Fernerkundung, Geoinformation Jahrgang 2015 Heft 4},
        year={2015},
    }



Trajectory Adjustment

Functional Overview

If point clouds discrepancies are still obvious after Boresight, it may be caused by trajectory errors. With
this tool, trajectories and related point clouds can be post-processed and refined.

The Trajectory Adjustment algorithm used in LiDAR360 is based on the literature reference (Glira et al.,
2016). The basic algorithmic process is as follows:

1. Extract feature points and their normal vectors in the overlapping regions of adjacent flight strips.
2. Match the extracted feature points from adjacent flight strips to obtain matching point pairs.
3. Construct a trajectory error correction model and calculate the distances along the normal vectors

of the relevant point pairs.
4. Use the least squares method to minimize the distance between matching point pairs and obtain an

optimal solution for the trajectory correction.

ClickPreprocessing>Trajectory Adjustmentbutton， the interface will pop up. This function estimates
fluctuating errors of trajectory, then updates point clouds based on correction values.。

Interface

Single Flight Trajectory Adjustment



In the Trajectory Adjustment interface of LiDAR360, the unit measurement is based on flight. Each flight
requires three types of data: trajectory data, point cloud data, and control point data (optional). Taking the
single flight trajectory adjustment as an example, the interface supports you to manually create flight units.
The specific process is as follows:

Click button，manually create a new flight, fill in the name (which cannot be the same as an
existing mission), select the flight, add the corresponding trajectory data and point cloud data. Once
this is done, the flight is created.

Create a flight
In addition, data can also be imported through LiGeo projects. Click button and select the LiGeo project
file for which you want to perform adjustment calculations. The software will automatically parse and
obtain trajectory and point cloud data, but please ensure that the data actually exists, otherwise the LiGeo
project cannot be imported normally.。



Import LiGeo Project
After creating the flight and adding corresponded trajectory and point cloud data, select the trajectory
component that needs to be corrected and set the time interval of trajectory fluctuation nodes. If you have
control point data, you can select the control point option to add the corresponding control point file (in
XML format). If this is the first time adding the file (in TXT format), you need to click the control point
button to add corresponding matching points for each control point manually.

To manually add point pairs, click the control point button to pop up the GCP List interface. The upper part
displays the control point list, while the lower part displays the matching point list for each control point.

GCP List



Each point pair can correspond to multiple matching points, but the matching points in a point pair must
come from different point cloud objects. The specific operation process is described below:

1.Click button，a file dialog box window pops up. Select the control point file (in txt format, containing X,
Y, and Z field information. Please see the attachment for details).

Contorl Points

Display Contorl Points
2.Select one of the control point options, activate mouse operation, and double-click the option to jump to
the vicinity of the control point. Then, add corresponding matching points based on the point cloud
situation, as shown in the figure.



Contorl Point 1

Contorl Point2
1. Click button，save the added results in XML format and click OK to finish.。



Add GCP File
In addition, in order to provide users with more convenient use of the control point function, this
manual provides an overview of its additional operations：

1.View Control Points: If a control point file (XML file) has been added, the control point button can be
clicked to view the position of each control point and its corresponding matched points in the control point
file (XML file).

2.Manually delete and add control points. In the control point dialog, select a control point option and right-
click the mouse to perform control point deletion or addition.

3.Setting Control Point Type. This algorithm mainly categorizes control points into two types: control points
and check points. The former will participate in the strip adjustment correction process, while the latter
only serves a verification purpose, mainly used to measure the absolute accuracy of the adjustment
results. In the dialog box, the control point type can be set by using the Usage field.

After adding all the data, click "OK" and the software will automatically perform strip adjustment and
correction of the point cloud data.

After the completion of the correction, LiDAR360 software will automatically perform quality assessment
and generate an HTML accuracy report. The report will be saved in working directory/report. Click on
report.html to open the generated accuracy report

Users can use the profile tool to view the corrected results, as shown in the figure.



Before Correction

After Correction

Parameters Settings

Adjust
ΔX/ΔY/ΔZ：Position component of trajectory correction.
ΔRoll/ΔPitch/ΔHeading：The angular component of trajectory correction.

Spline Time Interval：The trajectory fluctuates based on the set time interval, with higher
frequencies for shorter intervals. If the trajectory error has significant local shaking, a shorter interval
can be set, otherwise a longer interval should be used. The default value is effective for most data.
Output Path：The storage path of the output files after the LiDAR360 function runs. The output files
include: corrected point cloud, corrected flight trajectory, and quality statistics HTML report.

Note：In principle, the input for this function requires the entire flight line file used for collecting
point cloud data. However, if there is no complete flight line file available, multiple POS files that
have been clipped to the flight line can also be used. It is crucial that the GPS time of the point



cloud data matches that of the flight line to ensure that after correction, there will be no layering
effect in local areas.

Multiple flights Trajectory Adjustment

Multiple flights Trajectory Adjustment is a repeated operation of single flight line leveling, which means
adding multiple flights that need to be leveled repeatedly to the interface, checking the trajectory
components that need to be corrected, setting the time interval for the trajectory fluctuations, clicking OK,
and the software will automatically carry out multiple flights and correct the point cloud data.

Trajectory Adjustment
Use the Profile Tool to view and adjust correction results, as shown in the figure.



Before Correction

After Correction
Note：For each flight, its corresponding trajectory and point cloud data must be added, otherwise
adjustment calculation cannot be performed.

Mirror Angle Correction

Mirror angle error refers to the scanning angle error of LiDAR scanner, which is caused by insufficient
precision of scanner components or complex scanning structures, and is more likely to occur in lightweight
and low-cost scanners like the Risley Prism-Based Livox Mid-40. This error may cause point cloud
deformation, and the longer the ranging distance, the more obvious the point cloud deformation will be. It
has a greater impact on the accuracy of the point cloud position, resulting in point cloud gap in the cross-
sectional point cloud along the scanning direction. Correcting the mirror angle error can improve the
accuracy of point cloud on the edge of flight strips.



Mirror Angle
The coordinates of the laser points in the scanner coordinate system are denoted as $X = \begin{bmatrix}
x{s} & y{s} & z{s} \end{bmatrix}^T$, where the azimuth angle of the outgoing light beam is denoted as
$\Omega$ and the elevation angle is denoted as $\Phi$. Specifically, $\Omega$ can be obtained from
$arctan(y{s}/x{s})$, while $\Phi$ can be obtained from $arccos(z{s}/||X||{2})$. Since the change in
scanning angle mainly affects the azimuth angle, the elevation angle is less affected, and therefore the
scanning angle error is mainly reflected in the azimuth angle error. To correct for the scanning angle error,
the azimuth angle is divided into $N$ groups at regular intervals of $1\degree$, with the correction
quantity for the $i$th group denoted as $\Delta{i}$. The corrected coordinates of the laser points in the
scanner coordinate system after the azimuth angle correction can be expressed as:

$\hat{X} =$ $||X||_{2} \begin{bmatrix} sin(\Omega+\Delta_i)cos\Phi & sin(\Omega+\Delta_i)sin\Phi &
cos(\Omega+\Delta_i) \end{bmatrix}^T$

The mirror angle error correction is an optional function of the LiDAR360 software for strip adjustment.
The correction can be applied to all angles or only to specified angles outside a certain range.

Please check the Mirror Angle Correction option and select "DJI L1" or "LiAir series" based on the type of
laser scanning system being used. If you need to correct all angles, select "All angles". You can also set
the range of angles to skip. Mirror Angle Correction is performed per flight mission and not per laser
scanning system. For multi-mission flight strip adjustment, if you select the Mirror Angle Correction option,
it will be performed for each mission.

Before Correction

After Correction
If you select mirror angle correction, a histogram of the correction will be generated in the strip adjustment
report report.html."



Correction Result

The histogram is the result of smoothing the correction values three times.



Hybrid Adjustment

Functional Overview

The hybrid adjustment function of image and navigation data can perform joint adjustment by combining
the imported aerial triangulation results while conducting strip adjustment of point cloud, reducing errors
between point clouds and aerial triangulation results.

Usage

The operations of inputting flight data, trajectory, point cloud and setting parameters (adjustment, time
interval, mirror error), control points, etc. for joint image strip adjustment are the same as those for single-
strip adjustment in Trajectory Adjustment function. You can refer to that function for settings.

Note: Joint image strip adjustment only supports a single strip participating in the adjustment and
does not support setting multiple strips.

Joint image strip adjustment supports selecting categories of point clouds involved in the adjustment by
default with all options checked.

In the Image Project column, select the image project (*.LiAep) that needs to participate in the adjustment.

Note: Only image projects containing connection point information can perform joint adjustments.

The output path is where result files will be stored after running this function. The result files include
corrected point clouds, corrected flight trajectories, corrected aerial triangulation results and statistical
quality HTML reports.



After adding all data, click "Confirm" button and software will automatically perform strip adjustments and
correct point cloud data.

Once correction is completed, software will generate an HTML accuracy report which you can open by
clicking on it.



Control Point Report

Summary

Control point report tool will create a report about elevation difference of laser point clouds and ground
control points, which can be used to check the elevation accuracy of laser point clouds and improve the
height accuracy of laser point clouds using calculated adjusted values.

Control point file is the text file separated by comma. Every row is composed by 3 columns which are X, Y
and Z. The first row is the header, and please refer to Control Point File Format for specified format. At
least 3 control points are requested to successfully create the control point report.

The output report displays information of elevation difference between used laser point clouds and control
points of elevation, statistic information of height difference like average magnitude, standard deviation,
root mean square, average of elevation difference as well as maximum and minimum height difference.

Usage

Click Strip Alignment > Control Point Report.

After computation, the position of every control point can be checked by left double click at any position on
the control point row in order to jump to the location of control point. Using Profile tool can help to check
the relative position between control points and point cloud more intuitively.



After the calculation, users can choose the control points, or change the maximum slope and maximum
triangle edge length, and then click "Calculate" to re-calculate.

Settings

Input Data: Input file can be single point cloud data file or point cloud data set.
From Class (default value is "all class"): User needs to select the point cloud class which is used
to check control point elevation accuracy, and normally point cloud of hard surface such as ground
point, construction point, etc. are chosen.
Z tolerance (default value is "0.15"): The accuracy of the point cloud in the Z-axis direction. To
avoid the distance between the points is too small leads to the excessive slope.
Max Slope (°, default value is "45"): Maximum terrestrial gradient tolerance. If gradient is larger
than this value, elevation difference will not be computed. Normally control points are chosen at the
flat terrain, therefore if gradient is too steep, the result will be easily affected by wrong information.
Max Triangle (m，default value is "20"): The longest side length of triangle is used to avoiding the
large deviation caused by elevation interpolation. If the side length of triangle is too long, it is
indicated that points of initial category in point cloud area where control points are located are less
and calculated error of elevation difference is large.
Known Points: Input control point file.
Point Size (default value is "0.10"): The location of control points can be displayed in the window by
double clicking the corresponding data in the list of control point report. The size of point controls the
size of control points shown in the window.
Dz limit (default value is "3"): Set the tolerance of Dz. If Dz is not within the tolerance, show red in
order to inspect elevation difference with large error between point cloud and control points. Maximum
tolerance = Average Dz + Dz × Std Deviation. Minimum tolerance = Average Dz - Dz × Std Deviation.
Export Delimiter：Set the exported control point report delimiter, including semicolon, comma, etc.
Calculate: After setting parameters, click this button to calculate elevation difference.
Export: Export the control point report file in txt format. The relevant information of the control point
calculation is separated by the set delimiter. The export file contains the elevation error information of
the point cloud data and the statistical information of Dz.



Trajectory Quality Analysis

Summary

Trajectory Quality Analysis tool checks trajectory quality from the height analysis, speed analysis and
flight attitude analysis.

Usage

Click Strip Alignment > Trajectory Quality Analysis.

Load trajectory file(s) and set the parameters of height analysis, speed analysis and fight attitude analysis.
This tool supports generating reports for each analysis. Click Export to save the quality report in html
format.

Click  to load data. The supported formats of POS files contain *.OUT and *.pos. Click  to clear
loaded data.

Settings

Height Analysis: Height analysis report contains strip name, max height, min height, height
difference, height variance, mean height and qualified flag of each strip. The Yes is qualified, and No
is unqualified. The mean height of qualified strip is displayed as green, or as red. Click Export button
to save the result in html format.
Design Height (m, default value is "0"): Designed height value.
Height Tolerance (%, default value is "0"): The floating ratio of designed height. For example, 5%
denotes that the qualified height range is between (1- 5%) × designed height and (1 + 5%) ×



designed height.
Generate Report: Click Generate Report button to save height analysis quality report.

Speed Analysis: The speed analysis report contains strip name, max speed, min speed, speed
difference, speed variance, mean speed and qualified flag of each strip. The mean speed of qualified
strip is displayed as green, or as red. Click Export button to save the result in HTML format.
Design Speed (m/s, default value is "0"): Designed speed value.
Speed Consistency (%, default value is "0"): The floating ratio of designed speed. For example,
5% denotes that the qualified speed range is between (1- 5%) × designed speed and (1 + 5%) ×
designed speed.
Generate Report: Click Generate Report button to save speed analysis quality report.

Flight Attitude Analysis: Flight attitude analysis report contains strip name, max roll, mean roll, max
pitch, mean pitch, strip deformation (%) and qualified flag of each strip. The Yes is qualified, and No is
unqualified. The strip deformation of qualified strip is displayed as green, or as red. Click Export
button to save the result in html format.
Strip Deformation (%, default value is "3"): According to the related data standard, the qualified
threshold of strip deformation is generally set to 3%.
Generate Report: Click Generate Report button to save flight attitude analysis quality report.

Integral Report: Click Full Report button to save the integral report.



Elevation Difference Inspection

Summary

Elevation Difference Inspection tool analyzes the elevation difference between point clouds.

Usage

Click Strip Alignment > Elevation Difference Inspection

Settings

Input Data: Input files can be single point cloud file or point cloud dataset. The data to be processed
must be opened in the LiDAR360.
From Class: The point cloud classes used in the elevation difference quality inspection.
Grid Size (m, default value is "2"): The grid size in the point cloud gridding.
Cut off Value (m, default value is "0.5"): The data will be ignored if the height difference is greater
than this threshold. Considering the moving vehicles in the scanning area which can be scanned at
different time, it is necessary to set the cut off value for height difference.
Output Path: The results of elevation difference quality inspection will be exported to the selected
folder, which contains the result of each strip density quality inspection and integral report in HTML
format.



Strip Overlap Analysis

Summary

Strip Overlap Analysis tool analyzes the overlap between point clouds.

Usage

Click Strip Alignment > Strip Overlap Analysis

Settings

Input Data: The input files should be 2 or more point cloud files. The data to be processed must be
pre-opened in LiDAR360.
Input POS File: Click  to load the data. The supported formats of POS files include *.OUT and
*.pos. Click  to clear the loaded data. Click  to clear the loaded POS file(s).
Overlap Threshold (%, default value is "25"): Set the threshold to define the overlap region
between two adjacent strips.
Output Path: The results of overlap quality inspection will be exported to the selected folder, which
contains the results of each strip overlap quality inspection in SHP format and a comprehensive
report in html format.



Density Quality Analysis

Summary

Density Quality Analysis tool analyzes the density of point cloud.

Usage

Click Strip Alignment > Density Quality Analysis

Settings

Input Data: Input file can be single point cloud file or point cloud dataset. The data to be processed
must be opened in the LiDAR360.
Density Threshold: The point density between the adjacent thresholds is shown in the
corresponding color.
Grid Size (m, default value is "1"): The grid size in the point cloud gridding.
Output path: Select the output path of density inspection quality report. The folder contains the
results of each strip density quality inspection and integral report in html format.



Data Management
The data management module includes basic processing tools for point clouds and images, mainly
including pre-processing of point clouds, mutual conversion between point cloud and image formats,
projection tools, etc.

Point Cloud Tools

Remove Outlier

Noise Filter

Normalization

Normalization by GroundClass

Denormalization

Merge

Extract Boundary

Subsampling

PCV

Extract Color from Image

Subdivision

Transform GPSTime

Smooth Points

Segment by Attribute

Vegetation Index

Raster Tools

Raster Mosaic

Raster Subdivision

Raster Calculator

Tile

Tile by Range

Tile by Point Number

Tile by Line

Tile by Polygon

Projections and Transformations



Define Projection

ReProjection

Transformation

Convert Projected Surface

Elevation Adjustment

Transformations Calculation

ICP Regression

Convert ASCII to BLH

Rectify

Manual Rotation and Translation

Geoid Model

Create Transformations

Elevation Fitting

Clip

Clip by Circle

Clip by Rectangle

Clip by Polygon

PointCloud Conversion

Convert to ASCII

Convert to TIFF

Convert to Shape

Convert to DXF

Convert to LAS

Convert to E57

Convert to PLY

Convert LiData to LiData

Convert LAS to LiData

Raster Conversion

TIFF to LiModel

Convert to Texture LiModel

TIFF to LiData



TIFF to ASCII

Model Conversion

LiModel to TIFF

LiTin to DXF

LiBIM to OBJ

LiBIM to FBX

LiBIM to CityJson

Vector Conversion

Shape to KML

KML to Shape

Extract

Extract by Class

Extract by Elevation

Extract by Intensity

Extract by Return

Extract by Time

Extract by Additional Attributes

Extract by Group

Model Tools

LiBIM Merge
Vector Tools

Smooth Line



Point Cloud Tools Index
Point Cloud Tools include the following point cloud processing functions.

Remove Outliers

Noise Filter

Normalize by DEM

Normalize by Ground Points

Denormalization

Merge

Extract Point Cloud Boundary

Resampling

PCV

Extract Color from Image

Subdivision

Transform GPS Time

Smooth Points

Segment by Attribute

Vegetation index



Remove Outliers

Summary

Common noises include high level gross errors and low level gross errors. As shown below, high level
gross error is usually caused by the returns of high-flying objects (such as birds or aircraft) during the
process of data collection; low-level gross error are returns with extremely low attitudes caused by the
multipath effect of a laser pulse. The Outlier Removal tool aims to remove these errors as much as
possible and therefore improve the data quality.

The algorithm will first search for each point's neighboring points within a user-defined area and calculate
the average distance from the point to its neighboring points. Then, the mean and standard deviation of
these average distances for all points are calculated. If the average distance of a point to its neighbors is
larger than maximum distance (maximum distance = mean + n * standard deviation, where n is a user-
defined multiple number), it will be considered as an outlier and be removed from the original point cloud.

Effect picture:

Usage

Click Data Management > Point Cloud Tools > Remove Outliers



Settings

Input Data: The input file can be a single point cloud data file or multiple data files. File Format:
*.LiData.
Neighbor Points (default value is "10"): The number of points required in the neighborhood to
calculate the average distance of each point. If there are not enough points found, the algorithm will
not be executed.
Multiples of std deviation (default value is "5"): The factor multiplied by the standard deviation to
calculate the maximum distance.
Output path: Path of the output file. After the function being executed, a new file will be generated.
When more than one files are entered, the path needs to be set to a folder.
Parallel Set: Whether to use the multi-core CPU parallel computing mechanism for remove outliers.

Note: The algorithm of this function can be performed repeatedly to improve the denoising results.
The outlier removal results is limited if the noises are to dense.



Noise Filter

Summary

Remove the outliers from the point cloud data. Different from the remove outliers function, this function
has a better processing performance (filters more outliers) on objects with a flat surface (such as walls,
interior tunnel walls, and the ground).

Usage

Click Data Management > Point Cloud Tools > Noise Filter.

Settings

Input Data: The input data can be a single point cloud file, or can be a point cloud data collection;
these data to be processed must be pre-opened in LiDAR360 software.
Radius(Default value is “0.5m”): Set the radius of the fitting plane. This function can be used when
users know the approximate density of the point cloud data.
Recommended Radius: Automatically calculate the appropriate searching radius according to the
input point cloud data.
Multiples of std deviation(Default value is “1.0”): Using the relative error (sigma) as a parameter
for outliers removal. The algorithm will automatically calculate the standard deviation (stddev) of a
point P's surrounding fitting plane. If the distance, d, from this point to that plane is less than sigma *
stddev, this point, P, will be kept. The reduction of this relative error results in removing more points.
Conversely, more points will be retained. The change of this parameter will not ifnluence the
efficiency.
Remove Isolated Points: The point will be treated as an isolated point when there is less than 4
points within the distance of the searching radius (cannot create a fitting plane with less than 4
points).
Output Path: The point cloud data will be save at this path after the outliers are removed.



Normalize by DEM

Summary

The normalization tool can remove the influence of terrain relief on the elevation value of the point cloud
data. This function requires that the extent of the DEM overlaps with the extent of the point cloud data.
The normalization process is performed by subtracting the corresponding terrain elevation of the DEM
from each point's Z value. The output of this function is similar to Normalize by Ground Class.

Usage

Click Data Management > Point Cloud Tools > Normalize by DEM

Settings



Input Data: The input file can be a single point cloud data file or multiple data files. File Format:
*.LiData.
Input DEM File: Users can select single or multiple single-band TIFF image files from the drop-down
list. File format: *.tif.

: Users can add external DEM file data.
: Users can select a file in the list and click this button to remove the file from the list.
: Click this button to clear all the data in the list.

Add Z Value to Additional Attributes: Add the Z value of the current point cloud to the additional
attribute table. If this option is not checked, then the normalized point cloud cannot be denormalized.
Output Path: Path of the output file. After the algorithm being executed, the new normalized file will
be generated. When entering more than one file, the path will need to be set as a folder.



Normalize by Ground Points

Functional Overview

The normalization tool can remove the effects of topographic relief on the elevation value of point cloud
data. This function requires that the input data has already been classified into ground points and non-
ground points. The normalization process is performed by subtracting the terrain elevation (represented by
the elevation of the closet ground point to each point) from each point's Z value. The output of this function
is similar to Normalize by DEM.

Usage

Click Data Management > Point Cloud Tools > Normalize by Ground Points

Parameters Settings

Input Data: The input file can be a single point cloud data file or multiple data files. File Format:
*.LiData.
Search Mode: 2D method is suitable for most terrains, while 3D method is suitable for cliff terrain and
can solve the problem of incorrect vegetation height after normalization. However, steep slopes or
other terrains are recommended to use 2D search.
Add Z Value to Additional Attributes: Add the Z value of the current point cloud to the additional
attribute table. If this option is not checked, then the normalized point cloud cannot be denormalized.
Output path: Path of the output file. After the function being executed, the normalized new file will be
generated. When entering more than one file, the path needs to be set as a folder.



Denormalize

Summary

Denormalization tool can reset the Z value of the normalized data. Users need to check the option "Add
Original Z Value to Additional Attributes" when performing Normalize by Ground Points or Normalize by
DEM. After denormalization, the Z value will be reset as the original Z value stored in the additional
attributes.

Usage

Click Data Management > Point Cloud Tools > Denormalize

Settings

Input Data: The input data could be one or more point cloud files. The input data should be in
*.LiData format.
Output Path: The path of the output data after denormalization. When number of input data sets is
more than one, the output path should be a folder.



Merge

Summary

Merge multiple point cloud files into a single point cloud file. This function is the reverse operation of Tile
by Range and Tile by Point Number.

Usage

Click Data Management > Point Cloud Tools > Merge

Settings

Ignore Different Additional Attributes: When the input data sets are more than one, if this option is
checked, then only the same additional attributes will be merged. If there are any different additional
attributes and this option is unchecked, the mergence cannot be done.
Input Data: The input file can be a single point cloud data file or multiple data files. File Format:
*.LiData.
Output path: Path of the output folder. After the algorithm being executed, a new file will be
generated.



Extract Point Cloud Boundary

Functional Overview

Use a regular hexagon to extract the boundary of a point cloud data. At present, three types of boundaries
are supported, namely hexagonal boundary, convex hull and concave hull. The ultimate output file is the
final border vector file.

Usage

Click Data Management > Point Cloud Tools > Extract Point Cloud Boundary

Parameters Settings

Input point cloud data: Input one or more point cloud data files. File format: *.LiData.
Extraction Methods: Choose the method to extract the boundary. Currently supports three methods,
hexagon, convex hull, and concave hull.

Hexagon: Use regular hexagons to extract the boundaries of the point cloud data. Based on the
hexagon height to determine the size of the hexagon. According to the bounding box of point
cloud data, draw each hexagon. If the number of point clouds in the hexagon is greater than or
equal to the set minimum number of points, draw the hexagon, merge the connected regular
hexagon, and output the final boundary vector file.

Hexagon Height (m) (default value is "10"): The height of the hexagon, which is used to
set the size of a hexagon.
Minimum Number of Points (default value is "1"): The threshold of points in a hexagon
below which no boundaries are drawn.

Convex Hull (default): Extract the convex hull of the point cloud in the X-Y plane (the z-value is
ignored). The output file is the vector file (polygon) of the convex hull of the original point cloud.
Concave Hull: Extract the concave hull of the point cloud in the X-Y plane (the Z-value is
ignored). The output file is the vector file (polygon) of the concave hull of the original point cloud.

Maximum Side Length (m) (default value is "2"): Each edge of concave hull has the
maximum distance (Len) in the xy plane. As this value becomes larger, more long edges will
be preserved and the resulting boundary will become more similar to the convex hull. On the
contrary, more boundary details will be retained by the short edges, and the computational



efficiency will be reduced. At this time, the program will automatically estimate the average
distance between all the points, and set the parameter as twice of the average distance.

Output to:
Single file (default): When checked, the boundary vector files generated by each LiData file will
be merged into the same vector file.
Multi-file: Each LiData file will generate its own boundary file.

Output Path: The path of the output file as a new vector file generated after the execution of the
function.



Subsampling

Summary

Subsampling point clouds, namely, reducing the number of point clouds, LiDAR360 offers three methods
for resampling: minimum point spacing, sampling rate, and octree.

Usage

Click Data Management > Point Cloud Tools > Subsampling

Settings

Input Data: The input file can be a single point cloud data file or multiple data files. File Format:
*.LiData.
Sampling Type: This parameter defines the resampling method.

Minimum Points Spacing (default, default value is "0.0000"): Users need to set a minimum
point spacing between two points so that the minimum three-dimensional distance between any
two points in the sampled point cloud will not be less than this value. The larger the value is set,
the fewer points will be kept.
Sampling Rate (default value is "99.99%"): Users need to set the percentage of reserved
points. In this mode, LiDAR360 will randomly retain the specified number of points. Reserved
Points = Total Number of Points * Sample Rate. The value of this parameter ranges from 0 to
100%. The smaller the value is set, the fewer points will be kept.
Octree (default value is "21"): This method allows users to select an "octree" subdivision level
and build 3D voxels for the input point cloud. Only the point closest to each voxel center will be
retained. The "octree" subdivision level ranges from 1 to 21. The smaller the value is set, the
fewer points will be kept.

Output path: Path of the output file. New file will be generated after the function being executed.



PCV

Summary

PCV tool can be used to improve visualization effect of a point cloud. The principle of the PCV (Portion of
Visible Sky) algorithm is to evenly distribute multiple light sources at the top of the hemisphere or sphere
calculate, and then calculate the cumulative number of times when the light can be irradiated by
illuminating each point in a point cloud. The last statistical result will be used as the intensity of the point
cloud. The rendering effect of the point cloud intensity after PCV calculation is shown in the figure below.

Usage

Click Data Management > Point Cloud Tools > PCV

Select the point cloud data that needs to be processed by PCV.

After the PCV process, the intensity range of a point cloud will be 0-255. By clicking on display by
intensity or clicking display by the mixed mode, users can see the boundary between different land
covers more clearly in the point cloud after PCV process. The figure below shows an example of
intensity and height blend displaying effect after PCV calculation.





Extract Color from Image

Summary

Extract Color from Image tool can extract RGB information from multi-band imagery and assigned them to
each point in a point cloud. The user is required to enter one or more multi-band images that overlapping
with the extend of the point cloud data.

After the process is completed, the display mode of the point cloud data will automatically change to RGB
display (you can also click  on the toolbar button, to display the point cloud in RGB).

Usage

Click Data Management > Point Cloud Tools > Extract Color from Image

Settings

Input Data: The input file can be a single point cloud data file or multiple data files. File Format:
*.LiData.
Category: Select whether to map through Ortho Image or Image Project. >
Overwrite Color: Determine whether to overwrite points that already have color attribute values.
Input File:

If you choose multi-band Ortho image, you will need to input multi-band imagery data that shares
the same geographical location as the point cloud. If the image data is already open in the
software, click the drop-down button to select the data, or you can click  to import external
image data. To remove selected data, click , and to clear the list of image data, click . After
processing, the point cloud data will automatically be displayed in RGB (you can also click the
toolbar icon  to display the point cloud in RGB). File format: *.tif.
If you choose image projects, you need to select the desired image project file (*.liaep) from the
drop-down menu. You can refer to the Import Data page for importing image projects, specifically
the section on adding aerial triangulation results data.



Subdivision

Summary

Subdivision tool can divide a point cloud to a series of frames based on the user defined scales. Currently,
for rectangle-division, LiDAR360 supports four subdivision scales: a scale of 1:5000 (taken to 1 km),
1:2000 (taken to 0.1 km), 1:1000 (taken to 0.1 km), and 1:500 (taken to 0.01km). The frame ID will be
named by the coordinate number, which is composed of the southwest corner of the frame (Y coordinate
+ X coordinate). After the operation is completed, one or multiple LiData file will be generated. A vector file
in shp format will also be generated recording each subdivided frame.

Usage

Click Data Management > Point Cloud Tools > Subdivision

Settings

Input LiData File: Input the point cloud data to be subdivided. If the point cloud data is already open
in the software, click the drop-down button to select the data; or you can click  to open external
point cloud data. Click  to remove the selected data. Click  to clear the data list. File format:
*.LiData.
Subdivision by Rectangle: Use "Subdivision by Rectangle". Scale is 1:500 by default.
Subdivision by Latitude and Longitude: Use "Subdivisions of Graticules". Scale is 1:500 by default.
Scale: Users can choose the scale of the division. For rectangle-division, LiDAR provides four scales,
including 1:500, 1:1000, 1:2000, 1:5000. For subdivisions of graticules, LiDAR provides eleven
scales, including 1:500, 1:1000, 1:2000, 1:5000, 1:10000, 1:25000, 1：50000, 1:100000, 1:250000,
1:500000, 1:1000000.
Buffer (default is "0"): The size of buffer around each data.
Ignore Different Additional Attribute: In the case of processing multiple input point clouds, if this
option is checked, only the same additional attributes will be merged. Otherwise, as long as there are
different additional attributes, the merge cannot be performed.
Output Path: The path for the output folder. After running this function, the new divisions will be
generated.



Transform GPS Time

Function Description

This function converts the GPS time information in LiData from GPS coordinate time to GPS week
second, or from GPS week second to GPS coordinate time. There are two ways to record the GPS time
information, GPS week second and GPS coordinate time (GPS standard time minus 10^9).

Usage

Click Data Management > Point Cloud Tools > Transform GPS Time.

If the GPS time of the selected data is GPS weeks and seconds, the pop-up interface is as shown in the
figure below：

If the GPS time of the selected data is GPS coordinated, the pop-up interface is as shown in the figure
below：

Settings

Input Data：Enter a LiData point cloud data file.

If the GPS time of the input point cloud data is GPS weeks and seconds, it needs to be converted to GPS
coordination time.

Collection Date：If the GPS time information of the input point cloud is in GPS week second and to
be transformed into GPS coordinate time, the week number is necessary. And the week number must
be greater than 1654. Otherwise, when being subtracted by 10^9, the GPS time will be negative. If
the GPS time information of the input point cloud is in GPS coordinate time and to be transformed into
GPS week second, the week number is unnecessary.



Smooth Points

Summary

Smooth the laser point cloud based on the neighbouring points, making the point cloud look more
consistent.

Usage

Click Data Management > Point Cloud Tools > Smooth Points.

Settings

Input Point Cloud Data：Input the LiData point cloud data to be smoothed.
Smoothing Type：

XYZ（Default） ：In the 3D smoothing process, the points on the vertical plane are smoothed in
the XY direction, and the points on the horizontal plane are smoothed in the Z direction.
Elevation ：Fit the best fitting plane equation according to the neighboring points, and adjust the
elevation of the center point to better fit the plane equation. If the adjustment distance exceeds
the repair threshold, no adjustment will be made.

Search Radius (m) (Default Value is “0.2”)：Search radius of neighboring points.
Max Fix Distance (m) (Default Value is “0.1”)：The maximum single-point adjustment distance
threshold, beyond which it will not be adjusted.
Output Path：Set the output path for smooth point cloud files generated by the smoothing process.
Default：Restore the setting parameters to the default values.
Parallel settings: Whether to use the multi-core CPU parallel computing mechanism for smoothing.



Vegetation Index

Functional Description

Vegetation index can reflect the background influences of plant canopy, such as soil, wet ground, snow,
dead leaves, roughness, etc., and is related to vegetation cover.

Principle Description

Normalized difference vegetation index

The normalized difference vegetation index(NDVI) requires near-infrared (NIR) and red (R) attributes in
point cloud data. The specific calculation method is as follows:

Visual band difference vegetation index

The visual band difference vegetation index requires that red (R), green (G) and blue (B) attributes exist in
the point cloud data and are not all 0. The specific calculation method is as follows:

Usage

Click Data Management > Point cloud tool > Vegetation index, Set parameters click OK to generate
Vegetation Index, vegetation index will be written into the point cloud additional attribute "Vegetation
Index".



Parameters Settings

Input data: The input file can be a single data file or a point cloud data set; the file(s) to be processed
must be opened in the LiDAR360 software.
Index Type:

NDVI: The vegetation index is calculated from near - infrared (NIR) and red light (R) attributes.
Visual band difference: The vegetation index is calculated according to the red (R), green (G)
and blue (B) attributes.

Note: If the point cloud does not have RGB attribute or both are 0, the two planting indexes cannot be
calculated. Normalized vegetation index cannot be calculated if the point cloud does not have Near
Infrared attribute.



Segment by Attribute

Functional Overview

This function first extracts the point clouds of interest through attribute filtering and category filtering, then
uses Euclidean clustering to segment the point clouds of interest into several clusters, further filters these
clusters, and finally counts the information of these clusters and outputs a statistical report. This function
does not generate new point cloud files but writes the labels of the clusters into an additional attribute
named "Group" in the point cloud (this additional attribute is an integer single component that cannot be
defined as other types or components). Point clouds with identical labels greater than 0 are considered as
belonging to the same cluster, such as 1, 2...; -1 is an invalid label indicating that this point does not
belong to any cluster. Users can further process the point clouds of interest through Extract by Attribute,
Classify by Attribute or Extract by Group. This function generates a CSV format statistical report. Each row
in this report represents a cluster, and users can freely choose which statistics information they want.

Usage

Click Data Management > Point Cloud Tools > Cluster by Attribute

Parameter Settings

Point Cloud : The input file must be a single LiData point cloud data file. Users can select already
opened LiDAR360 software's point cloud data or open other LiData files from disk.
From Class: Initial categories are used to extract interested category points.
Additional Attributes Filter: Used for extracting interested range within additional attributes. Refer to
Extract by Additional Attributes. If not selected, this filtering will not be performed.
Cluster Result Filter:



Minimum Point (default is "10"): If checked, the following filter will be performed: if the number
of points in a cluster is less than this value, the cluster will be classified as an invalid cluster and
its label will be set to -1.
Minimum Area (default is "0"): If checked, the following filter will be performed: if the projection
area of a cluster is less than this value, it will be considered as an invalid cluster and its label set
to -1.

Search Radius (default is "0.5"): Euclidean clustering threshold. Point clouds with Euclidean
distance smaller than this threshold are grouped into one cluster. The calculation of Euclidean
distance depends on search method. The larger this value, the fewer clusters you get.
Search Method: Dimension used for calculating Euclidean distances between point clouds during
clustering process; currently supports 2D and 3D. When Search Method is “2D”, only horizontal
direction's euclidean distance would be considered during clustering process.

3D (Default): Calculation formula for Euclidean distance: d =√(x0-x1)²+(y0-y1)²+(z0-z1)²
2D: Calculation formula for Euclidean distance: d =√(x0-x1)²+(y0-y1)²

Select Statistic Informations for Group (checked by default)：If checked，add statistics about
certain additional attributes in output CSV report。

Additional Attributes ：Select name of additional attribute，refer to Extract by Additional
Attributes.
Informations to Statistic ：Choose one or more items from name, convex hull area, point cloud
number, position, AABB bounding box, minimum value, maximum value, average value and
standard deviation for statistics. Name，convex hull area，point cloud number，position and
AABB bounding box are required.

Default: Set parameters to default values.
Output Path: Output path of CSV statistical report.



Brightness Contrast

Functional Overview

For point clouds with color information, adjust the brightness and contrast of the point cloud.

Usage

Click Data Management > Point Cloud Tools > Brightness Contrast. Adjust the two parameters until the
preview effect meets expectations, then click "OK" to process.

Parameters Settings

Input Data: The input file can be a single point cloud data file or a point cloud dataset. Only point
clouds containing color information will be displayed in the list.
Brightness: Adjust the brightness by sliding the bar or entering the values directly. The range is from
-100 to +100.
Contrast: Adjust the contrast by sliding the bar or entering the values directly. The range is from -50
to +50.
Preview: Click the button after adjusting the parameters to preview the current effect in the window.
Preview only affects the selected point cloud data.
Output Path: The output path of the resulting point cloud file.

This function only applies to point clouds containing color information.



Raster Tools
Raster tools include Band Calculation, Raster Mosaic, and Raster Subdivision.

Raster Mosaic

Raster Subdivision

Raster Calculator



Raster Mosaic

Summary

Raster Mosaic refers to the technical process of merging two or more images to one image. LiDAR360
provides seven sampling methods: Nearest Neighbour, Bilinear, Cubic, CubicSpline, Lanczos,
Average, and Mode. It is the reverse operation of Raster Subdivision.

Usage

Click Data Management > Raster Tools > Raster Mosaic

Settings

Input Tiff File: Users can select multiple files (>1) to be processed from the drop-down list.
: Users can add multiple external images for image mosaic.
: Users can select a file in the list and click this button to remove the file from the list.
: Click this button to clear all images in the list.

Sample Type: Users need to select the sampling type from the drop-down list.
NearestNeighbour (default): Nearest neighbor, sampled from the nearest neighbor.
Bilinear: Bilinear sampling (2 x 2 cores).
Cubic: Cubic convolution approximation (4 x 4 kernels).
CubicSpline: Cubic B-spline approximation (4×4 kernel).
Lanczos: Lanczos Window Sine Interpolation (6×6 Cores). Lanczos can be used as a low pass
filter or to smoothly interpolate the value of a digital signal between its samples.
Average: Calculate the average of all non-value pixels.
Mode: Select the most frequently occurring value for all sampling points.

Output path: Path of the output folder. After the function is executed, a new file will be generated.

https://en.wikipedia.org/wiki/Lanczos_resampling


Raster Subdivision

Summary

The raster subdivision tool is the inverse operation of Raster Mosaic. The frame number adapts the
coordinate number and consists of the southwest corner of the frame (Y coordinate + X coordinate). A
scale of 1:5000 is taken into 1 km, 1:2000 and 1:1000 to 0.1 km, and 1:500 to 0.01 km.

Usage

Click Data Management > Raster Tools > Raster Subdivision

Settings

Input File: Users can select the file to be processed from the drop-down list.
: Users can add external files that need to be processed.

Scale (default "1:500"): Users can select a targeted scale. LiDAR360 has four scale options: 1:500,
1:1000, 1:2000, and 1:5000.
Output path: Path of the output folder. After the function is executed, new subdivided files will be
generated.



Raster Calculator
This tool is a spatial analysis tool. User can input raster data algebraic expressions, use operators and
functions to do mathematical calculations, in order to establish selection queries, or enter raster data
algebraic syntax.

Advantages of the raster calculator tool:

1. Supports the use of variables in raster data.
2. The ability to apply operators to three or more inputs of an expression.
3. The raster calculator is used to execute single-line algebraic expressions through a simple, calculator-

like tool interface, using a variety of tools and operators. When multiple tools or operators are used in
an expression, the speed of execution is generally faster than executing each operator or tool
separately.

Principle Description

Use the calculator buttons to enter values in expressions. Use the operator buttons to enter mathematical
operators (addition, division, etc.) and logical operators (greater than, equal to, etc.) into expressions. By
clicking these buttons, user can enter a number or operator into the current position of the pointer in the
expression. The following are some examples of expressions that can be executed in the raster calculator
tool. In these expressions, the raster layer name is enclosed in quotation marks, such as "dist".

("pop" > 150) & ("dist" > 10)
(("reclass_rd_dist" * 3) + ("reclass_landuse" * 2) + "reclass_elev") /6.0
("Band4" - "Band3") / Float("Band4" + "Band3")
Con("elev" <= 3000, 1, 0)
Con(IsNull("elev"),0, "elev")
Con(("landuse1" == 1) & ("landuse2" == 5), "landuse1" + "landuse2", 99)
Con(Raster('elev') != 0,'elev')
(Con('elev', 'elev', "", "elev_feet <> 0")) + Raster("tree_height")
Con("inRas" < 45,1, Con(("inRas" >= 45) & ("inRas" < 47),2, Con(("inRas" >= 47)&("inRas" < 49),3, Con("inRas"
 >= 49,4))))

Usage

Click Data Management > Raster Tools > Raster Calculator.



Settings

Raster Data：Display the raster data path (.tif) contained in the main interface, user can import the
local raster data, perform expression calculations, and remove or clear the imported data.

Calculator Buttons：Contains number buttions 1, 2, 9, 0, etc. Algebraic operator buttions +, -, *, /,
etc. Logical operators >, <, ==, etc. The major operation and logical buttons are as follows:

/ Divided by != Not equal to == Equal to & AND

X Multiplied by < Less than <= less="" than="" or="" equal<="" td=""> | OR

- Minus > Greater than >= Greater than or equal ^ Exclusive OR

+ Plus ~ NOT C Clear expression

Function：Lists the functions of abs, tan, cos, log, etc.

Function Description

abs Absolute value function

acos Arc-cosine function

acosh Hyperbolic arc-cosine fuction

cosh Hyperbolic cosine function

asin Arc-sine function

asinh Hyperbolic arc-sine function

sin Sine function

tan Tangent function

atanh Hyperbolic arc-tangent function

atan Arc-tangent function

cot Cotangent function

pow Exponent power function

log Logarithm function

sqrt Square root function



sinc Sinc function

Calculator Expression：Use the calculator button to enter values in the expression, or use
operators, functions, etc. to form a raster calculation expression with raster data, and display it in this
panel.

Output Path：Select the output directory or .tif file path. This output raster represents the result value
of the calculation expression.



Vector Tools
Smooth Line



Smooth Line

Functional Overview

The Line Smoothing tool can smooth the input vector lines. It supports 2D and 3D polylines and polygons.

Usage

Click Data Management > Vector Tools > Smooth Line

Parameters Settings

Input Files List: Input one or more vector files. Input file format: .gpkg, .shp, *.dxf.
Method: Multiple methods are available to smooth the vector lines.
Mean smoothing (3\5\7 neighborhood): Use a 3\5\7 neighborhood for mean smoothing on each
point of the vector line.
Bezier (Using Line as control): Smooth using segmented Bezier curves, generating a new vector
line without control points.
Bezier (Using Point as control): Smooth using segmented Bezier curves, generating a new vector
line with control points.
B-Spline (Using Point as control): Smooth using cubic B-spline curves, generating a new vector
line passing through some of the control points.
B-Spline Fit: Fit using cubic B-spline curves, generating a new vector line without any control points.
Output Path: Output folder path. The newly generated vector lines will be output to this folder.

|Method|Effect(The red line is the original polyline while blue is after being smoothed)|

|:----:|:----:|



|Mean Smoothing(3\5\7 neighborhood)| |

|Bezier Smoothing(line control)| |

|Bezier Smoothing (point control)| |

|B-Spline (point control)| |

|B-Spline Fit| |



3D Building Tool
LiBIM Merge



Merge of LiBIM file
This function is used for the merge of several LiBIM files.

Usage

Click Data Management > 3D Building Tools > Merge LiBIM Files.

Parameters Settings

File list: Input the LiBIM files to be merged. Users need to click the button  to add the file data to be
converted from outside; Users can select a file in the list and click  button to remove the file from
the list. Click  button to clear all the data in the list.
Output path: Select the output file directory path. After the algorithm is executed, the merged LiBIM
file is generated.



Tile
The Tile Tool Includes Tile by Range, Tile by Point Number, Tile by Draw Line, and Tile by Polygon.

Tile by Range

Tile by Point Number

Tile by Draw Line

Tile by Polygon



Tile by Range

Brief

Tile by Range divides the point cloud into a series of small data files based on the user-defined width
,length and buffer size of the small data file. This process begins from the lower-left corner of the input
file's bounding box,the result includes the point cloud blocks data(including buffer) and the blocks
boundary stored in the shp file(not including buffer). The output of this function is similar to Tile by Point
Number.

Brief

Click Data Management > Point Cloud Tools > Tile by Range

Settings

Input Data: The input file can be a single point cloud data file or multiple data files. File Format:
*.LiData.
Width (m)(default value is "500"): The width of the data block size, which is the length in the X-axis
direction.
Height (m)(default value is "500"): The length of the data block size, which is the length in the Y-
axis direction.
Buffer (m)(default value is "0"): The extend size of every block in all directions.
Output path: Path of the output folder. After the function being executed, new files will be generated
which include the point cloud blocks data(including buffer) and the blocks boundary stored in the shp
file(not including buffer).



Tile by Point Number

Summary

Tile by Point Number divides the point cloud into a series of small data files with a total of user-defined
number of points. This process begins from the lower-left corner of the input file's bounding box. The
output of this function is similar to Tile by Range.

Principle

The Point Number entered by the user will be recalculated according to the actual number of blocks in
the actual chunking process. The formula is as follows:

Among them,  is the number of tiles,  is the actual point number of a tile,  is the

total number of points in the original file, and is the user-defined point number.

Effect picture of tile:



Original point cloud data and point cloud data after chunking by point (different yellow bounding boxes
represent different point cloud data).

Usage

Click Data Management > Point Cloud Tools > Tile by Point Number

Settings

Input Data: The input file can be a single point cloud data file or multiple data files. File Format:
*.LiData.
Point Number (default value is "50000"): Set the number of points in each tile. Note that the actual
number of points in a tile may be slightly different from the user-defined number.
Output path: Path of the output folder. After the function being executed, new files will be generated.



Tile by Draw Line

Summary

Draw a straight line on the Viewer and divide the point cloud data into two pieces by using this line as the
boundary.

Usage

ClickData Management > Point Cloud Tools > Tile by Line

Enter the coordinates for the start and end points, or update the start and end points by drawing a line on
the Viewer after clicking the buttons on the right side of the dialog box.

Settings

Input Data：The input file should be a single point cloud data file. File Format: *.LiData.
Initial Point（X,Y）：The XY of initial point.
Termination Point（X,Y）：The XY of termination point.
Out Path：Path of the output folder，After the function is executed, the divided point cloud file and
the shp file of the block boundary are generated. The block boundary stored in the shp file does not
include the size of the buffer.



Tile by Polygon

Summary

Read the polygon information in the vector data by the polygon block function, extract the points inside the
polygon, the points outside the polygon or the points between the polygons to generate a new point cloud
file.

For Polygon objects in vector data, a new file is generated for the points within each polygon, and a point
cloud file is generated for the points that are not in any polygon.

For MultiPolygon objects in vector data, the point cloud file of the inner polygon will be generated as point
cloud data, the set of points between the inner polygon and the outer polygon will be generated as point
cloud data, and all points outside the Polygon will be generated as point cloud files.

Usage

ClickData Management > Point Cloud Tools > Tile by Polygon

Settings

Input Point Cloud Data：The input file can be a single point cloud data file or multiple data files. File
Format:*.LiData.
Vector File: User can select the Vector File loaded into LiDAR360 software from the drop-down
menu, or select  button to load an external vector data file.
Named With The Attribute Name of The shp File：Select the attribute field of Polygon and name
the newly generated block data.
Calculate the topological relationship of polygons: For the Polygon object in the vector data,
calculate the topological relationship between polygons. If checked, the topological relationship
between polygons will be calculated; if not checked, all points in the Polygon will be generated into a
new file.



Output Path：Path of the output folder, the point cloud file after the function is executed will be
output under this file path.



Projections and Transformations
Different kinds of transforms for point clouds, e.g. reprojection, elevation adjustment, are provided. The
calculation of parameters necessary for transforms, e.g. seven-parameter solution, four-parameter
solution, are provided as well.

Define Projection

Reproject

Transformation

Convert Projection Surface

Elevation Adjustment

Transformations Calculation

Fitting Geoid Model

ICP Registration

Convert ASCII to BLH

Manual Registration

Manual Rotation and Translation

The Geoid Model

Create Transformations



Define Projection

Summary

Define a coordinate reference system for point cloud data. The coordinate reference system generally
includes geographic coordinates (usually latitude and longitude coordinates), geocentric coordinates and
projected coordinates (plane coordinates converted by projection). This feature only supports defining
geographic and projected coordinates.

Usage

Click Data Management > Projections and Transformations > Define Projection

Settings

Select Input file: The input file can be a single point cloud data file or multiple point cloud data files.
File format: *.LiData.

Current File's Coordinate Name: Display the current coordinate name.

Target Coordinate Name: Display the current coordinate name.

Details: Displays detailed information about the currently set coordinate system.



Add Coordinate System: Users can add external coordinate system settings or customize
coordinate system settings. LiDAR360 software provides four ways to add external coordinate
system:

Add Geographic Coordinate System
Add Projected Coordinate System
Add Vertical Coordinate System

Filter: Users need to enter a customized coordinate system. By entering the coordinate system
keywords, the corresponding coordinate system can be filtered from the Coordinate reference
systems of the world table (for example: to set the point cloud coordinate system to WGS 84 / UTM
Zone 49N, users can enter UTM 49N in the filter for fast screening, or enter its EPSG number 32649
for quick search.) Users can also import external coordinate system by clicking the Add Coordinate
System button.

Set Coordinate System: Select the coordinate system to be set, which can be selected from the
default coordinate system or a custom coordinate system. First, select the horizontal coordinate
system on the Horizontal tab. At this time, the vertical coordinate system defaults to the height of the
ellipsoid. If you need to define a vertical coordinate system, you can switch to the Vertical tab to
select a vertical coordinate system, and the two together form a combined coordinate system.The
coordinate system selection interface includes the following choices:

Recent: Records recently used coordinate systems.
Favorites: Contains the coordinate systems that have been marked as favorites.
Projected Coordinate Systems: Includes all default projected coordinate systems.
Geographic Coordinate Systems: Includes all default geographic coordinate systems.
User Defined Coordinate Systems: Includes all user-defined coordinate systems.
Layers: Contains the coordinate systems of the loaded data.
Vertical Coordinate Systems: Includes all default vertical coordinate systems.
User Defined Vertical Coordinate Systems: Includes all user-defined vertical coordinate
systems.

Right-click on any coordinate system, and from the popup menu, select the Add to Favorites
option to add the selected coordinate system to your favorites. To remove a coordinate system
from your favorites, right-click on the favorite coordinate system and choose the Remove from
Favorites option.

Right-click on any custom coordinate system and select the Delete option to remove a custom
coordinate system. If the deleted custom vertical coordinate system is used in a custom
composite coordinate system, you will be prompted to confirm whether to delete the composite
coordinate system as well. Choosing "Yes" will delete all these coordinate systems, while
choosing "No" will leave them intact.

Right-click on any coordinate system, and select the Copy and Modify option to modify the
coordinate system parameters and save it as a custom coordinate system. The current
coordinate system parameters will be filled into the corresponding modification interface. For
specific settings, please refer to the section on adding coordinate systems on this page.

Set Geoid Model: On the Vertical tab page, you can set the geoid model of the vertical coordinate
system. If the user need to use this option, the user need to provide the vertical reference grid data.
For the method, please refer to the next section Vertical Coordinate System. At present, this setting



has the following three situations.

When this option is not set, if the vertical datum grid data is provided, the appropriate geoid
model will be automatically searched and used during coordinate transformation. If not provided,
the geoid model will not be used during coordinate transformation (except for the EGM2008
model included in the software installation package).
If the selected vertical coordinate system can use the geoid model supported by default, it can be
selected from the drop-down list, and the model will be specified when performing coordinate
transformation. For the geoid models currently supported by default in LiDAR360 software,
please refer to the Geoid Model page.
If the geoid model to be used is not included in the package provided by PROJ, the user can
place the model file to be used under the geoid folder in the software installation directory, and
then add the geoid model by clicking the Add Geoid button to add the file (support tiff and gtx
formats), the model will be added to the drop-down list, after selecting the added model, the
custom geoid model will be used in the coordinate transformation process.

If the coordinate range of the selected geoid model does not match the coordinate range
after point cloud coordinate transformation, the model will not take effect.

Selected Coordinate System: The information of the coordinate system selected by the user will be
displayed here.

After clicking OK, the WKT information representing the projection will be written to LiData.

Vertical Coordinate System: Users can customize the vertical coordinate system. Vertical coordinate
system transformations and grid projections require vertical datum grid data for valid transformations.
EGM2008 geoid model elevation conversion is provided by default in the software. If you need to support
other regional geoid models, you need to download the corresponding grid data files. The grid files are
provided by the official PROJ library, which can be downloaded here proj-data-1.8, or on the official
website https ://proj.org/download.html to download the latest version of proj-data. After downloading,
unzip the file to the geoid folder in the software installation directory, the default is C:\Program
Files\GreenValley Suite\LiDAR360\5.0.0.0\geoid, "5.0.0.0" is the version number, and there will be
differences between different versions.

Note: The custom geoid model must be placed in the geoid folder to take effect.

Add Geographic Coordinate System

https://download.osgeo.org/proj/proj-data-1.8.tar.gz
https://proj.org/download.html


Name: Users can customize the name of a geographic coordinate system .
Datum:

Name: Users can customize a datum name or select a known datum from the drop-down list.
Spheroid: If a user selects the datum from the drop-down list, the ellipsoid parameter does not
require to be entered.

Name: The name of the spheroid.
Semimajor Axis: Spheroid's major semiaxes.
Inverse Flattening: Inverse flattening of the spheroid.

Angular Unit:
Name: Users can customize the angle unit name, or select the angle unit name from the drop-
down list.
Radians Per Unit: Define the unit of arc in the geographic coordinate system.

Prime Meridian:
Name: Users can customize the name of the central meridian, or select the name of the central
meridian from the drop-down list.
Longitude: Enter the central meridian longitude.

Add Projected Coordinate System



Name: Users can customize the name of a projection coordinate system.
Projection:

Name: Users can customize a projection name or select a known projection from the drop-down
list. It should be noted that user-defined projections can be modified from a projection template
selected from the drop-down list.

Linear Unit:
Name: Users can customize the linear unit name or select the linear unit name from the drop-
down list.
Meters per Unit: Input meters per unit.
Geographic Coordinate System: Users can click "Change" to select a geographic coordinate
system.
Change: Clicking the "Change" button will bring up the following dialog box for changing the
geographic coordinate system. Users can filter and select the desired coordinate system. Both
default geographic coordinate systems and custom geographic coordinate systems are
supported.



Add Vertical Coordinate System

Name: Users can define a custom projection coordinate system name.
Direction: Set whether the coordinate axis direction is upward or downward.
Datum Type: Set the datum type of the vertical coordinate system. "Ellipsoidal" is for ellipsoidal
datum, and "Gravity-related" is for gravity-related datum.
Ellipsoid Datum: When the datum type is set to "Ellipsoidal," you can set the ellipsoid datum using
this option. Once selected, the ellipsoid parameters will be automatically filled in the ellipsoid



parameters list below.
Vertical Datum: When the datum type is set to "Gravity-related," you can set the vertical datum using
this option.
Linear Unit:

Name: Users can define a custom linear unit name or select one from the dropdown list.
Meters per Unit: Enter the meters per unit.
Geographic Coordinate System: Users can click "Modify" to select a geographic coordinate
system.
Default: Restore default parameters.



Reproject

Function Description

The point cloud can be reprojected among geographic coordinate systems and projected coordinate
systems. When different geographic coordinate systems are converted to each other, LiDAR360 provides
the seven parameter transformation model to adjust the differences between ellipsoids and reference
planes.

Usage

Click Data Management > Projections and Transformations > Reproject

Settings

Select Input File: The input file can be a single point cloud data file or multiple data files. File Format:
*.LiData.
Current File's Coordinate Name: Display the coordinate system name of the current point cloud.
Use Seven Parameters: Users can choose whether to use seven parameters for re-projection. If



checked, seven parameters will be used; vice versa.
Seven Parameters Setting: Select the Use Seven Parameters option and click the Create button to
create a seven-parameter conversion relationship. Please refer to Create Transformations.
Filtering: Users need to enter a customized coordinate system. By entering the coordinate system
keywords, the corresponding coordinate system can be filtered from the Coordinate reference
systems of the world table (for example: to set the point cloud coordinate system to WGS 84 / UTM
Zone 49N, users can enter UTM 49N in the filter for fast screening, or enter its EPSG number 32649
for quick search.) Users can also import external coordinate system by clicking the Add Coordinate
System button.
Add coordinate systems: For details, refer to Define Projection parameter settings.
Output path: Path of the output file. New files will be generated after the function being executed.

Note: The reprojected point cloud must already have projection information. To check whether the
current point cloud has projection information, users can select the data in the data list and its
projection information will be displayed in the current file coordinate system



Transformation

Function Description

LiDAR360 software supports multiple coordinate transformation methods. Users can select a
transformation method to perform coordinate conversion according to their needs.

Usage

Click Data Management> Projection and Coordinate Conversion> Coordinate Conversion

Usage

1. Input Data： The input file can be a single point cloud data file or multiple data files. File Format:
*.LiData.

2. Select or customize transformation method: available for reference, Create Transformtions.

3. Output Path：Path of the output folder. After the algorithm being executed, new files after coordinate
conversion will be generated.



Convert Projection Surface

Functional Overview

For Gauss projection and UTM projection, the length deformation value will increase when the projection
area is far away from the central longitude of the projection belt. Convert Projection Surface function can
be used to reduce length deformation.

Usage

Click Data Management > Projection and Coordinate Conversion > Convert Projection Surface

Steps

1. Input point cloud data: The input file with projection information can be a single point cloud data file
or multiple data files. File format: *.LiData. Click the point cloud file to display the coordinate system of
the point cloud on the interface.

Only point cloud files whose horizontal coordinate system is Gauss projection or UTM projection
are supported.

2. Set projection surface height: Set the elevation of the projection. The positive value is the distance
above the ellipsoid and the negative value is the distance below the ellipsoid, the unit is in meters.

3. Output Path: Output folder path, after the algorithm is executed to generate a new file after
coordinate conversion.

Principle

1. Calculate the radius of curvature of the earth Ra where the point cloud is located. Where a is the
semi-major axis of the ellipsoid, e is the eccentricity of the ellipsoid, and B is the average latitude of
the measurement area of the point cloud.



2. Calculate the scale factor q. In the formula, Hb is set as the elevation parameter of the projection.

3. Calculate the modified coordinates, where Xc and Yc are the modified coordinates, X and Y are the
original coordinates, and X0 and Y0 are the projection center coordinates of the coordinate system.



Elevation Adjustment

Summary

The elevation of raw laser data is normally represented by ellipsoidal height. Normally these values need
to be transformed to values in regional height system or local height system. For large area, the
adjustment of elevation can not be defined as a mathematical formula. Hence, the model of elevation
adjustment is required to be defined. The algorithm is to build triangular network model using known
control point data as well as to interpolate and correct local points using height anomaly between different
height systems. Adjusted elevation result can be checked according to the Control Point Report.

It is recommended to use control point data containing entire project region to adjust model in order to
provide more accurate elevation information to the project border.

Usage

Click Data Management > Projections and Transformations > Elevation Adjustment

Setting

Input Data: Input files can be single point cloud file or point cloud data set.
Input File: Users need to input adjustment model file of control points. This file data can be generated
by tool of Control Point Report.
Output path: Output adjusted point cloud data.



Conversion relationship calculation

Function Description

This function calculates the required conversion relationship based on the control point pair, and can save
the calculated conversion relationship to the history file for reuse. Currently supports four-parameter and
seven-parameter solutions.

Usage

Click Data Management> Projection and Coordinate Conversion> Conversion Relationship Calculation

Parameter Settings

Parameter Solution：The method of parameter calculation supports four parameters and seven
parameters.
Source/target coordinate file：Input the control point source coordinate file, the format can be
referred to Seven Parameter format.
Source/target coordinate system：When the coordinate form is x y h / BLH, the coordinate system
can be selected, please refer to Define Projection.
Source/target coordinate form：

X Y Z (Earth-centered coordinate system): Select this item when the input data is in the
projected coordinate system. At this time, the "source/target coordinate system" cannot be
selected. Directly calculate the seven-parameter transformation between the source coordinate
and the target coordinate. If the user selects four parameters, it will be forced to switch to X Y Z
X Y H / BLH: Select this item when the input data is in the projection/geographical coordinate
system. At this time, you need to select the "source/target coordinate system". After the selection
is completed, it will automatically switch once according to the selected coordinate system. When
selecting BLH, you can select degrees or degrees: minutes: seconds.

x y h: The "source/target coordinates" will be projected to geographic coordinates according
to the projected coordinate system selected by the user, and then the geographic



coordinates will be transferred to the geocentric coordinate system according to the ellipsoid
information in the projected coordinate system, and finally the seven parameters between
the two geocentric coordinate systems will be solved.
BLH: The user needs to select "Geographic Coordinate System", the program transfers the
coordinates to the geocentric coordinate system according to the ellipsoid information in the
geographic coordinate system, and finally solves the seven parameters between the two
geocentric coordinate systems.

Report：Calculate the conversion relationship and generate a report, which contains the
calculated conversion relationship parameters and the back-projection report of various control
points. The report can be saved as HTML and ASCII format.
Define conversion relationship：Please refer to Create Transformation.

Seven-Parameter Solution
Using Bursa model to calculate the seven parameters for the transformation among different coordinate
systems according to three or more pairs of tie-points. The parameters include three translation
parameters, dx, dy, dz, three rotation parameters, rx, ry, rz, and a scaling factor, m. The calculation
formula is shown below. Bursa seven parameters formula can be written as follow:

Convert the above formula to a equation set, which is：

In the equation set, there are seven unknown parameters. If there are three or more than pairs of tie-
points, these seven parameters can be solved through the above equation set using the least square
method.

Four-Parameter Solution
According to two or more control points, users can calculate the four parameters that used to perform
coordinate system transformation. The four parameters include two translation parameters, dx and dy, a
rotation parameter, T, and a scaling factor, K.



ICP Registration

Summary

By setting benchmark point cloud and point cloud to be registered, perform the point cloud registration
through ICP (Iterative Closest Points) algorithm. The basic steps of this algorithm are shown as follow.

Supposing that there are two given 3D-point collections, X1 and X2, the steps of ICP registration are
shown as follows:

Step 1. For each point in X2, calculate and find its closest point in X1;

Step 2. Estimate the combination of rotation and translation using a root mean square point to point
distance metric minimization technique which will best align each source point to its match found in the
previous step.

Step 3. Transform X2 using the obtained transformation.

Step 4. Iterate the above steps until the average distance from X2 to X1 is less than a given threshold.

Usage

Click Data Management > Projections and Transformations > Data Registration, then click ICP(R3) button
above the viewer.

https://en.wikipedia.org/wiki/Iterative_closest_point


Settings

Select Class: Choose the starting category for point cloud ICP registration. The default selection is
the entire category.
Use Selection Region: You can utilize selection tools such as  to select overlapping areas in the
point cloud. Check the Use Selected Area option to perform registration using the overlapping region;
if not checked, registration will be performed using the entire global point cloud. It is recommended to
check this option.
Registration Type: This includes two types: point-to-point and point-to-plane. The former estimates
transformation parameters by minimizing the Euclidean distance between matching points, while the
latter solves for the optimal transformation matrix by minimizing the normal (plane) distance between
source and target points. When point cloud data contains features such as ground, walls, or other
objects with planar characteristics, it is advisable to prioritize the latter.
Thread Number (default is "4"): The algorithm supports multi-threaded acceleration calculations.
When this parameter is set to a value greater than the maximum number of threads on your
computer, the algorithm will default to using the maximum number of threads available.
Sampling Points Limit (default is 100,000): This parameter is used for downsampling the original
data. The algorithm randomly samples the original point cloud data to the specified number of points
to obtain a subset of the original point cloud. Subsequently, the registration process will be based on
this subset.

Max Distance of Points Searching (default is 1m): This parameter is used for constructing
matching pairs through nearest neighbor search. When coarse alignment accuracy is low, such as
when two walls are more than 5 meters apart after coarse alignment, if you set the maximum point
search distance to 1 meter, then it may cause errors in feature association between two walls and
lead to incorrect matches. In this case, you should increase the maximum point search distance
slightly, such as setting it at 10 meters and running global optimization once so that it pulls closer
together some parts of your point cloud but local details may have poor stitching results; then set
back max-point-search-distance=1m and run global optimization again which usually gives better
stitching results after optimizing twice or thrice.

Overlap Threshold (default is 40%): This parameter determines which stations need adjustment
matching during inter-station nearest neighbor search. This parameter is used in conjunction with the
maximum inter-station search distance. When the distance between two stations is less than the
maximum inter-station search distance, it is also necessary to determine whether the overlap ratio of
point clouds between two stations meets requirements. If the overlap ratio is greater than the set
overlap threshold, these two stations will be included in adjustment network.



Normal Filter Threshold (default is 60%): This parameter filters extracted line and surface features.
The algorithm retains a proportion of features specified by this parameter for calculation. The larger
this parameter value, the more features are involved in algorithm calculation and better optimization
results can be achieved but at longer computation time cost. It's recommended that this parameter
should be greater than 50%.

Note:

1.This function does not support the registration between models and models.

2.If the files to be registered and the reference files are significantly distant in location, it is advisable
to perform coarse registration first (rotation and translation registration and point-to-point registration).



Convert ASCII to BLH

Summary

Transform the X, Y, Z information stored in the ASCII data to B (latitude), L (longitude), and H (ellipsoid
height) in Geographic Coordinate System. All the other attributes in ASCII file will be kept.

Usage

Click Data Management > Projections and Transformations > Convert ASCII to BLH.

Settings

Input ASCII Data: Input an ASCII file. The supported formats include .txt and .CSV.
Coordinate System of Current Data: Select the coordinate system of current point cloud file
Skip Lines: The number of lines that need to be skipped for the currently selected ASCII data
(usually description information or column headers).
Separator: The separator of each component of the selected ASCII data.
Source Projection: Projection information of the selected ASCII data.
Output Path: Output the converted file to the specified path.



Manual Select Point Pairs Registration

Summary

The manual point selection registration tool can be used for data correction between point clouds, images,
and model data. Place the reference data and the data to be registered in two windows, select or fit
spheres (for point cloud data) in both windows to obtain at least three pairs of corresponding points.
Calculate the coordinate transformation matrix between the two datasets through these corresponding
points to perform coordinate correction on the data. By selecting point pairs, users can view residuals
between datasets in a list of corresponding points.

Usage

1. Select or fit spheres in two windows (for point cloud data) to obtain at least three pairs of
corresponding points. Calculate the coordinate transformation matrix between the two datasets using
these corresponding point pairs for data coordinate correction. By selecting point pairs, users can
view the residuals between the datasets in the corresponding point pair list.

2. (Optional) Users can click Open Data to load known corresponding point pairs from external sources.
If you do this, you can skip steps 4, 5, and 6.

3. Click Select Corresponding Points or Select Target Spheres to choose one point each in the
reference window and the window to be registered as corresponding points.

4. After selecting one pair of corresponding points, click the Add Row for Point Pairs button to add an
empty row.

5. Repeat steps 3 and 4 to select at least three pairs of corresponding points.



6. (Optional) If the user does not want a specific row of corresponding point pairs to participate in the
coordinate transformation, there are two ways to achieve this: (1) uncheck the corresponding row in
the list; (2) click Delete Corresponding Point Pairs to remove point pairs with larger residuals.

7. (Optional) If there is a pair of corresponding point pairs with a large residual or if you want to correct
the coordinates of that pair, there are two ways to achieve this: (1) select the row of corresponding
point pairs in the list, and then reselect that point in either the reference window or the window to be
registered; (2) double-click on the coordinate values you want to modify in the list and make direct
changes.

8. (Optional) To view a specific pair of corresponding points, double-click on a row in the corresponding
point pair list, and that corresponding point pair will be centered and displayed in the window.

9. (Optional) Click Save Data to save the selected corresponding point pairs.

Toolbar

Above the toolbar, the buttons from left to right are: Load Data, Save Data, Add Point, Delete Point, Pick
Point, and Pick Registration Point.

 Open Data: Import an existing list of corresponding points from an external source. For the format of
corresponding point pairs, see the corresponding point pair format in the appendix.

 Save Data: Save the selected list of corresponding points as a txt file.

 Add Row for Point Pairs: After selecting one pair of corresponding points, click this button to add a
new row for the next pair of corresponding points in the table.

 Delete Corresponding Point Pairs: To delete a row of corresponding point pairs, select the row and
click this button.

 Select Corresponding Points: Select corresponding points in both the reference window and the
window to be registered.

 Select Target Spheres: If target spheres are used for point cloud matching, this tool can be used to
automatically select and fit the target spheres, with the coordinates of the corresponding points being the
sphere center coordinates. Below the toolbar, the buttons from left to right are Point Size, Adjust Scale,
and Predict.

Point Size: Adjusts the size of the selected points in the window.

Adjust Scale (default "unchecked"): Check this option if the data have different scales. If unchecked, it
assumes rigid transformation between point clouds, and the computed rotation matrix does not include
scaling factors; otherwise, it includes scaling factors.

Predict (default "unchecked"): Check this checkbox and, when there are more than three pairs of
corresponding points, selecting corresponding points in the window to be registered will predict



corresponding points in the reference window.



Manual Rotation and Translation

Description

Manual Rotation and translation registration is used for the rotation and translation of individual point
clouds or models. In the viewer, you can perform rotation and translation operations on the data to be
registered, obtaining the corresponding transformation matrix. By clicking the pause button, you can
preview the registration status of the data. After applying this transformation, you will obtain the
transformed data.

Usage

After entering the data registration function from the toolbox, click on the "Rotation/Translation(R1)"
button, select the align data in the pop-up dialog box. After selection is completed, enter into manual
rotation and translation tool while software pops up a Data Registration interface at upper right corner.

Toolbar

In the data registration interface, the buttons from left to right are as follows: Match Center, Pause
Rotation and Translation Transformation, Set Rotation Center, Restore to Initial State.

Translation and rotation angle information is calculated based on the rotation center, which is the world
coordinates corresponding to the geometric center point of the data to be registered.

 Match Center: This function is available when there is reference point cloud data. It calculates the
center of the reference point cloud and the center of the data to be processed and translates the data to
be processed to the position of the reference data.

 Pause: Pauses the rotation and translation operations for the data to be processed. In this state, you
can view the differences between the current transformation and the reference data from various angles.

 Set Rotation Center: Click this function to open a dialog box for setting the rotation center
coordinates.

 Restore: Restores the data to be processed to the initial state and changes the rotation transformation
matrix to the identity matrix.

 Apply Transformation Matrix: After applying the transformation matrix, you can save the transformed
point cloud results to the original file or generate a new file. Transformation formula: Given the coordinates
of a point before transformation as P0(X0, Y0, Z0). The transformation matrix M is as follows:



The transformation formula is [X1 Y1 Z1 1] = [X0 Y0 Z0 1] * M / (a03X0 + a13Y0 + a23*Z0);
The coordinates after transformation are P1(X1, Y1, Z1).

TX: Check this option to perform translation on the X-axis. The amount of X-axis translation will be
displayed as delta X.

TY: Check this option to perform translation on the Y-axis. The amount of Y-axis translation will be
displayed as delta Y.

TZ: Check this option to perform translation on the Z-axis. The amount of Z-axis translation will be
displayed as delta Z.

Rotation: There are four options: X, Y, Z, and XYZ. If you choose X, you can only perform rotation around
the X-axis; if you choose Y, you can only perform rotation around the Y-axis; if you choose Z, you can only
perform rotation around the Z-axis; if you choose XYZ, you can perform rotation on all three axes (X, Y,
Z).

Rotation Sphere Tool

As shown in the figure, you can drag the red, green, and blue arrow axes while holding the left mouse
button to perform translation along the X-axis, Y-axis, and Z-axis of the point cloud. The dragged axis will
be highlighted. By holding the left mouse button and dragging the red, green, and blue trajectory circles,
you can perform rotation of the point cloud around the X-axis, Y-axis, and Z-axis. The dragged trajectory
circle will be highlighted.



Geoid Model
When performing coordinate transformation in the projection library, vertical coordinate system
transformation and grid projection need to provide vertical datum grid data for effective transformation.
EGM2008 geoid model elevation conversion is provided by default in the software. If you need to support
other regional geoid models, you need to download the corresponding grid data files. The grid files are
provided by the official PROJ library, which can be downloaded here proj-data-1.8, or on the official
website https ://proj.org/download.html to download the latest version of proj-data. After downloading,
unzip the file to the geoid folder in the software installation directory, the default is C:\Program
Files\GreenValley Suite\LiDAR360\5.0.0.0\geoid, "5.0.0.0" is the version number, and there will be
differences between different versions.

Supported Geoid Model

Geoid Model Vertical coordinate system

GEOID99

NAVD88 height - EPSG:5703

NAVD88 height (ft) - EPSG:8228

NAVD88 height (ftUS) - EPSG:6360

GEOID03

NAVD88 height - EPSG:5703

NAVD88 height (ft) - EPSG:8228

NAVD88 height (ftUS) - EPSG:6360

GEOID06

NAVD88 height - EPSG:5703

NAVD88 height (ft) - EPSG:8228

NAVD88 height (ftUS) - EPSG:6360

GEOID09

NAVD88 height - EPSG:5703

NAVD88 height (ft) - EPSG:8228

NAVD88 height (ftUS) - EPSG:6360

GEOID12A

NAVD88 height - EPSG:5703

NAVD88 height (ft) - EPSG:8228

NAVD88 height (ftUS) - EPSG:6360

NMVD03 height - EPSG:6640

PRVD02 height - EPSG:6641

VIVD09 height - EPSG:6642

ASVD02 height - EPSG:6643

GUVD04 height - EPSG:6644

GEOID12B

NAVD88 height - EPSG:5703

NAVD88 height (ft) - EPSG:8228

NAVD88 height (ftUS) - EPSG:6360

NMVD03 height - EPSG:6640

https://download.osgeo.org/proj/proj-data-1.8.tar.gz
https://proj.org/download.html


PRVD02 height - EPSG:6641

VIVD09 height - EPSG:6642

ASVD02 height - EPSG:6643

GUVD04 height - EPSG:6644

GEOID18

NAVD88 height - EPSG:5703

NAVD88 height (ft) - EPSG:8228

NAVD88 height (ftUS) - EPSG:6360

PRVD02 height - EPSG:6641

VIVD09 height - EPSG:6642

GGM10

NAVD88 height - EPSG:5703

NAVD88 height (ft) - EPSG:8228

NAVD88 height (ftUS) - EPSG:6360

OSGM15

Belfast height - EPSG:5732

Douglas height - EPSG:5750

Lerwick height - EPSG:5742

Malin Head height - EPSG:5731

ODN (Offshore) height - EPSG:7707

ODN height - EPSG:5701

ODN Orkney height - EPSG:5740

St. Marys height - EPSG:5749

Stornoway height - EPSG:5746

EGM96 EGM96 height - EPSG:5773

EGM2008
EGM2008 height - EPSG:3855

MSL height - EPSG:5714

GSIGEO2001 JGD2011 (vertical) height - EPSG:6695



Create Transformation Relationship

Functional Overview

The user can define and edit a variety of transformation relationships that can be saved to a history file for
the user to reuse. These transformation relationships can be defined during "transformation relationship
calculations" as well as when importing data.

1ppm = 0.001‰ is defined as one part per million (1 PPM)

Supported conversion relationship:

Four parameters:
Translation parameter Dx (meter, default value: 0).
Translation parameter Dy (meter, default value: 0).
Rotation parameter Theta (second, default value: 0).
Zoom ratio t (default value: 1.0).
Elevation fitting: You can check whether to carry out elevation fitting. If elevation fitting is
checked, you need to select predefined elevation fitting parameters from the drop-down list.
Refer to the method of defining elevation fitting parameters. Elevation fitting solution.

Note: When converting with Dx -0, Dy -0, Theta = 0, t = 1.0, the original paint cloud will be obtai
ned.

The four-parameter formula can be written as follows:

It can be solved according to the following formula:



 
Seven parameters: The seven parameters in the Bursa model.

Translation parameter Dx (meter, default value: 0).
Translation parameter Dy (meter, default value: 0).
Translation parameter Dz (meter, default value: 0).
Rotation parameter Rx (meter, default value: 0).
Rotation parameter Ry (meter, default value: 0).
Rotation parameter Rz (meter, default value: 0).
Zoom ratio m (ppm).

Note: The scale m in the seven parameters is different from the scale t in the four parameters. The
 two can be transformed into each other. The conversion relationship is m = (t - 1.0) * 1e6. Assumi
ng t is 0.9999988, then m = (0.9999988-1.0) * 1e6 = -1.2.

The formula of Bursa's seven parameters can be written as follows:

The seven-parameter model can be converted into 3D affine transformation parameters, and the
conversion relationship is:

Dx = Dx;
Dy = Dy;
Dz = Dz;
Rx(″) = Rx(″);
Rx(″) = Rx(″);
Rx(″) = Rx(″);
Mx(ppm) = m(ppm);
My(ppm) = m(ppm);



Mz(ppm) = m(ppm);

3D affine transformation:

Dx, Dy, Dz (m, default value is "0"): Values (panning values) added to X, Y, Z.
Mx, My, Mz (ppm, default value is "0"): Scale factors applied to X, Y, and Z. It has the same
definition as the scale factor m in the seven parameters.
Rx, Ry, Rz (second, default value is "0"): The angle of rotation about the X, Y, and Z axes in
degrees.

Tips: the number of digits after The decimal point must be at least 8 in oder to reach mm-level
accuracy.

Four parameters (displayed as two-dimensional transformation parameters): Two-dimensional
transformation parameters, also known as XYMultiply.

Two-dimensional transformation parameters can be expressed in the following formula:

Among them, Px, Py, Pz, a, b, c, d, e are the transformation parameters, Sx, Sy, Sz are the original
coordinates, and X, Y, Z are the transformed coordinates. This is often used as a 2D Helmert
transformation. The parameters can be converted from four parameters. Assuming that the four
parameters are: Dx, Dy, theta, t, the conversion method is:



Px = Dx;
Px = Dy;
Pz = 0.0;
Define k = t;
Define tRad = theta / 3600.0 / 180 * PI;
Then:
 a = k * cos(tRad);
 b = -k * sin(tRad);
 c = k * sin(tRad);
 d = k * cos(tRad);
 e = 1.0;

Linear transformation: The linear transformation is used to pan and zoom a point cloud. A panning
parameter and a scaling parameter need to be set to the X, Y, Z coordinates, respectively.

Linear transformation is calculated using the following formula:

Among them: Sx, Sy. Sz are the scaling factors for the x, y, and z coordinates. Px, Py, and Pz are the
panning parameters for the x, y, and z coordinates. x, y, and z are the original coordinates, and X, Y, and
Z are coordinates obtained after the linear transformation.

Elevation fitting parameter: It is used to calculate elevation anomalies when xy is known, and then
correct Z.

Plane fitting. The plane fitting formula is ζ = a0 + a1x + a2y; It contains three parameters a0-a2.
Linear interpolation. The linear interpolation formula is ζ = a0 + a1x + a2x² + a3x³; It contains four
parameters a0-a3.
Conicoid Fitting. ζ = a0 + a1x + a2y + a3xy + a4x² + a5y²; It contains six parameters a0-a5.
The formula for the Fitting of the Cubic Bézier Curve and Surface is ζ = a0 + a1x + a2y + a3xy +
a4x² + a5y² + a6x²y + a7xy² + a8x³ + a9y³; It contains ten parameters a0-a9.



 

 



Fitting Geoid Model

Functional Overview

There are mainly three elevation datums involved in surveying: the physical surface of the earth - the
geoidal surface, the mathematical surface of the earth - the reference ellipsoid, and an abstract geoid
surface. These three elevation datums correspond to three commonly used elevation systems, namely:
orthogonal, geodetic elevation and quasi-geodetic elevation system (normal elevation system). The
relationship between these elevation datums is shown in the following figure. The elevation system
currently used in China is the normal elevation system, while the GPS elevation is usually the geodetic
elevation system. Since the reference ellipsoid does not coincide with the geoid, there is an elevation
anomaly between the geodetic height and the normal height. The so-called GPS height fitting is the
process of obtaining the abnormal height and then obtaining the normal height to establish a geoid
surface. Analytical interpolation is the most commonly used method for elevation fitting. The main idea is
to approximate the quasi-geoid with a curved surface to establish the closest quasi-geoid in the survey
area, so as to calculate the elevation anomaly of any point in the survey area. But the analytical
interpolation method requires that the height difference of the combined measurement points should not
be too large, and the distance between the two points should not be too long, otherwise the terrain
fluctuation between these points cannot be truly reflected.

The elevation fitting function mainly uses the geodetic height and normal height to solve the elevation
anomaly process. LiDar360 currently supports four elevation fitting methods. They are plane fitting, linear
interpolation, Conicoid fitting and cubic surface fitting. When choosing these mathematical models, first
consider the distribution of GPS points (control points) and terrain conditions. Depending on the method
and formula used, the minimum number of control points required for elevation fitting varies. These four
methods all calculate the fitting parameters according to the least squares solution.

Plane Fitting: At least 3 pairs of control points are required. The plane fitting method can be used in
a small area or in a plain area to quickly obtain the required parameters with a small number of
control points.

The plane fitting formula is ζ = a0 + a1x + a2y;
Polynomial Curve Fitting. At least 4 pairs of control points are required. This method can be used if
the GPS points are distributed in a line, and the geoid-like surface along the line is a continuous and
smooth curve. But when using this method, the measured line should not be too long (usually
controlled within 300 meters). If the fitting range is too large, the abnormal elevation changes of the
points will be more complicated, and the resulting fitting errors will be larger.

The linear interpolation formula is ζ = a0 + a1x + a2x² + a3x³;
Quadric Surface Fitting. At least 6 pairs of control points are required. In the small area GPS
network, the geoid is regarded as Conicoid, and the elevation anomaly is expressed as a quadratic



function of plane coordinates (x, y). The parameters are then fitted by least squares. Then each
parameter is fitted by the least square method.

Conicoid fitting formula is ζ = a0 + a1x + a2y + a3xy + a4x² + a5y²;
Trigonometric Fitting requires at least 10 pairs of control points. The principle is similar to Conicoid
fitting, which expresses the elevation anomaly as a cubic function of plane coordinates (x, y).

The cubic surface fitting formula is ζ = a0 + a1x + a2y + a3xy + a4x² + a5y² + a6x²y + a7xy² +
a8x³ + a9y³;

Usage

Click Data Management > Projection and Coordinate Conversion > Elevation Fitting

Parameters Settings

Altitude Fitting Model: The four above-mentioned elevation fitting models can be selected from the
drop-down menu. After you switch models, the formulas used by that model are also switched and
displayed on the interface.
Input Control Points: Import control point files in ascAll format. The control point file that needs to be
selected must contain at least four columns, namely X, Y, geodetic height, and normal height. The
imported control points will be displayed on the interface in the form of a table. The first column is
"Whether it is a checkpoint". When this column is checked, the control point will be used for checking
and not participating in the fitting. The number of control points involved in the fit must meet the
minimum number of control points required for the elevation fit model. The control points participating
in the fitting will be used to calculate the "inner coincidence accuracy", and the control points used for
checking will be used to calculate the "outer coincidence accuracy". The same formula used for the
accuracy of the inside and outside is: μ=√[VV]/(n-1) .
Report: Use control points to perform elevation fitting and display the fitting results and accuracy
assessments on the interface. The report can be saved in html format.
Define Transformations: Use control points to perform elevation fitting and save the fitting results for
next use. Refer to creating a transformation relationship.



Clip
The clipping tools include Clip by Circle, Clip by Rectangle and Clip by Polygon.

Clip by Circle

Clip by Rectangle

Clip by Polygon



Point Cloud Conversion
Point Cloud Format Conversion Tool Provides Conversion Between Point Cloud and Other File Formats.

Convert to ASCII

Convert to TIFF

Convert to Shape

Convert to DXF

Convert to Las

Convert to E57

Convert LiData to LiData

Convert Las to LiData



Convert to ASCII

Summary

The Convert to ASCII tool can convert the LiData point cloud to ASCII format, a text format that can be
easily viewed in a text editor.

Usage

Click Data Management > Conversion > Convert to ASCII

Settings

Input Data: The input file can be a single point cloud data file or multiple data files. File Format:
*.LiData.
Attributes to Export: Users can select the attributes that need to be exported. All Las attributes are
supported.
Export Format: LiDAR360 supports two suffix formats: txt and csv, and support separators are:
commas, spaces and TAB.
Output path: Path of the output folder. After the conversion is executed, the converted new file(s) will
be generated.



Convert to TIFF

Summary

The Convert to TIFF tool can convert LiData point cloud data to raster images according to the Attribute
of the points in Cell Value method.

Usage

Click Data Management > Conversion > Convert to TIFF

Settings

Input Data: The input file can be a single point cloud data file or multiple data files. File Format:
*.LiData.
XSize (m, default value is "2"): The X pixel resolution of the output raster.
YSize (m, default value is "2"): The Y pixel resolution of the output raster.
Attribute (default is "Z"): Select the point attribute used to calculate the raster cell value.

Z (default): Generate the raster data using the Z value of the point cloud data.
Intensity: Generate raster data using the intensity values of the point cloud data.
Scan angle: Generate raster data using the scan angle of point cloud data.
Return number: Generate raster data using the return number of the point cloud data.
Number of returns of given pulse: Raster data is generated using the number of returns of
given pulse of the point cloud data.

Cell value: Choose how to fill raster pixel values.
Minimum (default): Use the smallest attribute value as the value of a raster cell.
Average: Use the average of attribute values of all points within a raster cell as its value.
Maximum: Use the largest attribute value as the value of a raster cell.

Merge files into one: Users can set merging all raster into one data file. If not checked, each point
cloud data will be generated into a separate raster file.
Output path: Path of output folder. After the function is executed, the converted new file is generated.



Convert to Shape

Summary

The Convert to Shape tool can convert point cloud files in LiData format to point files in vector format.

Usage

Click Data Management > Conversion > Convert to Shape

Settings

Input data: The input file can be a single point cloud data file or multiple data files. File Format:
*.LiData.
Attributes to Export: Users can select the attributes that need to be exported, and all Las attributes
are supported. The selected attributes will be written in the attributes of the shape file data.
Output path: Path of the output folder. After the conversion being executed, the converted new file
will be generated.



Convert to DXF

Summary

The Convert to DXF tool can convert LiData format point cloud files to point vector data in DXF format.
LiDAR360 software exports DXF files in ASCII format.

Usage

Click Data Management > Conversion > Convert to DXF

Settings

Input Data: The input file can be a single point cloud data file or multiple data files. File Format:
*.LiData.
From Class: Source class (es), supports up to 256 different classes.
Tile: Since the amount of point cloud data is often large, the software provides an optional tile mode
that can split the input data file to a number of tiles.

No Tile: Export a single DXF file.
Tile by Rows and Columns: According to the boundary of the point cloud data, the point cloud
will be split into a total number of rows * columns data blocks evenly, and a single DXF file will be
generated.

Rows (default value is "3"): User-defined number of rows that the point cloud want to be
split into.
Columns (default value is "3"): User-defined number of columns that the point cloud want
to be split into.

Tile by Width and Height: The point cloud will be split into a number of tiles from the lower left
corner by the specified width and height, one DXF file per block.

Width (m, default value is "100"): User-defined block width.
Height (m, default value is "100"): User-defined block height.



Output path: Path of the output folder. After the conversion being executed, the converted new file(s)
will be generated.



Convert to Las

Summary

Convert to Las can convert point clouds in LiData format to LAS format, namely the standard Lidar point
cloud data format.

Usage

Click Data Management > Conversion > Convert to Las

Settings

Select Input File: The input file can be a single point cloud data file or multiple data files. File Format:
*.LiData.
Attributes to Export: Users can select the attributes that need to be exported. All Las attributes are
supported.
RGB Range: There are three options for the RGB range.

none：Output according to the original RGB range of the selected file.
0~255 (8 bits): Output with the RGB mapped to 0~255. If the color range of the file selected is
0~1 or 0~65535, it can be mapped to 0~255 for output.
0~65535 (16 bits)：Output with the RGB mapped to 0~65535. If the color range of the file
selected is 0~1 or 0~255, it can be mapped to 0~65535 for output.

Source Unit: The unit of the LiData to be exported as LAS file. As the only supported unit in
LiDAR360 is meters currently, this option is fixed as "meter".
Target Unit: The unit of the exporting LAS file. Choose from meters, decimeters, centimeters,
millimeters, feet, and inches.
LAS Version (Default value is 1.4): The version of the exporting LAS file. Choose from 1.2 to 1.4.



Please refer to LiData Format for details. When exporting from a higher version to a lower version, the
exceeded field range limitation will be set as 0.
Output Path: Path of the output folder. After the conversion being executed, the converted new file(s)
will be generated.



Convert to E57

Functional Overview

Convert to E57 can convert point clouds in LiData format to E57 format.

Usage

Click Data Management > Point Cloud Conversion > Convert to E57

Parameters Settings

Select Input File: The input file can be a single point cloud data file or multiple data files. File Format:
*.LiData.
Attributes to Export: Users can select the attributes that need to be exported. The basic and
additional attributes are supported.
Output Path: Path of the output folder. After the conversion being executed, the converted new file(s)
will be generated.



Convert to PLY

Functional Overview

Convert to PLY can convert point clouds in LiData format to PLY format.

Usage

Click Data Management > Point Cloud Conversion > Convert to E57

Parameters Settings

Select Input File: The input file can be a single point cloud data file or multiple data files. File Format:
*.LiData.
Attributes to Export: Users can select the attributes that need to be exported. The basic and
additional attributes are supported.
Output Path: Path of the output folder. After the conversion being executed, the converted new file(s)
will be generated.



Convert LiData to LiData

Summary

Convert the version of LiData file. Currently, the tool supports the conversion between LiData 1.9 and
LiData 2.0. LiData 2.0 supports the additional attributes and expands the scope of some attribute fields
(i.e., the number of classes has been expanded from 32 to 256). It is required to use LiData 2.0 file to run
some of the functions, i.e., change detection, deviation analysis.

Usage

Click Data Management > Conversion > Convert LiData to LiData

Settings

Input Data: Input data could be one or more point cloud files. File format: *.LiData.
LiData Version (2.0 by default): The version of output LiData file. It is supported to export LiData in
the version of 1.9 or 2.0.



Convert Las to LiData

Summary

Convert to LiData can convert point cloud data in LAS or LAZ formats to LiDAR360 customized point
cloud format (LiData format).

Usage

Click Data Management > Conversion > Convert Las to LiData

Settings

File List: Import the file that needs to be converted. The file formats currently supported are : .las,
.laz. Users need to click  to select the point cloud data; users can select one or more file(s) in the
existing list and click  to delete them from the list; users can click  to remove all files in the list.
Attributes to Export: Users can select the attributes that need to be exported. All Las attributes are
supported.
Source Unit: The unit of the importing point cloud file. Choose from meter, decimeters, centimeters,
millimeters, feet, and inches.
Target Unit: The unit of the exporting LiData. As the only unit supported in LiDAR360 is meter, this
option is fixed as "meter".
LiDAR Version (The most updated version of LiData by default): The version of the exporting
LiData. Choose from 1.9 and 2.0

Note: LiData 2.0 supports all the features of LAS 1.4. LiData 1.9 is mainly used to support LAS
1.0 to LAS 1.3. Please refer to LiData Format for details. When exporting from a higher version to
a lower version, the exceeded field range limitation will be set as 0.

Coordinate Transformation: Please refer to Import Data.



Output Path: Path of the output folder. After the conversion is executed, the converted new file(s) will
be generated.



Raster Conversion
Raster format conversion tool provides conversion between raster data and other file formats.

Convert TIFF to LiModel

Convert to Texture LiModel

Convert TIFF to LiData

Convert TIFF to ASCII



Convert TIFF to LiModel

Summary

Convert TIFF to LiModel tool can convert single-band raster data (DEM, DSM, CHM, etc.) to LiModel
format. The LiModel format is a LiDAR360 software customized format that allows the converted single-
band raster data to be displayed and edited in a 3D window.

Usage

Click Data Management > Conversion > Convert TIFF to LiMode

Settings

Input Tiff File: Users can select the file to be processed from the drop-down list.
: Users can add files to be converted that have not been opened.
: Users can select a file in the list and click this button to remove the file from the list.
: Click this button to clear all files in the list.

Output path: Path of the output folder. After the conversion being executed, the converted new file(s)
will be generated.



Convert to Texture LiModel

Summary

Convert to Textured LiModel tool is based on the Convert Image to LiModel tool, which maps color values
of a DOM data to the LiModel model for display. This function only supports single file data conversion.

Usage

Click Data Management > Conversion > Convert to Texture LiModel

Settings

Input DEM: Users can select a file to be converted from the drop-down list or use the button 
 to load an external data file. Single-band raster data is required.

Input DOM: Users can select a desired file from the drop-down list or use the button  to
load an external data file. The selected color image needs to have at least three bands.
Output LiModel: Path of the output file. After the conversion being executed, the converted new file
will be generated.



Convert TIFF to LiData

Summary

Convert TIFF to LiData tool can convert single-band raster data (DEM, DSM, CHM, etc.) to LiData. This
tool is particular useful when the users can harldy acuquire point clouds in a certain area but have
accurate raster products.Tthis function can help to simulate the point cloud data in that region missing
LiDAR points.

Usage

Click Data Management > Conversion > Convert TIFF to LiData.

Settings

Input TIFF File: Users can select the files need to be processed from the drop-down list. The files will
be added to the list of files to be processed.

: Users can insert external files to be processed.
: Users can select one file in the list of files to be processed, and click this button to remove this file

from that list.
: Click this button to clear the list of files to be processed.

Select Sampling Center: Users can choose either the corner (default) or the center points of the
pixels as the sampling center.
Output Path: Path of output folder. After the function is executed, the converted new file is
generated.



Convert TIFF to ASCII

Summary

Convert TIFF to ASCII tool can be used to convert TIFF format raster images to files in ASCII format.

Usage

Click Data Management > Conversion > Convert TIFF to ASCII

Settings

Input Tiff File: Users can select the file to be processed from the drop-down list.
: Users can add external file(s) to be converted.
: Users can select one or files in the list and click this button to remove them from the list.
: Click this button to clear all files in the list.

Output path: Path of the output folder. After the conversion being executed, the converted new file(s)
will be generated.



Model Conversion
Model Conversion tool provides conversion between model files and other format.

Convert LiModel to TIFF

Convert LiTin to DXF

Convert LiBuilding to OBJ

Convert LiBuilding to FBX

Convert LiBuilding to CityJson



Convert LiModel to TIFF

Summary

Convert LiModel to TIFF tool converts LiModel format files to raster images in TIFF format. After editing
LiModel data, users can use this function to convert the data to TIFF format.

Usage

Click Data Management > Conversion > Convert LiModel to TIFF

Settings

Input LiModel File: User can select a file to be processed from the drop-down list.
: Users can add external data files to be converted.
: Users can select a file in the list and click this button to remove the file from the list.
: Click this button to clear all the data in the list.

Output path: Path of the output folder. After the conversion being executed, the converted new file
will be generated.



Convert LiTin to DXF
Convert the TIN in LiTin format to Drawing Exchange Format, or DXF format.

Usage

Click Data Management > Conversion > LiTin to DXF.

Settings

File List: Input the TIN files to be converted. The supported format is LiTin. Users can click  to add
external data, or users can select the file in the file list and click  button to remove the file from the
list. Click  button to clear all the files from the file list.
Output Path: select the output path to store the newly generated DXF file.



Convert LiTin to FBX

Functional Overview

Convert TIN data in LiTIN format to FBX format model files.

Usage

Click Data Management > Model Conversion > Convert LiTin to FBX.

Parameters Settings

File List: Input the TIN file that needs to be converted. The currently supported formats are: *.LiTin.
Users need to click the  button to add the data files waiting for conversion from outside; Users can
select a file data in the list and click the  button to remove it from the list. Clicking on  this button
clears all data in the list.
Output Path: Select an output directory path, and after algorithm execution, generate corresponding
FBX files.



Convert LiTin to LiData

Functional Overview

Convert TIN data in LiTIN format to LiData point cloud file.

Usage

Click Data Management > Model Conversion > Convert LiTin to LiData.

Parameters Settings

File List: Input the TIN files that need to be converted. The currently supported formats are: *.LiTin.
Users need to click the  button to add the data files for conversion from external sources. Users
can select a file from the list and click on the  button to remove it from the list. Clicking on  will
clear all data in the list.
Output Path: Select an output directory path for generating corresponding LiData point cloud files
after algorithm execution.



Convert LiTin to OBJ

Functional Overview

Convert TIN data in LiTIN format to OBJ format model files.

Usage

Click Data Management > Model Conversion > Convert LiTin to OBJ.

Parameters Settings

File List: Input the TIN file that needs to be converted. The currently supported formats are: .LiTin.
Users need to click the  button to add the data files for conversion from external sources. Users
can select a file from the list and click on the  button to remove it from the list. Clicking on  will
clear all data in the list.
Output Path: Select an output directory path for generating corresponding OBJ files after algorithm
execution.



Convert LiBIM to OBJ
Convert LiBIM format data into standard 3D model file in .obj format.

Usage

Click Data Management > 3D Building Tools > Convert LiBIM to OBJ.

Parameters Settings

File list: Input LiBIM files to be converted. Users need to click the button  to add the file data to be
converted from outside; Users can select a file in the list and click  button to remove the file from
the list. Click  button to clear all the data in the list.
Output path: Select the path of the output file directory. After the algorithm is executed, the
corresponding obj file is generated.



Convert LiBIM to FBX
Convert LiBIM format data into standard 3D model file in .fbx format.

Usage

Click Data Management > 3D Building Tools > Convert LiBIM to FBX.

Parameters Settings

File list: Input LiBIM files to be converted. Users need to click the button  to add the file data to be
converted from outside; Users can select a file in the list and click  button to remove the file from
the list. Click  button to clear all the data in the list.
Output path: Select the path of the output file directory. After the algorithm is executed, the
corresponding fbx file is generated.



Convert LiBIM to CityJSON
Convert LiBIM format data into standard city.json format file.

Usage

Click Data Management > 3D Building Tools > Convert LiBIM to CityJSON.

Parameters Settings

File list: Input LiBIM files to be converted. Users need to click the button  to add the file data to be
converted from outside; Users can select a file in the list and click  button to remove the file from
the list. Click  button to clear all the data in the list.
Output path: Select the path of the output file directory. After the algorithm is executed, the
corresponding city.json file is generated.



Vector Conversion
Vector Conversion Tool Provides Mutual Conversion of Vector Format Files.

Convert Shape to KML

Convert KML to Shape



Convert Shape to KML
The data in shape format will be converted to KML format. KML format
reference：https://wiki.openstreetmap.org/wiki/KML

Usage

Click Data Management > Conversion > Convert Shape to KML.

Settings

Input Shape File： Users can select the files need to be processed from the drop-down list. The files
will be added to the list of files to be processed.

：Users can insert external files to be processed.
：Users can select one file in the list of files to be processed, and click this button to remove this

file from that list.
：Click this button to clear the list of files to be processed.

Output Path：Path of output folder. After the function is executed, the converted KML file is
generated.

https://wiki.openstreetmap.org/wiki/KML


Convert KML to Shape
The data in KML format will be converted to shape format. KML format
reference：https://wiki.openstreetmap.org/wiki/KML

Usage

Click Data Management > Conversion > Convert KML to Shape.

Settings

Input KML File： Users can select the files need to be processed from the drop-down list. The files
will be added to the list of files to be processed.

：Users can insert external files to be processed.
：Users can select one file in the list of files to be processed, and click this button to remove this

file from that list.
：Click this button to clear the list of files to be processed.

Under Geographic Coordinate System: Check this option to convert the geographic coordinates in
the kml file to projected coordinates during export to shp. For the selection of projected coordinate
system, refer to Define Projection
Output Path：Path of output folder. After the function is executed, the converted Shape file is
generated.

https://wiki.openstreetmap.org/wiki/KML


Vector Format Conversion

Summary

Convert vector data among gpkg, dxf, and shp formats.

Usage

Click Data Management > Vector Conversion > Vector Format Conversion.

Settings

File List: Input the vector files that need to be converted. Users need to click the button  to add the
file data that needs to be converted from outside. Users can select a file data in the list and click the 

 button to remove it from the list. Clicking on  this button clears all data in the list.

Output format

Gpkg: Output vector files in gpkg format.

Dxf: Output vector files in dxf format.

Shp: Output vector files in shp format.

Merge into one file: If selected, convert all files in the list into one output format of a vector file;
otherwise, each file is converted into an output format of a selected output type.

Output path: Selects the directory path for outputting files. After conversion is complete,
corresponding vector files are generated.



Extract
The extraction tool can filter the data based on several criteria and generate new data files.

Extract by Class

Extract by Elevation

Extract by Intensity

Extract by Return

Extract by GPS Time

Extract by Additional Attributes

Extract by Segmentation



Extract by Class

Summary

Extract by class tool can extract all the point cloud data of the user-selected class, and save the data in
one file. This function supports multiple file operations.

Usage

Click Data Management > Extract > Extract by Class

Settings

Input Data: Input one or more point cloud data files. File Format: *.LiData.
From Class: Users need to select the class to be extracted from the drop-down list. The unavailable
status in the drop-down list represent the corresponding category that does not exist in the file.
Output path: Path of the output folder. After the function being executed, the extracted new file(s) will
be generated.



Extract by Elevation

Summary

Extract by Elevation tool can extract the point cloud data in the user-defined elevation range to a file. This
function supports multiple file operations.

Usage

Click Data Management > Extract > Extract by Elevation S

Settings

Input Data: Input one or more point cloud data files. File Format: *.LiData.
Min (m, default value is "100"): Users need to enter the minimum elevation value of the point cloud
data to be extracted.
Max (m, default value is "200"): Users need to enter the maximum elevation value of the point cloud
data to be extracted.
Output path: Path of the output folder. After the function being executed, the extracted new file(s) will
be generated.



Extract by Intensity

Summary

Extract by Intensity tool can extract all the point cloud data within the user-defined intensity range. This
function supports multiple file operations.

Usage

Click Data Management > Extract > Extract by Intensity

Settings

Input Data: Input one or more point cloud data files. File Format: *.LiData.
Min (default value is "100"): Users need to enter the minimum intensity value of the point cloud data
to be extracted.
Max (default value is "200"): Users need to enter the maximum intensity value of the point cloud
data to be extracted.
Output path: Path of the output folder. After the function being executed, the extracted new file(s) will
be generated.



Extract by Return

Summary

Extract by Return tool can extract all the point cloud data of the user-defined return number, and saved
the data in a file. This function supports multiple file operations.

Usage

Click Data Management > Extract > Extract by Return

Settings

Input Data: Input one or more point cloud data files. File Format: *.LiData.
Return number: Users need to select the return number of the point cloud data to be extracted. Click
on the drop-down menu to select the return number, including: first return, last return, 2nd return, 3rd
return, 4th return, and returns after 4th.
Output path: Path of the output folder. After the function being executed, the extracted new file(s) will
be generated.

Note: If the data does not have the return number selected by the user, the extraction will not be
executed.



Extract by Time

Summary

Extract by GPS time tool can extract all the point cloud data within the user-defined GPS time range, and
save them in a file.

Usage

Click Data Management > Extract > Extract by Time

Settings

File List: Select the file to be processed from the drop-down list.
Min Time: Displays the minimum GPS time value in the point cloud file selected by the user. This
value does not require user settings.
Max Time: Displays the maximum GPS time value in the point cloud file selected by the user. This
value does not require user settings.
Start Time (default value is "min Time"): Input the minimum GPS time value of the point cloud data
to be extracted.
End Time (default value is "max Time"): Input the maximum GPS time value of the point cloud data
to be extracted. This value must be larger than the start time.

: If you want to extract the point cloud at a specified interval, enter the interval value in the text box,
and then click this button, the values of the start time and end time will increase at the set interval.

: Add the input time range to the range list. All point cloud data in the time range will be extracted
into one file.

: Users can click this button to load external GPS range file. The time range in the file needs to be
between the min Time and the max Time. The file format can be referred to the appendix for
information in the GPS time extract file format.

: Users select a row in the time range list and click this button to remove the row from the list.



Output Path: Path of the output folder. After the function being executed, the extracted new file will
be generated.



Extract by Additional Attributes

Functional Overview

The Extract by Additional Attributes tool can extract point clouds based on the user-selected names,
components, and extents of additional attributes. Additional properties support one or more components.
Currently only the processing of a single point cloud is supported.

Usage

Click on Data Management > Extract > Extract by Additional Attributes

Parameters Settings

Point cloud Data: Select the point cloud data file, currently only one point cloud data is supported.
File format: *.LiData.
From Additional Attribute: User needs to select the attached property name for filtering from the
checkbox. This function cannot be run if the point cloud data does not contain additional attributes.
Component Selection: supports one component or multiple components, the number of components
depends on the additional properties of the point cloud. Each component corresponds to an optional
set of ranges. The point cloud and additional attributes within the range will be extracted to generate a
new point cloud file.
Output Path: The path of the extracted output file after the function is executed.



Extract by Segmentation

Functional Overview

The Extract by segment tool extracts point clouds based on user-selected ranges of integer single-
component additional attributes. This feature currently only supports the processing of a single point
cloud.

Usage

Click Data Management > Point Cloud Tools > Extract by segment

Parameters Settings

Point Cloud: Select the point cloud data file, currently only one point cloud data is supported. File
format: *.LiData.
Select Label: The user needs to select the additional attribute name from the checkbox as the label.
The label must be integer but component. This function cannot be run if the point cloud data does not
contain additional attributes of integer single component. The selected additional attributes will be
used as tags, and points with the same tags will be extracted as a file. Assuming that LiData contains
an integer single-component additional attribute A,in which the A attribute value of 10 points is "1",
and the A attribute value of 20 points is “2”,then the function will generate two files C after running.
(including 10 points, the attribute is "1") and D (including 20 points, the attribute is "2");
Range Selection: Select the range of labels. Only point clouds whose labels are within this range are
extracted.
Export Format: The format for exporting point clouds, currently DXF and Las are supported.
Output Path: The path of the extracted output file after the function is executed.



Statistics
LiDAR360 can be used for statistical analysis of point cloud data and raster data.

Grid Statistics

Volume Statistics

Raster Statistics



Grid Statistics

Functional Overview

LiDAR360 supports fast grid statistics analysis on point cloud data. The tool supports meshing of point
cloud data to count the number of points, density, and Z attributes in the grid. It can be used to view the
point cloud data flight and processing quality, as well as analyze the geographical features of the flight
area. If only one type of data in point cloud data is counted, the Extract tool can be used to extract point
clouds and perform statistics.

Steps

1. Select the point cloud data file to analyze from the Data List drop-down box.
2. Select Variable to be analyzed. Users can select the variablesZ to be analyzed from the drop-down

box.
3. Set Spacing size.
4. Click the Calculate button.
5. Click Draw Histogram to view the histogram of the grid statistics. (Optional) You can also use

Stretch method to stretch the histogram.
6. (Optional)Users can click Save Histogram to save the displayed histogram as a PDF file.
7. (Optional) Users can click Save Grid to save the statistics grid as a single-band grayscale image, or

select Color Bar and click Save GeoTiff to map single-band grayscale images to multiband color
images. It should be noted that if the user selects Stretch action, the single-band image will be
mapped after stretching.

Usage

Click Statistics > Grid Statistics



Parameters Settings

Data List: Users need to select point cloud data to be counted from the drop-down list.
Variable: Users need to select the variable to be analyzed from the drop-down list. Fill the statistic
value of the variable in the grid.

Number of Points (default): Count the number of points in the grid.
Density: Calculate the density of the point cloud within the grid, which is obtained by dividing the
number of points by the grid area.
Z: To calculate the user-defined Z-value of the point cloud in the grid, users need to select the
statistics list.

Statistics: If you select Z variable in the Variable list, users need to select the statistical method for Z
variable.

Minimum (default): The minimum value of Z variable in the statistics grid.
Maximum: The maximum value of Z variable in the statistics grid.
Mean: The average value of Z variable in the statistics grid.
Range: The range of Z variable in the statistics grid (range = maximum - minimum).
Deviation: The standard deviation of Z variable in the statistics grid.

Spacing (m, default value: "1"): The size of the statistics grid.
Calculate: After setting the parameters, click this button to calculate.
Save Grid: Save the statistics grid as a single- band grayscale image in the format of .tif or .csv.
Stretch: Users can choose whether to stretch Draw Histogram or Save GeoTiff.

None (default): Do not perform any stretching operation.
Minimum and Maximum: Use the maximum and minimum values of the statistical grid data for



stretching. Linear stretch is applied based on the minimum and maximum pixel values, which will
be regarded as the endpoints of the histogram. For example, the minimum and maximum values
of a image are 2488 and 2656, linear stretch will rearrange the values based on a linear equation
calculated from the maximum and minimum values to re-distribute pixel values from 0 to 255.

Minimum (default value is the minimum of the grids): The minimum value of the stretch.
Maximum (default value is the maximum of the grids): The maximum value of the
stretch.

Std Deviation: The stretching operation is performed using the standard deviation of the
statistical grid data. The quasi-difference stretch type applies the linear stretching to the
maximum value (maximum = mean + n standard deviation) and minimum value (minimum =
mean - n standard deviation).

n: The multiple of the standard deviation.
Percent Clip: Percent stretch uses statistical grid data. Percent Stretch applies a linear
stretch between the pixel values of the minimum and maximum cropping percentages.
For example, the minimum and maximum values of a image are 2488 and 2656
respectively, and the user-defined minimum and maximum values of clipping
percentage are 0.02 and 0.98 respectively. Values less than 0.02 stand for values
between 2488 and 2492, and values above 0.98 stand for values between 2652 and
2656. The value between 2488-2492 will become 0, while the value between 2652-2656
will become 255. Other values will be distributed between 0-255.

Minimum: The minimum stretch percentage, range 0~1.0.
Maximum: The maximum stretch percentage, range 0~1.0.

Draw Histogram: Draw a histogram of grid statistics in the canvas.
Save Histogram: Save the drawn histogram in the PDF format.
Color Bar: LiDAR360 provides 11 color bar options for users to choose.
Save GeoTiff: Save statistical grid data as a multi-band color image based on the user-selected
Color Bar.
Close: Close the tool.

Note: The Save Grid function saves the original statistical result as a single-band TIFF file. Save GeoTiff
function saves the result after histogram stretch and performs RGB three-channel mapping according to
the selected color bar.



Volume Statistics

Summary

LiDAR360 supports the use of surface model data (single-band tif data) with spatial overlaps to calculate
volume statistics. By subtracting the lower surface from the upper surface, the statistical filling amount
(Fill), excavation amount (Cut ) and total fill volume (Total) (calculated by subtracting fill volume from
volume of excavation) can be obtained.

Usage

Click Statistics > Volume Statistics

Settings

Upper Surface: Users can select the *.tif format file from the drop-down list, or click  to
select external file.
Lower Surface: Users can select the *.tif fornat file from the drop-down list or click  to
select external file.
Output Statistics: Specify the path to output the statistical result as a *.txt format file. The file
contains the path of the upper and lower surface files, spatial resolution, XSize, YSize, and the
amount of the filler.

Note: The upper and lower surface files are single-band data, they must have the same spatial
resolution and the spatial ranges have intersections. The unit of the point cloud data processed by
LiDAR360 is meter, and the calculated fill volume, excavation volume, and total amount are in cubic
meter.



Raster Statistics

Summary

This function can perform neighborhood calcuation for each cell in a tif format raseter data. The output can
be different kinds of statistics of the neighborhood. The statistics include mean, maximum, minimum,
range, standard deviation, and sum.

Usage

Click Statistics > Raster Statistics

Settings

Statistics Type ("Mean" by default): Users can choose any type of statistics in the drop-down
menu. The statistics include mean, maximum, minimum, range, standard deviation, and sum.

Mean: Calculate the mean value for the neighborhood of each cell to be as the value of the cell
at the same location as the orignal cell.

Maximum: Calculate the maximum value for the neighborhood of each cell to be as the
value of the cell at the same location as the orignal cell.
Minimum: Calculate the minimum value for the neighborhood of each cell to be as the value
of the cell at the same location as the orignal cell.
Range: Calculate the range for the neighborhood of each cell to be as the value of the cell at
the same location as the orignal cell.
STD: Calculate the standard deviation for the neighborhood of each cell to be as the value of
the cell at the same location as the orignal cell.
Sum: Calculate the sum for the neighborhood of each cell to be as the value of the cell at
the same location as the orignal cell.

Neighborhood Settings: Settings of the neighborhood size.
Height: Height of the neighborhood.
Width: Width of the neighborhood.

Ignore NoData in Calculation (Checked by default): If this option is checked, the software will will
ignore the NoData cells in the neighborhoods during the calcuation. If this option is not checked,
software will define the cell with NoData in its neighborhood as NoData. If this option is checked, for
those NoData cells, the software will calcuate the statistics with the values from their neighborhoods.



If the all the cells in the neighborhood of a cell are NoData, whether or not this option is checked, this
cell will be defined as NoData during the calculation.
Output Result: The path for the result of raster statistics.



Classification
LiDAR360 can be used to classify unclassified point cloud, or to reclassify points that have already been
classified.

Slope Filter

Conicoid Filter

Classify Ground Points

Classify Ground Points by CSF

Extract Median Ground Points

Classify by Attribute

Classify by Additional Attributes

Classify Low Points

Classify Below Surface Points

Classify Isolated Points

Classify Noise Points

Classify Air Points

Classify by Height Above Ground

Classify by Min Elevation Difference

Classify Closeby Points

Classified by Region

Classify Buildings

Classify Model Key Points

Classify Water Points

Classify by Machine Learning

Classify by Trained ML Model

Classify Ground by Selected

Classify by Deep Learning

Custom Deep Learning Classification

Classify by Interactive Edit



Slope Filter

Summary

As the name implies, this filtering method extracts terrain based on changes in point cloud slope.
Therefore, its drawbacks are as follows: sensitive to slope change, not reliable in steep areas, and easy to
flatten the convex parts on the terrain. This method is more suitable for areas with smooth terrain
changes, in that case, the filtering efficiency is high. Click this button, and the dialog as shown below pops
up.

Settings

From Class: Source class (es).
To Class: Target class.
Slope Threshold (°, default value is"30"): The maximum slope threshold of the slope between grid
point and its 8 neighborhood grids. If it is larger than the threshold, it is classified into non-ground
points, and vice versa.
Grid Size (m, default value is"1"): The side length of the grid. In addition, a 3 * 3 grid composes a
filter window.



Conicoid Filter

Summary

Ground points are classified by fitting quadric surfaces. The specific idea is: first, mesh the point cloud,
select the lowest point of the grid within a certain size window to construct the quadric surface, and
compare the distance between the point cloud and the fitting surface in the calculation window and the set
distance threshold, which is less than this Thresholds are classified as ground points; otherwise, they are
classified as non-ground points. This method is suitable for undulating terrain, but not very steep areas.
Click this button, and the dialog as shown below pops up.

Settings

From Class: Source class (es).
To Class: Target class.
dz Tolerance (m, default value is"0.3"): After fitting the surface using the grid low point, calculate
the height difference between each unclassified point and the surface. If the height difference is
greater than the threshold, the unclassified point is classified as non-ground point. Otherwise, it’s
classified as ground point.
Grid Size (m, default value is"1"): The size of the grid that meshes the point cloud. The smaller the
grid size, the finer the ground will be fitted, which keeps more details, but the filter efficiency will be a
bit affected.
Window Size (default value is"3"): This function uses a moving window to fit the surface, so the
window size directly affects the final filtering result. The larger the window, the larger the area where
surface is fitted each time. The grid size and window size need to complement each other for best
results.



Classify Ground Points

Summary

Ground points classification is an important operation of point cloud preprocessing, which can be
implemented in LiDAR360 with an improved progressive TIN densification filtering algorithm (Zhao et
al.,2016).

The algorithm first generates a sparse triangulated irregular network(TIN) through seed points, and then
iteratively processes layer-by-layer densification until all ground points have been classified. The specific
steps of the algorithm are described as follows:

1. The initial seed point selection. If the point cloud contains buildings, the maximum building size is
taken as the grid size to grid the point cloud, and for the point cloud without the building, the default
value is used as the grid size. Take the lowest point in the grid as the starting seed point.

2. Build a TIN. The initial TIN was constructed using the initial seed point.
3. Iterative densification process. Traverse all the unclassified points, query the triangles that each point

belongs to in the horizontal projection plane; Calculate the distance(d) from the point to the triangle
and the max angle between the point and three vertices with the triangles plane. As shown in the
figure below, the distance and max angle are compared with the Iteration distance and Iteration
angle, separately. If it is less than the corresponding threshold, then the point is classified as a
ground point and added to the triangulation. Repeat this process until all ground points have been
classified.

The flow of algorithm is shown in the figure.



Usage

Click Classify > Classify Ground Points

Settings

Input Data: The input file can be a single point cloud data or a point cloud dataset, which must be
opened in the LiDAR360 software.
From Class: Source class(es).
To Class: Target class.
Scenario (optional): For different terrain scenarios, you can choose flat terrain, gentle slope terrain,



steep slope terrain, and mountain terrain. Check different terrain features, corresponding to different
default parameters.
Max Building Size (m, default value is "20"): The maximum length of the building edge that exists
in the point cloud scan. If this parameter is set too small, the flat roof of the building may be mistaken
for the terrain. When there is a building in the point cloud data, the maximum building size can be
measured by using the Length Measurement in the menu bar. The value of this parameter should be
greater than the measured value. For point cloud data without buildings, this parameter can use the
default value of 20m.
Max Terrain Angle (°, default value is "88"): The maximum slope of the terrain shown in the point
cloud. This parameter can determine whether the points nearby the ground points belong to the
ground or not. Usually, the parameter can be set as default.
Iteration Angle (°, default value is "8"): The allowable range of angles between unclassified points
and ground points. The area with large topographic relief can be appropriately set larger and adjusted
accordingly with the iteration distance. Generally, it is set to 6 to 12 degrees.
Iteration Distance (m, default value is "1.4"): Distance threshold between the unclassified points
and the triangle in the triangle mesh. When the terrain undulations are large, it can be appropriately
enlarged and adjusted accordingly to the iteration angle, which is generally set at 1.2-1.6 meters.
Reduce Iteration Angle When Edge Length < (m, default value is "5", Optional): When the
triangle length of the points to be classified is smaller than the threshold, the iteration angle should be
decreased. If this parameter is checked, it means that when the triangle side length of the point to be
classified in the triangulation network is less than the threshold value, the iteration Angle can be
reduced accordingly to obtain smoother ground points. When a sparse ground point needs to be
obtained, the threshold may be increased accordingly.
Stop Triangulation When Edge Length < (m, default value is "2", Optional): When the triangle
length of the point to be classified corresponds to the length of the triangle is less than the threshold,
the densification of triangulation network is stopped. This value can prevent the locally generated
ground point from being too dense. When this value increase, the ground points will be sparse, and
vice versa.
Only Key Points (Optional): On the basis of ground point filtering, the key points of the model are
further extracted as the ground point category, which can preserve the key points on the terrain and
comparatively extract the points in the gentle ground area. For the specific usage of this function,
please seeClassify Model Key Points.

Note: Because the actual terrain is complex and changeable, when using this function to perform
ground point classification, different parameters needs to be adjusted in order to achieve relatively
ideal results. In addition, the classification result in local area can be reclassified by Classify Ground
by Selected and the Classify by Interactive Editing tool.

    @inproceedings{
        author={Zhao X Q, Guo Q H, Su Y J and Xue B L},
        title={Improved progressive TIN densification filtering algorithm for airborne LiDAR data in forested
 areas},
        booktitle={ISPRS Journal of Photogrammetry and Remote Sensing,117:79-91},
        year={2016}
    }



Classify Ground Points by CSF

Functional Overview

Ground point classification is the basic operation of point cloud data processing. This function
adoptsGround Point Filtering Algorithm Based on Cloth Simulation(Cloth Simulation Filter, IPTD(Zhang et
al.,2016)).

This algorithm can be divided into the following steps:

1. Invert the Z direction of the point cloud. The point cloud is divided into a grid with a certain resolution
in the XY direction, and the nodes of the grid are used as a simulated cloth.

2. Set the initial height of the cloth to the point cloud maximum and start the iteration. During each
iteration, the cloth will "sink" to the point cloud with a certain gravity, and the positional relationship
between the cloth nodes and the point cloud is calculated at the same time. Nodes that have landed
on the point cloud will not be movable during the next iteration. An immovable node will slow the
sinking of surrounding nodes according to the stiffness value r.

3. After a certain number of iterations, calculate the positional relationship between each point and the
cloth; points whose distance from the cloth in the Z direction is less than a certain threshold will be
classified into target categories.

Usage

ClickClassification > Classify Ground Points by CSF.

Parameters Settings

Input Data: The input file can be a single data file or a point cloud data set; the file(s) to be processed
must be opened in the LiDAR360 software.

https://www.researchgate.net/profile/Wuming-Zhang


From Class: Categories to be classified.
To Class: Classification target category.
Scene: There are three types of scenes: steep slope, gentle slope and flat ground.
Grid Size (meters) (default "1.0"): The resolution of the cloth nodes. 1.0 is suitable for most point
clouds. For data with large terrain fluctuations, this value can be appropriately reduced.
Classify Threshold (meters) (default "0.5"): After the iteration is complete, the points whose
distance from the cloth in the Z direction is less than this threshold will be classified into the target
category.
Max Iteration (default "500"): The algorithm completes the iteration when it reaches the maximum
number of iterations or when all cloth nodes are immovable.
Smoothes the Margins of Steep Slopes: When the cloth is located on a steep slope, due to the
internal constraints between the cloth nodes, it cannot fit the ground well, and the algorithm may
generate large errors. Checking this option can eliminate the effects of steep slopes to a certain
extent. If the scene does not contain steep slopes, you can uncheck it.

    @inproceedings{
        author={Zhang W, Qi J, Wan P, Wang H, Xie D, Wang X, Yan G},
        title={An Easy-to-Use Airborne LiDAR Data Filtering Method Based on Cloth Simulation.},
        booktitle={Remote Sensing. 8(6):501.},
        year={2016}
    }



Extract Median Ground Points

Summary

Point clouds generated from data collected by small aircrafts and unmanned aerial vehicles (UAVs)
typically have many ground points and individual point densities in these regions can be very high.
Traditional point cloud filtering methods used to thin these high density regions often produce ground point
subsets with vertical thicknesses that can be measured in centimeters. When these filtered point clouds
are used to create 3D mesh objects (e.g. TINs), the results tend to be poor as the 3D modeled surfaces
have an uneven appearance.

The Extract Median Ground Points tool can be used to obtain a ground point cloud that is thinner and
smoother than those produced using traditional point cloud filtering methods. Generating this type of
ground point cloud allows for consideration of the points found in a denser and thicker ground point cloud.
This method belongs to the optimization step after the initial ground point has been extracted.
Therefore, the point cloud data must first be classified using ground point classification method.
The comparison results before and after using the median ground point classification method are as
follows:

Usage

Navigate to and click on Classify > Extract Median Ground Points



Settings

Input Data: Single or multiple point cloud data files can be input into the tool. Each point cloud must
contain points classified as ground points and have been loaded in the LiDAR360 software.
From Class: Source class(es) that represent ground points or other points are included in the median
ground points finding operation.
From Ground Class to: Classify target ground points that do not meet the median rule to this class.
Min Height (meters, default value is "0.02"): The minimum height above the lowest ground point
elevation found in the input file(s)from which ground points will be taken and used to find the median
ground point elevation. Ground points falling below the Min Height will not be used to find the median
ground point elevation value. The default value is set to 0.02 meters.
Max Height (meters, default value is "0.3"): The maximum height above the lowest ground point
elevation found in the input file(s)from which ground points will be taken and used to find the median
ground point elevation. Ground points falling above the Max Height will not be used to find the median
ground point elevation value. The default Max Height value is set to 0.3 meters.
Grid Size (meters, default value is "0.5"): The grid size defines the horizontal extents of the square
area from which ground points will be extracted from the input file(s)and then used to find a median
ground point elevation value for each grid cell. When the number of points in a grid cell falls below a
user-defined threshold, the median ground point elevation for that grid cell will not be included in the
output dataset. The default Grid Size is 0.5 meters.
Multiples of Std Deviation (default value is"0.3"): The number and thickness of the extracted point
cloud ground points are controlled by the user-defined Multiples of Std Deviation parameter. The
default value is 0.3, which means that 22% of ground points are extracted as ground points.
Moreover, a value of 0.5 Multiples of Std Deviation corresponds to 40% of all points classified as
ground points being extracted. 0, 7 corresponds to 50%, 0.9 corresponds to 62%, and 1.5
corresponds to 86%.
DefaultValue: Click to set all Extract Median Ground Points tool parameters to their default values.

Note: This classification algorithm is only applicable to thicker ground point data scanned by small
aircrafts and unmanned aerial vehicles (UAVs). This data must be classified by ground points first, as
an optimization step.



Classify by Attribute

Summary

This function classifies the point cloud into another class according to their attributes. Currently available
classification attributes include Absolute Elevation, Intensity, GPS Time, Scan Angle, and Return Number.
In addition, the function can restore all classes and/or reclassify the point cloud for undesirable
classification results.

Usage

Click Classify > Classify by Attribute

Settings

Input Data: The input file can be a single point cloud data or a point cloud dataset, which must be
opened in the LiDAR360 software.
From Class: Source class(es).
To Class: Target class.
Choose Attribute: The selected attribute will be used to classify the point cloud.

None (default): The default setting will change all points in the From Class option to To Class.
Absolute Elevation: Classified by elevation range. If the elevation value of a point is between
the specified range, it will be assigned to the To Class.
Intensity: Classified by intensity range. If the intensity value of a point is between the specified
range, it will be assigned to the To Class.
Time: Classified by GPS time. If the GPS time value of a point is between the specified range, it
will be assigned to the To Class.
Angle: Classified by scan angle. If the scan angle value of a point is between the specified
range, it will be divided into the To Class.
Return: Classified by the return number. If the return number at a point is between the specified
range, it will be assigned to the To Class.



Classify Low Points

Summary

The low point refers to the noise point that is lower than the actual terrain. The existence of the low point
will affect the extraction of the ground point, because the progressive triangulation filtering algorithm is
based on the seed points represented by the lowest point of the gridded point cloud. Therefore, filtering
out the low point is a preprocessing operation, which directly affects the filtering effects, the establishment
of a digital model, and the generation quality of contour lines. The triangulated terrain model created by
the ground points with low points is shown below.

The distribution of low points is divided into individual points or clusters. The algorithmic flow of this
function is:

1. Traverse the point cloud and search for points to be classified within a certain range of radius of the
current single point or point cluster.

2. Calculate the maximum height difference between the current point and the neighboring point, which
is compared with the threshold.

3. If the value is greater than the threshold, the current point is considered to be a low point, otherwise, it
is not classified as a low point.

Usage

Click Classify > Classify Low Points



Settings

Input Data: The input file can be a single point cloud data or a point cloud dataset, which must be
opened in the LiDAR360 software.
From Class: Source class(es).
To Class: Target class.
Points Number (default value is“1”): When the number of points is set to 1, the single low point is
classified. If it is greater than 1, cluster low points are classified.
Radius (m, default value is"5"): The radius threshold between the unclassified point and the
neighboring point.
Height (m, default value is"0.5"): The height difference threshold between the unclassified point
and the neighboring point.
DefaultValue: Click this button to set all parameters as default.



Classify Below Surface Points

Summary

This function classifies points in the initial category that are below the elevation of the surrounding
neighborhood. For example, when the starting category is ground, this method can be used to classify
points lower than the surface elevation to be the lower-than-the-surface point. The main algorithm idea of
this function is:

1. Search for a certain number of nearest points for the current point in initial class.
2. Fit the plane with the nearest point.
3. Calculate the absolute value of the height difference between the current point and the plane. If the

value is less than the set Z tolerance, it is not categorized. If it is greater than the tolerance, go to the
next step.

4. Calculate whether the difference between the current point elevation and the average value of the
neighboring points is greater than the Limit of the standard deviation. If it is greater than, then it is
classified as the target category; otherwise, it is not classified.

Usage

Click Classify > Classify Below Surface Points

Settings

Input Data: The input file can be a single point cloud data or a point cloud dataset, which must be
opened in the LiDAR360 software.
From Class: Source class(es).
To Class: Target class.
Limit (default value is"3"): The multiple of the mean squared error of the neighboring point fitting
plane of the unclassified points. The larger the value, the less points will be classified into the target
class.



Z tolerance (m, default value is"3"): The threshold of height difference. The point to fit plane
distance less than this value is not classified. The larger the value, the less points will be classified
into target class.
DefaultValue: Click this button to set all parameters as default.



Classify Isolated Points

Summary

This function classifies points in a certain area of point cloud, which is generally used to find outliers in the
air or below the ground.

Usage

Click Classify > Classify Isolated Points

Settings

Input Data: The input file can be a single point cloud data or a point cloud dataset, which must be
opened in the LiDAR360 software.
From Class: Source class(es).
To Class: Target class.
Points Number (default value is"3"): If the number of points in the neighboring radius are less than
or equal to the value, the point is considered as an isolated point.
Radius (m, default value is"5"): Neighboring search radius.
DefaultValue: Click this button to set all parameters as default.



Classify Air Points

Summary

This function classifies points that are significantly higher than the surrounding points into airborne noise
points. The idea of the algorithm is the same as the principle of Outlier Removal in the data management
module.

Usage

Click Classify > Classify Air Points

Settings

Input Data: The input file can be a single point cloud data or a point cloud dataset, which must be
opened in the LiDAR360 software.
From Class: Source class(es).
To Class: Target class.
Neighbor Points (default value is"10"): The number of neighbors that will be used to determine
whether a point is a noise in the sky. Calculate the distance between each point to the nearest point
and calculate the standard deviation of the nearest distances.
Multiples of std deviation (default value is"5"): If the deviation of points beyond the minimum
allowable threshold, they are considered as noise in the sky. The larger the threshold, the less the
noise will be divided into.
DefaultValue: Click this button to set all parameters as default.



Classify Noise Points

Summary

Classify the outliers in the point cloud data as a certain class in the format of *.LiData.

Usage

Click Classify > Classify Noise Points.

Settings

Input Data: The input data can be a single point cloud file, or can be a point cloud data collection; the
data to be processed must be pre-opened in LiDAR360 software.
Radius(Default value is “0.5m”): Set the radius of the fitting plane. This function can be used when
users know the approximate density of the point cloud data.
Recommended Radius: Automatically calculate the appropriate searching radius according to the
input point cloud data.
Multiples of std deviation(Default value is “1.0”): Using the relative error (sigma) as a parameter
for outliers removal. The algorithm will automatically calculate the standard deviation (stddev) of a
point P's surrounding fitting plane. If the distance, d, from this point to that plane is less than sigma *
stddev, this point, P, will be kept. The reduction of this relative error results in removing more points.
Conversely, more points will be retained. The change of this parameter will not ifnluence the
efficiency.
Remove Isolated Points: A point will be treated as an isolated point when there is less than 4 points
within a distance of the searching radius (cannot create a fitting plane with less than 4 points).



Classify by Height Above Ground

Functional Overview

Classify points on the surface of terrain at certain heights. This function can quickly classify vegetation at
different heights. For example, this classification can be done three times to distinguish low vegetation (0-
1m), medium vegetation (1-10m) and high vegetation (10-100m), as shown in the figure below.

Usage

Click Classification > Classify by Height Above Ground.



Parameters Setting

Input Data: Make sure that each input point cloud data has been classified with ground points; Input
files can be single point cloud data files or point cloud datasets; The data to be processed must be
opened in LiDAR360 software.

Category List (Support setting multiple height ranges for classification)

From Class: The category to be classified.
Ground Point Class: 2-Ground Points
To Class: Target category for classification.
Minimum Height(m)(Default is "0"): Minimum height difference above ground points in the area to
be classified.
Maximum Height(m)(Default is "1"): Maximum height difference above ground points in the area to
be classified.
Default: Click this button to restore all parameters to default values.

Note: This function requires ground point categories in the point cloud.



Classify by Min Elevation Difference

Summary

For each point in the data, this function calculates the elevation difference between the lowest point within
a specified radius around it and itself. If the elevation difference is between Min Elevation Difference and
Max Elevation Difference, that point will be marked as Target Class.

Usage

Click Classify > Classify by Min Elevation Difference

Settings

Input Data: The input file can be a single point cloud data or a point cloud data set, which must be
opened in the LiDAR360 software.
From Class: Source class(es).
To Class: Target class.
Min Elevation Difference (m, default value is"0"): Threshold for the minimum elevation difference.
Max Elevation Difference (m, default value is"1"): Threshold for the maximum elevation difference.
Radius (m, default value is"5"): The radius of the area needs to be classified at the current point,
which needs to be classified.
DefaultValue: Click this button to set all parameters as default.



Classify Close by Points

Summary

This function is used to classify those points close to the certain class(es) of points. For each points in the
source class, find the points in its specified 2D or 3D neighborhood area, and determine whether these
points meet certain conditions (i.e., belong to a specified class). Those points meet the requirement will be
classified as the target class.

Usage

Click Classify > Classify Closeby Points.

Settings

Input Data: The input data could be one point cloud file or a set of point cloud files. The data to be
processed must be opened in LiDAR360 software.
Neighbor Class: The points of this class which is close to the source points will be classified.
Source Class: The points close to this class will be classified.
Target Class: Target class of the classification.
Search Method: The method for searching in the neighborhood. Support 2D or 3D neighborhood.

Radius: Neighborhood search radius.



Classify by Range

Summary

Initial points within the polygon are classified into target categories.

For Polygonal objects in the vector data, if the calculation of topological relationship is not checked, the
points of all initial categories in the polygon will be divided into the target category; if the calculation of
topological relationship is checked, the points in the interval between the inner polygon and the outer
polygon will be The points of the initial class are divided into the target class, and the points in the inner
polygon remain unchanged.

For Multi-Polygonal object in the vector data, the points of the initial category in the interval between the
inner polygon and the outer polygon are divided into the target category, and the points in the inner
polygon remain unchanged.

Usage

Click Classify > Classify by Range.

Settings

Input Data: The input file can be a single point cloud data or a point cloud dataset, which must be
opened in the LiDAR360 software.
From Class: Categories to be classified.
To Class: Classification target category.
Vector File: User can select the Vector File loaded into LiDAR360 software from the drop-down
menu, or select  button to load an external vector data file.



Whether to calculate the topological relationship of polygons: For the Polygonal object in the
vector data, calculate the topological relationship between polygons. If checked, the topological
relationship between polygons will be calculated; if not checked, all points in the Polygon will be
generated into a new file.



Classify Buildings

Summary

This function classifies buildings in point cloud data.

Usage

Click Classify > Classify Buildings

Settings

Input Data: The input file can be a single point cloud data file or a point cloud dataset, which must be
opened in the LiDAR360 software and has already been classified by ground points.
From Class: Source class(es).
Ground Class: The default ground point is 2-class.
To Class: Target class.
Normal Radius (m, default value is "3"): The radius of the neighborhood when calculating the
normal vector of each point in the point cloud. Usually set to 4-6 times the distance between points.
Angle Threshold (°, default value is "10"): The angle threshold between two points in plane
clustering. When the actual angle of two points is less than the threshold, the two points will be
clustered into the same group.
Elevation Tolerance (m, default value is "0.6"): The distance threshold from point to plane in plane
clustering, which is expected to be slightly larger than the average point distance. When the actual
distance is less than the threshold, the point and plane will be clustered into the same group.
Minimum Points Number (default value is "100"): The minimum points number of building patches.



Max Slope (°, default value is "60"): The angle between the plane and the vertical direction. Greater
than this value is not considered as the top of the building but the wall or other classes.
Max Building Size (m, default value is "60"): The maximum length of buildings, which was used for
the detection of building patches between blocks.
DefaultValue: Click this button to set all parameters as default.

Note: Using this function requires that the point cloud has been classified by ground points.



Classify Model Key Points

Functional Overview

This function can thin a certain level of the classified points. It is generally used to generate a sparse point
set that retains the key points in the complex terrain area and thin the points in the flat area from the
extracted dense ground points.

The idea of the algorithm is: first, meshing of point cloud data, and then use the seed points in the grid to
establish the initial triangulation network. According to the upper and lower boundary thresholds, the
points that meet the conditions are added to the triangulation network. The process is iterated until all of
the key points of terrain model are classified. In the following figure, the yellow point is the ground point
and the purple point is the key point of terrain model.

Usage

ClickClassify > Model Key Points.

Parameters Settings

Input data: The input file can be a single data file or a point cloud data set; the file(s) to be processed
must be opened in the LiDAR360 software.
Original category: Categories to be classified.
Target category: Classification target category.
Tolerance Above (m, default value is"0.15"): The maximum allowable elevation tolerance value on
the triangulation network model composed of original points. If it exceeds this threshold, it is regarded
as the key point. Simply saying, the larger the value is set, the more sparse the extracted key points
of the model will be; otherwise, the denser it will be.
Tolerance Below (m, default value is"0.15"): Maximum allowable elevation tolerance in the
triangulation network model composed of original points. If it exceeds this threshold, it is regarded as



the key point. Simply put, the larger the value is set, the more sparse the extracted key points of the
model will be; otherwise, the denser it will be.
Grid Size (m, default value is"20"): The value is used to ensure the density of key points extracted
from the model. For example, if you want to ensure that there is at least one point in the grid every 20
meters, this value is set to 20.
Default Value: Click this tool option to restore all default parameters.



Classify by Machine Learning

Summary

This feature uses random forests (machine learning) method to classify point cloud data. In the same
batch of data, it is necessary to manually edit the categories of a small amount of data. After the model is
trained, a large amount of data is processed in batches, and it is used to reduce the amount of labor. This
feature supports two kinds of processes, one is through selecting training samples, generating training
models, and classifying the data, the other is classifying the data directly using the existing models.

Usage

Click Classify > Classify by Machine Learning

Settings

Input Data: The input file can be a single point cloud data or a point cloud dataset, which must be
opened in the LiDAR360 software.
From Class: Source class(es).
Training Class: The classes that are of interest to the user are trained, which will also be included in
the classification results. At least two types of training categories should be selected, of which one
must be unclassified
Training Files: Click  to load training data. Click  to remove the selected data. You can train
multiple files. The categories in the training data are edited manually.
Building Parameters: The parameters are set only when buildings are included in the training class,
which were used to set the maximum building size and minimum building height, respectively.

Max Building Size (m, default value is"60"): The largest building size in the data to be



processed.
Min Building Height (m, default value is"3"): The smallest building size in the data to be
processed.

Save Model: After training, save the model in the file path with the custom .vcm file format . This
model file can be used as input data for Run Machine Learning Classification Model.
DefaultValue: Click this button to set all parameter as default.

Training a small amount of manually edited data, including unclassified, vegetation, building, and all
involved in training, as shown below:

Handle a large number of data results, including unclassified, vegetation, building, as shown below:



Classify by Trained ML Model

Summary

By directly importing the machine learning model with the suffix vcm for classification to classify the point
cloud. It should be noted that the source cloud data trained for the imported machine learning model
should contain relevant geometric features of the unclassified data.

Usage

Click Classify > Classify by Trained ML Model

Settings

Input Data: The input file can be a single point cloud data or a point cloud data set, which must be
opened in the LiDAR360 software.
From Class: Source class(es).
Import Model File: Import the trained model file, whose suffix is vcm. This file is generated by
Classify by Machine Learning.



Classify Ground by Selected

Functional Overview

Due to the complex and varied terrain of point cloud data, it is often difficult to achieve good classification
results using a set of parameters when using Classify Ground Points, especially for the mixed areas
(mountains, plains, etc.). Therefore, in the case that the complex terrain cannot get a good classification
effect in one classification, the ground point classification toolbar of the selected region can be considered
to reclassify the ground point in the region with unsatisfactory local classification effect.

Usage

Load the data first inside the window, Click Classify > Classify Ground by Selected, the classification
toolbar appears at the top of the data window, as shown below.

From left to right: polygon selection, rectangle selection, sphere selection, subtract selection, clear
selection, classify by attribute, Conicoid Filter, slope filter, TIN filtering, extract median ground points,
recover selection, and exit. Select and Clip tools can be found in Select and Clip

Note: The ground point classification algorithms provided by the selected area point classification
include: Conicoid Filter, slope filter, TIN filtering. Different methods should be chosen according to the
terrain. Generally, the effect of TIN filter is the most stable and therefore we recommend this first. In
addition, it would be better to handle each file separately.



Classify by Interactive Editing

Summary

Because it is difficult to attain 100% accuracy with the automatic classification algorithm, human-computer
interaction classification is usually required to meet product requirements. Manual inspections and
reclassifications are performed in the profile window. The profile tool is used to examine the classification
results and modify them. For the accuracy improvement of the classification, real-time changing TINs can
be generated to assist the classification.

Steps

1. When performing interactive editing and classification of point cloud, it is better to ensure that the
point cloud is displayed in the class display mode.Click on the color bar toolbar  to display by class.

2. Click , open the profile window to start checking the classification results. In the main window of
profile mode, point cloud can only be displayed in 2D mode.

3. Select the point cloud in the main window and select the corresponding point cloud in the profile
window. Please refer to Profile Editing。

4. For points with inaccurate classification, you can use the Select Toolsto classify again. Set the
classes throughClassify Panel, classify the pionts selected by selection tools to the target classes.

5.In general, to visualize point cloud classes more intuitively, you need to generate a TIN. Please refer to
the TIN Tools。

6.If the manual classification error needs to be modified, you can undo the previous operations with the
shortcut Ctrl + Z, or clear all temporary operations by clicking .

7.After confirming the classification results, you should click to finish save.

Note: After classifying by editing, you need to click the Save button to save it in the file.



Classify by Additional Attributes

Functional Overview

With this function, a category in the point cloud can be classified into another category according to the
additional attribute range. An attached property supports one or more components.

Usage

Click Category > Sort by Additional Properties.

parameter settings

input data: The input file must be a single point cloud data file. Users can select point cloud data
already opened in LiDAR360 software, or open other LiData files on disk.
Initial Category: Category to be classified.
Target Category: Categorize the target category.

Additional attributes and range selection: refer to Extract by Additional Attributes



   

 

               
            

             
   

      

Parameters Settings

Data to be processed: Select single or multiple data loaded in the software.
From Class: You can select the category that needs to be classified, and the unselected category will
not be covered by the model classification result, which is especially effective when there are some

Classify  by  Deep  Learning

Functional  Overview

This feature employs a deep learning segmentation model to classify point cloud data and is suitable for 
various scenarios such as airborne urban, airborne rural, ground-based forestry, and vehicular roads. 
The model is developed based on sparse convolution, ensuring efficiency while also delivering better 
detail representation.

Usage

Click  onClassification  >  Classify  by  Deep  Learning



    
          

              

                 
             

   

Use GPU:Using GPU acceleration to improve the performance of classification.
Note: The output of this function will overwrite the original data file, users who need it should
back up the data by themselves. Due to limited training data scenarios, deep learning models
may perform poorly on certain scenarios and certain types of data.

    

          

               

                 

              
   

    

       

  

               

                 

              
   

fine  categories  in  the  data.
Sence:Choose  a corresponding sence  to  use  different  deep  learning  model, classify point cloud.

UAV Urban supports uncategorized, vegetation, buildings, poles, power lines, and cars.
UAV Rural supports uncategorized, vegetation, buildings, poles, and power lines.
TLS Forestry supports low vegetation and tall vegetation.

  MLS Roads support uncategorized, low vegetation, high vegetation, buildings, powerlines, poles,
static vehicles, dynamic vehicles, signs, and barriers.
Classify  xx:  Check  to  enable  this  category,  you  can  select  the  number  corresponding  to  this 
category.
Height  Above  Ground:  Select  the  ground  point  of  category  2  as  the  reference  ground  point  and  fill  in
the  ground  height.  This  parameter  can  effectively  prevent  the  ground  point  from  being  wrongly 
classified  as  a  building.



Classify by Custom Deep Learning
 This function uses a deep learning segmentation model to classify point cloud data. This function uses
supervised classification, in the same batch of data, need to manually edit a small number of data
categories, after training the model to batch process a large number of data. Two processes are
supported: select and generate training models, processing data to be classified; Use the existing models
to process the data to be classified.

Requirement

GPU
Requirement Description

GPU Type the CUDA type of minimum computing capability is 3.5. So 6.1 or higher is
recommend. Refer to Compute Capability

GPU Driver NVIDIA GPU drivers — version 452.39 or higher

GPU Memory minimum: 6GB recommend: 8GB or higher, depending on deep learning model
structure and batch size

Usage

Click Classification >Custom Deep Learning Classification

 Usage Procedure: Data preparation -->Training point cloud classification model -->Use training model for
classification

 Please note that when you enablethe back-end for the first time.

The following is the task management page, which can display the status/management of training point
cloud classification model tasks and use the training model to classify tasks.

 Tool bar from left to right Create a task,delete a task, start a task, pause a task, export a task, task
information,import task,model management,setting,refresh

https://developer.nvidia.com/cuda-gpus
https://www.nvidia.com/drivers


 The task management page, it can display state/manage training point cloud classification model tasks
and use training model classification tasks. Note the connection to the back end should be set at the first
startup.

Data Preparation

The data required for training (labeled data) should be prepared before training, and you can use the
profile editing function provided by lidar360 to edit the category data.  The training data should be real
scene data, and data in las, lidata and laz formats are allowed. The amount of training data is adjusted
according to different scenarios and algorithm processing methods. In principle, the more annotated data
involved in the training, the better. We recommend that at least 100m*100m data be prepared for use to
obtain a good use experience.Please note that data annotation must be consistent with the principle, and
the setting of categories should not be changed according to the scene. Mislabeled data can have a
negative impact.

Training point cloud classification model

 Click Classification > Classify by Deep Learning-> Training point cloud classification model





After filling in the data path as required, the user clicksdefault使用默认参数即可开始使用

Task Name: The task name will be used as the trained model name.
Training Data: If the data marked by categories is placed in the same folder, all data in the supported
formats of the folder will be read.
Validation Data: Put the data marked by categories in the same folder. The data in this folder will be
used as indicators such as the accuracy of sample calculation.
Preprocess Transform:

Split Function: Data preprocessing, you can select data preprocessing function here, usually
include statistical filtering, voxel filtering, etc.

Split Transform:
Split Function: Data segmentation, in order to avoid the use of too much memory, users can
segment the data to the appropriate size, the size is related to data distribution, algorithm and so
on. We will continue to describe how to choose the appropriate size later.

Select Class: Category mapping, where one or more source classes correspond to target classes,
can save a lot of work when adjusting algorithm classification categories and correcting category
definitions.



Model:
Model List: The model temporarily provides three classical models: PVCNN, KPConv and
MinkUNet (not the original implementation, with a small number of changes). For these three
algorithms, we have provided corresponding recommended parameters settings. You can use
the Default button in the lower left corner to automatically fill in subsequent parameters.

Training:
epochs: Iteration period. Each complete loop that processing all data is an epochs.
batch size: For each batch of data, which means the model processing several data. If memory
allows, larger data has more advantages in model accuracy and training speed. For GPU with
dedicated RAM of 8GB, please use the default batch size 2. If you find that there’s still lots of
GPU memory available during training, you can safely increase the batch size to process more
blocks at once.
lr: Learning rate cooperate with the optimizer control the speed and direction of the model
learning (generally, the lower the learning rate, the more stable and easier to fall into the saddle
point).
Optimizer: Optimizer, as above.
lr scheduler: Learning rate controller, the learning rate varies with the period to obtain better
accuracy in some cases.
loss: The default loss function is cross entropy CrossEntropyLoss. FocalLoss generally has a
better effect when the categories are not balanced, and may have worse effect when the label is
wrong. So using CrossEntropyLoss is better.

The preceding bold parameters are mandatory. Other parameters are optional.

Use training model for classification

Click Classification >Classification by Deep Learning >Use training model for classification



Model: Select the Model to use. The name of the Model will be named after the training task name.
The model will be automatically added into the Model management after training.

Note: The model will be generated when the training task is completely stopped (the training task is
completed, the training task is paused, and the training task exits when the memory exceeds).

Evaluate point cloud training results

Three indicators MIoU, Acc and MAcc are provided, which are mainly calculated based on confusion
matrix

The True value is positive, the number that the model considers to be positive (True Positive=TP). The
True value is positive, the number that the model considers to be negative (False Negative=FN) The true
value is negative, the number that the model considers to be positive (False Positive=FP) The true value
is negative, the number that the model considers to be negative (True Negative=TN)

True category

1 0

Predicted category

1
Positive

True Positive
True positive

False Positive
False positive

0
Negative

False Negative
False negative

True Negative
True negative

Such a table of four indicators becomes the confusion matrix

IoU (Intersection over Union)

The intersection of goals and predictions/the union of goals and predictions

MIoU(Mean Intersection over Union) MIoU

Acc(Accuracy)



MAcc(Mean Accuracy)

In general, we only need to focus on the miou metric, which is the average intersection ratio

Set back-end

 Click the following buttons in turn. Note that the third button will not be clicked when the back-end is not
connected.

Model management

The model management interface manages available models and imports external models (lidar360 client
output models only).



Import project

External models can be imported to obtain parameters/weights.

- Model File: External model file path (only supported by Lidar360 client output) - Model Weight:
indicates the weight of the model. If it is checked, training continues. If it is not checked, only model
training parameters are obtained

Deep learning model comparison



The following data are for the training stage. Use the voxel size of 0.5 for voxel subsampling, with a single
data point of 20w and a batch of 2 statistics. The time complexity and space complexity are mainly
affected by the degree of data density. It is difficult to control the point density after multiple subsampling
of the model, and can only provide a general value for reference.

Hardware Configuration

 cpu:i7-10700k(8t16c)

 gpu:RTX3060

Algorithm Speed(items/s) Memory usage(GB) Space complexity Time complexity

PVCNN 1.82 8G about O(logN) about O(logN)

KPConv 0.04 11G about O(logN) about 0(n**2)

MinkUNet 1.05 8G about O(n) about O(logN)

KPConv generally has the highest level of precision and detail, and is recommended for small scenarios
that require fine classification. The MinkUNet has a larger field of view with a decent speed and is
recommended for large scenes. PVCNN has great detail performance and fastest speed, and is generally
recommended.

Feature selection

rgb and intensity features can be added according to the specific data The rgb and intensity features can
make the model fit earlier, with little difference in final accuracy (depending on the actual data), and
negligible difference in memory consumption and computing speed.

Features miou

rgb+intensity 99.1

intensity 98.8

rgb 99.0

None 98.7

Debugging guide

Insufficient memory: Reduce the batch_size parameter and split transform to the split size.
Category imbalance: Recommend that loss change to FocalLoss.
Loss jitter back and forth: At the beginning of training, you can wait for more rounds. If in 10-20
epoch it is not stable, can try to make lr / 10 smaller. It is recommended to you to use
CosineAnnealingWarmRestarts for lr_scheduler. If necessary, the large lr training can be used in the
early stage, and the use of import model training function in the later stage can change to the small lr
training.

Note

1. The validation set uses data enhancement from the training set by default



2. If users didn’t specify the input feature, we will input the basic feature as required by the model



Terrain
The Terrain module contains a range of products required for terrain production, such as DEM, DSM,
contour line and cross section, etc. of which the Digital Elevation Mode indicates that the bare earth
surface (vegetation and other objects are removed), the Digital Surface Model represents the surface
characteristics of terrain and other objects (e.g. tree canopy), and Canopy Height Model indicates the
normalized height of vegetation and ground objects. Hillshade maps can be created by any digital model
for visualization.

Raster Parameters

DEM

DSM

CHM

DOM

Hillshade

Slope

Roughness

Aspect

Raster to Contour

Point Cloud to Contour

Generate TIN

TIN to Contour

Generate Elevation Annotation

TIN to DEM

DEM Sheet Join

DEM Accuracy Assessment

Deviation Analysis

Change Detection

Section Analysis

LiModel Editor

LiTIN Editor

Smooth Meshes



Interpolation Parameters Settings
When generating terrain products, you need to set some grid cell size parameters and determine the
interpolation method used for grid cell calculations. The parameters settings are divided into conventional
and standard.

Under the standard parameters, the schematic diagram of the framing frame and each corresponding
range is as follows:

Green box: standard framing box range;

The red double-line box: the result range box (the expansion range is related to the scale M, which is
0.01/M (m), for example, the scale is 1: 500, and the expansion range is 5m), and the range is calculated
according to the internal scale;

Blue dotted frame: In the process of DEM generation, the size of the buffer area is expanded outside the
result range frame to ensure the same elevation in the overlapping range of adjacent frames.

Parameter Type

General: General DEM parameter configuration.
Standard: Configured according to standard DEM production parameters.

Grid Size

Through XSize and YSize, users can set the size of sampling interval (resolution) in meters. For instance,
if XSize and YSize values are set to 2, respectively, the grid unit size is 2 meters by 2 meters.



Scale bar (only set under standard mode parameters)

The scale of the framed frame.

Buffer size

Buffer Size (cell) (default is "5"): The size of each block of raster data extending around, in unit of
cell.

Interpolation Methods

LiDAR360 provides three kinds of raster cell interpolation methods: IDW (Inverse Distance Weigh)
interpolation, kriging interpolation, and TIN (Triangulated Irregular Network) interpolation.

IDW

In the inverse distance weighting interpolation method, the value of a grid element is computed using its
nearby points, and the weighted average value is judged by the distance of the center point of the grid
unit. Users need to set the weight value. The search radius can be used to define the input points of each
raster image meta value interpolation, which consists of variable radius and fixed radius.

Power(default value is "2"): The power of the sampling point to the center distance of the pixel to
control the degree of the influence of the sampling point elevation on the pixel center.

Radius Variable: Use a "Variable" to find a specified number of sampling points for interpolation.

Distance(Pix)(default value is "5"): Restricts the distance to search for adjacent points, by
default 5 pixels.
Number of Points(default value is "12"): The number of nearest neighboring points used for
interpolating, which is set 12 as default.

Radius Fixed: Interpolation using all points in a fixed radius range.

Distance(Pix)(default value is "5"): The point within the range of the radius is used for
interpolation, by default 5 pixels.
Number of Points(default value is "12"): The smallest number of points used for interpolation,
which is set 12 by default. If required points were not found within the specified radius, it will
increase the search radius until find the minimum number of points.

Kriging

The Kriging interpolation method computes the optimized covariance and uses the Gaussian process
interpolation grid value. The search radius can be used to define the input points of each raster image
meta value interpolation, which consists of variable radius and fixed radius.

Radius Variable: Use a "Variable" to find a specified number of sampling points for interpolation.

Distance(Pix)(default value is "5"): Restricts the distance to search for adjacent points, by
default 5 pixels.
Number of Points(default value is "12"): The number of nearest neighboring points used for
interpolating, which is set 12 as default.



Radius Fixed: Interpolation using all points in a fixed radius range.

Distance(Pix)(default value is "5"): The point within the range of the radius is used for
interpolation, by default 5 pixels.
Number of Points(default value is "12"): The smallest number of points used for interpolation,
which is set 12 by default. If required points were not found within the specified radius, it will
increase the search radius until find the minimum number of points.

TIN

Extracts a grid cell value from a surface formed by a plurality of triangles consisting of the nearest
adjacent point. This tool offers two options of interpolation.

Delaunay: Create the Delaunay triangulation by traditional point-by-point insertion. All the points will
be involved.

Spike Free TIN: Remove all the points with abnormal altitude. It can lead to generating triangulated
network without obvious spikes.

Freeze Distance (default value is "1.0 meter"): The shortest distance in xy plane of each side
of triangle in the triangulated network. When inserting a new point and its Z value lower Insertion
Buffer, freeze all the triangles whose three sides are all less than Freeze Distance. The frozen
triangles will no longer change. The larger this value is, the fewer points will be involved in
creating the network, the more smooth the network will be and the less details will be included.
Conversely, more points will be involved in creating the network, the more details will be included
and the more possible spikes will appear in the network.
Insertion Buffer (default value is "0.5 meter"): When trying to freeze a new triangle right after
freezing another one, the difference in altitude value should be lager than this threshold.
Decreasing this value will result in more triangles will be frozen too early, new point cannot be
inserted, less spikes will appear, processing will be faster, and more details will be lost.
Conversely. more details will be included, and more spikes will be included in the network.

    @inproceedings{
        author={ Khosravipour A, Skidmore A K, Isenburg M},
        title={Generating spike-free digital surface models using LiDAR raw point clouds: A new approach for 
forestry applications},
        booktitle={ International journal of applied earth observation and geoinformation, 52: 104-114},
        year={2016}
    }



Merge files into one

If this option is not checked, each point cloud data will be processed separately, resulting in more than
one grid file. Check this option to merge all generated raster files into one file.

Fill in holes

If there are no points near the grid unit, the grid cells may not have data values. When this option is
checked, data values can be computed by analyzing adjacent grid units and using the selected
interpolation method to fill in an area with no values.

Note: The "Fill in holes" function is only for closed holes.



DEM

Summary

Digital Elevation Model (DEM), is the digitized simulation of terrain through limited topographic elevation
data (i.e. the digitized representation of terrain surface). It represents the ground elevation with a set of
ordered numerical array. It is a branch of the digital terrain model, which can be used to generate all other
terrain feature values.

Usage

Before you can generate a digital elevation model, first Classify Ground Points. Click on the Terrain >
DEM.

Settings

Input Data: The input file can be a single point cloud data or a point cloud dataset, which must have
classified ground points and opened in LiDAR360 software.
Parameter Settings: See Grid Parameters Settings.
Import terrain features (optional): Import terrain features (breaklines, simulated terrain points)
component files, breaklines and simulated terrain points will participate in DEM generation.
Output Path: Save DEM file to a path.
Default Value: Click this button to restore all parameter defaults.

The original point cloud (left below) and the DEM (right below).



Based on DEM, a myriad of products including Slope, Aspect, Roughness and Contour can be generated.

Note: Point clouds that are used to generate DEM need contain ground points.



DSM

Summary

Digital Surface Model (DSM) refers to the digital representation of height of the surface including the
buildings, bridges, trees etc. Compared to a DEM, a DSM contains more elevation information for
buildings, bridges, forests and other surface object that don’t exist in the DEM. DSM is based on DEM and
further covers the elevation of surface information other than the ground.

Usage

Click on the Terrain > DSM.

Settings

Input Data: The input file can be a single point cloud data or a point cloud dataset, which must be
already opened in LiDAR360 software.
Include Class: Classifications of point cloud for DSM generation.
Parameter Settings: See Interpolation Parameters Settings.
Output Path: Save DSM file to a path.
Default Value: Click this button to restore all parameter defaults.

The DSM generated from the point cloud whose initial category is ground and unclassified. Point cloud
data is shown on the left, DSM is shown on the right.





DOM

Functional Overview

DOM (Digital Orthophoto Map) refers to aerial photos that have been geometrically corrected and possess
both map geometric accuracy and image features. This function uses the results of aerotriangulation
project to generate DOM.

Usage

To generate digital orthophoto images, it is necessary to import the aerotriangulation project from various
software and convert them into LiDAR360's internal image project files. Then, use the DEM or DSM
function within the terrain module to interpolate the corresponding area's point cloud files and generate a
DEM or DSM.

ClickTerrain > DOM。

Parameters Settings

Image Project: Select the imported image project file.
DEM/DSM: Select the generated DEM or DSM file, supporting single channel TIFF files with 32-bit
depth.
Resolution: The resolution can be set in two modes. When selecting the automatic mode, the
program will automatically calculate the ground sample distance (GSD), and the parameter set is a
multiple of the GSD. When selecting the manual mode, the DOM resolution can be set directly.
Color Correction: Whether to perform color correction on the photos to reduce color difference for
some photos. This is only effective for image projects containing tie points.
Maximum Oblique Angle: Only use photos with oblique angles less than this value for
orthorectification.
Output Path: Save the generated DOM file to the specified path.

In automatic mode, the calculated resolution will not be less than 0.05 meters.



CHM

Functional Overview

Canopy Height Model (CHM) can be obtained by subtracting DEM from DSM, and the following figure
shows the relationship of DSM (Digital Surface Model), DEM (Digital Elevation Model) and CHM(Canopy
Height Model).

Usage

Using this function requires a DEM and a DSM. Click on the Terrain > CHM.

Parameters Settings

Input DSM: Input a DSM file, the generation method can be seen in DSM.
Input DEM: Input a DEM file, the generation method can be seen in DEM.
Output CHM: The path of CHM file to save.

The original point cloud (seen left below) and the generated CHM(see figure right below).





Hillshade

Summary

The Hillshade tool obtains the assumed illumination of the surface by determining the illumination for each
image element in the grid. The assumed illumination can be obtained by setting the position of the light
source and calculating the illumination value of each image element related to the adjacent pixels. In the
analysis or graphic display, the Hillshade tool can greatly enhance the surface visualization especially
when using transparency.

Usage

Click on the Terrain > Hillshade.

Settings

Input Tiff File: Input DEM file format in Tiff. The drop-down box allows to select the Tiff data that has
already been opened in the LiDAR360 software. Users can also import Tiff data by clicking .OR
delete imported Tiff data by clicking .Or clear all the imported data by clicking .
Azimuth (°)(default value is "315"): Using North as the benchmark, the degree range is 0~360
clockwise and the default is set to 315 degree(NW).
Altitude(°)(default value is "45"): The angle between the incident direction of the light source and
the ground plane, which ranges from 0 to 90 degrees and uses 45 degree as default.
ZScale(default value is "1"): The stretch scale of the Z value.
Color Relief: Color rendering of hillshade.

Yes: There are 11 types of optional color bar.
No(default): Black and white color bar.

Output path: The path where the generated hillshade map file will be saved.
Default Value: Click this button to restore all default parameters.

DEM (left below) and Hillshade map (right below).





Slope

Functional Overview

Slope shows how deep is the terrain surface. This function analyzes terrain slope based on DEM and
generates slope images.

Usage

Click on Terrain > Slope.

Parameters Settings

Input Tiff File: Input DEM file in Tiff format. The Drop-down box allows to select the Tiff data that has
already been opened in the LiDAR360 software. User can also can click  to import Tiff data.Delete
the imported Tiff data by clicking .Clear all the imported data by clicking .
ZScale (default value is "1"): The stretch scale of the Z value.
Output path: The path where the generated slope map file to be saved.
Default Value: Click this tool option to restore all default parameters.

DEM (left below) and slope map (right below).



Roughness

Functional Overview

Indicators that reflect changes in surface fluctuations and degree of erosion. It is generally defined as the
ratio of surface area to the projected area on the horizontal plane.

Usage

Click on Terrain > Roughness.

Parameters Settings

Input Tiff File: Input DEM file in Tiff format. The Drop-down box allows to select the Tiff data that has
already been opened in the LiDAR360 software. User can also can click  to import Tiff data.Delete
the imported Tiff data by clicking .Clear all the imported data by clicking .
Output Path: The path where the generated roughness map file to be saved.

DEM (left below) and roughness map (right below).



Aspect

Functional Overview

Aspect refers to the orientation of the terrain slope, defined as the direction of the projection of the slope
normal on the horizontal plane. Slope direction is of great importance for mountain ecology. The slope is
an angle, which is measured clockwise with a range between 0 (north) and 360 (north as well). This
function can analyze terrain aspect based on DEM and generates aspect map.

Usage

Click on Terrain > Aspect.

Parameters Settings

Input TIff File: Input DEM file in Tiff format. The Drop-down box allows to select the Tiff data that has
already been opened in the LiDAR360 software. User can also can click  to import Tiff data.Delete
the imported Tiff data by clicking .Clear all the imported data by clicking .
Z Scale (default value is "1"): The stretch scale of the Z value.
Output Path: The path where the generated aspect file to be saved.
Default Value: Click this tool option to restore all default parameters.

The DEM (left below) and the aspect map (right below).



Raster to Contour

Functional Overview

The contour refers to the curve of the adjacent points with equal elevation on the topographic map. Raster
to Contour is to connect the grid points that have the same elevation value, which can build the contour.

Usage

ClickTerrain > Raster to Contour.

Parameters Settings

Input TIff File: Input DEM file in Tiff format. The Drop-down box allows to select the Tiff data that has
already been opened in the LiDAR360 software. User can also can click  to import Tiff data.Delete
the imported Tiff data by clicking .Clear all the imported data by clicking .
Contour Interval (m, default value is "10"): The elevation difference between adjacent contours.
Contour Base (default is "0"): The elevation of the generated contour is calculated from the
reference elevation, that is, the elevation which differs from the reference by interval multiples of the
interval is the contour elevation.For example, the Contour Base is 0, Contour Interval is 10, then the
elevation distribution of the contour is: 0, -10, -20, -30... 10, 20, 30... .
Output path: The path where the generated contour file to be saved.
Default Value: Click this tool option to restore all default parameters.

DEM (left below) and contour (right below)

Note: To smooth the contours, you can usethe elevation smoothing tool in LiModel Editing.



Generating elevation annotations

Summary

Using point cloud and contour lines to generate elevation points for topographic mapping.Notes Elevation
Points File.

Usage

Click Terrain > Generating elevation annotation.

Settings

Input Tiff File: Input DEM file format in LiData.
Input Contour File (.shp): Input Contour file format in shp，The file needs to contain one or more
contours.
Radius (m)(default value is "15"): A Note Elevation Point is generated within a region with a defined
radius.
Output path: The path of the generated contour lines file(s) to save.



Point Cloud to Contour

Functional Overview

The Point Cloud to Contour tool extracts elevation contours from input point cloud data., The specific
process is as follows: Develop a triangular regular network (TIN) from ground class points. This is then
used to TIN to Contour.

Usage

Click on Terrain > Point Cloud to Contour.

Parameters Settings

Input Data: Ensure that each input point cloud data is the data that has been classified by ground
points; the input file can be a single data file or a point cloud data set; the file(s) to be processed must



be opened in the LiDAR360 software.
Scale: There are 11 scales for generating the point cloud, which correspond to different height
intervals.

1: 500: 1: 500 scale.
1: 1000: 1: 1000 scale.
1: 2000: 1: 2000 scale.
1: 5000: 1: 5000 scale.
1: 10000(default): 1: 10000 scale.
... ...

From Class: Point cloud classes that participates in the construction of contour lines.
Contour Base (m)(default value is "0"): The elevation of the generated contour is calculated from
the base elevation. The difference between elevation of the contour and base elevation is the
integral multiples of the contour interval. For example, the criterion is 0, and the contour interval is
10m, thus the distribution of contour is: 0, -10, -20, -30, 10, 20, 30...
Triangle's Maximum Length (m)(default value is "30"): The triangulation network is constructed
from elevation attributed ground points, that is used to generate contours. If the length of a triangle
side, or arc, in the network is greater than the defined threshold, that edge will be excluded from the
construction of elevation contours. If there is no interruption in the expected generated contour line,
this threshold can be set to exceed the maximum size of the ground point cloud void.
Minor Contour (default state is checked): It is also known as minor contour. A contour line drawn at
half contour when the basic contour does not show some local topography. If you do not need to
generate this type of contour line, deselect it.

Spacing (m)(default value is "2.5"): Height interval, the absolute value of height difference
between two adjacent minor contour lines.
Color (default value is "yellow"): The color of Minor Contours. It is modifiable.
Line Weight (default value is "1"): The weight of Minor Contours. It is modifiable.

Basic Contour (default state is checked): It is also known as basic contour. It allows users to
include lines of equal elevation that represent the landscape. If you do not need to generate this type
of contour line, deselect it.

Spacing (m)(default value is "5”): Height interval, the absolute value of height difference
between two adjacent minor contour lines.
Color (default value is "blue"): The color of Basic Contours. It is modifiable.
Line Weight (default value is "2"): The weight of Basic Contours. It is modifiable.

Major Contour (default state is checked): It is also known as major contour. In order to facilitate the
interpretation of contour elevation, contours are drawn from the elevation starting surface and at
every 4th interval above and below the Base Contour. If you do not need to generate this type of
contour line, deselect it.

Spacing (m)(default value is "25”): Height interval, the absolute value of height difference
between two adjacent major contour lines.
Color (default value is "red"): The color of Major Contours. It is modifiable.
Line Weight (default value is "3"): The weight of Major Contours. It is modifiable.

Generate Notes Elevation Points (default state is checked): Generate notes elevation points in
outputs. Notes Elevation Points formatrefer to the appendix.

Radius (m)(default value is "15"): A Note Elevation Point is generated within a region with a
defined radius “15”.

Optimization: Optimized settings for smoothing the generated contours.



Mean Smooth (default state is checked): The Mean Smoothing contour optimization method
replaces the measured or estimated ground elevation points along a contour line with mean
contour points that represent weighted average coordinates of adjacent contour points found on
a given line of equal elevation.

3: The number of neighboring contour points participating in smoothing at the current point is
3.
5 (default): The number of neighboring contour points participating in smoothing at the
current point is 5.
7: The number of neighboring contour points participating in smoothing at the current point is
7.

Bezier Smooth (default value is "155"): A Smoothing contour optimization method that fall
within an angle threshold range from 0 to 180 degrees. The larger the threshold setting, the
smoother the contour lines.
Delete the contour when its area <(m2)(default value is "25"): When the area of the closed
contour is less than this threshold, it will be deleted.
Delete the contour when its length (m)(default value is "5"): Non-closed contours are deleted
if their length is less than this threshold.

Generate Shp (default): Save Point Cloud to Contour tool outputs to a shapefile (shp) format with the
following feature attributes: contour line type, contour line width, contour line color, and contour line
elevation.

Polyline (default): The linear information in the Shp file is 2-D.
polyline25D: The linear information in the Shp file is 2.5-D.

Generate DXF: The generation of DXF format contour files,
Output path: The path where the generated contour file to be saved.
Default Value: Click this tool option to restore all default parameters.

Point cloud data (left below) and contour map (right below).

Note: Before using this tool, ground points should be generated in advance.



Generate TIN

Summary

Generate irregular triangulation model based on point cloud, LiDAR360 adopts custom triangulation model
file format*.LiTin。

Usage

ClickTerrain > Generate TIN。

Parameters Setting

Input data：The file can be a single point cloud data file or a point cloud data set; the data to be
processed must be opened in the LiDAR360 software.
From Classes：Source class(es).
Method：Methods to generate TIN. Now there are two methods, Delaunay and Spike Free TIN.

Delaunay：Use point-by-point insertion to generate Delaunay TIN.
Maximum Triangle Side Length(default value is "30 meter"): Delete any triangle whose
longest size is longer than this value.
Spike Free TIN：Remove the points with abnormal elevation, in order to generate TIN without
obvious spikes.

Freeze Distance (default value is "1.0 meter") :The shortest distance in xy plane of each
side of triangle in the triangulated network. When inserting a new point and its Z value lower
Insertion Buffer, freeze all the triangles whose three sides are all less than Freeze Distance.
The frozen triangles will no longer change. The larger this value is, the fewer points will be
involved in creating the network, the more smooth the network will be and the less details
will be included. Conversely, more points will be involved in creating the network, the more
details will be included and the more possible spikes will appear in the network.
Insertion Buffer (default value is "0.5 meter") :When trying to freeze a new triangle right
after freezing another one, the difference in altitude value should be larger than this
threshold. Decreasing this value will result in more triangles will be frozen too early, new
point cannot be inserted, less spikes will appear, processing will be faster, and more details



will be lost. Conversely, more details will be included, abd more spikes will be included in the
network.

Tile：The results consist of three types of tiles: "Tile by Scale","Tile by Width and Height" and "No
Tile".

Tile by Scale(default)：Generate TIN by a certain scale.
Scale：Point cloud tile scale.

1：500(default)：1：500 scale.
1：1000：1：1000 scale.
1：2000：1：2000 scale.
1：5000：1：5000 scale.

Buffer(m))(default value is "10"):The buffer size of the overlap between two adjacent point
cloud tiles.

Tile by Width and Height:Tile by a certain width and height.
Width(m)(default value is "100"):Width of point cloud tile.
Height(m)(default value is "100"):Height of point cloud tile.
Buffer(m)(default value is "10"):The buffer size of the overlap between two adjacent point
cloud tiles.

No Tile：The point cloud generates a TIN as a whole and no tile.
Flatten(optional)：The flatten tool is used to flatten the specified range based on user input files.
Input File: The input file is the polygon-type shapefile. The irregular triangulation will be flattened
based on the file range and the Z attribute.
Z Attribute:The Z attribute of flattening.
Import terrain features (optional): Import terrain features (breaklines, simulated terrain points)
component files, breaklines and simulated terrain points will participate in TIN generation.
Output path:The path where the generated TIN file to be saved.

Point cloud data (left below) and TIN (right below).
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TIN to Contour

Summary

This function directly connects contour point positions of the same elevation on the TIN stored in the LiTin
file to generate contour lines.

Usage

Click on the Terrain > TIN to Contour.

Settings

Input TIN File：Input LiTin file(s). The drop-down box allows to select the LiTin data that has already
been opened in the LiDAR360 software. User can also import LiTin data by clicking . Or delete
imported LiTin data by clicking . Or clear all the imported data by clicking .
Default Value: Click this button to restore all default parameters.

The other parameters settings of the interface are the same as Point Cloud to Contour.



TIN to DEM

Summary

This function can generate DEM with the LiTin file.

Usage

Click Terrain > TIN to DEM。

Settings

Input TIN File:Input LiTin file(s). The drop-down box allows to select the LiTin data that has already
been opened in the LiDAR360 software. User can also import LiTin data by clicking . Or delete
imported LiTin data by clicking . Or clear all the imported data by clicking .
XSize(m)(default value is "2.0"):The XSize of the grid to generate the DEM.
YSize(m)(default value is "2.0"):The YSize of the grid to generate the DEM.
Import Breakline(optional):Import the breakline file and add the multi-segment lines in the file as
soft breakline to TIN.
Output path:The path where the generated DEM file to be saved.
Default Value: Click this button to restore all default parameters.



DEM Edge Alignment

Functional Overview

By processing the border area of the digital elevation model of adjacent frames, the same grid point
elevation within the overlapping range is guaranteed to be consistent.

Usage

1. Click Terrain > DEM Edge Alignment, the DEM Edge Alignment interface will pop up:

1. Click to add the DEM file and select the digital elevation model file of the edge to be connected
(currently only .tif format is supported);

2. Set the parameters, and click OK to execute the DEM Edge Alignment.

Parameters Settings

Resampling: The method used for resampling the overlapping area.
Nearest Neighbor sampling (default): The nearest neighbor method, sampling from the nearest
neighbor.
Bilinear sampling: Bilinear sampling (2 x 2 kernel).
Cubic convolution approximation: Cubic Convolution Approximation (4×4 kernel).
Cubic B-spline approximation: Cubic B-spline approximation (4 x 4 kernel).
Lanczos window sinusoidal interpolation: Lanczos Windowed Sine Interpolation (6 x 6
kernel). Lanczos can be used as a low-pass filter or to smoothly interpolate between its samples
The value of the digital signal.
Average sample: Calculates the average of all non-null pixels.
Statistical sample: Select the value that occurs most frequently among all sampling points.

Tile frame (optional): Add a frame. If no framing frame is added, it will be saved in the original size of
each DEM file; if a framing frame is set, the framing will be performed according to the framing frame.

https://en.wikipedia.org/wiki/Lanczos_resampling


DEM Accuracy Analysis

Functional Overview

The elevation accuracy of the digital elevation model is analyzed by the checkpoint method.

Usage

1. ClickTerrain > DEM Accuracy Assessment, the DEM Accuracy Assessment interface will pop up:

1. Click Add DEM file , select the digital elevation model file be analyzed (currently only .tif format);

2. Click Add Check point to add a checkpoint file (only .txt format is supported);；

3. Click Execute Analysis ,set parameters to execute precision assessment and assessment result
statistics (corresponding to checkpoints) number, number of gross error points, gross error rate,
average error, medium error, tolerance);

4. Click the export report , set the relevant information to export the precision assessment report.

Import DEM

Add the digital elevation model file to be analyzed, currently only .tif format files are supported.

Import checkpoint

Add checkpoints. Checkpoints can be derived from GNSS measurement, photogrammetry, existing results
(topographic maps, digital elevation models, etc.) Reference System.

Analysis



To perform an accuracy analysis, it must be performed after adding the DEM file and adding the
checkpoint file.

Analysis Settings

RMSE formula: The formula for calculating the error in elevation.
High precision:

Equal precision:

In the formula, M is the error in the result, n is the number of detection points, and  is elevation
difference.

Tolerance: Error tolerance

Note: ①Usually, in the case of high-precision detection, use 2 times the allowable medium error as the
tolerance, and use formula 1 to calculate the result medium error; in the same precision detection, use the

. The allowable middle error is used as the tolerance, and the middle error of the result is calculated by
formula 2. Errors within the tolerance range participate in the precision statistics, and errors beyond the
tolerance are regarded as gross errors. ② After the analysis is performed, the analysis status of each
DEM file, indicates the digital elevation model error The gross error rate is less than 5%, indicates that
there is no detection point within the range of the digital elevation model, means that the gross error rate
of the digital elevation model is greater than 5%.

Export report

Export the error detection report in elevation.

Export information settings

Project Name: The project name.
scale: Scale bar.
Inspection Method: The detection method.
Unit: Unit.
Instrument Name, Model: Instrument name, model.
Instrument Number: The instrument number.
Output Path: The report save path, currently only supports .html format.



Deviation Analysis

Description

To calculate the distance between two point cloud. The distance of each point of the compared point cloud
from the reference point cloud will be saved as an additional attribute. This function can calculate the
distance between any two point in 3D space, which can be used for deviation analysis.

Usage

Click Terrain > Deviation Analysis.

Settings

Reference Cloud: Selected reference LiDAR data.
Compared Cloud: Selected LiDAR data to be compared.
From Class: Select point class involved in Deviation Analysis.
Voxel Size: The smaller the voxel size, the more precise the deviation analysis.
Minimum Distance: The additional attribute value of points smaller than this distance will be set to 0.
Additional properties with distances greater than this threshold will be saved.
By Default: Click this button to restore default settings.



Change Detection

Functional Overview

Calculate the relative change in height between two point clouds and output it as a TIFF image and an
HTML report. In the image, red represents an increase while green represents a decrease, with other
areas displayed in grayscale according to their elevation values. The relative change in height between
the two point clouds will be added as additional attributes to the corresponding LiData files (for example,
the elevation change of a comparison point cloud relative to a reference point cloud will be written as an
additional attribute to the comparison point cloud's LiData). This function can be used for disaster
analysis, illegal construction comparison, earthwork volume change analysis, vegetation growth change
analysis, etc.

Usage

Click Terrain > Change Detection.

Parameters Settings

Reference Cloud: Select the reference point cloud. The reference point cloud is used as a baseline
for comparing against other clouds; its changes (currently only Z-values) are recorded as
"DistanceReference" attribute and shown in green color on images.
Compared Cloud: Select the comparison point cloud. Changes (currently only Z-values) of this
compared with those of Reference Point Cloud are recorded as "DistanceCompare" attribute and
shown in red color on images.
From Class: Starting class of points that participate in change detection. Each category from both
sets of points will be compared separately.

Cell Size: Grid length when converting points into grids; smaller values result in more detailed
comparisons but take longer time.

Dz Tolerance Min/Max: Only when changes fall within these limits would they be assigned distance
values; otherwise, they are considered as no change and the corresponding distance value is 0.

Output Path: Output path for intermediate results and HTML report.
Default: Click this button to restore all parameters to their default values.
Report Setting: After the function finishes running, a pie chart of change statistics will be generated
as shown below.



Note: The LiData versions of both reference point cloud and comparison point cloud must be 2.0 or
above. Lower version LiData can be converted to higher version using Convert LiDatatoLiData. Note:
Additional attribute values can be displayed by right-clicking on them in the menu.



Construction Progress Analysis

Functional Overview

Calculate the newly constructed and demolished parts between two sets of point cloud data, and output
the result as point cloud files and HTML reports. In the imagery, red represents an increase, green
represents a decrease, and other parts are displayed in grayscale based on elevation values. The
changed parts between two sets of point clouds will be output as a point cloud file, and whether the points
have changed will be added as an additional attribute to the corresponding LiData file. The newly added
part relative to the reference point cloud will be labeled as 1 in the additional attribute, and the reduced
part relative to the reference point cloud will be labeled as -1. This function is mainly used for analyzing
construction progress.

Usage

Click Terrain > Construction Progress Analysis。

Parameters Settings

Reference Point Cloud: Select the reference point cloud. The reference point cloud serves as the
baseline for comparison, and the reduced portion relative to the compared point cloud will be written
as an additional attribute "ConstructionProgressAnalysis" into the reference point cloud, displayed in
green in the image.
Compared Point Cloud: Select the compared point cloud. The increased portion of the compared
point cloud relative to the reference point cloud will be written as an additional attribute
"ConstructionProgressAnalysis" in the compared point cloud and displayed in red in the image.
Voxel Size: This is the voxel edge length used to voxelize the point cloud. A smaller value increases
detection sensitivity to point cloud changes, while a larger value provides greater coverage but
reduced sensitivity.
Minimum Cluster Size: This specifies the minimum number of points a cluster in the changing point
cloud must contain. Clusters with fewer points than this threshold will be considered as noise and not
be processed further.
Default: Click this button to reset all parameters to their default values.
Output Path: This is the output path for intermediate results and HTML reports.



Note: Both the reference and compared LiDAR data versions must be 2.0 or higher. Lower versions
of LiDAR data can be converted to higher versions using Convert LiData to LiData. Note: Additional
attribute values can be displayed by right-clicking the data and selecting "Display by Attribute."



Section Analysis

Functional Overview

Section Analysis aims at road section and tunnel section, mainly solving problems such as design of
reference section line based on point cloud and model data, extraction of real section, analysis of section
over-cut and undercut, generation of report and so on. This function is based on the measured data to
obtain the measured section of each position or the real topographic relief situation; The measurement
section can be edited and managed; Finally output the information of each section and generate over-cut
and undercut report It is recommended to use ground points for section generation to obtain accurate
section data.

Usage

Load the point cloud or model data into the current activation window, click Terrain > Section Analysis, the
section analysis tool bar will appear above the data display window.

From left to right: Editor, create guide lines, import guide lines, extract section point clouds, generate
orthogonal guide line, save reference guide line, import design section, generate road section, generate
tunnel section, hide\display vector tool, clear tool, and exit tool.

ClickEditor > Start edit

Select the point cloud or model data that the window has loaded to start the section analysis. Users need
to choose between measured data and design data. The measured data is used to generate the real
section (red by default), while the design data is used to generate the design section. The measured data
is required and the design data is optional. Only when the design data is selected can the over-cut
analysis be carried out after the real section is generated.

Draw the center line/longitudinal section

Import the reference section

Functional Description: Use the mouse to pick up several points to create a reference section.
You can draw multiple reference sections.

Functional Description: Click this button to open the import guide interface, supporting text files
(*.txt), graphics files (*.dxf), vector files (*.shp)



Import result format refer tothe section result file format.. When Import dxf, it will automatically match dxf’s
text as a reference line's name, the matching way is traverse the reference lines of the file,compare all the
texts’ positions with the beginning and end points of the reference line. Find the text closest to the starting
or ending points as the name of this guide line. This text will not be used by other guides. Guides that do
not match the text will be automatically named by the software according to the current naming mode.
Refer to the "Settings" function in "Generate Road/Tunnel Sections" for the naming mode. Guides can be
imported in the following types:

Central Axis: All guides will be imported as centerlines.
Cross section: Guides with only two points are imported as cross sections.
Auto: Guides larger than two points will be imported as centerlines; Guides with only two points are
imported as cross-sections, and the intersection with each centerline is automatically determined to
obtain the appropriate name and mileage.

Extract the point cloud along the reference section line

Parameters Settings

SectionSelect the reference center line from which the point cloud is to be extracted.
Buffer Size (m) (default: "1.00"): The buffer distance perpendicular to the center line/vertical
section. For 100 m, each end of the center line is buffered 50 m.

Save the reference section

(*.txt), graphics files (*.dxf), vector files (*.shp)

Functional Description: Click this button to extract the point cloud data file around the reference
center line. If the model file is loaded, all the vertexes of the triangulation gird within the model
scope are extracted.

Functional Description: Click this button, the Save Guide dialog box will appear, you can save
the created reference line data as txt, shp or dxf format file.



Center Axis: Only the center line and its name are exported.
Cross section: Only the cross section and its name are exported.
Both: Export all guides and their names.

Automatically add a reference cross section

Parameters Settings

Left Width (m) (default: 5): The length of the left side of the reference cross section along the line.
Right Width (m) (default: "5"): The length of the right end of the reference cross section along the
line.
Step (m) (default: "10"): The step size of the reference cross section generated along the center line
direction.
Starting Mileage (km) (default: "0")Generates the starting mileage of the reference cross section,
and the mileage value of the cross section is accumulated on this basis.
By Step: Generate a reference cross section only by a specific step, regardless of nodes.
By Node: Generate a reference cross section only by a specific node, regardless of divisions.
By Step and Node: Generate a reference cross section by a specific step and process the nodes
simultaneously.
By Slope: When there is a height difference between the nodes of the longitudinal profile/centerline,
the cross-section position can be calculated using the slope method. The slope is defined as the ratio
of the horizontal distance and height difference between two points on a line segment, usually
expressed as a percentage. In this mode, the larger the slope, the more cross-sections obtained.

Functional Description: This function is used to generate several cross sections perpendicular
to the reference center line.



Slope (%) (default "5"): The program automatically calculates the height difference for each
section of centerline, then uses input slope value to calculate horizontal step length and finally
places cross-sections at these intervals.

Maximum Mileage Step Length (m) (default "10"): Horizontal step length threshold used in
conjunction with slope threshold. This threshold ensures that at every certain distance in gentle
slopes there will be one cross-section when setting small values for slope thresholds which may
result in too few cross sections.

Add a reference cross section manually

Parameters Settings

Left Width (m) (default: 5): The length of the left side of the reference cross section along the line.
Right Width (m) (default: "5"): The length of the right end of the reference cross section along the
line.

The cross-section shown in the figure.

Import design section

Functional Description: Click this button to enable the function of manually generating reference
cross section. You can add a cross section at any position on the longitudinal section with the
mouse.

Functional Description: Click this button to import the design section into the software. Support
text file (*.txt), read the section line will all be displayed as the design section line. For details
about the section format, see "Import Reference Section”



Generate road/tunnel sections

Cross section drawing refers to the section drawing perpendicular to the middle line of the road at the
center of the pile. In traditional surveying and mapping, the section drawing takes the horizontal distance
as the horizontal coordinate and the elevation as the vertical coordinate and is drawn on the millimeter
square paper. The scale is generally 1: 100 or 1: 200. The aspect scale must be consistent. Earthwork
quantity calculation and construction lofting, are based on this. For road sections, the measured section
can be generated using points of any class (the default is ground points), and you can adjust the distance
threshold and the maximum side length to control the refinement of the section

The right side of the section interface is the section manager. Double-click on the manager tree node to
jump to the corresponding section. The attributes of this section will also be displayed in the attributes bar
below. Click "Calculate" button to pop up the parameters settings dialog box of calculate section. Different
parameters are used for road section and tunnel section.

Parameters Settings

Road section parameters:
Select Section: The user can select one or more guides from the list. By default, all guides are
selected. Guides in the list have been grouped by the center line they belong to. For road
sections, the centerline can generate a measured section. The measured cross section
generated by the selected guides will override the old results.
Section Thickness (m) (default: "1"): The extent of the section point clouds extracted along the
centerline/longitudinal section direction will be used to calculate the true section. When the point
cloud is sparse, the value can be appropriately increased in order to better preserve the details of
the measured section. This best value is set to 3 to 5 times the average point spacing.
From Class: Indicates the type of point cloud that participates in the generation of a cross-
section.
Section step (m) (default: "5"): The section can be segmented based on the set step size
according to the distance threshold, the section will use linear interpolation method to
interpolate points at integer multiples of section step size. If this value is set to 0, you should
simplify the whole section. The larger the value, the less the true section points are retained.

Functional Description: Generate road sectional view based on reference section line.



Distance Threshold (default: "0.01"): The profile will be condensed using the Douglas
algorithm according to this parameter. The smaller the value, the higher the refinement degree of
the cross-section; otherwise, the higher the simplification degree. After simplification, it is
possible to appear point clouds that exist below the sectional line.
Type: Take the section data according to the elevation type to generate the section view.

Lower (default): Take the lowest point of the section data to generate the section view.
Upper: Take the highest point of the section data to generate the section view.

Max Edge Length (m) (default: "0.5"): Threshold of maximum line segment side length. If the
distance between two points in the cross section is greater than this value, it will be broken into
two sections.
Coordinate Origion: Starting position of section line in x direction.

From Center: The x-direction starting position of the section line is the intersection point with
the central axis.
From the Beginning: The x-direction starting position of the section line is the left end along
the central axis.

Tunnel section parameters:
Select Guides: The user can select one or more guides from the list. By default, all guides are
selected. Guides in the list have been grouped by the center line they belong to. For the tunnel
section, the center line does not generate the measured section. The measured cross section
generated by the selected guides will override the old results.
Maximum Side length (m) (default: "5"): Threshold for maximum line segment side length. If
the distance between two points in the cross-section is greater than this value, it will break into
two segments. The larger the value, the less the true section points are retained.
Section Thickness (m) (default: "0.1"): Generate the sectional view using point cloud data
along the section line width.

Functional Description: Generate tunnel section view according to section line.



Click the calculate button to bring up the parameters settings dialog box. Click OK to generate the tunnel
cross-section. The mouse can be used to translate the canvas, zoom and other operations.

Export Section: Export the generated section lines and save them to one or multiple files. We
support csv, HDM, HDM (Southern), shp, and dxf formats in Chinese, but hdm formats are not
supported in English. Export result format refer tothe section result file format..
Export Image: Save the current dialog cross-section as a image, can save the format as pdf, the user
can set the resolution and size of the exported cross-section in the export interface.

Edit section line node: Edit the node of the tunnel section line. After editing is enabled, you can drag
the node. It is used to edit incorrect tunnel boundaries or tunnel boundaries with noisy point.
Section comparison: The generated tunnel reference section is compared with the tunnel design
section, and the area of the filled excavation and the total amount of filled excavation (volume) are
calculated. Fill area and dig area are shown in different colors (color can be set).

The method of calculating the total amount of fill excavation is as follows: The half distance of the
previous mileage pile and the second mileage pile to this mileage pile multiply by the area of fill
excavation of this mileage pile, and only the second half and the first half of the distance of
starting mileage pile and ending mileage pile are calculated respectively. For example, if the
mileage pile is K0+80, the excavated area is S, the previous mileage pile is K0+72, and the later
mileage pile is K0+90, then the excavated amount of the mileage pile V = ((80-72)/2 + (90-80)/2)
* S.The total filling and excavation volume can be obtained by summing up the volume of each
mileage pile.



Export comparison report: You can export the section and section information on the current
canvas into a report, output to the specified folder.

Distance measurement: Enabling the distance measurement, you can use the left mouse button to
click on the canvas to pick up the required measurement points, it can also scale and shift the canvas
at the same time. Double-click the left mouse button to complete the measurement, click the
"Distance Measurement" button again to end the measurement.
Setting: The Setting dialog box is displayed.

Display: You can set the color of the point cloud, the color of the section node, and the color of
the filling and digging side.
Section Name: You can name the sections according to a specific naming pattern. It can be
divided into prefix and suffix. The prefix can be entered arbitrarily. The suffix is mileage. They are
mileage (km+m) and mileage respectively.

Show Section Attributes: You can show/hide the current section attributes.

The measuring section report is shown in the figure below.

Show/hide Sections

Remove Sections

Exit

Functional Description: Click this button and choose to show or hide vectors according to your
needs, includingdrawn lines, orthogonal lines, sectional lines and all vectors.

功Description: Click this button and select whether to clear the vector as required, includingclear
drawn lines, clear orthogonal guides, clear sectional lines and clear all.

Functional Description: Exit section analysis.



LiModel Editor

Functional Overview

Provides editing operations forLiModel. The user can select area of interest using Polygon Selection,
Lasso Selection, Screen Selection, or shp Selection, which can be edited by various operations such as
Flatten Height, Smooth Height, Repair No Data, Repair Height by Variance, Repair Height and Delete
Height.

Usage

Click Terrain > LiModel Editor, The current activation window will show the LiModel Editor toolbar.

Data Selection

Click Start Edit in the drop-down menu for editing. You can select one or more data which has been
opened in LiDAR360 for editing.

Polygonal Selection
Left-click to add the polygon vertex. double- click to finish the selection. Right-click to Back One
Point or Clear Selection before finish. Unlike Polygon Selection tool, you cannot select an area
that exceeds the data range.



Lasso Selection

Screen Selection

Shp Selection

Flatten Height

Flatten Height(meter): Set the elevation value. The default value is the average of the elevation
values of the vertices of the selected region.

The schematic diagram is as follows, the left image is the original data, and the right image is the edited
version.

Left-click to start the Lasso Selection, move to add one point, and double-click to finish the
selection. Right-click to Back One Point or Clear Selection before finish. Unlike Lasso Selection
tool, you cannot select an area that exceeds the data range.

Left-click to add the polygon vertex. double- click to finish the selection. Right-click to Back One
Point or Clear Selection before finish. You can select the area that exceeds the data range.

For a specific range, the existing 2D SHP format vector file can be imported, and the polygon is identified
by the software as the editing area.

Click this button, or right-click to select Flatten Height. You can set elevations for selected area
range models to specified elevation values for rivers or waters that have the same altitude.



Smooth Height

Kernel Size (default value is "5"): The size of the mean filter kernel, it can only be odd.

The schematic diagram is shown below. The left figure shows the original data, and the right figure shows
the effect after editing.

Repair No Data

Click this button, or right-click to select Smooth Height, which can smooth the selected area range
model. Using image mean smoothing to process the model in the selected region point by point, it
is suitable for smoothing DEM to generate smooth contour lines.

Click this button, or right-click to select Repair No Data. Use bilinear interpolation to calculate the



The schematic diagram is shown below. The left figure shows the original data, and the right figure shows
the effect after editing.

Repair Height by Variance

Elevation Variance Threshold(the default value is 10): The elevation variance threshold is used to
determine whether it is a noise.

The schematic diagram is shown below. The left figure shows the original data, and the right figure shows
the effect after editing.

Click this button, or right-click to select Repair No Data. Use bilinear interpolation to calculate the
elevation value of NO Data values in the area.

Click this button, or right-click to select Repair Height by Variance. It is used to repair the noise
caused by noise, according to the variance of its elevation value with the neighborhood point to
determine whether it is a noise. Bilinear interpolation is used to calculate the elevation of the
noise point.



Repair Height

Grid point type: This parameter defines the range of grid point to be processed and may constrain
the processing scope.

All grids(default): All selected areas will be repaired.
Elevation Range: Only grids with elevation values within the minimum and maximum values are
repaired. The default values for the maximum and minimum values are the maximum and
minimum elevation values for the vertices of the selected area.
Internal No Data Value: Only the non-valued areas are repaired.

The schematic diagram is shown below. The left figure shows the original data, and the right figure shows
the effect after editing.

Delete Height

The schematic diagram is shown below. The left figure shows the original data, and the right figure shows
the effect after editing.

Click this button, or right-click to select Repair Height. It is used to repair the elevation in the
specified range. The bilinear interpolation method is used to calculate the elevation of the
parameter conditions.

Click this button, or right-click to select Delete Height. Delete the selected point elevation point.



Save DEM

Cancel DEM

Exit

Save the edited result to LiModel file.

Cancel editing, discard edit result, reload original file to display.

Click the exit button in the toolbar to exit LiModel editor. If the editing result is not saved, and click
the Exit button or click the Edit button to finish the editing of the menu, the software will pop up
the prompt window as shown below. Click Yes to save the editing result and exit. Click No to exit
without saving the editing result. Click Cancel returns.



LiTIN Editor

Functional Overview

Provides irregular grid model LiTin for editing operations,provides adding single point, deleting single
point, deleting multiple points, adding single fracture line, adding closed area (lake ) Break-lines, Add
Double Region (River) breaklines, Delete breaklines, Select Edges, Select Triangles.

Note: Using the model display tool as shown in the figure below, you can display LiTin by model,
triangle or point respectively (you can also use the letter key W on the keyboard to switch between
different display modes). For easy viewing of editing effects, it is recommended to use the disclosure
triangle to display LiTin.

Usage

ClickTerrain > LiTin Editor, the LiTin Editing bar will appear in the current activation window.

Select Edit File

Click Start Editing in the Edit drop-down menu and select the data to be edited.The data to be edited must
have been opened in the LiDAR360 software, and only one data can be selected for editing at a time.

Add Single Point



Elevation Source: This parameter defines the elevation value of the added point.
From Surface (default): The elevation of the insertion point is determined by triangular
interpolation.
Max Z From Surface: The maximum value of the range of elevation values within this model.
Min Z From Surface: The minimum value of the range of elevation values within this model.
As Specified: User input custom elevation value.

Delete Single Point

Delete Multi Points

Breakline of Water Area

 Draw a closed area through mouse interaction, set parameters, and click the Add button to complete
the addition.

Set Elevation: Project the break line point to the same elevation plane, users can manually input or
activate the selection button to pick up the points in the scene for elevation setting. The default is the
elevation of the last drawn point.
Minimum Elevation: Project the break line point to the elevation plane corresponding to the lowest
point in the area.

Breakline of Gradual River

Click the left mouse button to add a vertex and insert a single point into LiTin. The XY coordinates
of the point are determined by the mouse click. The sources of elevation values include
triangulation surface, maximum surface elevation, minimum surface elevation and user input. This
function is suitable for local area editing, intervening in the contour trend of this area.

Left mouse click to delete a vertex, delete a single point from the LiTin model, and reconstruct the
triangulation network with adjacent points. This function is suitable for local area editing, removing noise
points or misclassified points, and intervening the contour trend of this region.

Select an area interactively with the mouse, and the triangulation network points in the area will
be deleted in batches, causing local triangulation network reconstruction. It is suitable for local
area editing. It can delete noise points or misclassified points in batches according to the polygon
range, and intervening the contour trend of this region.



 Draw two riverbank lines interactively with the mouse (they need to be drawn in the same direction),
set the parameters, and click the add button to complete the addition.

Start Elevation Value: This parameter defines the starting elevation value of the river. The default is
the elevation of the starting point of the second river bank, and the user can manually input or activate
the selection button to select the midpoint of the scene to set the elevation.
End Elevation Value: This parameter defines the end elevation value of the river. The default is the
elevation of the end point of the second river bank. Users can manually input or activate the selection
button to select the midpoint of the scene to set the elevation.

Liner Breakline

 Draw a PL interactively with the mouse, set the parameters and click the add button to complete the
addition.

Breakline Type: This parameter defines the break line type.
Soft Breakline (default)*: Soft break line.
Hard Breakline*: Hard break line.
Change Elevation: Unchecked by default, available under hard fracture, whether to change the
elevation of the fracture line point.
Start Elevation Value*: This parameter defines the starting elevation value of the hard fracture.
Users can manually enter or activate the selection button to select the midpoint of the scene for
elevation setting.
End Elevation Value*: This parameter defines the end elevation value of the hard fracture.
Users can manually enter or activate the selection button to select the midpoint of the scene for
elevation setting.

Import Breaklines

Breaklines File: Select the breakline vector file you want to use from the directory tree or externally.
Layer Name: Choose the specified layer to use, and the layer type should be closed multiline.
Area Type: Closed area types include: planar (buildings, lakes, etc.) and gradual (rivers).
Elevation: Choose the automatic elevation calculation method: area average, maximum, minimum,
and percentiles.

Delete breakline

Select Edges

Click the Import Breaklines button, configure the parameters, click OK, and wait for execution.

Delete the selected break line by mouse interaction.

Select the sides of the triangle interactively with the mouse. The selected sides are displayed in
red.



Select Triangle

Save TIN Edit

Cancel TIN Edit

Exit

red.

Select the triangle interactively with the mouse, the selected triangle is displayed in red.

Save editing results to LiTin file.

Cancel editing, discard edit result, reload original file to display.

Click the Exit button on the tool bar to exit LiTin editing. If the editing results are not saved, click
the Exit button or click the Edit button to pop up the menu to end editing, the software will pop up
the prompt window as shown in the figure below, click Yes to save the editing results and exit,
click No to exit directly without saving the editing results, click Cancel returns.



Smooth Meshes

Functional Overview

Smooth the triangulation model

Usage

ClickTerrain > Smooth Meshes, the Parameters Settings interface pops up, select the data setting
parameter to execute.

Parameters Settings

Input data: Select from the current project directory or select the model data file to smooth from the
folder.
Smooth Iterations: The number of smoothing iterations to be performed, the larger the model, the
smoother the model and the longer it takes.
Default Value: Click this tool option to restore all default parameters.



ALS Forest
This chapter describes how to deal with aerial (both UAV and airborne) LiDAR data for forestry
applications. This chapter include: Statistical Parameter Extraction, Regression Analysis, Individual Tree
Segmentation, Batch Processing, Clear Tree ID, Extract Point Clouds by Tree ID and ALS Editor.

Theory of Elevation Metrics

Theory of Intensity Metrics

Theory of Canopy Cover

Theory of Leaf Area Index

Theory of Gap Fraction

Forest Metrics

Calculate Forest Metrics by Grid

Calculate Forest Metrics by Polygon

Calculate Forest Metrics by Forest Stands

Regression Analysis

Sample Data and Independent Variables

Linear Regression

Support Vector Machine

Fast Artificial Neural Network

Random Forest Regression

Run Existing Regression Model

Segmentation

View the CHM Segmentation Results

Point Cloud Segmentation

View the Point Cloud Segmentation Results

Generate Seed Points from CHM

Generate Seeds from Layer Stacking

Point Cloud Segmentation from Seed Points

CHM Segmentation

Batch Process

Forest Metrics



Point Cloud Segmentation

Canopy Height Model(CHM) Segmentation

Registration

Auto Registration by Tree Locations
Clear Tree ID

Clear Tree ID by File

Extract by Tree ID

Statistic Individual Tree Attributes

Generate Tree Model

Forest Structure Change Detection

Individual Tree Segmentation Mosaicing

ALS Seed Point Editor

Individual Tree Editor



Theory of Elevation Metrics
Elevation Metrics are statistical parameters related to point cloud elevation. They are frequently used in
regression analysis as independent variables. In this model, 46 statistical parameters related to elevation
and 10 parameters related to point cloud density can be calculated,

Principle Description

Average Absolute Deviation: formula: , where Z  represents the elevation of ith

point within a statistical unit, Z represents the average elevation of all points within a statistical unit,
and n is the number of points in a statistical unit.

Canopy relief ratio: formula: , where mean represents the average elevation of a

statistical unit, min represents the minimum elevation of a statistical unit, and max represent the
maximum elevation of a statistical unit.
AIH (15): Within a statistical unit, all normalized lidar point clouds are sorted according to the
elevation and the cumulative heights of all points are calculated. The cumulative height of X% points
in each statistical unit is the statistical unit's AIH. In LiDAR360, 15 AIH can be calculated, including
1%, 5%, 10%, 20%, 25%, 30%, 40%, 50%, 60%, 70%, 75%, 80%, 90%, 95% and 99%.
AlH Interquartile Distance: formula: , where AIH75% represents the 75% AIH
statistical layer, and AIH25% represents the 25% AIH statistical layer.
Coefficient of Variation: It is the coefficient of variation of Z values for all points in a statistical unit.

formula: , where, Z  represents the standard deviation of elevation within a

statistical unit, and, Z  represents the average elevation within a statistical unit.
Density Metrics (10): The point cloud data is divided into ten slices with the same height interval
from low to high, and the proportion of returns in each height interval is the corresponding density
metrics.
Kurtosis: The kurtosis of the Z value of all points in a statistical unit. formula:

, where Z  represents the elevation of ith point within a

statistical unit, Z represents the average elevation of all points within a statistical unit, n is the number
of points in a statistical unit, and σ is the standard deviation of point cloud height distribution within a
statistical unit.
MADMedian: The median of median absolute deviation.
Maximum: The maximum value of Z of all points in a statistical unit.
Minimum: The minimum value of Z of all points in a statistical unit.
Mean: The mean value of Z of all points in a statistical unit.
Median: The median of Z of all points in a statistical unit.

Generalized means for the 2nd power: formula: , where Z  is the Z value of the ith

point n in a statistical unit, and n is the number of points in a statistical unit.

Generalized means for the 3rd power: formula: where, Z  represents the elevation of
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ith point within a statistical unit, and n is the number of points in a statistical unit.
Elevation Percentile (15): Within a statistical unit, all normalized lidar point clouds are sorted by
elevation, and then the elevation at which X% of points in each statistical unit are located is the
elevation percentile of this statistical unit. In LiDAR360, 15 elevation percentiles are calculated,
including 1%, 5%, 10%, 20%, 25%, 30%, 40%, 50%, 60%, 70%, 75%, 80%, 90%, 95% and 99%.
Elevation Percentile Interquartile Distance: formula: , where Ele75%
represents the 75% elevation statistical layer, and Ele25% represents the 25% elevation statistical
layer.
Skewness: This value shows the symmetry of Z values of all the points in each statistical unit.

formula: , where Z  represents the elevation of ith point within a statistical unit, Z

represents the average elevation of all points within a statistical unit, n is the number of points in a
statistical unit, and σ is the standard deviation of point cloud height distribution within a statistical unit.
Standard Deviation: The standard deviation of Z values of all points in a statistical unit.
Variance: The variance of Z of all points in a statistical unit.

i



Theory of Intensity Metrics

Summary

The intensity metrics are similar to the elevation metrics with the exception that point intensity is used
rather than point elevation. Therefore, this function can be used only if the point cloud data contains
intensity information. Overall, 42 statistical parameters related to intensity can be calculated, and the
resultant product is a table in CSV format or a set of TIFF files.

Principle

Average Absolute Deviation: Computed using the following equation: , where I

represents the intensity of i  point within a statistical unit, I represents the average intensity of all
points within a statistical unit, and n is the number of points in a statistical unit.
AII (15): Within a statistical unit, all normalized lidar point clouds are sorted according to their intensity
values and the cumulative intensities of all points are calculated. The cumulative intensity of X%
points in each statistical unit is the statistical unit's AIH. In LiDAR360, 15 AIH can be calculated,
including 1%, 5%, 10%, 20%, 25%, 30%, 40%, 50%, 60%, 70%, 75%, 80%, 90%, 95% and 99%.

Coefficient of Variation: Computed using the following equation: , where I

represents the standard deviation of intensity within a statistical unit, and I  represents the
average intensity within a statistical unit.
Kurtosis：The kurtosis of the intensity values of all points in a statistical unit. The calculation formula

is , in which Z  is the intensity value of the i-th point in each

statistical unit, Z is the average intensity of all points in each statistical unit, n is the point number in
each statistical unit, and σ is the standard deviation of point cloud intensity distribution within a
statistical unit.
MADMedian：The median of median absolute deviation of the intensity values of all points in a
statistical unit.
Maximum：The maximum of the intensity values of all points in a statistical unit.
Minimum：The minimum of the intensity values of all points in a statistical unit.
Mean：The mean of the intensity values of all points in a statistical unit.
Median：The median of the intensity values of all points in a statistical unit.
Skewness: This value shows the symmetry of intensity values of all the points in each statistical unit.

The calculation formula is , in which Z  is the intensity value of the i-

th point in each statistical unit, Z is the average intensity of all points in each statistical unit, n is the
point number in each statistical unit, and σ is the standard deviation of point cloud intensity
distribution within a statistical unit.
Standard Deviation：The standard deviation of the intensity values of all points in a statistical unit.
Variance: The variance of the intensity values of all points in a statistical unit.
Intensity Percentile (15)：Within a statistical unit, all normalized lidar point clouds are sorted by
intensity, and then the intensity at which X% of points in each statistical unit is located is the intensity
percentile of this statistical unit. In LiDAR360, 15 intensity percentiles are calculated, including 1%,
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5%, 10%, 20%, 25%, 30%, 40%, 50%, 60%, 70%, 75%, 80%, 90%, 95% and 99%.
Intensity Percentile Interquartile Distance: Computed using the following equation:

, where Int75% represents the 75% intensity statistical layer, and Int25%
represents the 25% intensity statistical layer.



Theory of Canopy Cover
Canopy Cover is the percentage of vertical projection of forest canopy to forest land area (Jennings et
al.,1999). It is an important parameter in forest management, and it is also an essential factor for
estimating forest volume.

Principle Description

LiDAR360 adopts two different algorithms for calculating canopy cover for point cloud with and without
return number information respectively. If the point cloud has return number information, it will be first
divided into different grids according to a user-defined xsize and ysize.

Where CC is canopy cover, n is the number of vegetation first returns, n  is the number of all first
returns.

If the point cloud hasn’t return number information. For a certain statistical unit, canopy cover can be
calculated as the ratio of vegetation points to total points. Similar to the calculation of Theory of Gap
Fraction, points higher than the height threshold in the calculation process are considered as vegetation
points.

Where CC is canopy cover, n is vegetation return, n is the total number of returns.

According to (Ma et al., 2017), the canopy cover generated from these two methods have no significant
difference. The resultant product is a raster file in TIFF format, the value ranges from 0 (no canopy
cover/completely open) to 1 (completely covered by canopy).
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Theory of Leaf Area Index
The Leaf Area Index (LAI) is one of the most basic parameters that characterizes the forest canopy
structure. It is defined as half of the surface area of all leaves projected on the surface area of a unit
(Chen et al., 1991), LAl can be calculated from the normalized LiDAR vegetation points.

Schematic diagram of LAI theory principle (a) Direction of light incidence, (b) the zenith angle refers to the
angle between the incident ray and the vertical direction, (c) the projection of the leaf in the vertical
direction, (d) describes the extinction coefficient, and (e) describes the aggregation coefficient.

Principle Description

LAI value is calculated using the following equation:

where, ang is the average scan angle, GF is the gap fraction, and k is the extinction coefficient, which is
closely related to the leaf angle distribution (Richardson et al.,2009).

The average scan angle is calculated from LiDAR points using the following equation:

where, ang is the average scan angle, n is the number of LiDAR points and angle  is the scan Angle of the
ith LiDAR point.

The Gap Fraction (GF) is calculated using the following equation:

where, n  is the number of ground points and n is the total number of LiDAR points.

    @inproceedings{
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        year={1991}
    }
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Theory of Gap Fraction

Summary

Gap Fraction is a crucial variable that governs interactions between light and vegetation and requires
accurate modelling to predict light climate in the canopy, photosynthetic activity or canopy reflectance.

Principle

The Gap Fraction (GF) is calculated using the following equation:

where n  is the number of ground points and n is the total number of vegetation and ground points.
Note that all LiDAR points with a normalized height lower than the user-defined height break (2m is
commonly used) are treated as ground points in gap fraction calculation (Richardson et al.,2009).

    @inproceedings{
        author={Richardson J J, Moskal L M and Kim S H},
        title={Modeling approaches to estimate effective leaf area index from aerial discrete-return LIDAR},
        booktitle={Agricultural and Forest Meteorology,149: 1152-1160},
        year={2009}
    }
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Forest Metrics
The Forest Metrics menu contains Elevation Metrics, Intensity Metrics, Canopy Cover, Leaf Area Index,
and Gap Fraction generated from point cloud data.

Calculate Forest Metrics by Grid

Calculate Forest Metrics by Polygon

Calculate Forest Metrics by Forest Stands



Calculate Forest Metrics by Grid

Functional Overview

Calculate the forest metrics based on the point cloud data in grids. Split the point cloud data with multiple
grids, and then calculate the forest metrics in each grid. The forest metrics include elevation, intensity,
canopy cover, Leaf Area Index and gap fraction. First, this function will divide the point cloud into different
grids with a certain size in the horizontal direction. And then Calculate the forest metrics based on users
selection, and, for each grid, generate a CSV file or TIFF file to store the result.

Usage

Click ALS Forest > Forest Metrics > Calculate Forest Metrics by Grid to generate the selected forest
metrics.

Parameters Settings

Input data: Ensure that each input point cloud data is normalized; the input file can be a single data
file or a point cloud data set; the file(s) to be processed must be opened in the LiDAR360 software.
XSize and YSize (meter) (default value is "15"): This value should be larger than the crown size of
the trees. For the data acquired from most of the forest, this value should be larger than 15.
Height Threshold (meter) (default value is "2"): The threshold to divide the data in vertical
direction. The point cloud above this height will be used to calculate the forest metrics. The default
value is 2m.
Leaf Angle Distribution (default "0.5"): A mathematical expression of leaf probability distribution in
three-dimensional space, which is related to vegetation type, leaf angle, and beam direction.
According to the empirical formula, the user can determine the value of leaf angle distribution
according to the actual situation of the forest. Studies have shown that the elliptic distribution of leaf



angle, which has a leaf angle distribution value of 0.5, may be applicable to the actual situation.
Output Path: Output path. After running, each input point cloud data file will generate a
corresponding CSV file or a set of TIFF files, which can be used as independent variables in
regression analysis.
Default: Restore the setting parameters to the default values.

Note: Only when the point cloud data is loaded in the software can you use the Elevation Metrics
function; otherwise, the message "There is no point cloud data meeting the conditions of calculation!"
will pop up. If the maximum Z value of the point cloud is greater than 200 or the maximum Z minus
the minimum Z is greater than 200, the data is considered to be unnormalized, and the software will
pop up the prompt message shown in the figure below, click "YES", this type of data Still participating
in the calculation, click "NO", this type of data will not participate in the calculation, and the user can
re-select the data that meets the conditions.



Calculate Forest Metrics by Polygon

Functional Overview

Calculate the forest metrics based on the point cloud data in the given polygon file. The forest metrics
include elevation, intensity, canopy cover, Leaf Area Index and gap fraction. Read the position information
of the polygon(s) stored in the input SHP file. Calculate the forest metrics and generate a result record for
each polygon.

Usage

Click ALS Forest > Forest Metrics > Calculate Forest Metrics by Polygon to generate the selected forest
metrics.

Parameters Settings

Input Data: Make sure that all the input files are normalized. The input file(s) can be a single file or a
file set. The file(s) to be processed must be opened in LiDAR360 before using this function.
SHP file: The vector data that contains the polygon(s) in which the users need to generate the forest
metrics. The SHP file can be added to LiDAR360 or manually input by the users.
Height Threshold (meter) (default value is "2"): The threshold to divide the data in vertical
direction. The point cloud above this height will be used to calculate the forest metrics. The default
value is 2m.
Leaf Angle Distribution (default "0.5"): A mathematical expression of leaf probability distribution in
three-dimensional space, which is related to vegetation type, leaf angle, and beam direction.
According to the empirical formula, the user can determine the value of leaf angle distribution
according to the actual situation of the forest. Studies have shown that the elliptic distribution of leaf
angle, which has a leaf angle distribution value of 0.5, may be applicable to the actual situation.
Output Path: Path of the output file. After the output path is run, each calculation will generate a
corresponding CSV file.
Default: Restore the height threshold and leaf inclination angle distribution to the default values.

Note: Only when the point cloud data is loaded in the software can you use the Elevation Metrics function;
otherwise, the message "There is no point cloud data meeting the conditions of calculation!" will pop up. If
the maximum Z value of the point cloud is greater than 200 or the maximum Z minus the minimum Z is



greater than 200, the data is considered to be unnormalized, and the software will pop up the prompt
message shown in the figure below, click "YES", this type of data Still participating in the calculation, click
"NO", this type of data will not participate in the calculation, and the user can re-select the data that meets
the conditions.



Calculate Forest stands by Forest Stands

Functional Overview

Calculate forest stands by forest stands for each point cloud data,can calculate many kinds of forest
metrics.The metrics include Elevation Metrics, Intensity Metrics, Canopy Cover, Leaf Area Index, and Gap
Fraction. For each point cloud data, a record will be generated and stored in a CSV file.

Usage

Click ALS Forest > Forest Metrics > Calculate Forest Metrics by Forest Stands to generate the selected
forest metrics.

Parameters Settings

Input data: Ensure that each input point cloud data is normalized; the input file can be a single data
file or a point cloud data set; the file(s) to be processed must be opened in the LiDAR360 software.
Height Break (meter) (default value is "2"): The threshold to divide the data in vertical direction.
The point cloud above this height will be used to calculate the forest metrics. The default value is 2m.
Extinction Coefficient (default "0.5"): A mathematical expression of leaf probability distribution in
three-dimensional space, which is related to vegetation type, leaf angle, and beam direction.
According to the empirical formula, the user can determine the value of leaf angle distribution
according to the actual situation of the forest. Studies have shown that the elliptic distribution of leaf
angle, which has a leaf angle distribution value of 0.5, may be applicable to the actual situation.
Output Path: Output path. After running, each input point cloud data file will generate a
corresponding CSV file or a set of TIFF files, which can be used as independent variables in
regression analysis.
Default: Restore the height threshold and leaf inclination angle distribution to the default values.



Note: Only when the point cloud data is loaded in the software can you use the Elevation Metrics
function; otherwise, the message "There is no point cloud data meeting the conditions of calculation!"
will pop up. If the maximum Z value of the point cloud is greater than 200 or the maximum Z minus
the minimum Z is greater than 200, the data is considered to be unnormalized, and the software will
pop up the prompt message shown in the figure below, click "YES", this type of data Still participating
in the calculation, click "NO", this type of data will not participate in the calculation, and the user can
re-select the data that meets the conditions.



Regression Analysis
The basic idea of the regression analysis is: firstly, establish a regression model between in-situ forest
parameter measurements and LiDAR statistics at the plot level, and then use the obtained model to
predict forest parameters from LiDAR statistics. Studies have shown that the regression methods can
estimate forest parameters that cannot directly derive from LiDAR point cloud, such as aboveground
biomass, and achieve a relative high accuracy without saturation (Popescu et al., 2004). However,
building regression models requires a number of field measurement data. Please refer to Forestry FAQ for
the selection of field measurements.

Sample Data and Independent Variables

Linear Regression

Support Vector Machine

Fast Artificial Neural Network

Random Forest Regression

Run Existing Regression Model

    @inproceedings{
        author={Popescu S C and Wynne R H},
        title={Seeing the trees in the forest: Using lidar and multispectral data fusion with local filtering
 and variable window size for estimating tree height},
        booktitle={Photogrammetric Engineering and Remote Sensing, 70(5): 589-604},
        year={2004}
    }



Sample Data and Independent Variables

Sample Data

All regression methods require sample data derived from field measurements to train the regression
model. The sample data can be imported using the “Import Training Data” dialog of each regression
model. The imported file should be in text format (.txt extension) and must contain a header to label each
column. The first two columns should be the X and Y coordinates of each sample, followed by any
dependent values.Note that multiple dependent values can be given, but only one can be used for each
regression execution. If each sample corresponds to a tree, the value of the dependent variable can be
the height of the tree. SeeSample Data File in the File Formatssection of the Appendix for information
about sample data file.

 then be viewed in the Import Training Data section.

Dependent Variable: This parameter defines the dependent variable used in the regression analysis.
Only one dependent variable from the sample data file can be selected each time.

Plot Type: This parameter defines the plot type. It should be selected based on the plot surveying
methodology.

Square (default): The plot is square.
Circle: The plot is circle.
Length (meter): When the plot type is square, set the length of the plot.
Radius (meter): When the plot type is circle, set the radius of the plot.
Local Error Buffer: When the plot type is circle, set the radius of the plot.
X: X coordinate of the plot center.
Y: Y coordinate of the plot center.

Independent Variables

Users can also import data in .csv or .tif format. While importing a.csv table, only one can be selected at a
time, and must contain at least four fields, including X, Y, X size, and Y size (each column would be added
to the list as an independent variable). However, multiple .tif images can be added at once. Every time a
.tif image is added successfully, an independent variable named after the file name of .tif will be added to
the list. n the selection of the independent variables, select the independent variable used in regression
analysis (for more information about each independent variable, refer to elevation, intensity, canopy cover,
leaf area index and gap fraction).



Linear Regression

Description

This tool use Python scikit-learn and NumPy to build linear regression model.

Usage

Click ALS Forest > Regression > Linear Regression.

Parameters

Sample data：Refer to Sample data and dependent variable.
Dependent variable：Refer to Sample data and dependent variable.
Plot type：Square or circle.
Length：Length or radius of the plot.
Optimize by considering location uncertainty：If check, the value in the location uncertainty
represents the accuracy value of the range query. The model will query all sample points that meet

http://scikit-learn.org/stable/
http://www.numpy.org/


the conditions according to the range (if the number of sample points exceeds 50, the first 50 points
will be selected as samples), and then the model will be selected based on these sample points The
best point is used as analysis data. If uncheck, the model will select the closest point as the analysis
data according to the sample point.
Accuracy assessment：Using the K-Fold cross evaluation model. According to the input K-Fold
parameters, the samples are divided into K class, one of them is taken as the test data in turn, the
others are used as the training data for model training, the test data is used for testing, and the
smallest error is selected The model of is used as the best model. Note: The K-Fold value must be
greater than or equal to 2.
Save regression Model：If check, the model will be generated in output path.
Save regression dataset：If check, the csv will be generated in output path.
Output path：To select output path. The corresponding model report (linear regression.html) file will
be generated, which records the error and related values of the model; the corresponding result file
(linear regression.tif) will be generated, which is calculated according to the model and the imported
tif or csv file The value of the independent variable predicts the result of the corresponding dependent
variable; and according to the check situation, choose to generate the regression model and data set.

Note: The imported sample data must be included in the imported independent variable data range.
Independent variables can be added or deleted according to the actual situation. The final result file is
generated based on the imported independent variable information.



Support Vector Machine

Summary

This tool is an implementation of the LIBSVM (Chang et al.,2011) for support vector regression (SVR).
LiDAR360 supports forest metrics estimation using two SVR types (epsilon-SVR and nu-SVR) and four
kernel types (linear, polynomial, radial basis function and sigmoidal).

Usage

Navigate to ALS Forest > Regression Analysis > Support Vector Machine.

Settings

Import Training Data: Refer to Sample Data and Independent Variables.
Independent Variables: Refer to Sample Data and Independent Variables.
Kernel Type: Users can select the type of kernel function here including RBF function, Linear,
Polynomial, and Sigmoid.



RBF Function (default): , where γ > 0.
Linear: .
Polynomial: , where γ > 0.
Sigmoid: .

SVM Type: Two types of SVM method are provided.
EPSILON_SVR (default): EPSILON SVR(ϵSVR ).
NU_SVR: NU SVR(νSVR).

Degree (default value is "3"): Kernel function parameter.
Gamma (default value is "0.1"): Kernel function parameter.
Accuracy Assessment: Based on the K-Fold cross validation model, a sample would be partitioned
into k subsets according to input K-Fold value (no less than 2). Take one of subsets as a validation
dataset and the remaining subsets as training datasets to form a model, then run this model and test
the fitting of validation set to training sets. Repeat this process until every subset is treated as a
validation set at least once and select out the model with the least MSE (mean square error) as the
optimal model.
Save Regression Model: Tick the checkbox to save the SVM model (Support Vector
Machine.model) under the output path.
Save Regression Dataset: Tick the checkbox to save the training dataset (Support Vector
Machine.csv) in .csv format under the output path.
Output Path: Choose an output directory. A support vector machine regression model report
(Support Vector Machine.html), recording the model's parameters and accuracy (R-square, RMSE),
would be generated under this directory. A prediction result file (Support Vector Machine.tif), based
on the support vector machine regression model and input variables from a .tif or .csv file, would also
be generated under this output directory.



Note: The dimension of imported sample/training data must be within the scope of independent
variables, which may be adjusted accordingly. The model/result is based on the passed-in variables.

    @inproceedings{
        author={Chang C C and Lin C J},
        title={LIBSVM: A Library for Support Vector Machines},
        booktitle={ACM,2(3):1-27},
        year={2011}
    }



Fast Artificial Neural Network

Summary

Implementation of FANN (Fast Artificial Neural Network) regression to provide ANN (Artificial Neural
Network) regression.

Usage

Navigate to and click on ALS Forest > Regression Analysis > Fast Artificial Neural Network.

Settings

Import Training Data: Refer to Sample Data and Independent Variables.
Independent Variables: Refer to Sample Data and Independent Variables.
Momentum (default value is "0.6"): Set the momentum parameter in ANN regression analysis for
selecting the optimized path.
Learning Rate (default value is "0.7"): The global learning rate for training the network.

http://leenissen.dk/


Accuracy Assessment: Based on the K-Fold cross validation model, a sample would be partitioned
into k subsets according to input K-Fold value (no less than 2). Take one of the subsets as a
validation dataset and the remaining subsets as training datasets to form a model, then run this model
and test the fitting of the validation set to training sets. Repeat this process until every subset is
treated as a validation set at least once then select out the model with the least MSE (mean square
error) as the optimal model.
Save Regression Model: Tick the checkbox to save the ANN model (Fast Artificial Neural
Network.model) under the output path.
Save Regression Dataset: Tick the checkbox to save the ANN training dataset (Fast Artificial Neural
Network.csv) in .csv format under the output path.
Output Path: Choose an output directory. A fast artificial neural network regression model report
(Fast Artificial Neural Network.html), recording the model's parameters and accuracy (R-square,
RMSE), would be generated under this directory. A prediction result file (Fast Artificial Neural
Network.tif), based on the fast artificial neural network regression model and input variables from a .tif
or .csv file, would also be generated under this output directory.

Note: The dimension of imported sample/training data must be within the scope of independent
variables, which may be adjusted accordingly. The model/result is based on the passed-in variables.



Random Forest Regression

Principle Description

This tool use Python Package scikit-learn and NumPy to build up the Random Forest model.

Usage

Click ALS Forest > Regression Analysis > Random Forest Regression.

Setting

Sample Data: Please refer to Sample Data and Independent Variables。
Independent Variables: Please refer to Sample Data and Independent Variables。
Random Forest: These values define Random Forest's parameters.

Tree Num：Tree number in the Random Forest model.
Max Depth：The maximum depth of Random Forest model.
Min Split：The minimum split of Random Forest model.
Min Leaf：The minimum leaf number in Random Forest model.

Accuracy Assessment：Use K-Fold cross-validation model. According to the inserted K-Fold
parameters, divide the sample into K groups. Each group will be taken as testing data by training the
model using other remianing samples. Note that K-Fold value should be larger than 1 (don't include
1).
Save Regression Model: If the box is checked, a model named (Random Forest.model) will be
generated in the output path, after the program being successfully run.
Save Regression Dataset：If the box is checked, a training data model named (Random Forest.csv)
will be generated in the output path, after the program being successfully run.
Output Path: The path for the output files. The software will generate a model report (Random
Forest.html) with the residuals and related values of the model, a result file (Random Forest.tif), and a
regression model file (optional).
Default Value: Restore all the default values for all parameters.

http://scikit-learn.org/stable/
http://www.numpy.org/


Note: The inserted sample data must be included in the range of inserted independent variables. The
number of independent variables can be changed based on the users' situation. The final result is
generated according to the inserted independent variables. Max Depth and Tree Num should be
greater than 0.



Run Existing Regression Model

Summary

This tool estimates forest metrics using any available regression models (Linear Regression, Support
Vector Machine, Fast Artificial Neural Network and Random Forest Regression).

Usage

Navigate to ALS Forest > Regression Analysis > Run Existing Regression Model.

Insert Model File

Select a regression model file (*.model) generated by the regression analysis tools, including linear
regression, support vector machines, fast artificial neural network, or random forest, etc.

Insert Independent Variables

Inserted file should be in CSV or TIF format. CSV files must have attributes of X, Y, XSize, and YSize.
Each attribute will be added into the list as a independent variable. Only one CSV file can be added; while
several TIF files can be added. Each TIF will be added to the list as a independent variable with its file
name. The number of independent variables must be the same as the number of independent variables in
the model selected. (To learn more about each independent variable, please refer to Elevation Metrics,
Intensity Metrics, Canopy Cover, Leaf Area Index, and Gap Fraction)



Setting

Plot Type: This parameter defines the plot type. Users can choose that according to the survey in the
sample data.

Square (default): The plot is in square shape.
Circle: The plot is in circle shape.

Length (meters): When the plot type is square, set the length of the plot.
Radius (meters)：When the plot type is circle, set the radius of the plot.

Output Path: Select the path for the output files. The software will generate two files, "Regression
Predict.tif" file and "Regression Predict.html" report, after succeeding to predict. The TIF file is the
result of prediction.

Note: the number of inserted independent variable must be the same as the number of independent
variables in the inserted model. Otherwise, it will lead to failing to predict or large residuals.



Segmentation
Segmentation provides a series of functions for segmenting individual trees and therefore acquire
individual tree attributes from ALS data.

CHM Segmentation

View the CHM Segmentation Results

Point Cloud Segmentation

View the Point Cloud Segmentation Results

Generate Seed Points from CHM

Generate Seeds from Layer Stacking

Point Cloud Segmentation from Seed Points



CHM Segmentation

Summary

CHM segmentation utilizes the watershed segmentation (Chen et al., 2006) technique to identify and
delineate individual trees, and therefore obtain individual tree information, such as tree location, tree
height, crown diameter, crown area and tree boundaries.

Principle

The basic principle of watershed segmentation algorithm is if placing a water source in each regional
lowest point in the CHM and flooding the entire relief, barriers can be generated when different water
sources meet. The resulting set of barriers can build a watershed by flooding, which is the segmentation
result. Note that the CHM segmentation result can be affected by the CHM resolution. It is recommended
that the CHM should have a spatial resolution higher than 1 m to ensure a sufficient segmentation result.
Moreover, the CHM segmentation result can also be largely influenced by tree density and tree species. If
the algorithm does not work well in certain study area, users can try to use other segmentation algorithms
to get the best segmentation result.

(a) CHM; (b) Watershed Segmentation Algorithm; (c) CHM Segmentation Result

Usage

Navigate to ALS Forest > Segmentation > CHM Segmentation.

Settings



Input Data: The input file can be a single CHM file or multiple CHM files. The data should be opened
in LiDAR360 before being processed.
Maximum Tree Height (meter)(default value is "80"): The threshold defining the maximum tree
height in a study areas. CHM pixels above this threshold will not be considered in the segmentation.
Minimum Tree Height (meter)(default value is "2"): The threshold defining the minimum tree height
in a study areas. CHM pixels below this threshold will not be considered in the segmentation.
Buffer Size (pix)(default value is "50"): A threshold controls the block size for performing CHM
segmentation, which can avoid physical memory overflow. This value should be larger than the
maximum crown area and smaller than 1500. If the CHM is larger than 1500 by 1500 pixels, the CHM
will be forced to divided into a number of blocks with a size of 1500 by 1500 pixels.
Crown Base Height Threshold (meter)(default value is "0.8"): The starting height of the crown
range. A reasonable base height value can help to improve the accuracy of the boundary and area of
crown. After setting the base height, the pixels higher than this height will be included to generate the
vector boundary of crown, while the pixels lower than this height will be excluded. Users should set
this value according to the species and growing situation of the trees in order to get the best result.
Gaussian Smooth (optional): This parameter is to control whether to perform Gaussian smoothing.
In general, it is recommended to check the Gaussian smoothing option to remove noise effects.
Sigma (default value is "1"): Gaussian smoothing factor. The greater the value is, the smoother the
results are. The degree of smoothness can affect the number of trees being segmented. In the case
of under-segmentation, it is recommended to reduce this value (e.g. 0.5); and in the case of over-
segmentation, it is recommended to increase the value (e.g. 1.5).
Radius (pix)(default value is "5"): The window size used by Gaussian smoothing, which should be
an odd number. Generally, it can be set to the average crown diameter.
Output Path: Path of the output file. The resultant product is a comma-separated table in “csv” format
and a polygon file in "shp" format. The CSV table contains the ID, location (x and y coordinates),
height, crown diameter, and crown area of each segmented tree. The shp file contains the boundary
of each tree, and its corresponding attribute table contains the ID, location (x and y coordinates),
height, crown diameter, and crown area of each segmented tree. Refer to the CHM Segmentation
Results for segmentation result examples.
DefaultValue: Restore the default parameters.

Note: The CHM Segmentation function can only be used when the raster data is loaded in the
software. Otherwise, the message “There is no raster data!” will pop up.

    @inproceedings{
        author={Chen Q, Baldocchi D, Gong P and Kelly M},
        title={ Isolating Individual Trees in a Savanna Woodland Using Small Footprint Lidar Data},
        booktitle={Photogrammetric Engineering and Remote Sensing, 72(8): 923-932},
        year={2006},
    }



View the CHM Segmentation Results
After the CHM segmentation is completed, each input CHM data will generate a corresponding CSV file
and SHP file, and the CHM can be superimposed and displayed with the CSV file and the shp file. Load
the CHM, csv and shp files into the software respectively. The following figure shows the superimposed
display effect of CHM and shp data, and the attribute table of csv data.

Open the csv file as a table, as shown below, and select the X, Y, Z corresponding to the TreeLocationX,
TreeLocationY and TreeHeight, respectively. Check the "Show Label" option (if the label has too much
text and block other information, one can remove the data and reopen it without checking the "Show
Label" option). Click “Apply” to load the csv file in the software.

On the csv file name, click the mouse right button, select Table Attribute, and the property information will
be prompted. Double-click on the mouse left button anywhere in each line, the viewer will jump to the
corresponding individual tree location.





Point Cloud Segmentation

Summary

The point cloud segmentation algorithm determines the position, tree height, crown diameter, crown area,
and crown volume of individual tree by analyzing the elevation values of points and their distances from
other points.

Principle Description

Li et(Li et al.,2012) developed a point cloud segmentation algorithm that separates individual trees from
the point cloud one by one. The algorithm works as follows:

Starting with seed point A (global maximum), this algorithm estimates lower points based on critical
spacing and minimum spacing rules to develop a tree cluster from seed point A. For example, if point A is
the highest point, it is considered as the top (target) of Tree 1. Then classify all points below A
successively. First, Point B is classified as Tree 2 because dAB > a set critical value (this parameter is
determined by users). Then we set Point C whose distance dAC is less than the critical value. By
comparing with Points A and B, Point C's category was set to Tree 1 because dAC < dBC. Comparing
with Points B and C classifies Point D into Tree 2; comparing with Points C and D classifies Point E into
Tree 2. The critical value should be equal to the canopy radius. When the critical value is too large or too
small, under-segmentation or over-segmentation may occur.

Usage

Navigate to and click on TLS Forest > Point Cloud Segmentation.



Settings

Input Data: Ensure that each input point cloud data is Normalize by DEM or Normalize by Ground
Points.
From Class: Class involved in point cloud segmentation, with default selection of all categories
contained in the point cloud data.
Grid Size (m) (default: "0.6"): Grid resolution parameter used to identify tree positions, generally set
to one-fifth of the average crown diameter; this parameter usually ranges from 0.3~0.6 meters.
Buffer Size (pix) (default: "50"): When the length and width range of the segmented data exceeds
1500*grid size, block processing will be performed, and this value is the buffer threshold for blocking,
measured in pixels. It can be set as maximum crown diameter divided by raster resolution.
Minimum Tree Height (m) (default: "0"): Minimum tree height threshold for segmenting individual
trees; those below this value will be segmented into individual trees.
Height Above Ground (m)(Default:"2")：Points lower than this threshold are considered not part of
a tree and are ignored during segmentation process.
Gaussian Smoothing：Whether to perform Gaussian smoothing; it is recommended to select
Gaussian smoothing option to remove noise interference.
Sigma(Default:"1")：Gaussian smoothing factor; higher values result in smoother results while lower
values lead to less smoothness. Smoothness affects number of trees segmented out; if under-
segmentation occurs, reduce Sigma value(e.g., 0.5), otherwise increase Sigma value(e.g.,1.5); in
addition to the Gaussian smoothing factor, CHM segmentation results are also affected by CHM
resolution. To adjust CHM resolution, DEM and DSM resolutions need to be adjusted.
Radius (pix) (default: "5"): Window size used for Gaussian smoothing; this value is odd and can
generally be set to the average crown diameter.
Optimize Color Rendering for Individual Tree Segmentation Result(Default Selected)：By
rearranging ID information after tree segmentation, it can greatly solve the problem of adjacent trees
being assigned with same color.
Output File Type: Select output file type including CSV table files and tree attribute files.
Output Path: Output path where each point cloud data will generate corresponding segmentation
result; the result is a comma-separated CSV table or tree attribute file containing attributes such as
Tree ID, x,y coordinates, tree height,crown diameter,crown area,and crown volume; refer to Point
Cloud Segmentation Result File Format in Appendix for details on format.
DefaultValue: Reset each parameter to the default value.



    @inproceedings{
        author={Tao S L, Wu F F, Guo Q H, Wang Y C, Li W K, Xue B L, Hu X Y, Li P, Tian D, Li C,Yao H, Li Y M
, Xu G C and Fang J Y},
        title={Segmentation tree crowns from terrestrial and mobile LiDAR data by exploring ecological theori
es},
        booktitle={ISPRS Journal of Photogrammetry and Remote Sensing,110:66-76},
        year={2015}
    }



View the Point Cloud Segmentation Results
After segmenting the trees, Tree IDs are saved to each point in the point clouds used in the segmentation,
the results can be viewed within a window viewer. Load the point cloud used for the tree segmentation into
a 3D viewer. Ensure the viewer is active and press the Display by Tree ID button in the color tools toolbar.
The following is an example of a point cloud colored by individual tree. The ALS Editor tool can be used to
check the single tree segmentation results. At the same time, it can be used for editing operations such as
add, delete seed points etc., and segment the point cloud data based on the edited seed points.

The tree ID attribute of each point can be queried by the Pick Point（ ）tool on the toolbar.

CSV file generated by segmentation can be superimposed with the point cloud, and the CSV file can be
opened as a table. Select X, Y and Z as the TreeLocationX, TreeLocationY and TreeHeight respectively in
the CSV file as shown below, and check the Show Label (if the label has too much text and blocking other
data, affect the display effect, you can remove the data and open again, do not check the Show Label),
click “Apply” to load the CSV file in the software.



Click the right mouse button on the CSV file name, select Table Attribute, you can view the property
information, double-click the left mouse button anywhere in each line, you can jump to the corresponding
location. The following figure shows the effect of superimposed display of point cloud data and CSV file.
Open the attribute table of the CSV file and double-click to jump to the selected row.



Generate Seed Points by CHM

Summary

This tool aims to generate individual tree seed points from CHM so that they can be used for Point Cloud
Segmentation based on Seeds. The ALS Editor tool can be used to edit the seed points and therefore
improve the individual tree segmentation accuracy.

Usage

Navigate to ALS Forest > Segmentation > Generate Seed Points from CHM.

Settings

Input Data: The input file can be a single CHM file or multiple CHM files. The data should be opened
in LiDAR360 before being processed.
Maximum Tree Height (meter)(default value is "80"): The threshold defining the maximum tree
height in a study areas. CHM pixels above this threshold will not be considered in the segmentation.
Minimum Tree Height (meter)(default value is "2"): he threshold defining the minimum tree height
in a study areas. CHM pixels below this threshold will not be considered in the segmentation.
Buffer Size (pix)(default value is "50"): A threshold controls the block size for performing CHM
segmentation, which can avoid physical memory overflow. This value should be larger than the
maximum crown area and smaller than 1500. If the CHM is larger than 1500 by 1500 pixels, the CHM
will be forced to divided into a number of blocks with a size of 1500 by 1500 pixels.
Gaussian Smooth (optional): This parameter is to control whether to perform Gaussian smoothing.
In general, it is recommended to check the Gaussian smoothing option to remove noise effects.
Sigma (default value is "1"): Gaussian smoothing factor. The greater the value is, the smoother the
results are. The degree of smoothness can affect the number of trees being segmented. In the case
of under-segmentation, it is recommended to reduce this value (e.g. 0.5); and in the case of over-
segmentation, it is recommended to increase the value (e.g. 1.5).
Radius (pix)(default value is "5"): The window size used by Gaussian smoothing, which should be
an odd number. Generally, it can be set to the average crown diameter.



Output Path: Path of the output file. The resultant product is a comma-separated table in “csv” format
which contains ID and x, y, z coordinates of each seed points.
DefaultValue: Restore the default parameters.

Note: Generate Seed by CHM Segmentation function can only be used when the raster data is
loaded in the software. Otherwise, the message “There is no raster data!” will pop up. The interface
and parameters setting of Generate Seed by CHM are the same as those of CHM Segmentation. The
difference between these two tool is that CHM Segmentation will generate a csv file that includes
attributes such as tree height, crown diameter and crown area, and a shp file for tree boundary, while
Generate Seed by CHM will not generate a shp file. For the seed point file format, refer to Seed
Points File.



Generate Seeds from Layer Stacking

Summary

This tool aims to generate individual tree seed points using an layer stacking algorithm so that they can be
used for Point Cloud Segmentation based on Seeds. The ALS Editor tool can be used to edit the seed
points and therefore improve the individual tree segmentation accuracy.

Usage

Navigate to ALS Forest > Segmentation > Generate Seeds from Layer Stacking.

Settings

Input Data: Ensure that each input point cloud data is Normalize by DEM or Normalize by Ground
Points. The input file can be a single file or multiple data files. Point cloud data should be opened in
LiDAR360 before being processed.
XSize (meter)(default value is "1"): Grid x-axis resolution. It is recommended to set this parameter
between 0.3m and 2m.
YSize (meter)(default value is "1"): Grid y-axis resolution, It is recommended to set this parameter
between 0.3m and 2m.
Height Above Ground (meter)(default value is "2"): Usually, it is desirable to ignore points below a
particular height to avoid influence low vegetations (e.g., grass and shrub). Points below this
threshold will not be considered in the segmentation. A value of 2 m is commonly used.
Layer Thickness (meter)(default value is "1"): The layer thickness is used to cut the layer for
stacking. It is recommended to set this parameter between 0.5m and 2m.
Minimum Spacing Between Trees (meter)(default value is "1"): This parameter should be set as
the minimum spacing of the tree. This parameter can be adjusted to avoid over- or under-
segmentation.
Buffer Size (pix)(default value is "50"): A threshold controls the block size for performing
segmentation, which can avoid physical memory overflow. This value should be larger than the



maximum crown area and smaller than 1500. If the image is larger than 1500 by 1500 pixels, it will be
forced to divided into a number of blocks with a size of 1500 by 1500 pixels.
Gaussian Smooth (optional): This parameter is to control whether to perform Gaussian smoothing.
In general, it is recommended to check the Gaussian smoothing option to remove noise effects.
Sigma (default value is "1"): Gaussian smoothing factor. The greater the value is, the smoother the
results are. The degree of smoothness can affect the number of trees being segmented. In the case
of under-segmentation, it is recommended to reduce this value (e.g. 0.5); and in the case of over-
segmentation, it is recommended to increase the value (e.g. 1.5).
Radius (pix)(default value is "5"): The window size used by Gaussian smoothing, which should be
an odd number. Generally, it can be set to the average crown diameter.
Output Path: Path of the output file. The resultant product is a comma-separated table in “csv” format
which contains the ID and x, y, z coordinates of each seed points.
DefaultValue: Restore the default parameters.

Note: Only when the point cloud data is loaded in the software can you use the Generate Seed by
Layer Stacking function; otherwise, the message "There is no point cloud data meeting the conditions
of calculation!" will pop up. If the maximum Z value of the point cloud is greater than 200 m or the
maximum Z minus the minimum Z is greater than 200 m, the data is not considered to have been
normalized, and the prompt information shown in the figure below will pop up. Click “YES” to keep
using this type of data in the operation; otherwise, click "NO" and reselect the input data file. The
seed point file obtained by layer stacking is the same as the seed point file generated by CHM,
please refer to Seed Points File.



Point Cloud Segmentation from Seed Points

Summary

The TLS PCS with Seeds function supports batch processing for multiple files. The input data includes
normalized point cloud data and the corresponding seed point file. For TLS point cloud normalization,
please refer to the Normalize by DEM or Normalize by Ground Points tool section of the LiDAR360 User
Guide.

Usage

Navigate to and click on TLS Forest > Point Cloud Segmentation from Seed Points.

Parameters

From Class: Classes which participate in the PCS with seeds (all classes by default).
Point Cloud File: Click  to select the point cloud data to be processed.
Seed File: Click  to select the seed file.

: Five datasets can be batch processed per tool run. Click  to add files to be processed.
: Delete the selected point cloud and seed points file.
: Clear the file list.

Height Above Ground (meter)(default value is "2"): Only the points above this hight will be
involved in individual tree segmentation. This parameter is used to decrease the influence of ground
points and weeds to the segmentation. It will influence the accuracy of the detection of trunk, if this
value is too large.
Optimize color rendering for individual tree segmentation result (checked by default): By
reorganizing the tree ID generated after the individual tree segmentation, it can greatly solve the
problem of rendering the same color to the trees next to each other. Note: if choosing to optimize the



color rendering, the tree IDs in new csv file for individual tree segmentation are not one-to-one
correspond to those in the input seeds files.
Output File Format:Select the format of output file, choice including .csv attribute table and tree
attribute file.
Output Path: Path of the output file, which is a comma-separated database table in the .csv format
containing the ID of each individual tree identified during the segmentation process, the x, y
coordinate of each individual tree, individual tree heights, DBHs, crown diameters, crown areas, and
crown volumes.
DefaultValue: Reset each parameter to the default value.



Batch Process
The batch processing menu contains the automated workflows for the extraction of forest metrics, which
includes Forest Metrics, Point Cloud Segmentation, Canopy Height Model(CHM) Segmentation, and all
prerequisites for these operations as follows:

1. Remove Outliers
2. Classify Ground Points (Filter)
3. DEM
4. Normalize by DEM
5. Forest Metrics, Point Cloud Segmentation or Canopy Height Model(CHM) Segmentation processing

Forest Metrics

Point Cloud Segmentation

Canopy Height Model(CHM) Segmentation



Forest Metrics

Usage

Navigate to ALS Forest > Batch Process > Forest Metrics. The For Forest Metrics tool can extract all
metrics found in the ALS Forest > Forest Metrics automatically.

The first interface that appears in the dialog box is a series of steps to be followed in the automatic
extraction of statistical parameters.

If any process has been completed, it can be ignored in the batch. Clicking “Next” will prompt a dialog
shown as follows to ask whether the uncheck step has been done? If yes, click "OK" to the next step to
select the file for batch processing.

All the point cloud data opened in the software is showed in the list of unprocessed file. Users can
determine whether the data is involved in the operation use the check box in front of the file name. By
default, each point cloud data will be processed separately. If you check "Merge files into one", the
software will merge the selected point cloud data into one file before subsequent processing.

Click “Next” and set appropriate parameters for all steps involved in the batch processing.

For parameters setting of "Outlier Removal", please refer to Remove Outliers.



For parameters setting of "Classify Ground Points", please refer to Classify Ground Points.

For parameters setting of "DEM", please refer to DEM.

At the step of "Input DEM File", users can choose the DEM generated by the last step or an existing one
already loaded into the project (the speed of batch processing will increase dramatically if an existing DEM
is used rather than creating it at every batch).



Click “Next” and choose the "Forest Metrics Type" which need to be extracted. Depending on the choice,
a set of parameters will need to be given, please refer to Forest Metrics.

Click “Finish” to begin the batch process.



Point Cloud Segmentation

Usage

Navigate to ALS Forest > Batch Process > Point Cloud Segmentation. The Point Cloud Segmentation tool
is used for automatic segmentation and processing of airborne LiDAR data.

The steps of this process are similar to the Forest Metrics. For more information about the point cloud
segmentation, please refer to the Point Cloud Segmentation.



Canopy Height Model(CHM) Segmentation

Usage

Navigate to ALS Forest > Batch Process > Canopy Height Model(CHM) Segmentation. The CHM
Segmentation tool is used for automatic segmentation and processing of CHM derived from LiDAR data.

The steps of this process are similar to the Forest Metrics. For more information about the CHM
segmentation, please refer to the CHM Segmentation.



Registration
Registration method for forestry data.

Tree Based Point Cloud Registration



Auto Registration by Tree Locations

Summary

This function register two point cloud data sets based on the location of the trees (Li J , Zhao P , Hu Q , et
al., 2020) (Guan H , Su Y , Hu T , et al., 2019). The location information of the trees is stored in a CSV file,
and the file should at least contain two attributes, the TreeLocationX and TreeLocationY. Please refer to
Individual Tree Segmentation Result File Format for the detailed format information. The data to be
registered must be two flat surface with trees, which means the registration will only translate the data and
rotate the data around the Z-axis. The calculation of the transform matrix consists of two steps, namely the
calculation of the horizontal rotation matrix and the calculation of the vertical translation. For horizontal
transform, this function first creates feature descriptors for each individual tree position; then votes based
on the similarity of the feature descriptors. The individual tree position with the higher score will be used
as the matching point, and finally calculate the two-dimensional rotation matrix according to the matching
points. For registration in the vertical direction, this function first obtains the point cloud in the
neighborhood of each individual tree, and then uses the maximum or minimum value in the point cloud for
registration in the Z direction. This process uses the 3σ principle to make the confidence level of the
difference in Z direction highest. The success rate of registration depends on the matching degree
between the point cloud to be registered and the corresponding position of the registration point cloud.
The higher the matching degree, the higher the algorithm success rate. The matching degree of individual
tree depends on the degree of data overlap. the accuracy of position, and so on.

Usage

Click ALS Forest > Registration > Auto Registration by Tree Locations

Settings

Reference Point Cloud: The reference point cloud data. After the registration, the point cloud to be
registered will be transform to the coordiante system of the reference point cloud.



Point Cloud to be Registered: The point cloud data to be registered. After the registration, the
transform matrix will be applied to this point cloud data and generate a new file.
Number of Neighborhood Points (default value is 8): The size of the neighborhood used to
generate the feature descriptors. The increase of the size of the neighborhood will increase the time
complexity of the algorithm, while it will increase the robustness of the feature descriptors at the same
time. The decrease of this value will improve the algorithm efficiency, while it will increase the number
so that the matching point outliers as well. This value should be set to 8 ~ 12.
Minimum Votes (default value is 6): The individual tree positions below this number of votes will be
considered as outliers and will not participate in the match. The smaller this value, the more matching
points will be obtained, but the error of matching point pairs will also be greater. The larger this value
is, the fewer matching points are obtained. If the value is too large, there will not be enough matching
points for transform matrix calculation. When the number of neighborhood points increases, this value
can be increased accordingly. This value should be set to 6 ~ 9.
Homography Matrix Backprojection Error (default value is 3.0): Backprojection error of
homography matrix. Candidate points selection is performed by using homography matrix combined
with Ransac algorithm. The smaller the backprojection error, the fewer the matching points of the
selected single wood and the higher the matching degree. The larger this value is, the looser the filter
conditions for matching points are, and the greater the error of matching point pairs. While this value
is too small, it may lead to not enough matching points participating in the calculation. This value
should be set to 2~4 most suitable.
Searching Radius （meter) (default value is 2.0): When performing Z-direction registration, the
search radius used for neighborhood search. When registering in the Z direction, users need to find
the real point cloud of each individual tree in a certain neighborhood on the XY plane, and then use
the coordinates of the real point cloud for registration. If the value is too large or too small, the point
cloud will not be able to describe the real terrain relief. This value should be set to 1.0~3.0, if it is too
large, it will reduce the efficiency of the algorithm.
Z Translation ("Minimum" by default): There are two registration methods in the Z direction,
namely "maximum value" and "minimum value". This value describes that after performing a radius
search on the position of the individual tree, the "maximum/smallest value" of the point cloud in the
neighborhood is taken as the true matching point, which is used to calculate the final translation in the
Z direction. When using the "maximum value", it is necessary to ensure that there is no missing or
distorted treetop point cloud near the individual tree, otherwise it will be impossible to extract accurate
matching points from the point cloud. When using the "minimum value", it is necessary to ensure that
there are enough ground points near the individual wood, otherwise the Z direction matching will fail.

    @inproceedings{
        author={Li J , Zhao P , Hu Q , et al.},
        title={ Robust point cloud registration based on topological graph and Cauchy weighted lq-norm},
        booktitle={Isprs Journal of Photogrammetry & Remote Sensing, 160:244-259},
        year={2020},
    }

    @inproceedings{
        author={Guan H , Su Y , Hu T , et al.},
        title={ A Novel Framework to Automatically Fuse Multiplatform LiDAR Data in Forest Environments Based
 on Tree Locations},
        booktitle={IEEE Transactions on Geoence and Remote Sensing},
        year={2019},



    }



Clear tree ID

Functional Overview

After the point cloud is segmented, the tree ID information will be saved in the LiData file. If the point cloud
needs to be segmented again, the tree ID information needs to be cleared first.

Usage

Click on Airborne Forestry > Clear Tree IDs.

Select the point cloud data to be processed and click OK.

Parameter Settings

Filter by height: Whether to filter by height, if this option is checked, the tree ID information of the
points between the minimum height and the maximum height will be cleared, if this option is not
checked, the tree ID information of all points will be cleared Tree ID information.
Minimum (default "0"): Clears the minimum elevation of the tree ID.
Max (default "1"): Clears the maximum elevation of the tree ID.



Clear Tree ID based on File

Summary

After the point cloud is segmented, there may be a wrongly segmented tree. The ID corresponding to the
wrongly segmented tree can be recorded in a CSV file, and then the CSV file can be used to clear the
wrongly segmented tree in the point cloud.

Usage

Click ALS Forest> Clear Tree ID by CSV File.

Select the point cloud data to be processed and click OK.



Statistic Individual Tree Attributes

Summary

This function is used to correct the tree heigh, crown area, and other individual tree information after the
individual tree editing.

Usage

Click ALS Forest > Statistic Individual Tree Attributes.

Settings

Input Data: The input data should be the point cloud after individual tree segmentation.
Height Above Ground (meter) (default value is "0.3"): The point above this height will be used in
the segmentation. This parameter can help uses to weaken the influence from the ground or grasses
on the statistics calculation. If this value is too large, it will impact on the detection of tree structure.
Minimum Tree Height (meter) (default value is "2"): This parameter can be set according to the
growth situation of trees in the measuring area. It can be used to filter the small trees.
Output Path: The output path of the statistics result. The file contains the Tree ID, XY location of
each tree, tree height, crown diameter, crown area, and crown volume.
Default: Reset all the parameters as their default values.



Generate Tree Model

Functional Overview

The real tree model is constructed based on the results of segmentation or attribute editing. It can provide
a more intuitive and real model display form for the attribute information, and quickly check and browse
the segmentation results. At the same time, the high-precision and high-fidelity tree model enhances the
sense of reality and immersion for the digital city, woodland and other scenes.

Usage

Click ALS/TLS Forest > Generate Tree Model.

Parameters Settings

Individual Tree Attribute File: The input file is the point cloud individual tree attribute file. The
individual tree attribute file format can refer to the individual tree segmentation result file; The
individual tree attributes file can also come from the individual tree attributes file with the tree species
information after the Tree Species Marker.
Tree Species Model: According to the tree species information contained in the selection file, select
the tree model that shows the tree species in the tree model drop-down box.
Add New Model: Add the tree model as required, set the model corresponding to the perspective
display picture and close shot model object, tree model management reference option Settings in the
forest Settings page of the tree model settings
Output Path: Output path, set the storage path corresponding to the generated tree modeling file,
and generate a folder with the same name in this path to save the resource file used by the tree
modeling file. When we are copying the tree model file, copy the resource folder with the same name.



Extract by Tree ID

Summary

This function is used to extract part or all point clouds from the segmented point cloud based on Tree ID.
When exporting the data into one file, the optional formats include LiData, CSV, and LAS. When exporting
the data into multiple data, the optional format will be CSV file only.

Usage

Navigate to ALS Forest > Extract Point Cloud by Tree ID.

Settings

Select File: Select the point cloud data with segmented tree ID information from the drop-down list.
Only one file can be selected at a time, and it has to be opened in LiDAR360 already.
Min (default value is "0"): The minimum value of tree ID to be extracted. The default value is zero.
Max: The maximum value of tree ID to be extracted. The default value is the number of trees in the
point cloud. If the point cloud has not been segmented, the minimum and maximum values of the tree
ID are both zero.
Extract to A File (default): The point cloud in the selected range is extracted into a CSV, LiData, or
LAS file that contains the X, Y, Z coordinates and tree ID information.
Extract to Multiple Files Based on Tree ID: Extract the point cloud data based on tree ID and save
them as different CSV files for each tree. The stored information are X, Y, Z coordinates and tree ID
information for each tree.
Output Path: Output path for the results.



Forest Structure Change Detection

Summary

The LiDAR PAC (profile area change) metric, as a simple and integrated method, demonstrated promising
potential in characterizing fine-grained changes in forest structure. The method can be beneficial for forest
managers in evaluating fire-induced environmental and economic losses, and provide useful information
for forest restoration design.

Principle Description

First, this function divides the data into different grids according to the XSize and YSize set by the users.
For each grid, normalize the height value of all the points to the range of 0 to 1. And then, sort the points
by height and calculate its cumulative height percentile. Calculate the height value for each integer
cumulative percentile from 0 to 99% (100 values in total). Then fit the 100 cumulative height percentiles to
the profile curve, and calculate the profile area (PA) delineated by the percentile profile curve and the X
axis. After calculating the PA value of the curve area before and after the change, use the PA after the
change minus the PA value before the change to get the PAC value.

Usage

Click ALS Forest > Forest Structure Change Detection

Settings

Input: Make sure that all the input files are normalized. The input file(s) can be a single file or a file
set. The file(s) to be processed must be opened in LiDAR360 before using this function.
XSize (meter) (default value is "30"): The grid size in X direction. This value should be larger than
the crown size of the trees. For the data acquired from most of the forest, this value should be larger
than 15.
YSize (meter) (default value is "30"): The grid size in Y direction. This value should be larger than
the crown size of the trees. For the data acquired from most of the forest, this value should be larger
than 15.
Height Threshold (meter) (default value is "2"): The threshold to divide the data in vertical
direction. The point cloud above this height will be used to calculate the forest metrics. The default
value is 2.
Output Path: Path of the output file. Two PA images (before and after the change), a PAC image,
and a report will be generated.



DefaultValue: Restore the default parameters.

Note: The selected point cloud data must be normalized ALS data.

    @inproceedings{
        author={Tianyu Hu,Qin Ma,Yanjun Su,John J.Battles,Brandon M.Collins,Scott L.Stephens,Maggi Kelly,Qing
hua Guo},
        title={A simple and integrated approach for fire severity assessment using bitemporal airborne LiDAR 
data},
        booktitle={Int J Appl Earth Obs Geoinformation,78(2019): 25-38},
        year={2019}
    }



Individual Tree Segmentation and Matching

Functional Overview

When point cloud segmentation is required or the data area requiring fine tree segmentation is large, the
point cloud needs to be divided into multiple blocks and distributed to multiple data processing personnel
for collaboration. When usingthe block by rangeorblock by polygontool to block point cloud data,it is
inevitable that the same tree in the block boundary area will be divided into two or more parts. In order to
improve the accuracy of the data after the overall segmentation, buffer parameters are set according to
the actual situation of the data during the partitioning. After each piece of data is segmented. You can
remove the same tree in the data buffer area of adjacent point clouds.with this function.

Usage

ClickALS Forest > Individual Tree Segmentation and Matching, organize the results after point cloud
segmentation.

Parameters Settings

Buffer: This parameter is used to find the most matched polygon information in vector data for each
point cloud data. It needs to ensure that the value is correct; otherwise, the correctness of the result
sorting will be affected. This value needsto be the same as the buffer parametersetin the block-by-
rangeor block-by-polygon function.
Input Data: Please ensure that each input point cloud data isis the data after point cloud
segmentationortree segmentation based on seed points.
Point cloud file: Click to select the point cloud data to be processed.
Seed point file: Click to select the seed point file corresponding to the point cloud data.

: Five data can be processed by default. Click to increase the number of files to be processed.
: Deletes the selected point cloud and corresponding seed point files.
: Deletes the file list.



ALS Editor

Description

The ALS seed point editing tool is used to check the results of individual tree segmentation. At the same
time, it allows for manual interactive editing such as adding or deleting seed points. Based on the edited
seed points, the point cloud can be segmented again to improve the accuracy of individual tree
segmentation. Since version 3.2, right-click shortcut menus are supported.

ALS Seed Point Editing Shortcut Keys

|Shortcut Key|Description|

|:----:|:--:|

|Shift + Mouse Left Button|Section translation|

|↑ |Move section up |

|↓ |Move section down |

|→ |Move section right |

|← |Move section left |

|Ctrl + z |Undo seed point editing|

|Ctrl + y |Redo seed point editing

Usage

In an active window, load the ALS point cloud data to be edited.

Navigate to and click on ALS Forest > ALS Editor.

The ALS Editor toolbar options, from left to right, are: Start/End Edit, Open Seed Point File, Save Seed
Point File, Add Seed Points, Select Seed Points, Deselect Seed Points, Cancel Selection, Delete Selected
Seed Points, Clear All Seed Points, Profile, Filter Trees, Point Cloud Segmentation Based on Seed, Clear



TreeID, Seed Setting, and Exit.

Start/End Edit

Click Editor > Start Edit.

Select the data to be edited (this should be a normalized point cloud and only one dataset can be edited at
a time). Click “OK”, and then other functions on the ALS Editor toolbar will be available.

During the editing process the selected data cannot be removed from the window. When editing is
completed, click “End Edit”. Other toolbar functions will be unavailable at this point.

Open Seed Points File
Brief: Select a seed point file (please refer to Seed Points File in the appendix for the correct
format) and the window below will pop up. Please note that there is a header line in the seed
point file, therefore the first line should be ignored when the file is opened.



Save Seed Points File

Add Seed Points

Select Seed Points

Deselect Seed Points

Cancel Selection

Delete Selected Seed Points

Brief:When the editing is completed, the seed points can be saved as a new CSV file without
overwriting the original file.

Brief: Add seed points manually in under-segmented areas. Users may be prompted to select the
peak - or the point close to the peak - of a tree as the seed point.

Brief: Select seed points for editing.

Brief: This tool can be used to deselect incorrect seed points which may have been selected in
error.

Brief: Cancel the selection of seed points.

Brief: For areas that are over-segmented, incorrect seed points can be selected and deleted by



Clear All Seed Points

Profile

Tree Filter

Brief: For areas that are over-segmented, incorrect seed points can be selected and deleted by
using the Select tool.

Brief: Remove all seed points in the window.

Brief: When the ALS Editor toolbar is opened, the point cloud window will change to 2D display
mode. The profile tool can show if the seed points are accurate in 3D. Click the Profile Tool button
and a new window will be created. Click the mouse left button to select a polygon and all points
within the polygon will be displayed in the new window in 3D.

Description：After point cloud data is segmented, attributes such as tree height and crown area
can be obtained. The tree filter tool can be used to view (highlight), hide, delete, and export
single-tree results within a specified attribute range. For example, setting the view of trees within
a certain height range or viewing trees with larger or smaller crown areas to check the results of
single-tree segmentation (larger crown areas may have under-segmentation while smaller ones
are generally caused by dead trees or over-segmentation). To use this function, the segmented
point cloud and segmentation result table must be loaded into the software. As shown in the
figure below: filter point clouds by tree height, set minimum and maximum values to 2.01 and 10
meters respectively, and point clouds within this range will be highlighted.



Point Cloud Segmentation Based on Seed

Clear Tree ID

Seed Setting

Color (default color is "Red"): Click , and then the dialog for selecting colors will pop up as
shown below. Any color may be selected as the seed point color from this window.

Brief: Segment the point cloud data based on the edited seed points. Refer to PCS with Seeds.

Brief: If the point cloud data has been previously segmented, the Tree ID should be removed
prior to performing individual tree segmentation again. Refer to Clear Tree ID.

Brief: Users can set the color, alpha and size of the seed points, and may choose to show the
seed point ID and its label size.



Alpha (default value is "0.5"): Transparency of the seed point, ranging from 0 to 1, with 0 being
completely transparent and 1 being opaque. The default value is 0.5. Click  and the
value will be incremented or decremented by 0.1, or the user can directly enter a specific value.

Show Seed ID (optional): Use the check box to determine if the seed point ID is displayed in the
window.
Seed Size (default value is "0.5"): The seed size, ranging from [0,100). Click  and the
value will be incremented or decremented by 1, or the user can directly enter a specific value.
Label Size (default value is "1"): The label size, ranging from [0, 100). Click  and the
value will be incremented or decremented by 1, or the user can directly enter a specific value.

Exit

Note: If the point cloud has been segmented, you need to Clear Tree ID prior to segmenting it again.
If segmentation has not been performed, the message "All files have been segmented, please clear
tree ID first!" will be displayed.

Brief: To exit ALS Editor, click the exit button and a prompt window below will pop up. Click “Yes”
to close the ALS Editor toolbar or click “No” to return to the editor window.



## Individual Tree Editor ##

Functional Overview

Individual Tree Editor can extract and edit individual trees in large data points cloud, and can quickly
locate and filter out user-concerned individual trees. It is mainly used to solve over-segmentation, under-
segmentation and missing segmentation and other cases, and can also repair fine of under-story trunk.

Usage

Load the point cloud data needs to be edited in the window and make sure to activate that window.

Click TLS Forest > Individual Tree Editor or ALS Forest >Individual Tree Editor to activate the editing bar
in current window. Some functions of different modules maybe different.

The buttons in the individual tree editor tool bar, from left to right, are: start/end editing, profile, open the
individual tree attributes file, individual tree filter, settings and exit.

Please note that if there is no special need, you should normalize the point clouds which need to be
edited. Please refer to Normalization. After editing is complete, the original point cloud can be restored by
reverse denormalization. The profile window takes the plane with Z value of 0 as the datum, and for the
normalized point cloud, the datum is the ground. For the unnormalized point cloud, the point cloud is far
from the datum due to the influence of elevation, which may cause the point cloud and the cut polygon
may not exist in the profile view. Therefore, normalized point cloud data can be better edited. In addition,
functions such as removing support brackets and re-segmentation under this module need normalized
point clouds to get correct results.

Start/End Editing

Click Edit > Start Editing

Select the data to be edited and click "OK" to render the point cloud as displayed by tree id. Other
functions of the individual tree point cloud editing tool bar will become available.

The selected data cannot be removed from the window during editing. After editing, click "End Edit" to end
the editing.



Profile

Note: 1. Please pay attention to the individual tree boundary when picking up the hexagonal area,
because the incomplete part may affect the result, or try to avoid modifying the boundary when
editing. None of the editing functions in this module will have an effect on hidden trees, so you can
hide trees you don't want to edit to avoid affecting the results.

1. Since version 5.0, the method of drawing the profile area is modified to: Click the left mouse
button, drag, and release the mouse to complete the drawing of the profile area.

Functional Description: Click the "Profile" button to open the profile window and draw a
hexagonal area in the window where the point cloud is located. This area is the individual tree
point cloud area to be edited. The individual tree editor toolbar appears above the profile
window.From left to right: Load/remove edit area, Save, Create individual tree, Merge individual
tree, Delete individual tree, Re-segment/remove support bracket, Back up, Redo, Select point,
Hide tree.



Open Individual Tree Attributes File
Functional Description: Individual tree attributes file is a CSV file generated after individual tree
segmentation. Please note that this function recognizes and skips several rows of the table
header by default. If necessary, it can be adjusted by itself. Before clicking apply, ensure that the
table header field is consistent with the corresponding column in the CSV file.



Individual Tree Filter

Settings

Profile Distance: When drawing the profile, please observe the distance between the point and the
display area in the profile window for the users to view the editing area or editing effect according to
the distance conveniently. For example, for ALS forest, the section distance can be set to hundreds of
meters. And for TLS Forest, it can be set to tens of meters.
Auto Save: It is used to auto-save the edited area when switching the profile areas.

Functional Description: Before performing individual tree filtering operations, open the individual
tree attributes file. This function can be set according to the parameter range, quickly screen
interested individual tree. When the filter is enabled, the editor's main window sets the filtered
individual tree color in the scene to transparent, and the profile window automatically applies the
filter to hide the corresponding individual tree in the edit area. Currently, there are two filtering
modes. Trees that match the filtering range are kept display in display mode, while other trees will
be hidden. In hidden mode, the effect is reversed.

Functional Description: This includes profile distance, auto save and other settings.



Load/Remove Editing Area

Save

Functional Description: Click *Load Editing Area* button to set the area in the hexagon as the
area to be edited. The data for editing the individual tree point cloud is the data in this area. All
editing tools are available in the profile window. Enter the editing state at this time, selects the
section area in the main window again, it will automatically choose the data in the selected area
to be the new editing data.

Click “Remove Editing Area” button, and this action will exit the editing directly if no operation is
done to the point cloud file; Otherwise the system will prompt you whether to save the point cloud
data. Choose yes to save the point cloud data to a file, and you can see that the large data point
cloud in the main window has been modified. Or you can choose no to exit the individual tree
point cloud that is being edited without saving the data.

Functional Description: Click the "Save" button to save the modified individual tree point cloud
data to the file. At the same time, you can see that the big data point cloud in the main window
has been modified accordingly. Back up data if necessary, because it cannot be restored after
being saved.



Create Tree

 
From Class: Only specific classes of points are used to filter . Please note that the tree ID has
nothing to do with the category, and it does not have to be classified as a tree to have a tree ID.
Use Points: Only the points with specific tree IDs are used, avoiding making changes to other trees.
There are three options:

Any: Applicable to all visible points.
Current Tree: Applicable only to the point cloud corresponding to the selected tree ID in the list.
When selecting this option, pick the tree ID in the window to the input list by activating the pick
tool. After picking, select "Pick seed point" to switch back to this function.
No Tree ID: Applicable only to the point with tree ID of 0.

Selection Tool: Select the points within the area by different selection tools.

Functional Description: This function can effectively extract the selected point cloud and set it
as the new tree ID. Click the "Create Tree" button and will appears the window shown as below.
Select the category to create the tree point in the category drop-down list box, choose the
category to participate in the point cloud segmentation from the filter point drop-down list
box,select the whole category by default, select the scene job tool from the selection tool, select
the polygon by default, then select the area in the profile window, double-click the end, you can
see the color of the selected area changed, which means the tree is created. This function is
often used in conjunction with other functions, such as creating a new tree ID for a point below a
certain height and deleting it to remove the ground portion, or making an individual tree in a
selection to be a new individual tree and segmenting it again.



Merge Tree

 

Functional Description: It is used to manually solve the over-segmentation problem. Click
“Merge Tree” button, use the mouse to pick up tree in the profile window, if the picked tree ID is
not 0, mark the tree ID at the mouse position.Then pick up other trees, and they will be combined
into the first picked individual trees. You can see that in the profile window, the color of the picked
trees will change to the color of the first picked individual trees, right-click the mouse to end the
pickup.



Delete Tree

Remove Bracket

 
Max DBH: Maximum DBH of the extracted trunk. Appropriate DBH settings can better extract the
trunk. If the value is smaller, the extracted trunk will be finer, and if it is larger, more support bracket
point clouds will be retained. When you open the individual tree attributes file and click the reference
point, the DBH displayed on the input box will automatically update to a slightly larger DBH value for
the corresponding tree in the file.

Functional Description: Click "Delete Tree" button and use mouse to pick up trees in the profile
window. If the picked tree’s ID isn’t 0, you can mark it as 0 and delete the tree.

Functional Description: This function only exist in the individual tree editor of TLS Forest, and
can remove the support brackets of the tree trunk by semi-automatic interaction. Click the left
mouse button to select a point on the trunk below the branch point above the support bracket as
the reference point, process the point cloud below the height of this point, and set the tree ID of
the point cloud corresponding to the support bracket to 0. The principle of the algorithm is the
trunk and branches grow at the same time according to the height, and remove the growing
branches. Therefore, when the lowest height of the support bracket is the same as the lowest
height of the trunk, the result will be better.



Re-segmentation

 
From Class: Only specific classes of points are used to filter. Please note that the tree ID has nothing
to do with the category, and it does not have to be classified as a tree to have a tree ID.
Use Points: Make targeted editing based on the point set of the selected tree ID. It is usually used for
under-segmentation of an individual tree or under-segmentation of multiple individual trees. There are
three options to use set of points:

Any: Applicable to all visible points.
No Tree ID: Applicable only to the point with tree ID of 0.
Current Tree: Applicable only to the point cloud corresponding to the selected tree ID in the list.
When selecting this option, pick the tree ID in the window to the input list by activating the pick
tool. After picking, select "Pick seed point" to switch back to this function.

Minimum Height: Filter points below the minimum height to prevent dividing points on the ground.
When the individual tree point cloud and the low grass bush on the ground are jagged and
interleaved, the tree generated by the algorithm will grow downward and outward, resulting in

Functional Description: This function can only solve the problem of over-segmentation and
under-segmentation of trees through semi-automatic interaction in the editing of the individual
tree editor area under the ALS Forest. The algorithm process spatial search to the point clouds
based on the seed points picked up in the view, and one seed point generates at most one
individual tree. For over-segmentation, a point with obvious spatial characteristics (have a certain
distance from other trees and easy to distinguish, generally the top of the tree) can be picked as
the seed point, and a point closely related to this point in space will be classified as a new
individual tree. For under-segmentation, multiple seed points need to be picked up and multiple
single trees are generated by the same algorithm at each seed point position.

Click “Re-segmentation” button, and the function dialog box will pop up, click the left mouse
button to pick up points as the seed points in the profile after setting the corresponding
parameters, click "Run" to re-segment the point clouds in the editing area. The segmented tree
IDs contain the biggest tree ID of the big data point cloud and the IDs above it, the tree
segmented by this function will not be saved to the individual tree attributes file. Before using this
function, you can hide the trees that don’t need to be divided, set the usage category and set of
points to obtain higher precision segmentation effect.



segmentation errors. This phenomenon can be effectively avoided when the parameter is set above
the height of the ground low grass bush.

Pick Seed Point: You can pick up seed points under the checked state. If you switch to tools such as
"Pick Point" and "Measurement", the check box will be automatically unchecked. At this time, you can
use these tools without quitting the function. If you manually check it, you can switch back to the
mode of picking seed points.

Undo

Redo

Pick Point

Hide Tree

Exit

Functional Description: Click *Undo* button to undo the last option. The maximum times of
undoing is 20. Any operation before the last 20 steps cannot be undone.

Functional Description: Click *Redo* button to redo the last option. The maximum times of
undoing is 20. Any operation before the last 20 steps cannot be undone.

Functional Description: Click the "Pick Point" button and use the mouse to pick up the point
cloud in the profile window. The attribute information of the point will be displayed.

Functional Description: Click "Hide tree" button, use the mouse to pick up the point cloud in the
profile window, and hide the tree with the corresponding tree ID of the point in the scene. The
hidden tree can avoid being modified.

Functional Description: Click the "Exit" button to close the profile window and exit from
individual tree editor directly if no editing operation has been done; Otherwise the system will
prompt you whether to save the data. If you select Yes to save the data in the edit area to the file,
you can see that the big data point cloud in the main window has been modified. Or you can
select No to exit the editing area directly without saving the data. At the same time, close the
profile window and exit from individual tree editor .





TLS Forest
The TLS Forest modules are used for terrestrial or backpack LiDAR point cloud data processing. The
main functions include: leaf area index, ground points filters, point cloud segmentation, single tree
segmentation based on seed points, clear tree ID, statistics and increase individual tree attributes, seed
point editing, individual tree point cloud editing, DBH measure, tree species marker, etc.

Leaf Area Index

Canopy Cover

Gap Fraction

Point Cloud Segmentation

Stem Based Segmentation

View Point Cloud Segmentation Results

PCS with Seeds

Clear Tree ID

Clear Tree ID by CSV File

Extract by Tree ID

Statistic Individual Tree Attributes

Increase Individual Tree Attribute

Individual Tree Report

Generate Tree Model

Tree Species Identification

Stem Extraction

Stem Extraction

CBH Extraction

Biomass Estimation

Biomass Model Manager

TLS Seed Point Editor

Individual Tree Editor

DBH Measure



Leaf Area Index

Summary

Leaf Area Index (LAI) is defined as half of the surface area of all leaves projected on the surface area of a
unit.

Principle Description

The algorithm was developed according to Li et al. (Li et al.,2016).For each statistical unit, a three-
dimensional network is first constructed with a cell size of 1.5 times the average distance between each
two points. Then, for the constructed three-dimensional network, count the total number of three-
dimensional cells in each layer and the number of cells containing laser points in that layer. Based on that
result, calculate the frequency of laser points in each layer.

Where </img> is the point frequency of the s-th layer,  is the number of cells which contains the
laser points in the s-th layer;  is the total number of three-dimensional cells in the s-th layer. And then
calculate the LAI in the s-th layer:

Where  is the leaf inclination correction factor. Usually, it is set as 1.1. Finally, accumulate the LAI of
each layer to calculate the LAI for the entire statistical unit.

Usage

Click TLS Forestry > Leaf Area Index, to generate TLS leaf area index.



Settings

Input Data: Ensure that each input point cloud data is Normalize by DEM or Normalize by Ground
Points. The input file can be a single file or multiple data files. Point cloud data should be opened in
LiDAR360 before being processed.
XSize (meter)(default value is "15"): The length of a grid size should be greater than an individual
tree crown width. For most forest types, the grid size should be greater than 15 meters.
YSize (meter)(default value is "15"): The width of a grid size should be greater than an individual
tree crown width. For most forest types, the grid size should be greater than 15 meters.
Volex Size Setting：

Volex Size (meter) (default value is "0"): The size of the cell which is used to divide the
statistical unit.
Coefficient (default value is "1.5"): The coefficient used to calculate the size of the three-
dimensional cell. The cell size is the product of this coefficient and the average distance between
each two points in the point cloud.

Output Path: Path of the output file. A corresponding raster file (.tif format) will be generated for each
input point cloud data. The .tif files can be used as an independent variable of the regression
analysis.

Note: Only when the point cloud data is loaded in the software can you use the TLS Leaf Area Index
function; otherwise, the message "There is no point cloud data meeting the conditions of calculation!"
will pop up. If the maximum Z value of the point cloud is greater than 200 m or the maximum Z minus
the minimum Z is greater than 200 m, the data is not considered to have been normalized, and the
prompt information shown in the figure below will pop up. Click “YES” to keep using this type of data
in the operation; otherwise, click "NO" and reselect the input data file.

@inproceedings{ author={ Li Y , Guo Q , Tao S , et al.}, title={Derivation, Validation, and Sensitivity
Analysis of Terrestrial Laser Scanning-Based Leaf Area Index}, booktitle={ Canadian Journal of Remote
Sensing, 2016, 42(6):719-729.}, year={2016} }



Filter Ground Points

Summary

Extract ground points from TLS point cloud data.

Usage

Navigate to TLS Forest > Filter Ground Points.

Settings

Input Data: The input data can be a single point cloud data file or multiple data files. Point cloud data
should be opened in LiDAR360 before being filtered.
From Class: The list of point cloud classes that can be used for ground point filtering. If a certain
class is existed in the point cloud and its check box is checked, it will be involved in the filtering
operation.
To Class: Targeted class.
Grid Size (meter)(default value is "0.5"): Resolution of the grid.
Ground Thickness (meter)(default value is "0.3"): Point cloud data from the lowest point of the grid
to the points with the user-defined thickness will all be classified as ground points.
Window Smooth (optional): Use neighborhood grid data to conduct ground point consistency
filtering.
Window Size (default value is "3"): Size of the neighborhood window. 3 indicates a window size of
3*3.
DefaultValue: Restore the default parameters.





Canopy Cover

Functional Description

Canopy cover, also known as "vegetation coverage", refers to the percentage of the vertical projection
area of vegetation on the ground to the total area of the statistical area. Canopy Cover is an important
index to measure the status of surface vegetation, an important basic data to describe the ecosystem, and
an important indicator of environmental changes in regional ecosystems, which is of great significance to
the hydrology, ecology and regional changes and other studies.

Principle Description

For each statistical unit, the 3D volume column is first constructed based on the set grid spacing. Then, on
the basis of the constructed body columns, count the total number of columns and the number of columns
containing laser points with a height greater than a certain threshold, and calculate the canopy cover.

Among them, </img> is the coverage rate,  is the number of columns in which the height of the
highest point cloud is higher than a threshold, and  is the total number of columns.

Usage

Click TLS forest > Canopy Cover to generate the canopy cover tif file.



Parameters Settings

Input data: Ensure that each input point cloud data is normalized; the input file can be a single data
file or a point cloud data set; the file(s) to be processed must be opened in the LiDAR360 software.
X Grid Size (meter) (default value: "5"): For the data acquired from most of the forest, this value
should be larger than 5.
Y Grid Size (meter) (default value: "5"): For the data acquired from most of the forest, this value
should be larger than 5.
Height Break (meter) (default value: "2"): The key parameter of coverage, only points in the column
with a height greater than this value are considered to be covered by vegetation.
Grid Settings:

Grid Size (meter) (default value: "0.25"): Count the grid size of the point cloud in the cell into
3D grids.
Coefficient (default value: "2"): According to the average spacing of the point cloud, the
coefficient factor of the 3D mesh size in the statistical unit is automatically calculated.

Output Path: The output path of a corresponding TIFF file which is generated by each input point
cloud data after running.

Note: If the maximum Z value of the point cloud is greater than 200 or the maximum Z minus the
minimum Z is greater than 200, the data is considered to be unnormalized, and the software will pop
up the prompt message shown in the figure below, click "YES", this type of data Still participating in
the calculation, click "NO", this type of data will not participate in the calculation, and the user can re-
select the data that meets the conditions.



Gap Fraction

Functional Overview

Gap fraction is the probability that light rays pass through the canopy and reach the surface without being
intercepted. It is a key variable to describe the spatial distribution of canopy structure and biomass.The
denser the distribution of the crown layer, the smaller the porosity. The range of porosity is between 0.0
and 1.0.

Principle Description

For each statistical cell, a 3D grid is first constructed according to the set grid spacing. Then, according to
the constructed 3D gird, the total number of 3D girds in each layer and the number of girds containing
laser points are counted, and the frequency of laser points in each layer is calculated.

Among them, </img> is the Sth layer’s frequency of laser points,  is the s-th layer’s total number
of grids containing laser points,  is the Sth layer’s total number of three-dimensional grids. Then
calculate the gap fraction of the s-th layer:

Finally, the gap fraction of each layer was accumulated to obtain the gap fraction of the whole statistical
unit:

Usage

Click TLS Forest > Gap Fraction to generate a porosity tif file.

Parameters Settings

Input data: Ensure that each input point cloud data is normalized; the input file can be a single data file or
a point cloud data set; the file(s) to be processed must be opened in the LiDAR360 software.



X Size (meter) (default value: "5"): For the data acquired from most of the forest, this value should
be larger than 5.
Y Size (meter) (default value: "5"): For the data acquired from most of the forest, this value should
be larger than 5.
Voxel Size Settings:

Voxel Size (meter) (default value: "0.25"): Count the grid size of the point cloud in the cell into
3D grids.
Coefficient (default value: "2"): According to the average spacing of the point cloud, the
coefficient factor of the 3D mesh size in the statistical unit is automatically calculated.

Output Path: The output path of a corresponding TIFF file which is generated by each input point
cloud data after running.

Note: If the maximum Z value of the point cloud is greater than 200 or the maximum Z minus the
minimum Z is greater than 200, the data is considered to be unnormalized, and the software will pop
up the prompt message shown in the figure below, click "YES", this type of data Still participating in
the calculation, click "NO", this type of data will not participate in the calculation, and the user can re-
select the data that meets the conditions.



Stem Based Segmentation

Functional Overview

Different from Point Cloud Segmentation, this function divides point cloud segmentation into two steps:
"Stem extraction" and "point cloud segmentation". In the first step, deep learning is used to extract the
trunk. (López Serrano et al., 2022) In the second step, the remaining tree crowns are grown using the
trunk as a seed point. Compared with TLS Point Cloud Segmentation, this method is less affected by
undergrowth and can accurately extract more trunks. It works best for artificial forests with DBH above
10CM.

Usage

Navigate to and click on TLS Forest > Stem based Segmentation.

 

                

             
          
              

            
              

               
          
              

   
              
  

              

 

                 

             

          

              

             
               

               

          

               
   

               
  

              

 

                 

             

          

              

             
               

               

          

               
   

              

Parameters  Settings

Input  Data:  Ensure  that  each  input  point  cloud  data  is  Normalize  by  DEM  or  Normalize  by  Ground 
Points.
From  Class:  Classes  which  participate  in  the  point  cloud  segmentation  (all  classes  by  default).
Extract  Stem:  Steps  that  must  be  taken  before  stem  based  segmentation.

To  Class  (default  is  "23"):  The  segmented  tree  trunk  will  be  labeled  as  this  calss.
Height  Above  Ground  (meters)  (default  is  "0.3"):  Only  point  clouds  above  this  value 
participate  in  trunk  extraction.  This  parameter  is  used  to  reduce  the  influence  of  ground  point 
cloud  thickness  or  weeds  on  the  effectiveness  of  single-tree  segmentation.  If  this  value  is  set  too
high,  it  will  affect  the  accuracy  of  detecting  tree  stem  diameter.
Extract Trunk to Top  (meters)  (default  is  "4.7"):  The  segmentation  of  the  trunk  does  not  
exceed this  value  at  most.

Segmentation
To  Class  (default  is  "24"):  The  segmented  tree  crown  will  be  labeled  as  this  category.



ResultParameters

Height Above Ground

Start Segment Height

Cluster Tolerance (meters) (default is "0.2"):  Users can control the efficiency and accuracy of 
single-tree segmentation by adjusting this parameter. This value controls the detection of 
individual trees and the growth of single-tree crown point clouds. The larger the clustering 
threshold, the higher the efficiency of single-tree segmentation, but if it is too large, it will affect 
the segmentation effect.

Segment from (meters) (default is "1.0"):  Point clouds above this height participate in tree crown 
segmentation. Tree trunk points below this height are still retained. This parameter further weakens 
the influence of thick point clouds or weeds on single-tree segmentation results. If this value is set too
high, low-height tree crowns cannot participate in segmentation, which will affect discrimination under
branches with high density; if it is set too small, it cannot effectively reduce the impact of shrubs on 
segmenting results.
Attribute:

Maximum DBH (m) (default is "1.4"): The maximum elevation threshold for participating in the 
fitting of breast diameter point clouds.
Minimum DBH (m) (default is "1.2"): The minimum elevation threshold for participating in the 
fitting of breast diameter point clouds.

Optimize color rendering for individual tree segmentation result (checked by default): By 
reorganizing the tree ID generated after the individual tree segmentation, it can greatly solve the 
problem of rendering the same color to the trees next to each other.

Output Path: Path of the output file, which is a comma-separated database table in the .csv format 
containing the ID of each individual tree identified during the segmentation process, the x, y 
coordinate of each individual tree, individual tree heights, DBHs, crown diameters, crown areas, and 
crown volumes. Please refer to  Individual Tree Segmentation Result File Format  in the 
appendix.Please refer to  View the Point Cloud Segmentation Results  for the steps to view the results.
DefaultValue: Reset each parameter to the default value.

The impact of parameters on the results:



    @inproceedings{
        author={López Serrano et al., 2022 F.R. López Serrano, E. Rubio, F.A. García Morote, M. Andrés Abellá
n, M.I. Picazo Córdoba, F. García Saucedo, E. Martínez García, J.M. Sánchez García, J. Serena Innerarity, L. 
Carrasco Lucas, O. García González, J.C. García González},
        title={Artificial intelligence-based software (AID-FOREST) for tree detection: A new framework for fa
st and accurate forest inventorying using LiDAR point clouds},
        booktitle={Int J Appl Earth Obs Geoinf., 113 (2022), Article 103014},
        year={2022}
    }



View the Point Cloud Segmentation Results
After segmenting the trees, Tree IDs are saved as an attribute to each point in the point cloud data. The
results can be viewed within a window viewer. Load the point cloud used for the tree segmentation into a
3D viewer. Ensure the viewer is active and press the Display by Tree ID button in the toolbar. The
following is an example of a point cloud colored by individual tree. TLS Editor tools are used for checking
the TLS individual tree segmentation results. Moreover, it can be used to edit operations such as add,
delete seed points, and segment the point cloud data based on the edited seed points.

The tree ID attribute of each point can be queried by the Pick Point（ ）tool on the toolbar.

CSV file generated by segmentation can be overlaid with the point cloud, and the CSV file can be opened
as a table. Select X, Y and Z as the TreeLocationX, TreeLocationY and TreeHeight respectively in the
CSV file as shown below, and check the Show Label (if the label has too much text and blocking other
data, one can remove the data and reopen it without checking the Show Label). Click “Apply” to load the
CSV file in the software.

To view the DBH, CSV can also be selected to be displayed by circle and select DBH as the diameter.



Click the mouse right button on the CSV file and select Table Attribute. The property information will be
displayed. Double-click the mouse left button anywhere in each line, and it will jump to the corresponding
location. The following figure shows the effect of superimposed display of point cloud data and CSV file.



Point Cloud Segmentation from Seed Points

Functional Overview

The TLS PCS with Seeds function supports batch processing for multiple files. The input data includes
normalized point cloud data and the corresponding seed point file. For TLS point cloud normalization,
please refer to the Normalize by DEM or Normalize by Ground Points tool section of the LiDAR360 User
Guide.

Usage

Navigate to and click on TLS Forest > Point Cloud Segmentation from Seed Points.

Parameters Settings

From Class: Classes which participate in the PCS with seeds (all classes by default).
Point Cloud File: Click  to select the point cloud data to be processed.
Seed File: Click  to select the seed file.

: Five datasets can be batch processed per tool run. Click  to add files to be processed.
: Delete the selected point cloud and seed points file.
: Clear the file list.

Cluster Tolerance (m) (default is "0.2"): Users can control the efficiency and accuracy of single tree
segmentation by adjusting this parameter. The larger the cluster threshold, the higher the efficiency of
single tree segmentation, but if it is too large, it will affect the segmentation effect.
Minimum Cluster Size (default is "500"): This value mainly affects the growth of single tree crown
point cloud. The smaller the number of points set, the better the segmentation effect but slower speed
and vice versa.
Maximum DBH (m) (default is "1.4"): The maximum elevation threshold for fitting breast height



diameter point clouds.
Minimum DBH (m) (default is "1.2"): The minimum elevation threshold for fitting breast height
diameter point clouds.
Height Above Ground (meter)(default value is "2"): Only the points above this hight will be
involved in individual tree segmentation. This parameter is used to decrease the influence of ground
points and weeds to the segmentation. It will influence the accuracy of the detection of trunk, if this
value is too large.
Optimize Color Rendering for Individual Tree Segmentation Result (checked by default): By
reorganizing the tree ID generated after the individual tree segmentation, it can greatly solve the
problem of rendering the same color to the trees next to each other. Note: if choosing to optimize the
color rendering, the tree IDs in new csv file for individual tree segmentation are not one-to-one
correspond to those in the input seeds files.
Output File Format:Select the format of output file, choice including .csv attribute table and tree
attribute file.
Output Path: Path of the output file, which is a comma-separated database table in the .csv format
containing the ID of each individual tree identified during the segmentation process, the x, y
coordinate of each individual tree, individual tree heights, DBHs, crown diameters, crown areas, and
crown volumes.
DefaultValue: Reset each parameter to the default value.



Clear Tree ID

Summary

After the point cloud has been segmented, the tree ID information is stored in a LiData file. If the
segmented point cloud data needs to be segmented again, users need to clear the tree ID first.

Usage

Navigate to TLS Forest > Clear Tree ID.

Select the point cloud data to be processed, and then click "OK".



Extract by Tree ID

Summary

This function is used to extract part or all point clouds from the segmented point cloud based on Tree ID.

Usage

Navigate to TLS Forest > Extract by Tree ID.

Settings

Select File: Select the point cloud data with segmented tree ID information from the drop-down list.
Only one file can be selected at a time, and it has to be opened in LiDAR360 already.
Min (default value is "0"): The minimum value of tree ID to be extracted. The default value is zero.
Max: The maximum value of tree ID to be extracted. The default value is the number of trees in the
point cloud. If the point cloud has not been segmented, the minimum and maximum values of the tree
ID are both zero.
Extract to A File (default): The point cloud in the selected range is extracted into a CSV file that
contains the X, Y, Z coordinates and tree ID information.
Extract to Multiple Files Based on Tree ID: Extract the point cloud data based on tree ID and save
them as different CSV files for each tree. The stored information are X, Y, Z coordinates and tree ID
information for each tree.
Output Path: Output path for the results.



Statistic Individual Tree Attributes

Summary

This function is used to correct the tree heigh, crown area, and other individual tree information after the
individual tree editing.

Usage

Click TLS Forest > Statistic Individual Tree Attributes.

Settings

Input Data: The input data should be the point cloud after individual tree segmentation.
Maximum DBH (meter)(default value is "1.4"): Upper DBH threshold for fitting DBH.
Minimum DBH (default value is "1.2"): Lower DBH threshold for fitting DBH.
Height Above Ground (meter) (default value is "0.3"): The point above this height will be used in
the segmentation. This parameter can help uses to weaken the influence from the ground or grasses
on the statistics calculation. If this value is too large, it will impact on the detection of tree structure.
Minimum Tree Height (meter) (default value is "2"): This parameter can be set according to the
growth situation of trees in the measuring area. It can be used to filter the small trees.
Update File (Unchecked by default): If this option is checked and the input file contains the valid
DBH values, the DBH values will not be recalculated. Only other attributes will be updated. If this
option is unchecked, or the DBH values in the input file is invalid, all the attributes will be recalculated.
Output Path: The output path of the statistics result. The file contains the Tree ID, XY location of
each tree, tree height, crown diameter, crown area, and crown volume.
Default: Reset all the parameters as their default values.



Increase Individual Tree Attributes

Summary

This function is mainly used to expand the attribute field of individual tree attribute file.

Usage

Click TLS Forest > Increase Individual Tree Attributes.

Settings

Individual Tree Attributes File: The input data is a individual tree attribute file, which is a comma-
separated CSV table, and must contain at least two fields: TreeLocationX, TreeLocationY, the
detailed file format can refer to Individual Tree Segmentation Result File Format。
Reference File: The reference point file is a comma-separated text file with two lines and three fields:
X, Y, and Radius; X and Y are reference point positions, and Radius is radius. If the reference point
file is input, the azimuth and distance of the trees within a certain radius with the reference point as
the center are calculated, and then added to the individual tree property file as extended attributes.
Slope File：The slope file is in TIFF format. If the slope file is imported, the slope of the tree position
is obtained and added to the single tree attribute file as an extended attribute.
DEM File：The DEM file is in TIFF format. If the DEM file is imported, the slope of the tree position is
obtained and added to the single tree attribute file as an extended attribute.

After clicking OK, you need to set the fields of the reference point file. The three fields of X, Y, and Radius
need to be set correctly, and the other fields are set to Ignore. For the setting method, please refer to the
section on selecting reference Open file to add TXT data.



The following is an example of reference point files:

X,Y,Radius
322716.24,4102494.69,15.0

The following is an example of individual tree property file:

TreeID, TreeLocationX, TreeLocationY
1, 322716.24, 4102494.69
2, 322751.21, 4102499.9
3, 322519.35, 4102499.3

The following is an example of the extended individual tree property file:

TreeID, TreeLocationX, TreeLocationY, Azimuth, Distance
1, 322716.24, 4102494.69, 36.165, 8.982
2, 322751.21, 4102499.9, 41.282, 4.491
3, 322519.35, 4102499.3, 32.008, 4.708



Individual Tree Report

Functional Overview

This function is based on the result file of individual tree segmentation, extracts the image of individual
tree point cloud from the point cloud with individual tree segmentation, and displays the image of individual
tree point cloud and individual tree attribute information to the user in the form of html report, which is
convenient for users to quickly check and archive the result of individual tree segmentation.

Usage

Click TLS Forest > Individual Tree Report.

Parameters Settings

Select File: Select the point cloud data to generate the individual tree report from the drop-down list
of selected files. Only one file can be selected at a time. The file must be opened in the LiDAR360
software.
Individual Tree Attributes Files: Select the point cloud individual tree attribute file. For the format of
individual tree attribute file, please refer to the format of individual tree segmentation result file;
Extract by Tree ID: If this parameter is selected, the tree ids for the report range from the minimum
number to the largest tree ID. The tree ids can be queried in the selected CSV file.
Minimum Tree ID: The default value of the minimum value of the tree ID that generates the report is
1.
Maximum Tree ID: The default value is the maximum value of the tree ID in the point cloud.
Color Rendering: Select the rendering method to generate the individual tree point cloud image. You
can select three rendering methods: point cloud RGB rendering (optional when point cloud has RGB
attributes), tree ID rendering and elevation rendering.
Image Drawing attributes: Select the attribute information drawn on the individual tree point cloud



image. The attribute information is derived from the selected individual tree segmentation result file.
Render viewing: Select a view mode for generating images. The front view, left view, and two views
can be displayed at the same time.
Report attributes: Select the property information displayed in the html report from the selected
individual tree segmentation result file.
Description information: User-defined description displayed by the user in the html report.
Output Path: The path for storing the generated html report.

Note

This function is only applicable to the TLS point cloud data after individual tree segmentation. The ALS
point cloud may be sparse, so the picture of individual tree point cloud in the report cannot directly show
the individual tree shape.



Generate Tree Model

Functional Overview

The real tree model is constructed based on the results of segmentation or attribute editing. It can provide
a more intuitive and real model display form for the attribute information, and quickly check and browse
the segmentation results. At the same time, the high-precision and high-fidelity tree model enhances the
sense of reality and immersion for the digital city, woodland and other scenes.

Usage

Click ALS/TLS Forest > Generate Tree Model.

Parameters Settings

Individual Tree Attribute File: The input file is the point cloud individual tree attribute file. The
individual tree attribute file format can refer to the individual tree segmentation result file; The
individual tree attributes file can also come from the individual tree attributes file with the tree species
information after the Tree Species Marker.
Tree Species Model: According to the tree species information contained in the selection file, select
the tree model that shows the tree species in the tree model drop-down box.
Add New Model: Add the tree model as required, set the model corresponding to the perspective
display picture and close shot model object, tree model management reference option Settings in the
forest Settings page of the tree model settings
Output Path: Output path, set the storage path corresponding to the generated tree modeling file,
and generate a folder with the same name in this path to save the resource file used by the tree
modeling file. When we are copying the tree model file, copy the resource folder with the same name.



Tree Species Identification

Function Description

The tree species identification superimposes the point cloud and seed points according to the panoramic
photos, determines the tree type and records it in the corresponding seed point file.

Note: The point cloud must be the original point cloud and cannot be the normalized point cloud, and
the elevation of the seed point file cannot be the normalized elevation.

Usage

Load the point cloud data to be edited into the window, and use this window as the active window, then
open the panorama window, and the panorama photo will be superimposed to display the point cloud and
seed points, and determine the tree species corresponding to each seed point.

Click Foundation Forestry>Tree Species Identification, and the tree species editing tool bar will appear in
the current active window.

Tree species ID editing tool bar, from left to right: start/end editing, panorama, selection frame, single tree
attribute window switch, exit.

Start/End Editing

Click Edit > Start Editing

Select the data to be edited, click "OK", other functions of the tree species identification editing tool bar will
become available, a single tree property window will pop up at the bottom of the window, and a dialog box
for loading panorama will pop up at the same time.

During editing, selected data cannot be removed from the window. After editing, click End Editing to end
the editing.



Load seed point file

Click Edit > Load Seed Point File

Select the seed point file data to be loaded, the seed point file loading window will pop up, determine the
attributes of each column of the seed point, click Apply, the seed point data will be displayed in the
singular attribute window, and will be added to the point cloud window at the same time.

During editing, selected data cannot be removed from the window. After editing, click End Editing to end
the editing.

Panoramic window

Function description

Click the *panorama window* button to open the panorama window, and a dialog box for loading
panorama files will pop up. By default, the point cloud of the main window will be added and displayed,
and the panorama toolbar will appear above the panorama window. From left to right, they are: previous
frame, next frame Frame, panorama roaming, point cloud display range, point cloud transparency.

### select frame ### Function Description

Single tree property window switch

Function description

For the description of individual tree property measurement, please refer to Single Wood Property
Measurement。

Exit

Click the *Select Frame* button, use the mouse to pick up the point cloud in the point cloud
window, and the panorama will automatically jump to the panorama photo closest to the pick-up
position.

Click the *Single Tree Property Window Switch* button to control whether the single wood
property window is displayed.



Function description

Previous frame

Function Description

Next Frame

Functional Description

Automatic Roaming

Functional Description

Only display selected seed points

Functional Description

Panorama Point Cloud Conical Display Radius: Adjust the radius of the conical range for point
cloud and seed point identification in the panorama window.

Point cloud transparency: Adjust the scroll bar for point cloud transparency, the point cloud
becomes transparent to the left until it is invisible, and the point cloud becomes more opaque to the
right until the point cloud is clearest.

Click the *Exit* button to exit the tree species identification module.

Click the *Previous Frame* button, and the panorama jumps to the previous frame.

Click the *next frame* button, and the panorama jumps to the next frame.

Click the *Auto Roam* button, the panorama will browse all the next frames from the current
frame according to a certain time interval until the last one Frame stop, or click the *Auto Roam*
button again to stop roaming.

Click *Only display selected seed points* button, the panorama window will only display the
selected seed points in the single tree attribute measurement window , the other seed points are
hidden.



Individual Tree Attributes

Functional Overview
Function description: Click this button to open the profile window to measure the properties of a
single tree, including tree height, branches Attributes such as bottom height and tree straightness
can be saved, and the edited single-tree attribute information file can be saved. When the single
tree attribute editing state is turned on, when the seed point of the window changes, the single
tree attribute table information will not be updated. If it needs to be updated, it should be closed
and reopened.

: Click this button to change the edited Single wood attribute information is saved as a csv file.

: This tool needs to be used in section window mode, jumps to the previous double-clicked single
wood information item Single wood information, the section window also displays the jumped
single wood point cloud, you can also use the shortcut key ← to jump forward.

: This tool needs to be used in section window mode, jumping to the next step of the single-wood
information item currently selected by double-clicking Single wood information, the section
window also displays the jumped single wood point cloud, and you can also use the → shortcut
key to jump backwards.

: Calculates tree straightness. It is necessary to use the selection tool in the section window to
select the point cloud whose straightness needs to be calculated. According to the relevant
standards for tree straightness calculation proposed by Macdonald E et al., the height of the
selected point cloud must be greater than 6m, if the calculated straightness information is not
refreshed, you can select the cell to right-click to refresh.



: Length measurement tool, you can measure tree height related information in the section
window.

: Area measurement tool, can measure the crown area, crown diameter and other related
information in the section window. The crown diameter can be obtained by first measuring the
crown area, and then using the area measurement formula S=πr² to obtain the crown diameter 2r.

: Height measurement tool, in the section window, you can measure the tree height, the height of
the branches and other related information.



Section Radius: Adjust the hexagon radius in the section window.

Display Attribute: Adjust the displayed seed point identification, you can display any column of
information in the singular attribute measurement in the scene, and control whether the seed point
identification is displayed.

Jump Tree ID: Jump to the seed point position corresponding to the tree ID. If you open a section,
the section point cloud will jump to the vicinity of the corresponding seed point. When you open the
panorama window, jump to the corresponding panoramic photo.

Note: Before measuring the properties of a single tree, it is necessary to ensure that the seed points
are included in the window. In addition, there is no refresh phenomenon for table-related data. You
can use the right-click of the selected cell or use the F5 shortcut key to refresh the relevant table
data.

DBH Check

the branches and other related information.

: start editing, you can edit the added fields after editing.

: add fields, add extended fields in the property sheet, support integer, real number, text, date,
enumeration, etc. type.

: delete the field and delete the added extension field.

Function description: The DBH check tool is used to check whether there is intersection or
overlap of DBH. Users can double-click or right-click to view the checked DBH, and delete the
wrong DBH by right-clicking or selecting.



After the function is turned on, the following figure is shown:

Single Tree Screening

As shown in the figure below: After the point cloud data is segmented for a single tree, filter the point cloud
by tree ID, set the minimum and maximum values to 1 and 10 respectively, and the point clouds within this
range will be highlighted.

Function description: The single-tree screening tool is used to check and edit the DBH fitting
results or single-tree segmentation results. According to the screening range, the DBH fitting
results can be displayed, hidden, deleted and extracted, and the point cloud after single tree
segmentation can be highlighted. Filtering operations include: filtering by confidence, filtering by
tree ID range, tree DBH filtering, and filtering by tree height range. Among them, filtering by
confidence is only applicable after batch fitting DBH; filtering by tree height is only applicable after
single-tree segmentation operation.



Extract Eucalyptus Stem

Functional Overview

This function will identify tree stem from Eucalyptus TLS forest point cloud data and divide them into target
categories.

Usage

Click TLS Forest > Extract Eucalyptus Stem.

Parameters Settings

Input data: The input file can be a single data file or a point cloud data set; the file(s) to be processed
must be opened in the LiDAR360 software.
Computing Unit: You can choose GPU or CPU.
Classification Target Class: The user must select at least one function in classification and
segmentation. After checking the classification and running, the stem will be classified into the target
class.
Segmentation Source Class: When the user selects segmentation, the source class trees will be
segmented into individual trees. When the classification is checked, the target class of the
classification will be set as the source class of the segmentation. Otherwise, the user needs to specify
the segmentation source class.



Extract Tree Stem(TLS)

Functional Overview

This function is used to extract stems from terrestrial laser scanning point cloud data. Point clouds
belonging to the same stem will be given a unique tree ID. This function is mainly aimed at the point cloud
data obtained by high-precision station scanning to solve the complex problem of forest land vegetation,
and the DBH of the extracted stem can reach a minimum of 0.1m. This algorithm is not suitable for point
clouds acquired by airborne (ALS), backpacks and other acquisition methods, because the normal
consistency of the stem surface of these point clouds were not strong.

Usage

Click TLS Forest> Extract Tree Stem(TLS).

Parameters Settings

Input Data: The input data must be normalized point cloud data. For normalization method, please
refer to normalization or normalization according to ground points. The input file can be a single data
file or a point cloud data set; the file(s) to be processed must be opened the in LiDAR360 software.
Height Above Ground (m) (default value: "0.5"): The point with z value lower than this will be
regarded as the low understory vegetation and will not participate in the stem extraction. This
parameter is used to reduce the influence of low understory vegetation on the effect of individual tree
segmentation. 0.5-0.8m is appropriate for most TLS data.
Max Stem Height (m) (default value: "4.0"): Maximum height of a stem. Points above this value will
not be involved in the stem extraction. If this value is set too large, it will affect the accuracy of stem
extraction and reduce the calculation efficiency. Taking rainforest data as an example, the height
difference between trees may reach 20 to 30 meters, so only point clouds of common part height
(less than 4.0 meters) are taken for stem extraction, and DBH and other forest parameters are
calculated.
Min Stem Height (m) (default value: "1.5"): Minimum height of a stem. The height of the shortest
tree in the forest land. This height mainly affects the detection results of low stems. This value must
be greater than "Height above ground point" and less than "Maximum stem height". Low stems with a
height of 0.8 times this value will be detected.
Buffer Size (m) (default value: "2.0"): Buffer area for getting data is used to solve the edge
connection problem of adjacent data blocks in the algorithm. This value needs to be set to be slightly
larger than the maximum diameter at breast height (DBH) of the trees in the scene. If this value is set



too large, the calculation efficiency will be reduced, and if it is set too small, it will result in over-
segmentation of part of the stems. 2.0 is suitable for most TLS data.
Max Stem Inclination (degree) (default value: "15"): The stem forms the maximum inclination with
the vertical direction. Stem points with the inclination angle less than this value will participate in
subsequent calculation as candidate points. The larger this value is set, the more stem points are
extracted, but the accuracy is reduced. On the contrary, the smaller this value is set, the fewer the
number of tree stem points are and the higher the precision is. 10~15° is suitable for most data.
Voxel Sampling (m) (default value: "0.02"): The grid size of Voxel thinning. Raw TLS data needs
voxel thinning to reduce the computational burden. When this threshold is greater than the average
point density of the point cloud (calculated automatically within the algorithm), grid thinning will be
performed according to this threshold, otherwise grid thinning will not be performed. If the data has
been subject to resampling, this value can be set as the default value.

> @inproceedings{ author={Shengli Tao, Nicolas Labrière, Kim Calders ,Fabian Jörg Fischer, E‑Ping
Rau,Laetitia Plaisance, Jérôme Chave}, title={Mapping forest disturbances across the Southwestern
Amazon: tradeoffs between open-source, Landsat-based algorithms}, booktitle={Environmental Research
Communications, 3(9):091001(13pp)}, year={2021} }



Extract CBH

Functional Overview

CBH (Crown base height) refers to the vertical height of a tree from the ground surface to the lowest
branch point of the tree crown. CBH, also known as crown under height, is the height below the first level
of stem, and in practice often refers to the height below the branches of the first main branch that forms
the crown of the standing tree. Because of the difference of the genetic characteristics of each tree
species, CBH is different. This function takes the individual tree attribute file and point cloud as input to
calculate CBH and volume of the tree, and adds the calculation results to the end column of the individual
tree attribute file.

Usage

Click TLS Forest> Extract CBH.

Parameters Settings

Input data: The input data must be normalized point cloud data. For normalization method, please
refer to normalization or normalization according to ground points. The input file can be a single data
file or a point cloud data set.

Individual Tree Attribute File: The input data is the single-wood attribute file of the corresponding
point cloud. It is a comma-separated CSV table and must contain at least two fields: TreeLocationX
and TreeLocationY. For details about the file format, see the format of TLS individual tree
segmentation result file.

Calculate stem volume from Bottom to: If selected, calculate the volume of the tree trunk.

CBH: Calculate stem volume to a point below the first branch.
Tree top: Calculate stem volume to the top of the tree.

Calculate stem volume: When this option is selected, the calculation result of StemVolume will be
added to the end column. If this column already exists, it will be overwritten.

Note: After running, CBH calculation results will be added to the end column. If this column already
exists, it will be overwritten.



TLS Seed Point Editor

Functional Overview

The TLS Seed Point Editor toolbar contains functions for checking the results of individual tree
segmentation routines run on Terrestrial Laser Scan (TLS) input data. The TLS Editor is also used to
extract Diameter at Breast Height (DBH) for individual trees, to add or delete seed points, to execute point
cloud segmentation operations that include seed points, and to measure physical attributes of individual
trees found in the source dataset. Since v3.2, the right-click shortcut menu is supported.

TLS Seed Point Editing Shortcuts

Shortcut Description

shift + mouse left Profile translation

↑ Translate the profile up

↓ Translate the profile down

→ Pan profile to the right / to the next tree in single tree attribute table

← Pan profile to the left / to the previous tree in single tree attribute table

Ctrl + z Undo seed point editing

Ctrl + y Redo seed point editing

Usage

Load the point could data to be edited into the viewer and activate the view window.

Navigate to and click on TLS Forest > TLS Editor to load the TLS Seed Point Editor toolbar in the active
view window.



TLS Seed Point Editor toolbar functions (from left to right): Start/End Edit, Open Seed Points File,
Open/Close Trajectory File, Fit DBH, Batch Extraction of DBH, Add Seed Points, Delete Seed Points,
Clear All Seeds, Profile, Pan Profile, Measure Individual Tree Attribute, Point Cloud Segmentation from
Seed Points, Clear Tree ID, Filter by Elevation, Setting, and Exit.

Start/End Edit

To begin editing session navigate to and click on Editor > Start Edit.

Select the data to be edited, click "OK", a setting window will pop up, the user can set the displayed point
cloud height, the default point cloud is 1.2-1.4m, the user can set whether to display the mouse position
synchronously in the profile view. Other functions of the TLS seed point editor toolbar will become
available.

In the process of editing, the selected data cannot be removed from the window. Click “End Edit” to
complete the editing, and other functions in the toolbar will then be unavailable.

Open Seed Points File

Function Description: Select a seed point file (please refer to Seed Points File in the appendix)



Save Seed Points File

Open Trajectory File

Function Description: Select a seed point file (please refer to Seed Points File in the appendix)
for the format of seed point file, and the window below will pop up. Please note that there is a
header line in the seed point file, therefore, the first line should be ignored when the file is
opened.

Function Description:When editing is completed, the seed points can be saved as a new .csv
file without overwriting the original file.



Function Description: Load trajectory file, support the output trajectory file format (*.xyz) of LiBackpack
series products.

Close Trajectory File

Function Description: Close the loaded trajectory file.

Fit DBH

The picture below (left) is the result of selecting the point cloud data of an individual tree. The picture
below (right) is the result of DBH fitting: 1 indicates ID number, 0.2030 is the fitted DBH value in meters.

Batch Extraction of DBH

Min Points Number (default value is "10"): Minimum threshold for the number of trees of each
category. If the number is less than this value, then no DBH fitting will be conducted.
Methods of Fitting DBH: Users can flexibly select the point cloud in a 2D window by setting a height
or using the profile window for DBH fitting. Methods of fitting DBH include Fitting by Circle, Fitting by
Column and Fitting by Ellipse. By default, the method of Fitting by Circle is adopted. If the tree is
slanting, the Fitting by Cylinder method can be used.

Fit Circle (Default): Use the least squares method to the fit a circle from the x-y coordinates of input
points.
Fit Column: Use the least squares method to fit a three-dimensional cylinder from input points where

Function Description: Select the desired individual tree for DBH fitting.

Function Description: Select the point cloud data of multiple trees and then perform batch fitting
of tree DBH (the parameter settings are shown as below). By default, the function uses the entire
point cloud in the window for batch DBH fitting. Users can also select out a part of point cloud for
fitting.



the diameter is the DBH of the tree.
Fit Ellipse: Use the least squares method to fit an ellipse from the x-y coordinates of input points, and
the DBH will be calculated as 2 sqrt（major axis minor axis). This method is for trees with an oval-
shaped trunk.

The picture below (left) is the result of selecting the point cloud data of multiple trees. The picture below
(right) is the result of DBH fitting: 1, 2, 3, 4, 5 and 6 indicate ID number, 0.1319, 0.1912, 0.1422, 0.1634,
0.1934, and 0.2274 are the fitted DBH value in meters.

Add Seed Points
Function Description: Interactively add seed points manually, support adding seed points in the
edit window and profile window.



Delete Seed Points

Note: Since version 5.0, the previous process of deleting seed points has been modified to simplify
selecting and deleting seed points into one operation. After selecting a seed point, the selected seed
point will be deleted immediately.

Clear All Seeds

Profile

Rectangular Selection: Draw three points in the point cloud window to create a rectangle. The first
two points define the centerline of the rectangle, and the third point determines the width. Double-click
to complete the selection.

Hexagonal Selection: Draw a hexagonal region in the point cloud window. Click the left mouse
button, drag, and release the mouse to complete the profile area drawing.

Note: Since version 5.0, the method of drawing the profile area has been modified as follows: click
the left mouse button, drag and release the mouse to complete the drawing of the profile area.

Function Description: Delete the selected seed point data. Click this button, the selection tool
dialog box will pop up, the user can select the appropriate selection tool (polygon selection, circle
selection, rectangle selection tool) according to the needs, and pick a suitable area in the scene
to delete the seed points in the area.

Function Description: Clears all seed points in the window.

Function Description: When the TLS Editor toolbar is opened, the point cloud window will
change to 2D display mode. The profile tool can show if the seed points are accurate in 3D. Click
the Profile Tool button and a new window will appear. Click the mouse left button to select a
polygon, and all points within the polygon will be displayed in the new viewer in 3D.



Pan Profile

Measure Individual Tree Attributes

Function Description

For descriptions of individual tree measurements, please refer to Individual Tree Attribute.

Point Cloud Segmentation from Seed Points

Clear Tree ID

Parameters Settings

Function Description: After drawing the profile area in the main window, users can translate the
profiled area by clicking this tool, and see the profile data in real-time.

Click this *Measure Individual Tree Attributes* button on the toolbar to control whether to display
the Measure Individual Tree Attribute window.

Function Description: Segment the point cloud data based on the edited seed points. Refer to
PCS with Seeds. The tree heights will be recalculated after tree segmentation.

Function Description: If the point cloud data has been segmented already, the TreeID should be
removed prior to reperforming individual tree segmentation. Refer to Clear Tree ID.

Function Description: Includes seed point setting and height setting for point cloud display.



DBH Configuration：
Minimum DBH (Meter) (Default Value is "0.05"): The minimum DBH value based on user's
prior knowledge. If the DBH of a tree is smaller than this value, the fitted DBH will be treated as
an error.
Maximum DBH (Meter) (Default Value is "1.00"): The maximum DBH value based on user's
prior knowledge. If the DBH of a tree is larger than this value, the fitted DBH will be treated as an
error.
Maximum Tree Inclination Angle (Degree)(Default Value is "30"): The maximum tree
inclination angle based on user's prior knowledge. If the inclination angle of a tree is larger than
this value, the corresponding points will not be treated as a tree. Note that this threshold is only
effective to the method of Fit Column.



Seed Setting: Seed point setting includes the color, alpha and size of the seed points, and whether
the seed point ID and its label size are shown.

Color (Default Color is "Red"): Click , and then the dialog for selecting colors will pop up
as shown below. Any color can be selected as the seed point color from this window.

Alpha (Default Value is "0.5"): Transparency of the seed point, ranging from 0 to 1, with 0 being
completely transparent and 1 being opaque. The default value is 0.5. Click , and the
value will be incremented or decremented by 0.1; or one can directly enter a specific value.

Display Label: Set if display the label of the Seed ID in the window.
Label Size (Default Value is "1")：The label size, ranging from [0, 100). Click ,
and the value will be incremented or decremented by 1; or you can directly enter a specific value.
Show Seed ID (Optional): Use the check box to determine if the seed point ID is displayed in
the window.
Size (Default Value is "0.2"): The seed size, ranging from [0,100). Click , and the
value will be incremented or decremented by 1; or one can directly enter a specific value.

Confidence Level: Estimate the confidence level of batch fitted DBH values, and visualize the fitting
results with different confidence levels using different user-defined colors.

Low Confidence Level: The DBH fitting results is poor, and users need to visually examine and
edit the results to improve the fitting accuracy. Users can set the visualization color.
Medium Confidence Level: The DBH fitting results is medium, and users may need to visually
examine and edit the results if necessary. Users can set the visualization color.
High Confidence Level: The DBH fitting results is very good. Note that if only a single tree was
fitted, the default confident level will be set as high.

Note that if the visualization height range is larger than 0.4 m when fitting the DBH in batch,
LiDAR 360 will use a more strict method to estimate the confidence level. This method
usually performed better for trees with a long trunk.

Camera Distance of Profile View (Default Value is 20): When drawing a profile, the distance from
the observation point to the display area of the profile window is convenient for users to view the
editing area or editing effect according to the distance according to the job needs.

Filter by Elevation
Function Description: Point cloud display height and whether to show mouse position in profile
viewer.



Point Cloud Display Settings:
Position: The height of the point cloud in the profile viewer.
Buffer: The thichness of the point cloud in the profile viewer.
Show Mouse Position in Profile Viewer: When opening a profile, whether to display the real-
time position of the mouse in the profile when the mouse moves in the profile window.

Note: The Ctrl_L + Mouse Wheel scrolling shortcut can only be used when the filter by elevation
window is active, and the profile view is the current focus window. After closing the window, the
parameters will keep as before it close.

Exit

Note: If the point cloud has been segmented, you need to Clear Tree ID before being segmented
again. Otherwise, the message "All files have been segmented, please clear tree ID first!" will prompt.

Undo and Redo

Function Description: During the seed point editing process, if there is an editing error or misoperation,
press [ctrl+z] to undo the operation, and press [ctrl+y] to resume the operation.

Note: In a seed point editing, the undo and redo functions are limited to 20 times respectively.

    @inproceedings{
        author={ Macdonald E, Mochan S},
        title={Protocol for stem straightness assessment in Sitka spruce},
        booktitle={Journal of Bacteriology,176(17):5578-82},
        year={2000}
    }

Function Description: To exit TLS Seed Point Editor, click the exit button and a prompt window
will pop up. Click “Yes” to close the TLS Seed Point Editor, or click “No” to return to the editor
window.



DBH Measuring

Summary

The DBH measurement tool can measure the tree DBH on the TLS forestry point cloud data. And support
to export the measurement results as txt, asc, neu, xyz, pts, and csv formats.

Usage

Load the point cloud data to be edited into the window, and set this window as the active window.

Click TLS Forestry > DBH Measuring to open the DBH measuring window.

Steps

1. Activate the DBH measuring button  (Initially activated). Use the left mouse button to click the
roots of the trees in the scene to measure DBH in sequence. This function will select the point cloud
of the corresponding range according to the set parameters and use the method of fitting the circle to
fit DBH. The fitting results are displayed in the 3D window and the DBH measurement window at the
same time.

2. Click to select any row in the list, and click the  button to delete this measurement result.

3. Click the Start Edit botton , and double-click the cell in the table to change the selected field.

4. Click the Add Field botton , and the following window will pop up. Currently, it supports the following
types of custom fields: integer, float, text, date, and enum. After clicking the "OK" button, the new field
will be displayed in the list window.

5. Click the Remove Field button  to delete the added field selected in the Remove Field dialog (only
the fields created by the users can be removed).

6. The selected results can be exported in multiple formats such as txt, asc, neu, xyz, pts, and csv. Click
the  button, the "Select Method" dialog box pops up (as shown).



7. Click the  button to select the output path and select all the fields need to be export. Then,
click "OK" button to finalize the exporting.

8. If the users do not save the selected result, when exiting this function, the software will pop up the
following interface, click "Save" to save the point, click "No" to exit the function.

Settings

Measuring Height: This function uses a cylindrical area to select the point cloud, and fits the points
obtained with a planar circle to get the DBH. The measuring height corresponds to the height from the
fitting circle to the selected tree root.
Buffer Height: The height of the cylindrical area to select the point cloud.
Buffer Radius: The radius of the cylindrical area to select the point cloud.
Label Size: The display size of the label for displaying DBH measurement results in the three-
dimensional window.
Total Number: The total tree of measurement result (cannot be manually modified).



Forest Biomass Estimation

Overview

This function estimates the biomass of a region using a biomass model. For an introduction to the
biomass model, please refer to the Biomass Model Management overview. The input for this function is a
single tree attribute file, which can be obtained from the results of point cloud segmentation, or it can be a
custom CSV file that includes fields for tree species (optional), diameter at breast height (DBH - required),
and tree height (required). Please refer to the appendix for information on ground point cloud single-tree
segmentation result file format.

Usage

Click Terrestrial Lidar > Forest Biomass Estimation.



 

               
             

              
        

Parameters  Settings

Input Individual Tree Attribute File: Refer to the Ground-based Point Cloud Individual Tree 
Segmentation Result File Format. Depending on whether the input data includes the "tree species" 
field, there are two interface options. After program execution, the calculation results will be 
appended to the end of the file by column.

Select Database: Currently supports three databases:  North American Database(NBEL), and 
Custom Database.

When Input File Does Not Include Tree Species: When no tree species are selected, all trees in the
file are assumed to be of the same species. Begin by selecting the existing tree species from the 
database. If the desired tree species is not available, it can be defined using Biomass Model 
Management. Then choose the region under that tree species, as well as the model type. Finally, 

NBEL North America Database: Includes 7000+ biomass formulas for the North American region, 
referencing the U.S. Department of Agriculture. When switching to the North American database, 
users can input one or more filtering conditions as needed to filter out the desired formulas and 
then execute the calculation.

Filter Formulas: Users can select one or more conditions from "Region," "Tree Species," "Author," "
Part," and "Formula Number\Index," then click the "Filter Formulas" button. The filtered formulas 
will be displayed in the table below. Each row in the table represents a formula, and each column 
represents detailed information about the formula.

Add, Export, Save, Delete Formulas: Double-click on a row in the filter table, or click on a formula in
the filter table and then click the add button on the left to add the formula to the pending formula 
table. The export button can save formulas in the pending formula table, and the import button can 
import formulas and directly execute the calculation. The delete and clear buttons can remove 
formulas from the pending formula table.

select the calculation results: Currently supports five calculation results, and one or more can be 
chosen.When Input File Includes Tree Species: When selecting a tree species, it is necessary to 
individually select the region, calculation results, and model type for each tree species. If the 
database includes the selected tree species, the icon in front of that species will show as

. After selecting the region (for cuatom), the icon will change to

. Only when the icon shows this status can the biomass of that tree species be correctly calculated

and output. If the database does not include the selected tree species, the icon will show as

. In this case, it is necessary to define the biomass model for that tree species. Otherwise, the 

biomass of that tree species will not be calculated.



  
 
 

 

 
 

 
 

 
 

 

 
 

 

               
             

              
        

Calculation Results: Each formula in the pending formula table will be added as a new column to 
the individual tree attribute file.

Custom Database: Contains all user-defined formulas. When switching to the custom database, 
users can directly select tree species, region, and formula in order, then execute the calculation.

OK: Execute the calculation. The calculated biomass results will be added as new columns to the 
individual tree attribute file.



Biomass Model Manager

Functional Overview

Biomass refers to the total dry weight of organic matter per unit area at a certain moment in ecology. It is
usually expressed in kilograms per square meter (kg/㎡) or tons per hectare (t/h㎡). The usual method for
measuring biomass is to harvest all the materials within a unit area and then dry and weigh each part
separately. For carbon storage statistics, the parts that need to be harvested include aboveground parts
(trunk, leaves, flowers) and belowground parts (soil, dead wood, litter, etc.). In actual operation, it is
difficult to calculate underground biomass and harvesting samples requires a lot of work and can cause
serious environmental damage. Therefore, regression formulas are usually used to calculate the total
biomass within a unit area sample statistically. Then forest-scale biomass can be obtained by multiplying
with forest area. Considering that different tree species have different growth curves due to differences in
light exposure and humidity they receive; therefore different biomass inversion models must be
constructed for different tree species using basic parameters such as tree height (H) and diameter at
breast height(D). Researchers have done extensive research on formulae for biomass models of different
species mostly based on H & D as basic inversion parameters. This function supports
inputting/deleting/querying/modifying dozens of tree species models based on China's forestry industry
standard.

Usage

Click Ground-based Forestry > Forest Biomass Model Management.

Parameters Settings

Import: You can import custom database files which should only come from exported biomodel
database files via this function.



     
             
    
               

   
              

                
     

          
       

           
               
 
          

    
           

         
          

               
    

              
              

             
      

Export:  Export  data  as  database  file.
Define  Tree  Species:  Open  custom  tree  species  function.  This  function  can  input  custom  tree
species  models  into  the  database.
Species  Name:  Enter  a  custom  tree  species  name  that  cannot  be  duplicated  with  other  tree  species 
names  in  the  database.
Locations:  Each  tree  species  can  support  multiple  regions  to  enter  different  biomass  models  for  each
region.  Click  on  the  add  button  on  the  right  to  add  a  region  and  corresponding  biomass  model.
Locations  (required):  Enter  the  region  name.
Result  Type  (required):  Enter  target  parameters,  including  AGB  (aboveground  biomass),  UGB 
(belowground  biomass),  BCF  (biomass  conversion  factor),  V(volume)  etc.

Predefined Formula (Required): Select a calculation formula. Currently supports several predefined
formulas as well as custom formulas. Predefined formulas require choosing a formula template and 
manually inputting formula coefficients and parameter ranges (optional). Custom formulas allow the 
direct definition of formulas of any template type.

Self Define: Click the custom button to open the custom formula interface. You can fill in the formula 
as needed. The left side displays the parameter list, currently supporting three types of Parameters: 
Diameter at Breast Height (DBH) in centimeters, Tree Height in meters, and Crown Diameter (cl) in 
meters. Users can choose one or more of these parameters for combination. The right-side panel 
provides some common formula functions for selection. The bottom panel lists some common 
formula examples to assist users in input. After entering the formula, if the button on the right turns 
into a green checkmark, it indicates that the formula is valid and can be added to the list.
Formula  Parameters(required):  Depending  on  which  formula  is  selected,  the  number  of  formula 
parameters  may  vary  but  no  more  than  three  at  most.
Formula  Range(optional)：Since  trees  accumulate  biomass  at  different  rates  during  different  growth
periods,  it  may  be  necessary  to  segmentize  height  of  trunk  for  biomodels  processing  such  as  treating 
trunks  below  5cm  diameter  separately.

Model  Management:  After  entering  all  biometric  formulas,  you  can  view  and  manage  them  in  Model
Management  interface  by  clicking  on  each  individual  tree  species  or  its  respective  regions  where  all 
supported  formulas  are  displayed  along  with  detailed  information  about  each  type  of  publicized  data
including  their  types,  parameters,result  types,and  applicable  ranges.

@inproceedings{ LY/T 2654-2016 LY/T 2657-2016 LY/T 2659-2016 LY/T 2656-2016 LY/T 2661-2016 }



Geological Analysis
Geological Analysis provides automatical as well as manual analysis tools for flow direction, flow
accumulation, fill, dip and strike.

Raster Flow Direction

Raster Flow Accumulation

Raster Fill

Query Dip and Strike



Raster Flow Direction

Summary

The tool use D8 algorithm to calculate the raster of flow direction for each pixel.

D8 algorithm is to build flow direction from each pixel to downhill neighbouring pixel of the most steep
angle.The output of pixel value is within 1-255 of Integer format.

Note:
1.If the pixel Z value is the lowest among the eight neighbouring pixels, it will be assigned to the
minimum value among its neighbourings. And flow direction is to this pixel. If multiple neighbouring
pixels have the same lowest value, it will still be assigned to the minimum value among its
neighbourings.But its flow direction will be definded via one of the following method. This can filter
abnormal low noisy point.

2.If the z-value of a pixel changes the same in multiple directions, and the pixel is part of a sunken
point, the flow direction of the pixel will be considered undefined. At this time, the value of the pixel in
the output flow direction raster will be the sum of these directions. For example, if the z-value
changes the same to the right (flow direction = 1) and downward (flow direction = 4), the flow
direction of the cell is 1 + 4 = 5. You can use the sink tool to mark pixels with undefined flow
directions as sunken points.

3.If the z-value of a pixel changes the same in multiple directions, and the pixel is not part of a
depression, a lookup table that defines the most probable direction will be used to specify the flow
direction. See Greenlee (1987).

4.The output D8 descent rate raster data will be calculated based on the z-value change rate of the
path length between the pixel centers and expressed as a percentage. For adjacent pixels, this is
similar to the percentage slope between pixels. When crossing a flat area, the distance becomes the
distance to the nearest pixel with a lower elevation. The result is a graph of the percentage increase
in elevation in the steepest descent path from each pixel.

5.When calculating the D8 descent rate raster data of a flat area, in order to improve performance,
the distance to the diagonally adjacent pixel (1.41421 cell size) is approximately calculated as 1.5 cell
size.

Description

The key to obtaining the hydrological characteristics of the surface is to determine the flow direction from
each pixel in the grid. This can be done with the flow direction tool.

The tool takes the surface as input and outputs a raster showing the direction of flow from each pixel. If
the output rate of decline raster data option is selected, an output raster expressed as a percentage will be
created, showing the maximum rate of change in elevation from each pixel along the flow direction to the
length of the path between the pixel center. If the Force all edge cells to flow outward is selected, all cells
at the edges of the surface raster will flow outward from the surface raster.



The flow direction is determined by the steepest descent direction or the maximum descent direction from
each pixel. The flow direction is calculated as follows:

maximum_drop = change_in_z-value / distance * 100

Calculate the distance between the centers of the pixels.

1.If the pixel size is 1, the distance between two orthogonal pixels is 1, and the distance between two
diagonal pixels is 1.414 (the square root of 2). If multiple pixels have the same maximum descending
direction, the range of adjacent pixels will be expanded until the steepest descending direction is found.
After finding the direction of the steepest descent, the output pixel will be encoded with a value
representing that direction.

2.If all neighboring pixels are higher than the pixel to be processed, the pixel to be processed will be
regarded as noise and filled with the lowest value of its neighboring pixels. The pixel to be processed has
a flow direction towards itself. However, if the single pixel sink point is located near the actual edge of the
grid or has at least one NoData pixel as an adjacent pixel, it cannot be filled due to insufficient
neighborhood information. To treat a pixel as a real single-pixel sink, all neighborhood information must
exist.

3.If two pixels flow into each other, they are both meeting points and have an undefined flow direction.
This method of obtaining flow direction through a digital elevation model (DEM) was introduced by Jenson
and Domingue (1988).

Usage

Click Geological Analysis >Raster Flow Direction.

Parameters

Input File：Select input tiff file.

Output Path：Select output path.

  @inproceedings{
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  @inproceedings{
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Raster Flow Accumulation
This tool is used to calculate raster of flow accumulation by pixel.

Notes:

1.The result will be a flow accumulation raster, each pixel value is calculated by all the uphill pixels by
cumulative weight.

2.D8 flow direction modeling algorithm is used in this tool.

3.If the Raster Flow Direction is not used for the input raster, the flow accumulation might be annular
and go into endless loop.

4.Pixels of undefined flow direction will only take in uphill pixels, they will not form any downhill flow.
For D8 algorithm, if the pixel is not of value 1、2、4、8、16、32、64 or 128, we consider the pixel
flow-undefined.

5.Flow accumulation is based on the amount of uphill pixels, the pixel itself will not be considered in.

6.The large value pixels can indicate rivers.

7.The low value pixels can indicate ridges.

Summary

This tool is used to calculate raster of flow accumulation by pixel. The pixel value is the cumulative weight
of all the uphill pixels.

Usage

Click Geological Analysis >Raster Flow Accumulation

Parameters

Input File：Select input tiff file.

Output Path：Select output path.

    @inproceedings{
        author={Sch\"{o}enson, S. K., J. O. Domingue},
        title={Extracting Topographic Structure from Digital Elevation Data for Geographic Information System
 Analysis},
        booktitle={Photogrammetric Engineering and Remote Sensing},
        year={1988},



    }

    @inproceedings{
        author={Sch\"{o}Tarboton, D. G., R. L. Bras, I. Rodriguez–Iturbe},
        title={On the Extraction of Channel Networks from Digital Elevation Data},
        booktitle={Hydrological Processes},
        year={1991},
    }



Raster Fill
Raster Fill is used to improve the raster by filling in the depression of the raster.

Depression pixel refers to the pixel lower than other surrounding pixels, which is unable to define the flow
direction.The pour point is the boundary pixel with the lowest elevation relative to the confluence area of
the depression pixel. If the depression is filled with water, the water will pour out from that point.

1. Z defines the maximum elevation difference between depression pixel and pour point, which decides
the minimum depth of the depression area need to be filled.

For example, suppose the elevation of the pour point in a depression area is 210 feet, and the
deepest point of the depression is 204 feet (depth:6 feet). If the z limit is set to 8, this depression will
be filled. However, if the z limit is set to 4, the area will not be filled because the depth exceeds the
limit value, and it is regarded as a valid depression pixel.

2.All qualified depression pixels will be modified to the elevation of pour point.

3.The more the depression points, the longer the processing time.

Summary

The Raster Fill tool uses functions equivalent to the focus flow, flow direction, depression, watershed, and
area fill tools to locate and fill depressions. The execution of the tool will iterate until all depressions within
the specified z limit are filled. While filling the depressions, other depressions may be created at the
boundaries of the filled area, and these depressions will be removed in the next iteration.

Usage

Click Geological Analysis> Raster Fill。

Parameters

Input File：Select input tiff file.

Output Path：Select output path.

Note: If the raster data is of integer type, the output filled raster data is also of integer type. If the input
raster data is of floating point type, the output raster data is also of floating point type.
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Query Dip and Strike

Summary

This tool is used to calculate dip and strike automatically or based on the point cloud selected manually.
Related analysis tool and result report are also available.

Usage

Load the point cloud in the viewer. Click Geological Analysis > Query Dip and Strike, and the toolbar will
show in the viewer.

In the Query Dip and Strike window, there are several buttons: Export Data, Query Dip and Strike,
Automatically Query Dip and Strike, Clear data, Statistic Report,Adjust radius and Settings.

 Export Data：Save data in the table as CSV file.
 Query Dip and Strike： By clicking this button, a round selection box will show in the point cloud

viewer.You can also adjust the radius of the circle. After selecting the point cloud by the round box, the
Dip and Strike info will show as 3D model in the viewer. Meanwhile, a query record will add in the table
below.

 Auto Query Dip and Strike：This tool can automatically calculate Dip and Strike, and add the record
in the table below.



Point Cloud File：Select point cloud file in the drop-down list.
From Class：Select the class of point cloud to be calculated, default setting is ground point.
Octree Level：Create an octree for the point cloud. The higher the level, the fewer the number of
point clouds contained in each octree node. The specific results of the segmentation are as follows:
the larger the value is set, the finer the queried facet, otherwise the larger the facet.
Facets：Parameters of Facets.

Facets Type：Different type of Facets.
Max Root mean square error：The maximum root mean square of the distance between
the point cloud of the cluster and the fitted plane in the segmentation.
Max distance@68%：The maximum distance of the top 68% of the distance between the
point cloud of the cluster in the segmentation and the fitted plane.
Max distance@95%：The maximum distance of the top 95% of the distance between the
point cloud of the cluster in the segmentation and the fitted plane.
Max distance@99%（by default）：The maximum distance of the top 99% of the distance
between the point cloud of the cluster in the segmentation and the fitted plane.
Max distance： The maximum distance between the point cloud of the cluster in the
segmentation and the fitted plane.

Distance Threshold： The larger the threshold, the more points will be segmented into a facet,
which means there will be more large facets.
Min Points Per Facet：The minimum points of a facet. The larger the value, the more the points
of a facet.

 Clear Data：Clear data in the viewer and the table.
 Statistic Report：Click the button to do statistics and filter on the dip and strike. Set the interval for

dip and strike statistics. The rose diagrams and corresponding statistical reports can also be generated.
When filtering, you can choose different filtering types and rendering types, and filter by setting the
minimum and maximum angle threshold.



 Settings：Checking or unchecking the box to decide whether to show label, axis and horizontal plane.



Mine
Provides tools related to mines, including extract tunnel points, compute normal vectors, trangulation
modeling, poisson modeling and other functions.

Tunnel

Extract Tunnel Points

Compute Normal Vectors

Surface Reconstruction

Triangulation Modeling (Poisson)

Open-pit Mine

Volume Change Analysis

Extract Toes And Crests

Inter Ramp Compliance

MeshEditor

Mesh Editor



The function of tunnel includes: Extract tunnel points, Triangulation modeling, Compute normal vectors,
Poisson modeling.

Extract tunnel points

Compute normal modeling

Poisson modeling

Surface Reconstruction



Extract Tunnel Points

Summary

Generate the center axis by importing from files or manually drawing, and then remove the noise inside
the tunnel along the center axis, and generate a new file. The algorithm first extracts the roadway point
cloud in a certain range around the center axis, and slices the roadway point cloud vertically along the
center axis at the certain step. Then calculate the outer ring (roadway boundary) of each slice, remove the
internal noise, and finally merge the results. This function is suitable for caves, shield tunnels,
underground tunnels and other data.

Usage

Click Mine > Extract Tunnel Points 。

Settings

Input Data:The input file can be a single point cloud data or a point cloud dataset, which must be
opened in the LiDAR360 software.
Center Axis: Currently, two methods of "import from files" and "manual drawing" are supported to
obtain the center axis. The algorithm will extract the tunnel point cloud around these center axes and
denoise, and finally generate a new file.

Import Center Axis from Files: Supports center axis files in SHAPE format and ASCII format.
The center axis file must contain at least two columns, namely: X and Y. After the center axis file
is imported, it will be displayed in the scene. The center axis needs to be fitted with the point



cloud, otherwise the function will not work properly.
Manual Drawing: The user can use the interactive polyline as a medium to automatically
calculate the center axis. Click this button  to start drawing a polyline in the view with the left

mouse button, double-click to end the drawing of the current polyline, and add it to the list of
polylines. Select a polyline in the list and click the button  to delete the corresponding polyline.

Step (m) (Default Value is "0.25"): The tunnel is longitudinally sectioned along the center axis with
this step length, and each segment of the point cloud after sectioning is individually denoised. The
step size affects the efficiency and precision of the algorithm. The smaller the step size, the lower the
efficiency and the finer the denoising effect. When the tunnel surface consistency is good and the
direction change is gentle, the value can be increased appropriately. Good results can be obtained by
keeping this value between 0.2 and 3.0.

Tunnel Thickness (Default Value is "0.2"): The thickness of the tunnel refers to the average
distance from the inner wall of the tunnel to the surface of the tunnel. Points in the tunnel greater than
this distance will be counted as noise points.
Tunnel Width (m) (Default Value is "8"): The tunnel width refers to the maximum width of the
contour section in the tunnel, which determines the extration range of the point cloud on both sides of
the center axis. This value needs to be greater than the maximum values of the net width of the entire
tunnel to avoid the inability to obtain the tunnel point cloud during the calculation process.



Compute Normal Vectors

Summary

Calculate the normal vector of the tunnel. The algorithm will search for adjacent points within a certain
radius for each point, and then calculate the local plane and normal direction based on these points.
Finally, use the minimum spanning tree to optimize the direction of the normal (optional). The generated
normal will be stored as an additonal attribute, and the addtional attribute field is "Normals".

Usage

Click Mine > Compute Normal Vectors。

Settings

Input Data: The input file can be a single point cloud data or a point cloud dataset, which must be
opened in the LiDAR360 software. File format: *.LiData.
Search Radius (m) (Default Values is "0.5"): Neighborhood search radius. The algorithm obtains
neighboring points through neighborhood search for each point, and then calculates the normal
direction based on these points. If this value is too large or too small, it will cause the normal
calculation error, and when it is too large, it will also cause the algorithm efficiency to decrease. This
value can be set to 5 times the average dot spacing to get the best results.
Orientation (Default is checked): When this option is checked, the minimum spanning tree will be
used to optimize the consistency of the normal direction.



Triangulation Modeling(Poisson)

Functional Overview

Triangulation Modeling(Poisson) is used to generate a 3D model file in .obj format using point clouds.
Prior to running this function, Tunnel Normal Computation must be performed on the point cloud. Set
parameters and preview results in the window on the right-hand side of the screen. Adjust density
parameters for optimal results before saving.

Usage

Click Mine > Tunnel > Triangulation Modeling(Poisson).

Parameters Settings

Point Cloud File: Input one or more point cloud data files. File format: *.LiData.

Every Node Sample (default "1.5"): The minimum number of points retained in each node after
octree reconstruction is used to weaken noise interference with reconstruction results. A larger value
provides greater noise resistance but ignores more details; set between 1.0 and 5.0 for small
amounts of noisy point clouds, and between 15 and 20 for large amounts.

Point Weight (default "2.0"): The weight of interpolated points in the Poisson implicit equation
determines how closely the reconstructed implicit triangular mesh surface matches the original point
cloud.

Resolution (default "0.4"): The resolution of the reconstructed implicit triangular mesh surface
determines its density; higher resolutions result in denser meshes that preserve more detail, while
lower resolutions produce sparser meshes.

Density: After reconstruction, adjust this parameter during preview generation to confirm final
reconstruction results.



Surface Reconstruction

Functional Overview

This function is used for fast 3D modeling based on point clouds. Prior to executing this function, it is
usually necessary to perform preprocessing such as denoising, sampling and smoothing on the raw data.
This function does not require calculation of normals or generation of 3D model files.

Usage

Click Mine > Tunnel > Surface Reconstruction.

Parameters Settings

Input Point Cloud Data: Input one or more point cloud data files. File format: *.LiData.
Remove Small components: Whether to remove small objects such as floating debris.
Max size of hole: Used for filling smaller holes.



The functions of Open-pit Mine include: Volume Change Analysis Report， Extract Toes and Crests，
Inter Ramp Compliance.

Volume Change Analysis Report

Extract Toes And Crestes

Inter Ramp Compliance



Volume Change Analysis Report

Functions Overview

This function is mainly used to calculate the point cloud fill and cut volume based on the model or plane
and generate a report.

Usage

Click Mine > Volume of closed model.

Parameter settings

Enter the data to be compared：The data to be compared can be point cloud or model data . If the
data is already open in 360, the user can select from the drop down menu. You can also use the
button on the right to import directly.
Datum：

Model：Select model as datum. A model file must be selected at this point.If the model data is
already open in 360, the user can select from a drop down menu.You can also use the button on
the right to import directly. Currently only models in ".LiTin" format are supported.
Flat：Select the plane as datum.At this moment, you need to specify the plane height. The
amount of cut and fill will be calculated based on this level.

Choose a vector file：The user can select the vector file to load into the LiDAR360 software from



the drop-down menuvector file，they can also select  button to load an external vector

data file。The file needs to contain several closed polygons. These polygons will be used as the
boundaries of each area concerned by the user for fill and cut calculations, and the calculated results
will also correspond to the polygons one-to-one.
Minimum area (square meters) (default "1.0")：Polygon areas smaller than this area will be
discarded.
Cut and fill report：Click OK and after the calculation is completed, the volume change analysis
report interface will pop up.The calculated cut and fill of each area is displayed in the form of a table.
Each polygonal area will be drawn on the basemap with floating labels showing its cut and fill and
surface area.

Report settings：Units can be changed in the report settings interface. The first column of the table
can change the visibility of the area. Double-click the 2 and 3 columns to change the visibility, fill and
cut information and color of the corresponding area, respectively.
Export：Export report to html format.



Extract Toes and Crests

Summary

Automatic extraction of mine toes and crests based on triangulation model.

Usage

Click Mine> Extract Toes and Crests, the parameter interface will pop up, set the parameters to execute
the extraction.

Settings

Input Mesh File: Select from the project layer catalog or select model files from a folder.
Min Slope Angle (°): Minimum step slope angle.
Max Slope Angle (°): Maximum step slope angle.
Min Length (m): Shortest slope line length.
Smooth Iteration: Number of smoothing iterations for the triangulation model.
Save Format: The format in which the extraction result slope line is saved (supports .shp, .dxf).
Default: Click this button to restore all parameter default values.



Inter-Ramp Compliance Analysis

Functional Overview

This function quickly calculates the step slope angle and bench width to generate a profile based on the
interest area, mine trend line, and completed surface model of the top and bottom lines of slopes.

Usage

Click Mine > Inter-Ramp Compliance Analysis  in the function to open the page:

The options are specify data , auto generate cross section , manual generate cross section ,
compute , reports and exiting .

1. Specify Datas

Click on specify data button to pop up a dialog box for data selection and parameter setting:

Boundary File: The polygon range file of an interest area, can be draw in vector editor model.
Segments File: The trend line file of an open-pit mine in the area, can be draw in vector editor model.
Strip Width (m): The width parameter for generating a single mesh strip in the interest area based on
the polygon and trend lines.
As-build surface: A current 3D model of an open-pit mine in obj format.
Crest line file: The corresponding file for the top line of an open-pit mine slope.



Crest line layer: The corresponding layer for the top line of an open-pit mine slope.
Toe line File: The corresponding file for the bottom line of an open-pit mine slope.
Toe line layer: The corresponding layer for the bottom line of an open-pit mine slope.
Muck top lines(optional):The upper boundary file corresponds to a mud area in an opencast mining
operation.
Muck bottom lines(optional):The lower boundary file corresponds to a mud area in an opencast
mining operation.

Click OK, and yellow grid strips will be generated.

2. Auto Generate Cross section

Clicking on auto generate cross section will pop up a dialog box:

Cross section every strips: Generate cross-section every few strips.

Click OK to generate blue cross section position lines.

3. Manual Generate Cross Section

Clicking on manually generate cross section  allows you to interactively add or delete cross section
position lines within windows.

The currently selected strip location is highlighted in red. Confirm with the left mouse button. If there is no
cross-sectional position line within the currently selected strip, a new one will be added; if it already exists,
it will be deleted.

4. Compute

Clicking on compute  calculates step slope angles and bench widths to generate profiles. The generated
results can be previewed in the profile window on the right side.

5. Reports

Clicking on reports  pops up a dialog box:

Author: Report author.
Output Path: Report save path. Set parameters, click OK, then PDF reports and CSV tables will be
generated at the target location.

6. Exit



Click exit  to



Mesh Editor
The mesh editor function allows for the editing and modification of triangular mesh models, including
selection tools, editing tools, display settings, etc. This tool can be used to edit and optimize automatically
generated models.

Usage

Click on Mine > Mesh Editor  to open the function page:

It is mainly divided into the following parts:

Editor

Select

Edit

Setting

Use the editor tool to select a model object and enter edit mode. Use the select and edit to modify and
optimize the model. Save edited objects by clicking and exit from model editing.



Editor

Control mesh editing, supporting the editing of one mesh object at a time.

Start Edit

Click Edit > Start Edit  to select a model file for editor. During the editing process, the edited model data
cannot be removed.

Save

Click Edit > Save 

to save your edits and overwrite the original file.

End Edit

Click Edit > End Edit 

If there are any modifications made to the model file, you will be prompted with a message asking if you
want to save your changes:

Click "Yes" to save your edits and overwrite the original file. Click "No" to cancel your edits and exit. Click
"Cancel" if you wish to continue editing this model object.



Selection Tools

The selection tools for the currently edited model include triangle face selection from left to right, including
selection tools (rectangle, lasso, polygon), selection mode (select through, select visible), whether to
select back faces, substract, select components, expand, shrink, flood fill select, hide selection and unhide
selection. There are also options for select all, unselect all, invert selection tools.

Selection Tools

Switch between current selection tools via a drop-down menu:

 Rectangle Select

 Lasso Select

 Polygon Select

Selection Mode

Two modes can be switched between:

 Select Visible: In this mode only triangles visible in the window can be selected using the chosen
tool.

 Select Through: In this mode all triangles within a selected area can be selected using the chosen
tool.

The difference is shown below:

  

Select Back Faces

 Select back faces. Whether or not to enable back face selection is enabled by default.

Substract

From left to right: selected area, select through, visible selection



 Substract: When this mode is enabled, selecting a region with the chosen tool will deselect any
previously selected triangles within that region.

Select Component

 Select component: This function selects all triangles belonging to the same component as the
currently selected triangle face. For example, if one triangle of a floating object is selected and this
function is executed, then all triangles of that floating object will be selected.

Expand

 Expand: This expands the range of currently-selected triangle faces outward from their current
position.

Shrink

 Shrink: This shrinks the range of currently-selected triangle faces inward from their current position.

Flood Fill Select

 Flood fill selections: This selects all connected triangles in an approximately flat plane relative to the
currently-selected face(s).

Hide Selection

 Hide selected items: This function makes the currently-selected triangle faces invisible, making it
easier to select obscured or internal triangles.

Unhide Selection

 Cancel hiding: This function restores visibility to all previously-hidden triangle faces.

Select All

 Select all: This selects all faces of the currently-edited object.

Unselect All

 Deselect all: This deselects all faces of the currently-edited object.

Invert Selection



 Invert selection: This function inverts the current selection. Currently-selected items will be
deselected and vice versa.



Editing Tools

Editing operations for the currently edited model, from left to right include undo, redo, delete, fill all holes,
fill single hole, bridge, smooth and decimate.

Undo

 Undo - undo the last edit operation.

Redo

 Redo - re-execute the last edit operation.

Delete

 Delete - delete the currently selected triangle face.

Fill All Holes

 Fill all holes. Click on the function button to pop up a parameter interface:

Skip The Big Hole Num: Skip the number of holes with more edges. The skipped holes will be
displayed in green and those being filled will be displayed in red.

Click apply to execute filling all holes. After filling is complete, click OK to exit and save the current
patching result or click cancel to exit without saving it.

Fill Single Hole

 Fill a single hole. Enter single-hole filling mode and select a hole by moving your mouse over it. The
selected hole will turn red. Confirm by clicking on the left mouse button to fill the selected hole.

Bridge

 Bridge. Click on bridge to enter bridging mode. Use the left mouse button to select a point on the
hole and then select an edge of the hole to generate a single triangle face. The selected points and edges
can come from either the same or different holes, as shown below:



 

Smooth

 Smooth - click on this function button to pop up a parameter interface:

Mode

Tangential: smooth towards local triangle tangent direction.

Normal: smooth towards local triangle normal direction.

Tangential+Normal: smooth in both directions.

Continuity

C0: maintain continuity of local point position smoothing.

C1: maintain continuity of local point normal smoothing.

Max Distance Error : maximum allowable displacement between smoothed and original vertex
positions. If exceeded, corresponding vertices will not be changed. Default is -1, with no limit on
vertex movement distance.

Statistic : source category for processing broken lines corresponding point cloud, generally mesh
category.

Display by deviation: whether or not model displays according to size of post-smoothing vertex
displacement amount; valid only when not displaying double-sided models.

Decimate

 Decimate - click on this function button to pop up a parameter interface:



Target Triangle Count: simplify the number of triangles to the set value.
Target Percentage: control the target number of triangles as a percentage.



Settings

 Click on the settings button to open the settings interface:

Display

Vertex: Whether to display vertices of the mesh model.

Edge: Whether to display edges of the mesh model.

Face: Whether to display faces of the mesh model.

Backface: Whether or not to distinguish between front and back faces when displaying models.

Colors

Front Color: The color used for displaying front-facing polygons when backface display is enabled.

Back Color: The color used for displaying back-facing polygons when backface display is enabled.

Single Color: The color used for displaying models when backface display is disabled.

Vertex Color: The color used for displaying vertices of a model.

Edge Color:: The color used for displaying edges of a model.

Auto Save

Time (minutes): How often should cache be saved while editing a model, in case program crashes and
you need to recover your work.



Building modeling
The function of Building Modeling realizes automatic extraction of building model based on classification
point cloud, manual editing and storage of automatically extracted model results. In the process of building
model editing, the point cloud and image data are used as the background, and the real-time preview
effect of the building model is used as the auxiliary, the building model is constructed by manually editing
the two-dimensional vectorization object of the building model quickly and accurately. At the same time,
the results of building model support the generation of OBJ, FBX, CityJSON format for third-party software
interconnection.

Modeling Process

Extract Building Footprint

Subsampling

Remove Outliers

Classify Ground Points

Classify by Deep Learning

DSM

DOM

Building Model Registration

Auto Create Buildings

Project Textures form Photos

Attributes Caculate

Building Editor

Matched Photos Editor

Materials Editor



Building Model Registration

By using point clouds, models, or imported control points, select corresponding image control points in the
image window. After collecting four pairs of control points, the image project will be registered based on
the four pairs of control points.

Usage

Image Viewer

Match Points



Image Viewer

Display a list of images in the image project file and the currently selected images in the list.

Find Image

Show the images found in the image list based on the current selected 3D point or the center point of the
building surface.

All Image

Show all images in the image project.

Save

Save the current texture editing result.



Match Points List

Import

Import matched points file to the match point list.

Export

Export match points from the match point list to a file.

Click Selection

Enable click selection function, select 3D points in the point cloud or model window, and select 2D image
points in the image window.

Add Point

Add a new line of match point record.

Delete Point

Delete currently selected match point record.

Save

Save current match result to image project file. If precise alignment is checked, you need to select a point
cloud file and perform precise alignment based on the current alignment result.



Extract Building Footprint from Image

Description

This function uses deep learning to extract building footprint from images. The input file must be a DOM
(digital orthophoto image) or a three-channel color image produced by aerial photography, such as an
orthophoto image. It cannot be a single-channel image such as DEM or DSM. The output is a gpkg vector
file containing multiple building footprints.

Usage

Click on 3D Building > Extract Building Footprint from Image.

                 
       

        

Parameters

Image  File:  Select  the  opened  file  in  the  software  or  select  the  image  data  from  the  folder.  Currently
supports  tif,  tiff,  jpg,  jpeg  and  png  formats.

Simplify (default is "Yes"): When selected, the outlines of buildings will be simplified, reducing the
jaggedness in the original outlines to some extent.

Regularization (default is "Yes"): Specifies whether to perform regularization on the generated 
building outlines. After regularization, the angles between any two adjacent sides of the building 
outline will not exceed the angle threshold.

Angle Threshold (default is "10"): Line segments with angles smaller than this threshold will be 
merged into a straight line.

Delete Contours When Area < (default is "10"): If selected, outlines with an area less than this 
value will be deleted.

Output  Path:  Save  path  for  outputting  contour  vector  files.



Create building models automatically

Functional Overview

Based on the general architectural model description, the Lidar360 automatic modeling function generates
level-of-detail(LOD)2 architectural models. For the LOD 2 architectural model, the main expression is the
shape of the roof, and the wall is a vertically stretched plane. Automatic building modeling is based on
ALS point cloud data and building vector footprint. The vector footprint is mainly used to determine the
scope of each building and constrain model generation. Automatic modeling creates a high-precision Lod2
model of a building, and the resulting model can be modified in detail with manual editing tools.

Usage

Process of creating building models automatically is as follows:

1. Use the classification tool to classify ground points.

2. (Optional) Use the classification tool to classify buildings.

3.Click3D Modeling function page >Automatic building modelbutton, pop up a dialog box:

1. Set parameters and click OK to start the execution.

Parameters Settings

Point cloud file: Select point cloud data from the software opened or from the folder. Point cloud
data should be classified by the ground points at least.
Building footprint file: Building vector footprint file supports shp, dxf, gpkg format file, can be
generated through the Lidar360 vector editing module or use the existing building footprint file.
Roof type: It is used to determine the use of point cloud when extract the shape of the roof. Building
category is selected by default. If building classification is not performed on the data, you can co-opt
the creation points, unclassified points, or user h household to customize the category of roof.
Ground Class: It is used to determine the floor elevation of a building. The ground point category is
used by default.
Minimum detail area: It is used to extract the roof shape for surface filter parameters, a smaller value



can extract more details, and the error will increase correspondingly; a larger value can extract less
details, the error rate is small. It can be set to 0 if no filtering is performed.
Output Path: The path to save the model file.



Editor
Control the start and end of building model editing, and support to edit one building model object at a time.
The building model objects that can be edited include: select building model files for editing, new sketch
building model file.

Select Building Model File to Edit

Click Editor>Select Building Model File to Edit

The interface for selecting Building Model object data pops up. The Building Model object data that has
been loaded into the editing window will appear in the selection list. Select the data to be edited.

If there is no building model object data in the edit window, a dialog box is displayed to select the building
model file and load the data from disk for editing.

After starting editing, other functions of the Building Model editing tool bar will be activated.

During the editing process, the edited Building Model data cannot be removed from the editing window.

New Sketch Building Model

Click Editor>New Sketch Building Model File to Edit

A temporary edit model object is constructed in the edit window. Manual extraction of buildings and
manual editing after extraction can be carried out. At the same time, the edited building model data is
loaded into the directory tree as a temporary object in the window.

After starting editing, other functions of the Building Model editing tool bar will be activated.

During the editing process, the edited Building Model data cannot be removed from the editing window.

Save

End Edit

Click Editor > End Edit

Functional Description: Click*editor > save*. If the sketch is not saved, the Save File interface
will pop up, otherwise it will be saved to the original file.



After ending edit, a prompt box will pop up to save the editing results. After the user makes a selection as
required, the user can exit the editing function, and the editing module of the building model becomes
unavailable.



Utility Tools
Basic Function: including undo, redo and setting.

Undo

Redo

Undo the last edit.

Redo the last edit.



Settings

Color settings: Define the color of three linetypes, which are OuterEdge, InternalEdge,
IntersectionLine.

Width settings: Define the color of three linetypes, which are OuterEdge, InternalEdge,
IntersectionLine.

Configure building model to edit modular parameters.



Create the building model manually

Functional Overview

Building model generation is carried out by drawing the footprint range of a single building, which is mainly
used to automatically create buildings that are missing from the extracted building model function or the
building vector footprint. The point cloud data is consistent with the functional requirements of creating
building models automatically, and at least ground point classification should be carried out.

Usage

The process of manually creating a building model is as follows:

1. Click 3D modeling feature page > EditingButton, Create or Select a building model file.

2. Click 3D modeling feature page >Create the building model button to pop up the dialog:

1. Set parameters.

2. In the point cloud window, click the left mouse button to draw the boundary contour of the target
building. Right mouse button can go back to the previous point, double click to confirm, and execute
the generation of building model.

Parameters Settings

Roof type: It is used to determine the use of point cloud when extract the shape of the roof. The
selection of building category is defaulted. If the data is not classified by building, you can co-opt the
created point, the unclassified point, or use it to customize the category as the roof.
Ground Class: It is used to determine the floor elevation of a building. The ground point category is
used by default.
Minimum detail area: It is used to extract the roof shape for surface filter parameters, a smaller value
can extract more details, and the error will increase correspondingly; a larger value can extract less
details, the error rate is small. It can be set to 0 if no filtering is performed.



Building height model

Functional Overview

Building ground elevation: Determine a new building ground elevation by manually inputing or selecting
point cloud ground points.

Building elevation: Input manually and determine the overall height of the building.

The building height model is an auxiliary feature for building editing and is used to change the
height of the overall building.



Building Editor

Description

Choose a generated building model file or create a new building model file to start editing. This function
supports manual creation of building models and adjustment of building model details.

Usage

Editor

UtilityTools

CreateBuildings

BuildingElevation

BuildingEditorTools

AssistantTools

ShowingOrHidingTools

BuildingModelsList



Building editing tool

Edit the endpoints, line segments and patches on the 2D vectorized objects of the building model.

Move Edge Vertex

1. Click the left mouse button to select the endpoint on the building.
2. Move the mouse to a new position.
3. Click the left mouse button to finish moving the endpoints of the building.
4. Click the right mouse button to end the move point operation.

Insert Edge Vertex

1. Click the left mouse button to select the line segment.
2. Move the mouse to a new position.
3. Click the left mouse button to select the insertion point location, or click the right mouse button to go

back to step 1.
4. Click the right mouse button to end the insertion point operation.

Remove Edge Vertex

1. Move the mouse to determine the currently-selected endpoint through the snap flag.
2. Click the left mouse button to delete the currently-selected endpoint.
3. Click the right mouse button to delete the point operation.

Move Edge

1. Click the left mouse button to select the line segment on the building.
2. Move the mouse to determine the new position of the line segment, click the left button to complete

the move, or click the right button to go back to step 1.
3. Click the right mouse button to end the move line operation.

Align Edge

Move the endpoint on the building. The operation steps are as follows.

Insert a new node on the line segment of the building. The operation steps are as follows.

Delete the endpoint on the building. The operation steps are as follows.

Move the line segment on the building. The operation steps are as follows.



1. Move the mouse to determine the currently-selected endpoint through the snap flag, and click the left
mouse button to select the reference line.

2. Move the mouse to determine the position of the edit line by capturing the flag, and click the left
mouse button to select the edit line, or click the right mouse button to go back to Step 1.

3. Move the mouse to locate the new edit line and click the left mouse button to move the edit line, or
right-click the mouse button to go to Step 2.

4. Click the right mouse button to end the alignment line operation.

Apply Intersection Line

1. Move the mouse to determine the line segment through the snap flag that meets the operation
conditions of applied cross line. Click the left mouse button to complete the operation of applied cross
line.

i. Right click to end the operation of applied cross lines.

Remove Patch

1. Move the mouse, determine the patch to delete by snap identification, and click the left mouse button
to delete the patch

2. Click the right mouse button to end the delete-face operation.

Split Patch

1. Click the left mouse button to select Patch to be edited.
2. Click the left mouse button to draw the first point of the split line, or click the right mouse button to end

the current editing and go back to step 1.
3. Click the left mouse button to draw the second point of the split line to end the operation, or click the

right mouse button to end the current editing and go back to step 1.

Merge Patches

Move the line segment you want to edit vertically or parallel through the selected reference line.
The operation steps are as follows.

Turn the adjacent step edges of two faces into intersecting line. The operation steps are as
follows.

Delete patches. The operation steps are as follows.

Split patch. The operation steps are as follows.

Merge two adjacent surface patches The operation steps are as follows.



1. Click the left mouse button to select Patch 1
2. Click the left mouse button to select Patch 2 and merge Patch 2 onto Patch 1, or click the right mouse

button to go back to step 1.
3. Click the right mouse button to exit the operation of merging patches.

Add Hole

1. Click the left mouse button to select Patch to be edited.
2. Click the left mouse button to select points and draw a polygon. Double click the left mouse button to

finish the drawing or click the right mouse button to return to a point of the polygon.
3. Right click to add face operation.

Split Building

1. Click the left mouse button to draw the first point of the split line.
2. Click the left mouse button to draw the second point of the split line, or click the right mouse button to

end the current editing and go back to step 1.
3. Left click to select one side of the split line as a new building, and jump to the corresponding location

at the same time, or right-click to end the current editing, and go back to step 2.
4. Right click to end the operation of dividing buildings.

Fit Patch

1. Select the point cloud category used for fitting the roof, the default is the building type point cloud.
2. Click the left mouse button to select the building roof to be fitted.

Extrude Building

1. Open profile viewer and select the range of building profile to be constructed in the main viewer.
2. Open the function of Extract buildings, draw the outline of the building in the profile viewer, and

double-click the left mouse button to finish drawing, and right-click to go back.
3. Move the mouse in the main Viewer, click the mouse to select and determine the two boundaries of

the building, and complete the construction of the building.

Add an inner ring to building patch to form a void. The operation steps are as follows.

Split the building from one to two. The operation steps are as follows.

Fitting building roofs and adjusting the slope of individual roofs. The operation steps are as
follows:

Generating a new model, the specific operational steps are as follows:



Project Textures from Photos

Description

The project textures from photos function automatically applies textures to the roofs or walls of buildings
using imported Aerotriangulation projects or orthophotos.

Usage

Parameters

Model：ncludes two modes: Oblique and Ortho. Choose Oblique mode if using image project results
for texture mapping, and choose Ortho mode if using an orthophoto.

Oblique Mode

Building File：The building file (*.LiBIM) to be texture mapped.
Aerotriangulation projects：The image project file (*.LiAep) used for texture mapping.
Detect Occlusion： Whether to use a point cloud file for obstruction detection during texture
mapping to reduce the likelihood of wall features being obstructed by other objects.
Point Cloud：The point cloud file (*.LiData) used for occlusion detection.
Roof Only：Whether to apply texture mapping only to roofs. This option is suitable for image projects
that only contain nadir photos.
Max Oblique Angle：Only use photos with angles between the shooting angle and wall slope less
than this value for texture mapping to prevent excessive warping of wall textures.
Output Path：The path to where the generated texture mapped building file would be saved.

Ortho Mode

Building File：The building file (*.LiBIM) to be texture mapped.。
DOM：The orthophoto file (*.tiff) used for texture mapping。
Output Path：The path to where the generated texture mapped building file should be saved.

Ortho mode can only apply texture mapping to roofs.



Matched Photos Editor

Description

The Matched Photos Editor in LiDAR360 enables editing of already textured LiBIM data. By selecting each
building patch, choosing the desired image from the candidate list, and adjusting the endpoint position on
the image, the texture of the building patch can be updated.

Usage

Select the building object to adjust texture in the building model list.

Building Model List

Image Viewer



Materials Editor

Process

1. Click the button to open the Materials Editor viewer, select or load the building data file to be edited,
and the currently viewer containing the selected building data file is the workspace of this function.

2. After selecting building model data, Building Models List and materials editor interfaces will pop up.

3. (Optional) Click  button to activate selection tool, left-click on a patch in this function's workspace,
to select the patch and edit its material.

4. (Optional) Click button to clear current texture or image.

5. Select desired materials.

5.1 Method one：Choose required materials from library by selecting group where they are located
and clicking on them in material editor list interface.

5.2 Method two：Choose required materials from local files by clicking  button, pop up file
selection dialog box, and set image file as material for the selected patch.

5.3 (Optional) Click button to add currently selected material to library.

6. Adjust material control parameters.

Description: Edit the materials of building patches.



6.1 Method one：Set X,Y offset and X,Y scaling ratio of material in model materials editor interface.

6.2 Method two：Interactively control parameters by the interactive sphere that appears on the
selected patch in workspace.

Parameters

X Offset: Set the offset value of X-axis position of material origin point in texture image, valid range is
0-1.0, default value is 0.

Y Offset: Set the offset value of Y-axis position of material origin point in texture image, valid range is
0-1.0, default value is 0.

X Scale: Set scaling ratio along X-axis direction for texture image，default value is 1.

Y Scale: Set scaling ratio along Y-axis direction for texture image，default value is 1.

Same as X: Keep same scaling ratio between Y axis and X axis for current face's textures.

Auto Save：Automatically save modifications made during previous building's materials editing when
a new building has been chosen to edit.

Apply All：Apply current patch's materials settings to other patches with same semantics within
current building model.

Reset：Restore current building's materials settings from LiBIM files.

Save：Save current modifications into LiBIM files.

Default: Reset all controls back to their default values.



Basic Function
The tool is used for auxiliary window linkage during building model editing.

Auxiliary - Window Linkage

A new window and the window is linked with the main window to support the editing of architectural
models.



Show/Hide
The functions of this tool include model preview, and opening and closing the building list.

Model Preview

Open or close the building model preview window.

Open and Close Building List

Open or close the current list of buildings being edited.



Building Models List

This function displays the list of building models would be edited and records whether the current building
model has been checked. Also it supports selection, deletion, and checking of building models.

Select

Left-click to select the building model in the list that you want to edit, and the editing viewer will turn to the
position of the selected building model object.

Delete

Right-click on the building model list item, and left-click to select delete. It will remove the building model
list item from the building list and remove the corresponding building model from the editing viewer.

Check

Right-click on the building model list and select "Checked". The corresponding building model item will
display "Approve" as the suffix, and the icon in front of the list item will turn green with a check mark. The
viewer will automatically jump to the next item, and the editing window would also jump to the position of
the next building model.

Recompute

Right-click on building list,the list of building construction parameters will pop up. After adjusting the
parameters, re-fit the new building.



Attributes Calculate

Description

The Attribute Calculation function automatically calculates the attributes of building models, such as
building height, eave height, base elevation, roof orientation and roof shape based on the input data. The
results will be output to the attribute table of the building file.

Usage

Parameters

Building File: Input format is LiBIM building model file. You can select LiBIM data that has been
opened in LiDAR360 software through the drop-down box or load LiBIM data by clicking on the button
on the right.

Deviation Analysis (Optional): This function mainly calculates RMSE error values from points in
point clouds to building models. By default, it calculates RMSE errors from building points (category
6) to building models.

The result of Building Attribute Calculation is shown in the figure below.





Power Line
The Power Line module is used for processing and analysis of power line point cloud, including
Settings,Mark Tower,Classify,Dangerous point detection and Clear Danger Points.

Settings

Mark Tower

Classify

Detect Danger Points

Clear Danger Points



Settings

Summary

This setting will pop up automatically when powerline module is turned on. Powerline module parameter
settings include common settings and detection parameter settings. Common settings include working
directory settings, point cloud coordinate systems settings, class and detection parameters settings,
detected line voltage level settings; detection parameter settings include class settings, detection types,
and safety distance settings.

Common Settings

The user can set the working directory, point cloud coordinate system, class and detection parameters,
detected line voltage level and add configuration tables. The software can record the user's last 5 input
history records in settings of the working directory, point cloud coordinate system and classes and
detection parameters. User can select the most recently used item in the drop-down list. The working
directory is used to manage the project. The prj.ini file in the working directory records the point cloud
coordinate system, classes and detection parameters, and voltage level of the current project.

Working Directory: Used to save the intermediate and final results.
Classes and Detection Parameters: Set the path of the xml format configuration file.
Detected Line Voltage Level: The voltage level of the detected powerline.

Detection Parameter Settings

Displays key detection classes and safety distance detection parameters. User can add voltage levels and
then configure their corresponding detection parameters, including clearance distance analysis and
crossing analysis. Clearance distance analysis includes detections for different classes of objects, as well
as different safety distance and distance detection methods. For crossing analysis, user only needs to set
the classes to be detected, and user does not need to set a safety distance.



Select: Whether to detect this class.
Checked (default): Detect the danger point in this class.
Unchecked (default): Do not detect the danger point in this class.

Class: Select the number (from 1 to 32) of the class in the drop-down menu.
Detection Type: Select the detection type in the drop-down menu.

Clearance Distance: Judge the point whether to be a danger point by the clearance distance. If
the distance is less than this value, it is a danger point.
Vertical Distance: Judge the point whether to be a danger point by the vertical distance. If the
distance is less than this value, it is a danger point.
Horizontal Distance: Judge the point whether to be a danger point by the horizontal distance. If
the distance is less than this value, it is a danger point.
Horizontal Distance / Vertical Distance: Firstly judge the point whether to be a danger point by
the horizontal distance. If the distance is less than set horizontal value, it is a danger point. If the
distance is larger than set horizontal value, judge the point whether to be a danger point by the
vertical distance.
Horizontal Distance / Clearance Distance: Firstly judge the point whether to be a danger point
by the horizontal distance. If the distance is less than set horizontal value, it is a danger point. If
the distance is larger than set horizontal value, judge the point whether to be a danger point by
the clearance distance.
Horizontal Distance / Vertical Distance / Clearance Distance: Firstly judge the point whether
to be a danger point by the horizontal distance. If the distance is less than set horizontal value, it
is a danger point. If the distance is larger than set horizontal value, judge the point whether to be
a danger point by the vertical distance. If the distance is less than the set vertical distance, it is a
danger point. If the distance is larger than the set vertical distance, judge the point whether to be
a danger point by the clearance distance then.

Add Row: Add a new detection class record.
Delete Row: Delete the selected row of detection class.
Add Column: Add a new column for a severity level threshold. I.E., severe, important, and general.
Delete Column: Delete the selected column.



Change Column Name: Change the name of selected column.
Save: Save the configuration to the current xml file.
Save as: Save the configuration as a new xml file.



Mark Tower

Summary

After clicking in the point cloud data and choosing the tower type, user can save the result into LiTower
file. After adding the position information of the tower, the software will automatically generate the index
and name information of the tower. Index is a number starting from the starting value and incrementing by
1. By default, name is the same as Index. Tower type includes "None", "Tension Tower", and "Straight
Line Tower". Double-click the row for each tower to jump to that tower in the displaying window. By
checking or unchecking the checkbox in front of "display all tower points" to display or hiding the tower
points in the window. Point size can be modified.

Display All Tower Points (checked by default)：Display the tower names or indexes in the
window. Uncheck this option to hide the all the tower names or indexes.
By Index: Display the tower index.
By Name: Display the tower name.
Point Size (meter) (default value is "5.0"): Set the red marker sphere and text font size of the tower.

Select Tower
Click this button to start to pick the tower points. Click again to exit this function and save the



Add Tower After

Add Tower Before

Delete Tower

Modify Tower Position

Input Tower File

Export Tower File

Click this button to start to pick the tower points. Click again to exit this function and save the
current tower information to the tower.LiTower file in the working directory.

Add a tower record after currently selected record.

Add a tower record before currently selected record.

Delete the current selected tower record.

Modify the position of the selected tower.

Input the tower file and renew the tower list in LiTower, txt, csv, and kml file.

Export the information in the current tower list to LiTower or kml file.



Classify

Summary

Usage

Add the point cloud data, and click Power Line > Classify.

Settings

According to the tower file, clip and classify the point cloud data. Classify the point cloud into
transmission tower, powerline, ground points, noise, and other selected classes.This function can
process multiple data simultaneously. Click to add the data to be processed. Click to
remove the selected data. Click to clear the data list. This function can perform segmentation,
classification, and noise removal in one step, or user can select the function needed by checking
the box in front of the name of each function.



GPU Acceleration (Unchecked by default): Use GPU to accelerate when voltage is more than
500KV.

Corridor Width (meters) (default is "60"): Width extending to both sides of the powerline. The
software can record the user's current settings and automatically restore the settings when opened
again.

Starting Tower Index: Towers with index numbers smaller than this value are not involved in the
calculation. The default value is the minimum Index in the tower file.
Ending Tower Index: Towers with index numbers larger than this value are not involved in the
calculation. The default value is the maximum Index in the tower file.
Classify Ground Points: Please refer to the Classify Ground Points in the Classify toolbox for the
detailed information of parameter settings. The software will not classify the ground points if this
option is unchecked.
Remove Noise (Checked by default): Classify the noise points. The software will not classify the
noise if this option is unchecked.
Number of Thread (default value is "4"): Set the number of thread (1 to 32) to run this function. The
software can record the currently setting and when the user open this function again, the setting will
be kept.
Default: Restore the default parameter settings.

Note: The segmented data will be stored in the output path folder. The name of the file will be
(Smaller Tower Index_Larger Tower Index). In order not to impact the following steps, it is highly
recommended not to change the file name. After the automatic classification, user need to check the
accuracy of the result and manually modify it in the Profile Tools.



Detect Danger Points

Summary

Usage

Click Power Line > Detect Danger Points

Settings

Starting Tower Index: Towers with index numbers smaller than this value are not involved in the
calculation. The default value is the minimum Index in the tower file.
Ending Tower Index: Towers with index numbers larger than this value are not involved in the
calculation. The default value is the maximum Index in the tower file.

Batch process the point cloud file to generate the danger points images and reports based on the
tower file. The interface of detect danger points function is shown as follow. This This function can
process multiple data simultaneously. Click to add the data to be processed. Click to
remove the selected data. Click to clear the data list.



Corridor Width (meters) (default is "60"): Width extending to both sides of the powerline. The
software can record the user's current settings and automatically restore the settings when opened
again.

Detection Parameters: Detect the clearance danger points according to the customized

Cluster by Class: Unchecked by default. Used to control whether to cluster the result by class.If
this option is checked, the danger points will be clustered into different groups if they are in
different classes; otherwise, the class information will not influence the clustering process. The
software can record the user's current settings and automatically restore the settings when
opened again.
Min Distance (meters) (default value is "0.3"): Points with clearance distance less than this
distance are not detected as danger points, as they are considered to be noise. The software can
record the user's current settings and automatically restore the settings when opened again.
Safety Distance (meter) (default value is "4.5"): If the distance between the detected point and
the powerline point is greater than the minimum distance and less than or equal to the safe
distance, the point is considered to be a danger point. If the xml file is not set, user needs to
enter the safety distance; otherwise, this parameter is extracted from the xml file. When using the
xml to set the parameter, user can set different safety distances for different classes, and for
different severity level.
Cluster Threshold (meter) (default value is "15.0"): The maximum spatial separation distance
when the detection results are clustered. This value should be smaller than the maximum
clustering range. Three-dimensional Euclidean clustering is used to cluster the danger points.
The software can record the user's current settings and automatically restore the settings when
opened again.

Maximum Clustering Range (meters) (default value is "20.0"): After the detection results
are clustered, if the length along the power line direction is greater than this value, they are
divided into multiple dangerous point clusters. The software can record the user's current
settings and automatically restore the settings when opened again.

Number of Thread (default value is "4"): Set the number of thread (1 to 32) to run this function. The
software can record the currently setting and when the user open this function again, the setting will
be kept.
Default: Restore the default parameter settings.



Clear User Data

Summary

Usage

Power Line > Clear

Settings

Number of Thread (default value is "4"): Set the number of thread (1 to 32) to run this function. The
software can record the currently setting and when the user open this function again, the setting will
be kept.

Clear all the danger point detection result in the point cloud. After execute this function
successfully, all the danger points (in red) will be changed into non-danger point.



Tutorials
Getting Started Tutorial

Point Cloud Data Basic Operations Tutorial

Data Management

Statistics

Classify

Strip Alignment Tutorial

Terrain Tutorial

Forestry Tutorial

ALS Regression Analysis

Power Line Dangerous point detection

Videos
1. LiDAR360 Installation and License Activation
2. LiDAR360 Overview and Loading Data
3. LiDAR360 Window Management
4. LiDAR360 Measurement Tools
5. LiDAR360 Selection Tools
6. LiDAR360 Profile Tools
7. LiDAR360 Camera Roam in 90 Seconds
8. Point Cloud Generation
9. LiDAR360 Strip Adjustment Module

10. LiDAR360 Classify Ground
11. LiDAR360 Classify Ground by Selected
12. LiDAR360 Terrain Module
13. LiDAR360 Tree Segmentation
14. LiDAR360 ALS Forestry Module
15. LiDAR360 TLS Forestry Module

https://youtu.be/dgL7XTsZ-Tc
https://youtu.be/_At7rVVslDU
https://youtu.be/7pdqo7tY0A4
https://youtu.be/z7KEild2uLQ
https://youtu.be/JZ1PC9VSDZI
https://youtu.be/uxtArbCCwl4
https://youtu.be/1e2cBpmT038
https://youtu.be/5XmpQmgXM2M
https://youtu.be/HZz1tlN-60M
https://youtu.be/-XLi3URV2I4
https://youtu.be/Gz4x2B4bBXo
https://youtu.be/y9l_hSRj5mc
https://youtu.be/23Q0BHdbR8Q
https://youtu.be/wIBE3suS43I
https://youtu.be/0OE8SAZN9rA


Strip Alignment
This tutorial introduces the standard workflow of strip alignment for airborne LiDAR point clouds through
boresight calibration by LiDAR360.

Steps

1. Data Quality Inspection Data Quality Inspection is required to make sure the data meets the
requirements of strip alignment module. It improves the alignment quality after processing.

1.1. Click Strip Alignment > Trajectory Quality Analysis to check the trajectory quality from
the height analysis, speed analysis and flight attitude analysis.
1.2. Click Strip Alignment > Strip Overlap Analysis to analyze the overlap between point
clouds.
1.3. Click Strip Alignment > Density Quality Analysis to analyze the density of point cloud.

2. Click Strip Alignment > Boresight to align strips through boresight calibration.

3. (Optional) Click Strip Alignment > Elevation Difference Inspection to analyze the elevation
difference between point clouds.

4. (Optional) Click  Cut Overlap in the Strip Alignment module. For point cloud from LiDAR, the
smaller the scanning angle, the higher the quality of the corresponding point cloud. Therefore, to
ensure the quality of the point cloud data in the area, the low quality redundant points in the
overlapped regions can be removed.

Tutorial Videos

1. Point Cloud Generation

2. LiDAR360 Strip Adjustment Module

https://youtu.be/5XmpQmgXM2M
https://youtu.be/HZz1tlN-60M


Terrain
This tutorial introduces the standard workflow for terrain processing by LiDAR360.

Steps

1. Due to multipath effect, there are gross noise points in the point cloud data. Click Data Management
> Point Cloud Tools > Remove Outliers to remove outlier points of point cloud data.

2. Click Classify >Classify Ground Points to classify ground points for unclassified point cloud.
3. For the result of ground points classification at first time, if the classification results of a large number

of points are inaccurate due to unreasonable parameter settings, you can click Classify > Classify
by Attribute to restore the point cloud category to unclassified and set parameters again for
reclassification.

4. After ground points classification, for the inaccuracy of local area point cloud classification, you can
use the Classify Ground by Selected or Classify by Interactive Edit to perform the ground point
classification of the local area.

5. Make sure the classification of ground point cloud is accurate, then click Terrain > DEM or Terrain >
DSM to generate DEM or DSM. Currently the software provides three ways to generate DEM or DSM
from the point cloud: TIN, Kriging, IDW.

6. Click Terrain > Hillshade to create a hillshade map. This tool determines the illumination-enhanced
surface visualization by setting each cell in the raster. At the same time, you can click Data
Management> Conversion>Convert TIFF to LiModel to convert single-band Tiff images to LiModel.
The LiModel data can be viewed in 3D view more intuitively. In addition, the LiModel data can be
edited by clicking Terrain > LiModel Editor for generating a better quality of DEM model. Similarly,
DSM data can also be operated as above.

7. There are two ways to generate contour lines: Raster to Contour and Point Cloud to Contour. By
these two ways, you can generate contours from the DEM raster data generated in the previous step
or use the ground points after the fourth step classification. In addition, the TIN can be generated from
the ground point cloud, and the result of ground points classification can be viewed more intuitively.
The TIN model can be modified by clicking Terrain > LiTIN Editor, and then click Terrain > TIN to
Contour to generate contour lines.

Tutorial Videos

1. LiDAR360 Classify Ground Points
2. LiDAR360 Classify Ground by Selected
3. LiDAR360 Terrain Module

https://youtu.be/-XLi3URV2I4
https://youtu.be/Gz4x2B4bBXo
https://youtu.be/y9l_hSRj5mc


ALS Point Cloud Regression Analysis

Summary

Lidar technology has a strong ability to obtain the three-dimensional structure of the forest, and the
obtained canopy structure parameters have a strong correlation with the forest volume and above-ground
biomass. It is a large-area forest photosynthesis capacity assessment, biomass and carbon storage.
Estimation provides a good means. LiDAR360 provides four methods: linear regression, support vector
machine, fast artificial neural network, and random forest. The regression model is constructed from the
sample plot survey data and the variables obtained from the lidar point cloud to estimate the forest volume
and the amount of the sample square or larger area. Parameters such as biomass.

Regression analysis using LiDAR360 roughly goes through the following steps: denoising, filtering,
generating Digital Elevation Model (DEM), point cloud normalization, generating forest parameters, and
regression analysis.

Linear Regression Model

SVR Regression



Fast Artificial Neural Network Regression Model

Data Preparation

The input data for regression analysis is normalized point cloud data. The steps to generate a normalized
point cloud are as follows:

-Click Data Management> Point Cloud Tools> Outlier Removal to denoise the point cloud data and
remove the influence of noise.

-Click Classification> Classify Ground Points to classify the ground points from the point cloud to
generate DEM.

-Click Terrain> DEM to generate a digital elevation model based on the site surface.

-Click Data Management> Point Cloud Tools> Normalization to generate normalized point cloud data.

-Click ALS Forest> Forest Parameters> Calculate Forest Metrics By Grid, Calculate Forest Metrics
By Polygon or Calculate Forest Metrics by Forest Stands to generate the independent variable data
set required for regression.

Steps

The linear regression steps are as follows:

-Click ALS Forest>Regression Analysis>Linear Regression to load the generated forest parameter
independent variables into the function dialog box for linear regression analysis.

The support vector regression steps are as follows:

-Click ALS Forest> Regression Analysis> Support Vector Machine, load the generated forest
parameter argument into the function dialog box, and perform support vector regression analysis.

The steps of fast artificial neural network regression are as follows:



-Click ALS Forest> Regression Analysis> Fast Artificial Neural Network to load the generated forest
parameter independent variables into the function dialog box for quick Artificial neural network regression
analysis.

The regression steps of the random forest network are as follows:

-Click ALS Forest> Regression Analysis> Random Forest to load the generated forest parameter
independent variables into the function dialog box for fast artificial nerve Network regression analysis.

Accuracy Assessment

After the regression analysis is completed, an html file with the same name as the result file will be
generated to view the accuracy of the regression analysis and the variables involved in the regression
analysis.

The figure below is the support vector machine regression accuracy report. Degree, Gamma and K-Fold
are input parameters, which are set by the user in the parameter interface. The accuracy evaluation of the
regression model is determined by R, R Square and RMSE. R Square is the ratio of the sum of squares of
the difference between the predicted data and the mean of the original data to the sum of the squares of
the difference between the original data and the mean. The value range is [0 1]. The closer the value is to
1, the independent variable's ability to explain the dependent variable. The stronger. RMSE (Root Mean
Square Error), this value is the mean value of the square root of the error between the predicted value and
the measured value. Dependent and Independent Variable are the dependent and independent variables
participating in the regression analysis. Only one dependent variable is used for each regression analysis.





Power Line Dangerous point detection
This tutorial introduces the standard workflow of power line data processing by LiDAR360.

Steps

The main process for using the power line module to process point cloud data, detect dangerous points,
and generate dangerous point detection reports is as follows:

1. Click File > Data > Add Data to open data.
2. Click Power Line > Start Mark Tower，Start the power line module.
3. Click Power Line > Mark Tower to mark position of towers and edit properties of towers.
4. Click Classify > Clipping and Classifying to clip and classify point cloud data into tower, power line,

ground points, noise and unclassified data automatically. It is necessary to manually check the
classification results after automatic classification.

5. Click Power Line > Danger Points to perform dangerous points detection, tree segmentation, image
rendering and report generation.



Appendix
This chapter introduces some key terms, file formats, shortcut keys and ways of high-performance
graphics mode adjustment.

Key Terms

File Formats

LiData

LiAtt

LAS

LiModel

LiTin

Clipping Point Cloud File Format

Circle File

Rectangle File

Extract by Time File Format

Homologous Points File Format

POS File

OUT File

Control Point File Format

Notes Elevation Points File

Sample Data File

Seed Points File

Individual Tree Segmentation Result File

Seven Parameters Calculation File Format

Section Product File Format

Rectangle File Format

Centerline File Format

LiBIM File Format

ID List of Json Callable Functions for Batch Processing

Shortcut Keys

Menu Shortcut Keys



Viewer Shortcut Keys

Shortcut Keys for Profile Editing

High-Performance Graphics Mode Adjustment



Key Terms
Workflow – A sequence of steps to produce the final products.
Clipping – Extracting a subset of points from point cloud using an extent.
Extracting – Extracting a subset of points from point cloud using a specific point attribute.
Return Number – The Return Number is the pulse return number for a given output pulse. A given
output laser pulse can have many returns, and they must be marked in sequence of return. The first
return will have a Return Number of one, the second a Return Number of two, and so on up to five
returns.
Intensity – The intensity value is the integer representation of the pulse return magnitude. This value
is optional and system specific. However, it should always be included if available.
Outlier – A point or group of points isolated from other points of interest that are considered noise or
extraneous objects.



File Formats
This section introduces the data formats supported by LiDAR360 and the specific file formats involved in
various functional modules, such as POS file, control point file, seed point file and so on.

LiData

LiAtt

LAS

LiModel

LiTin

Clipping Point Cloud File Format

Clip by Circle File Format

Clip by Rectangle File Format

Extract by Time File Format

Homologous Points File Format

POS File

OUT File

Control Point File Format

Notes Elevation Points File

Sample Data File

Seed Points File

Individual Tree Segmentation Result File

Seven Parameters Inputs

Section Product File Format

LiTower

MatrixFormat



LiData
LiData is a point cloud data file format defined by LiDAR360. It consists of a public header block, variable
length records, and point data records.

This format can be exchanged with other common point cloud data format files, including LAS, LAZ, E57,
PLY, ASCII, etc.

When loading common point cloud data formats (including: LAS, LAZ, E57, PLY, ASCII, etc.) into
LiDAR360, a LiData file named after the same name will be generated, and the subsequent operations are
based on that LiData file.

LiData file has a version number to indicate its version. Currently, the most updated version of LiData is
V2.0.

Starting from LiDAR360 V4.0, the all the LiData versions before V2.0 are supported. For LiDAR360 V3.x,
the highest supported version is LiData V1.9. The differences between LiData V1.9 and V2.0 are listed as
follows:

Features LiData V1.9 LiData V2.0

Classfication 0-31 （32 classes in
total) 0-255 (256 classes in total)

Classfication
Flag Not supported Supported

Scanner
Channel Not supported Supported

Near
Infrared Not supported Supported

Scan Angle
Rank

In degree, in the range
of [-90°~+90°]

In in range of [-30000, +30000] (unitless) which
corresponds to the degree of [-180°, +180°]

Additional
Attribute Not supported Supported

Additional Attributes are stored in the LiAtt files



LiAtt File Format
LiAtt is the additional attribute file format of LiData. It consists of a file header and additional attribute data
records.

The additional attribute is supported since LiData V2.0.

The additional attributes are matched with the corresponding LiData file by the file name.

When the non-matching LiData and LiAtt files are manually modified to have the same file name, the
software may still be able to recognize all the additional attributes in the LiAtt file, but the corresponding
additional attribute values may be incorrect. Modifying the LiAtt may destroy the LiAtt file structure and
cause the additional attribute file to no longer be recognized when opening the LiData file next time.

Deleting LiAtt files does not affect the normal use of LiData files. But after LiDAR360 loads LiData,
deleting the corresponding LiAtt files may cause some operations to fail and cause unknown errors.



LAS
LAS file format Support the LAS file in the following formats:

LAS 1.1

LAS 1.2

LAS 1.3*

LAS 1.4*

Limitation for LAS 1.3 and LAS 1.4:

Not support waveform data currently.

https://www.asprs.org/committee-general/laser-las-file-format-exchange-activities.html
http://www.asprs.org/wp-content/uploads/2010/12/asprs_las_format_v11.pdf
http://www.asprs.org/wp-content/uploads/2010/12/asprs_las_format_v12.pdf
http://www.asprs.org/wp-content/uploads/2010/12/LAS_1_3_r11.pdf
http://www.asprs.org/wp-content/uploads/2010/12/LAS_1_4_r13.pdf


LiModel
LiModel file stores triangulated regular network models generated by DEM or DSM. It saves regular grid
nodes and block-organized triangulated regular network models according to quadtree. DOM texture
information can be superimposed on the model. LiModel could be transformated from massive data of
DEM or DSM. It supports editing operations including flatten height, smooth height, noise points removal
and so on. After editing, it can be exported to Tiff file for generating contours.



LiTin
The LiTin file is generated by the irregular 2.5D triangulation model based on the point cloud. It can
improve quality of contour lines by editing operations including flatten height, smooth height, vertex
addition and removal, etc. It organizes data in full memory mode, which takes up large memory and
causes low rendering efficiency. So it is suggested to generate LiTin file into tiles.



Clipping Point Cloud File Format

Summary

The file is a text file that contains a list of scopes used to load multiple circles or rectangles.

Clip by Circle File Format

Each circle consists of three values separated by commas: the X coordinate, the Y coordinate and the
radius of the center.

The following table is an example of a circular extent file:

322610.51, 4102305.22, 50

322685.86, 4102400.5, 50

322820.45, 4102510.21, 100

322850.35, 4102655.33, 100

323000.00, 4103000.00, 60

The above values can be stored in a text file (such as "extents.txt") and loaded into the LiDAR360
software.

Clip by Rectangle File Format

Each rectangle consists of four values separated by commas: X minimum, X maximum, Y minimum and Y
maximum.

The following table is an example of a rectangular extent file:

322601.255, 322801.255, 4102309.655, 4102409.655

322548.966, 322600.110, 4102310.180, 4102360.180

322539.155, 322600.255, 4102309.655, 4102359.655

322745.950, 322780.110, 4102204.660, 4102250.180

322875.224, 322975.224, 4102028.660, 4102128.660

The above values can be stored in a text file (such as "extents.txt ") and loaded into the LiDAR360
software.



Extract by Time File Format
Each extraction range consists of two values separated by commas: starting GPS time and ending GPS
time.

The following table is an example of extracting range files by GPS time:

526494.500,527494.500

527494.500, 528494.500

527494.500, 528494.500

528494.500, 529494.500

529494.500, 530494.500

The above values can be stored in a text file (such as "extents.txt ") and loaded into the LiDAR360
software.



Homologous Points File Format
Homologous points file is a comma separated text file. The first row is a file header. Each row consists of
9 columns: ID, reference coordinate (X,Y,Z), alignment coordinate(X,Y,Z).

 ID     ref_X        ref_Y        ref_Z      align_X       align_Y    align_Z 
P01, 322500.1100, 4102499.9600, 2613.1400, 322500.0089, 4102499.9856, 0.0000
P02, 322999.8400, 4102499.7900, 2614.3400, 322999.9283, 4102499.9585, 0.0000
P03, 322999.8300, 4102000.3200, 2554.4100, 322999.8738, 4102000.1457, 0.0000
P04, 322500.3700, 4102000.1600, 2490.7400, 322500.1140, 4102000.0595, 0.0000



POS File
The POS File contains information such as GPS time, longitude, latitude, height, roll, pitch, heading, GridX
and GridY. GPS time, longitude, latitude, height, roll, pitch and heading must be necessary, while
longitude and latitude or GridX and GridY include at least one. If POS file doesn't include GridX and
GridY, we need to set projection coordinate system when we input trajectory files. GridX and GridY can be
calculated according to projection coordinate system, longitude and latitude in strip alignment module.

The trajectory information stored in its file is structured as follows:

Data Units Type

GPS time seconds double

longitude degree double

latitude degree double

height meters double

roll degree double

pitch degree double

heading degree double

GridX(Optional) meters double

GridY(Optional) meters double

The examples the POS file is shown below. Example 1(not including GridX，GridY):

 380954.000,112.5311950876, 26.8969520123,378.543,  7.1701230000,  3.0890110000,-39.4065340000
 380954.008,112.5311938923, 26.8969533249,378.537,  7.2001860000,  3.0914780000,-39.4034150000
 380954.016,112.5311926975, 26.8969546376,378.531,  7.2368710000,  3.0936380000,-39.4011190000
 380954.024,112.5311915034, 26.8969559507,378.525,  7.2683090000,  3.1015050000,-39.3975470000
 380954.032,112.5311903098, 26.8969572641,378.518,  7.3007560000,  3.1115160000,-39.3929590000
 380954.040,112.5311891169, 26.8969585779,378.512,  7.3269790000,  3.1179720000,-39.3878260000
 380954.048,112.5311879247, 26.8969598920,378.506,  7.3525870000,  3.1180460000,-39.3804020000
 380954.056,112.5311867331, 26.8969612065,378.500,  7.3745730000,  3.1151630000,-39.3713830000

Example 2(including GridX，GridY):

383207.336,112.5421590662,26.9034172036,313.865,3.538615,2.660518,-67.848653,653147.099716932,2976670.6235468
9
383207.344,112.5421572108,26.9034177865,313.861,3.533299,2.659177,-67.840828,653146.914649722,2976670.6858765
4
383207.352,112.5421553554,26.9034183697,313.857,3.522385,2.658042,-67.828619,653146.729582108,2976670.7482394
3
383207.36,112.5421535001,26.9034189529,313.854,3.512757,2.659231,-67.816251,653146.544524429,2976670.81060244
383207.368,112.5421516447,26.9034195363,313.85,3.502656,2.662677,-67.807435,653146.35945655,2976670.87298749
383207.376,112.5421497892,26.9034201198,313.846,3.502243,2.664987,-67.803265,653146.174378605,2976670.9353835
383207.384,112.5421479336,26.9034207035,313.843,3.500293,2.668456,-67.80232,653145.989290462,2976670.99780155
383207.392,112.5421460783,26.9034212874,313.839,3.501546,2.671267,-67.797563,653145.804231844,2976671.0602421
2
383207.4,112.5421442231,26.9034218713,313.835,3.496569,2.674773,-67.789195,653145.619183163,2976671.12268281
383207.408,112.542142368,26.9034224554,313.832,3.483849,2.676885,-67.774991,653145.434144147,2976671.18514579
383207.416,112.5421405129,26.9034230395,313.828,3.471533,2.676137,-67.765536,653145.24910513,2976671.24760876



383207.424,112.5421386577,26.9034236237,313.824,3.47028,2.675779,-67.760612,653145.064056049,2976671.3100827
383207.432,112.5421368024,26.9034242079,313.82,3.475101,2.677064,-67.761833,653144.878997039,2976671.37255652
383207.44,112.5421349471,26.9034247923,313.817,3.476053,2.681571,-67.761664,653144.69393776,2976671.43505249



OUT File
Out file is a binary file that stores trajectory information. The following table shows the format of the
POSPac SBET file provided by Applanix. For details, refer to the PosPac quick start guide.

The trajectory information stored in its file is structured as follows:

Data Units Type

time seconds double

latitude radians double

longitude radians double

altitude meters double

x velocity meters/second double

y velocity meters/second double

z velocity meters/second double

roll radians double

pitch radians double

platform heading radians double

wander angle radians double

x body acceleration meters/second² double

y body acceleration meters/second² double

z body acceleration meters/second² double

x body angular rate radians/second double

y body angular rate radians/second double

z body angular rate radians/second double

https://www.applanix.com


Control Point File Format
The control point file contains a list of control points in TXT format. The first row is the file header, while
other rows store comma separated X, Y, Z coordinates of control points. The following table is an example
of a control point file:

X, Y, Z
473575.563, 291005.332, 127.244
473576.899, 291004.245, 126.328
473576.899, 291004.243, 126.317
473576.899, 291004.245, 126.328
473576.899, 291004.243, 126.317



Notes Elevation Points File
The notes elevation points file is a comma-delimited CSV file. The first row is the file header, while other
rows store X, Y, Z and Label (separated by comma).

The following figure shows an example of notes elevation points file:

X, Y, Z, Label
322539.46, 4102000.01, 2489.21, 2489.21
322551.33, 4102009.72, 2489.55, 2489.55
322562.85, 4102000.03, 2489.74, 2489.74
322563.16, 4102019.38, 2489.98, 2489.98 
322511.58, 4102056.04, 2492.86, 2492.86



Sample Data File
The sample data file is a text file (*.txt) delimited by commas that contains a file header in the first row.
The first two columns of each row are the X and Y coordinates, followed by a number of dependent
variables. Multiple dependent variables can be stored, but only one is used for each regression analysis.

The dependent variable is tree height in the following example of a sample data file:

X,Y,Height
322859.25,4102463.86,33
322862.25,4102459.35,31.5
322864.56,4102462.49,32
322874.58,4102463.50,35
322655.52,4102192.25,21.1



ALS种子点文件格式

种子点文件为CSV表格文件或树属性文件，包含描述数据信息的表头，其中至少包含四列，且这四列依次

为：树ID、树的X坐标、树的Y坐标和树的Z坐标。

下表为样地数据文件的部分示例：

TreeID,TreeLocationX,TreeLocationY,TreeLocationZ    
1,322971.5,4102497.5,47.387
2,322549.5,4102496.5,49.42    
3,322678.5,4102495.5,48.456    
4,322716.5,4102494.5,34.366    
5,322516.5,4102489.5,23.726

TLS种子点文件格式

种子点文件为CSV表格文件或树属性文件，包含描述数据信息的表头，其中至少包含五列，且这五列依次

为：树ID、树的X坐标、树的Y坐标和树木DBH的Z坐标、DBH。

下表为样地数据文件的部分示例：

TreeID,TreeLocationX,TreeLocationY,TreeLocationZ,DBH    
1,-5.135,-21.219,1.303,0.244
2,-1.693,-30.778,1.3,0.365
3,3.249,-26.096,1.3,0.389
4,-3.852,-28.103,1.304,0.309
5,4.89,-30.851,1.301,0.299



CHM Segmentation Result
The CHM segmentation result contains a comma-separated .csv table file and a polygon-type .shp vector
file.

The .csv table contains the attributes of tree ID, x, y coordinate position, tree height, crown diameter and
crown area.

The following table shows an example of the segmentation result of CHM:

TreeID, TreeLocationX, TreeLocationY, TreeHeight, CrownDiameter, CrownDiameter(S-N),CrownDiameter(E-W),CrownA
rea
1, 322716.24, 4102494.69, 36.165, 8.982, 9.865, 8.099, 63.36
2, 322751.21, 4102499.9, 41.282, 4.491, 5.132, 3.850, 15.84
3, 322519.35, 4102499.3, 32.008, 4.708, 4.712, 4.704, 16.64
4, 322742.15, 4102497.7, 26.956, 8.347, 7.536, 9.158, 54.72
5, 322892.26, 4102499.5, 45.493, 7.792, 7,967, 7.617, 47.68

The SHP file contains the geometric extents of each tree segmented. The attribute table contains the ID,
x, y coordinate position, tree height, crown diameter and crown area attributes of each tree.



ALS Forest Results of Point Cloud Segmentation &
PCS with Seeds
The ALS Forest results of point cloud segmentation and PCS with seeds are comma-separated .csv table
files containing the attributes of TreeID, x, y coordinate position, tree height, crown diameter, crown area
and crown volume.

The following table shows an example of the results of the ALS individual tree segmentation:

TreeID, TreeLocationX, TreeLocationY, TreeHeight, CrownDiameter, CrownArea, CrownVolume
1, 322511.52, 4102089.78, 60.606, 10.85, 92.04, 3240.171
2, 322511.81, 4102015.14, 53.785, 13.15, 135.09,4358.651 
3, 322537.43, 4102062.51, 46.667, 12.45, 126.76, 3272.472
4, 322529.42, 4102073.12, 45.197, 4.071, 13.019, 342.992 
5, 322525.07, 4102101.07, 43.861, 3.105, 7.57, 107.672

TLS Forest Results of Point Cloud Segmentation &
PCS with Seeds
The TLS Forest results of point cloud segmentation and PCS with seeds are comma-separated .csv table
files containing the attributes of TreeID, x, y coordinate position, tree height, DBH, crown diameter, crown
area and crown volume.

The following table shows an example of the results of the TLS individual tree segmentation:

TreeID, TreeLocationX, TreeLocationY, TreeHeight, DBH
1, 136547.147, 289995.532, 6.498, 0.081
2, 136562.037, 289985.496, 5.652, 0.112
3, 136543.853, 290001.586, 6.115, 0.078
4, 136547.766, 289997.909, 5.868, 0.081
5, 136547.127, 289980.102, 5.217, 0.097

Format of Tree Attribute Information from TLS Point
Cloud Segmentation
Individual tree attribute information from TLS point cloud segmentation is recorded in comma-separated
.csv table files containing the attributes of tree ID, x, y coordinate position, tree height, DBH, crown
diameter, crown area, crown volume, crown base height and straightness.

The following table shows an example of the individual tree attribute information from TLS point cloud
segmentation:

TreeID, TreeLocationX, TreeLocationY, TreeHeight, DBH, CrownDiameter, CrownArea, CrownVolume, CBH, Straightne
ss
1, 136547.147, 289995.532, 6.498, 4.394, 12.964, 132.006, 120.961, 1.221, 7
2, 136562.037, 289985.496, 5.652, 3.008, 6.234, 30.524, 32.742, 1.351, 3
3, 136543.853, 290001.586, 6.115, 4.123, 8.627, 58.447, 78.947, 1.234, 4
4, 136547.766, 289997.909, 5.868, 4.464, 9.574, 71.984, 43.512, 1.471, 6



5, 136547.127, 289980.102, 5.217, 6.070, 11.155, 97.727, 307.870, 1.186, 1



Seven Parameters Calculation File Format
Control points should have at least three pairs and should be saved correspondingly in source and
targeted coordinate files. Supported coordinate formats are spatial Cartesian coordinate system (X, Y, Z)
and geographic coordinate system (B, L, H) (in the format of degree or degree:minute:second). Each point
should be written in one row, and the geographic coordinates should be written in format of latitude,
longitude, and height, separated by comma.

Example (degree:minute:second):

    24:20:52.04982,116:40:30.53733,75.01
    24:20:16.93056,116:40:25.28056,78.57
    24:19:41.28740,116:40:18.60240,83.92



Section Result File Format

Two-Dimensional Section Result File Format

The 2D section file format can be ASCII file (.txt), vector file (.shp), dxf file (.dxf), and hdm format.

csv file is separated by comma. Names can help to distinguish they are cross section or longitudinal
section (CrossSection is the name for points in cross section and LongiSection is the name for points
in longitudinal section by default). The section result file contains three columns, including name,
distance to origin (in longitudinal section, the origin is the starting point. In longitudinal section, the
origin is the intersection of cross section and longitudinal section. To left is negative, to right is
positive), and elevation. Name suggests in which cross section this point is. E.g., CrossSection1(0)
indicates this point is in the cross section named CrossSection1, and this cross section and the
longitudinal section 0 are orthogonal. Elevation records the true hight of this point in the three-
dimensional coordinate system. Following is the part of exported two-dimensional section result file:

    Name,Distance,Height
    CrossSection1(0),39.510,0.025
    CrossSection1(0),39.413,0.085
    ...
    CrossSection2(0),33.884,0.000
    CrossSection2(0),32.447,0.033
    ...
    CrossSection7(1),43.774,0.000
    CrossSection7(1),42.662,0.025

hdm (south). This format file is a comma-separated text file that records the mileage of each section
and the distance perpendicular to the central axis. The format can be described as follows:

One hdm file can contain multiple cross sections.
Each section line starts with BEGIN field, followed by section mileage, section serial number (can
be omitted), and ends before the next BEGIN field. For example, BEGIN, 0.000:1, it means that
the mileage of this section is 100.000, and the serial number is 1.

The section data is then recorded and separated by commas. There are 2 fields in each row. The
first field is the offset and the second field is the elevation. The offset is divided into positive and
negative points. Mileage direction), the left deviation is negative, the right deviation is positive.

- For the cross section without a middle stake point, the offset takes the first point on the left as the bas
e point, and both are positive.

- The example is as follows, including 3 hdm data with mid-stake point section: 

        BEGIN,0.000:1
        -13.265,90.242
        -12.617,90.284
        0.000,90.173
        13.819,89.890
        18.002,89.631
        19.329,88.435



        20.581,88.404
        20.721,89.645
        23.318,89.641
        BEGIN,7.229:2
        -13.918,90.280
        -7.584,90.219
        0.000,90.106
        1.415,89.919
        16.547,89.944
        BEGIN,27.542:3
        -24.713,90.563
        -22.875,90.290
        -7.484,90.045
        0.000,89.819
        7.535,89.624
        21.322,89.731

    Note: The middle pile is not necessarily the center point of the cross section, and the left and right wi
dths of some cross sections are different 

hdm (latitude ground). This file is a comma-separated text file that records the pile number, the height
of the middle pile and the distance to the middle axis of each section. One hdm file can contain
multiple cross sections. Each section line occupies three lines, the first line is the mileage and the
height of the middle pile, the second line is the offset and elevation in the left direction of the line, and
the third line is the offset and the elevation in the right direction of the line. Then record a section line.

  Mileage pile number Middle pile height
  Left Offset Elevation Left Offset Elevation Left Offset Elevation Left Offset Elevation Left Offset El
evation
  Right offset Elevation Right offset Elevation Right offset Elevation Right offset Elevation Right offs
et Elevation 
  0    288.08
      5.93    0.18    21.79    3.45    32.07    4.49    36.32    8.21
      4.22    -0.09    10.03    0.08    12.31    -5.28    26.9    -5.28
  0    456
      4.22    -0.09    10.03    0.08    12.31    -5.28    26.9    -5.28
      5.93    0.18    21.79    3.45    32.07    4.49    36.32    8.21
  ...

When the export format is a vector file, distance and height will be connected as X and Y values
respectively to form a series of polygons. Each polygon corresponds to a section. The section name
is saved in the file as an attribute value.

When the export format is dxf (2004), each section will be automatically arranged into a table with N
rows and three columns according to their respective coordinate values, and the vertical sections will
form a single row. Below each section is a text label (optional), the label content includes left and right
width, middle pile height difference, fill and excavation area, etc. When exporting, you can choose
horizontal and vertical scales, whether to add elevation symbols on the survey section, and the prefix
of the fill and cut mark text. The scale information will be marked in the lower right corner of the
graph. The label text and the cross-section coordinates are in different layers.

Three-Dimensional Section Result File Format



The 3D Section result file format can be ASCII file (.csv), vector file (.shp) and dxf file (.dxf).

ASCII file. A comma-separated text file. There are 4 columns in the file, namely: name, X coordinate,
Y coordinate, and Z coordinate. Points with the same name belong to the same section.

Name,X,Y，Z CrossSection1(0),323128.788,4104260.073,0.025
CrossSection1(0),323130.481,4104261.752,39.413 ...
CrossSection2(0),323245.294,4104234.559,0.073 CrossSection2(0),323245.659,4104234.934,0.103
... CrossSection7(1),323429.209,4104472.832,0.000
CrossSection7(1),323430.965,4104472.877,0.011

Vector file. X, Y, and Z will be sequentially connected as coordinate values to form a series of
polygons. Each polygon corresponds to a section. The section name will be saved in the file as the
attribute value.

dxf format file. X, Y, and Z will be sequentially connected as coordinate values to form a series of
polygons. Each polygon corresponds to a section.

Note: When exporting multiple files, all vertical sections and cross sections will be output as separate files;
when exporting a single file, all sections belonging to the same vertical section will be integrated into one
file, and all vertical sections will remain Will be output as a separate file.



Matrix Format
The matrix file has four rows and four columns, each row of data is separated by a comma.

a00,a01,a02,a03

a10,a11,a12,a13

a20,a21,a22,a23

a30,a31,a32,a33    

See example below:

0.99, 0.085, 0.86, -100

0.99, 0.085, 0.86, 100

0.99, 0.085, 0.86, 100

0, 0, 0, 1



LiBIM File Format
LiBIM is a file format for saving 3D Building Modeling data. It consists of a file header block and a model
data records.

It can import and display the data content through LiDAR360 software, and edit the 3D building model
based on the data. It also can support the functions like converting LiBIM to OBJ, converting LiBIM to
FBX, converting LiBIM to CityJson.



ID List of Json Callable Functions for Batch
Processing
The following table shows the Plugin ID and Action ID of each Json callable function available in
LiDAR360.

Function Name Plugin ID Action ID

Remove_Outliers 0 0

Normalize_by_DEM 0 1

Normalize_by_Ground_Points 0 15

Tile_by_Range 0 2

Tile_by_PointNumber 0 16

Merge 0 3

Extract_Point_Cloud_Boundary 0 4

Subsampling 0 5

PCV_Rendering 0 6

Define_Projection 0 7

Reproject 0 8

Extract_Color_from_Image 0 9

Subdivision 0 10

Transformation 0 11

Clip_by_Circle 0 30

Clip_by_Rectangle 0 31

Clip_by_Polygon 0 32

Convert_to_LiData 0 40

Convert_to_Las 0 41

Convert_to_ASCII 0 42

Convert_to_TIFF 0 43

Convert_to_Shape 0 44

Convert_to_DXF 0 48

Extract_by_Class 0 60

Extract_by_Elevation 0 61

Extract_by_Intensity 0 62

Extract_by_Return 0 63

Classify_Ground_Points 1 0

Extract_Median_Ground_Points 1 5

Classify_by_Attribute 1 10



Classify_Low_Points 1 11

Classify_Below_Surface_Points 1 12

Classify_Isolated_Points 1 13

Classify_Air_Points 1 14

Classify_byHeightAboveGround 1 15

Classify_byMinElevationDifference 1 16

Classify_Buildings 1 20

Classify_Powerlines 1 21

Classify_Model_Key_Points 1 17

Classify_by_Machine_Learning 1 25

Classify_by_Trained_ML_Model 1 26

DEM 2 0

DSM 2 1

Point_Cloud_to_Contour 2 20

Generate_TIN 2 23

Elevation_Metrics 4 0

Intensity_Metrics 4 1

Canopy_Cover 4 2

Leaf_Area_Index 4 3

Gap_Fraction 4 4

Linear_Regression 4 5

Support_Vector_Machine 4 6

Fast_Artificial_Neural_Network 4 7

Point_Cloud_Segmentation 4 10

Generate_Seeds_from_Layer_Stacking 4 14

Clear_Tree_ID 4 11



Shortcut Keys
This section introduces the shortcut keys associated with menus, viewers and point editing in profile
windows.

Menu Shortcut Keys

Viewer Shortcut Keys

Point Editing Shortcut Keys in Profile Window



Menu Shortcut Keys

Shortcut Key Meaning

Ctrl+N New LiDAR360 project(*.LiPrj file)

Ctrl+O Open LiDAR360 project(*.LiPrj file)

Ctrl+Shift+O Open files supported by LiDAR360

Ctrl+S Save LiDAR360 project(*LiPrj file)

Alt+F4 Exit LiDAR360

Ctrl+F3 Add New window

Ctrl+F4 Close Current Window

F11 Full Screen

F3 Orthogonal/ Perspective Projection

F1 Help



Viewer Shortcut Keys

Shortcut
Key Meaning

A Anticlockwise Rotation

G Clockwise Rotation

C Front Rotation

E Back Rotation

T Tips

W Show Model/Triangle/Points

P Adjust lighting (improve the display effect of LiModel, LiTin, OSGB and other model
files)

↑ Up

↓ Down

← Left

→ Right

+ Zoom in

- Zoom out

Left Button Rotation

Right Button Pan

Middle
Wheel Zoom

Space Default

Delete Delete Label/Delete Seed Points



Shortcut Keys for Profile Editing

Shortcut
Key Meaning

0-9 Modify the currently selected points to the new classification indicated by the number
key pressed

L Activate the "Line Above Selection" tool

Shift+L Activate the "Line Below Selection" tool

Shift+R Activate the "Rectangle Selection" too

Shift+P Activate the "Polygon Selection" tool

Shift+C Activate the "Circle Selection" tool

Shift+F Activate the "Circular Brush Selection" tool

Ctrl+Shift+L Activate the "Lasso Selection" tool

Ctrl+Shift+D Activate the "Detect Plane" tool

Shift+Q Switch between different selection tools in order

Shift+E Switch between different classification tools in order

ALt+← Change the selected tile to the left one

ALt+→ Change the selected tile to the right one

ALt+↑ Change the selected tile to the upper one

ALt+↓ Change the selected tile to the lower one

X Activate/deactivate profile tool rotation tool

Ctrl+Shift+S Save

↑ Move the cross-section/profiling area forward

↓ Move the cross-section/profiling area backward

→ Rotate the cross-section/profiling area clockwise

← Rotate the cross-section/profiling area counter-clockwise

R Activate/deactivate profile scene rotation tool



High-Performance Graphics Mode Adjustment
1. Open system settings

1. Choose game settings - > Graphics settings

2. Click to browse - >choose“LiDAR360.exe" - > Options drop-down menu, select "High Performance"





FAQ
This chapter introduces the frequently asked questions and solutions in the use of LiDAR360. It contains
Installation and License Activation FAQ, Platform FAQ, Strip Alignment FAQ, Terrain FAQ, Forestry FAQ
and Power Line FAQ.

Installation and License Activation FAQ

Platform FAQ

Strip Alignment FAQ

Terrain FAQ

Forestry FAQ



Hardware requirements and supported operating
systems

RAM: at least 8G or more.
CPU: Intel® Core™ i5/i7; Dual-core processor.
Display Adapter: NVIDIA graphics card recommended, video memory no less than 2GB.
Operating Systems: Windows 7 (64 bit), Windows 8 (64 bit), Windows 10 (64 bit), Microsoft
Windows 11 (64-bit), or Windows Server 2012 or later.

Why does LiDAR360 pop up the message indicating
the trial license expired after installation?

The LiDAR360 trial license fail might be caused by the following reasons:

System Time Changes: During the trial period, some reasons that may cause system time
change, resulting in expired trials.
Trial Expiration: LiDAR360 has 30-day trial period for each version. If the same version has
been installed for 30 days, the trial has expired.
Other Reasons: Please contact us by email info@greenvalleyintl.com.

How to activate LiDAR360?
Send Activation Information: Run the software as administrator, click Help > Activate License in
the menubar, or double-click the License Manager.exe in the installation directory.

mailto:info@greenvalleyintl.com


Fill in Name (Mandatory);
Fill in Company (Mandatory);
Select the appropriate module(s);
Click Copy;
Send an email with the copied content to info@greenvalleyintl.com.

Activate License：
Copy the license code to your local drive. Pleaser refer to the License Manager for license
activation.

Does LiDAR360 support Windows Server System?
Windows Server is supported.

Please install and activate LiDAR360 using the administrator account. The software must be
installed in the folder to which all users have access.

Can I continue to use LiDAR360 after the trial period
ends?

When the trial period ends, you can still use the LiDAR360 software as a point cloud visualization
tool. The major software functions, such as the viewer, measurement tool and selection tool in the
toolbar will still be available. If you still need a full license or a license for a specific module, please
contact us info@greenvalleyintl.com for more information on purchasing the software.

mailto:info@greenvalleyintl.com
mailto:info@greenvalleyintl.com


How to view the help manual?
Click the Help button in the upper right corner of the software interface.

How can I use the authorization code on another
computer if it cannot be revoked due to the broken of
current computer?

Please sent an email to us through info@greenvalleyintl.com with the corresponding authroization
code. We will revoke the code in the activation server for you so that it can be used in another
computer.



How to check the version information of LiDAR360
software?

You can check the version information of LiDAR360 in Help > About, 2.0 is the software version and
1019 is the build date.

How to change the menu language?
Click Display->Language in the menu bar to switch between English, Chinese, Japanese, French,
Korean, and Spanish.

Why does the software exit abnormally?
Based on our experience, the major two reasons of abnormal exits are the insufficient disk space or
memory space in your computer and the existence of opened instance of screen word capturing
software. If you meet any other scenarios that lead to abnormal exits, please contact us
info@greenvalleyintl.com.

What are the supported data formats in LiDAR360?
LiDAR360 can import the following data formats:

Point Cloud: LiData files (*.LiData custom point cloud format), LAS files (*.las,*.laz), ASCII files (
*.txt, *.asc, *.neu, *.xyz, *.pts, *.csv), PLY files (*.ply), E57 files (*.e57), PCD file (*.pcd).
Raster: Image File(*.tif,*.jpg).
Vector: Vector File(*.shp).
Table: Table File(*.csv)
Model: Proprietary Model File(*.LiModel), Proprietary TIN File*.LiTin), OSG Model File(*.osgb,
*.ive, *.desc, *.obj).

mailto:info@greenvalleyintl.com


LiDAR360 can export the following data formats:

Point Cloud: LiData files (*.LiData custom point cloud format), LAS files (*.las,*.laz), ASCII files (
*.txt, *.asc, *.neu, *.xyz, *.pts, *.csv), PLY files (*.ply), E57 files (*.e57), PCD file (*.pcd).
Raster: Image File(*.tif,*.jpg).
Vector: Vector File(*.shp, *.dxf)
Table: Table File(*.csv)
Model: Proprietary Model File(*.LiModel), Proprietary TIN File(*.LiTin).

How to fix drag and drop in windows 8 and windows
10?

Go to RUN, or search "regedit.exe" then run as administrator. On Registry Editor go to:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System, double
click "EnableLUA", and change the value from 1 to 0. Restart windows, and the problem will be
solved. Reference.

Why is the EDL visual effect not obvious if multiple
data are added in the same window?

It's recommended to show distant multiple data in separate windows with EDL effect. Or remove
unwanted data in the current window.

What is the unit of point cloud data in LiDAR360?
LiDAR360 V5.2 and later supports user-defined unit settings. You can set custom units through "Display
Settings" -> "Measurement Settings" in the upper right corner of the window. Currently supported units are
meters, feet, decimeters, centimeters, millimeters, and inches.

How to subsample the point cloud uniformly?
LiDAR360 provides subsampling methods by Minimum Points Spacing, Sampling Rate, or Octree.
The subsampling by Octree is an uniform method.

Click Data Management > Point Cloud Tools > Subsampling, then select the sampling type
Octree.

How to Pick Rotation Center while using the Pick
Multi-Point tool?

Hold the Ctrl key and pick rotation center by left-click.

https://answers.microsoft.com/en-us/windows/forum/windows_10-files/how-to-fix-drag-and-drop-in-windows-10/0ea16377-dfcf-4a28-9e38-c35f4113202b?page=13&auth=1


Why are point cloud transformation results incorrect
in LiDAR360?

This is because different units are used in each program. In LiDAR360 degree units are used. In
order to carry out a correct transformation, the units must be degrees.

Can lidar data or software be built into a GIS
Platform?

Yes. Our software can generate shapefiles (.shp) and .tiff files which can be integrated into a GIS
system. In our software you can also create new polygons, lines as well as generate contour lines,
DEM and other digital models.

What memory(RAM) requirement is there to process
large datasets in LiDAR360?

We recommend at least 16GB of RAM for processing large datasets.

Why there are very large error after rectifying? How to
solve it?

You can view the residuals for all the homologous points pairs and remove the homologous points
pairs with large residuals. After that, redo the rectifying process.

Why does the dialog box text appear incomplete or
garbled when viewing single point cloud information?

Update the discrete graphics card driver to the latest, and then run the software in high-performance
graphics mode. To adjust the high-performance display mode under the Win10 operating system,
please refer to Set high-performance display mode.

Why is DJI L1 data a straight line when opened
through LiDAR360 (data display is incorrect)?

This situation is because LiDAR360 supports the display of projected coordinates, and it is necessary
to convert geographic coordinates to projected coordinates
Data management -> point cloud format conversion -> Las conversion to LiData to select the



projection coordinates, and the converted data can be displayed correctly by re-importing it into the
software.

The startup time of LiDAR360 software is too long,
can I troubleshoot computer performance problems?

Analysis of the reason for this situation is that the configured group authorization cannot be
connected, and the software startup caused by the time delay is too slow. The solution: (1) Find the
bit_config.xml file in the folder and delete it; (2) Where the software configures the authorized IP
address of the group, find the corresponding file and delete it.



What are the supported POS formats by LiDAR360?
ASCII format (*.pos) and binary format (*.out) are currently supported.

*.pos file contains GPS time, longitude and latitude, flight height, roll, pitch and heading. An
example is shown as follows:

*.out file is a proprietary format of the company Applanix. Please refer to OUT File.

Is the strip alignment manual or automatic in
LiDAR360?

There are both manual and automatic methods in LiDAR360. And the results will be displayed in real-
time.

What is the time reference in POS file supported by
LiDAR360? Is the GPS time necessary?

The only requirement is that the time stamps in POS file and point cloud data files have the same
reference (e.g., GPS Time or UTC Time). If they are not the same, you have to convert one to the
other. Generally, time in point cloud counts in SOW(seconds of a week) or SOD(seconds of a day).



Sometimes, the point clouds after strip alignment are
partially aligned, but partially not, and in some area
they are even distorted. Why?

This may occur if the POS file is of low accuracy. The principle of the Strip Alignment module is to
correct boresight errors between laser scanner system and GPS/INS system. The precondition is
that the POS accuracy for the acquired data meets the standard specifications. Otherwise the
resulting point clouds are partially distorted. Boresight correction alone doesn't guarantee the aligned
results with high accuracy.

Why there is no output when I try to clip the point
cloud data with the POS file?

Please check the GPS starting and ending time of both the POS file and the point cloud data. And
see if there are any overlap between the GPS time of two files.

The data collected by the DJI L1 device, the track time
reference is inconsistent with the point cloud GPS
time reference, such as the track time in weeks and
seconds, and the point cloud time information when
the GPS is adjusted? (The range of GPS weeks and
seconds is 0~604800, which can be used to
distinguish GPS weeks and seconds and adjust GPS
time)?

The GPS time conversion process is as follows: Preprocessing -> Air Belt Adjustment, input the
trajectory file, the trajectory file of the DJI L1 device is in .out format, after inputting the trajectory file,
the GPS time conversion and coordinate system selection dialog box will pop up, check the box.
Select "GPS time conversion", select the source GPS time, and "Convert to", select the data
collection date for the acquisition date, and convert the trajectory time to the point cloud time.



The actually scanned LiDAR point density is much
larger than the DEM point density requirement of the
production. Can data be subsampled?

If the actually scanned LiDAR point density is much greater than the production demand, you can use
the Subsampling tool to subsample the point clouds. This function provides three types of
subsampling methods: "Minimum Points Spacing", "Sampling Rate" and "Octree".

Some of the contour lines generated by the function
"Point Cloud to Contour" are broken. Why?

The broken contour lines may be caused by the lack of ground points. The contours can be
contiguous by increasing the parameter "Triangle's Maximum Length" on the interface. For example,
set 30 meters up to 50 meters or an even larger value.

During DEM processing, the result of this process has
.tiff format. Can I convert this into 3D data?

You can convert your .tiff DEM into our custom 3D model format (LiModel). Go to Data Management
> Conversion > Convert TIFF to
LiModel(../ToolReference/DataManagement/Conversion/ConvertImagetoLiModel.md).



How to check and improve the quality of DEM
generated by LiDAR360?

- You can view the DEM effect through Terrain->Section Editing->DEM Preview. For unqualified DEMs, you can op
timize the DEM through terrain patching and inserting breaklines, regenerate the DEM, and check the accuracy 
of the generated DEM through Terrain->DEM Accuracy Check. Check and output report.

How do you generate a smoother contour for a DEM?
Perform a smoothing operation using smooth height tool. Save the data. Then Convert the LiModel
back to .tiff format, Data Management > Conversion > Convert LiModel to
TIFF(../ToolReference/DataManagement/Conversion/ConvertLiModeltoImage.md). From here
perform a contour operation Terrain > Raster to
Contour(../ToolReference/Terrain/RastertoContour.md).

How to choose the interpolation method for
generating DSM?

It is recommended to choose IDW interpolation for forestry area, and TIN interpolation (Spike Free
TIN) for urban area.

    @inproceedings{
        author={Zhao X Q, Guo Q H, Su Y J and Xue B L},
        title={Improved progressive TIN densification filtering algorithm for airborne LiDAR data in forested
 areas},
        booktitle={ISPRS Journal of Photogrammetry and Remote Sensing,117:79-91},
        year={2016}
    }

Can LiDAR360 achieve specific area classification, such as lake,
river area?

You can go through Classification -> Section Editing -> Start Editing -> Generate TIN -> Add
Breaklines -> Leveling Areas (Lakes)/Double Breaklines (Rivers) -> Set Initial Category, Target
Category, such as Water Body -> Add, complete lake area classification

Can LiDAR360 achieve uniform assignment of elevations for point
clouds within a given vector range?

You can select the area to be unified elevation through Classification->Section Editing->Start Editing-
>Generate TIN->Add Breakline->Closed Area Breakline->Polygon, you can specify the elevation, or
you can pick the triangle mesh patch with the mouse point uniform elevation



Can LiDAR360 generate CHM in batches?
LiDAR360 can generate CHM in batches (ALS Forest > Batch Process > Canopy Height
Model(CHM) Segmentation).

How to evaluate the accuracy of individual tree
segmentation results?

For evaluation of individual tree segmentation accuracy, please refer to Li et al's article on (Li et al.,
2012). By comparing with field measurement, the number of correctly segmented trees, the number of
falsely segmented trees, and the number of missed trees are calculated according to the following
formulae: recall (r), precision (p), and F-score (F). Recall indicates the tree detection rate, precision
indicates the correctness of the detected trees, and F-score is the overall accuracy taking both
commission and omission errors into consideration. The values of r, p and F vary from 0 to 1.



（a）Correctly detected tree (True Positive, TP)（b）undetected tree (False Negative, FN) （c）
falsely detected tree(False Positive, FP)

What parameters affect the CHM segmentation
accuracy and how should these parameters be set?

The accuracy of CHM segmentation are affected by CHM resolution and Gaussian smoothing factor.
CHM is the difference between DSM and DEM. The CHM resolution is determined by the
resolution of DSM and DEM. Generally speaking, this value should not exceed one-third of the
crown width, and the range can be set to 0.3-1m. Usually, the resolution of 0.5-0.6m can get a
higher segmentation accuracy.
Sigma is the Gaussian smoothing factor (default value is "1"). The greater the value is, the
smoother the results are. The degree of smoothness can affect the number of trees being
segmented. In the case of under-segmentation, it is recommended to reduce this value (e.g. 0.5);
and in the case of over-segmentation, it is recommended to increase the value (e.g. 1.5).

Moreover, beside the algorithm parameters, the CHM segmentation result can also be largely
influenced by tree density and tree species. If the algorithm does not work well in s certain study area,
users can try to use other segmentation algorithms to get the best segmentation result.

How to remove some results with small crown area
after running CHM segmentation?

After running CHM segmentation, a shp file containing the tree boundary is obtained. The attribute
table includes the ID, location, height, crown diameter and crown area of each tree. The data can be
imported into a third-party software (e.g. ArcGIS), and you can remove the segmentation results with
a small crown area according to the crown area attribute.



How to make point cloud data below 2m be
participated in segmentation?

The parameter "Height Above Ground" on the Point Cloud Segmentation and Point Cloud
Segmentation from Seed Points interfaces indicate that points below the value are not considered
as part of the tree and will be ignored during the segmentation process. The default value is 2m. If
you need to make the point cloud below 2m participate in the segmentation, the value can be reduced
appropriately.

Which kind of segmentation method for coniferous
and broad-leaved mixed forest data can be used to
obtain higher accuracy?

For coniferous and broad-leaved mixed forest data, CHM Segmentation is recommended.

The growth of trees in the area is not the same, how to
achieve higher segmentation accuracy?

It is recommended to clip the point cloud according to the growth as different data by Select Tools or
Clip Tools and handle them separately.



If the tree canopy is covered in weeds, can tree
identification still be performed in LiDAR360?

Yes, it can.

How to export individual tree segmentation results to
third-party software for analysis?

Click ALS Forest > Extract by Tree ID, the segmented point cloud can be exported to CSV file for
subsequent analysis using other software. LiDAR360 supports exporting each tree as a separate
CSV file or exporting all points as one file. The exported CSV file is shown in the figure below, which
contains X, Y, Z coordinates and tree ID information.

How many sample data files are required for
regression analysis?

The number of sample data used for regression analysis is not clearly defined. In general, under the
premise of ensuring the accuracy of plot location and measurement, the greater the number of
sample data is, the higher the accuracy of regression analysis can achieve. Sample sites should be
randomly selected and representative to cover different forest types within the study area. A sample
size less than 30 is referred as a small sample, and a sample size of 30 or greater is referred as a



large sample. To ensure regression analysis accuracy, the recommended sample size should be
greater than or equal to 30 (you should also consider the size and complexity of the study area).

How to choose the independent variables involved in
the regression analysis?

The elevation percentiles obtained from LiDAR data are generally the independent variables for
regression analysis. However, specific elevation percentiles are not all the same for different study
areas.

Can trained regression models be used for other
data?

Yes. Click ALS Forest > Regression Analysis > Run Existing Regression Model. Available
regression models (Linear Regression, Support Vector Machine, Fast Artificial Neural Network
and Random Forest Regression) can be used to estimate forest metrics.

Can I export the independent variables (e.g. elevation
percentiles) generated by LiDAR360 into third-party
software (e.g. SPSS, R) for regression analysis?

Yes. Independent variables provided by LiDAR360 including Elevation Percentile, Elevation
Density, Intensity Percentile, Leaf Area Index, Canopy Cover and Gap Fraction. Among them,
Elevation Percentile, Elevation Density and Intensity Percentile are in CSV formats, and they can be
imported into third-party software such as SPSS directly. Leaf Area Index, Canopy Cover, and Gap
Fraction are in TIF formats that can be converted to text format by ArcGIS and imported into third-
party software.

    @inproceedings{
        author={ Li W K, Guo Q H, Jakubowski M K and Kelly M},



        title={A new method for segmentation individual trees from the LiDAR point cloud},
        booktitle={ Photogrammetric Engineering and Remote Sensing,78(1):75-84},
        year={2012}
    }

What if the TLS Stem Extraction runs in a flash or
there is no change in the classification result?
-The function of TLS Stem Extraction is based on deep learning and needs to use GPU. Make sure the
latest driver has been installed on your computer.

-For Windows7 System, the driver need to be installed includes：

451.67-desktop-win8-win7-64-international-whql.exe

GeForce_Experience_v3.20.3.63.exe

Please select the appropriate driver according to your own operating system for your Nvidia GPU and
installation.

If you still cannot run this function after installing the latest driver, please check whether the required
system patches are installed. For example, Windows 7 needs to install the following patches:

Windows6.1-KB3068708-x64.msu

Windows6.1-KB3080148-x64.msu

Please make sure all the required patches are correctly installed on your computer.

After single tree classification, which column in the
result table is the height of the tree? What if not?

After single trees are divided, there is no tree elevation value in the result table, only X and Y
coordinate values. To get the elevation attribute of each tree in the table, you can: first use the DEM
tool to generate the DEM of the plot, and then use the "Foundation Forestry -> Tree Attribute ->
Extended Single Tree Attribute" tool to make the DEM file according to the single tree attribute. The
coordinate position of the tree divided by the wood, and the elevation value can be assigned to the
CSV table.

Why is the tree flat when the scanned data is viewed
in the cross-section? Is there any way to improve it
(the scan is scanned according to the normal
trajectory), in this case, it is easy to have problems
fitting the DBH through the software?

Considering the fact that the tree trunk is flat in the tree scan results, it may be because the sapling

https://www.nvidia.cn/Download/index.aspx?lang=cn


plants are relatively small. For large-scale woodland data, it is recommended that the scanning
trajectory be more curved; during data calculation, in LiBackPack-BP In the software, first uncheck
the smoothing option, and the data will not be smoothed.

There is a big difference between the results of single-
tree segmentation and the actual number of single-
trees. It is ruled out that the DBH fitting is inaccurate
and non-parameter setting problems?

Exclude the DBH fitting accuracy and parameter setting problems, then the cause of this problem
may be the inconsistency between the original data unit and the LiDAR360 parameter setting unit. For
example, the original data unit is feet, while the LiDAR360 data processing unit is unified as meters.
Unit conversion is required before data processing.
Conversion method: If the original data is in the las format, directly convert "las to LiData", and select
"feet" as the source unit; if the original data format is LiData, first "convert to las" and then perform the
above operations.



LiDAR360 Version Release Notes

V7.0 - 9/30/2023
Preprocessing：

Add mirror angle correction in trajectory adjustment for livox laser
Add hybrid adjustment, improve point cloud accuracy
Optimize data registration process, supporting registration of point clouds and models
Add automatic trimming for boresight
Add Z-value recording in projection coordinates for trajectory

Data Management：
Add point cloud RGB brightness and contrast control tool
Add smoothing line tool, provide various smooth methods
Add point clouds to PLY tool
Add building model export to DAE
Add smoothing meshes tool
Optimize reprojection Tool, supporting to copy projection coordinates and modify, enabling
favorites management, and allowing selection of projections from the layer directory tree
Optimize boundary extraction, supporting the extraction of inner rings and island-like boundary
Optimize extract color from Image tool, supporting coloring based on image projection
Optimize point cloud to image tool, enabling the generation of RGB images from multiple
attributes
Optimize smoothing tool, supporting joint smoothing of multiple files

Classification：
Add deep learning urban/rural scene classification.
Support multiple segment classification for classify by height above ground

Terrain：
Add drainage analysis tool
Add construction progress analysis tool
Add contour consistency check tool
Add contour semi-automatic process tools

Add break contour tools
Add join contour tools
Add filter minimum area tool
Add check contour consistency
Add Generate elevation annotation point tool

Add generate elevation annotation points on contour lines
Add generate DOM from aerial projects tool
Optimize TIN to DEM tool to solve the problem of external interpolation outside boundary
Optimize dimming of mountain shadows
Add automatic elevation calculate for vector features in LiTIN editor
Section analysis

Support tunnel section parameterized design



Support generating section based on slope
Support distance display for section comparison
Support exporting the central line trajectory of tunnel

Forestry：
Add biomass estimation and biomass model management
Add deep learning-based single individual segmentation to improve tree detection
Add forestry attribute custom format to simplify attribute usage
CHM segmentation adds east-west and north-south crown width parameter extraction
Optimize forest metrics by grid, supporting class selsction
Optimize TLS forest metrics, support exporting csv result
Optimize TLS seed point editor, support rectangle selection

Mine：
Add inter-ramp compliance tool
Optimize toes and crests extraction, support auto-separating of toes and crests
Optimizing poisson reconstruction with grid density preview
Optimize mesh surface reconstruction to improve efficiency and effectiveness
Mesh model editor

Support both front and back mesh display, and overlay display of points, lines, and surfaces
Support mesh selection tools such as lasso, polygon, and rectangle
Support mesh back faces selection and invert selection
Support mesh visible and through selection
Support selection expand and shrink, component selection, and flood selection
Support hide selection, select all, and deselect all
Support filling all holes and filling single holes
Support bridging holes
Support mesh smooth
Support mesh decimate

Building：
Add extracting building footprint from image
Add building model registration with image
Add projecting textures from photos
Add manual image texture mapping, material texture mapping, and material library management
Add building attribute management, including adding, deleting, and editing attributes
Add automatic calculation of building attributes, including volume, height, and house shape
Improve building model editing

Add surface division
Add surface refitting
Add curved surface editing
Building split patch supports split by polyline
Add file management after deletion

UAV Processing：
Supports one-click processing of trajectory adjustment, pos process, cut point cloud by trajectory,
cut overlap, smooth points, subsampling, remove outliers, classify ground points, classify by
deeep learning

Vector Editor：
Add vector entity attribute-linked editing, supporting batch elevation modification



Add merge polylines
Support gpkg data format
Add vector text labeling
Add boolean operations for vector entity
Add vector intersection
Add copy parallel
Add extraction of building outlines based on models
Optimize layer management, seamlessly aggregating CAD and GIS data
Optimize vector display, supporting vector node display settings
Optimize reshaping and draw by intersection tool

Other：
Add vector display line width setting
The directory tree adds trajectory and aerial project management
Support selection of attribute fields to display, data saving as new, attribute editing, and attribute
filtering
The selection and clipping tool supports saving remaining data
Volume measurement reporting support and saving the current scene graph
The rolling screen tool supports multiple data types such as point clouds, models, vectors, and
tables
Mesh editing, LiBIM, LiModel, LiTIN, and other editing supports shortcut key settings
Support gradual background color setting for rendering scene

v6.0 - 8/10/2022
New Modules and Features:

Added voxel down-sampling when loading data is converted to LiData
Added strip adjustment function for multiple sorties
Added conversion based elevation projector plane coordinate
Added support for KML vector format
Vector Drawing

Added arc drawing
Added the drawing of one point circle, two point circle and three point circle

Added building modeling module
Added automatic building of LOD2 level model based on base map
Added semi-automatic building of LOD2 level model
Added building model editing tool

Added vertex moving tool
Added vertex deleting tool
Added vertex adding tool
Added line removal tool
Added line alignment tool

Added building model plane editing tool
Added sheet merge tool
Added sheet removal tool
Added the face intersection line tool



Added the tool for add faces
Added building ground elevation adjustment
Support the output of building models in obj, fbx, cityjson, and other formats
Support LiBuilding data consolidation

Forestry module
Added individual tree segmentation and matching tools
Added tree 3D modeling
Added export of individual tree report
Added tree trunk extraction tool based on TLS data
Added tool for extracting crown base height of individual tree
Added TLS porosity calculation
Added TLS cover degree calculation
Added TLS individual tree editor

Added semi-automatic support removal tool
Added individual tree attribute filter check

Added airborne forestry individual tree point cloud editing tool
Added semi-automatic individual tree point cloud segmentation
Added attribute-based filter check
Added the operations for creating, deleting, and merging individual tree point cloud

Terrain module
Added DOM production tool based on DEM\DSM

Added Custom Deep Learning Classification Tools
Support customized process for training and reasoning tasks
Support model management
Support algorithm update

Enhancements:
Shortcut keys are supported for clipping tool selection
Point cloud fitting plane can be used as the measurement datum for volume measurement
Split window rendering mode is supported for point cloud rendering
The efficiency of point cloud conversion to LiData data is improved by 30%
The efficiency of common tools such as smoothing, denoising and resampling are optimized, and
the parallel mode is improved by 50%-120%
Model data architectural semantic rendering is supported
Project Management Window

Import of .ligeo and .mmprj project data is supported
Clipping tools

“Tile by polygon” supports buffer settings
Single point drawing of rectangular areas is supported for rectangular clipping

Control of object move tool is supported for manual translation and rotation
Classification

The classification of tower and power line is expanded through deep learning of relevant
classification

Terrain
Whether the section is controlled by interpolation is supported for road section analysis tool



v5.4 - 07/25/2022
New Modules and Features:

Added the function of extracting by additional attributes
Added the function of segment by attribute
Volume Measurement

Added the triangulation method for volume measurement for more accurate calculation
Added volume measurement of solid model

Projection and coordinate conversion
Added geoid option
Support independent selection of horizontal projection and vertical projection
Added four parameters and geoid joint conversion
Added geoid surface model fitting
Added model data conversion options to the manual rotation and translation and the manual
registration tools

Added the function of classification by additional attributes
Added model smoothing function
Vector Editing

Added point break, line break, merge, delete functions
Added Bspline and BezierSpline drawing
Added Bspline and BezierSpline shaping
Added 2D and 3D vector drawing elevation mode settings
Added polyline smoothing tool
Added highest and lowest points snapping

Added the function of manual tree species marker
Added individual tree attribute settings and the support of selection of calculation methods such
as tree position and crown width
Vector editing

Support extracting toes and crests
Support volume change analysis

Enhancements:
Added gallery mode to the common editing tools in the interface, which supports floating display
of tools
The classification class supports 0-255 class selection
Support 2D and 3D data linkage
Custom tab settings window supports tool searching
Data rendering

Added raster, vector, model, and table data to display by window
Display by window supports point cloud, raster, vector, model, table data filtering by value
range
Added raster data hillshade feature rendering
Support data to save the last right-click attribute rendering settings

Multi-point selection supports coordinate positioning
Strip alignment supports the use of selected categories for boresight error calculation
Trajectory adjustment supports the import of multiple trajectories
Control point report supports import label display and export report format setting



Point cloud subdivision functions support preview
Boundary extraction supports extraction to the same vector file
Classification editing

Added the semi-automatic classification of buildings and noise points
Support 3D editing mode
Support joint image editing
Support block editing by range, scale and external import range
Improved the function of ground point simulation

TLS seed point editing
Support profile and main window position displaying
Added shortcut keys for the main window height filter function
Profile view window supports range line display
Optimized DBH batch extraction function to improve tree recognition accuracy

Clear TreeID tool supports height filtering
Optimized the display of geostatistical rose diagram v5.3 - 03/20/2022

New Modules and Features:
Added building and vegetation categories based on deep learning
Added DEM Edge Alignment
Added DEM accuracy assessment
Added CSF filter

Enhancements:
Section Viewing and Editing

Added vertical stretch display
Section classification editing

Added ground point simulation
Added DEM preview
Support frame selection of multiple blocks to construct and edit block data

Color rendering
Added real-time contour rendering
Improved the convenience of rendering point cloud attributes

Ground point classification supports terrain scene selection
Support coordinate and projection transformation during point cloud data import
Manual translation and rotation tools support setting the rotation center
Improved the efficiency of generating contour lines by 2-10 times
Optimized the efficiency of functions such as denoising, smoothing, ground point classification,
noise filtering, etc. Support multi-threading and memory resource settings in the options
Optimized the image rendering operation experience and improve the fluency
Solved the problem of shortcut keys customization conflict, support unified control

v5.2 - 11/19/2021
New Modules and Features:

Breakline



Point cloud profile editor supports breakline drawing
Improved LiTIN editor breakline drawing
Support adding breaklines to DEM
Support adding breaklines to contour lines

Added extract water area tool
Support point clouds in PCD format

Enhancements:
Section

Support create section by adding model data
Support adding section at any position
Optimized create section by point cloud and fix the missing section caused by the missing
point cloud
Optimized export of section to meet production requirements

Optimized Projection and Coordinate Conversion, add support for storage of user-defined
conversion models, parameters can be created and applied directly
The measurement tool supports unit setting
Optimized the efficiency of the control point report function with an average increase of 40%
Generated CHM function to support big data processing
Strip alignment supports SBET format trajectory data
Contour function supports class selection
Roaming tool supports pause during roaming
Added trial application on start page
Point cloud data GPS time conversion supports selecting date for conversion
Mutual conversion between shp and kml supports geographic coordinate system
Subdivision tool supports buffer setting
Support report custom settings
Optimized the bit rate of the screen recording tool to provide a default value based on the system
resolution

v5.1 - 07/29/2021
New Modules and Features:

Added mine module
Extract tunnel points
Compute normal vectors
Triangulation modeling
Poisson modeling

Vector editing
Support 3D vector drawing
Added tools for shaping elements
Added split polygon tool
Added semi-automatic extraction of building outlines
Added semi-automatic extraction of road shoulders
Added intersection drawing line
Added section auxiliary drawing



Added associated window to assist drawing
Added selection file editing
Added temporary draft editing
Support 3D capture
Support 3D selection
Support shortcut keys setting
Support rollback and redo

Added the hover mode, support the use of hover mode under measurement point selection
Added cutting by straight line
Added dividing by polygon

Enhancements:
Profile editing and classifying

"Select tool" supports category settings to be individually set and recorded
"Select cutting" supports cutting of the triangulation model
Individual tree point cloud editing supports directory tree control display and hidden
"Cut by polygon" supports inner and outer cutting options
Manual translation and rotation support XIYZ component progress control
Directory tree

Support right-click to open the folder
Vector data supports dxf format

v5.0 - 01/29/2021
New Modules and Features:

Added geology module
Added flow direction function
Added flow direction function cumulant
Added fill function
Added slope/aspect query function

Added data IO API for software development
Support creating LiData point cloud file
Support reading LiData point cloud file
Support modifying LiData point cloud file

Added powerline module
Added deep learning of powerline classification
Added danger point detection function
Added customization of the danger point detection
Support danger point visualization

Added point cloud smoothing function
Added trunk extraction function
Added elevation annotation points generation based on contour lines function

Added new format transform tools
shp to kml
kml to shp

Support background grid display in viewers



Support extracting point cloud by TreeID
Support clear individual tree record and segmentation by TreeID
Added calculation of forest metrics

Enhancements:
UI

Brand new Ribbon user interface style
Support free dragging of child windows
Support customization of UI pages
Support automatic hiding of docked window
Support one-click industry application processing

Strip alignment
Added strip adjustment function
Support clipping trajectory by the quality and selecting with a brush on a trajectory

Directory tree
More comprehensive point cloud information display
Support selecting the version of the LAS file when right-clicking to export
Support right-clicking to add additional attributes of point cloud
Support right-clicking to rename files
Support setting the point size of table data

Expanded the projection library to support more projections and geoid surface
Optimized PCV efficiency to support more point cloud calculations for PCV
Optimized ALS automatic individual tree segmentation
Improved point cloud attribute expansion of an individual tree to support slope and altitude
information
Optimized individual tree seed point editing

Improved method of profile selecting
Improved method of adding and deleting seed points
Added viewpoint position and direction for easy positioning of trees
Real-time update of attribute table corresponding to seed point modification
Support undo and redo
Support setting profile viewpoint distance

Optimized individual tree point cloud editing
Improved method of profile selecting
Support creating an individual tree by specifying a chosen tree
Support setting profile viewpoint distance
Automatic saving of configuration

Optimized profile point cloud editing
Improved the efficiency of block editing by more than 50%
Support mouse position tracking in the profile window
Support data exporting

Added section comparing analysis function in section analysis
Upgraded LiModel format to solve the problem of coordinate accuracy loss
Reduced the GPU usage rate of point cloud display by 20%
Support multiple calls to the same function in batch processing
Fixed the bug when using cross selection and clipping tool simultaneously
Improved the efficiency of point cloud conversion to DXF file



v4.1 - 06/08/2020
New Features:

Added three-point angle measurement
Added registration of UAV and backpack forestry point cloud data
Added individual tree attribute information expansion
Added detection of forest structure changes
Added DBH measurement
Help menu

Added software usage problems and demand feedback channel
Added FAQ, quick start, official website link, etc.

Enhancements:

Optimized the efficiency of loading multiple files
Improved color rendering of point cloud attributes
Additional attribute management

Support deleting
Support component combination rendering

Improved profile editing and classifying
Support grid scale display in profile window
Support directory tree to manage point cloud tiles in memory

Support import boundary of measurement area with SHP file in volume measurement
Improved the efficiency of filtering function and the density of ground points
Support directory tree to manage point cloud tiles in memory in individual tree point cloud editing
function
Support combined calculation in forestry metrics
Support extract point cloud by tree ID, support export the extracted point cloud to LAS and LiData
format
Support attribute filtering in ALS seed point editing
Improved LiTIN editing, support 3D view editing, and support the setting of starting height of
broken line
Added tunnel cross-section in cross-section analysis
Window layout supports multiple layout modes
Newly designed UI icons

v4.0 - 12/30/2019
New Features:

Added denormalization tool
Added classifying close points tool
Added manual rotation and translation tool
Added convert ASCII to BLH tool
Added individual tree editor tool. Support to create, merge, and delete tree
Added statistics individual tree attributes tool
Added TLS leaf area index tool



Added ALS forestry metrics calculation in give area tools
Added deviation analysis tool for two data of the same area collected in different times
Added change detection tool
Added GPS time transformation tool which supports transforming GPS time between GPS
coordinated time and GPS week and second

Enhancements:

Support online update checking and installing
Upgraded the version of LiData to V2.0 which supports all the features of Las1 .4 (except the
waveform information) and the additional attribute of the point cloud file
Support the color rendering for all the attributes of point cloud data
Support the rotation of 2D view
Support fast mode and precise mode in volume calculation and providing the information of the
measuring area
Support zooming to the layer by double-clicking the file in the directory tree
Support recovering the data association in the same path for the project file path
Support EDL effect in render to file and save to video tools
Support generating automatic alignment report and clearing the data alignment information
Improved the profile editor which supports customizing shortcut keys and solves the problem of
profile buffer settings
Improved the EDL effects in orthogonal projection
Improved the cross selection tool which supports data clipping when being used with selection
tool, or 2D drawing when being used with Vector Editing.
Improved data interaction experience:

Improved browsing fluency
Support automatically picking the rotation center
Improved point picking experience
Support measuring components in the measurement tools
Support measuring points number in the density measurement tool

Support recording the original Z value in normalization tool
Improved the data formats supported:

Support E57 point cloud format
Support additional attributes for LAS, PLY, and ASCII format point cloud files
Support choosing the version of las file when exporting point cloud in las format (las 1.2, las
1.3, and las 1.4)
Support converting version of LiData (V 1.9)
Support converting point cloud in Geographic Coordinate System to projected LiData

Improved the calculation method of individual tree crown volume
Improved the efficiency of the calculation of forestry metrics

v3.2 - 06/06/2019
New Features:

Added brightness settings tool
Added ICP registration function



Support exporting TIN in DXF format
Added raster statistics tool

Enhancements:

Optimized EDL display effect in profile editing mode
Optimized the ground point filter
Optimized the efficiency and effect of "Classify Buildings" tool
Support rectangular/circular interactive area selection tool in clipping function
Changed band calculator to raster calculator which supports custom formula
Shortcut keys and right-clicking menu in ALS individual tree segmentation editing tool
Support position uncertainty optimization mode in regression analysis
Support corresponding multiple point cloud files to one trajectory in "cut point cloud based on
trajectory" tool
Profile editing and classifying:

Added the lasso selection tool
Added the plane detection tool
Support clearing the triangular network already been built
Support setting the size of brush selection tool
Support setting the step length of the profile translation
Optimized the efficiency of triangular network generating

TLS individual tree segmentation editing:
Support ignoring the Z-values of the input seed file
Support right-clicking menu and shortcut keys
Support hot keys in single tree attributes measuring
Support display of LiBackpack trajectory file

Manual registration:
Support inputting/outputting coordinate transformation matrix
Support the preview of transformation

Raster and table data:
Support color settings
Support highlighting objects when they are selected
Support centralizing the objects when they are double-clicked

Bug Fixed:

Fixed the bug that the order of the vector and table data's attribute table is wrong
Fixed the bug that only the displayed data will be used in "batch extraction DBH" tool
Fixed the bug that profile selection will disappear in the main window if users edit point cloud in
profile window

v3.1 - 12/31/2018
New Features:

Profile editing and classifying:

Support block editing and classifying
Support multiple windows selecting and classifying



Add the brush selecting tool
Block editing mode supports to undo/redo
Added the automatic timing/automatic saving function
Added multiple selecting area filter classification/classification setting tools
Support shortcut keys switch function
Block editing mode supports RAM usage warning

Added convex hull and concave hull mode for boundary extraction

Added check for updates function
Enhancements:

Improved the efficiency of LiData generating
Support to recalculate the histogram of point cloud intensity and elevation
Moved the rectify to reprojection and conversion module
Multiple point selecting tool supports to customize the extended attributes
Support projected coordinate systems in JGD2011 coordinate system
Support POS files in more formats. Now support POS file with projected coordinates
Support converting length units for las and LiData files

v3.0.1 - 12/10/2018
New Features:

TLS individual tree segmentation editing:
Added circle selection tool
Added profile translation tool
Added DBH inspector tool

Enhancements:

Optimized the color rendering for individual tree segmentation.
Optimized the segmentation of the vector boundary of crown in CHM individual tree
segmentation.
Support the .shp file in section tool.

Bug Fixed:

Fixed the bugs already known

v3.0 - 10/16/2018
New Features:

Added saving users’ parameters settings as default, and the prompt of the information about
each parameter when putting mouse on it
Support the spike-free TIN generation algorithm
Added the random forest regression model
Added the regression predict analyze
Added the Projection and Coordinate Conversion Toolset:

Seven parameters solution



Four parameters solution
Vertical datum transformation

Added noise classification function
Support conversion of raster data to LiData

Enhancements:

Improved the ground point filtering algorithm
Improved the accuracy and efficiency of the TLS individual tree segmentation tool
Upgraded the LiTIN format to support saving the corresponding LiDAR point classes in LiTIN
data and display LiTIN data by classes
Improved the editing and flattening TIN data in LiTIN format
"Tile by range" supports buffer setting and vector exporting
Support subdivisions of Graticules
Support generating multiple files when performing polygon clipping
Support selecting RGB range when convert data to las format

v2.2 - 06/20/2018
New Features:

Multi-threaded batch processing;
Support invoking of command line;
Measurement of individual tree attributes (total height, CBH, stem straightness. etc.) from TLS
data.

Enhancements:

Improved regression analysis which allows for the importation of independent variables from
external sources;
Output elevation and intensity variables as .tif formatted files;
Individual tree segmentation from a selected point cloud class;
Improved TLS data editing tools that allow users to (1) batch process data to extract DBH
measurements and (2) fit DBHs to point clouds selected in the profile view window;
Added crown diameter, area, and volume to the output of the TLS individual tree segmentation
tool;
Improved Section Analysis Tool in the Terrain Module now allows users to: (1) analyze .dxf
formatted files, (2) import more than one file at a time and draw multiple section lines. (3) define a
step value to simplify sections. (4) export multiple section files
Output contour feature as 2D polylines;
Editing of vector dataset attributes;
Improved profile feature user experience.

Bug Fixed:

Tree heights now updated for tree filtering after tree segmentation tool has been run;
Projection information of las data can now be read.

v2.1.2 - 04/25/2018



Enhancements:

Improved batch extraction function for DBH (Diameter at Breast Height);
LiData upgrade.

v2.1.1 - 04/08/2018
Enhancements:

Support LAZ/LAS 1 .4 file formats;
Intensity information with ply data now can be read.

v2.1 - 02/05/2018
New Features:

Automatic calculation of flight strips matching parameters;
Median ground point clouds classification;
Supervised classification based on machine learning;
Support revising ground point filtering results of a defined region;
Support cross section analysis;
Vector Editing;
Support selected region extends from both end in profile viewer;
Tile by Point Number;
Support generating TIF images with projection information.

Enhancements:

Improved DEM, DSM interpolation algorithm;
Improved efficiency of point cloud and TIN generated contour lines;
Improved efficiency of individual tree segmentation algorithm (individual tree segmentation from
point cloud and individual tree segmentation based on seed point);
Support richer terrain product formats, including a new ASC format for raster data and a new
DXF format for the contour line.

Bug Fixed:

De-redundant function;
Multipoint selection;
Fixed a bug of Classifying by attribute.

v2.0 - 10/30/2017
New Features:

New License Key: The software could be activated on a monthly basis or by module;
Forest Module (divided to ALS module and TLS module);

ALS Module:
Seeds generation algorithm: It's used to generate segmentation seed layer based on



CHM, Point Cloud Segmentation and Layer Stacking;
Seeds edition: adding/deleting seeds, selecting seeds and segmenting individual tree
based on seeds;
Added individual tree batch processing based on seed layer;

TLS Module:
Ground Classification using TLS data;
Added the seed point based ground point cloud individual tree batch processing;
Added the calculation of DBH;
Seeds edition: adding/deleting seeds, selecting seeds and segmenting individual tree
based on seeds;

Classification Module:
Improved performance of ground points filter algorithm;
Classification for key feature points. By identifying the key surface points, this allows the
down-sampling of relatively flat areas thus improving processing efficiency without sacrificing
quality;
Added a check box to the interface of ground point filter function to extract model key points
after separating ground points;

Power Line Module:
Added creation of vector output for power line and tower classifications;
Real-time measurement of the distances from any given point to the closest power line and
tower;

Added the setting of point cloud display point size for individual layers;
Added automatic identification of point cloud center point and setting it as rotation center;
Improved visual effects of TIN;
Shapefile layer attribute table now can be displayed;
Identifying and locating the corresponding individual tree in the viewer by double-clicking a row in
the segmentation result list table.
Cross selection tool supports more accurate adjustment of the boundingbox;
Added Display Parameters Settings in LOG viewer while the LOG file still stays at system's
TEMP folder;
Support information collection when the software crashes. You can send crash information in the
pop up interface to the mailbox;
The cut results for multiple data sources can be saved separately or be merged into a file.

v1.5 - 07/14/2017
New Features:

Added power line module. The main functions include marking tower position, cutting the point
cloud data based on the tower position, automatic classification of power line and tower,
dangerous points detection and report generation;
Added selection toolbar which includes polygon selection, rectangle selection, sphere selection,
in cut, out cut, save cut and cancel selection;
Added editing point cloud classification with real-time TIN;
Support merging multiple files into one;
Support undo to profile editing and selection function by Ctrl+Z.



Enhancements:

CHM segmentation algorithm improvement. Users can adjust more parameters and generate the
shape file of tree boundary;
Added the residual report to the registration function. Users can choose the points for coordinate
Conversion;
Cross selection result can be export;
The parameters setting for batch processing for multiple files and multiple functions can be
imported and exported;
Improved profile editing efficiency;
Users can choose whether to generate minor, basic and major contour when using "point cloud
to contour" and "TIN to contour” functions;
Added seven parameters transformation for reprojection function;
The results of Clip by Circle and Clip by Rectangle can be exported as one file, or saved as
individual files according to the extent of circle or rectangle;
The real-time coordinates in the status bar are more accurate;
Improved user experience of navigating.

v1.4 - 05/31/2017
New Features:

Added "generate TIN", "TIN edit", "TIN to Contour", "TIN to DEM" functions;
Added Grid Volume Statistics function;
Added "Camera Roam" and "Save to Video functions”;
Fixed the bug of memory leak when loading .ply data.

v1.3 - 04/17/2017
New Features:

Added PLY data import and export to I/O module;
Added elevation difference, overlap and density quality reports to strip adjustment module;
Added "Resampling based on octree" and "point cloud convert to DXF" to data management
module;
Power line classification;
Support mix and glass coloring modes in rendering;
Batch Processing for multi-files and multi-functions;
Geometric correction (support point cloud registration based on points or sphere targets).

Enhancements:

Speed improvements for contour generation based on point cloud;
Users can set the properties of minor, basic and major contours for "point cloud to contour". The
elevation attributes can be read;
The boundary of concave polygon is shown for area measurements;
The resolution of surface model is not limited to 0.5m.

Bug Fixed:



Fixed the bug of file opening error when there is an invalid file in multiple .csv files;
Fixed the bug of window flash caused by EDL effect in windows 10;
Bug fixed for stepwise regression;
Bug fixed for software crash caused by opening old version of LiData;
Bug fixed where LiDAR360 could not be opened with unstandardized projection settings.

Lite - 02/04/2017
Free version, with main functions including data visualization and grid statistics.

v1.1 - 12/22/2016
New Features:

Software platform update: 2D&3D integration, multiple window linkage, rolling screen, display
order changed by drag, cross selection,etc;
Strip quality check function;
Added generating contour lines based on point cloud;
Chinese software version;
Bug fixed for raster image subdivision and LiModel with texture.

v1.0 - 10/11/2016
First version release of LiDAR360.
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