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Introduction
LiPowerline offers a complete and intuitive solution for power line inspection and analysis from LiDAR point
clouds. It includes a powerful toolset for automatically classifying power lines, towers and vegetation and
effectively detecting a range of user-defined danger points such as vegetation overgrowth and tree fall.

LiPowerline is able to segment individual sections of the corridor based on the location of each power tower and
process all segments simultaneously.

After segmenting the corridor, LiPowerline utilizes our proprietary machine learning algorithms to automatically
classify power lines and towers. The conditional classification algorithm then allows for the ground point, building
and noise classification. Users are also given the option to manually edit the automatic classification results.

LiPowerline also has the ability to vectorize insulators and power lines, the results of which, can then be used to
simulate and predict how environmental variabilities, such as strong wind, ice coverage and high temperatures,
may affect the safety of electricity transmission.

Performing individual tree segmentation will allow users to simulate tree future growth and extract both identified
and potential danger points.

Crucial risk and analysis information is then automatically generated as an assessment report, allowing for a
precise understanding of the asset.

Specifically, LiPowerline has the following modules:

Data Management: The module provides management tools for point cloud and raster data, which include
format conversion, point cloud de-noising, normalization, raster band calculation and so on.

Statistics: Based on the number, density and elevation of LiDAR points, statistics can be calculated for data
quality evaluation.

Classify: The module provides various classification methods for point cloud classification including ground
classification, ground key point classification, interactive classification, machine-learning-based classification
(for building, vegetation, and custom classes) etc.

Power Line: The module supports automatic point classification(tower, conductor, shield line, insulator,
drainage thread, scissors crossing line, ground point, vegetation, buildings, roads and water), real-time
analysis of the powerline corridor condition and generate user-defined reports. Support simulation analysis
under conditions such as high temperature, icing, and strong winds. Provide various tower and conductor
measurement and analysis tools, such as tower tilt, sag analysis, etc. In addition, it supports the generation
of tower fine inspection, wire inspection, and channel inspection routes, and checks the flight safety of the
routes.

Get Started
Please refer to Installation and License to install the software. The usage is described in Tutorials.



Installation
Download the latest version of LiPowerline from the GreenValley International official website before installation.

System Requirements

RAM: at least 8G or more.
CPU: Intel® Core™ i5/i7; Dual-core processor.
Display Adapter: NVIDIA graphics above GTX 970, video memory no less than 4GB.
Operating Systems: Microsoft Windows 7 (64-bit), Microsoft Windows 8 (64-bit), Microsoft Windows 10 (64-
bit), Microsoft Windows 11 (64-bit), Microsoft Windows Server 2012 and higher.

Note: Please enable high-performance graphics mode for running the software. On Windows 8 and
Windows 10 if the software is installed on the system disk, you need to set it up to run as an administrator.

Setup

1. Run the LiPowerline Setup Wizard.
2. Click Next button in the Welcome Interface.
3. Click I Agree button to continue if you accept the License Agreement.
4. Choose the installation path (or use default path), then click Install button.
5. Click Finish button after installation.

License Manager

There are two licensing approaches to activate LiPowerline, by license dongle or license code. For license
dongle, users must not format, delete, or copy the license dongle.

1) License dongle

Properly insert a license dongle to USB port to activate LiPowerline.

2) License code

License code would be generated based on activation information given by LiPowerline users. After purchasing a
license code, please follow the following steps to activate LiPowerline.

1.Run the software.

2.Click Help > Activate License, the License Manager window will pop up.

3.Under General Information tab, fill in your name and company name, select the modules you want to activate,
and then click Copy.

4.Email the copied information to info@greenvalleyintl.com.

5.There are two licensing modes: single use licensing and concurrent use licensing. After receiving the activation
key, activate or revoke the license using online or offline mode.

Single Use Licensing

Activation/Update

https://greenvalleyintl.com/
mailto:info@greenvalleyintl.com


Online Activation/Update: When connecting to the internet, under the "Single Use Licensing" tab, enter
the authorization key, select "Online", and click "Activate" to activate or update. Activation information,
such as expiration date, will displayed below. Under "General Information" page, you may also check
the expiration date for each individual module. If you need to set up proxy to connect to the internet,
click  to use proxy, and set up the address, port, user name, and password.

Offline activation: Step 1: Select "Offline" under the "Single Use Licensing" tab; Step 2: Click "Generate
Request File" button to generate the request file (.req); Step 3: Use a computer that can connect to the
internet to browse to https://user.bitanswer.cn, enter the authorization key to log in, click "Update",
upload the request file (.req), and download the generated upgrade file (.upd); Step 4: go back to the
License Manager interface, click "Apply Promote File" and select the downloaded .upd file.

https://user.bitanswer.cn


Revoke

To unbind an activation key from a computer, user could revoke the activation key online or offline. After
the authorization key is revoked, it can be reused on the same computer or a different one.

Online Revoke: In "Single Use Licensing" tab, enter the authorization key, select "Online", and click
"Revoke" to revoke the key. If you need to set up proxy to connect to the internet, click  to use
proxy and to set up the address, port, user name, and password.



Offline Revoke: Step 1: Select "Offline" under the "Single Use Licensing" tab; Step 2: Click "Generate
Revoke File" button to generate the request file (.req); Step 3: Use a computer that can connect to the
internet to browse to https://user.bitanswer.cn, enter the authorization key to log in, click "Update",
upload the request file (.req), and download the generated upgrade file (.upd); Step 4: go back to the
License Manager interface, click "Apply Promote File" and select the downloaded .upd file.

Delete

To delete authorization information from the computer, right-click on the authorization key and select
"Delete Key". After being deleted, the same activation key can only be used on the same computer.

https://user.bitanswer.cn


Concurrent Use Licensing

Install enterprise activation tool on the server to activate the key online or offline. Other users can use the
activation windows to input the server's IP address to activate the software. The default port is 8273. Click
"Apply".

6.Click the help button  on the License Manager interface to view the license manager user guide.



Note: If any of the software instance (i.e. LiDAR360, LiMapper, LiGeoreference, LiPowerline) is being
opened while updating the license in License Manager, please restart the software to make the license be
effective.

Note: If an user would like to move a key from one computer to another, he/she should revoke first, then
activate on the other. If the license code has been deleted, the user should reactivate on the same
computer first, then revoke and activate this key on the other computer.

Note: Please contact info@greenvalleyintl.com for inquiry and purchase.

Languages

Currently, the supported languages are English. You can switch the menu language in the following way:

1. Click Display > Language > English in the menu bar.
2. Language change needs a restart to be effective. Click Yes in the pop-up dialog to restart the software

immediately, or click Cancel and restart later.

mailto:info@greenvalleyintl.com


Tool Reference
This chapter describes the usage of menu bar, toolbar, project management windows and toolbox of LiPowerline
in detail.

Project Tools

Color Tools

Viewing Tools

Operation Tools

Setting Tools

Measure Tools

Model Tools

Profile Tools

Select Tools

Rectify Tools

Project Management Window

Viewers

Display

Data Management

Statistics

Classify

Power Line



Project Tools
Add Data

Add and Merge Point Cloud Data

Delete Data

Export Data

Open Project

Save Project

Exit



Add Data

Import LAS/LAZ File

The LAS file is intended to contain LiDAR point data records. The data will generally be put into this format from
software (e.g. provided by LiDAR hardware vendors) which combines GPS, IMU, and laser pulse range data to
produce X, Y, and Z point data. The intention of the data format is to provide an open format that allows different
LiDAR hardware and software tools to output data in a common format.

1. Click File > Data > Add Data to view the Open Data window.

2. Choose the LAS file you want to import and click Open for the Open LAS File window where you can do
some initial settings as shown in the figures below:

3. Click tab Header to check general LAS file header information such as Version, Source ID, System ID,
Generating Software, File Creation Day/Year, Header Byte Size, Data Offset, Number of Point Records etc.

4. Click tab Attribute Option to set Crop Option and decide which point attributes you want to import for each
point record. LiPowerline imports all the point attributes by default.

Brief: One of the most useful features of LiPowerline is its ability to interface with data in many file
formats. You can import point clouds (LAS/LAZ, TXT, PLY, ASC, NEU, XYZ, PTS, CSV etc.), tables,
images (JPG, TIF), models (OSG, LiModel, LiTin) or vectors into LiPowerline. It allows you to visualize,
animate and edit your point cloud as well. Point cloud data will be converted into LiData file at the first
time being added. LiData file is the LiPowerline native file format for point cloud and optimized for
viewing.



5. Click tab Coordinate Option to set the coordinate system for your point records.



You can search the coordinate system much more quickly by using regular expressions. For example, the
WGS 84 coordinate system will be displayed instantly when you input EPSG code of WGS 84 system as
shown in the figure below:

You can also import coordinate system form WKT or PRJ by clicking drop-down menu Add Coordinate
System. Recently used coordinate reference systems holds a history list.

6. Click Apply or Apply All when you finish your configuration. Apply implies that you want this configuration for
current point cloud data only. Apply All means all the point cloud data share the same configuration during
the LiPowerline's running and it won't show this configuration window again even you add new data.

Import TXT File

A point cloud is a set of vertices in a three-dimensional coordinate system usually defined by X, Y, and Z
coordinates and other attributes such as color and normal. These attributes can be simply arranged in one line for
each point record and one single TXT file for one-point set.

1. Click File > Data > Add Data to view the Open Data window.

2. Choose the TXT file you want to import and click Open for the Open Ascii File window where you can do
some initial settings as shown in the figure below:



3. LiPowerline can automatically detect the delimiters but you can also specify delimiter manually.

4. There are indeed cells that are colored red in the import window if TXT file has a header. Just skip them by
setting Skip line value to 1.

5. Use the drop-downs to give the proper form of your point records.

Import CSV File

The so-called CSV (Comma Separated Values) format is the most common import and export format for
spreadsheets and databases. CSV format was used for many years prior to attempts to describe the format in a
standardized way in RFC 4180. The lack of a well-defined standard means that subtle differences often exist in
the data produced and consumed by different applications. These differences can make it troublesome to
process CSV files from multiple sources. Still, while the delimiters and quoting characters vary, the overall format
is similar enough that it is possible to write a single module which can efficiently manipulate such data.

1. Click File > Data > Add Data to view the Open Data window.

2. Choose the CSV file you want to import and click Open for the Open ASCII File window where you can do
some initial settings as shown in the figures below:



CSV file can be opened as table or point cloud.

3. Open as Table is recommended if the CSV file is the resultant product of the Segmentation function. The
CSV table contains the ID of each tree, the x, y coordinate locations, the tree height, the crown diameter, and
the crown area properties. The data type could be Point or Circle. If Point type was selected, you should
specify the X,Y,Z columns additionally.

If Circle type was selected, you should specify the center and radius.

Click Show Label radio button to show/hide label for each point or circle.

4. The Import TXT File section has more detailed descriptions if you Open as Point Cloud.



Import PLY File

The polygon (PLY) file format, also known as the Stanford triangle format stores three-dimensional data from 3-D
scanners. It is a format for storing graphical objects that are described as a collection of polygons. A PLY file
consists of a header, followed by a list of vertices and then, a list of polygons. The header specifies how many
vertices and polygons are in the file. It also states what properties are associated with each vertex, such as (x, y,
z) coordinates, normals, and color. The file format has two sub-formats: an ASCII representation and a binary
version for compact storage and for rapid saving and loading. The header of both ASCII and binary files is ASCII
text.

1. Click File > Data > Add Data to view the Open Data window.

2. Choose the PLY file you want to import and click Open for the Open PLY File window where you can do
some initial settings as shown in the figure below:

3. Specify properties that associated with each vertex's coordinates(x,y,z).

4. Specify properties that associated with each vertex's color (r,g,b) if they have any. Otherwise, simply choose
None.

5. Click Apply when you complete your configuration.

Import Raster File

A raster data structure is based on a (usually rectangular, square-based) tessellation of the 2D plane into cells. In
its simplest form, a raster consists of a matrix of cells (pixels) organized into rows and columns (grid) where each
cell contains a value representing information. The geographic location of each cell is implied by its position in the
cell matrix. Accordingly, other than an origin point, e.g. bottom left corner, no geographic coordinates are stored.
Due to the nature of the data storage technique data analysis is usually easy to program and quick to perform.

1. Click File > Data > Add Data to view the Open Data window.

2. Choose the Raster file and click Open.

Import Vector File

Vector data can be represented at its original resolution and form without generalization. Graphic output is usually
more aesthetically pleasing (traditional cartographic representation). Since most data is in vector form and no
data conversion is required. Accurate geographic location of data is maintained.



1. Click File > Data > Add Data to view the Open Data window.

2. Choose the Vector file and click Open.

Import Model File

LiModel file is the native file format where LiPowerline stores triangulated regular network models generated by
DEM or DSM. LiTin file is generated by the irregular 2.5D triangulation model based on the point cloud.

1. Click File > Data > Add Data to view the Open Data window.

2. Choose the Model file and click Open.

Note: You can drag file(s) into LiPowerline directly. If you can't, click here for more help.

https://answers.microsoft.com/en-us/windows/forum/windows_10-files/how-to-fix-drag-and-drop-in-windows-10/0ea16377-dfcf-4a28-9e38-c35f4113202b?page=13&auth=1


Add and Merge Point Cloud Data

Steps

1. Click tool botton  to open the Add and Merge Data window.

Bounding boxes of point clouds are displayed in the left area. Bounding box of the selected point cloud is
highlighted in red.

2. Select LAS or LiData as your data type.

3. Click  to add LAS/LiData file(s).

4. Click  to remove LAS/LiData file(s).

5. Click  to remove all file(s).

Brief: Merge two or more point clouds in LAS/LAZ or LiData format to one single point cloud in LiData
format.



Delete Data

Steps

1. Select the data item you want to remove in the tree widget to active the Remove button .

2. Click  .

Note: In some cases, it is not allowed to remove data from LiPowerline when it is busy running some
critical functions.

Brief: Remove data.



Export Data

Steps

1. Select the point cloud data you want to export in the tree widget on the left.

2. Move the mouse to that item and right click.

3. Click Export to show the Export Point Cloud window.

4. Input file path and name:

5. Set file type:

Brief: As described in Import section, you can easily move data into and out of LiPowerline. You can
currently export point clouds from LiData to many other formats (LAS/LAZ, TXT, PLY, ASC, NEU, XYZ,
PTS, CSV etc.).



6. Click Save .



Open Project

Steps

1. Click File > Open Project to show Open Project window:

2. Select a LiPowerline project file and click Open.

Brief: Open a LiPowerline project file(*.LiProj).



Save Project

Steps

1. Click the Save Project button  on the tool bar,and then click Save.

2. If this is the first time that you are saving the project, type a name for it in the file name box, and then click
Save.

3. You can save a project in the following file format: *.LiPrj.

Brief: Save project.



Exit
Brief: Exit the software.

Steps

1. (Optional) Click File > Exit to quit.

2. (Optional) Use the hotkey Alt+F4 to quit.



Color Tools
With tools in this section, LiPowerline allows you to visualize vast amounts of point cloud using the best data
representations for your analysis. You can change the coloration of the point cloud displaying by class or
intensity, GPS time, return of number,etc. You can also enhance the render effect using visualization tools such
as EDL, PCV and Glass which are intuitive and helpful for quality check.

Display by Height

Display by Intensity

Display by Class

Display by RGB

Display by Return

Display by Time

Display by Blend

Display by Tree ID

Display by Mix

Display by Danger Tree

Display by EDL



Display by Height

Steps

1. Click the window that loads point cloud data with the left mouse button and set it as the active window.
2. Click the button  on the toolbar to pop up the dialog "Display by Elevation", as shown below.

3. Select the appropriate color bar in the combo box and click the "OK" button. The color indicator of the
window will generate the corresponding color bar according to the elevation range of the point cloud data. At
the same time, the data is displayed by elevation in the scene. The visual effects are better with EDL mode,
as shown below.

Note: This tool only works with point cloud data.

Brief: This tool is used for displaying point cloud data. The elevation values of point cloud data are
mapped to several uniformly varying color intervals, so as to display the variation of elevation values
more intuitively.



Display by Intensity

Steps

1. Click the window that loads point cloud data with the left mouse button and set it as the active window.
2. Click Tool > Colorbar >  Display by Intensity. The color indicator of the window will generate the

corresponding gray color bar according to the intensity range of the point cloud data. At the same time, the
data is displayed by intensity in the scene. The visual effects are better with EDL mode, as shown below.

Note: This tool only works with point cloud data.

Brief: This tool is used for displaying point cloud data. The intensity values of point cloud data are
mapped to several uniformly varying color intervals, so as to display the variation of intensity values
more intuitively.



Display by Class

Steps

1. Click the window that loads point cloud data with the left mouse button and set it as the active window.
2. Click the button  on the toolbar to pop up the dialog "Display by Class", as shown below.

3. Select the appropriate color for each class and click the "OK" button. The color indicator of the window will
generate the corresponding color bar according to the class attribute of the point cloud data. At the same
time, the data is displayed by classification in the scene. The visual effects are better with EDL mode, as
shown below.

Brief: This tool is used for displaying point cloud data. The classes of point cloud data are mapped to
discrete color values, so as to distinguish different classes of point cloud data more intuitively.



Note: This tool only works with point cloud data.



Display by RGB

Steps

1. Click the window that loads point cloud data with the left mouse button and set it as the active window.
2. Click the button  on the toolbar. The data is displayed according to its own RGB values in the scene, as

shown below.

Note: This tool only works with point cloud data contains RGB attributes.

Brief: Capable of displaying point cloud data, rendering the point cloud using its inherent RGB color
attributes.



Display by Return

Steps

1. Click the window that loads point cloud data with the left mouse button and set it as the active window.
2. Click Tool > Colorbar >  Display by Return to pop up the dialog "Display by Return", as shown below.

3. Select the appropriate color bar for each return number and click the "OK" button. The color indicator of the
window will generate the corresponding color bar according to the return number attribute of the point cloud
data. At the same time, the data is displayed by return number in the scene. The visual effects are better with
EDL mode, as shown below.

Note: This tool only works with point cloud data.

Brief: This tool is used for displaying point cloud data. The return numbers of point cloud data are
mapped to discrete color values, so as to distinguish different return numbers of point cloud data more
intuitively.



Display by Time

Steps

1. Click the window that loads point cloud data with the left mouse button and set it as the active window.
2. Click Tool > Colorbar >  Display by Time to pop up the dialog "Display by Time", as shown below.

3. Select the appropriate color bar in the combo box and click the "OK" button. The color indicator of the
window will generate the corresponding color bar according to the GPS time range of the point cloud data. At
the same time, the data is displayed by time in the scene. The visual effects are better with EDL mode, as
shown below.

Note: This tool only works with point cloud data.

Brief: This tool is used for displaying point cloud data. The GPS time values of point cloud data are
mapped to several uniformly varying color intervals, so as to display the variation of GPS time values
more intuitively.



Display by Blend

Steps

1. Click the window that loads point cloud data with the left mouse button and set it as the active window.
2. (Optional) Process the point cloud data by PCV.
3. Click Tool > Colorbar >  Display by Blend to pop up the dialog "Display by Blend", as shown below.

4. Select the appropriate color bar in the combo box and click the "OK" button. The color indicator of the
window will generate the corresponding color bar according to the elevation range of the point cloud data. At
the same time, the data is displayed in the scene according to the elevation values and intensity values. The
visual effects are better with EDL mode, as shown below.

Brief: This tool is used for displaying point cloud data. Consider the elevation attribute and intensity
attribute, the point cloud data is mapped to several uniformly varying color intervals, so as to reflect the
comprehensive variation of elevation/intensity more intuitively, and display the feature class and
boundary more explicitly.



Note: This tool only works with point cloud data. The visual effects will be better after PCV process for the
point cloud data.



Display by Tree ID

Steps

1. Click the window that loads point cloud data with the left mouse button and set it as the active window.
2. Click the button  on the toolbar. If the point cloud data contains tree ID attribute, then the data will be

displayed by tree ID in the scene. The visual effects are better with EDL mode, as shown below.

Note: This tool only works with point cloud data after individual tree segmentation.

Brief: This tool is used for displaying point cloud data after point cloud segmentation. The tree ID's of
point cloud data are mapped to discrete color values, so as to distinguish different trees of more
intuitively.



Display by Mix

Steps

1. Click the window that loads point cloud data with the left mouse button and set it as the active window.
2. Click Tool > Colorbar >  Display by Mix to pop up the dialog "Display by Mix", as shown below.

3. Select the attribute for display.
4. Select the appropriate color bar in the drop-down box.
5. Check the classes and return numbers for filtering.
6. Click the "OK" button. Then the color indicator of the window will generate the corresponding color bar

according to the selected attribute range the point cloud data. The data will be filtered by the specified
attributes first and then be displayed by the specified attributes in the scene. The visual effects are better
with EDL mode, as shown below.

Brief: This tool is used for displaying point cloud data. Different attributes of point cloud data are
mapped to several uniformly varying color intervals, at the same time different ways of attribute filtering
are supported, so as to display the variation of a certain attribute of the filtered point cloud data more
intuitively.



Settings

Display By: The selected attribute will be mapped to specified color range.
Height(Default): The elevation attribute of the point cloud data.
Intensity: The intensity attribute of the point cloud data.
Time: The GPS Time attribute of the point cloud data.

ColorBar: The color bar supports several uniformly varying color intervals for color mapping.
Filter by Classification: List all the classes users can choose to filter the point cloud data.
Filter by Return Number: List all the return numbers users can choose to filter the point cloud data.

Note: This tool only works with point cloud data.



Display by Danger Tree

Summary

Steps

1. Click the window that loads the point cloud data with the left mouse button and set it as the active window.
2. Click  in toolbar at the left side of the software UI. In the popup menu, click the  button, if the point

cloud contains the information of Tree ID and the clearance distance, the dangerous trees will be displayed
by tree ID. The visual effects are better with EDL model, as shown below.

Note: This tool only works on point cloud data that has undergone single-tree segmentation and
clearance danger point detection.

Used to display the dangerous tree in the segmented point cloud. By mapping the Tree ID of the
dangerous tree and the attribute of clearance distance to different color values, intuitively distinguish the
different dangerous in different colors.



Display by EDL

Steps

1. Click the window that loads point cloud data with the left mouse button and set it as the active window.
2. Click the button  on the toolbar. The visual effects of the point cloud data in the scene will be improved

with EDL mode. The following picture shows the comparison before and after using EDL display mode.

Note: This tool only works with point cloud data.

Brief: This tool is used to display the point cloud data and enhance the visual effects of the contour
features using the Eye Dome Lighting (EDL) mode. EDL is a shading technique that works with other
display mode (e.g. display by height, display by intensity) to improve the depth perception in 3D point
cloud visualization.



Viewing Tools
Set current active window to some view.

Top View

Bottom View

Left View

Right View

Front View

Back View

Front Isometric View

Back Isometric View

Set Projection Mode

Pick Rotation Center



Top View

Steps

1. After clicking this button , current active window will be shown:

Note: This tool is only for viewer in 3D mode, and it does not reset the center position of the viewer. If you
need to reset to the default view, please click Full Extent.

Brief: Set camera to top view. View data from +z to -z direction. View plane: x-y plane.



Bottom View

Steps

1. After clicking this button , current active window will be shown:

Note: This tool is only for viewer in 3D mode, and it does not reset the center position of the viewer. If you
need to reset to the default view, please click Full Extent.

Brief: Set camera to bottom view. View data from -z to +z direction. View plane: x-y plane.



Left View

Steps

1. After clicking this button , current active window will be shown:

Note: This tool is only for viewer in 3D mode, and it does not reset the center position of the viewer. If you
need to reset to the default view, please click Full Extent.

Brief: Set camera to left view. View data from -x to +x direction. View plane: y-z plane.



Right View

Steps

1. After clicking this button , current active window will be shown:

Note: This tool is only for viewer in 3D mode, and it does not reset the center position of the viewer. If you
need to reset to the default view, please click Full Extent.

Brief: Set camera to right view. View data from +x to -x direction. View plane: y-z plane.



Front View

Steps

1. After clicking this button , current active window will be shown:

Note: This tool is only for viewer in 3D mode, and it does not reset the center position of the viewer. If you
need to reset to the default view, please click Full Extent.

Brief: Set camera to front view. View data from -y to +y direction. View plane: x-z plane.



Back View

Steps

1. After clicking this button , current active window will be shown:

Note: This tool is only for viewer in 3D mode, and it does not reset the center position of the viewer. If you
need to reset to the default view, please click Full Extent.

Brief: Set camera to back view. View data from +y to -y direction. View plane is x-z plane.



Front Isometric View

Steps

1. After clicking this button , current active window will be shown:

Note: This tool is only for viewer in 3D mode, and it does not reset the center position of the viewer. If you
need to reset to the default view, please click Full Extent.

Brief: Set camera position to front 45 degrees of X-Y plane.



Back Isometric View

Steps

1. After clicking this button , current active window will be shown:

Note: This tool is only for viewer in 3D mode, and it does not reset the center position of the viewer. If you
need to reset to the default view, please click Full Extent.

Brief: Set camera position to back 45 degrees of X-Y plane.



Set Projection Mode

Steps

1. After clicking this button , the option of projection mode is popped up. If Orthogonal Projection is
selected, current active window will be set in orthogonal projection. If Perspective Projection is selected,
current active window will be set in perspective projection.

Settings

Shortcut Key: F3

Note: This tool is only for viewer in 3D mode.

Brief: Select projection mode(orthographic/perspective).



Pick up Rotation Center

Summary

Steps

1. Click button on left toolbar, move mouse on the viewer currently activated. And the mouse cursor
changes into , pick up a point and this point will become new rotation center. Then the cursor will restore
as arrow shape. Press "Shift" to reset rotation center.

Note: This function is only avaliable in 3D viewer.If users want to cancel current rotation center, please
click Top View, Bottom View, Left View, Right View, Front View, Back View or Global View.

Pick up rotation center in 3D viewer.



Operation Tools
The operation toolbar contains tools to control view operations.

Full Extent

Zoom In

Zoom Out

Pan

Go To



Full Extent

Steps

1. Click the window that contains data with the left mouse button and set it as the active window.
2. Click the button  on the toolbar. All the data in the active window will be scaled automatically to cover the

entire window, as shown below.

Note: When there are multiple windows, this tool only works on the active window.

Brief: This tool is applicable to all data types supported by LiPowerline. It makes all the data cover the
entire window in top view and provides full view of all the data.



Setting Tools
Basic settings for viewers.

Configure Point Size

2D View

3D View

Capture Image

Cross Selection

Window Linkage

Rolling Screen

Display Options

Camera Setting

Manipulator Setting

Shortcut Key Settings

Camera Roam

Configuration File Operation



Configure Point Size

Steps

1. Click this button  to open the dialog shown as below:

2. Configure point size and type.

Settings

Circular Points: Determine point type. If checked, point will be rendered as circle, otherwise, point will be
rendered as square.
Fixed Size: If checked, point size would be fixed. User can adjust point size using the slider below (range 0-
50 pixels).
Point Autosize: If checked, point size is auto changing based on the depth of the viewer.

Note: This function is global. If user wants to configure a single point cloud, just right-click it, select
Configure Point Size and Type from the context menu.

Brief: Configure point size and type.



2D View

Steps

1. After clicking this button, current active window will switch to 2D mode, as shown below:

Note: If current active window contains raster data, it can only be set to 2D mode. After removing raster
data, it can be set to 3D mode.

Brief: Switch current active window to 2D mode.



3D View

Steps

1. After clicking this button, current active window will switch to 3D mode, as shown below:

Note: If current active window contains raster data, it can only be set to 2D mode. After removing raster data, it
can be set to 3D mode.

Brief: Switch current active window to 3D mode



Capture Image

Steps

1. Click this button, open save file dialog, default file name is window name, click "OK" to save file.

Brief: Save the view in current window as a JPG file.



Cross Selection

Steps

1. Click Tool >  Cross Selection to open the dialog shown below:

2. Click button  to reset ROI.
3. Click button  to export point cloud inside the ROI to a new LiData File.
4. Click button  to exit cross selection.
5. The whole display effect is shown below. Drag the blue, green ,or red rectangular interactor in the viewer to

adjust the size of the ROI. Drag the blue, green ,or red spherical interactor to adjust the orientation of the
ROI.

Brief: Cross select partial point cloud using ROI. This function can be used for flood analysis and other
applications.



Settings

Prerequisite: Current viewer contains point cloud.
Show ROI: Show or hide ROI.
ROI: Adjust the minimum and maximum X, Y, Z of the ROI.
Shift ROI: +X, +Y, +Z means to move the ROI to the X, Y, Z positive direction for a default distance. -X, -Y, -
Z means to move the ROI to the X, Y, Z negative direction for a default distance.

Note: This function is for all point clouds in the current viewer.



Window Linkage

Steps

1. Click Tool >  Window Linkage to open the dialog shown below:

2. The windows list contains all windows in LiPowerline, double-click a window that needed to linkage, or select
the window then click button  to add the window. Also, user can click button  to add
all windows to linkage windows list. The linkage windows list all windows under linkage, double-click a
window to remove, or select the windows and then click button  to remove. Also, user can click
button  to remove all linkage windows.

3. If "Cross Line" is checked, cross line will be displayed in the linkage windows. The following figure shows if
the cross line is checked:

Brief: Enable windows linkage of multiple viewers.



Note: If the current window contains raster data, it will be displayed in 2D. If the linkage windows contain
3D window and 2D window, the windows will be displayed in 2D mode.



Rolling Screen

Steps

1. Click Tool >  Rolling Screen to open the dialog shown below:

2. Current files list contains files in current viewer. Double-click a file that needs to be added to rolling screen,
or select files and then click , or click button  to add all files to rolling screen files.
The rolling screen files list contains files in rolling screen, double-click a file to remove, or select files and
then click button  to remove, or click button  to remove all files.

3. Click "OK". In the viewer, press the "Shift" button on the keyboard then drag. The window is shown below:

Settings

Prerequisite: An active viewer.

Brief: Enable rolling screen for current viewer.



Note: This function cannot be apply to the profile window. Click this button again to exit.



Display Options

Steps

1. Click this button to open the dialog shown as below:

2. Click "Colors" page to set background color:

Brief: Configure background color, label properties and lights.



3. Click "Labels" page to set label color and size:

After creating any tag, user can move it by dragging. Push "Delete" key on the keyboard to delete selected
tags.



4. Click "Light" page to set the direction of light. Light settings only effect on model files (LiModel, LiTin, OSGB,
etc.).

5. Click "Default All" to restore all settings to default values.



Camera Setting

Steps

1. After clicking this button, the dialog shown below would pop up:

2. Adjust camera rotation using sliders.
3. Click  to pick a point as rotation center.

Brief: Camera settings for current active 3D window.



Settings

Prerequisite: Current active window must be in 3D mode.
Current mode: Show projection type of current active window, including perspective projection and
orthogonal projection.
X: Camera rotation around X axis.
Y: Camera rotation around Y axis.
Z: Camera rotation around Z axis.
Rotation Center: Rotation center, which could be picked from viewer.
Camera/Eye Center: Non-editable, computed using rotation.
Field of view: Field of view, default 30 degree.
Distance: Distance to viewpoint. Non-editable.



Manipulator Setting

Step

1. Click the  button on the left toolbar of the software interface, and then click the  button in the pop-up
menu to open the following interface:

Parameter Settings

Select Sensitivity: The sensitivity is divided into levels 1, 2, and 3, with higher levels indicating higher
sensitivity. The default level is 1.

Brief: Set the mouse sensitivity.



Shortcut Key Settings

Clear Current: Clear the shortcut key Settings for the currently selected function. 
Clear All: Clear shortcut key Settings for all functions.
Default: Restore default shortcut key Settings.

Note: Some shortcut keys are already used for specific operations, please set other keys.

Brief:Set shortcut keys for common functions. Select the function for which you want to set the shortcut
key and click the keyboard to set the shortcut key.



Camera Roam
Brief: This function can control the scene camera to navigate through a roam path. Two types of roam path are
supported including roam path based on viewport and roam path based on POS file. This function can also
generate immersive video if cooperated with Save to Video function.

Steps

1. Click Disply > Camera Roam to open Camera Roam Set dialog as bellow.

2. Choose mode as desired(Select "Roam by Viewports" or "Roam by Pos Path").

2.1 Roam by Viewports
Add Key Frame: Click this button to add current viewport as a key frame.
Delete Key Frame: Click this button to delete a key frame.
Load Key Frames from File: Click this button to import a key frame file.
Save Key Frames to File: Click this button to export all key frames to file.
Delete All Key Frames: Click this button to delete all key frames.



Select a key frame in the list: Scene camera will be adjusted to this key frame.
2.2 Roam by POS File

Check or uncheck "Show Path" as desired.
Set the Path Width, which will be activated when "Show Path" is checked.
Click "Restore Original State" to return to the first control point.
Select "Top View Roam" or "Front View Roam" as desired.
Click Settings to open the following dialog.

Select a POS File: txt format only, each line of the file represents a key frame. The first three
columns are assumed to be XYZ. Column delimiters include comma, semicolon and space.
Set parameters: Including offset, time step, yaw, pitch, roll.
Click "Ok" to end the roam path setting.

3. Click "Start Roam" to begin roam through current path. After finished, the following dialog will show.

4. Click "Ok" to end the camera roam.
5. Click "Cancel" to exit this function.

Settings

Input: Viewport of current window or POS file.



Settings of Roam by POS file:
Path Width: Non negative integer only, defines the line width of POS trajectory in the viewer.
X/Y/Z Offset: The default value will be the offset of scene coordinate to the world coordinate system, as
POS data is in the world coordinate system.
Time Step: real number larger than 0.01 only, defines the time interval between key frames. The smaller
this value is, the slower the roaming speed is.
Yaw/Pitch/Roll: Local roam coordinate is defined that the origin is key frame center, the Y axis points to
the motion direction, the X axis is defined based on Y axis and world coordinate Z axis using right-hand
coordinate system principle, the Z axis is defined based on X axis and Y axis using right-hand
coordinate system principle. By default, the roam camera is towards -Z, the right of camera is +X, the
upper of camera is +Y. Yaw means spinning around +Z. Pitch means spinning around +X. Roll means
spinning around +Y.



Configuration File Operation

Step

1. Click the button on the left toolbar of the software interface, and then click the button in the pop-up
menu to open the following interface:

Parameter Settings

Save Configuration File As: Save all configuration files to another folder.
Import Configuration Files: Import configuration files from the selected folder.
Delete Configuration Files: Delete configuration files.

Brief: View and change the camera settings of the currently active 3D view.



Measure Tools
The measure tools are used to measure geometric information about the data.

Pick Point

Multi Pick Point

Length Measurement

Area Measurement

Angle Measurement

Height Measurement

Volume Measurement

Density Measurement



Pick Point

Usage

Click Point Cloud > Measurement > Point

Steps

1. Click a valid point in the scene and a label that displays the point attributes will pop up. If the point belongs to
point cloud data, then the label will show the position, intensity, return number, classification and GPS time,
as is shown below. If the point belongs to raster data, then the label will show the position, stretched RGB
value and pixel value.

Click the right mouse button, two context menus will pop up. The menu "Clear Measure" is used to clear the
selection result. The menu "Quit Measure" is used to exit the pick point function.

Note: This tool only works with point cloud data, raster data and model data. It's available in the profile
window too.

Brief: This tool is applicable to point cloud data, raster data and model data. For point cloud data, the
attributes that can be queried contain position, intensity, return number, classification and GPS time. For
raster data, the attributes that can be queried contain position, stretched RGB value and pixel value.



Multi Pick Point

Usage

Click Point Cloud > Measurement > Points

Steps

1. Left-click the points in the scene and the selection results are marked by labels. At the same time, a table
that contains the attributes of the selection points will pop up, shown as follows. The attributes of point cloud
data shown in the table contain index, position (XYZ), classification, return number, GPS time and intensity.
The attributes of raster data shown in the table contain index, position (XY) and band value. The total
number of the points is updated real-time above the table.

2. The "marker size" is used to set the point size of the marker in the scene. The "start index" is used to set the
start index of the selected points.

3. Double-click a row of the table, the scene will go to the position of the corresponding point automatically.
4. Select a row of the table by left-clicking and click the button  to delete the point.
5. The selection set can be exported as *.txt format. Click the drop-down menu  to pop up "Select Format"

dialog, as shown below. If the selected points belong to raster data, then the menu "Save 2D points" is
available. If the selected points belong to 3D data, then the menu "Save 3D points" is available. If the
selected points contain 2D data and 3D data, then the menu "Save all points" is available.

Brief: This tool is applicable to point cloud data, raster data and model data. For point cloud data, the
attributes that can be queried contain position, intensity, return number, classification and GPS time. For
raster data, the attributes that can be queried contain position, stretched RGB value and pixel value.
Different from the pick point tool, this tool allows querying multiple points at the same time, and the
selection set can be exported in *.txt format.



6. Click  to pop up the export dialog. Input the output path, and check the attributes that need to

be exported. Click "OK" to complete the export. Click "Cancel" to cancel the export.
7. If the selected points have not been saved before quitting this tool, a message box will pop up as follows.

Click "Save" to save the points. Click "Discard" to cancel the selections.

Settings

X: X component of the coordinate.
Y: Y component of the coordinate.
Z: Z component of the coordinate.
Classification: The class attribute of point cloud data.
Return: The return number attribute of point cloud data.
Time: The GPS time attribute of point cloud data.
Intensity: The intensity attribute of point cloud data.
Index: The index of select point.
BandValue: The band value of raster data.
Output Path: The path of the output file.

Note: This tool only works with point cloud data, raster data and model data. If the center of rotation needs
to be changed, hold down the the Ctrl key and select the center of rotation with the left mouse button. This
tool is available in the profile window too.



Length Measurement

Usage

Click Point Cloud > Measurement > Length

Steps

1. Left-click at least two points in the scene and the corresponding polyline will be rendered real-time. The
measurement result is displayed in a label as follows. Double-clicking the last point will stop the
measurement process, and the distance value will continue to be displayed in the label.

Click the right mouse button, three context menus will pop up. The menu "Back One Point" is used to go
back to the previous step. The menu "Clear Measure" is used to clear the measurement result. The menu
"Quit Measure" is used to exit the measure tool.

Note: This tool only works with point cloud data, raster data and model data. The "Back One Point" is only
available before the measurement is stopped. This tool is available in the profile window, too.

Brief: This tool is applicable to point cloud data, raster data and model data, which calculates the
distance between two consecutive points.



Area Measurement

Usage

Click Point Cloud > Measurement > Area

Steps

1. Left-click at least three points in the scene and the corresponding polygon area will be rendered real-time.
The measurement result is displayed in a label as follows. Double-clicking the last point will stop the
measurement process, and the measurement result will continue to be displayed in the label.

Click the right mouse button, three context menus will pop up. The menu "Back One Point" is used to go
back to the previous step. The menu "Clear Measure" is used to clear the measurement result. The menu
"Quit Measure" is used to exit the measure tool.

Note: This tool only works under orthogonal projection. The "Back One Point" is only available before the
measurement is stopped.

Brief: This tool is applicable to all data types supported by LiPowerline, which calculates the projected
area within the polygon region. Current window will switch to Orthogonal Projection automatically for 3D
data.



Angle Measurement

Usage

Click Point Cloud > Measurement > Angle

Steps

3D View:
1. Select the reference point of angle measurement by left-clicking.
2. Select the measurement point by double-clicking. The pitch angle between the reference point and the

measurement point will be rendered in the scene and the measurement result is displayed in a label as
follows.

2D View:

1. Select the first point of angle measurement by left-clicking.
2. Select the second point of angle measurement by left-clicking.
3. Select the third point of angle measurement by double-clicking. The projection angle of the three points

on the horizontal plane will be rendered in the scene and the measurement result is displayed in a label
as follows.

Brief: This tool is applicable to point cloud data, raster data and model data, which calculates the angle
of pitch between two points in 3D view and calculates the projection angle of three points on the
horizontal plane in 2D view.



Click the right mouse button, three context menus will pop up. The menu "Back One Point" is used to go
back to the previous step. The menu "Clear Measure" is used to clear the measurement result. The
menu "Quit Measure" is used to exit the measure tool.

Note: This tool only works with point cloud data, raster data and model data. The "Back One Point" is only
available before the measurement is stopped. The tool is available in the profile window too.



Height Measurement

Usage

Click Point Cloud > Measurement > Height

Steps

1. Select the reference point of height measurement by left-clicking.
2. Select the measurement point by double-clicking. The relative height difference between the reference point

and the measurement point will be rendered in the scene and the measurement result is displayed in a label
as follows.

Click the right mouse button, three context menus will pop up. The menu "Back One Point" is used to go
back to the previous step. The menu "Clear Measure" is used to clear the measurement result. The menu
"Quit Measure" is used to exit the measure tool.

Note: This tool only works with point cloud data and model data. The "Back One Point" is only available
before the measurement is stopped. The tool is available in the profile window too.

Brief: This tool is applicable to point cloud data and model data, which calculates the relative height
difference between two points.



Volume Measurement

Usage

Click Point Cloud > Measurement > Volume

Steps

1. It is suggested to adjust the window to top view before the tool is used. Select at least three points to
generate the reference plane for volume calculation by left-clicking. Select the last point by double-clicking.
The border of the selected region will be rendered in red and the dialog "Volume Measure" will pop up.

2. Set the cell size.
3. Set the reference plane of volume measurement. The options include minimum value, mean value and

custom value.
4. Click the "Compute" button to generate the measurement result. The corresponding volume will be rendered

in the scene, as shown below.

Brief: This tool is applicable to point cloud data and model data, which calculates filling, cutting and total
amount relative to a reference height. It's commonly used in volume measurement of coal pile and hull.



5. Click the "Export" button to export the result in *.pdf or *.txt format.

Settings

Cell Size: It defines the smallest unit size for calculation. The smaller the value is, the more accurate the
calculation is.
Basic Height: It defines the reference plane to calculate filling and cutting.

Minimum (Default): Use the minimum height of the selected points as the height of the reference plane.
Mean: Fit the best plane according to the selected points.
Custom: This value is specified by the user.

Note: This tool only works with point cloud data and model data in 3D view.



Density Measurement

Usage

Click Point Cloud > Measurement > Density

Steps

1. Active window is adjusted to orthogonal projection automatically when this tool is started. Then the dialog
"Density" pops up.

2. If the option "Width" is checked, the width value can be manually input, and the height value will be set to the
same as the width value, then the area value will be decided by "Width" and "Height". The measurement
region can be selected by left-clicking.

3. If the option "Width" is unchecked, the width value and the height value will be decided by the size of the
rectangle that is drawn interactively by left-clicking the upper left corner and the lower right corner. The area
value will be decided by "Width" and "Height". The rectangle will be rendered in the scene and the
measurement result is displayed in a label as follows.

Settings

Width: It defines the width of the reference rectangle.
Height: It defines the height of the reference rectangle.
Area: It defines the area of the reference rectangle.

Note: This tool only works with point cloud data and model data under orthogonal projection.

Brief: Point density is an important metric to measure the quality of point cloud data. The average
number of points per square meter can be counted with this tool.



Model Display
Set the display mode of models in current active window.

Show Model

Show Triangle

Show Point



Show Model

Steps

1. Click this function, the models in the current active window will display in model, as shown in the figure
below:

Settings

Shortcut key: Press the "W" key to switch the display mode between model, triangle and point.

Note: The model types for this function includes LiTIN, LiModel, IVE and other model types.

Brief: Set model files in the current window to display in model type.



Show Triangle

Steps

1. Click this button, the models in current active window will display as triangle mesh, as shown in the figure
below:

Settings

Shortcut key: Press the "W" key to switch the display mode between model, triangle and point.

Note: The model types for this function includes LiTIN, LiModel, IVE and other model types.

Brief: Switch display mode of models in current window to triangle mesh mode.



Show Point

Steps

1. Click this button, the models in current active window will display as points, as shown in the figure below:

Settings

Shortcut key: Press the "W" key to switch the display mode between model, triangle and point.

Note: The model types for this function includes LiTIN, LiModel, IVE and other model types.

Brief: Switch display mode of models in current window to point mode.



Profile Tools
The profile window provides many tools for users to observe, measure, and even change data properties from
specific angles, such as modifying the category of point cloud data.

2D Profile

3D Profile

After enabling this function, the origin cloud display window will be fixed in top view mode and support
users to arbitrarily delineate a rectangular area in the window. After determining the delineated area, a
side view of the area will be displayed in an independent section window, where users can select the
tools in the top toolbar to operate on point cloud data. Close the independent window to exit 2D section
editing. The 2D section editing view is shown in the following figure.

After enabling this function, a toolbar will be displayed at the top of the origin cloud display window, and
you can directly operate on point cloud data in the selection area of the window. Click on the far right
corner of the top toolbar  to exit 3D profile editing. The 3D section editing view is shown in the
following figure.



Top Toolbar

In the process of point cloud processing, due to the limitations of automatic algorithms, many functions cannot
fully meet the requirements. In this case, the profile function can be used to manually edit point cloud data. The
tools at the top of the profile window are as follows.

Auto Hide

Profile

Auto Save

Views

Measure Tool

Automatic Profile

Manual Classify

Settings

Polygon Selection

Rectangle Selection

Circle Selection

Polyline Above Selection

Polyline Below Selection

Continous Brush

Save Results



Cancel

Profile and Angle/Height Measurement Tool

Angle Measurement, Height Measurement and Pick Point are available in Profile window.

Profile and Strip Alignment

When doing strip alignment, users need to check data misalignment among strips caused by Heading/Pitch/Roll
angles.

For example, the picture below shows the data misalignment before doing strip alignment.

During the strip alignment process, users can check alignment effect by setting different parameters in profile
window.



When users are happy with alignment effect in profile window, the point cloud can be transformed according to
the current parameters and written directly to disk.

Besides, users can use measurement tools in profile window to help adjusting Heading/Pitch/Roll angles. Please
refer to Strip Alignment for detailed information.

Profile and Powerline

In powerline module, users need to classify point cloud into different classes, such as tower, conductor,
dangerous point, vegetation etc. Limited by auto classification algorithm, manual editing is necessary for higher
accuracy.

After clipping and classifying the powerline data, users can check and modify classification result in profile
window.



Auto Hide
Hide Profile Toolbar.

Steps

1. (Optional)Click to hide profile toolbar automatically.
2. (Optional)Click to fix toolbar.

Note: When Auto Hide function is prohibited, the toolbar will be floating on the top of profile window. In
contrast, the toolbar will hide after a few seconds and appear again when cursor moves to the top. This
function is especially suitable for small screen and tight space.



Profile

Summary

Steps

1. Click  profile.

2. After clicking the left mouse button to confirm the endpoints in the section window (please confirm at least
three endpoints), double-click the left mouse button to delineate the area, as the picture below.

 

Under the 3D profile editing function, an area can be delineated and only the point cloud of that area can
be displayed in the window.



Auto Save Settings

Summary

Steps

1. Click Display the automatic save settings interface, as shown in the following figure.

2. Check "Auto Save" and set a time interval before clicking "OK". The default time interval is 5.00 minutes.

The time interval can be set to automatically save the executed operations for point cloud classification.
Note: All operations for point cloud classification are temporary and must be saved before they can take
effect.



View

Summary

Steps

1. By default, the profile window shows the front view of selection area. Users can click drop-down menu  to
change the view.

2. (Optional)Click to choose front view.

3. (Optional)Click to choose back view.

4. (Optional)Click to choose left view.

5. (Optional)Click to choose right view.

Note: If users are interested to view selection area from other view, they can click  to activate rotation
function in profile window. After activation, users can rotate the selection area by any random angle.

Unlike general 3D viewer, the profile window does not support rotation by default. There are four views
can be chosen: front view, back view, left view and right view.



Measurement Tool

Summary

Steps

1. Left click to pick up the first end point.

2. Move mouse and double click to pick up another end point.

Different from the general measurement, the default is the orthogonal projection in the profile window.
After clicking two points, users can easily calculate the horizontal and vertical distances in the current
view. When rotation function in the profile window is not enabled, the frustum axis is always vertical to
the Z axis and parallel to the horizontal plane. The vertical and horizontal distances under this condition
can be very useful in some scenarios. For example, users can use this information for parameter
estimation before strip alignment.



Automatic Profile

Summary

Steps

1. Click Display the automatic segmentation profile interface, as shown in the following figure.

2. Set the start index, end index, and segment buffer of the tower.

3. (Optional) The previous section/next section can directly cut the entire tension section line.

4. (Optional) The previous tower/next tower will only be cut for the next section.

5. (Optional) Fixed selection area width. Users can fix the width to move
the position of the selection area. Click on the circular checkbox on the left to turn it solid. After setting the
width value (in meters), click to move the selection area forward with a fixed width, click to move the
selection area back with a fixed width.

6. (Optional) Rotate the selection area. Users can rotate the selection area at a fixed
angle. After setting the angle value (angle system, between -360~360), you can click to rotate the
selection area.

Under the 2D profile editing function, the point cloud is automatically cut based on the starting and
ending tower numbers.



Manual Classification

Summary

Steps

1. Click to set From Class and To Class.

By default, the classes are arranged in the LAS white paper. Users can also select a class and click the
button on the right side of the interface to adjust the order: Up Down Top Bottom Users can
also double click the class and rename it(Not including specific classes 0-8).

1. Choose a suitable selection tool and classify manually:

Polygon: Suitable for random polygon or complex concave polygon. For example, a tree or a building.
Use Parity Ruleto check if the feature is selected.

Rectangle: Suitable for features with simple shapes. Compared to polygon selection, the edges of a
rectangular selection can only be parallel to the corresponding edges of the window.

Circle: Circle selection is convenient for some circumstances. For example, a circle pool.

Above Polyline: Point clouds above the polyline will be selected.

Below Polyline: Point clouds below the polyline will be selected.

2. (Optional)Press hot key Ctrl+Z to undo last operation. Or click  to clear all temporary operation.

3. After all class modifications are done, click  to save the modification.

Note: After the algorithm automatically classifies, manual inspection is required to ensure accuracy.

Note: All operations related to point cloud classification are temporary and must be saved before they can
take effect.

Most of the tools provided by the profile window are integrated on the toolbar. These tools can be used
for manual classification.

https://en.wikipedia.org/wiki/Even%E2%80%93odd_rule


Select Tools

Select and save point clouds in interest area.

Polygon Selection

Rectangle Selection

Sphere Selection

Subtract Selection

In Cut

Out Cut

Save Cut Result

Cancel Selection



Polygon Selection

Usage

Click Tool > Cut Point Cloud > Polygon Selection

Steps

1. Click the Polygon Selection button to activate this function (Click again if you want to deactivate it).

2. Add polygonal vertices by left click. At least 3 vertices are needed to form a closed loop.

3. (Optional) Delete added vertices in reverse order by right click, if some of them are unwanted.

4. Left double click to add the last vertex. The selected points in the polygon area are highlighted.

Brief: Select point cloud data in polygon area.



5. (Optional) Combine multiple selections.



6. (Optional) Remove unwanted points from the selected, if Subtract Selection is active. The removed points
are no more highlighted.



Shortcut Key: Press Ctrl + Z to undo the selection operation.

Note: This function is only applicable to point cloud data.



Rectangle Selection

Usage

Click Tool > Cut Point Cloud > Rectangle Selection

Steps

1. Click the Rectangle Selection button to activate this function (Click again if you want to deactivate it).

2. Add the first vertex by left click. Then move cursor to adjust rectangle size.

3. (Optional) Delete the first vertex by right click, if it's unwanted.

4. Left double click to add the second diagonal vertex. The selected points in the rectangle area are highlighted.

Brief: Select point cloud data in rectangle area.



5. (Optional) Combine multiple selections.



6. (Optional) Remove unwanted points from the selected, if Subtract Selection is active. The removed points
are no more highlighted.



Shortcut Key: Press Ctrl + Z to undo the selection operation.

Note: This function is only applicable to point cloud data.



Sphere Selection

Usage

Click Tool > Cut Point Cloud > Sphere Selection

Steps

1. Click the Sphere Selection button to activate this function (Click again if you want to deactivate it).

2. Add the center point of sphere by left click. Then move cursor to adjust radius.

3. (Optional) Delete the center point by right click, if it's unwanted.

4. Left double click to confirm the radius. The selected points in the sphere are highlighted.

Brief: Select point cloud data in sphere.



5. (Optional) Combine multiple selections.



6. (Optional) Remove unwanted points from the selected, if Subtract Selection is active. The removed points
are no more highlighted.



Shortcut Key: Press Ctrl + Z to undo the selection operation.

Note: This function is only applicable to point cloud data.



Subtract Selection

Usage

Click Tool > Cut Point Cloud > Subtract Selection

Steps

1. Activate one of the geometric selection tools (Polygon Selection, Rectangle Selection or Sphere Selection)
before using Subtract Selection. Then please activate/deactivate Subtract Selection by left click.

2. (Optional) If Subtract Selection is inactive, multiple selections can be combined.

Brief: This function is effective on one of the geometric selection tools (Polygon Selection, Rectangle
Selection or Sphere Selection). If Subtract Selection is inactive, more points can be added to the
currently selected. If active, unwanted points can be removed from the currently selected.





3. (Optional) If Subtract Selection is active, unwanted points can be removed from the currently selected.





Shortcut Key: Press Ctrl + Z to undo the last operation.

Note: This function is only applicable to point cloud data.



In Cut

Usage

Click Tool > Cut Point Cloud > In Cut

Steps

1. Select points using Polygon Selection, Rectangle Selection or Sphere Selection. The selected points are
highlighted.

2. Click the In Cut Button. The result is shown in the following figure.

Brief: Cut point clouds after selection. The selected points are kept while the unselected are hidden.



3. (Optional) You can repeat this function several times to get the result you need.

Shortcut Key: Press Ctrl + Z to undo the cut operation. The corresponding selection is also cancelled.

Note: This function is only applicable to point cloud data.



Out Cut

Usage

Click Tool > Cut Point Cloud > Out Cut

Steps

1. Select points using Polygon Selection, Rectangle Selection or Sphere Selection. The selected points are
highlighted.

2. Click the Out Cut Button. The result is shown in the following figure.

Brief: Cut point clouds after selection. The selected points are hidden while the unselected are kept.



3. (Optional) You can repeat this function several times to get the result you need.

Shortcut Key: Press Ctrl + Z to undo the cut operation. The corresponding selection is also cancelled.

Note: This function is only applicable to point cloud data.



Save Cut Results

Usage

Click Tool > Cut Point Cloud > Save Cut Results

Steps

1. Click this button after successful cut operations(In Cut, Out Cut). An interface is shown as follows.

2. Select source point cloud files, from which new files are generated.

3. (Optional) Check/Uncheck the option "Merge files into one" according to demand.

4. Specify the output path. New file names are created based on the source file names and system time. An
example of new file name is "SourceFileName_CutResult_SystemTime.LiData".

5. After data saving, a dialog will ask if you want to add the new files to current project.

6. Click Yes or No according to demand.

Brief: Save results after cut operation as new point cloud files.



Cancel Selection

Usage

Click Tool > Cut Point Cloud > Cancel Selection

Steps

1. Click this button after selections(Polygon Selection, Rectangle Selection, Sphere Selection) or cut
operations(In Cut, Out Cut). All the selections and cut operations will be cancelled.

Note: This function is only applicable to point cloud data.

Brief: Cancel all the selections and cut operations.



Project Management Window
The data list in the project is managed by layers and windows separately.

Layer Management

Point Cloud

Raster

Vector

Table

Model

Window Management

Note: The data loaded into the project can be displayed in single/multiple window(s), or not displayed at all.
Please drag data to a certain window for display.



Layer Management

Brief

The project layers manage the data in the software by group, whose types include Point Cloud, Raster,
Vector, Table, and Model.

Point Cloud: Proprietary LiData File(*.LiData), LAS File(*.las,*.laz), ASCII
File(*.txt,*.asc,*.neu,*.xyz,*.pts,*.csv);
Raster: Image File(*.tif,*.jpg);
Vector: Vector File(*.shp);
Table: Table File(*.csv);
Model: Proprietary Model File(*.LiModel), Proprietary TIN File(*.LiTin), OSG Model
File(*.osgb,*.ive,*.desc,*.obj);

In the project layers the user can remove data from the software, show/hide data in all windows by
checking/unchecking the box before data node (or data type node). The data can be dragged from data node to
different windows for display. The context menu (i.e. right-click menu) of data node, which differs depending on
data types, is mainly used for data query, display, statistics, export, and removal, etc.

Click the  button to show the project layers as follows:

Context Menu

Open the context menu by right clicking data type or data.

Context menu of point cloud
Context menu of raster
Context menu of vector
Context menu of table
Context menu of model

Note: The context menu of layer management is effective on all windows, while the context menu of
window management is only effective on specified window.



Point Cloud Context Menu

Brief

The context menus are used to for data import, removal, query, display, statistics, export, etc.

Data Type Context Menu

The user can open this menu by right clicking the point cloud data type.

Import Data: The point cloud data formats supported by LiPowerline include LiData (*.LiData), LAS (*.las,
*.laz), ASCII (*.txt, *.asc, *.neu, *.xyz , *.pts, *.csv) and PLY (*. ply). The LiData is the proprietary point cloud
data format, on which the point cloud processing are based. Other imported formats of LAS, ASCII and PLY
will be converted to LiData for subsequent processing. This function is the same as the tool  Add Data.
Remove All: Remove all the point cloud data from the project.

Data Context Menu

The user can open this menu by right clicking a point cloud data object.

Info: View the basic information of point cloud data as shown below. Click the Export button to export the
information as a *.txt file.

View Mode: Select the display mode of point cloud data between the following types.



Display by Height: The interface is shown as follows. The value range of display can be stretched by
minimum/maximum or standard deviation in order to improve the visual effects.

The curve can be saved in *.pdf format. Click the button "Save Curve" to pop up the following interface.
Set the width, height, resolution, output path of the curve and click "OK" button to save the curve to local
disk.

The visual effects are consistent with the tool  Display by Elevation.

Display by Intensity: The interface is shown as follows. The value range of display can be stretched by
minimum/maximum or standard deviation in order to improve the visual effects.



The curve can be saved in *.pdf format. Click the button "Save Curve" to pop up the following interface.
Set the width, height, resolution, output path of the curve and click "OK" button to save the curve to local
disk.

The visual effects are consistent with the tool  Display by Intensity.

Display by Class: This function is the same as the tool  Display by Class.
Display by RGB: This function is the same as the tool  Display by RGB.
Display by Return: This function is the same as the tool  Display by Return.
Display by Time: This function is the same as the tool  Display by Time.
Display by TreeID: This function is the same as the tool  Display by TreeID.
Display by Selected: Select user-defined color to display the point cloud data. The interface and the
visual effects are shown below.



Display by Blend: This function is the same as the tool  Display by Blend.

Display by Mix: This function is the same as the tool  Display by Mix.
Zoom to Layer: Calculate the bounding box of the current point cloud data. All the windows, in which the
data object is loaded, will show full extent of the bounding box.
Restatistics: Recalculate the Mean Z, Std Z, Mean Intensity and Std Intensity of point cloud data. This
function is used to repair older versions of LiData which may contain incomplete information.
Export: Export the point cloud data to LAS (*.las, *.laz), ASCII (*.txt, *.asc, *.neu, *.xyz, *.pts, *.csv) and PLY
(*.ply) format. This function is the same as the tool  Export.
PCV: Process the point cloud data with PCV to improve the visual effects.
Point Size: The point size of each point cloud data object can be set separately or set uniformly according to
the global settings. The shape of points can be set to circle or square. The interface is shown as follows.



For global point size settings, see the usage of the tool  Configure Point Size.
Remove: Remove the selected point cloud data from the current project. This function is the same as the
tool  Remove.

Settings

Display by Height:
Color Bar: The colorbar supports several uniformly varying color intervals for color mapping.
Stretch: The stretch methods of the histogram.

Minimum and Maximum (Default): Apply a linear stretch based on the minimum and maximum
pixel values, with the minimum and maximum pixel values as the endpoints for the histogram. For
example, the minimum and maximum pixel values of the image could be 2488 and 2656
respectively. The values can be stretched linearly between 0 and 255. Distributing pixel values over
the entire histogram range, the brightness and contrast of the image are increased and features in
the image are easier to distinguish.
Std deviation: Apply a linear stretch between the pixel values defined by the std deviation (n)
value. For example, the minimum and maximum pixel values of the image could be 2488 and 2656
respectively. If the value of standard deviation (n) is defined as 2, then the values beyond 2
standard deviation become 0 or 255, the remaining values stretch between 0 and 255.

Display by Intensity:
Stretch: The stretch methods of the histogram.

Minimum and Maximum (Default): Apply a linear stretch based on the minimum and maximum
pixel values, with the minimum and maximum pixel values as the endpoints for the histogram. For
example, the minimum and maximum pixel values of the image could be 2488 and 2656
respectively. The values can be stretched linearly between 0 and 255. Distributing pixel values over
the entire histogram range, the brightness and contrast of the image are increased and features in
the image are easier to distinguish.
Std deviation: Apply a linear stretch between the pixel values defined by the std deviation (n)
value. For example, the minimum and maximum pixel values of the image could be 2488 and 2656
respectively. If the value of standard deviation (n) is defined as 2, then the values beyond 2
standard deviation become 0 or 255, the remaining values stretch between 0 and 255.

Save Curve:
Width: The width of the saved curve.
Height: The height of the saved curve.
Resolution: The resolution of the saved curve.
Output path: The output path of the saved curve.

Point Size:



Circular Points (Optional): Set the shape of the point to circle or square.
Specified set (Optional): Set the point size of the specified point cloud data separately.
Use global set (Optional): Set the point size of the specified point cloud data with global settings.



Raster Context Menu

Brief

The context menus are used to for data import, removal, query, display, etc.

Data Type Context Menu

The user can open this menu by right clicking the raster data type.

Import Data: The raster data formats supported by LiPowerline include TIF and JPG. The function is the
same as the tool  Add Data.
Remove All: Remove all the raster data from the project.

Data Context Menu

The user can open this menu by right clicking a raster data object.

Info: View the basic information of raster data, including file path, description, X size, Y size, bands count,
pixel size, invalid value of each band, projection, etc. The interface is shown below.

Histogram: View the histogram of the raster data, where the values of each band can be stretched
separately. The raster data is displayed in gray color bar by default. Select an appropriate color bar in the
combo box. Click the button "Apply", the raster data in the scene will be rendered according to the above
settings, as shown below.



Select the stretch method and generate the corresponding histogram, as shown below.

The button "Default" is used to restore the default settings. The button "Recompute Histogram" is used to
calculate all the pixel values of the raster data again. The sampling points are 250000 by default. When the
pixel size of the raster data exceeds the value, the statistical results may be inaccurate, then this button is
needed. The histogram can be saved in *.pdf format. Click the button "Save Histogram" to pop up the
following interface. Set the width, height, resolution, output path of the histogram and click "OK" button to
save the result to local disk.



Zoom to Layer: Calculate the bounding box of the current raster data. All the windows, in which the data
object is loaded, will show full extent of the bounding box.

Zoom to Native Resolution (100%): Display the raster data in 1:1 ratio according to the resolution of the
raster data.
Remove: Remove the selected raster data from the current project. This function is the same as the tool 
Remove.

Settings

Histogram:
Stretch: The stretch methods of the histogram.

Minimum and Maximum (Default): Apply a linear stretch based on the minimum and maximum
pixel values, with the minimum and maximum pixel values as the endpoints for the histogram. For
example, the minimum and maximum pixel values of the image could be 2488 and 2656
respectively. The values can be stretched linearly between 0 and 255. Distributing pixel values over
the entire histogram range, the brightness and contrast of the image are increased and features in
the image are easier to distinguish.
Percent Clip: Apply a linear stretch between the pixel values defined by percent clip minimum and
percent clip maximum. For example, the minimum and maximum pixel values of the image could be
2488 and 2656 respectively. Percent clip minimum and percent clip maximum values are 0.02 and
0.98, values less than 0.02 mean the values between 2488 and 2492, values more than 0.98 mean
the values between 2652 and 2656, values between 2488 and 2492 become 0, values between
2652 and 2656 become 255, the remaining values are between 0 and 255.
Std deviation: Apply a linear stretch between the pixel values defined by the std deviation (n)
value. For example, the minimum and maximum pixel values of the image could be 2488 and 2656
respectively. If the value of standard deviation (n) is defined as 2, then the values beyond 2
standard deviation become 0 or 255, the remaining values stretch between 0 and 255.
Histogram Equalization: Apply a non-linear stretch between the pixel values, redistribute the pixel
values so that the pixel values in a certain range is approximately equal. This method works well
when there are a lot of pixel values that are closely grouped together.



Color Bar: The colorbar supports several uniformly varying color intervals for color mapping.
BandList: Select a band from the band list to draw the histogram.
Show all bands (Optional): Whether to show all bands.

Save Curve:
Width: The width of the saved curve.
Height: The height of the saved curve.
Resolution: The resolution of the saved curve.
Output path: The output path of the saved curve.



Vector Context Menu

Brief

The right button menu of vector data in the layer management tree mainly includes import and export vector data,
it also contains information, show attribute table, zoom to layer, color by elevation, and display by selected for
single vector data.

Data Type Context Menu

Import Data: The import data format is SHP (*.shp), the same with the function , see Add Data. Import
vector data generate by point cloud to contour, as shown below:

Remove All: Remove all vector data from LiPowerline.

Data Context Menu

Info: View the basic information of vector file, including file path, elements count and bounding box.

Open Attribute Table:Displays the property sheet information of the vector data. The result is shown in the



figure:

Zoom to Layer: Calculates the bounding box of the current vector data, and all windows that contains this
file will display globally in this bounding box range.
Color by Elevation: Display the vector data by z value based on selected color bar.
Display by Selected: Display the vector data in fixed color, as shown in the following figure:



Remove: Remove vector file from LiPowerline.

Note: Except "Import Data", the other function in context menu work on all windows that contains this
vector file.



Tables Context Menu

Brief

The right button menu of table data in the layer management tree mainly includes import and export table data, it
also contains information, attribute, zoom to layer, and removal for single model data.

Data Type Context Menu

Import Data: The import data format is CSV(*.csv). If click this function, pop-up the dialog, select data type
as "Point" or "Circle", and set the specified field X, Y, Z, Diameter (if the data type is circle), and check
whether to show labels.

Select data type as "Point", the table file displayed as below:



Select data type as "Circle", the table file displayed as below:



Remove All: Remove all table files from LiPowerline.

Data Context Menu

Info: View the table's basic information, including path, the number of elements, the minimum and the
maximum of X, Y, Z values.

Attribute: Display the contents of the table. As shown in the following figure, double click specific row, the
window will go to the position.



Zoom to Layer: Calculates the bounding box of the current table data, and all windows that contains this file
will display globally in this bounding box range.
Remove: Remove the selected file from LiPowerline.

Note: Except "Import Data", the other function in context menu work on all windows that contains this table
file.



Model Context Menu

Brief

The right button menu of model data in the layer management tree mainly includes import and export table data,
it also contains information, display setting, zoom to layer, restatistics, export for single model data.

Data Type Context Menu

Import Data: The model formats that LiPowerline supported includes: Model (.LiTin), LiModel (.LiModel),
OSG data (.osgb, .ive, .desc, .obj). Among them, the LiTIN format and LiModel format are LiPowerline
defined model format. This function is the same with the function  , see Add Data.
Remove All: Remove all model files from LiPowerline.

Data Context Menu

Info: View the basic information of model file, including the path, resolution, the minimum and maximum of X,
Y, Z. This function just for LiTin and LiModel file.

View Mode: Set the model file's display mode, including display by elevation, display by texture, display by
light. if select "Display by Elevation", pop-up the selection of color bar dialog, the display effect as below:



The user can [generate models with texture](../DataManagement/Conversion/ConverttoTextureLiModel.md).
An example of "Display by Texture" is shown below:



if select "Display by Lighting", pop-up the selection of color bar dialog, the display effect as below:



Zoom to Layer: Calculates the bounding box of the current model data, and all windows that contains this
file will display globally in this bounding box range.
ReStatistics: Recalculate basic information such as Min X Y Z and Max X Y Z. In general, if you edit the
LiModel data, such as smooth height or repair height, you can use the Restatistics function.
Export: This function is only for LiTin and LiModel file, and the export format is TIF. In General, after 3D
visualization editing of LiModel and LiTIN which generated by DEM, it is necessary to convert the editing files
to TIF format file.
Remove: Remove the selected model data from viewer window or project.

Note: Except "Import Data", the other function in context menu work on all windows that contains this
model file.



Window Management

Brief

The project windows manage all windows(i.e. viewers) and data in windows. The user can remove data from
window, edit display order by dragging data node, show/hide data in specified window by checking/unchecking
the box before window/data node. The context menu(i.e. right-click menu) of data node, which differs depending
on data types, is mainly used for data query, display, statistics, export, and removal, etc. These functions are
effective on specified window.

Click the  button to show the project windows as follows:

Context Menu

Open the context menu by right clicking window or data.

Window Context Menu

Remove All: Remove all data from the selected window.

Data Context Menu

Point Cloud Data Context Menu: Same as the context menu of point cloud data in layer tree.
Raster Data Context Menu: Same as the context menu of raster data in layer tree.
Vector Data Context Menu: Same as the context menu of vector data in layer tree.
Table Data Context Menu: Same as the context menu of table data in layer tree.
Model Data Context Menu: Same as the context menu of model data in layer tree.



Note: The context menu of window management is only effective on specified window, while the context
menu of layer management is effective on all windows.



Viewers
This menu provides operations to create, close and arrange windows.

New Window

Close

Close All

Tile Windows

Cascade Windows



New Window
Brief: Create new window in the current project.

Steps

1. Click the menu Viewers > Add Window. The result is as follows.

Shortcut Key: Ctrl+F3



Close
Brief: Close the active window in the current project.

Steps

1. Click the menu Viewers > Close. The active window will be closed.

Shortcut Key: Ctrl+F4



Close All
Brief: Close all windows except for the power line window in the current project.

Steps

1. Click the menu Viewers > Close All. All windows are closed except for the power line window.



Tile Windows
Brief: Rearrange all the viewers in tiled fashion.

Steps

1. Click the menu Viewers > Tile Windows. The result is as follows.

Note: This function needs at least one window in the current project.



Cascade Windows
Brief: Rearrange all the viewers in cascaded fashion.

Steps

1. Click the menu Viewers > Cascade Windows. The result is as follows.

Note: This function needs at least one window in the current project.



Display
Display menu of the software.

Render to File

Save to Video

Language

Show Legend

Show Coordinate Axis

Shaders

EDL

Glass

Class Setting Options



Render to File
Brief: This tool can render the current 3D view as an image file (*.bmp format is supported). The user can also
change the zoom factor, which affects the final image size.

Steps

1. Adjust the 3D view to get the scene you want to render.
2. Click Display > Render to File and you will get a dialog shown as follows.

3. (Optional) Set the zoom factor.
4. (Optional) Check or uncheck the "Don't scale features (points size)" according to demand.
5. (Optional) Set the Output path.
6. Click "OK" to get the rendered image.

Settings

Input: Current active window.
Zoom: Default value is 1 (original image size). You can increase the rendered image size by setting larger
zoom factor (the resulting size is displayed on the right).
Don't scale features (points size): By default unchecked. If it is checked, the rendered point size won't be
increased, even if the zoom factor is greater than 1.
Output path: The file path to which the image will be saved.



Save To Video
Brief: Record the current window screen and save as video (mp4 and avi formats are supported).

Steps

1. Click Display > Save To Video, an interface will show as follows.

2. Set the frame rate(default is 25 frame per second).
3. Set the bit rate.
4. Set the output path of video.
5. Click "OK". The following interface is shown on the left-top corner of the current window.

6. Change the camera to get the scene which you want to record.
7. Click "Stop" or "Start"

Stop: Pause the current record.
Start: Recover the record.

8. Click "End" to finish recording. The video will be saved.

Settings

Input: the scene of the window for record.
Frame Rate: The frequency (rate) at which consecutive images called frames appear on a display.
Bit Rate: Refers to the number of bits used per unit of playback time to represent the video. Lower bit rate
may result in lower resolution of the picture and has mosaics on the picture, and however the higher bit rate
may lead a larger video file.
Output path: The file path to which the video will be saved.



Language
The supported language in LiPowerline is English.

Steps

1. Click Display > Language > English to switch menu language. It will be effective after software restart.

2. Click Yes to restart the software immediately; Or click Cancel to restart later.



Show Legend
Brief: Show/hide the legend in display windows.

Steps

1. Click Display > Show Legend to check/uncheck this option.
Display window without legend:

Display window with legend:



Show Coordinate Axis
Brief: Show/hide the coordinate axis in display windows.

Steps

1. Click Display > Show Coordinate Axis to check/uncheck this option.
Display window without axis:

Display window with axis:



Shader
The software currently offers two special shaders: EDL and Glass. They can be combined with other display
modes(such as display by elevation and display by intensity) to enhance display effect.

EDL

Glass



EDL Shader
Brief: The EDL shader can enhance the rendering effect of depth discontinuity. With this tool the user can
distinguish the foreground easily from the background .

The EDL effect can be enabled/disabled for individual display window. An example is shown below. The left
window displays point cloud data by elevation without EDL effect. The right window is with EDL effect.

Note: The EDL Shader is only applicable to point cloud data.

https://blog.kitware.com/eye-dome-lighting-a-non-photorealistic-shading-technique


Glass Shader
Brief: With the glass shader point cloud object appears translucent.

This effect can be enabled/disabled for individual display window. An example is shown as follows.

Note: The Glass Shader is only applicable to point cloud data.



Class Setting Option
Brief: The class setting of LiPowerline complies with the ASPRS standard. As show in the figure below, the class
0-9 and 12 are fixed class type, the 10th, 11th, and 13th-31th class are reserved class. The fixed class can't be
modified, and the reserved classes are customizable. This function set the order of classes according to the
requirements and it will be displayed in order on the dialog and profile function.

Steps

1. Click Display > Class Setting Option, open the dialog (default list of classes):



class settings in the classification function interface are as shown in the following figure:



The class setting interface in the profile is shown in the following figure:



2. Select one class, click the button  to move down one step, click the button  to move to the bottom, click
the button  to up one step, click button  to move to the top; or mouse drag the class to a fixed position.



Taking Reserved15 class as an example, set the reserved15 as the highest priority, the class settings in the
classification function interface and the class setting interface in the profile are shown in the following figure:





3. Double click the class in the class list to setting the class's name. As shown below:

4. Click "Default" to restore the class setting option to default.
5. Click "OK" to save the current class setting list.



6. Click "Cancel" to cancel the current class priority setting and restore to the previous setting.



Strip Alignment
Airborne LiDAR measurement system is influenced by various error sources, of which the systematic errors (the
largest error source) cause the systematic deviation of laser footprint coordinates. Mounting of LiDAR
measurement system requires the axis of the scanning reference coordinate system and inertial platform
reference coordinate system to be parallel. However, while mounting of system, it is not guaranteed that they are
parallel, resulting in the so-called systematic boresight error. In the Strip Alignment module, airborne LiDAR point
clouds of overlapping strips can be aligned through boresight calibration.

Strip Alignment

Control Point Report

Adjust Elevation

Strip Quality Analysis

Elevation Difference Inspection Quality Analysis

Overlap Quality

Density Quality



Strip Alignment
Brief: In the Strip Alignment module, airborne LiDAR point clouds of overlapping strips can be aligned through
boresight calibration. This module includes the following functions: loading/deleting/splitting trajectories, cutting
point cloud according to trajectories, matching trajectory and point cloud, transforming point cloud based on
boresight calibration parameters, eliminating point cloud redundancy (cut overlap), etc.

Usage

1. Open strip alignment module. Click Menu > Strip Alignment > Strip Alignment, and the corresponding
interface is shown as follows.

2.  Add Trajectories: After clicking this button, an interface pops up to ask you to set the work directory.

Set the directory and a dialog for adding trajectories will be shown as follows.



LiPowerline supports two formats of trajectory files: POS(*.pos) (text format file) and SBET(*.out)] (binary
format file).

○ POS File Example 1: If the POS file does not contain GridX and GridY information, the user has to specify
following headers (GPS time, longitude, latitude, height, roll angle, pitch angle and yaw angle) for data
columns. An example is shown as follows.

It is required to select the correct projection coordinate system as the following picture.



○ POS File Example 2: If the POS file contains GridX and GridY information, the user has to specify following
headers (GPS time, longitude, latitude, height, roll angle, pitch angle, yaw angle, GridX and GridY) for data
columns. An example is shown as follows.



If the information of GridX or GridY is not correct, the POS File Example 1 can be used.
For both of the two examples, click "Apply" to make the current settings apply on current trajectory file, and
all the trajectory files will be affected by the current settings if you click "Apply all".

3.  Delete Trajectories:

3.1 Select the trajectories to be deleted in the trajectory list.

3.2 Click "Yes" or "No". Current selected trajectories will be removed. While clicking "Yes", the
corresponding trajectory files will be deleted. The figure below demonstrates the effect of the scenes
before and after the deletion of the red trajectory.



Before Deletion

After Deletion
4.  Show Single Trajectory: The color of the selected trajectory will be changed gradually, and then the

trajectory will twinkle several times.

5.  Pick Point: Left click a certain point in the trajectory and the information of this point will be displayed.



6.  Draw Polygon:

6.1 Click the Draw Polygon button to activate this function (Click again if you want to deactivate it).
6.2 Choose the vertexes of the polygon one by one by left click.
6.3 Delete added vertices in reverse order by right click, if some of them are unwanted.
6.4 Left double click to add the last vertex. The polygon will be stored in the "polygon.gv" file under the
work directory. If this file exists, the polygon will be automatically loaded at the step 2.

6.5 The polygon can be modified using left mouse button to select and drag.
7.  Split Trajectories: Click this button to split the source trajectories by polygon. New generated trajectories

will be stored as POS file format in the work directory and named by the GPS starting and ending times of
the trajectory. An example of new file name is "GPSStartTime_GPSEndTime.POS". The effect of cutting is
shown as follows. After this procedure, step 3 can be used to delete undesired trajectories.



8.  Cut Point Cloud Based on Trajectories.
8.1 Click the button to pop up a dialog.

Select the point cloud data files to be cut. Check the "Cut by Trajectories Buffer" and set the Buffer
parameter as desired.
8.2 Click "OK". LiPowerline will cut the point cloud by the trajectories and show the process speed
accordingly. The cutting results will be saved and the name of the point cloud is identical to the
corresponding POS file. A dialog pops up to ask the user whether to load the results or not.

9.  Match Point Cloud and Trajectory: Click this button, the point cloud data and the corresponding
trajectory will be displayed in the same color.



10.  Display Point Cloud by Trajectory: Click the button to pop up a dialog that lists the point cloud files and
the corresponding trajectories. Choose an appropriate color for each trajectory to display.

11.  Transform: Click this button to pop up a dialog.



○ 11.1 This function is applied to correct the Boresight Error, which can be calculated automatically
(Automatic Alignment) or input manually (Manual Alignment).

Automatic Alignment:
Select the boresight error you want to correct, and set the Translation TOL and Rotation TOL. Click
"Calculate" to generate the boresight error automatically and the result will be shown in the "Boresight
Correction" part of the interface. After the calculation of automatic alignment, LiPowerline will figure out the
Alignment Quality. The Alignment Quality will be shown in the "Alignment Quality" tab page. (Theory of
correction based on automatic adjustment.)

Manual Alignment:



Adjust the boresight error manually. (Theory of correction based on manual measurement.) Click "Apply" and
the transformation of error correction will be applied on the selected Transform Type. ○ 11.2 For both
automatic and manual method, correction result can be checked in the profile window.

Before transformation

After transformation
○ 11.3 Buttons on the right of the "Boresight correction" provide the following operations: "loading from file",
"saving to a file" and "cleaning".

○ 11.4 If the alignment effect is satisfied, you can switch Transform Type from the "Loaded Point Cloud" to
"Selected Point Cloud Files". Click "Apply" to finish the transformation.



12.  Cut Overlap: Click this button to set the Cut Overlap Parameters. Click "OK" button, then the redundant
points between the overlapped trajectories will be classified or deleted.



Settings

Parameters of Cutting point cloud based on Trajectories
Buffer: The remaining distance in both sides of trajectory while cutting.

Parameters of Transform
Boresight Error

ΔX/ΔY/ΔZ: Correction parameters of boresight offset error.
ΔRoll/ΔPitch/ΔHeading: Correction parameters of boresight pose error.

Automatic Alignment: It matches corresponding points between strips automatically and calculates
optimal correction value of boresight error via adjustment.

Translation TOL: The maximum translation tolerance of ΔX, ΔY, ΔZ. The default value is 0.05 m.
Rotation TOL: The maximum rotation tolerance of ΔRoll, ΔPitch, ΔHeading. The default value is 5°.
Options: Users can decide whether the 3 translations and 3 rotations are involved in adjustment to
calculate correction values. For most aerial data, it is not recommended to correct ΔZ. In default
state, all the rotations are selected while all the translations are unselected.

Alignment Quality: After automatic alignment calculation, LiPowerline will figure out the alignment
quality and show the result in the alignment quality result tab.

Min Error: Minimum error of matched corresponding points.
Max Error: Maximum error of matched corresponding points.
RMSE: RSE error of matched corresponding points.

Transform Type:



Loaded Point Cloud: The loaded point cloud which is matched with trajectory in LiPowerline. When
the transformation is applied, the corresponding point cloud is modified and the transformation
effect can be shown in real-time. When strip alignment module exits, relevant transformation is
eliminated without saving.
Selected Point Cloud Files: In this type, the file list area on the interface will be activated, users
can choose which point cloud file(s) will participate in the transformation. Then the results will be
saved to the file. It doesn't loss the information even though the strip alignment module exits.

Parameters of Cut Overlap:
Type:

Classify: Classify points into target category and save the result in the original point cloud file.
Delete: Classify points into target category and then delete them from initial point cloud data (Note:
If the input point cloud contains points of target category, they will also be removed).

From Class: Point cloud target category.
Edge: Grid unit size (length) of overlapping area. This parameter is used to rasterize the point cloud
data of the overlapped area.
Density: Smallest point density of grid unit. If the point density is smaller than the defined threshold,
these points will not be classified to redundant points.
By Angle with Trajectory: Angle between point cloud and trajectory. If this angle is larger than the
threshold, the point cloud will be classified to redundant points.
By Scan Angle: If scanning angle is larger than the threshold, point cloud will be classified to redundant
points. (Note: this function can only be used when scanning angle is recorded by point cloud.)

Note:
1. The matching principle of a point cloud file and a trajectory is that: Each GPS time of all the points in the
point cloud is inside the trajectory's GPS time span.
2.In most cases, the effect from X,Y or Z is tiny, while the ground control points are needed for higher
precision of Z value. Therefore, only Roll, Pitch and Heading are selected to take apart in the adjusting by
default.
3. The result may not satisfy if accuracy of the POS data file is not enough, and users can make an manual
alignment based on the result.
4. For Overlapped function, at least two pairs of matched point cloud and trajectories are needed.



Control Point Report

Brief

Control point report tool will create a report about elevation difference of laser point clouds and ground control
points, which can be used to check the elevation accuracy of laser point clouds and improve the height accuracy
of laser point clouds using calculated adjusted values.

Control point file is the text file separated by comma. Every row is composed by 3 columns which are X, Y and Z.
The first row is the header, and please refer to Control Point File Format for specified format. At least 3 control
points are requested to successfully create the control point report.

The output report displays information of elevation difference between used laser point clouds and control points
of elevation, statistic information of height difference like average magnitude, standard deviation, root mean
square, average of elevation difference as well as maximum and minimum height difference.

Usage

Click Strip Alignment > Control Point Report

After computation, the position of every control point can be checked by left double click at any position on the
control point row in order to jump to the location of control point. Using Profile tool can help to check the relative
position between control points and point cloud more intuitively.



Settings

Input Data: Input file can be single point cloud data file or point cloud data set.
From Class (default value is "all class"): User needs to select the point cloud class which is used to check
control point elevation accuracy, and normally point cloud of hard surface such as ground point, construction
point, etc. are chosen.
Max Slope (°, default value is "45"): Maximum terrestrial gradient tolerance. If gradient is larger than this
value, elevation difference will not be computed. Normally control points are chosen at the flat terrain,
therefore if gradient is too steep, the result will be easily affected by wrong information.
Max Triangle (m, default value is "20"): The longest side length of triangle is used to avoiding the large
deviation caused by elevation interpolation. If the side length of triangle is too long, it is indicated that points
of initial category in point cloud area where control points are located are less and calculated error of
elevation difference is large.
Known Points: Input control point file.
Refresh: If the statistical information of height difference in the dialog window such as average range of
elevation difference, standard deviation, RMS, average of elevation difference as well as maximum and
minimum height difference are not shown, click refresh button.
Size Point (default value is "0.10"): The location of control points can be displayed in the window by double
clicking the corresponding data in the list of control point report. The size of point controls the size of control
points shown in the window.
Dz limit (default value is "3"): Set the tolerance of Dz. If Dz is not within the tolerance, show red in order to
inspect elevation difference with large error between point cloud and control points. Maximum tolerance =
Average Dz + Dz × Std Deviation. Minimum tolerance = Average Dz - Dz × Std Deviation.
Calculate: After setting parameters, click this button to calculate elevation difference.
Export: Export control point report file of TXT format. The file contains elevation error information of point
cloud data and statistical information of Dz.



Adjust Elevation

Brief

The elevation of raw laser data is normally represented by ellipsoidal height. Normally these values need to be
transformed to values in regional height system or local height system. For large area, the adjustment of
elevation can not be defined as a mathematical formula. Hence, the model of elevation adjustment is required to
be defined. The algorithm is to build triangular network model using known control point data as well as to
interpolate and correct local points using height anomaly between different height systems. Adjusted elevation
result can be checked according to the Control Point Report.

It is recommended to use control point data containing entire project region to adjust model in order to provide
more accurate elevation information to the project border.

Usage

Click Strip Alignment > Adjust Elevation

Setting

Input Data: Input files can be single point cloud file or point cloud data set.
Input File: Users need to input adjustment model file of control points. This file data can be generated by
tool of Control Point Report.
Output path: Output adjusted point cloud data.



Strip Quality Analysis

Brief

Trajectory Quality Analysis tool checks trajectory quality from the height analysis, speed analysis and flight
attitude analysis.

Usage

Click Strip Alignment > Strip Quality Analysis.

Load trajectory file(s) and set the parameters of height analysis, speed analysis and fight attitude analysis. This
tool supports generating reports for each analysis. Click Export to save the quality report in html format.

Click  to load data. The supported formats of POS files contain *.OUT and *.pos. Click  to clear loaded
data. Click  to clear the loaded POS file(s).

Settings

Height Analysis: Height analysis report contains strip name, max height, min height, height difference,
height variance, mean height and qualified flag of each strip. The Yes is qualified, and No is unqualified. The
mean height of qualified strip is displayed as green, or as red. Click Export button to save the result in html
format.
Design Height (m, default value is "0"): Designed height value.
Height Tolerance (%, default value is "0"): The floating ratio of designed height. For example, 5% denotes
that the qualified height range is between (1- 5%) × designed height and (1 + 5%) × designed height.
Generate Report: Click Generate Report button to save height analysis quality report.



Speed Analysis: The speed analysis report contains strip name, max speed, min speed, speed difference,
speed variance, mean speed and qualified flag of each strip. The mean speed of qualified strip is displayed
as green, or as red. Click Export button to save the result in HTML format.
Design Speed (m/s, default value is "0"): Designed speed value.
Speed Consistency (%, default value is "0"): The floating ratio of designed speed. For example, 5%
denotes that the qualified speed range is between (1- 5%) × designed speed and (1 + 5%) × designed
speed.
Generate Report: Click Generate Report button to save speed analysis quality report.

Flight Attitude Analysis: Flight attitude analysis report contains strip name, max roll, mean roll, max pitch,
mean pitch, strip deformation (%) and qualified flag of each strip. The Yes is qualified, and No is unqualified.
The strip deformation of qualified strip is displayed as green, or as red. Click Export button to save the result
in html format.
Strip Deformation (%, default value is "3"): According to the related data standard, the qualified threshold
of strip deformation is generally set to 3%.
Generate Report: Click Generate Report button to save flight attitude analysis quality report.



Integral Report: Click Full Report button to save the integral report.



Elevation Difference Inspection Quality Analysis

Brief

Elevation Difference Inspection tool analyzes the elevation difference between point clouds.

Usage

Click Strip Alignment > Elevation Difference Inspection Quality Analysis

Settings

Input Data: Input files can be single point cloud file or point cloud dataset. The data to be processed must be
opened in the LiPowerline.
From Class: The point cloud classes used in the elevation difference quality inspection.
Grid Size (m, default value is "1"): The grid size in the point cloud gridding.
Cut off Value (m, default value is "0.5"): The data above the threshold will be ignored. The threshold is
used to remove moving target.
Output Path: The results of elevation difference quality inspection will be exported to the selected folder,
which contains the result of each strip density quality inspection and integral report in HTML format.



Overlap Quality

Brief

Strip Overlap Analysis tool analyzes the overlap between point clouds.

Usage

Click Strip Alignment > Overlap Quality

Settings

Input Data: Input file can be single point cloud file or point cloud dataset. The data to be processed must be
opened in the LiPowerline.
Input POS File: Click  to load data. The supported formats of POS files contain *.OUT and *.pos. Click 

 to clear the loaded data. Click  to clear the loaded POS file(s).
Overlap Threshold (%, default value is "25"): The overlap threshold between two adjacent strips.
Output Path: The results of overlap quality inspection will be exported to the selected folder, which contains
the results of each strip overlap quality inspection (in SHP format, the property table contains the profile
check result which may be qualified, unqualified, non-overlapping or boundary) and integral report in html
format.



Density Quality

Brief

Density Quality Analysis tool analyzes the density of point cloud.

Usage

Click Strip Alignment > Density Quality

Settings

Input Data: Input file can be single point cloud file or point cloud dataset. The data to be processed must be
opened in the LiPowerline.
Density Threshold: The point density between the adjacent thresholds is shown in the corresponding color.
Grid Size (m, default value is "1"): The grid size in the point cloud gridding.
Output path: Select the output path of density inspection quality report. The folder contains the results of
each strip density quality inspection and integral report in html format.



Data Management
This chapter introduces the basic tools commonly used for point cloud and raster data processing. Contents
include: point cloud tools, raster tools, clip tools, format conversion and data extraction.

Point Cloud Tools

Outlier Removal

Noise Filter

Normalization

Normalization by Ground Class

Tile

Merge

Boundary

Subsampling

PCV

Define Projection

ReProjection

Extract Color from Image

Subdivision

Transformation

Raster Tools

Band Calculator

Raster Mosaic

Raster Subdivision

Clip

Clip by Circle

Clip by Rectangle

Clip by Polygon

Conversion

Convert to LiData

Convert LiData to LiData

Convert to Las

Convert to ASCII



Convert to Raster

Convert to Shape

Convert to DXF

Convert Image to LiModel

Convert to Texture LiModel

Convert LiModel to Image

Extract

Extract by Class

Extract by Elevation

Extract by Intensity

Extract by Return

Extract by Time

Extract by Serial Time

Classify

Classify by Attribute

Classify Ground

Classify Low Points

Classify by Below Surface

Classify Isolated Points

Classify Air Points

Classify by Height Above Ground

Classify by Min Elevation

Classify by Close Point

Class Conversion

Classify Buildings

Classify Model Key Points



Point Cloud Tools
The Point Cloud Tools include Outlier Removal, Noise Filter, Normalization, Tile, Merge, Boundary, Subsampling,
PCV, Projection, Extract Color from Image, subdivision and Transformation.

Outlier Removal

Noise Filter

Normalization

Normalization by Ground Class

Tile

Merge

Boundary

Subsampling

PCV

Define Projection

ReProject

Extract Color from Image

Subdivision

Transformation



Outlier Removal

Brief

Common noises include high level gross errors and low level gross errors. As shown below, high level gross error
is usually caused by the returns of high-flying objects (such as birds or aircraft) during the process of data
collection; low-level gross error are returns with extremely low attitudes caused by the multipath effect of a laser
pulse. The Outlier Removal tool aims to remove these errors as much as possible and therefore improve the data
quality.

The algorithm will first search for each point's neighboring points within a user-defined area and calculate the
average distance from the point to its neighboring points. Then, the mean and standard deviation of these
average distances for all points are calculated. If the average distance of a point to its neighbors is larger than
maximum distance (maximum distance = mean + n * standard deviation, where n is a user-defined multiple
number), it will be considered as an outlier and be removed from the original point cloud.

Effect picture:

Usage

Click Data Management > Point Cloud Tools > Outlier Removal



Settings

Input Data: The input file can be a single point cloud data file or multiple data files. File Format: *.LiData.
Neighbor Points (default value is "10"): The number of points required in the neighborhood to calculate
the average distance of each point. If there are not enough points found, the algorithm will not be executed.
Multiples of std deviation (default value is "5"): The factor multiplied by the standard deviation to
calculate the maximum distance.
Same With Origin File Name: Whether to use the same file name of origin file name.
Output path: Path of the output file. After the algorithm being executed, a new file will be generated. When
more than one files are entered, the path needs to be set to a folder.
DefaultValue: If this button is clicked, all parameters will be set to default values.

Note: The algorithm can be performed repeatedly to improve the denoising results. The outlier removal
results is limited if the noises are to dense.



Noise Filter

Brief

Remove noise from a point cloud. Unlike the denoising function, this function works better for objects with planar
surfaces (e.g., walls, tunnel interiors, ground) and can filter out more noise points.

Usage

Click Plugins > Point Cloud Tools > Noise Filter

Parameter Settings

Input Data: The input file can be a single point cloud data file or a point cloud dataset.
Radius Search (meters) (default is "0.5"): Set the radius for fitting the plane. This method can be used
when the user knows the approximate density of the point cloud.
Recommended Radius Search: Automatically calculate a suitable search radius based on the input point
cloud.
Standard Deviation Multiplier (default is 1.0): Use the relative error (sigma) as the denoising criterion. The
program automatically calculates the standard deviation (stddev) of the plane fitted to the neighborhood of
each point P. If the distance d from the point to the plane is less than sigma*stddev, the point P will be
retained. Decreasing this value will result in more points being removed, and vice versa. Changing this value
does not affect efficiency.



Remove Isolated Points: If the number of points within the search radius is less than four (insufficient for
plane fitting), the point is considered isolated. Users can choose whether to remove such points based on
this parameter.
Same With Source File Name: If checked, a new file with the same name as the source file but with noise
removed will be generated in the output directory. Otherwise, the string "_NoiseFilter" will be appended to
the source file name.
Output Path: The output folder path. After the algorithm is executed, a new file with noise removed will be
generated in this directory.
DefaultValue: If this button is clicked, all parameters will be set to default values.



Normalization

Brief

The normalization tool can remove the influence of terrain relief on the elevation value of the point cloud data.
This function requires that the extent of the DEM overlaps with the extent of the point cloud data. The
normalization process is performed by subtracting the corresponding terrain elevation of the DEM from each
point's Z value. The output of this function is similar to Normalization by Ground Class.

Usage

Click Data Management > Point Cloud Tools > Normalization

Settings



Input Data: The input file can be a single point cloud data file or multiple data files. File Format: *.LiData.
Input DEM File: Users can select single or multiple single-band TIFF image files from the drop-down list. File
format: *.tif.

: Users can add external DEM file data.
: Users can select a file in the list and click this button to remove the file from the list.
: Click this button to clear all the data in the list.

Output path: Path of the output file. After the algorithm being executed, the new normalized file will be
generated. When entering more than one file, the path will need to be set as a folder.



Normalization by Ground Class

Brief

The normalization tool can remove the effects of topographic relief on the elevation value of point cloud data. This
function requires that the input data has already been classified into ground points and non-ground points. The
normalization process is performed by subtracting the terrain elevation (represented by the elevation of the closet
ground point to each point) from each point's Z value. The output of this function is similar to Normalization.

Usage

Click Data Management > Point Cloud Tools > Normalization by Ground Class

Settings

Input Data: The input file can be a single point cloud data file or multiple data files. File Format: *.LiData.
Output path: Path of the output file. After the algorithm being executed, the normalized new file will be
generated. When entering more than one file, the path needs to be set as a folder.



Tile

Brief

Tile by Range divides the point cloud into a series of small data files based on the user-defined width and length
of the small data file. This process begins from the lower-left corner of the input file's bounding box.

Usage

Click Data Management > Point Cloud Tools > Tile

Settings

Input Data: The input file can be a single point cloud data file or multiple data files. File Format: *.LiData.
Width (default value is "500"): The width of the data block size, which is the length in the X-axis direction.
Height (default value is "500"): The length of the data block size, which is the length in the Y-axis direction.
Output path: Path of the output folder. After the algorithm being executed, new files will be generated.



Merge

Brief

Merge multiple point cloud files into a single point cloud file. This function is the reverse operation of Tile.

Usage

Click Data Management > Point Cloud Tools > Merge

Settings

Input Data: The input file can be a single point cloud data file or multiple data files. File Format: *.LiData.
Output path: Path of the output folder. After the algorithm being executed, a new file will be generated.



Boundary

Brief

Use a regular hexagon to extract the boundary of a point cloud data. According to the Edge, determine the height
of each regular hexagon, and draw each hexagon based on the bounding box of the point cloud data. If the
number of points within a hexagon is greater than or equal to the user-defined Density value, this hexagon will
be kept and merged with its connected hexagons. The ultimate output file is the final border vector file.

Usage

Click Data Management > Point Cloud Tools > Boundary

Settings

Input Data: The input file can be a single point cloud data file or multiple data files. File Format: *.LiData.
Edge (default value is "10"): The height of the hexagon, which is used to set the size of drowning a
hexagon.
Density (default value is "1"): The thresholding number of points in a hexagon, below which no hexagon
will be drawn.



Output path: Path of the output file. A new boundary vector file will be generated after the algorithm is
executed. File format: *.shp.



Subsampling

Brief

Subsampling point clouds, namely, reducing the number of point clouds, LiPowerline offers three methods for
resampling: minimum point spacing, sampling rate, and octree.

Usage

Click Data Management > Point Cloud Tools > Subsampling

Settings

Input Data: The input file can be a single point cloud data file or multiple data files. File Format: *.LiData.
Sampling Type: This parameter defines the resampling method.
Minimum Points Spacing (default, default value is "0.2000"): Users need to set a minimum point spacing
between two points so that the minimum three-dimensional distance between any two points in the sampled
point cloud will not be less than this value. The larger the value is set, the fewer points will be kept.
Handle Points Below Height: If this item is checked, only points below that elevation are processed.
Handle Selected Class: If this item is checked, only the points of the target category are processed.
Same With Origin File Name: Whether to use the same file name of origin file name.

Output path: Path of the output file. New file will be generated after the algorithm being executed.



PCV

Brief

PCV tool can be used to improve visualization effect of a point cloud. The principle of the PCV (Portion of Visible
Sky) algorithm is to evenly distribute multiple light sources at the top of the hemisphere or sphere calculate, and
then calculate the cumulative number of times when the light can be irradiated by illuminating each point in a
point cloud. The last statistical result will be used as the intensity of the point cloud. The rendering effect of the
point cloud intensity after PCV calculation is shown in the figure below.

Usage

Click Data Management > Point Cloud Tools > PCV

Select the point cloud data that needs to be processed by PCV.



After the PCV process, the intensity range of a point cloud will be 0-255. By clicking on display by intensity
or clicking display by the mixed mode, users can see the boundary between different land covers more
clearly in the point cloud after PCV process. The figure below shows an example of intensity and height
blend displaying effect after PCV calculation.



Define Projection

Brief

Define projection information for point cloud data, including geographic coordinates (usually latitude and longitude
coordinates) and projection coordinates (plane coordinates converted by projection).

Usage

Click Data Management > Point Cloud Tools > Define Projection

Settings

Input Data: The input file can be a single point cloud data file or multiple data files. File format: *.LiData.

Filter: Users need to enter the customized coordinate system. By entering the coordinate system keywords,
the corresponding coordinate system can be filtered from the Coordinate reference systems of the world
table (for example: to set the point cloud coordinate system to WGS 84 / UTM Zone 49N, users can enter
UTM 49N in the filter for fast screening, or enter its EPSG number: 32649 for quick search.) Users can also
import external coordinate system settings by clicking the Add Coordinate System button.



Add Coordinate System: Users can add external coordinate system settings or customize coordinate
system settings. LiPowerline software provides four ways to add external coordinate system:

Import from WKT
Import from PRJ
Add Geographic Coordinate System
Add Projected Coordinate System

Hide deprecated CRSs: Hide deprecated coordinate systems.

Import from WKT

WKT format can refer to the following way:

    GEOGCS[
        "GCS_Beijing_1954"
      ,DATUM["D_Beijing_1954",SPHEROID["Krasovsky_1940",6378245.0,298.3]]
        ,PRIMEM["Greenwich",0.0]
        ,UNIT["Degree",0.0174532925199433]
        ,AUTHORITY["EPSG",4214]
    ]

    PROJCS[
        "MyProjCS"
        ,GEOGCS["WGS84",DATUM["WGS_1984",SPHEROID["WGS84",6378137,298.257223563,AUTHORITY["EPSG","7030"]],TOWGS84[0,0
,0,0,0,0,0],AUTHORITY["EPSG","6326"]]
        ,PRIMEM["Greenwich",0,AUTHORITY["EPSG","8901"]]
        ,UNIT["degree",0.0174532925199433,AUTHORITY["EPSG","9108"]]
        ,AUTHORITY["EPSG","4326"]]
        ,PROJECTION["Transverse_Mercator"]
        ,PARAMETER["latitude_of_origin",0]
        ,PARAMETER["central_meridian",-81],PARAMETER["scale_factor",0.9996]
        ,PARAMETER["false_easting",500000]
        ,PARAMETER["false_northing",0]
        ,UNIT["Meter",1]
    ]

Import from PRJ

PRJ format can refer to the following way:

    +proj=longlat +ellps=aust_SA +towgs84=-117.808,-51.536,137.784,0.303,0.446,0.234,-0.29 +no_defs

Add Geographic Coordinate System

http://spatialreference.org/ref/epsg/32650/
http://proj4.org/usage/quickstart.html


Name: Users can customize a geographic coordinate system name.
Datum:

Name: Users can customize a datum name or select a known datum from the drop-down list.
Spheroid: If a user selects the datum from the drop-down list, the ellipsoid parameter does not require
user to enter.

Name: The name of the spheroid.
Semimajor Axis: Spheroid's major semi axis.
Inverse Flattening: Inverse flattening of the spheroid.

Angular Unit:
Name: Users can customize the angle unit name, or select the angle unit name from the drop-down list.
Radians Per Unit: Define the unit of arc in the geographic coordinate system.

Prime Meridian:
Name: Users can customize the name of the central meridian, or select the name of the central meridian
from the drop-down list.
Longitude: Input the central meridian longitude.

Add Projected Coordinate System



Name: Users can customize the name of a projection coordinate system.
Projection:

Name: Users can customize a projection name or select a known projection from the drop-down list. It
should be noted that user-defined projections can be modified from a projection template selected from
the drop-down list. Linear units:

Linear Unit:
Name: Users can customize the linear unit name or select the linear unit name from the drop-down list.
Meters per Unit: Input meters per unit.
Geographic Coordinate System: Users can paste the geographic coordinate system parameters into
the text box, or click Change.

Change

When the user clicks on the Modify button, the following dialog box will pop up for modifying the geographic
coordinate system.



The user can filter out the needed coordinate system through the filter operation, or can also add the geographic
coordinate system through the New Geographic Coordinate System and the setting method is the same as
Add Geographic Coordinate System.



Reproject

Brief

The point cloud can be converted by projection, including the conversion between geographic coordinate system
and projected coordinate system. When different geographic coordinate systems are converted to each other,
due to the differences between the ellipsoid used and the reference plane, it will involve the conversion between
ellipsoids. LiPowerline provides the seven-parameter transformation model. Select the "using the seven-
parameters" option and click the "Seven Parameters Setting" button. The user can enter the values for X-
translation, Y-translation, Z-translation, X-axis rotation, Y-axis rotation, Z-axis rotation, and scale values for
seven-parameter transformation.

Usage

Click Data Management > Point Cloud Tools > Reproject

Settings

Input Data: The input file can be a single point cloud data file or multiple data files. File Format: *.LiData.
Use Seven Parameters: User decides whether to use seven parameters for re-projection, if checked, seven
parameters will be used.
Seven Parameters Setting: Select the Use Seven Parameters option, click the Seven Parameters Setting
button, and the Seven Parameters Dialog will pop up. Click  to fill the seven-parameter values by opening



a txt file; click  to save the set value as a txt file; click  to clear the entered value.
X (m): The X translation in seven parameters.

Y (m): The Y translation in seven parameters.
Z (m): The Z translation in seven parameters.
Rx (''): The X-axis rotation in seven parameters.
Ry (''): The Y-axis rotation in seven parameters.
Rz (''): The Z-axis rotation in seven parameters.
λ (ppm): The zoom scale in seven parameters.

Filtering: Users needs to input the customized coordinate system. By entering the coordinate system
keywords, the corresponding coordinate system can be filtered from the Coordinate reference systems of
the world table (for example: to set the point cloud coordinate system to WGS 84 / UTM Zone 49N, users
can enter UTM 49N in the filter for fast screening, or enter its EPSG number 32649 for quick search.) Users
can also import external coordinate system by clicking the Add Coordinate System button.
Add coordinate systems: For details, refer to Define Projection Parameter Settings.
Hide deprecated CRSs: Hide deprecated coordinate systems.
Output path: Path of the output file. New files will be generated after the algorithm is executed.

Note: The reprojected point cloud must already have projection information. To check whether the current
point cloud has projection information, users can select the data in the data list and its projection
information will be displayed in the current file coordinate system.



Extract Color from Image

Brief

Extract Color from Image tool can extract RGB information from multi-band imagery and assigned them to each
point in a point cloud. The user is required to enter one or more multi-band images that overlapping with the
extend of the point cloud data.

After the process is completed, the display mode of the point cloud data will automatically change to RGB display
(you can also click  on the toolbar Button, to display the point cloud in RGB).

Usage

Click Data Management > Point Cloud Tools > Extract Color from Image

Settings

Input Data: The input file can be a single point cloud data file or multiple data files. File Format: *.LiData.
Input File: The user needs to enter one or more multi-band images that are geographically overlapping with
the point cloud data. If the image data has already been opened in the software, click the drop-down button
to select the data, or you can click  to open the external image data. Click  to remove selected
images from the list and click  to clear the image data list. File format: *.tif.



Subdivision

Brief

Subdivision tool can divide a point cloud to a series of frames based on the user defined scales. Currently,
LiPowerline supports four subdivision scales: a scale of 1:5000 (taken to 1 km), 1:2000 (taken to 0.1 km), 1:1000
(taken to 0.1 km), and 1:500 (taken to 0.01km). Moreover, only subdivision in rectangular is supported currently.
The frame ID will be named by the coordinate number, which is composed of the southwest corner of the frame
(Y coordinate + X coordinate). After the operation is completed, a vector file will be generated in shp format
recording each subdivided frame.

Usage

Click Data Management > Point Cloud Tools > Subdivision

Settings

Input LiData File: Input the point cloud data to be subdivided. If the point cloud data is already open in the
software, click the drop-down button to select the data; or you can click  to open external point cloud
data. Click  to remove the selected data. Click  to clear the image data list. File format: *.LiData.
Scale: User-defined scale. LiPowerline has four scales: 1:500, 1:1000, 1:2000, 1:5000.
Output path: Path of the output folder. After the algorithm is executed, a new shp file will be generated.



Transformation

Brief

LiPowerline software supports multiple coordinate conversion methods. Users can select a conversion type to
perform point cloud data conversion according to their needs.

The four supported coordinate conversion methods are:

Linear
XYMultiply
Translate and Rotate
3D Affine

Steps

1. Input Data: The input file can be a single point cloud data file or multiple data files. File Format: *.LiData.
2. Select the Transformation Type. The user selects the desired conversion type from the drop-down box and

sets the relevant parameters.
3. Output path: Path of the output folder. After the algorithm is executed, new files after transformation will be

generated.

Usage

Click Data Management > Point Cloud Tools > Transformation

Settings

Linear



The linear transformation is used to pan and zoom a point cloud. A panning and scaling parameter need to be set
to the X, Y, Z coordinates, respectively. The targeted coordinates are calculated using the following formula:

Among them: Sx, Sy, Sz are the scaling factors for the x, y, and z coordinates. Px, Py, and Pz are the panning
parameters for the x, y, and z coordinates. x, y, and z are the original coordinates, and X, Y, and Z are
coordinates obtained after the linear transformation.

XYMultiply

The target coordinates are calculated using the following formula:

Among them, Px, Py, Pz, a, b, c, d, e are the transformation parameters, Sx, Sy, Sz are the original coordinates,
and X, Y, Z are the transformed coordinates. This is often used as a 2D Helmert transformation.

Translate and Rotate



The target coordinates are calculated using the following formula:

R11, R12, R13, R21, R22, R23, R31, R32, R33 are calculated as follows:

R11 = cos( Ry ) * cos( Rz )

R21 = cos( Ry ) * sin( Rz )

R31 = -sin( Ry )

R12 = sin( Rx ) sin( Ry ) cos( Rz ) - cos( Rx ) * sin( Rz )

R22 = sin( Rx ) sin( Ry ) sin( Rz ) + cos( Rx ) * cos( Rz )

R32 = sin( Rx ) * cos( Ry )

R13 = cos( Rx ) sin( Ry ) cos( R_z ) + sin( Rx ) * sin( Rz )

R23 = cos( Rx ) sin( Ry ) sin( Rz ) - sin( Rx ) * cos( Rz )

R33 = cos( Rx )* cos( Ry )

λ (default value is "0"): Scale conversion factor applied to X, Y, Z.
Dx, Dy, Dz (default value is "0"): Panning values added to X, Y, Z.
Rx, Ry, Rz (default value is "0"): The angle of rotation about the X, Y, and Z axes in degrees.

Note: To achieve millimeter-level accuracy, there should be at least eight decimal places after the decimal
point.

3D Affine



The target coordinates are calculated using the following formula:

Dx, Dy, Dz (default value is "0"): Panning values added to X, Y, Z.
Mx, My, Mz (default value is "0"): Scale factor applied to the X, Y, and Z axes.
Rx, Ry, Rz (default value is "0"): The angle of rotation about the X, Y, and Z axes in degrees.

Note: To achieve millimeter-level accuracy, there should be at least eight decimal places in the user inputs.



Raster Tools
Raster tools include Band Calculation, Raster Mosaic, and Raster Subdivision.

Band Calculator

Raster Mosaic

Raster Subdivision



Band Calculator

Brief

Band Calculator tool can generate a new raster image based on a user-defined map algebra equation from two
single-band images.

Band operator functions and operators include: Basic operations: plus (+), minus (-), multiply (×), and divide (÷);
Trigonometric functions: sine sin(x), cosine cos(x), tangent tan(x), arcsine asin(x), arc cosine acos(x), arc tangent
atan(x); Other mathematical functions: natural exp(x), natural logarithm ln(x), logarithm to base a log(a, x), square
root sqrt(x), quadratic power Power2, cubic power Power3, round integer part, inverse

The band operation function can be applied to single or two raster images, and the input data must meet the
following conditions:

(1) The input data must be a single-band image;

(2) The input data must have the same spatial resolution;

(3) The spatial range of the input data must have intersections.

Usage

Click Data Management > Raster Tools > Band Calculator

Settings

Output path: Path of the output folder. After the algorithm is executed, a new file will be generated after the
band operation.



Raster Mosaic

Brief

Raster Mosaic refers to the technical process of merging two or more images to one image. LiPowerline
provides seven sampling methods: Nearest Neighbour, Bilinear, Cubic, CubicSpline, Lanczos, Average, and
Mode. It is the reverse operation of Raster Subdivision.

Usage

Click Data Management > Raster Tools > Raster Mosaic

Settings

Input Tiff File: Users can select multiple files (>1) to be processed from the drop-down list.
: Users can add multiple external images for image mosaic.
: Click this button to clear all images in the list.

Sample Type: Users need to select the sampling type from the drop-down list.
NearestNeighbour (default): Nearest neighbor, sampled from the nearest neighbor.
Bilinear: Bilinear sampling (2 x 2 cores).
Cubic: Cubic convolution approximation (4 x 4 kernels).
CubicSpline: Cubic B-spline approximation (4×4 kernel).
Lanczos: Lanczos Window Sine Interpolation (6×6 Cores). Lanczos can be used as a low pass filter or
to smoothly interpolate the value of a digital signal between its samples.
Average: Calculate the average of all non-value pixels.
Mode: Select the most frequently occurring value for all sampling points.

Output path: Path of the output folder. After the algorithm is executed, a new file will be generated.

https://en.wikipedia.org/wiki/Lanczos_resampling


Raster Subdivision

Brief

The raster subdivision tool is the inverse operation of raster mosaic. The frame number adapts the coordinate
number and consists of the southwest corner of the frame (Y coordinate + X coordinate). A scale of 1:5000 is
taken into 1 km, 1:2000 and 1:1000 to 0.1 km, and 1:500 to 0.01 km.

Usage

Click Data Management > Raster Tools > Raster Subdivision

Settings

Input File: Users can select the file to be processed from the drop-down list.
: Users can add external files that need to be processed.

Scale (default "1:500"): Users can select a targeted scale. LiPowerline has four scale options: 1:500,
1:1000, 1:2000, and 1:5000.
Output path: Path of the output folder. After the algorithm is executed, new subdivided files will be
generated.



Clip
The clipping tools include Clip by Circle, Clip by Rectangle and Clip by Polygon.

Clip by Circle

Clip by Rectangle

Clip by Polygon



Clip by Circle

Brief

Clip by circle tool extracts the point cloud data within user-defined circle(s), and the extracted points can be
saved in one or multiple files.

Usage

Click Data Management > Clip > Clip by Circle

Settings

Input Data: Input one or more point cloud data files. File Format: *.LiData.
X Coordinate (m): Enter the X coordinate of the circle center.
Y Coordinate (m): Enter the Y coordinate of the circle center.
Radius (m): Enter the radius of the circle.
Generate a File: Extract all the point cloud data within 2D circle(s) to one file.
Generate Multiple Files: Extract the point cloud data within each circle and save them to one individual file.
The file is named by its center and radius by default.

: Click this button to add the coordinates and radius of a circle to the processing list. Perform the same
operation to add multiple clipping circles.

: Click this button to load external data files. The file format refers to the Clip Range File Format in the
appendix.

: Click this button to remove the selected row(s) in the processing list.



Output path: The generated file will be saved in this output path.



Clip by Rectangle

Brief

Clip by rectangle tool extracts the point cloud data within user-defined rectangular(s), and the extracted points
can be saved in one or multiple files.

Usage

Click Data Management > Clip > Clip by Rectangle

Settings

Input Data: Input one or more point cloud data files. File Format: *.LiData.
Y Maximum (m): Enter the maximum Y coordinate of the rectangle.
Y Minimum (m): Enter the minimum Y coordinate of the rectangle.
X Minimum (m): Enter the minimum X coordinate of the rectangle.
X Maximum (m): Enter the maximum X coordinate of the rectangle.
Generate a File: Extract all the point cloud data within the rectangle to a file.
Generate Multiple Files: Extract the point cloud data within each rectangle and save them to one file. The



file is named by the rectangle's lower left corner coordinate and the rectangle's width and height by default.
: Click this button to add the entered rectangle range to the processing list. Perform the same operation

to add multiple clipping regions.
: Click this button to load external data files. The file format refers to the Clip Range File Format in the

appendix.
: Click this button to remove the selected row(s) in the processing list.

Output Path: The generated file will be saved in this output path.



Clip by Polygon

Brief

Clip by polygon tool extracts the point cloud data within user-defined polygon vector file, and the extracted points
will be saved in one file.

Usage

Click Data Management > Clip > Clip by Polygon

Settings

Input Data: Input one or more point cloud data files. File Format: *.LiData.
Shape File: Select the vector file loaded into LiPowerline software from the drop-down menu, or click the

button  to load the external vector data file.

Output Path: The generated file will be saved in this output path.

Note: The vector data file used to clip the point cloud data must be a polygon file (not point or line file), and
currently MultiPolygon files are not supported.



Conversion
Conversion Tools contain Convert to LiData, Convert LiData to LiData,Convert to Las, Convert to ASCII,
Convert to Raster, Convert to Shape, Convert to DXF, Convert Image to LiModel, Convert to Texture
LiModel, Convert LiModel to Image, Convert Raster to ASCII.

Convert to LiData

Convert LiData to LiData

Convert to Las

Convert to ASCII

Convert to Raster

Convert to Shape

Convert to DXF

Convert Image to LiModel

Convert to Texture LiModel

Convert LiModel to Image



Convert to LiData

Brief

Convert to LiData can convert point cloud data in LAS or LAZ formats to LiPowerline customized point cloud
format (LiData format).

Usage

Click Data Management > Conversion > Convert to LiData

Settings

File List: Import the file that needs to be converted. The file formats currently supported are : .las, .laz. Users
need to click  to select the point cloud data; users can select one or more file(s) in the existing list and
click  to delete them from the list; users can click  to remove all files in the list.
Attributes to Export: Users can select the attributes that need to be exported. All Las attributes are
supported.
RGB Range: User can select the RGB range of the output file, which can be output by the source file or
converted to 8 and 16 bits.
Output Path: Path of the output folder. After the conversion is executed, the converted new file(s) will be
generated.



Convert LiData to LiData

Brief

Convert the current point cloud to another version of the LiData format.

Usage

Click Plugins > Conversion > Convert LiData to LiData

Parameter Settings

File List: Input file to be converted(.LiData).

LiData Version: The version of output LiData file.



Convert to Las

Brief

Convert to Las can convert point clouds in LiData format to LAS format, namely the standard Lidar point cloud
data format.

Usage

Click Data Management > Conversion > Convert to Las

Settings

Input Data: The input file can be a single point cloud data file or multiple data files. File Format: *.LiData.
Attributes to Export: Users can select the attributes that need to be exported. All Las attributes are
supported.
RGB Range: User can select the RGB range of the output file, which can be output by the source file or
converted to 8 and 16 bits.
Output Path: Path of the output folder. After the conversion being executed, the converted new file(s) will be
generated.



Convert to ASCII

Brief

The Convert to ASCII tool can convert the LiData point cloud to ASCII format, a text format that can be easily
viewed in a text editor.

Usage

Click Data Management > Conversion > Convert to ASCII

Settings

Input Data: The input file can be a single point cloud data file or multiple data files. File Format: *.LiData.
Attributes to Export: Users can select the attributes that need to be exported. All Las attributes are
supported.
Export Format: LiPowerline supports two suffix formats: txt and csv, and support separators are: commas,
spaces and TAB.
Output path: Path of the output folder. After the conversion is executed, the converted new file(s) will be
generated.



Convert to Raster

Brief

The Convert to Raster tool can convert LiData point cloud data to raster images according to the Attribute of the
points in Cell Value method.

Usage

Click Data Management > Conversion > Convert to Raster

Settings

Input Data: The input file can be a single point cloud data file or multiple data files. File Format: *.LiData.
XSize (m, default value is "2"): The X pixel resolution of the output raster.
YSize (m, default value is "2"): The Y pixel resolution of the output raster.
Attribute (default is "Z"): Select the point attribute used to calculate the raster cell value.

Z (default): Generate the raster data using the Z value of the point cloud data.
Intensity: Generate raster data using the intensity values of the point cloud data.
Scan angle: Generate raster data using the scan angle of point cloud data.
Return number: Generate raster data using the return number of the point cloud data.
Number of returns of given pulse: Raster data is generated using the number of returns of given pulse
of the point cloud data.

Cell value: Choose how to fill raster pixel values.
Minimum (default): Use the smallest attribute value as the value of a raster cell.
Average: Use the average of attribute values of all points within a raster cell as its value.
Maximum: Use the largest attribute value as the value of a raster cell.

Merge files into one: Users can set merging all raster into one data file. If not checked, each point cloud
data will be generated into a separate raster file.
Output path: Path of output folder. After the algorithm is executed, the converted new file is generated.



Convert to Shape

Brief

The Convert to Shape tool can convert point cloud files in LiData format to point files in vector format.

Usage

Click Data Management > Conversion > Convert to Shape

Settings

Input data: The input file can be a single point cloud data file or multiple data files. File Format: *.LiData.
Attributes to Export: Users can select the attributes that need to be exported, and all Las attributes are
supported. The selected attributes will be written in the attributes of the shape file data.
Output path: Path of the output folder. After the conversion being executed, the converted new file will be
generated.



Convert to DXF

Brief

The Convert to DXF tool can convert LiData format point cloud files to point vector data in DXF format.
LiPowerline software exports DXF files in ASCII format.

Usage

Click Data Management > Conversion > Convert to DXF

Settings

Input Data: The input file can be a single point cloud data file or multiple data files. File Format: *.LiData.
From Class: Source class (es).
Tile: Since the amount of point cloud data is often large, the software provides an optional tile mode that can
split the input data file to a number of tiles.

No Tile: Export a single DXF file.
Tile by Rows and Columns: According to the boundary of the point cloud data, the point cloud will be
split into a total number of rows * columns data blocks evenly, and a single DXF file will be generated.

Rows (default value is "3"): User-defined number of rows that the point cloud want to be split into.
Columns (default value is "3"): User-defined number of columns that the point cloud want to be
split into.

Tile by Width and Height: The point cloud will be split into a number of tiles from the lower left corner
by the specified width and height, one DXF file per block.

Width (m, default value is "100"): User-defined block width.
Height (m, default value is "100"): User-defined block height.

Output path: Path of the output folder where the converted new file(s) will be generated.



Convert Image to LiModel

Brief

Convert image to LiModel tool can convert single-band raster data (DEM, DSM, CHM, etc.) to LiModel format.
The LiModel format is a LiPowerline software customized format that allows the converted single-band raster
data to be displayed and edited in a 3D window.

Usage

Click Data Management > Conversion > Convert Image to LiMode

Settings

Input Tiff File: Users can select the file to be processed from the drop-down list.
: Users can add files to be converted that have not been opened.
: Users can select a file in the list and click this button to remove the file from the list.
: Click this button to clear all files in the list.

Output path: Path of the output folder. After the conversion being executed, the converted new file(s) will be
generated.



Convert to Texture LiModel

Brief

Convert to Textured LiModel tool is based on the Convert Image to LiModel tool, which maps color values of a
DOM data to the LiModel model for display. This function only supports single file data conversion.

Usage

Click Data Management > Conversion > Convert to Texture LiModel

Settings

Input DEM: Users can select a file to be converted from the drop-down list or use the button 

to load an external data file. Single-band raster data is required.

Input DOM: Users can select a desired file from the drop-down list or use the button  to load

an external data file. The selected color image needs to have at least three bands.
Output LiModel: Path of the output file. After the conversion being executed, the converted new file will be
generated.



Convert LiModel to Image

Brief

Convert LiModel to Image tool converts LiModel format files to raster images in TIFF format. After editing LiModel
data, users can use this function to convert the data to TIFF format.

Usage

Click Data Management > Conversion > Convert LiModel to Image

Settings

Input LiModel File: User can select a file to be processed from the drop-down list.
: Users can add external data files to be converted.
: Users can select a file in the list and click this button to remove the file from the list.
: Click this button to clear all the data in the list.

Output path: Path of the output folder. After the conversion being executed, the converted new file will be
generated.



Extract
Extraction tools include Extract by Class, Extract by Elevation, Extract by Intensity, Extract by Return,
Extract by Time, and Extract by Serial Time.

Extract by Class

Extract by Elevation

Extract by Intensity

Extract by Return

Extract by Time

Extract by Serial Time



Extract by Class

Brief

Extract by class tool can extract all the point cloud data of the user-selected class, and save the data in one file.
This function supports multiple file operations.

Usage

Click Data Management > Extract > Extract by Class

Settings

Input Data: Input one or more point cloud data files. File Format: *.LiData.
Output Separately: This parameter is not selected by default. If it is selected, one file is output for each
category.
Same With Origin File Name:This parameter is deselected by default. If it is selected, the output file name
is the same as the source file.
Output File Suffix: Suffix of output file.
From Class: Users need to select the class to be extracted from the drop-down list. The unavailable status
in the drop-down list represent the corresponding category that does not exist in the file.
Output path: Path of the output folder. After the algorithm being executed, the extracted new file(s) will be
generated.



Extract by Elevation

Brief

Extract by Elevation tool can extract the point cloud data in the user-defined elevation range to a file. This
function supports multiple file operations.

Usage

Click Data Management > Extract > Extract by Elevation S

Settings

Input Data: Input one or more point cloud data files. File Format: *.LiData.
Min (m, default value is "100"): Users need to enter the minimum elevation value of the point cloud data to
be extracted.
Max (m, default value is "200"): Users need to enter the maximum elevation value of the point cloud data
to be extracted.
Output path: Path of the output folder. After the algorithm being executed, the extracted new file(s) will be
generated.



Extract by Intensity

Brief

Extract by Intensity tool can extract all the point cloud data within the user-defined intensity range. This function
supports multiple file operations.

Usage

Click Data Management > Extract > Extract by Intensity

Settings

Input Data: Input one or more point cloud data files. File Format: *.LiData.
Min (default value is "100"): Users need to enter the minimum intensity value of the point cloud data to be
extracted.
Max (default value is "200"): Users need to enter the maximum intensity value of the point cloud data to be
extracted.
Output path: Path of the output folder. After the algorithm being executed, the extracted new file(s) will be
generated.



Extract by Return

Brief

Extract by Return tool can extract all the point cloud data of the user-defined return number, and saved the data
in a file. This function supports multiple file operations.

Usage

Click Data Management > Extract > Extract by Return

Settings

Input Data: Input one or more point cloud data files. File Format: *.LiData.
Return number: Users need to select the return number of the point cloud data to be extracted. Click on the
drop-down menu to select the return number, including: first return, last return, 2nd return, 3rd return, 4th
return, and returns after 4th.
Output path: Path of the output folder. After the algorithm being executed, the extracted new file(s) will be
generated.

Note: If the data does not have the return number selected by the user, the extraction will not be executed.



Extract by Time

Brief

Extract by GPS time tool can extract all the point cloud data within the user-defined GPS time range, and save
them in a file.

Usage

Click Data Management > Extract > Extract by Time

Settings

File List: Select the file to be processed from the drop-down list.
Min Time: Displays the minimum GPS time value in the point cloud file selected by the user. This value does
not require user settings.
Max Time: Displays the maximum GPS time value in the point cloud file selected by the user. This value
does not require user settings.
Start Time (default value is "min Time"): Input the minimum GPS time value of the point cloud data to be
extracted.
End Time (default value is "max Time"): Input the maximum GPS time value of the point cloud data to be
extracted. This value must be larger than the start time.

: If you want to extract the point cloud at a specified interval, enter the interval value in the text box, and
then click this button, the values of the start time and end time will increase at the set interval.

: Add the input time range to the range list. All point cloud data in the time range will be extracted into
one file.

: Users can click this button to load external GPS range file. The time range in the file needs to be
between the min Time and the max Time. The file format can be referred to the appendix for information in
the GPS time file format.

: Users select a row in the time range list and click this button to remove the row from the list.
Output Path: Path of the output folder. After the algorithm being executed, the extracted new file will be
generated.



Extract by Serial Time

Summary

Extract by Serial Time tool helps the user to extract the points in customized GPS time period and save them to a
separate file.

Usage

Click Data Management > Extract > Extract by Serial Time.

Settings

File List: Select the file to be processed from the file list.
File List Filter: Automatically select files to be processed based on the fields entered by the user.
Min Time: Display the minimum GPS time value in the point cloud file selected by the user. This value does
not require user settings.
Max Time: Display the maximum GPS time value in the point cloud file selected by the user. This value does
not require user settings.
Start Time (default value is "Min Time"): Input the minimum GPS time value of the point cloud data to be
extracted.
End Time (default value is "Max Time"): Input the maximum GPS time value of the point cloud data to be
extracted.
Output Path: The path of the output file.



Classify
LiPowerline can be used to classify unclassified point cloud, or to reclassify points that have already been
classified.

Classify by Attribute

Classify Ground

Classify Low Points

Classify by Below Surface

Classify Isolated Points

Classify Air Points

Classify by Height Above Ground

Classify by Min Elevation

Classify Closeby Point

Class Conversion

Classify Buildings

Classify Model Key Points



Classify by Attribute

Brief

This function classifies the point cloud into another class according to their attributes. Currently available
classification attributes include Absolute Elevation, Intensity, GPS Time, Scan Angle, and Return Number. In
addition, the function can restore all classes and/or reclassify the point cloud for undesirable classification results.

Usage

Click Classify > Classify by Attribute

Settings

Input Data: The input file can be a single point cloud data or a point cloud dataset, which must be opened in
the LiPowerline software.
From Class: Source class(es).
To Class: Target class.
Choose Attribute: The selected attribute will be used to classify the point cloud.

None (default): The default setting will change all points in the From Class option to To Class.
Absolute Elevation: Classified by elevation range. If the elevation value of a point is between the
specified range, it will be assigned to the To Class.
Intensity: Classified by intensity range. If the intensity value of a point is between the specified range, it
will be assigned to the To Class.
Time: Classified by GPS time. If the GPS time value of a point is between the specified range, it will be
assigned to the To Class.
Angle: Classified by scan angle. If the scan angle value of a point is between the specified range, it will
be divided into the To Class.
Return: Classified by the return number. If the return number at a point is between the specified range,
it will be assigned to the To Class.



Classify Ground

Brief

Ground points classification is an important operation of point cloud preprocessing, which can be implemented in
LiPowerline with an improved progressive TIN densification filtering algorithm (Zhao et al.,2016).

The algorithm first generates a sparse triangulated irregular network(TIN) through seed points, and then
iteratively processes layer-by-layer densification until all ground points have been classified. The specific steps of
the algorithm are described as follows:

1. The initial seed point selection. If the point cloud contains buildings, the maximum building size is taken as
the grid size to grid the point cloud, and for the point cloud without the building, the default value is used as
the grid size. Take the lowest point in the grid as the starting seed point.

2. Build a TIN. The initial TIN was constructed using the initial seed point.
3. Iterative densification process. Traverse all the unclassified points, query the triangles that each point

belongs to in the horizontal projection plane; Calculate the distance(d) from the point to the triangle and the
max angle between the point and three vertices with the triangles plane. As shown in the figure below, the
distance and max angle are compared with the Iteration distance and Iteration angle, separately. If it is
less than the corresponding threshold, then the point is classified as a ground point and added to the
triangulation. Repeat this process until all ground points have been classified.

The flow of algorithm is shown in the figure.



Usage

Click Classify > Classify Ground



Settings

Input Data: The input file can be a single point cloud data or a point cloud dataset, which must be opened in
the LiPowerline software.
From Class: Source class(es).
To Class: Target class.
Max Building Size (m, default value is "20"): The maximum length of the building edge that exists in the
point cloud scan. If this parameter is set too small, the flat roof of the building may be mistaken as the terrain.
When there is a building in the point cloud data, the maximum building size can be measured by using the
Length Measurement in the menu bar. The value of this parameter should be greater than the measured
value. For point cloud data without buildings, this parameter can use the default value of 20m.
Max Terrain Angle (°, default value is "88"): The maximum slope of the terrain shown in the point cloud.
This parameter can determine whether the points nearby the ground points belong to the ground or not.
Usually, the parameter can be set as default.
Iteration Angle (°, default value is "30"): The allowable range of angles between unclassified points and
ground points. For areas with large topography and undulations, it can be bigger.Generally, it is set between
10 to 30 degrees. In addition, the iteration angle should adjust with the iteration distance.
Iteration Distance (m, default value is "1.6"): Distance threshold between the unclassified points and the
triangle in the triangle mesh. When the topography is highly undulating, it should be set to a larger value. The
general setting is 1~2 meters.In addition, the iteration distance should adjust with the iteration angle.
Reduce Iteration Angle When Edge Length < (m, default value is "5", Optional): When the triangle
length of the points to be classified is smaller than the threshold, the iteration angle should be decreased.
Use the parameter to indicate that when the point to be classified corresponds to the length of the triangle in
the triangulation network is less than the threshold, the iteration angle is reduced accordingly. When a
sparse ground point needs to be obtained, the threshold may be increased accordingly.
Stop Triangulation When Edge Length < (m, default value is "1", Optional): When the triangle length of
the point to be classified corresponds to the length of the triangle is less than the threshold, the densification
of triangulation network is stopped. This value can prevent the locally generated ground point from being too
dense. When this value increase, the ground points will be sparse, and vice versa.
Only Key Points (Optional): Extract key points of terrain model on the basis of ground point filtering. This
function can preserve the key points on the terrain and sparse the points on the flat area. For the specific
usage, please see Classify Model Key Points.

Note: Because the actual terrain is complex and changeable, when using this function to perform ground
point classification, different parameters needs to be adjusted in order to achieve relatively ideal results. In
addition, the classification result in local area can be reclassified by Classify Ground by Selected and the
Classify by Interactive Editing tool.

    @inproceedings{
        author={Zhao X Q, Guo Q H, Su Y J and Xue B L},
        title={Improved progressive TIN densification filtering algorithm for airborne LiDAR data in forested areas},
        booktitle={ISPRS Journal of Photogrammetry and Remote Sensing,117:79-91},
        year={2016}
    }



Classify Low Points

Brief

The low point refers to the noise point that is lower than the actual terrain. The existence of the low point will
affect the extraction of the ground point, because the progressive triangulation filtering algorithm is based on the
seed points represented by the lowest point of the gridded point cloud. Therefore, filtering out the low point is a
preprocessing operation, which directly affects the filtering effects, the establishment of a digital model, and the
generation quality of contour lines. The triangulated terrain model created by the ground points with low points is
shown below.

The distribution of low points is divided into individual points or clusters. The algorithmic flow of this function is:

1. Traverse the point cloud and search for points to be classified within a certain range of radius of the current
single point or point cluster.

2. Calculate the maximum height difference between the current point and the neighboring point, which is
compared with the threshold.

3. If the value is greater than the threshold, the current point is considered to be a low point, otherwise, it is not
classified as a low point.

Usage

Click Classify > Classify Low Points



Settings

Input Data: The input file can be a single point cloud data or a point cloud dataset, which must be opened in
the LiPowerline software.
From Class: Source class(es).
To Class: Target class.
Points Number (default value is "1"): When the number of points is set to 1, the single low point is
classified. If it is greater than 1, cluster low points are classified.
Radius (m, default value is"5"): The radius threshold between the unclassified point and the neighboring
point.
Height (m, default value is"0.5"): The height difference threshold between the unclassified point and the
neighboring point.
DefaultValue: Click this button to set all parameters as default.



Classify by Below Surface

Brief

This function classifies points in the initial category that are below the elevation of the surrounding neighborhood.
For example, when the starting category is ground, this method can be used to classify points lower than the
surface elevation to be the lower-than-the-surface point. The main algorithm idea of this function is:

1. Search for a certain number of nearest points for the current point in initial class.
2. Fit the plane with the nearest point.
3. Calculate the absolute value of the height difference between the current point and the plane. If the value is

less than the set Z tolerance, it is not categorized. If it is greater than the tolerance, go to the next step.
4. Calculate whether the difference between the current point elevation and the average value of the

neighboring points is greater than the Limit of the standard deviation. If it is greater than, then it is classified
as the target category; otherwise, it is not classified.

Usage

Click Classify > Classify by Below Surface

Settings

Input Data: The input file can be a single point cloud data or a point cloud dataset, which must be opened in
the LiPowerline software.
From Class: Source class(es).
To Class: Target class.
Limit (default value is"3"): The multiple of the mean squared error of the neighboring point fitting plane of
the unclassified points. The larger the value, the less points will be classified into the target class.
Z tolerance (m, default value is"3"): The threshold of height difference. The point to fit plane distance less
than this value is not classified. The larger the value, the less points will be classified into target class.
DefaultValue: Click this button to set all parameters as default.



Classify Isolated Points

Brief

This function classifies points in a certain area of point cloud, which is generally used to find outliers in the air or
below the ground.

Usage

Click Classify > Classify Isolated Points

Settings

Input Data: The input file can be a single point cloud data or a point cloud dataset, which must be opened in
the LiPowerline software.
From Class: Source class(es).
To Class: Target class.
Points Number (default value is"3"): If the number of points in the neighboring radius are less than or
equal to the value, the point is considered as an isolated point.
Radius (m, default value is"5"): Neighboring search radius.
DefaultValue: Click this button to set all parameters as default.



Classify Air Points

Brief

This function classifies points that are significantly higher than the surrounding points into airborne noise points.
The idea of the algorithm is the same as the principle of Outlier Removal in the data management module.

Usage

Click Classify > Classify Air Points

Settings

Input Data: The input file can be a single point cloud data or a point cloud dataset, which must be opened in
the LiPowerline software.
From Class: Source class(es).
To Class: Target class.
Neighbor Points (default value is"10"): The number of neighbors that will be used to determine whether a
point is a noise in the sky. Calculate the distance between each point to the nearest point and calculate the
standard deviation of the nearest distances.
Multiples of std deviation (default value is"5"): If the deviation of points beyond the minimum allowable
threshold, they are considered as noise in the sky. The larger the threshold, the less the noise will be divided
into.
DefaultValue: Click this button to set all parameters as default.



Classify by Height Above Ground

Brief

This function classifies the points on the surface of the terrain with a certain height, which can quickly classify
vegetation at different heights. For example, this classification can be performed three times to separate low
vegetation (0-1m), medium vegetation (1-10m), and high vegetation (10-100m), see the figure below.

Usage

Click Classify > Classify by Height Above Ground

Settings

Input Data: The input file can be a single point cloud data or a point cloud data set, which must be opened in
the LiPowerline software.
From Class: Source class(es).



Ground Class: The default ground point is 2-class.
To Class: Target class.
Min Height (m, default value is "0"): The minimum height difference of the area to be classified above the
ground points.
Max Height (m, default value is "1"): The maximum height difference of the area to be classified above the
ground points.
DefaultValue: Click this button to set all parameters as default.

Note: This function need to contain the ground point in the cloud.



Classify by Min Elevation

Brief

This function classifies the points at a certain height within a certain radius in the source class.

Usage

Click Classify > Classify by Min Elevation

Settings

Input Data: The input file can be a single point cloud data or a point cloud data set, which must be opened in
the LiPowerline software.
From Class: Source class(es).
To Class: Target class.
Min Height (m, default value is"0"): The minimum height difference in the area to be classified above the
lowest point within the radius.
Max Height (m, default value is"1"): The maximum height difference in the area to be classified above the
lowest point within the radius.
Radius (m, default value is"5"): The radius of the area needs to be classified at the current point, which
needs to be classified.
DefaultValue: Click this button to set all parameters as default.



Classify Closeby Point

Summary

This tool can classify point clouds close to other classes. For each point in the "from class", the software looks for
the point cloud in the specified 2D or 3D neighborhood, and determines whether these points meet certain
conditions (such as containing a specified class). If the conditions are met, the point is classified into the "to
class".

Usage

Click Classify > Classify Closeby Point

Parameters

Input Data: The input data can be single or multiple, must have been opened in Lipowerline.
Closeby Class: If class in from class is detected in neighbour area, that point will be reclassified.
from Class
to Class
Search Method: Support 2D or 3D neighbourhood.

Radius: Neighbourhood search radius.



Class Conversion

Summary

A certain class of the point cloud can be converted into another class according to attribute characteristics in
batches. Currently available tools include: absolute elevation,intensity, GPS time, scan angle and return times. If
you are unsatisfied about the classification result and wish to do it all over again, you can use this tool to recover
point cloud class.

Usage

Click Plugin > Classify > Class Conversion

Parameters

Input Data: The input data can be single or multiple, must have been opened in Lipowerline.
from Class
to Class
Attribute: Classify by attribute.



None(by default): Change all points in "from class" to "to class".
Absolute Elevation: Classify by absolute elevation.
Intensity: Classify by intensity.
GPS time: Classify by GPS time.
Scan Angle: Classify by scan angle.
Return Times: Classify by return times.



Classify Buildings

Brief

This function classifies buildings in point cloud data.

Usage

Click Classify > Classify Buildings

Settings

Input Data: The input file can be a single point cloud data file or a point cloud dataset, which must be
opened in the LiPowerline software and has already been classified by ground points.
From Class: Source class(es).
Ground Class: The default ground point is 2-class.
To Class: Target class.
Normal Radius (m, default value is "3"): The radius of the neighborhood when calculating the normal
vector of each point in the point cloud. Usually set to 4-6 times the distance between points.
Angle Threshold (°, default value is "10"): The angle threshold between two points in plane clustering.
When the actual angle of two points is less than the threshold, the two points will be clustered into the same
group.
Elevation Tolerance (m, default value is "0.6"): The distance threshold from point to plane in plane
clustering, which is expected to be slightly larger than the average point distance. When the actual distance
is less than the threshold, the point and plane will be clustered into the same group.
Minimum Points Number (default value is "100"): The minimum points number of building patches.
Max Slope (°, default value is "60"): The angle between the plane and the vertical direction. Greater than
this value is not considered as the top of the building but the wall or other classes.



Max Building Size (m, default value is "60"): The maximum length of buildings, which was used for the
detection of building patches between blocks.
DefaultValue: Click this button to set all parameters as default.

Note: Using this function requires that the point cloud has been classified by ground points.



Classify Model Key Points

Brief

This function can thin a certain level of the classified points. It is generally used to generate a sparse point set
that retains the key points in the complex terrain area and thin the points in the flat area from the extracted dense
ground points.

The idea of the algorithm is: first, meshing of point cloud data, and then use the seed points in the grid to
establish the initial triangulation network. According to the upper and lower boundary thresholds, the points that
meet the conditions are added to the triangulation network. The process is iterated until all of the key points of
terrain model are classified. In the following figure, the yellow point is the ground point and the purple point is the
key point of terrain model.

Usage

Click Classify > Classify Model Key Points

Settings

Input Data: The input file can be a single point cloud data or a point cloud dataset, which must be opened in
the LiPowerline software.
From Class: Source class(es).
To Class: Target class.
Tolerance Above (m, default value is"0.15"): The maximum allowable elevation tolerance value over the
triangulation model composed by the original points. The larger the value, the more sparse the key points will



be extracted, and vice versa.
Tolerance Below (m, default value is"0.15"): The maximum allowable elevation tolerance value under the
triangulation model composed by the original points. The larger the value, the more sparse the key points will
be extracted, and vice versa.
Grid Size (m, default value is"20"): The value is used to ensure the density of key points extracted from the
model. For example, if you want to ensure that there is at least one point in the grid every 20 meters, this
value is set to 20.
DefaultValue: Click this button to set all parameters as default.



Rectify

Usage

Click Plugins > Rectify

Note: You have to create at least two display windows (except the profile window) before using this tool.

Steps

1. Create two display windows and load the reference data and the to-be-aligned data into separate windows.
Click the Rectify tool to open the following dialog.

Brief: This tool is used for coordinate rectification of to-be-aligned data with respect to reference data.
The two datasets can be "point cloud and point cloud", "point cloud and image", or "image and image".
At least 3 pairs of homologous points(or fitted spheres in point cloud) should be added in the datasets,
which are displayed in separate windows, before the calculation of transformation parameters. You can
evaluate the accuracy using the residuals of homologous points listed in the table window.



2. Select Reference window for the reference data and Alignment window for the to-be-aligned data. Then
click the Binding button. The following table window with a series of tools pops up.

3. (Optional) Click the Change Datum button to exchange the reference window and alignment window, if they
were mistaken.

4. (Optional) Click the Load Data button to load homologous points from existing file. Then you can skip the
manual measurement (steps 5, 6, 7).

5. Click Pick Point or Pick Registration Sphere to measure a pair of homologous points (or fit a pair of spheres)
in reference window and alignment window. If spheres are fitted, their centers are used as homologous
points.

6. Click the button Add Point to add blank row for a new pair of homologous points.

7. Repeat steps 5 and 6 to pick at least three pairs of homologous points (or spheres).

8. (Optional) If the option Predict is checked and there exist at least 3 pairs of homologous points, the
corresponding position in the reference window will be predicted after picking a point in the alignment
window.

9. (Optional) The user can exclude a pair of homologous points in the calculation of transformation
parameters: (1) Uncheck the row of the homologous points in the table; (2) Or click the Delete Point button
after selecting the corresponding row.

10. (Optional) The user can modify the coordinates of added homologous points: (1) Pick point again in the
alignment window and reference window after selecting a row of homologous points; (2) Or double click the
coordinates in a row, then input new values directly.

11. (Optional) The user can view each homologous point quickly for quality check: Double click a row in the
table to jump to the corresponding positions in the display windows.



12. (Optional) Click the Save Data button to save the homologous points to file.

13. Click the button Transform to calculate transformation parameters and generate aligned data.

Toolbar

Following functions are integrated in the toolbar.

 Save Data: Save homologous points to file.
 Load Data: Load homologous points from file (Please refer to File Format of Homologous Points).
 Change Datum: Exchange reference window and alignment window. The homologous points are also

exchanged.
 Add Point: Add blank row for a new pair of homologous points in the table.
 Delete Point: Delete selected row in the table.

Point Size (Default: "20"): Point size of homologous points in display windows.

Predict (Default: Unchecked): If this option is checked and there exist at least 3 pairs of homologous points, the
corresponding position in the reference window will be predicted after picking a point in the alignment window.

 Pick Point: Pick homologous points in reference window and alignment window.
 Pick Registration Sphere: If target ball is used for point cloud registration, this function can fit sphere

automatically after clicking the target ball in point cloud. The sphere center is used as homologous point.
R: Radius for sphere fitting. Please input the actual radius of target ball.

RMS: The threshold of root mean square error for sphere fitting. Please set larger value for point cloud of low
quality in case of fitting failure.

Transform: The coordinates are rectified based on homologous points. While processing image data, the
user can specify different methods, which include polygonal correction and polynomial correction. The polynomial
correction varies depending on N pairs of homologous points.

Polynomial Correction Condition

Primary Polynomial 3 <= N < 6

Quadratic Polynomial 6 <= N < 10

Cubic Polynomial 10 <= N



Power Line
To handle and analyze power line channel based on point cloud data, including Distribution Network Inspection,
Point Cloud Realtime Condition, Vector Realtime Condition, Simulation Condition, Completion Acceptance, Fine
Inspection, Measurement and Toolbox etc.

Distribution Network Inspection

Point Cloud Realtime Condition

Vector Realtime Condition

Simulation Condition

Completion Acceptance

Fine Inspection

Measurement

Tool Box

Detection Result List



Distribution Network Inspection
Distribution network inspection is suitable for quickly classifying and detecting the point cloud after collecting data
for field operations, and generating clearance dangerous point detection reports. This module also supports
generating distribution network trajectory and archiving photos. Specific functions are as below:

Add Data

Settings

Mark Tower

Clip and Classify

Classification Tools

Profile Tools

Batch Processing

Clear

Multiple Directory Report

Trajectory Planning

Measure Tower Inclination

Photo Archiving

Open Working Directory



Settings

Summary

Common Settings

The user can set the working directory, input point cloud spatial coordinate, classification and detection
parameters, detected line voltage level and add configuration tables. The software can record the user's last 5
input history records. User can select the most recently used item in the drop-down list. The working directory is
used to manage the project. The prj.ini file in the working directory records the point cloud coordinate system,
classes and detection parameters, and voltage level of the current project.

Working Directory: Used to save the intermediate and final results.
Input Point Cloud Spatial Coordinate: The coordinate system of the point cloud data.
Classification and Detection Parameters: Set the path of the xml format configuration file.
Detected Line Voltage Level: The voltage level of the detected power line.
Add Configuration Table: If the detection line voltage level list is empty and does not contain the current
voltage level, user can add a new voltage level by adding a configuration table and set its safety distance
detection parameters.

Power line parameter settings include common settings and detection parameter settings. Common
settings include working directory, input point cloud spatial coordinate, classification and detection
parameters, detected line voltage level; classify detection parameter settings include class settings,
detection types, and safety distance settings.



Detection Parameter Settings

Displays key detection classes and safety distance detection parameters. User can add voltage levels and then
configure their corresponding detection parameters, including clearance distance analysis and crossing analysis.
Clearance detection distance analysis includes detections for different classes of objects, as well as different
safety distance and distance detection methods. For scissors crossing analysis, user only needs to set the
classes to be detected, and user does not need to set a safety distance.

Select: Whether to detect this class.
Checked (default): Detect the danger point in this class.
Unchecked (default): Do not detect the danger point in this class.

Class: Select the number (from 1 to 32) of the class in the drop-down menu.
Detection Type: Select the detection type in the drop-down menu.

Clearance Distance: Judge the point whether to be a danger point by the clearance distance. If the
distance is less than this value, it is a danger point.
Vertical Distance: Judge the point whether to be a danger point by the vertical distance. If the distance
is less than this value, it is a danger point.
Horizontal Distance: Judge the point whether to be a danger point by the horizontal distance. If the
distance is less than this value, it is a danger point.
Horizontal Distance / Vertical Distance: Firstly judge the point whether to be a danger point by the
horizontal distance. If the distance is less than set horizontal value, it is a danger point. If the distance is
larger than set horizontal value, judge the point whether to be a danger point by the vertical distance.
Horizontal Distance / Clearance Distance: Firstly judge the point whether to be a danger point by the
horizontal distance. If the distance is less than set horizontal value, it is a danger point. If the distance is



larger than set horizontal value, judge the point whether to be a danger point by the clearance distance.
Horizontal Distance / Vertical Distance / Clearance Distance: Firstly judge the point whether to be a
danger point by the horizontal distance. If the distance is less than set horizontal value, it is a danger
point. If the distance is larger than set horizontal value, judge the point whether to be a danger point by
the vertical distance. If the distance is less than the set vertical distance, it is a danger point. If the
distance is larger than the set vertical distance, judge the point whether to be a danger point by the
clearance distance then.

Add Row: Add a new detection class record.
Delete Selected Row: Delete the selected row of detection class.
Add Column: Add a new column for a severity level threshold. I.E., severe, important, and general.
Delete Selected Column: Delete the selected column.
Modify Selected Column Name: Modify the name of selected column.
Save: Save the configuration to the current xml file.
Save as: Save the configuration as a new xml file.

Note: In crossing analysis, if user does not select the detection class, software will only analyze the upper
crossing and lower crossing by default.



Tower Edit
Tower editing includes Tower List, Mark Distribution Network Tower and Tower Tools. The tower list provides a
single line tower marking tool that supports marking tower points and importing and exporting tower files in
multiple formats. Marking distribution network towers is a tower marking and management tool provided for
multiple lines in the distribution network. It supports managing tower information for multiple lines in a tree
structure, automatically creating work directories, and generating tower files. Tower tools provides various tower
operation related functions, such as automatically saving tower files, automatically extracting tower points, and
generating tower account.

Tower List

Mark Distribution Network Tower

Tower Tools



Mark Tower

Summary

After clicking in the point cloud data and choosing the tower type, user can save the result into LiTower file. After
adding the position information of the tower, the software will automatically generate the index and name
information of the tower. Index is a number starting from the starting value and incrementing by 1. By default,
name is the same as Index. Tower type includes "None Type", "Tension Tower" and "Straight Line Tower".
Double-click the row for each tower to jump to that tower in the displaying window. By checking or unchecking the
checkbox in front of "Show All Tower Points" to display or hiding the tower points in the window. Point size can be
modified. By clicking the hot key "S" and "D" on the keyboard to move the edited tower record forward or
backward.

Show All Tower Point(checked by default): Display the tower names or indexes in the window. Uncheck
this option to hide the all the tower names or indexes.
By Index: Display the tower index.
By Name: Display the tower name.
Display Mode: In the 3D view of Mode 1, the size of the tower annotation changes with the zoom of the
view, while in the 3D view of Mode 2, the size of the tower annotation remains fixed and unchanged.



Point Size(meters)(default value is "5.0"): Set the red marker sphere and text font size of the tower.
Start Index: The number of the first tower is set to 1 by default. 

Mark Tower

Add Tower Backward

Add Tower Forward

Delete Tower

Modify Tower Position

Tower Centralization

Click this button to start to pick the tower points. Click again to exit this function and save the current
tower information to the tower.LiTower file in the working directory.

Add a tower record after currently selected record.

Add a tower record before currently selected record.

Delete the current selected tower record.

Modify the position of the selected tower.

Click this button and the centralize tower window will popup. Click to select several points on the tower,
and click calculate button to get the center point of the tower. Click the function button again to exit this
function, and the tower information will be stored in the tower.LiTower file in the working directory.



Clip Point Cloud

Cancel Clip

Batch Edit Tower Name

Right-click on the "Name" column in the tower list, and the popup selection menu is shown in the figure below,
including "Add Prefix", "Adding Suffix", and "Batch Editing". It can be used to add prefix, suffix, or simultaneous
edit the tower names.

Batch Edit Tower Type

Right-click on the "Type" column in the tower list, and the popup selection menu is shown in the figure below,
including "Set As Straight Line Tower" and "Set As Tension Tower". User can modify the tower type as straight
line tower or tension tower in batches.

Clip point cloud in the view to facilitate tower marking operations.

Cancel clipping point clouds in the view and restore the original point cloud view.



Import Tower File

1. Adjust the data type for each column, and select the number of skipped rows and the type of separator.
2. If the input data's coordinates are in latitude and longitude, user can check the "Transform" option in tab to

convert the geographic coordinates into projected coordinates.
3. Click "Apply" to import the tower file and renew the tower list.

Export Tower File

Input the tower file and renew the tower list in LiTower, txt, csv, and kml format. If the input file is in txt or
csv format, user can follow the steps below to load the tower information.

Export the information in the current tower list to LiTower, KML and CSV file.



1. Select the export file format, including LiTower,KML and CSV format. User can choose the export types of
point, line, point and line when selecting KML.

2. Set the output path.
3. Click "OK" to export the tower file.



Mark Distribution Network Tower

Summary

By managing towers according to distribution network lines, selecting tower positions through mouse interaction,
selecting tower types, and saving them as JSON format files. After adding the position of the tower, the software
will automatically generate default Index and Name information. The Index is incremented based on the starting
value, and the Name is consistent with the Index by default. The tower types include "None Type", "Tension
Tower" and "Straight Line Tower". Double click on the row where each tower record is located to jump to the
corresponding tower location. Select to show/hide all branches or tower points of the selected branch through the
"Show Branch" checkbox, and select to show/hide tower Connections through the "Show Tower Connections"
checkbox, with adjustable point sizes. The keyboard shortcuts S and D can move the edited tower record forward
and backward.

Show Branch(by default selected): By default, all branches are selected and the tower name or tower
index is displayed in the window view. Uncheck to hide the tower name or tower index.
By Index: Display the tower index.
By Name: Display the tower name.
Show Tower Connections(by default selected): Show tower connections in the window view, uncheck to
hide tower connections.
Point Size(meters)(default value is "0.5"): Set the size of the red identification ball and text font for the
tower.
Show Mode: In the 3D view of Mode 1, the size of the tower annotation changes with the zoom of the view,



while in the 3D view of Mode 2, the size of the tower annotation remains fixed and unchanged.
Start Tower Index: The number of the first tower is set to 1 by default.

Open File

Save File

Import File

Add Branch

 

Open the distribution network tower file(*.json) and refresh the line list and tower list.

Save line and tower information to a file (*.json).

Import tower files (*.LiTower *.kml), and manually maintain the line branch relationships after importing.

Add a line branch. If no branch is selected in the line list, create a main branch. If a tower of a branch is
selected, create a sub branch of that branch.



1. Branch Name: Set the name of the branch line.
2. Branch Color: Set the branch line color.
3. Attribute: Optional input of information to be recorded.
4. Parent Branch Name: Select an existing branch as the parent branch.
5. Main Branch Name: read-only status, automatically updated based on the selected parent branch, used for

viewing.
6. Start Tower Name: Select a tower from the parent branch as the starting tower.
7. Main Branch: If no tower is selected for adding a branch, it is selected by default. Otherwise, it is not

selected. If it is not selected, the parent branch and starting tower need to be set.
8. Click "OK" to create a new branch and update the line list.

Modify Branch

Delete Branch

Clear Line List

Add Tower Backward

To use this function, you should first select the branch to be modified in the line list before making any
modifications. The modification items are consistent with "Add Branch".

Delete the currently selected branch and its subordinate branches, as well as the tower records under
these branches.

Clear all line and tower records.

Add a tower record after currently selected record.



Add Tower Forward

Delete Tower

Modify Tower Position

Generate Working Directory

Add a tower record before currently selected record.

Delete the current selected tower record.

Modify the position of the selected tower.

Generate the corresponding working directory for each branch, and output the working directory and
tower file (*.LiTower) for each branch according to the specified output path.



1. Generate KML: It is not selected by default. If selected, a KML file will be generated, otherwise it will not be
generated.

2. Merge KML: Not selected by default. When generating KML, selecting "Merge KML" will generate a merged
KML to the output path, otherwise it will not be generated.

3. Point File: Not selected by default. When generating KML, selecting "Point File" will generate a point file to
the output path, otherwise it will not be generated.

4. Generate Tower Distance Account: It is not selected by default. If selected, a tower distance account will be
generated; otherwise, it will not be generated.

5. Use Branch Tower Naming Rules: It is selected by default. If selected, according to the naming rules for
branch line towers, set the name of the starting tower for the branch line.

6. Use Start Tower Index: It is selected by default. If selected, use the starting tower index of the branch line as
the tower name.

7. Use Original Tower Name: It is not selected by default. If selected, use the tower name from the previous
level of the line as the starting tower name for the branch line.

8. Adjust Tower Name: It is not selected by default. If selected, set the prefix or suffix of the tower name in the
working directory folder name.

9. Use Second Tower Name: It is not selected by default. If selected, Check this option to use the name of the
second tower as the starting tower name for lines with parent branches. In other cases, use the name of the
first tower as the starting tower name.

10. Output path: Select the output path.
11. Click "OK" to output the working directory and specify the output file.

Batch Clip Section
Batch clip point cloud data based on the marking results of the distribution network towers. The
functional interface is shown in the following figure, click to add pending data, click to remove the
selected data, click to clear the data list.



Channel width(meters)(default to "60"): The width that extends along the direction of the power line
towards both sides. The software can record the user's current settings and automatically restore them when
opened again.
Extension length(meters)(default to "10"): The extension distance at both ends of the tower.
Point cloud compression(not selected by default): Perform thinning on the processed data.
Root directory: Set the output root directory.

Batch Edit Tower Names

Right click on the "Name" column header of the tower list, and a selection menu will pop up as shown in the
following figure, including "Add Prefix", "Adding Suffix", and "Batch Editing". It can be used to add prefix, suffix, or
simultaneous edit the tower names.



Batch Edit Tower Types

Right click on the "Type" column header of the tower list, and a selection menu will pop up as shown in the
following figure, including "Set As Straight Line Tower" and "Set As Tension Tower". User can modify the tower
type as straight line tower or tension tower in batches.



Tower Tools

Auto Save Tower File

Reverse Sequence Of Tower

Extract Tower Point

Set a time interval to automatically save tower files and prevent tower data loss due to unexpected
situations.

Automatically reverse the list of towers and save it to the specified file.

Interactive extraction of tower point: Manually select the area where the target line is located and
automatically extract tower point within that area. Commonly used in scenarios where multiple lines are
parallel, try to avoid including other lines when selecting boxes.

Automatic extraction of tower points: Using input point clouds for classification, clustering the tower point
clouds and extracting tower point. The extracted tower point can be sorted based on the wire connection
relationship between the towers.



Set Parameters
Sort: Whether to sort, if not checked, default sorting will be used.
Start Tower Index: The starting value of the tower number is incremented in sequence for subsequent
tower numbers.
Cluster Radius(meters)(default value is "4.00"): The clustering radius of tower point clouds is
generally set as the minimum distance between towers.
Similar Ratio: The height similarity of the same series of towers is generally the ratio of the minimum
height to the maximum height of all towers.
Threads Num(4 by default): Set the number of thread when running the tool.
Default: Restore default parameter settings.

Extract Tower Points Based On Photos
Automatically extract tower points based on photos. The functional interface is shown in the following
figure, which can process multiple data simultaneously. Click to add pending data, click to remove
the selected data, click to clear the data list.



Set Parameters
LiTower: Selected by default. Select to output the LiTower file. If not selected, the LiTower file will not
be output.
KML: Selected by default. Select to output the KML file. If not selected, the KML file will not be output.
Output Path: Set the output path of the analysis result file, which defaults to the working directory.

Calibrate Tower Point Position

Tower Material Type Settings

Automatically calibrate the position of tower points. To use this function, the tower points should be
classified first before calibration.

Edit the material type of the tower, which can be opened and saved as a file (*. txt). The file is applied to
Measure Tower Inclination.



Tower Account

Generate a tower account file.



Clip/Classify

Summary

Usage

Click Clip/Classify > Clip and Classify.

Clipping and classifying the point cloud data into segments. The classification process will classify the
tower, conductor, shield line, insulator, drainage thread, scissors crossing line, ground, vegetation,
buildings, road, and water in the point cloud. This function can process multiple data simultaneously.
Click to add the data to be processed. Click to remove the selected data. Click to clear the
data list.



Settings

Output Path: Set the output path.
Clip (Checked by default): Clip the data into segments. If this option is unchecked, the data will not be
clipped.

Channel Width (meter) (default value is "60"): Width extending along both sides of the power line.
The software can record the user's current settings and automatically restore the settings when opened
again.
Segment Buffer (meter) (default value is "10"): Extension distance at both ends of the transmission
tower.
Start Tower Index: Towers with index numbers smaller than this value do not participate in gear
shifting. The default value is the minimum Index in the tower file.
End Tower Index: Towers with index numbers greater than this value do not participate in gear shifting.
The default value is the maximum Index in the tower file.
Point Cloud Compression (Unchecked by default): Resampling the processed data.

Classify (Checked by default): Using deep learning classification strategies to classify categories such as
towers, conductors, shield lines, insulators, drainage thread, scissors crossing up, scissors crossing down,
other lines, buildings, water, highway and noise.

Shield Line: Classify shield lines.
Insulator And Drainage Thread: Classify insulators and drainage threads, with this option available for
voltage levels of 35kV and above.
Scissors Crossing Up: Classify scissors crossing up.
Scissors Crossing Down: Classify scissors crossing down.
Noise: Classify noises.
Ground Points: Please refer to the classify ground tool for details.
Buildings: Classify building points.
Other Lines: Classify parallel lines.
Water: Classify water points.
Highway: Classify road points.

Process Overlapping Area(Checked by default): Process the overlapping areas between segments in the
section data to ensure consistent point cloud categories; If not checked, the point cloud in the overlapping



area of adjacent segment data may flicker during browsing due to inconsistent categories.
Threads Number (default value is "6"): Set the number of thread (1 to 32) to run this function. The
software can record the currently setting and when the user open this function again, the setting will be kept.
Default Value: Restore the default parameter settings.

Note: The segmented data will be stored in the output path folder. The name of the file will be (Smaller
Tower Index_Larger Tower Index). In order not to impact the following steps, it is highly recommended not
to change the file name. After the automatic classification, user need to check the accuracy of the result
and manually modify it in the Profile Tools.



Classification Tools

Summary

Classify by Attribute

Classify Ground

Classify Low Points

Classify by Below Surface

Classify Isolated Points

Classify Air Points

Classify by Height Above Ground

Classify by Min Elevation

Classify Buildings

Classify Model Key Points

Classification tools are mainly used to automatically classify the point cloud in different classes. The tool
set includes classify ground, classify by attribute, classify low points, classify by below surface, classify
isolated points, classify by height above ground, classify by min elevation, classify buildings, and classify
model key points.



Batch Detection and Analysis

Summary

Usage

Click Distributing Network Inspection > Tree Barrier Analysis > Batch Processing

Parameters

According to the tower file, the point cloud is processed in a procedure of detection and analysis, and
the dangerous point detection and scissors crossing analysis are carried out in sequence, the
dangerous point image and report are generated. The detection and analysis batch processing interface
is shown in the figure below. This function can process multiple data at the same time. Click to add
data. Click to remove data selected(remove the first record of the list if no data is selected). Click
to clear data list.



Clearance Danger Point Detection: Run Clearance Danger Point Detection.
Analysis(checked by default): Detect dangerous clearance points based on the set safety distance
threshold.
Report(checked by default): Generate clearance danger point detection report.

Scissors Crossing Analysis: Run Scissors Crossing Analysis.
Analysis(checked by default): Perform scissors crossing analysis based on the set parameters.
Report(checked by default): Generate scissors crossing analysis report.

Vector File: Input the vector file in shp format. The software can record the user's current settings and user
can restore the settings in the drop-down menu or select button next time when opening this function.
Simulation File: Input the simulation file (*.LiSim file). The software can record the user's current settings
and user can restore the settings in the drop-down menu or select button next time when opening this
function.
Clearance Danger Point Detection: Parameters in Danger point detection
Scissors Crossing Analysis: Parameters in Scissors Crossing Analysis
Generate Image: Parameters in Generate Image
Generate Report: Parameters in Generate Report
Log: Show log of processing.

Threads Number(4 by default): To set the number of running threads, can support 1-32 threads. The
software can record the user's current setting and automatically restore the setting when it is opened again.

Default: Recover default settings.

Note: If user opens the function from the vector real-time working conditions module, user needs to set the
vector file; if user opens the function from the simulation working conditions module, user needs to set the
working conditions simulation file.



Generate Image UI

Summary

The UI for image generating.

Settings

Image Parameter:
Scale Factor(checked by default): The scale for the generated image.
Color Setting: Set the color of the different classes of point cloud.
Front View Width (pixels) (default is "1000"): Front view width in pixel.
Front View Height (pixels) (default is "450"): Front view height in pixel.
Top View Width (pixels) (default is "1000"): Top view width in pixel.
Top View Height (pixels) (default is "450"): Top view height in pixel.
Profile Thickness(meter) (default is 10): Profile thickness of the images.
Prefix of Tower: Prefix of the tower name.
Suffix of Tower: Suffix of the tower name.
True Color(unchecked by default): Generate images based on true color of point clouds.
Use EDL Effect(unchecked by default): Generate images using EDL enhancement effects.

Subsampling(unchecked by default): Set whether to resample the point cloud.
Grid size X, Y, Z (meters) (default is "0.5, 0.5, 0.1"): Construct a three-dimensional voxel of X Y Z,
one point is reserved in each voxel.



Generate Report UI

Summary

The UI for report generating.

Settings

Report Name: The title of the report.
Assessor Company: The company which generates the report.
Electrical Transmission Bureau / Company: The name of power supply bureau or company.
Line Name: Line name.
Collection Date: The date on which point cloud was collected.
Calculate By Week Seconds: Point cloud collection time is calculated by weeks seconds.
Voltage Level: Cannot be changed by user.
Point Cloud Coordinate: The point cloud coordinate system used in the report.
Target Coordinate: The coordinate system used in the report.
Report Path: The output path of the report.



Clear

Summary

Usage

Click Distributing Network Inspection > Tree Barrier Analysis > Clear

Settings

Clear File
Clearance Danger: Check to clear clearance danger files in the project directory.
Scissors Crossing: Check to clear scissors crossing files in the project directory.

Clear Attribute
Clear Danger Attribute: Check to clear danger attribute.

Threads Number (default value is "4"): Set the number of thread (1 to 32) to run this function. The
software can record the currently setting and when the user open this function again, the setting will be kept.

Clear the results of quick report of danger points, cross over detection, etc. The clear interface is shown
in the following figure. This function can clear multiple data simultaneously. Click to add point cloud
data to be deleted. Click to remove the first item from the list (when there is no data
selected)/selected data. Click to clear the data list.



Multiple Directory Report

Summary

Based on the original reports, the software can merge the reports automatically. This is especially suitable for the
scenarios such as batch data processing and cross projection band data processing. Click  to add the
working directories need to be processed. Click  to remove the selected working directory. Click  to clear
the working directory list. Click the list item to confirm the working directory information.

Confirm information

After adding the working directories, click the list item to confirm the working directory information.

Start Tower Name: The name of starting tower.
End Tower Name: The name of ending tower.
Point Cloud SRS: The coordinate system of the point cloud.

Settings

Data Type: Select the data type to be processed. The data type includes point cloud based data, vector
based data, and data based on working conditions simulation. The software can record the user's current
settings and automatically restore the settings when opened again.

Based on Point Cloud: Extract the powerline data from the original point cloud data.
Based on Vector Data: Extract the powerline data from the vector file, and other classes objects from
original point cloud data.
Based on Simulation Data: Extract the powerline data from the simulation file, and other classes
objects from original point cloud data.

Detection Type: User can select multiple options. Set the detection type, and generate corresponding
reports.

Clearance Danger: Clear the clearance danger point detection result in the cache folder.
Scissors Crossing: Clear the scissors crossing point detection result in the cache folder.
Tree Fall: Clear the tree fall detection result in the cache folder.
Tree Growth: Clear the tree growth detection result in the cache folder.



Generate Report: Set the parameters for report generation.
Assessor Company: The company which generates the report.
Electrical Bureau: The name of power supply bureau or company.
Line Name: The name of the power line section.
Voltage Level: Cannot be changed by user.
Collection Date: The date on which point cloud was collected.
Target Coordinate: The coordinate system used in the report.
Report Path: The output path of the report.

Other:
Display in Degrees(Latitude and Longitude): The coordinates are displayed in longitude, latitude, or
radians.

Simulation File: If user choose to generate the report based on the simulated working conditions data, it is
required to set the simulation file (*.LiSim file).

Note: To ensure the order of automatic merge, please add the working directories in order.



Distribution Network Inspection

Summary

Distribution network inspection module allows users to configure inspections, interactively select tower
component points, and automatically generate distribution network inspection trajectory through software.

Usage

Click on the "Distribution Network Inspection" tab to open the menu, click the "Start/End" button to expand the
menu of trajectory planning, as shown in the following figure.

File Menu

Trajectory Menu

Waypoint

Tools Menu

Setting



Distribution Network Trajectory Operation

Summary

The distribution network trajectory menu is shown in the following figure, which includes functions such as clip
tower, generating distribution network trajectory, model generating trajectory, and safety analysis.

Clip Tower

Generate Distribution Network Trajectory

Generate Distribution Network Trajectory

Generate Channel Trajectory

Generate Point Cloud Data Collection Trajectory

Generate Trajectory With Interactive Method

Click "Generate Distribution Network Trajectory" to generate distribution network inspection trajectory.
The dropdown menu also includes generating channel trajectory, generating point cloud data collection
trajectory, interactively generating trajectory, and merging/splitting trajectory files.

Pick the photo point with the mouse, and then add waypoints based on the scene direction to generate
trajectory.



Add Method: Set the order of waypoint addition.
Add In Order: After selecting, add waypoints in order.
Insert After Selected Point: After selecting, insert a waypoint after the selected waypoint.

Automatic Waypoint Generation:
Take Photo: Check to generate waypoints with photo information. Uncheck to generate auxiliary
waypoints and tower crossing waypoints, etc.
Safety Analysis: Check to perform real-time safety analysis when adding waypoints.
Camera Type: Set the camera type. By default, it is read from the camera configuration.
Edit Waypoint: Click to jump to the edit waypoint function.
Shooting Distance: Set the distance from the waypoint to the photo point.
Waypoint Speed: Set waypoint speed.

Select Point Cloud With Ctrl:Click the Ctrl key to pick up the photo point again with the mouse and modify
the current waypoint position.

Merge/Split Trajectory Files

Options:
Merge(Trajectory Without Part Points): Merge multiple trajectory files in the order of the file list, and
the merged number of waypoints should not exceed the maximum number of waypoints.
Split(By Tower): Split the trajectory according to the principle of the closest horizontal distance between
the waypoint and tower position, and save the trajectory file in the output directory.

Merge Parameters:
Maximum Waypoints Count: Set the maximum number of merged waypoints, and when it exceeds the
maximum number of waypoints, the log will prompt and output.

Output Path: When merging, set the path to the merged file. When splitting, set the output folder.

Merge and split distribution network trajectory files in different ways.Click to add trajectory files. Click
to remove the selected vector data(remove the first record of the list if no data is selected). Click

to clear data list. Click to sort the trajectory files by tower names.



Generate Distribution Network Tower Trajectory(Surround Method)

From Model

Generate Trajectory Model

Safety



Measure Tower Inclination

Summary

Usage

Click Measurement > Measure Tower Inclination

By selecting the top and bottom points on the tower, calculate the tower inclination rate and the tower
height along the line direction and vertical line direction. And save the result in the specified directory.



Tower Point List

Calculate

Calculate the tower inclination according to the picked points. And display the result in the result list.

Add top tower points.

Add bottom tower points.

Delete selected the tower points.

Modify the selected tower point.

Clear tower points. This function includes "Clear Top Points", "Clear Bottom Points", and "Clear All
Points".



Result List

Parameters

Tower Name: Name of the target tower.
Tower Height(meters): The tower height information fetched from the point cloud data.
Tilt Rate of Line Direction: The inclination of the transmission tower along the main direction connecting
with the next transmission tower.
Tilt Rate of Vertical Line Direction: The inclination of the tower along the direction perpendicular to the
main direction of the line connecting to the next tower.
Standard Value: If tower tilt rate is lower than this value, this tower is consider qualified.
Tilt Direction of Line Direction: Tilt direction of line direction of the tower.
Tilt Direction of Vertical Line Direction: Tilt direction of vertical line direction of the tower.
Qualification: Does the calculation result meet the standard value.

Auto Calculate Tower Inclination

Summary

Open the tower inclination file.

Save the tower inclination file. The default position to save the information is the "TowerInclination.txt"
file in the tower analysis folder in the working directory.

Delete the selected record.

Clear the records in the list.

Import automatic calculation result of tower inclination.

Auto Calculate Tower Inclination.

Calculate Qualification By Specification.

Analyze and calculate the tower with the selected point cloud data, automatically calculate the tower tilt
parameter and save it to the result list. The function interface is shown in the following figure, which can
process multiple data at the same time. Click to add data. Click to remove data selected. Click
to clear data list.



Parameters

Tower Body Class: Pole point cloud category number.
Layer Height(meters): Calculated layer height.
Tower Height(meters): Set tower height.

Tower Inclination Report
Save the tower inclination file and generate the report.



Parameters

Please refer to Report Parameters for details.

Note: Before using this tool, user needs to classify the transmission tower in the point cloud.

Note: The tower tilt rate is the percentage of the ratio of the tower tilt value S to the height above the
ground H; that is, the tilt rate = the tilt value / the entire height of the tower.



Open Working Directory

Summary
Open the working directory of the current power line project.



Point Cloud Realtime Condition
To handle and analyze power line channel based on point cloud data and to generate analysis report. Specific
functions are as below:

Add Data

Settings

Mark Tower

Information

Clip and Classify

Classification Tools

Profile Tools

Danger Points Detection

Scissors Crossing Analysis

Water Analysis

Batch Processing

Tree Growth Analysis

Tree Growth Warning Analysis

Tree Fall Analysis

Clear

Generate Image

Generate Report

Multiple Directory Report



Line Information Collection

Line Name

Power Line Type

Collection Time

Working Condition Parameter

Line information collection includes line name, power line type, collection time and working condition
parameter.



Line Name

Summary

Set the line name of current line.



Power Line Type

Summary

Select the transmission tower type (straight line tower / tension tower) and then set the line type between each
two towers. Save the power line type file.

Usage

Click Collection > Information > Power Line Type.

Open File

Save File

Add Power Line Type

Open the power line type file

Save the power line type file. The default output path is the information folder in the working directory.
The results are in the "SectionPowerLineType.csv" file.

Add a new power line type, and set the start and end transmission towers name.



Delete Power Line Type

Modify Power Line Type

Check Availability

Delete the selected power line type.

Modify the selected power line type.

Check if there is any overlap in the power line type of different tower sections.



Collection Time

Summary

Set the collection time in different tower sections. Save the collection time file.

Usage

Click Collection > Information > Collection Time.

Open File

Save File

Add Collection Time

Open the collection time file.

Save the collection time file. The default output path is the information folder in the working directory.
The results are in the "CollectionTime.csv" file.

Set the start and end transmission towers name, and set the collection time.



Delete Collection Time

Modify Collection Time

Check Availability

Delete the selected collection time.

Modify the selected collection time.

Check if there is any overlap in the collection time of different tower sections.



Working Condition Parameter

Summary

Set the working condition parameter in different tower sections. Save the working condition parameter file.

Usage

Click Collection > Information > Working Condition Parameter.

Open File

Save File

Add Working Condition Parameter

Open the working condition parameter file.

Save the working condition parameter file. The default output path is the information folder in the
working directory. The results are in the WorkingConditionParameter.csv file.

Set the start and end transmission towers name, and set the working condition parameter.



Delete Collection Time

Modify Collection Time

Check Availability

Delete the selected working condition parameter.

Modify the working condition parameter.

Check if there is any overlap in the working condition parameter of different tower sections.



Danger Points Detection

Summary

Usage

Click Realtime Analysis > Danger Points

Settings

Detection Parameter:
Cluster By Class( Unchecked by default.): Used to control whether to cluster the result by class.If this
option is checked, the danger points will be clustered into different groups if they are in different classes;
otherwise, the class information will not influence the clustering process. The software can record the
user's current settings and automatically restore the settings when opened again.
Min Distance (meters) (default value is "0.3"): Points with clearance distance less than this distance
are not detected as danger points, as they are considered to be noise. The software can record the
user's current settings and automatically restore the settings when opened again.

Judge if the point is a danger point according to the clearance distance and the set safety distance. The
interface of the clearance danger point detect function is shown as follow. This function can process
multiple data simultaneously. Click to add the data to be processed. Click to remove the selected
data(remove the first record of the list if no data is selected). Click to clear the data list.



Safe Distance (meter) (default value is "4.5"): If the distance between the detected point and the
power line point is greater than the minimum distance and less than or equal to the safe distance, the
point is considered to be a danger point. If the xml file is not set, user needs to enter the safety distance;
otherwise, this parameter is extracted from the xml file. When using the xml to set the parameter, user
can set different safety distances for different classes, and for different severity level.
Cluster Threshold (meter) (default value is "15.0"): The maximum spatial separation distance when
the detection results are clustered. This value should be smaller than the maximum clustering range.
Three-dimensional Euclidean clustering is used to cluster the danger points. The software can record
the user's current settings and automatically restore the settings when opened again.
Max Cluster Range (meters) (default value is "20.0"): After the detection results are clustered, if the
length along the power line direction is greater than this value, they are divided into multiple dangerous
point clusters. The software can record the user's current settings and automatically restore the settings
when opened again.

Vector File: Input the vector file in shp format. The software can record the user's current settings and user
can restore the settings in the drop-down menu or select button next time when opening this function.
Simulation File: Input the simulation file (*.LiSim file). The software can record the user's current settings
and user can restore the settings in the drop-down menu or select button next time when opening this
function.
Threads Number (default value is "4"): Set the number of thread (1 to 32) to run this function. The
software can record the currently setting and when the user open this function again, the setting will be kept.
Default Value: Restore the default parameter settings.

Note: After the analysis, user can check the result accuracy in Clearance Danger Point List.

Note: If user opens the function from the vector real-time working conditions module, user needs to set the
vector file; if user opens the function from the simulation working conditions module, user needs to set the
working conditions simulation file.



Scissors Crossing Analysis

Summary

Usage

Click Realtime Analysis > Scissors Crossing

Calculate the scissors crossing point by cross analysis on the power line and the detected classes of
points. The interface of scissors crossing analysis is shown as follow. This function can process multiple
data simultaneously. Click to add the data to be processed. Click to remove the selected
data(remove the first record of the list if no data is selected). Click to clear the data list.



Settings

Detection Parameter:
Cluster Radius (meter) (default value is "3.0"): The maximum spatial distance when clustering
crossing points. The crossing point clusters in the range extract the nearest vertical distance point as the
crossing point of the cluster.
Buffer Size (meter) (default value is "0.5"): The power line point cloud in a certain buffer area near the
horizontal range of cross line will participate in the calculation.
Add Danger Points into Calculation(unchecked by default): Add danger points to the analysis and
calculation of intersection points.
Split Crossing Line(unchecked by default): Calculate the intersection point of each wire separately.

Vector File: Input the vector file in shp format. The software can record the user's current settings and user
can restore the settings in the drop-down menu or select button next time when opening this function.
Simulation File: Input the simulation file (*.LiSim file). The software can record the user's current settings
and user can restore the settings in the drop-down menu or select button next time when opening this
function.
Threads Number (default value is "4"): Set the number of thread (1 to 32) to run this function. The
software can record the currently setting and when the user open this function again, the setting will be kept.
Default Value: Restore the default parameter settings.

Note: After the analysis, user can check the result accuracy in Scissors Crossing Analysis List.

Note: If user opens the function from the vector real-time working conditions module, user needs to set the
vector file; if user opens the function from the simulation working conditions module, user needs to set the
working conditions simulation file.



Water Analysis

Summary

Usage

Click Realtime Analysis > Water

Settings

Detection Parameter:
Safe Distance (meter) (default value is "4.5"): The threshold of safety distance. If the distance from
the power line to the waterbody under it is less than this value, the corresponding point on the power line
will be recognized as a danger point.
Density Threshold (/square meter) (default value is "0"): The threshold used to extract the
waterbody from the point cloud. Those areas with point density lower than or equal to this value will be
recognized as "suspected waterbodies". After this extracting, merge the suspected waterbodies close to

Based on the "black hole" in the point cloud data, those continuous hollow areas which meets
requirements in the set parameters will be determined as the water area. Then the software will
calculate the distances from the power line points to the water surface to judge if the point on the power
line is danger point. The interface of water analysis is shown as follow. This function can process
multiple data simultaneously. Click to add the data to be processed. Click to remove the selected
data(remove the first record of the list if no data is selected). Click to clear the data list.



each other.
Smoothing Factor (default is "2"): Smooth the edge of the waterbody. The smaller the value is, the
finer the smoothing effect will be.
Area Threshold (square meter) (default value is "4000"): The threshold to extract the waterbody. If
the detected area is larger than this value, it will be recognized as waterbody.

Vector File: Input the vector file in shp format. The software can record the user's current settings and user
can restore the settings in the drop-down menu or select button next time when opening this function.
Simulation File: Input the simulation file (*.LiSim file). The software can record the user's current settings
and user can restore the settings in the drop-down menu or select button next time when opening this
function.
Threads Number (default value is "4"): Set the number of thread (1 to 32) to run this function. The
software can record the currently setting and when the user open this function again, the setting will be kept.
Default Value: Restore the default parameter settings.

Note: If user opens the function from the vector real-time working conditions module, user needs to set the
vector file; if user opens the function from the simulation working conditions module, user needs to set the
working conditions simulation file.



Tree Growth Analysis

Summary

Usage

Click Early Warning Analysis > Tree Growth

Based on the result of individual tree segmentation, calculate and extract the danger points after a
certain period of growth. This function can process multiple data simultaneously. Click to add the
data to be processed. Click to remove the selected data(remove the first record of the list if no data
is selected). Click to clear the data list.



Settings

Tree Growth Parameter:
Constant Growing Speed (default): If this option is checked, "Growth Speed" will be allowed to be set,
and all kinds of trees will be considered to grow at this growth rate.

Growth Years (year) (default value is "1"): Set the predicted growth time. The software can
record the user's current settings and automatically restore the settings when opened again.
Growth Rate (meter/year) (default value is "0.3"): Set the tree growth rate. The function can
record the user's current settings and automatically restore the settings when opened again.

Custom Growing Speed for Species: If this option is checked, user can set the growth rate for
different tree species in the table. Tree species files can be generated from Tree Species Classification,
and the default growth rate is 1 meter / year.

Start Time: Set the start time of growth.
End Time: Set the end time of growth.
Tree Species Growth Rate File: Set the growth rate file path for tree species.

Clustering Parameter:
Cluster(unchecked by default): If this option is checked, the software will cluster the result; otherwise,
the software will not cluster the result. The software can record the user's current settings and
automatically restore the settings when opened again.
Cluster Threshold (meter) (default value is "15.0"): The maximum spatial separation distance when
the detection results are clustered. This value should be smaller than the maximum clustering range.
Three-dimensional Euclidean clustering is used to cluster the danger points. The software can record
the user's current settings and automatically restore the settings when opened again.
Max Clustering Range (meter) (default value is "20.0"): After the detection results are clustered, if the
length along the power line direction is greater than this value, they are divided into multiple dangerous
point clusters. The software can record the user's current settings and automatically restore the settings
when opened again.
Safe Distance (meter) (default value is "4.5"): If the distance between the detected point and the
power line point is greater than the minimum distance and less than or equal to the safe distance, the
point is considered to be a danger point. If the xml file is not set, user needs to enter the safety distance;
otherwise, this parameter is extracted from the xml file. When using the xml to set the parameter, user
can set different safety distances for different classes, and for different severity level.

Tree Segmentation Parameter:
Smoothing Factor (default value is "1.5"): Individual tree segmentation smoothing coefficient. If there
are too many trees, increase the smoothing factor, otherwise, decrease the smoothing factor.
Height Above Ground (meter) (default value is "1.0"): Point clouds above ground by distances
greater than this value are used for individual tree segmentation, and less than this value will not be
segmented.

Vector File: Set vector file in shp format. The software can record the user's current settings, and can be



selected through the drop-down menu or selection button when it is opened again.
Simulation File: Set the input simulation file (*.LiSim file).
Threads Number(default value is "4"): Set the number of thread (1 to 32) to run this function. The software
can record the currently setting and when the user open this function again, the setting will be kept.
Default Value: Restore the default parameter settings.

Note: After the analysis, user can check the result accuracy in Tree Growth Analysis List.

Note: If the individual tree segmentation operation has been performed on the point cloud, this step will not
be performed and the analysis will be performed directly. If user wants to perform individual tree
segmentation again, user needs to clear the segmentation result with the Clear function, and then perform
this operation, or directly execute the Individual Tree Segmentation function.

Note: If user opens the function from the vector real-time working conditions module, user needs to set the
vector file; if user opens the function from the simulation working conditions module, user needs to set the
working conditions simulation file.



Tree Growth Warning Analysis

Summary

Usage

Click Early Warning Analysis > Tree Growth Warning

Based on the result of individual tree segmentation, calculate the years of each tree to grow to be a
danger tree. The interface of tree growth warning analysis is shown in the figure below. This function
can process multiple data simultaneously. Click to add the data to be processed. Click to remove
the selected data. Click to clear the data list.



Settings

Tree Growth Parameter:
Constant Growing Rate (default): If this option is checked, "Growth Speed" will be allowed to be set,
and all kinds of trees will be considered to grow at this growth rate.

Growth Rate (meter/year) (default value is "0.3"): Set the tree growth rate. The function can
record the user's current settings and automatically restore the settings when opened again.

Custom Growing Speed for Species: If this option is checked, user can set the growth rate for
different tree species in the table. Tree species files can be generated from Tree Species Classification,
and the default growth rate is 1 meter / year.

Tree Species Growth Rate File: Set the growth rate file path for tree species.
Tree Segmentation Parameter:

Smoothing Factor (default value is "1.5"): Individual tree segmentation smoothing coefficient. If there
are too many trees, increase the smoothing factor, otherwise, decrease the smoothing factor.
Height Above Ground (meter) (default value is "1.0"): Point clouds above ground by distances
greater than this value are used for individual tree segmentation, and less than this value will not be
segmented.

Threads Number (default value is "4"): Set the number of thread (1 to 32) to run this function. The
software can record the currently setting and when the user open this function again, the setting will be kept.
Default Value: Restore the default parameter settings.

Note: After the analysis, user can check the result accuracy in Tree Growth Warning Analysis List.

Note: If the individual tree segmentation operation has been performed on the point cloud, this step will not
be performed and the analysis will be performed directly. If user wants to perform individual tree
segmentation again, user needs to clear the segmentation result with the Clear function, and then perform
this operation, or directly execute the Individual Tree Segmentation function.



Tree Fall Analysis

Summary

Usage

Click Early Warning Analysis> Tree Fall

Settings

Tree Segmentation Parameter:
Smoothing Factor (default value is "1.5"): Individual tree segmentation smoothing coefficient. If there

Based on the result of individual tree segmentation, analyze the danger points on the trees during the
falling procedure. The interface of tree fall analysis analysis is shown in the figure below. This function
can process multiple data simultaneously. Click to add the data to be processed. Click to remove
the selected data. Click to clear the data list.



are too many trees, increase the smoothing factor, otherwise, decrease the smoothing factor.
Height Above Ground (meter) (default value is "1.0"): Point clouds above ground by distances
greater than this value are used for individual tree segmentation, and less than this value will not be
segmented.

Detection Parameter:
Cluster: This option is unchecked by default. If this option is checked, the software will cluster the result;
otherwise, the software will not cluster the result. The software can record the user's current settings
and automatically restore the settings when opened again.
Cluster Threshold (meter) (default value is "15.0"): The maximum spatial separation distance when
the detection results are clustered. This value should be smaller than the maximum clustering range.
Three-dimensional Euclidean clustering is used to cluster the danger points. The software can record
the user's current settings and automatically restore the settings when opened again.
Max Cluster Range (meter) (default value is "20.0"): After the detection results are clustered, if the
length along the power line direction is greater than this value, they are divided into multiple dangerous
point clusters. The software can record the user's current settings and automatically restore the settings
when opened again.
Safe Distance (meter) (default value is "4.5"): If the distance between the detected point and the
power line point is greater than the minimum distance and less than or equal to the safe distance, the
point is considered to be a danger point. If the xml file is not set, user needs to enter the safety distance;
otherwise, this parameter is extracted from the xml file. When using the xml to set the parameter, user
can set different safety distances for different classes, and for different severity level.
Offset Percentage (default value is "0"): The percentage of the tree's horizontal offset relative to the
height of the tree when falling.
Remove Danger Tree Top: Not selected by default. If the detected treetops are already a clearance
danger point, when this option is checked, the tool will not record this point; otherwise, it will be
recognized as a danger point. The software can record the user's current settings and automatically
restore the settings when opened again.

Vector File: Set vector file in shp format. The software can record the user's current settings, and can be
selected through the drop-down menu or selection button when it is opened again.
Simulation File: Set the input simulation file (*.LiSim file).
Threads Number (default value is "4"): Set the number of thread (1 to 32) to run this function. The
software can record the currently setting and when the user open this function again, the setting will be kept.
Default Value: Restore the default parameter settings.

Note: After the analysis, user can check the result accuracy in Tree Fall Analysis List.

Note: If the individual tree segmentation operation has been performed on the point cloud, this step will not
be performed and the analysis will be performed directly. If user wants to perform individual tree
segmentation again, user needs to clear the segmentation result with the Clear function, and then perform
this operation, or directly execute the Individual Tree Segmentation function.

Note: If user opens the function from the vector real-time working conditions module, user needs to set the
vector file; if user opens the function from the simulation working conditions module, user needs to set the
working conditions simulation file.



Clear

Summary

Usage

Click Report > Clear

Settings

Clear File: Select the file types need to be clear.
Clearance Danger: Clear the clearance danger point detection result in the cache folder.
Scissors Crossing: Clear the scissors crossing point detection result in the cache folder.
Water: Clear the water body detection result in the cache folder.
Tree Growth: Clear the tree growth detection result in the cache folder.
Tree Growth Warning: Clear the tree growth warning detection result in the cache folder.
Tree Fall: Clear the tree fall detection result in the cache folder.
Stress Detection: Clear the stress detection result in the cache folder.
Drainage Thread Clearance: Clear the drainage thread creepage distance detection result in the cache
folder.
Phase Spacing: Clear the phase spacing detection result in the cache folder.

Clear the danger point attributes and the the corresponding file of the point cloud. The interface of clear
function is shown in the figure below. This function can process multiple data simultaneously. Click 
to add the data to be processed. Click to remove the selected data. Click to clear the data list.



Sag: Clear the sag analysis result in the cache folder.
Images: Clear the image files in the cache folder.
Power Line and Shield Line Distance: Clear the power line and shield line distance result in the cache
folder.

Clear Attribute: Clear the attribute information of the point cloud.
Clear Danger Attributes: Clear the danger attributes in the point cloud files.
Clear Tree Segmentation: Clear the individual tree segmentation result of the point cloud. And delete
the segmentation result file saved in the cache folder.

Threads Number: Set the number of thread (1 to 32) to run this function. The software can record the
currently setting and when the user open this function again, the setting will be kept.

Note: When this function is executed from a different working condition page, the corresponding data is
cleared.



Generate Image

Summary

Usage

Click Report > Image

Generate images based on the detection results of danger points and the results of individual tree
segmentation, including front views, top views, cross-section views of danger points, and tree height
distribution and tree density distribution. The function interface is shown in the figure below. This
function can process multiple data at the same time. Click to add the data to be processed. Click 

to remove the selected data. Click to clear the data list.



Settings

Image Type: Select the type of danger points need to be rendered in the image.
Clearance Danger: Render the clearance danger point detection result in the image.
Scissors Crossing: Render the scissors crossing point detection result in the image.
Water: Render the water body detection result in the image.
Tree Growth: Render the tree growth detection result in the image.
Tree Fall: Render the tree fall detection result in the image.
Tree Height Image: Unchecked by default. If this option is checked, the height distribution map of trees
in the file will be drawn.
Tree Density Image: Unchecked by default. If this option is checked, the density distribution map of
trees in the file will be drawn.

Image Parameter:
Scale Factor (default value is "1.0"): Checked by default. The ratio of the image width to the height
scale. Used to control the degree of deformation of the image height.
Color Setting: Unchecked by default. User can set the color for different classes of point cloud in the
generated image. If the option is unchecked, the image is drawn according to the colors of the point
cloud displayed in the window; otherwise the image is generated according to the customized colors.
The software can record the user's current settings and automatically restore the settings when opened
again.
Front View Width (pixels) (default is "1000"): The width of the front view.
Front View Height (pixels) (default is "450"): Height of the front view.
Top View Width (pixels) (default is "1000"): The width of the top view.
Top View Height (pixels) (default is "350"): Height of the top view.
Profile Thickness (m) (default is "1"): Thickness of point cloud profile when generating danger point



image. The software can record the user's current settings and automatically restore the settings when
opened again.
Point Size (default is "1"): The point size of image. The software can record the user's current settings
and automatically restore the settings when opened again.
Prefix of Tower (optional): In the generated front view and top view images, the prefix of the tower
label. Prefix is empty by default.
Suffix of Tower (optional): In the generated front view and top view images, the suffix of the tower
label. Suffix is empty by default.
True Color: Generate images based on true color of point clouds.
Use EDL Effect: Generating images using EDL enhancement effects.

Resampling Parameter: Point cloud resampling parameter settings. Used to control image generation
quality. The software can record the user's current settings and automatically restore the settings when
opened again.

Resampling: Unchecked by default. Set whether to resample the point cloud.
Grid size X, Y, Z (meters) (default is "0.5, 0.5, 0.1"): Construct a three-dimensional voxel of X Y Z,
one point is reserved in each voxel.

Threads Number (default value is "6"): Set the number of thread (1 to 32) to run this function. The
software can record the currently setting and when the user open this function again, the setting will be kept.
Default Value: Restore the default parameter settings.

Note: The tree height image and tree density image are generated based on the individual tree
segmentation results. Users can use tree growth analysis, tree fall analysis or individual tree segmentation
tool to perform the individual tree segmentation.

Note: When this function is executed from a different working condition page, images are generated based
on the corresponding data.



International Report

Summary

The international report is the general version report. It can generate the report based on different data type and
detection type. The interface of "generate report" function is shown as follow. This function can process multiple
data simultaneously. Click to add the data to be processed. Click to remove the selected data. Click to
clear the data list.

Settings

Data Type: Select the data type to be processed. The data type includes point cloud based data, vector
based data, and data based on working conditions simulation. The software can record the user's current
settings and automatically restore the settings when opened again.

Based on Point Cloud: Extract the powerline data from the original point cloud data.
Based on Vector Data: Extract the powerline data from the vector file, and other classes objects from
original point cloud data.
Based on Simulation Data: Extract the powerline data from the simulation file, and other classes
objects from original point cloud data.

Detection Type: User can select multiple options. Set the detection type, and generate corresponding
reports.

Clearance Danger: Clear the clearance danger point detection result in the cache folder.
Scissors Crossing: Clear the scissors crossing point detection result in the cache folder.
Tree Fall: Clear the tree fall detection result in the cache folder.
Tree Growth: Clear the tree growth detection result in the cache folder.

Generate Report: Set the parameters for report generation.
Assessor Company: The company which generates the report.
Electrical Bureau: The name of power supply bureau or company.
Line Name: Line name.
Voltage Level: Cannot be changed by user.
Collection Date: The date on which point cloud was collected.
Point Cloud Coordinate: The coordinate system used in the point cloud data.
Target Coordinate: The coordinate system used in the report.



Report Path: The output path of the report.
Other:

Display in Degrees(Latitude and Longitude): The coordinates are displayed in longitude, latitude, or
radians.

Simulation File: If user choose to generate the report based on the simulated working conditions data, it is
required to set the simulation file (*.LiSim file).

Note: Data type and detection type are combined to use. If user wants to generate the clearance danger
and scissors crossing points report based on the point cloud data, they need to choose "Data Based on
Point Cloud" in the data type, and "Clearance Danger" and "Scissors Crossing" in the detection type. Then
set the other parameters, and Click "Start" to generate the report.



Vector Realtime Condition
To handle and analyze power line channel based on point cloud data and vector data and to generate analysis
report. Specific functions are as below:

Add Data

Settings

Mark Tower

Information

Clip and Classify

Classification Tools

Profile Tools

Vector Editing

Danger Points Detection

Scissors Cross Analysis

Batch Processing

Tree Growth Analysis

Tree Fall Analysis

Clear

Generate Image

Generate Report

Multiple Directory Report



Vector Editing

Summary

Usage

Click Vector Editing > Start/End button, a vector editor toolbar will pop up. Click the button again to end editing.
Vector Editor is as below:

File Editor

Editor

Shortcut Settings

Layer Settings

Insulator Vectorization

Power Line Vectorization

Shield Line Vectorization

Drainage Thread Vectorization

Tower Vectorization

Simple Model

Note: Please classify point cloud data into power line and tower before using vector editor.

Vector editing is mainly used to vectorize and edit insulator, power line, shield line, drainage thread,
scissors crossing line, tower and simple tower mode.



File Editor

Open Files: Open vector files(*.shp *.tow *.txt).
Save Files: Interface is as below. Tick the vector layer to be saved. Double click to rename the file. Select
output path and click OK to save the file. The file is saved to vector folder in working directory by default.

Export: Export vector file, including power line and tower.
Power Line: Export vector power line file in .dxf format.
Tower: Export vector tower file in .shp format.



Editor

Select:
Window Selection: Left click to draw a rectangle and entities within the rectangle will be selected.
Select Layers: Click and check the corresponding layer in pop-up window. All entities on this layer will
be selected.
Deselect All: Cancel all selection.

Delete:
Delete Entity: Delete selected entity.
Delete Layers: Delete entity on selected layer.

Vertex: Edit node on entity. Left click to select entity and then drag node to other place.
Update: Refresh scene.
Undo: Go back to last edition. This tool is not available while editing.
Redo: Redo last edition. This tool is not available while editing.
Clip: Crop point clouds for easy browsing and operation.
Merge: Merge point cloud and vector lines. Discretize vector lines within the scene and merge them into
point cloud data. Parameter settings reference Merge point cloud and vector data function.
Cancel Clip: Cancel the cropping point cloud operation.

Check
As shown in the following figure, check whether the insulators, power lines, shield lines, drainage
threads, scissors crossing up lines, and scissors crossing down lines in the scene are correct; It can
be checked separately or multiple options can be selected for batch inspection.



Shortcut Settings

Clear Current: Clear current shortcut key settings.
Clear All: Clear all shortcut key settings.

Note: Some shortcut keys have been used for specific operation, please set other shortcut keys.

Set shortcut keys for commonly-used functions in vectorization module.



Layer Settings

Show/Hide: Show/Hide the vector in layers.
Color: Color of vector data in layers.
Line Width (Pixel, 2 by default): Width of vector data in layers.
Line Type (Solid line by default): Line type of polyline in layers, such as solid line, dash line, dotted line.
Show Simple Tower Text: Control the explicit and implicit state of simple tower text.
Show Simple Tower Arm Text: Control the display and concealment status of text on simple tower
crossbars.
Show Simple Tower Insulator Text: Control the explicit and implicit state of text on simple tower insulators.
Snap Distance(pixels)(default value is "9"): Set the buffering capture distance in 3D views when clicking
with the mouse, measured in screen pixels, to facilitate user interaction.

Set the display status, color, line width, and line type of data for insulators, power lines, shield lines,
drainage threads, scissors crossing lines, towers, conventional vector lines, simple towers, simple tower
cross arms, and simple tower insulators.



Insulator Vectorization
Insulator Vectorization Toolbar is as below, including Hang Insulator, Modify Insulator, Auto Hang Insulator.

Hang Insulator

Clip Tower: Uncheck by default. If check this function for editing convenience, then the point cloud file will
be clipped into several separate files by tower mark and buffer size.
Buffer Size (meter, 10 by default): The half length of the XY plane of the cutting bounding box is used to
control the size of the cutting area.
Current Tower Index: Index of tower being edited.
Insulator Length (meter, 3 by default): Insulator length.
Translate X (meter, 0.1 by default): Set translation distance along X-axis of the last drawn insulator.
Translate Y (meter, 0.1 by default): Set translation distance along Y-axis of the last drawn insulator.
Translate Z (meter, 0.1 by default): Set translation distance along Z-axis of the last drawn insulator.

1. Set tower type and enter tower index corresponding to towers in viewer.

Vectorize insulator. Click Hang Insulator button and a window will pop up. The operation steps are as
below:



2. Use length measurement tool to measure the length of insulator and set average length as insulator length.
3. Left click to pick up hang point(point connecting insulator and power line). For tension tower, insulator is

vectorized as point; for straight line tower, insulator is vectorized as line.
4. Vectorize next insulator, or right click to exit insulator vectorization.

Modify Insulator

Translate X (meter, 0.1 by default): Set translation distance along X-axis of the selected drawn insulator.
Translate Y (meter, 0.1 by default): Set translation distance along Y-axis of the selected drawn insulator.
Translate Z (meter, 0.1 by default): Set translation distance along Z-axis of the selected drawn insulator.

1. Click Modify Insulator button, then click and select the insulator to be edited. Set edit parameters in the pop
up window.

2. Click the right mouse button to hide the dialog and continue to modify the next insulator.
3. After the modification is completed, right-click again to exit the function.

Auto Hang Insulator

To automatically hang insulators, wires and insulators needed to be classified first.

Note: For the distribution network point cloud data with a detected line voltage level of 10kV, only clustering
threshold are required, and all insulators are vectorized are points.

Note: please add in corresponding tower file(*.LiTower) before using insulator vectorization tools.

Edit position of selected insulator, the operation steps are as below:



Power Line Vectorization
Power Line Vectorization Toolbar is as below, including Fitting Power Line Based On Insulators, Fitting Power
Line Based On Point Cloud and Split Power Line.

Fitting Single Power Line Based On Insulators

1. Left click to pick up insulator hang points on small numbered tower, or right click to end fitting power line by
insulator.

2. If hang points on large numbered tower match them correctly, take step3. If match fails or goes wrong, press
"Z" and left click to pick up corresponding insulator hang point on large numbered tower.

3. Left click to pick up the middle point on the power line.
4. Finish fitting. And repeat former steps.

Batch Fitting Power Lines Based On Insulators

Start Tower Index: Set start tower index.
End Tower Index: Set end tower index.

Fitting Single Power Line Based On Point Cloud

Vectorize each power line by insulators. The operation steps are as below:

For multiple power line spans, users can click Batch Fitting button to batch fit power lines. Set start
tower index and end tower index in the pop up window. Then click to vectorize power lines. The
interface automatically exits when vectorization completed.

Manually pick up three points on the power line and vectorize the power line. The operation steps are as
below:



1. Left click to pick up power line end point, or right click to end fitting power line by three points.
2. Left click to pick up another end point or right click to go back to step1.
3. Left click to pick up middle point of the power line or right click to go back to step2.
4. Finish fitting. And repeat former steps.

Fitting Multiple Power Lines Based On Point Cloud

1. Left click to pick up top center point of the tower1 or right click to end fitting multiple power lines by two
points.

2. Left click to pick up top center point of the tower2 or right click to go back to step1.
3. Right click to finish fitting. And repeat former steps.

Batch Fitting Power Lines Based On Point Cloud

Start Tower Index: Set start tower index.
End Tower Index: Set end tower index.
Insulator Length(meters) ("3.0" by default): Set insulator length.
Slice Thickness(meters) ("1.0" by default): Set slice thickness.
Cluster Radius(meters) ("0.5" by default): Set cluster radius.

Split Power Line

Split and translate vectorized power lines selected in the viewer.

For each power line span, pick up two end points(e.g. Pick up center point for each tower). Power lines
between the two towers will be fit automatically. The operation steps are as below:

For the data in the scene, batch fit the power lines between the towers.



Split Power Line: Split selected power lines into multiple power lines following the settings.
Slant Distance(meter, 1m by default): The distance between two adjacent vectorized power lines after
splitting.
Split Number(2 by default): Power line split number. There are four options: 2, 4, 6, and 8.
Power Line Position: Power line position before being split, from minor tower to major tower.
Split: Perform split power line operation.

Translate Power Line: Translate selected power lines following the settings.
Keep Original Power Line: Uncheck by default, and original power line will not be kept. Otherwise the
opposite.
Vertical Line Direction(meter, 1m by default): Translation distance along vertical line direction.
Elevation Direction(meter, 0m by default): Translation distance along Z direction.
Translate: Perform translation power line operation.

Select All: Select all vectorized power lines in the viewer.
Deselect All: Cancel selection of all selected power lines.



Shield Line Vectorization
Shield Line Vectorization Toolbar is as below, including Three Points Fitting Single Shield Line and Batch Fitting
Shield Lines.

Three Points Fitting Single Shield Line

1. Left click to pick up shield line end point, or right click to end fitting shield line by three points.
2. Left click to pick up another end point or right click to go back to step1.
3. Left click to pick up middle point of the shield line or right click to go back to step2.
4. Finish fitting. And repeat former steps.

Batch Fitting Shield Lines

Manually pick up three points on shield line and vectorize shield line. The operation steps are as below:

For multiple shield line spans, users can click Batch Fitting button to batch fit shield lines.



Drainage Thread Vectorization
Drainage Thread Vectorization toolbar is as below, including Three Points Fitting Single Drainage Thread.

Three Points Fitting Single Drainage Thread

1. Left click to pick up end point of the drainage thread, or right click to end fitting.
2. Left click to pick up another end point of the drainage thread, or right click to get back to step1.
3. Left click to pick up a middle point of the drainage thread, or right click to get back to step2.
4. Finish fitting and repeat former steps.

Manually pick up three points from a single drainage thread and vectorize the drainage thread. The
operation steps are as below:



Tower Vectorization
Tower Vectorization Toolbar is as below, including Auto Generate Tower Model, Create Tower From Five Points,
Create Crossing Arm, Delete Crossing Arm, Create Attachment, Delete Attachment, Modify Tower, Load Tower
Template, Save Tower Template and Place Tower.

Create Tower From Five Points

1. Left click to pick up corner point1 on tower bottom or right click to end creating tower by five points.
2. Left click to pick up corner point2 on tower bottom or right click to go back to step1.
3. Left click to pick up corner point3 on tower bottom or right click to go back to step2.
4. Left click to pick up corner point4 on tower bottom or right click to go back to step3.
5. Left click to pick up tower top point or right click to go back to step4.
6. Right click and a right-click menu will pop up. Click "Finish Tower Drawing" to finish creating tower model.

When creating tower model, users can show/hide specific tower type by class setting.



Repeat the former steps to create next tower model. Or click "Draw Cross Arm" to create cross arm.

Generated tower model is as below:

Create Crossing Arm

1. Left click to select a current tower model to create crossing arm.
2. Left click to pick up end point1 of crossing arm or right click to go back to current point.
3. Left click to pick up end point2 of crossing arm.
4. Repeat step2 to add other crossing arms.
5. Right click and a right-click menu will pop up. Click "Finish Create Crossing Arm" to finish Create Crossing

Arm. Repeat the former steps to create crossing arms for next tower model. Or click "Draw Attachment" to
create cross arm attachment points.

Generated crossing arm is as below:

Create crossing arm to current tower model.



Create Attachment

After setting the length of the hanging point, click Apply to mount the hanging points of different lengths.

Length (meter, 1m by default): Length of the hanging point.

1. Left click to select the tower to create attachment point.
2. Left click to create an attachment point.
3. Repeat step2 to add other attachment point.
4. Right click to end editing current attachment point and repeat step1 to add attachment for next tower.

Generated attachment is as below:

Click Create Attachment and a window will pop up as below. Set attachment length, 1 meter by default.
Click to apply.



Modify Tower

1. Left click to select the tower model to be modified.
2. Modify parameters in the pop-up window and save.

Description: Modify the description, click Apply to save change.
Translation X(meter, 0 by default): Translation along X-axis, click Apply to save change.
Translation Y(meter, 0 by default): Translation along Y-axis, click Apply to save change.
Translation Z(meter, 0 by default): Translation along Z-axis, click Apply to save change.
Rotation Z(degree, 0 by default): Rotate by Z-axis, click Apply to save change.

3. Right click to end modifying current tower and repeat step1 to modify other tower.

Load Tower Template

Modify tower description information, pan and rotation parameter. This can be saved as tower template
file subsequently.

Load Tower Template(*.tow), the drop down menu is only available when tower template file is loaded



Save Tower Template

Place Tower

1. Left click to pick up tower top point to place template.
2. Select tower template in the tower type drop-down list in the pop-up window. Click "Yes" and place the

template to that position.

Tower Type: Select tower type in the lists from owner template.
3. Right click to end operation.

Load Tower Template(*.tow), the drop down menu is only available when tower template file is loaded
in.

Save vectorized tower with description information as tower template.

Firstly, load in a tower template, then place the template at specific position.



Simple Model
The simple tower model toolbar, as shown in the following figure, includes the functions of drawing a simple tower
model, placing, hanging a single wire, and batch hanging wires.

Note: When using the Tower Model Tool, the corresponding tower file (*. LiTower) must be loaded first.

Draw Simple Tower Model

Tower Name: Select the corresponding tower name.
Rotate Scene: Uncheck, rotate horizontally; Check, 3D rotation.
Clip(uncheck by default): If checked, the scene data will be clip based on the size of the buffer zone, with
the tower point as the center, for easy operation; If unchecked, no clipping will be performed.

Horizontal Buffer: Set the horizontal display range.
Vertical Buffer: Set the vertical display range.

Tower: Draw the tower body.
Tower Height: Set the height of the tower.
Center Point: Set the center point position.

Build a simple tower model. The functional interface is shown in the following figure. Click  to open
the simple tower model file. Click to save the simple tower model file.



End Point: Set the position of the end point in the main direction of the tower.
Adjust: After checking, existing model parameters can be adjusted, including height, center point, and
end point.
Add: Click to add the main body of the tower.
Delete: Click to delete the current model and delete its related cross arms and insulators.

Arm: Draw the cross arm of the tower.
Arm Index: Cross arm number, automatically generated after clicking add.
Arm Height: Set the height of the cross arm relative to the lowest point of the tower body.
Arm Width: Set the width of the cross arm, which only exists for tension towers.
Left Length: Set the left length.
Right Length: Set the right length.
Add Middle Phase: After checking, you can set the middle phase parameters of the cross arm.
Horizontal Offset: Set the horizontal offset value of the middle phase (negative value on the left and
positive value on the right, distinguished by minor to major towers).
Vertical Offset: Set the vertical offset of the middle phase.
Adjust: After checking, the cross arm model with the current number can be adjusted.
Add: Click to add the cross arm model.
Delete: Click to delete the cross arm model with the current number and link to delete its related
insulators.



Insulator: Draw insulators.
Insulator Index: Insulator number, automatically added.
Insulator Length: Set the length of the insulator.
Vertical Angle: Set the insulator angle, which only exists for tension towers.
Azimuth Angle: Set the azimuth angle and only add the middle phase to this parameter.
Adjust: After checking, you can adjust the parameters of the insulator with the current number.
Batch Add: Batch add insulators.
Batch Delete: Batch delete insulators.
Batch Adjust: Batch adjust insulators.

Same Arm: Adjust the selected insulator to correspond to the insulator under the cross arm.
Same Major/Minor Side: Adjust the selected insulators to correspond to the same side of the tower
with the same size.
All: Adjust all insulators.

Place

Simple Tower Model File: Set the file path for similar simple tower models.
Tower Name: Set the name of the tower to be placed.

Place the simple tower model at the designated tower name location.



Note: Ensure that both towers are both tension towers or straight line towers.

Single

Base On Sag: Hang the wire according to the sag value.
Sag Value: Set the sag value.

Base On Line Type: Suspend wires based on wire type and safety factor.
Line Type: Select the current wire type and use the built-in wire type library.
Safety Factor: Set a safety factor, generally not less than 2.5.

1. Click the left mouse button to select the suspension point for the insulator of the small tower.
2. When the number of insulator layers and the number of hanging points on each layer of the small and large

towers are consistent, the hanging points on the large tower can be automatically matched.
3. Matching successful, wire hanging completed. If it fails, you need to click the left mouse button to select the

insulator hanging point corresponding to the large tower.
4. The drawing is completed.

Note: There is a difference between the entry and exit points for tension towers. The starting hanging point
needs to select the outgoing tower point, and the ending hanging point needs to select the incoming tower
point.

Batch

Suspend a single wire for the current simple tower model.

Batch suspension of wires for the current simple tower model.



Base On Sag: Click  to add individual segment data (set small and large tower numbers and sag values).
Click to remove the selected segment. Click to clear the data list. Click to open the sag file. Click

to save the sag file.

Sag File: Set the sag file path in *. csv format, recording the tower number and wire sag value for each
level. The file is divided into three columns, separated by "," with the first column representing the
starting tower number; The second column represents the end tower number; The third column
represents the sag value. The following is an example of the sag file section:

Starting tower number, ending tower number, sag
28,29,2.5
29,30,4.0

Base On Line Type:
Start Tower Index: Set the starting tower number.

Batch suspension of wires for the current simple tower model.



End Tower Index: Set the end tower number.
Line Type: Select the current wire type and use the built-in wire type library.
Safety Factor: Set a safety factor, generally not less than 2.5.



Simulation Condition
To handle and analyze power line channel based on point cloud data and simulated data and then generate
analysis report. Specific functions are as below:

Add Data

Settings

Mark Tower

Information

Clip and Classify

Classification Tools

Profile Tools

Vector Editing

Danger Points Detection

Scissors Crossing Analysis

Batch Processing

Comprehensive Working Conditions Simulation

Tree Growth Analysis

Tree Fall Analysis

Current Carrying Capacity Analysis

Allowable Stress Analysis

Scissors Crossing Double Line Simulation Analysis

Clear

Generate Image

Generate Report

Multiple Directory Report

Note: Vector data used in this module must be vectorized by insulators.



Comprehensive Working Conditions Simulation

Summary

Usage

Click Early Warning Analysis > Simulation

Settings

Power Line(Shield Line, Drainage Thread): Select to processing line classification.

Comprehensive working condition simulation analysis can simulate and analyze the power line status in
different wind, high temperature and ice cover conditions. According to the type of tower, it can be
divided into continuous segment and isolated segment. The continuous segment refers to the tension
section composed of several straight line towers. The isolated segment is an independent segment with
a tension tower tower at both ends, which is analyzed using the isolated gear method. The interface of
comprehensive working condition simulation analysis is shown in the figure below. Click to add the
vector data to be processed. Click to remove the selected vector data(remove the first record of the
list if no data is selected). Click to clear the vector data list.



Voltage Level: Select the voltage level in the drop-down list. The default value is the voltage level in the
settings step.
Line Type: Select the line type from the drop-down list, or user can enter key words to search. If there is no
desired record in the list, user can add a new type of line with "Add Line Type" function. The software can
record the user's current settings and automatically restore the settings when opened again.

Line Specifications: View the corresponding specifications of the current power line type.
Add New Line Type: Add a new type of power line.

Line Type File: Select piecewise line type file. Simulate the working conditions in different segments with
different power lines.
Scanning Conditions: Conditions when the data were collected. The software can record the user's current
settings and automatically restore the settings when opened again.

Wire Temperature (Celsius): Wire temperature during the scanning.
Ice Thickness (mm): The thickness of ice one the wire during the scanning.
Wind Speed (m/s): Wind speed during the scanning.

Simulation Conditions: Simulated operating conditions. The software can record the user's current settings
and automatically restore the settings when opened again.

Wire Temperature (Celsius): The temperature of the wire under simulated conditions.
Ice thickness (mm): The thickness of ice under simulated conditions.
Wind speed (m/s): Wind speed under simulated conditions.

Section Condition Parameters: Select piecewise condition file. Import parameters from the working
condition file.
Start Tower Index: Set the index of the starting tower.
End Tower Index: Set the index of the ending tower.
Wind Deflection Process:

Wind Deflection Process: This option is unchecked by default. If this option is checked, the software
will interpolate the maximum wind deflection angle according to the interpolation angle to simulate the
swing of the wire during the wind deflection. If this option is unchecked, the software will simulate the
maximum wind deflection on both sides of the wire.
Interpolation Angle (degrees) (default is "5"): Angle used to interpolate the maximum wind deflection
angle.

Insulator File: Set the input vector file for the insulators.
Output Shp File: Select the path of the simulated Shp file to be output after the analysis.
Output Simulation File: Select the path of the simulation file to be output after the analysis.

Note: To execute this function, user needs to set the type of the transmission tower in Mark Tower. If the
power line in continuous segments are incomplete, the simulation analysis cannot be done, and the power
line in the output file will be missing as well.



Current Carrying Capacity Analysis

Background

The current carrying capacity and temperature of the power line are important parameters for operation and
design. At present, there are two main methods for increasing the current carrying capacity of high-voltage
overhead transmission lines: static capacity increase and temperature calculation. Based on the thermal balance
equation, the design code of China gives the formula for calculating the allowable current carrying capacity of
overhead transmission line conductors. It is the most commonly used formula for calculating the current carrying
capacity in China. In practical applications, the calculation direction opposite to the above is more applicable in
the design steps of the power transmission project, that is, given the maximum allowable carrying capacity, the
amount to be calculated is the temperature or temperature rise of the power line. Reference of the algorithm: (Lin
et al., 2012)

Summary

The carrying capacity analysis function is mainly used to calculate the temperature rise of the power line under a
certain ambient temperature and carrying capacity. The function interface is shown in the figure below.

Usage

Click Early Warning Analysis > Current Carrying Capacity



Settings

Parameter Settings:
Power Line Type("LGJ-240/30" by default): Select the power line type. After selecting any power line
type, the electrical parameters below will change accordingly. Currently, only cored power line types are
supported, such as "steel core aluminum stranded conductor" LGJ-300 / 40, where "300" represents the
diameter of the power line and "40" represents the diameter of the steel core.
Electrical Parameter: Parameters related to the power line. Among them, "DC resistance at 20℃",
"inner diameter of the power line", "outer diameter of the power line", and "calculated cross-sectional
area" will be automatically read from the file according to the selected power line type, without
adjustment.
Current Frequency (Hz) (default value is "50.0"): Current frequency of AC resistance.
Environment Parameter: Environment-related parameters. Need to adjust according to the actual
situation. The "radiation heat dissipation coefficient" and "strand surface heat absorption coefficient" are
both 0.9, and no adjustment is required.
Sun Irradiance (W/m^2) (default value is "1000"): Heat from the sun absorbed per square meter of



the power line.
Wind Speed (m/s) (default value is "0.5"): Wind speed of the environment where the power line is
located.
Resistance at 20℃ (per degree Celsius) (default value is "0.004040"): DC resistance of the power
line at 20℃.

Initial Parameter:
Ambient Temperature (Celsius) (default is "40"): The actual temperature of the environment where
the wire is power line.
Input Carrying Capacity(Ampere): The current passing through the power line.
Power Line Temperature Simulated(Celsius): Output the actual power line temperature simulated
under the above environmental conditions.

    @inproceedings{
        author={Lin},
        title={The Calculation of Current Carrying Capacity and Temperature of High Voltage Overhead Lines},
        booktitle={SOUTHERN POWER SYSTEM TECHNOLOGY, 6(4):23-27},
        year={2012},
    }



Allowable Stress Analysis

Summary

Usage

Click Early Warning Analysis > Allowable Stress

Settings

Safety Factor (default value is "2.5"): Power line safety factor.
Simulation File: Set the input simulation file (*.LiSim file)

Note: After the stress detection, user can view the result in the Allowable Stress Analysis List.

Based on the result of working conditions simulation, detect and analyze if the stress at the lowest point
of the sag exceeds the allowable stress. The interface of allowable stress analysis is shown in the figure
below.



Scissors Crossing Double Line Simulation Analysis

Summary

Usage

Click Early Warning Analysis > Scissors Crossing Double Line Simulation Analysis

Settings

Analysis Parameter:

Based on the result of working conditions simulation, analyze the distance between current line and
crossing line. Click to add the vector data to be processed. Click to remove the selected vector
data(remove the first record of the list if no data is selected). Click to clear the vector data list.



Click to add the current line and crossing line. Click  to modify selected line. Click to remove
selected line. Click to clear line list.

Buffer Size: Adjust channel width.

Line Settings:

Crossing Line Option: Select the crossing type and the working conditions simulation file for crossing
lines. Crossing types include scissors crossing up and scissors crossing down.
Current Line Option: Select the current line type and the current line working conditions simulation file.
Line Type include shield line and power line.

Report(check by default): Check to generate an analysis report based on the analysis result file. If not
checked, no report will be generated.

Assessor Company: The company which generates the report.
Electrical Transmission Bureau / Company: The name of power supply bureau or company.
Line Name: Line name.
Collection Date: The date on which point cloud was collected.
Target Coordinate: The coordinate system used in the report.
Report Path: The output path of the report.

Threads Num(default value is "4"): Set the number of thread (1 to 32) to run this function. The software
can record the currently setting and when the user open this function again, the setting will be kept.



Completion Acceptance
Completion Acceptance is suitable for completion analysis of power line and tower. Based on point cloud data,
vector data and working condition simulation data, this module analyzes different components of the line and
generates analysis report. The specific functions are as below:

Add Data

Settings

Mark Tower

Clip and Classify

Classification Tools

Profile Tools

Vector Editing

Sag Analysis

Phase Spacing Analysis

Drainage Thread Clearance Analysis

Spacer Analysis

Tension Tower Rotation Analysis

Insulator Inclination Analysis

Distance Between Conductor And Shield Wire

Protect Angle Analysis

Anchor Bolt

Lighting Protector Inclination

Earth Electrode Line

Danger Point Sag

Wind Turbine Tower Inclination

Merge Report



Sag Analysis

Summary

Usage

Click Completion Analysis > Sag

Analysis sag, line length etc based on vector file or simulation file input.The result data can be saved
as(*.csv *.xls)and generate report. Click to add data, click to remove data selected, click to
clear data list.



Parameters

Sag Analysis(checked by default): Checked to calculate sag etc.
Adjust Sag With Point Cloud(unchecked by default): Adjust sag based on point cloud.
Distance to Ground(unchecked by default): Calculate distance to ground.
Sag Deviation(unchecked by default): Calculate Sag Deviation.
Observed Temperature: Temperature when scanning.
Observed Wind Speed(m/s): Wind speed when scanning.
Powerline File: Set input file for powerline sag analysis, file format:shp.
Shield Line File: Set input file for ground conductor sag analysis, file format:shp.
Conductor File: Set input file for conductor sag analysis, file format:shp.
Output Path: cache/SagAnalysis/ by default.
Output Format(csv by default): support csv and xls.

Generate Report(checked be default): Generate report.
Assessor Company: Assessor company.
Electrical Transmission Bureau/Company: Electrical transmission bureau/company.
Line Name: Line name.
Target Coordinate: Target Coordinate System.
Report path: Path to store result files.

Threads Num(4 by default): Set the number of thread (1 to 32) to run this function. The software can record
the currently setting and when the user open this function again, the setting will be kept.

Note: Input data includes vector file and simulation file*.LiSim.And the vector file should be shapefile(.shp)
created by vectorization, not simulation.



Phase Spacing Analysis

Summary

Usage

Click Completion Analysis > Phase Spacing

This function is used to calculate and analyze the distances between power lines, and then generate the
analysis report. The phase spacing will change if the distance is too long or too short; the temperature is
too high; or the line is broken. Click to add the data to be processed. Click to remove the
selected data. Click to clear the data list.



Settings

Phase Spacing Analysis: This option is checked by default. If it is checked, the software will perform phase
spacing analysis; if not, the function will not be executed.

Profile Thickness (meters) (default value is "5.0"): The thickness of the cross profile of the power line
which is used to extract the point cloud for calculating. The software can record the currently setting and
when the user open this function again, the setting will be kept.
Cluster Threshold (meters) (default value is "3.5"): The maximum spatial separation distance when
the point cloud data is clustered. Power line points smaller than the threshold will be clustered into a
cluster. The software can record the currently setting and when the user open this function again, the
setting will be kept.
Calculate Horizontal Distance of Double Circuit Line: Not selected by default. When selected, if the
power line is a double loop, the horizontal distance between the left and right sides will be calculated.
Based On Shp File: Not selected by default. When selected, a power line vector file can be added, and
the vector is used as the basis for calculating the distance between phases. Suitable for special sections
of certain line situations.

Generate Report: This option is checked by default. If this option is checked the analysis report will be
generated; if the option is unchecked, the analysis report will not be generated.

Assessor Company: The company which generates the report.
Electrical Transmission Bureau/Company: The name of power supply bureau or company.
Line Name: Line name.
Target Coordinate: The coordinate system used in the report.
Report Path: The output path of the report.

Threads Num(default value is "4"): Set the number of thread (1 to 32) to run this function. The software
can record the currently setting and when the user open this function again, the setting will be kept.

Note: After the detection, the software will export the detection result file for each segment. User can check
the accuracy of the analysis in phase spacing analysis list. Each row contains a phase spacing. And the
name, coordinates of the target point, and the point cloud it belongs to will be recorded in different
columns.



Drainage Thread Clearance Analysis

Summary

Usage

Click Completion Analysis > Drainage Thread.

Settings

This function is used to calculate and analyze the clearance distances between the drainage threads
and the transmission towers, and generate the analysis report. When the clearance distance between
the drainage thread and the transmission tower is too small, it will become very dangerous. Before
executing this function, user needs to classify the drainage thread and transmission tower in the point
cloud. This function can process multiple data simultaneously. Click to add the data to be processed.
Click to remove the selected file. Click to clear the data list.



Drainage Thread Analysis: This option is checked by default. If this option is checked, the software will
perform drainage thread clearance analysis. If this option is unchecked, the analysis will not be done.

Cluster Threshold(meter)(default value is "2.0"): The maximum distance for the point cloud data
clustering. If the distance between two points is less than this value, they will be considered as on the
same drainage thread. Thus, user should input a value that the distances between most of the points on
the same drainage thread are less than. When the clustering splits the same drainage thread into
several ones, user needs to increase this value. When more than one drainage threads are clustered as
one, user needs to decrease this value.
Standard Distance(meter)(default value is "3.0"): The standard distance from the drainage thread to
the transmission tower. It is disqualified if the distance from the drainage thread to the transmission
tower is less than this value. The software can record the currently setting and when the user open this
function again, the setting will be kept.
Shp File: This option is unchecked by default. If this option is checked, the position information of the
drainage threads will be extracted from the input shp file. If this option is unchecked, the position
information of the drainage thread will be extracted from the point cloud. The software can record the
currently setting and when the user open this function again, the setting will be kept.
Distance to Tower Body: This option is unchecked by default. If this option is checked, the clearance
distance from the drainage thread to the tower body (without the cross arms) will be calculated. If this
option is unchecked, the clearance distance from the drainage thread to the tower body (the cross arms
included) will be calculated.

Generate Report: This option is checked by default. If this option is checked the analysis report will be
generated; if the option is unchecked, the analysis report will not be generated.

Report Name: The title of the report.
Assessor Company: The company which generates the report.
Electrical Transmission Bureau/Company: The name of power supply bureau or company.
Line Name: Line name.
Target Coordinate: The coordinate system used in the report.
Report Path: The output path of the report.

Threads Num(default value is "4"): Set the number of thread (1 to 32) to run this function. The software
can record the currently setting and when the user open this function again, the setting will be kept.



Spacer Analysis

Summary

Usage

Click Completion Analysis > Spacer.

Settings

This function is used to calculate and analyze the position and length information of the spacers in the
point cloud of the power line, and then generate the analysis report. The interface of this function is
shown as follow. This function can process multiple data simultaneously. Click to add the data to be
processed, click to remove the selected file, click to clear the data list.



Spacer Analysis: This option is checked by default. If it is checked, the software will perform spacers
analysis; if not, the function will not be executed.

Spacer Class(default value is "26"): The class number of the spacers in the input point cloud.
Profile Thickness(meters)(default value is "5.0"): The thickness of the cross profile which is used to
extract the point cloud for calculating. The software can record the currently setting and when the user
open this function again, the setting will be kept.
Cluster Threshold(meters)(default value is "3.5"): The maximum spatial separation distance when
point cloud data is clustered. Point clouds smaller than this threshold will be clustered into a cluster. The
software can record the currently setting and when the user open this function again, the setting will be
kept.
System Error(meters)(default value is "0"): Affected by the accuracy of the point cloud and the
classification, there will be errors in the result of the spacer length. This system error value will help to
correct the result by being added to the result.

Generate Report: This option is checked by default. If this option is checked the analysis report will be
generated; if the option is unchecked, the analysis report will not be generated.

Report Name: The title of the report.
Assessor Company: The company which generates the report.
Electrical Transmission Bureau/Company: The name of power supply bureau or company.
Line Name: Line name.
Target Coordinate: The coordinate system used in the report.
Report Path: The output path of the report.

Threads Num(default value is "4"): Set the number of thread (1 to 32) to run this function. The software
can record the currently setting and when the user open this function again, the setting will be kept.



Tension Tower Rotation Angle Analysis

Summary

Usage

Click Completion Analysis > Rotation Angle

Settings

Rotation Angle Analysis: This option is checked by default. If it is checked, the software will perform
tension tower rotation analysis; if not, the function will not be executed.
Generate Report: This option is checked by default. If this option is checked the analysis report will be
generated; if the option is unchecked, the analysis report will not be generated.

Assessor Company: The company which generates the report.
Electrical Transmission Bureau/Company: The name of power supply bureau or company.
Line Name: Line name.
Target Coordinate: The coordinate system used in the report.
Report Path: The output path of the report.

Used to calculate the tension tower rotation angle, and then generate the analysis report. The interface
of this function is shown as follow. This function can process multiple data simultaneously. Click to
add the data to be processed, click to remove the selected file, click to clear the data list.



Insulator Analysis

Summary

Usage

Click Completion Analysis > Insulator

Settings

Insulator Class(default value is "27"): Class number of insulators in point cloud data.
Cluster Threshold(meters)(default value is "3.5"): The maximum spatial spacing distance for the
clustering of insulator point cloud data, and insulators less than the threshold will be clustered into a cluster.

This function is used to calculate the inclination information of insulators in power lines and generate
analysis reports. This function requires classification of insulators in advance. The function interface is
shown in the figure below. This function can process multiple data at the same time. Click  to add
pending data, click to remove the selected data, click to clear data list.



Generate Report: This option is checked by default. If this option is checked the analysis report will be
generated; if the option is unchecked, the analysis report will not be generated.

Assessor Company: The company which generates the report.
Electrical Transmission Bureau/Company: The name of power supply bureau or company.
Line Name: Line name.
Target Coordinate: The coordinate system used in the report.
Report Path: The output path of the report.

Threads Num(default value is "4"): Set the number of thread (1 to 32) to run this function. The software
can record the currently setting and when the user open this function again, the setting will be kept.



Power Line And Shield Line Distance Analysis

Summary

Usage

Click Completion Analysis > Power line and shield line distance

Settings

This function is used to automatically analyze and calculate the distance between power line and shield
line and generate analysis report. The function interface is shown in the figure below. This function can
process multiple data at the same time.Click to add the data to be processed, click to remove
selected data, click to clear data list.



Calculate In The Middle Of Section: Not selected by default. Check it to calculate the pitch in the middle of
the pitch, uncheck it to calculate the pitch in the entire range.
Profile Thickness(default value is 0.5m): It is used to set the thickness of the spacing slice of the guide
wire and to calculate the spacing slice.
Generate Report: This option is checked by default. If this option is checked the analysis report will be
generated; if the option is unchecked, the analysis report will not be generated.

Assessor Company: The company which generates the report.
Electrical Transmission Bureau/Company: The name of power supply bureau or company.
Line Name: Line name.
Target Coordinate: The coordinate system used in the report.
Report Path: The output path of the report.

Threads Num(default value is "4"): Set the number of thread (1 to 32) to run this function. The software
can record the currently setting and when the user open this function again, the setting will be kept.



Protect Angle Analysis

Summary

Usage

Click Completion Analysis > Protect Angle

This function is used to analyze the protection Angle of transmission tower and generate analysis report.
When using this function, you must ensure that the center of the tower is selected accurately.The
function interface is shown in the figure below. This function can process multiple data at the same time.
Click to add pending data, click to remove the selected data, click to clear data list.



Settings

Profile Thickness(meters)(default value is "5.0"): The section thickness of the tower along the line
direction is used to extract the tower point cloud. When the point cloud is dense, the value can be reduced
appropriately. The value ranges from 2 to 5m.
Filter Width(default value is "2.00m"): Point cloud filtering width.

Generate Report: This option is checked by default. If this option is checked the analysis report will be
generated; if the option is unchecked, the analysis report will not be generated.

Assessor Company: The company which generates the report.
Electrical Transmission Bureau/Company: The name of power supply bureau or company.
Line Name: Line Name.
Target Coordinate: The coordinate system used in the report.
Report Path: The output path of the report.

Threads Num(default value is"4"): Set the number of thread (1 to 32) to run this function. The software can
record the currently setting and when the user open this function again, the setting will be kept.



Measure Anchor Bolt Information

Summary

Usage

Click Completion Analysis > Other > Anchor Bolt

This function is used to measure foot screw information during infrastructure acceptance and generate
analysis reports. The functional interface is shown in the following figure.

Select the position of the foot spiral.



Select the position of the foot spiral.

Clear the result list record.

Save the foot spiral measurement results.



Lighting Protector Inclination Analysis

Summary

Usage

Click Completion Analysis > Other > Lighting Protector Inclination

Parameter Settings

Lighting Protector Class: Category number of the arrester in the point cloud data.

The function is used to analyze the tilt of the Lighting Protector and generate analysis report.Ensure the
data has been classified.The function interface is shown in the following figure, this function can process
multiple data at the same time, Click to add data to be process, click to remove selected data,
click to clear data list.



Layer height(The default value is "0.3m"): For the horizontal slice thickness of the arrester, the smaller the
thickness is, the more precise the calculation is, and the higher the requirement for the density of the point
cloud is. In the case of sparse point clouds, the value can be appropriately increased.
Lighting Protector Min Radius(The default value is "1.50m"): The minimum radius of the arrester is used
to obtain point cloud data.
Standard ratio(The default value is "0.5%"): According to the standard ratio provided by the specification.
Generate report: Selected by default.If this parameter is selected, an analysis report is generated based on
the analysis result file. If unchecked, no report will be generated.

Assessor Company: The company that generated the report.
Electrical Transmission Bureau/Company: The name of the power supply bureau.
Line Name: Line name.
Target Coordinate: The coordinate system used in the report.
Report Path: Report output path.

Threads Num(The default value is "4"): Set the number of threads. 1-32 threads can be supported. The
software can record the user's current settings and automatically restore the Settings when it is turned on
again.



Earth Electrode Line And Drainage Thread Distance
Analysis

Summary

Usage

Click Completion Analysis > Other > Earth Electrode Line

Parameter settings

Analysis: Selected by default. If selected, calculate the distance between the grounding electrode wire and
the drainage wire; If not selected, it will not be calculated.
Drainage Thread(default to "28"): Set the category of drainage lines.
Earth Electrode Line(default to "29"): Set the category of grounding electrode wire.

This function is mainly used to automatically analyze and calculate the distance between the grounding
electrode wire and the drainage wire, and generate an analysis report. The functional interface is shown
in the following figure, which can process multiple data simultaneously. Click to add pending data,
click to remove the selected data, click to clear the data list.



Standard Distance(meters)(default to "4.7"): Set the standard distance between the grounding electrode
wire and the drainage wire.
Generate report: Selected by default.If this parameter is selected, an analysis report is generated based on
the analysis result file. If unchecked, no report will be generated.

Assessor Company: The company that generated the report.
Electrical Transmission Bureau/Company: The name of the power supply bureau.
Line Name: Line name.
Target Coordinate: The coordinate system used in the report.
Report Path: Report output path.

Threads Num(The default value is "4"): Set the number of threads. 1-32 threads can be supported. The
software can record the user's current settings and automatically restore the Settings when it is turned on
again.



Danger Point Sag Analysis

Summary

Usage

Click Completion Analysis > Other > Danger Point Sag

Parameter settings

Data Type: The default selection is based on point cloud data. If selected, obtain the dangerous point
analysis results based on point cloud data to calculate the sag of dangerous points.
Based on Point Cloud: Used to obtain dangerous point analysis results based on point cloud data.

This function is used to automatically analyze and calculate the sag of dangerous points. The functional
interface is shown in the following figure, which can process multiple data simultaneously. Click to
add pending data, click to remove the selected data, click to clear the data list.



Based on Vector Data: Used to obtain the results of hazard point analysis based on vector data.
Based on Simulation Data: Used to obtain the analysis results of hazardous points based on working
condition simulation data.
Power Line File: Set the input file for power line sag analysis, supporting vectorized files and operating
condition simulation files, with formats of . shp and . shp, respectively LiSim.
Drainage Line File: Set the input file for drainage line sag analysis, supporting vectorized files and working
condition simulation files, with formats of . shp and . shp, respectively LiSim.
Output Path: Set the analysis result file output path, which defaults to "cache/DangerPointSagAnalysis/" in
the working directory.
Thread Num(default value is "4"): Set the number of running threads for the function, which can support 1-
32 threads. The software can record the user's current settings.



Wind Turbine Tower Inclination Analysis

Summary

Usage

Click Completion Analysis > Other > Wind Turbine Tower Inclination

Parameter settings

This function is mainly used to automatically analyze and calculate the inclination of the wind turbine
tower, and generate analysis reports. The functional interface is shown in the following figure, which can
process multiple data simultaneously. Click to add pending data, click to remove the selected
data, click to clear the data list.



Analysis: Selected by default. Select to analyze the inclination of the wind turbine tower; If not selected, do
not analyze.
Tower Classification(default to "18"): Set the category of the wind turbine tower.
Tower Width(meters)(default to "20"): Set the tower width to set the range of sampling points. The
software can record the user's current settings.
Layer Height(meters) (default to "0.5"): Set the tower analysis layer height to extract the point cloud data
to be calculated. The software can record the user's current settings.
Standard Value(default to "0.3"): Set the wind turbine tower inclination normative ratio to determine
whether the tower inclination exceeds the specification. The software can record the user's current settings.
Generate report: Selected by default.If this parameter is selected, an analysis report is generated based on
the analysis result file. If unchecked, no report will be generated.

Assessor Company: The company that generated the report.
Electrical Transmission Bureau/Company: The name of the power supply bureau.
Line Name: Line name.
Target Coordinate: The coordinate system used in the report.
Report Path: Report output path.

Threads Num(The default value is "4"): Set the number of threads. 1-32 threads can be supported. The
software can record the user's current settings and automatically restore the Settings when it is turned on
again.



Merge Report

Summary

Usage

Click Completion Analysis > Other > Merge Report

Parameter settings

Output Path: Set the path for saving merged files.

Note: This feature is mainly used to concatenate multiple Word documents.

This feature is used to merge reports. The functional interface is shown in the following figure, which can
process multiple data simultaneously. Click to add the data to be processed, click to remove the
selected data, click to clear the data list.



Fine Inspection

Summary

To generate fine trajectory based on tower marker points and point cloud data. This module includes project
configuration, mark tower, trajectory planning, and image data processing.

Usage

Click the "Fine Inspection" tab to open the menu, and click the "Start/End" button to expand the trajectory
planning related function menu, as shown in the figure below.

Fine Inspection Menu

File Menu

Project Configuration

Trajectory Menu

Waypoint

Tools Menu

Setting

Defect Recognition



Fine Inspection Menu
Switch to fine inspection page, There are four functions: "Project Configuration", "Mark Tower", "Trajectory",
"Image". As shown below.

Project Configuration: Add inspection configuration and camera setting in addition to the basic
configuration. Inspection configuration is used to configure part point list and trajectory generation
parameters for different types of towers. Camera setting manages camera parameters by opening and
saving camera parameter file. The specific operation will be explained later in the text.
Mark Tower: Basic function for marking tower location and editing tower name and type.
Start/End: Turn on and off the trajectory planning function.
Defect Recognition: Split, rename, mark defects, and export reports for UAV inspection pictures.

Click "Start/End" button, Expand the trajectory planning related function menu, including "File", "Vector Editing",
"Trajectory", "Waypoint", "Tools and Setting", as shown below.

File: Open, save, auto save, split and merge trajectory files.
Vector Edit: Trajectory planning operation undo and redo operation, trajectory deletion.
Trajectory: Operation related to trajectory generation, including clipping tower, marking part points,
automatic generation, model generating trajectory and safety.
Waypoint: Waypoint editing related functions, including modifying waypoints, adding waypoints and deleting
waypoints.
Tools: Simulation includes flight simulation and flight time calculation. Batch includes statistics, batch check,
export to CSV and batch attribute modification, conversion to other formats, and conversion to DJI Pilot.
Setting: Display settings and shortcut key settings.



File Operation
The fine inspection file menu is shown in the following figure, including functions such as "Open", "Save", "Auto
Save", "Split", and "Merge".

Open

Save

Auto Save

Auto Save(Check by default): If checked, the trajectory file will be automatically saved every time interval.
Time Interval(3.0 minute by default): Set the time interval value.
Default: Modify all parameters to default values.

Split

Merge

open the .json format trajectory file.

Save the .json format trajectory file. By default, it is saved as the trajectory .json file in the fine inspection
folder under the working directory.

Save the .json format file. By default, it is saved as the trajectory .json file in the fine inspection folder
under the working directory.

Split the trajectory file in .json format according to the selected waypoint.

Merge .json format trajectory files.



Delete Duplicate Part Points(Check by default): If checked, delete duplicate part points.
Use Unified Tower Information(Uncheck by default): If checked, use the tower information of the first part
point uniformly.
Output File: Set the path for saving trajectory.

Vector Editor Operation
The fine inspection vector editor menu is shown in the following figure, including functions such as "Undo",
"Redo" and "Delete Trajectory".

Undo

Redo

Delete Trajectory

Undo the trajectory modifications.

Redo the route modifications.

Delete the selected trajectory.



Project Configuration
Project configuration is the first step in trajectory planning. Trajectory planning can only be carried out after the
configuration parameters and the points of different tower components are determined. Click Project
Configuration -> Inspection Configuration, as shown in the figure below.

Trajectory Base Setting

Camera Distance: The distance from the waypoint to the point of the tower component.
Obstacle Avoid Distance: The minimum safe distance between the trajectory and the wire of the tower.
Height Above Tower: The height of the UAV from the top of the tower.
Need Enter and Leave Way Points: Check if you need the entry point and exit point. The entry point and
exit point will be slightly higher than the top of the tower, located on the left and right of the tower.
Need Way Points Through Tower: Check if the tower point is needed.
Start Side: It is mainly divided into the right side of the line and the left side of the line, which is the take-off
side of the UAV.
Priority Side: Mainly includes default, small side and big side. For scanning the hanging point of the tension
tower insulator, generally the small side is selected.

Tower Type Setting

The software has built-in 9 tower type trajectory configuration lists, each configuration has defined component
point names and parameters, which can be selected according to the tower type. The 9 tower types are shown
below.
1. AC Double Circuit Linear Tower
2, AC Double Circuit Tension Tower(Right Jumper)
3, AC Single Circuit Guyed Linear Tower
4, AC Single Circuit Linear Tower(Middle Phase I Type Insulator)



5, AC Single Circuit Linear Tower(Middle Phase V Type Insulator)
6, AC Single Circuit Tension Tower(Left Arm Double Jumper)
7, AC Single Circuit Tension Tower(Right Arm Double Jumper)
8, DC Single Circuit Linear Tower(V Type Insulator)
9, DC Single Circuit Tension Tower

Show Phase: If uncheck, only the part name, image number, vertical camera angle and horizontal camera
angle will be displayed. After ticking, the parameters of circuit type, phase, big or small side, ironware type
and insulator type will be displayed.

Add New Setting Table: If you do not find the configuration table of the tower type you need, you can click
the plus sign on the right to customize and add a new tower configuration table, as shown below.



Delete Tower Type Setting: Click the minus button to delete the tower type configuration.

Change Tower Type Setting Order: Click the green arrow button to change the configuration order of the
tower types.

Tower Image Preview: Preview tower type image,  and  flip through images forward and backward.



Part Name List Editing: The plus and minus signs on the left can add and delete components, and the up
and down arrows can adjust the order of the components.

Camera Settings

Multiple types of UAV gimbal cameras are provided by default in the camera settings. The red row indicates the
currently used camera, and the right-click button can be used to set the current camera.



Load default settings.

Open the camera configuration file.

Save the camera configuration file.



Trajectory Operation

Usage

The trajectory menu is as shown in the following figure, including clip tower, mark part point, automatic
generated, model generation trajectory and safety.

Clip Tower

Clip tower is mainly to display the tower of the trajectory planning independently for easy trajectory editing.

Tower Name: Select the corresponding tower name.
Rotate Scene: Uncheck, horizontal rotation; check, 3D rotation.
Horizontal Buffer: Set the horizontal display range.
Vertical Buffer: Set the vertical display range.



Mark Part Point

The part point menu of fine inspection is shown in the following figure,including mark part point, delete part point,
clear part point, channel perspective, part point recognition, automatic waypoint generation and hide XYZ
columns.

Note: Before marking part points, it is necessary to mark tower and set the tower type.

Tower Settings

The list of tower types is shown below. There are 9 kinds of conventional tower types built into the software. If
you need to add other tower types, add them in Project Configuration->Inspection Configuration.



Mark Part Point

Delete Part Point

After selecting the tower type, there will be a corresponding list of part point. Select the corresponding
part point on the point cloud according to the order of the list. The status of marked part point is "Has
Been Set", and the status of unmarked part point is "Not Set". If there are part point that do not need to
be marked, you can skip them directly and select the following part point for marking. After marking all
part point, click the marking button again to finish the marking function. The list of part point and the
results of part point marking are shown in the following figure.

Select the part point in the list and click the button to delete the part point.



Clear

Channel Perspective

Automatic Waypoint Generation

Take Photo(Checked by default): If checked, the waypoint will include photo information.
Safety Analysis(Unchecked by default): If checked, the safety of the trajectory will be analyzed.
Camera Type: Set current camera type. The current camera type is set by default through Project
Configuration->Camera Settings.
Edit Waypoint: Switch to edit waypoint function.
Shooting Distance(m, default value is "5.0"): Set the distance from the waypoint to the part point.
Waypoint Speed(m/s, default value is "3.0"): Set the waypoint speed.

Hide XYZ Columns

Select the part point in the list and click the button to delete the part point.

Click the button to clear all marked part point.

Click the button to display the tower from the perspective of the channel.

After clicking the button, corresponding waypoints will be automatically generated when generating part
point.

If checked, hide the XYZ columns of the table; If uncheck, display the XYZ columns of the table.



Tower Image Preview

Display a preview image of the corresponding current tower type. If clicked ">>", the tower image preview dialog
box will be displayed; If clicked "<<", hide="" the="" tower="" type="" image="" preview="" dialog="" box.="" click
or  to flip through images forward or backward.

Generate Image

Tower Name: Select the current tower name.
Part Point: Check the part points that need to generate image information.
Select All: Check or uncheck all part points.
Tower Range(m, default value is "20.0"): Set the extraction point cloud range for the current tower. By
adjusting the range, fully display the tower and part points.
Point Size(default value is "1"): Set the size of a single point in the point cloud in the image.

Automatic Generation

If checked, hide the XYZ columns of the table; If uncheck, display the XYZ columns of the table.

Generate tower preview images based on tower point cloud and "Has Been Set" part point.

Automatic generation is to generate trajectory according to the inspection configuration. The drop-down
menu also includes functions such as "Generate", "Generate Straightly", "Generate Sequentially",
"Powerline Trajectory", "Distribution Network Trajectory", "Generate Channel Trajectory", "Generate
Point Cloud Data Collection Trajectory", "Generate Tower Trajectory(Surround Method)", etc.



Automatic Generated

Camera Type: Select camera type for taking photos. Add a new camera type in the camera configuration.
Waypoint Speed(m, default value is "3.0"): Set waypoint speed.

Automatically generate refined inspection trajectory for towers based on inspection configuration. After
clicking the button, set the camera type and waypoint speed, and click "Apply" to automatically generate
the trajectory.



Generate

Tower Index to Generate: The tower index needs to generate the trajectory.
Camera Distance(m, default value is "10"): The shooting distance from the waypoint to the part point.
Height Above Tower(m, default value is "10"): Height above tower.
Obstacle Avoid Distance(m, default value is "2.5"): Distance for obstacle avoidance detection.
Start Side(default value is "Left"): Waypoint shooting starting side.
Camera Type: Select camera type for taking photos. Add a new camera type in the camera configuration.
Waypoint Speed(m/s, default value is "3.0"): Set waypoint speed.
Need Enter and Leave Way Points(Checked by default): Add two auxiliary points for exiting the tower and
entering the tower.
Need Way Points Through Tower(Checked by default): Add auxiliary points for passing the tower.

Generate Straightly

Automatically generated based on inspection configuration and shortest path principle.

Generate flight trajectories directly by connecting parts points in order. There may be a possibility of the
trajectory passing through the tower, and auxiliary waypoints need to be manually added.



Tower Index to Generate: The tower index needs to generate the trajectory.
Camera Distance(m, default value is "10"): The shooting distance from the waypoint to the part point.
Height Above Tower(m, default value is "10"): Height above tower.
Obstacle Avoid Distance(m, default value is "2.5"): Distance for obstacle avoidance detection.
Start Side(default is "Left"): Waypoint shooting starting side.
Camera Type: Select camera type for taking photos. Add a new camera type in the camera configuration.
Waypoint Speed(m/s, default value is "3.0"): Set waypoint speed.
Need Enter and Leave Way Points(Checked by default): Add two auxiliary points for exiting the tower and
entering the tower.
Need Way Points Through Tower(Checked by default): Add auxiliary points for passing the tower.

Generate Sequentially

Tower Index to Generate: The tower index needs to generate the trajectory.
Camera Distance(m, default value is "10"): The shooting distance from the waypoint to the part point.
Height Above Tower(m, default value is "10"): Height above tower.
Obstacle Avoid Distance(m, default value is "2.5"): Distance for obstacle avoidance detection.
Start Side(default is "Left"): Waypoint shooting starting side.
Camera Type: Select camera type for taking photos. Add a new camera type in the camera configuration.

Automatically generate trajectory based on inspection configuration and part point order.



Waypoint Speed(m/s, default value is "3.0"): Set waypoint speed.
Need Enter and Leave Way Points(Checked by default): Add two auxiliary points for exiting the tower and
entering the tower.
Need Way Points Through Tower(Checked by default): Add auxiliary points for passing the tower.

Batch Power Line Trajectory Generating
Batch generation of power line inspection trajectory(Add point cloud data or vector data to generate
trajectory in batches).



Data Type:
Based on Point Cloud: Generating trajectory based on point cloud.
Based on Vector Data: Generating trajectory based on vector data.

Parameters:
Camera Type: Select camera type for taking photos. Add a new camera type in the camera
configuration.
Waypoint Direction: Set the position of the waypoint relative to the power line. When selecting
"Default", the waypoint of the left phase is on the left side of power line, and the waypoint of the right
phase is on the right side of power line. When selecting "Left Side" or "Right Side", the waypoint is
located on the left and right sides of the power line.
Overlap Ratio(default value is "0.1"): Set the overlap ratio of adjacent photos.
Pitch Angle(-90~0)(°, default value is "-45.0"): Set the depression angle of the shooting waypoint.
Safe Distance(m, default value is "4.0"): Set safe distance and power line obstacle avoidance
detection.
Compensation Distance(m, default value is "0.0"): Set compensation distance. The vector line is
located at the bottom of the power line point data. Used to compensate for the distance between vector
lines and point clouds.Only used for vector data.
Waypoint Interval(m, default value is "0.5"): Set the distance between the waypoints and perform the
safety inspection between the waypoints. Automatically calculate the Waypoint interval when setting the
overlap ratio.
Powerline Segment Distance(m, default value is "4.0"): Set the clustering threshold and cluster the
point cloud points.Only used for point cloud data.
Waypoint Speed(m/s, default value is "3.0"): Set waypoint speed.

Enter And Leave Way Points: Add two auxiliary points for entering the tower and leaving the tower.
Offset Distance(m, default value is "3.0"): Set horizontal offset distance.
Height Above Tower(m, default value is "10.0"): Set height above tower.

Output Path: Set the output path of the trajectory.
Default Value: Click "Default Value" to restore the initial parameters.



Run: Click "Run" to start the calculation.

Merge/Split Trajectory Files
Merge and split shield line and power line trajectory.



Option: Check the "Merge" and "Split" options.
Merge Parameters: Customize the maximum count of waypoints based on the maximum waypoints
supported by the UAV. The merge mode supports two types: sequential merge and interval reverse merge.
The merging function by section supports merging by the number of files. For example, if set to 2, two
trajectories can be merged, and the waypoint count of merged trajectory cannot exceed the maximum count.
If it exceeds, the merge will be abandoned. If "Copy Trajectory File" is checked, copy and output trajectory
that do not meet the merging requirements.
Split Parameters: Default 2, customizable.
Output Path: Specify the path to save the file results.

Generate Distribution Network Trajectory

Mode 1

Generate 3 photo waypoints for each tower based on the tower marking points.

Generate inspection trajectory suitable for distribution networks (Distribution network trajectory mode are
divided into mode 1, mode 2 and mode 3 and mode 4. The four different modes generate distribution
network trajectory).



Mode(default is "Mode 1"): Three photos of a single tower (from the left, right, and top of the tower).
Start Tower Index: Set the starting tower index.
End Tower Index: Set end tower index.
Camera Type: Select camera type for taking photos. Add a new camera type in the camera configuration.
Focal Length Multiple: Set camera focal length.
Waypoint Speed(m/s, default value is "3.0"): Set waypoint speed.
Camera Distance(m, default value is "8.0"): The shooting distance from the waypoint to the part point.

Mode 2

Take 13 photos of each tower on the trajectory, including the tower marking point, tower base, and major side
channel.



Mode 2: Thirteen photos of a single tower. (Eight photos taken from the four directions of the tower at two
heights, two photos taken from the tower base, and three photos taken from the major side.)
Safe Distance(m, default value is "3.0"): Set safe distance and conduct obstacle avoidance detection.

Note: To avoid collisions with towers during UAV return, the automatically generated trajectory needs to
check if the starting point is higher than the tower. After generating the trajectory, it is recommended to
analyze the safety.

Mode 3

Take 6 photos of each tower on the trajectory, including tower marking point, tower body, and major and minor
side channel.



Mode 3: Six photos of a single tower. (overall view of the tower, minor side, major side, left and right of the
tower head, and top view of the tower head.)
Vertical Compensation Distance(m, default value is "-0.5"): Adjust the height of the target points for
photography on the left and right sides of the tower head. Positive value, the target point moves up. Negative
value, the target point moves down.
Enter And Leave Waypoints(check by default): Add two auxiliary points for entering and leaving the tower.

Mode 4

Take 8 photos of each tower on the trajectory, including tower head, cross arm, insulator, major and minor side
channel.



Mode 4: Eight photos of a single tower. (overall view of the tower, cross arm, insulator, top view of the tower
head, minor side and major side.)
Insulator Shooting Angle(°, default value is "-30.0"): Set the shooting angle of the insulator.
Cross Arm Shooting Angle(°, default value is "-45.0"): Set the shooting angle of the cross arm.

Generate Distribution Network Trajectory Model

Minor Side Channel: Select the waypoint number for minor side channel of the trajectory, and if not
available, do not select it.
Major Side Channel: Select the waypoint number for major side channel of the trajectory, and if not
available, do not select it.
Single Tower Trajectory File: Choose a single tower trajectory.
Trajectory Model: Set the trajectory model path. The model file format is . dtm.

Generate Distribution Network Trajectory From Model

Generate distribution network trajectory model based on the distribution network trajectory.

Batch generate distribution network trajectory files from models.



Start Tower Index: Set the starting tower index.
End Tower Index: Set the end tower index.
Generate Single Tower Trajectory: If checked, generate corresponding single tower trajectory based on
the starting and ending towers; If unchecked, generate a single trajectory.
Trajectory Model: Select trajectory model file.
Trajectory File: If "Generate Single Tower Trajectory" is checked, set distribution network trajectory folder; If
"Generate Single Tower Trajectory" is unchecked, set distribution network trajectory path.

Generate Distribution Network Tower Trajectory(Surround Method)
Automatically generate a circular trajectory with the tower marker point as the center. Take multi-
directional and multi height photos of the tower.



Tower Name: Select the current tower name.
Camera Type: Select camera type for taking photos. Add a new camera type in the camera configuration.
Focal Length Multiple: Set camera focal length.
Waypoint Speed(m/s, default value is "3.0"): Set waypoint speed.
Start Side(default value is "Left Side"): Waypoint shooting starting side.
Add Enter And Leave Waypoints: Add two auxiliary points for entering and leaving the tower.
Delete Dangerous Waypoints: Delete dangerous waypoints based on obstacle avoidance distance and
point cloud data.
Upper Layer

Surround Radius(m, default value is "5.0"): Horizontal distance from waypoint to tower marking point.
Camera Angle(°, default value is "-30.0"): Pitch angle from waypoint to target point.
Vertical Compensation Distance(m, default value is "-0.5"): Adjust the height of the target points for
photography on the tower head. Positive value, the target point moves up. Negative value, the target
point moves down.
Photo Waypoint Number(default value is "30"): Generate a circular trajectory uniformly based on the
"Photo Waypoint Number" in the current layer.

Lower Layer: If checked, generate a two-layer circular trajectory.
Surround Radius(m, default value is "6.0"): Horizontal distance from waypoint to tower marking point.
Camera Angle(°, default value is "--15.0"): Pitch angle from waypoint to target point.
Vertical Compensation Distance(m, default value is "-7.0"): Adjust the height of the target points for
photography on the tower head. Positive value, the target point moves up. Negative value, the target
point moves down.
Photo Waypoint Number(default value is "30"): Generate a circular trajectory uniformly based on the
"Photo Waypoint Number" in the current layer.

Default Value: Click "Default Value" to restore the initial parameters.

Generate Channel Trajectory
Generate the channel inspection trajectory above the line.



Camera Type: Select camera type for taking photos. Add a new camera type in the camera configuration.
Height Above Tower(m, default value is "10.0"): Distance of passage point height above tower.
Camera Angle(°, default value is "-45.0"): Set the depression angle of the shooting waypoint.
Waypoint Speed(m/s, default value is "3.0"): Set waypoint speed.
By Tower: Whether to generate the channel trajectory according to the tower information.
By Fixed Spacing(m, default value is "50.0"): Whether to generate the channel trajectory according to the
fixed spacing? According to the fixed spacing, input the parameter distance at every interval to generate a
trajectory.
Start Tower Name: Set the name of the starting tower and generate a trajectory from the tower.
End Tower Name: Set the name of the end tower and generate a trajectory to the tower.

Generate Point Cloud Data Collection Trajectory

Generate the channel inspection trajectory above the line.

Base on point cloud data, generate unmanned aerial vehicle (UAV) trajectory for airborne LiDAR
equipment during field point cloud data collection .



Camera Type: Select camera type for taking photos. Add a new camera type in the camera configuration.
Reference Point Class: Optional shield line, conductor, and ground.
Channel width(m, default value is "60.0"): Set point cloud channel width.
Relative Height of Waypoint(m, default value is "50.0"): The height of the waypoint relative to the
reference point.
Start Tower Index: Set the starting tower index, and generate the trajectory from the tower.
End Tower Index: Set the the end tower index, and generate the trajectory to the tower.
Waypoint Speed(m/s, default value is "3.0"): Set waypoint speed.
Single Side Trajectory: If checked, you can choose the left and right sides; If unchecked, for both side
trajectory.
Insert Middle Waypoint: Add a waypoint in the middle of the tower.
Start Point At The End Point: If checked, the starting and ending waypoints are both near the ending tower.
Remove Photo Information: If checked, remove all camera information.

Generate Tower Trajectory(Surround Method)
Automatically generate a panoramic shooting trajectory for the tower. The waypoints are located on the
front, back, left, and right sides of the tower, and the number of waypoints on each side is determined by
the vertical overlap rate. Each waypoint can take multiple photos, and the number of photos is

determined by the horizontal overlap rate and camera type.



Tower Name: Select the current tower name.
Start Side(default value is "Left Side"): Waypoint shooting starting side.
Camera Type: Select camera type for taking photos. Add a new camera type in the camera configuration.
Focal Length Multiple: Set camera focal length.
Horizontal Overlap Ratio(default value is "0.3"): Overlap rate of photos on the same side of the tower. It
determines the number of photos on the current side.
Vertical Overlap Ratio(default value is "0.3"): The overlap rate of waypoints on the same side of the
tower. It determines the number of waypoints on the current side.
Camera Distance(m, default value is "4.0"): The closest distance from the waypoint to the tower point
cloud box.
Obstacle Avoid Distance(m, default value is "2.5"): Distance for obstacle avoidance detection.
Minimum Height To Tower Bottom(m, default value is "3.0"): Minimum height from waypoint to ground



point.
Waypoint Speed(m/s, default value is "3.0"): Set waypoint speed.
Default Value: Click "Default Value" to restore the initial parameters.

From Model

Trajectory Model

Generate Trajectory By Mode

The "Generate Trajectory By Model" function can use existing trajectory model to batch generate
trajectory. Trajectory model can be obtained through the "Generate Trajectory Model" function in the
drop-down menu. When there are a large number of duplicate towers on the same line, it can greatly
reduce the workload of users.

Select the planned trajectory, click "Generate Trajectory Model" from the drop-down menu, and click
Generate. The file name will be named according to the tower types, the file format is .tm format. The
default output path is the "Fine Inspection" folder.

After the trajectory model is generated, it is necessary to mark the parts of the tower. Mark all the part
points according to the inspection configuration of the same tower type, and ensure that the number and
location of the part points are consistent with the trajectory model.



Safety
The "Safety" function can check the obstacle avoidance distance between the trajectory and point cloud
data, as well as the safe distance between waypoints. If distance is greater than "Obstacle Avoidance
Distance", the list will be displayed in red, and the trajectory in the point cloud will also be displayed in
red. Double-click the list item to locate the corresponding trajectory, adjust it by editing the trajectory or
adding auxiliary waypoints, and then refresh.





Obstacle Avoidance Distance: The minimum distance between the trajectory and the point cloud data.
Only Check Waypoints: If checked, only analyze the safety of the waypoint.
Export dangerous results in the safety table: Click  to export dangerous results.
Fresh by Force: Perform a forced refresh after adjusting the waypoints.
Fresh: Refresh after adjusting the waypoint.



Edit Waypoint

Summary

Waypoint functions mainly include modifying waypoints, adding waypoints and deleting waypoints. The operation
is mainly performed after the trajectory is generated.

Usage

Use the "Fine inspection" module, after generating the trajectory, Click Waypoint > Edit, and the mouse turns into
a cross state. Click on any waypoint at this time, and a dialog box for adjusting and editing waypoints pops up.
You can edit the position of navigation point, the angle of taking photos, the number of taking photos, etc.



Settings

Previous Waypoint/Next Waypoint: Quickly switch to the previous waypoint and the next waypoint for
editing.
Camera List: Switch the current camera and display the corresponding vertebrae. Cameras can be added
and removed using the add/subtract button on the side. After adding a camera, the current camera will be set
as the newly added camera. Other tools can be used to modify the camera.
Add Camera: Adding camera is divided into selecting camera types and selecting part point. Multiple part
point can be selected to support shooting multiple part point at one waypoint.

Person Perspective: Quickly locate the first-person view of the waypoint.
Reset: After modifying the waypoint parameters, clicking the reset can restore the original parameters.
Overlay Display: When multiple photos are taken at a waypoint, check the option to overlay and display the
preview range.



Adjust Parameters: Mainly adjust the parameter of waypoints.
Drag Waypoint: Holding down the left mouse button, drag a point in the point cloud view to adjust its
position.
Safety Analysis: If checked, verify security
Allow Head Up: If checked, set the maximum angle for the camera to look up. Do not exceed the
maximum angle.
Pitch/Yaw: Adjust the pitch angle and yaw angle by manually entering, clicking the up and down arrows,
and dragging the slider.
Distance: The distance from the waypoint to be photographed is the value from the waypoint to the
component point, and the distance from the auxiliary waypoint is the value from the waypoint to the
marked tower point.
Focal Length Multiple: Set the focal length multiple.
Waypoint Speed: Set the waypoint speed.
Set Rotation Center: To re-select the rotation center of the navigation point, press Ctrl + left to select
any point on the point cloud. If you want to specify the component point or the front and back navigation
points, you can also use the select component point button.

Auxiliary Grid: If check the "Drag Waypoint", this will display. Not selected by default, the auxiliary grid is
displayed when selected.
Grid Size(default value is "5.00m"): Side length of grid.
Side Grid Count(default value is "10"): Number of side grids.
Horizontal Grid: Display a grid that passes through the tower point and is parallel to the XY plane.
Line Direction Grid: Display the grid passing through the tower point and parallel to the plane along the line.
Vertical Line Direction Grid: Display the grid passing through the tower point and parallel to the horizontal
line direction plane.
Show Auxiliary Line: Selected by default.If selected, navigational guides are displayed. If unchecked,
navigational guides are hidden.



Tools

Usage

Tools mainly include simulation and batch. Simulation includes flight simulation and time; batch includes
statistics, batch safety checking, batch attribute modification, batch save as trajectory, batch modify part name,
batch modify trajectory tower information, export to CSV format, export to DJI pilot.

Flight Simulation

After loading the flight route file, you can simulate the flight by selecting either the first-person or third-person
perspective in the flight simulation.



Time

Flight time calculation needs to load the route file, set the flighting speed and waypoint dwell time, and get the
total flight time of the UAV after executing the route.

Statistics

Statistics can export the parameter statistics table of the route, click "Run" to generate a csv format file. The file is
saved in the project folder. The statistical table mainly counts the number of photos of the route, the number of
auxiliary points, the number of manually added points and the number of waypoints, as shown in the figure below.



Batch Safety Checking

Batch Safety checking is used to check whether the route documents meet the safety requirements.

Trajectory File Directory: Default fine inspection folder.
Obstacle Avoidance Distance: The default is the same as the inspection configuration.
Minimum Interval Between Waypoints: The minimum safe distance between waypoints is 1.00m by
default.
Output CSV Path: Default fine inspection folder.

After running, a TrajectoryBatchChecking.csv file will be generated, mainly checking for 5 common issues,
where 1 indicates a problem and 0 indicates normal. When opened, it will appear as shown in the figure
below.



Trajectory Safe Distance Is Danger: Safety distance is dangerous, obstacle avoidance distance does not
meet the requirements.

Distance Between Waypoints Is Danger: The distance between two adjacent waypoints is dangerous and
does not meet the requirements.
Camera Angle Is Danger: Camera angle is dangerous. The pitch angle of the camera point is positive.
Do Not Have WayPoints: There are no waypoints.
Have Unphotographed KeyPoint: Some part points are not photographed.
Have Multiple Camera Types: The cameras used for taking photos on the same flight route are not
consistent.

Batch Attribute Changing

Batch attribute changing mainly includes key point change and way point change. Only the same tower type
routes can be modified in batches.



Modify Waypoint:
Waypoints to be Modified: Click the button on the right to add and select the waypoints that need to be
modified. Typically, you would select all of them.
Pitch Angle: The pitch angle of the waypoint, generally a negative value.
Yaw Angle: The yaw angle of the waypoint.
Photograph Distance: The distance at which photos are taken at the waypoint.
Camera Count: The number of photos taken at the waypoint.
Camera Type: Select the type of camera to be changed, a total of 14 types.
Focal Length Multiple: For selectable zoom camera types, you can set the zoom factor, with a setting
range of 0.1 to 12.0, and one decimal place to be preserved. For a fixed-focus camera type, this value
cannot be set.
Waypoint Speed: Flight speed at waypoints, with a setting range of 0.01 to 99.99, and two decimal
places to be preserved.

Waypoint Compensation: Check this option when converting drone routes for the M200 and M300 series.
UAV Type: Customize.
X Compensation: Default 0.4
Y Compensation: Default 0.5
Z Compensation: Default 0.6

Tip: This function is suitable for routes with the same tower type.

Batch Save As Trajectory

Batch save as routes allows for waypoints to be saved in reverse order, removing photo information, changing
waypoint speed, camera type, and zoom multiplier, as shown in the figure below.



Batch Modify Part Name

Custom fields can be added, such as adding line names and voltage levels, and batch modifying component
names, as shown in the following figure.

Batch Modify Trajectory Tower Information



If the tower information in the route file is misaligned, this tool can be used to correct and redefine the tower
number and name, as shown in the following figure.

Options:
Matching Mode: If this option is selected "Matching By Tower Index", the matching will be done using
the tower index recorded in the flight route file; If this option is selected "Matching By Tower Name", it
will be done using the tower names recorded in the flight route file; otherwise, the 'Trajectory File'
column is arranged in ascending order to the tower index recorded in the file, and the 'New Tower Index'
column is arranged in ascending order, and then matched according to the order after arrangement.
Use New Tower Name: Check this option to use the new tower name as the flight route file name when
saving the file; otherwise, use the original flight route file name.

Export to CSV Format

Exporting to CSV Format is to convert the route file into a CSV format table file, which can compare and quickly
view the parameters of each waypoint. The file is saved in the project folder by default.



Export to DJI Pilot

Convert to a drone route compatible with DJI Pilot app in KML or KMZ format. In advanced settings, you can set
initial speed(10m/s by default), yaw angle mode (1 Smooth transition; 2 along the route direction) and waypoint
turning mode (1 Fly in a straight line and stop at the waypoint; 2 Turn ahead and smooth through waypoints).



Setting
Settings include display setting and shortcut key Settings.

Display Setting

You can set the color, line width, and line type for each layer. Additionally, you can set the snap distance, preview
window scale, step size, and preview window point size. You can also choose whether to draw the tower
orientation.

Shortcut Setting

Set the shortcut keys for common operations.



Clear Current: Clear the shortcut key settings for the currently selected item.
Clean All: Clear the shortcut key settings for all items.



Defect Recognition

Summary

Defect recognition mainly includes place files by location, defect marking, auto recognition, and generate report.

Place Files by Location (Split Pictures)

Picture Path: Specify the photo folder, the folder contains the pictures of the multi-base tower.
Json Path: The route file is placed in the photo file, which is consistent with the photo path.
Output Path: Specify the output folder, new files and archive photos will be created according to the tower
number.

Place Files by Location (Rename Pictures)



Naming Rule: The default short naming rule.
Towers: The default is single tower, if rename the picture of a multi-base tower is needed, batch or all towers
option can be selected.
Image Order: The default is by capture time, can also be ordered by name.
Match Mode: The default is image location, the photo location matches the waypoint location and the photo
location, and the time taken is the waypoint sequence matches the photo time sequence.
Line Type: The default is single circuit, which is selected according to the tower type.
Line Name: Customize.
Voltage Level: Customize.
Assessor Company: Customize.
Inspection Personnel: Customize.
Threshold: The default is 1m, automatically match when the space position difference between the image
and the waypoint is less than 1m.
Picture Path: Specify the path of the photo directory.
Json Path: Specify the flight path file, do not need to enter if the multi-tower is renamed.
Tower Name Path: Specify the tower name path when double circuit line type is selected.
Output Path: Specify the output directory.

Place Files (Conductor and Shield Wire Pictures)



Naming Rule: The default long naming rule and another short rule.
Line Name: Customize.
Voltage Level: Customize.
Data Path: The organized path for conductor and ground wire photos.
Json Path: Specify the route file.
LiTower Path: Specify the LiTower file.
Output Path: Specify the output path.

Place Files (Distributing Network Pictures)



Naming Rule: The default naming rule and another rule with line name.
Line Name: Customize.
Picture Path: Distributing network pictures path.
Json Path: Specify the route file.
LiTower Path: Specify the LiTower file.
Output Path: Specify the output path.

Place Files (Imitation Line Pictures)

Picture Path: Imitation line pictures path.
LiTower Path: Specify the LiTower file.
Output Path: Specify the output path.
General Text: Edit text.



Edit Defect List

Edit the defect groups and categories in the dialog.

Defect Annotation

First edit and select the defect category, click the "Start/End Annotation" to frame the defect area on the picture, a
red frame will be displayed, then click "Save Defect File", and then click the "Export" button to export the defect
picture.

Generate Report



Click the "Generate Report" button to automatically generate a report.



Measurement
To measure different components of the power line channel such as tower or conductors, based on point cloud
data. And generate analysis report. Specific functions are as below:

Tower Inclination

Cross Arms Height Difference

Tower Nominal Height

Measure Minimum Distance

Minimum Crossing Distance

Phase Distance

Measure Sag

Sag

Measure Rotation Angle

Deflection

Protect Angle

Tower Diaphragm

Curve Length

Goto



Measure Cross Arms Height Difference

Summary

Usage

Click Measurement > Cross Arms Height Difference

By selecting the cross arm points on the transmission tower, calculate the height difference between the
left and right cross arms. And save the measurement result to the specified directory.

Open the height difference of cross arms file.

Save the height difference of cross arms file. The default output path is the tower analysis folder in the
working directory. The default file name is "CrossArmsHeightDifference.txt".



Parameters

Delete the selected record in the result list.

Clear the results in the result list.

Auto-Cross Arms Height Difference

Height difference of cross arms report.



Please refer to Report Parameters for details.



Measure Tower Nominal Height

Summary

Usage

Click Measurement > Tower Nominal Height.

Nominal height is the vertical distance from the tower cross arms (the lowest cross arms) to the
construction base surface of the tower center pile (the longest tower leg footplate or the top surface of
the foundation). By select the bottom cross arms point on the pylon, calculate the nominal height and
save to the specified directory.



Open

Save

Delete Selected Record

Clear Result

Automatic Calculation

Open the nominal height file.

Save the nominal height file. The default location to save the result is the "NominalHeight.txt" file in the
tower analysis folder in the working directory.

Delete the selected record in the result file.

Clear the result list.

Automatic calculation



Generate Report
Generate report.



Measure Minimum Distance

Summary

Usage

Click Measurement > Minimum Distance

Support ground object point measurement and wire point measurement. For the feature point model, the
minimum horizontal distance, minimum vertical distance and minimum clearance distance from the small
tower and power line can be measured in real time. For the wire point model, the minimum horizontal
distance from the small tower, the minimum clearance distance from vegetation and the vertical distance
to the ground can be measured in real time. Select the ranging type, click the left mouse button in the
view window, select any ground object point/wire point, and obtain the minimum distance from the point
to the small pole tower and power line.



Note: Note: To use this function, the classification of the power line is required. If the tower file (.LiTower
file) is not set, only the minimum distance to the power line will be displayed.



Measure Minimum Crossing Distance

Summary

Usage

Click Measurement > Minimum Crossing Distance

Parameters

Distance Type (default value is "Clearance"): Set calculation distance types, including clearance,
horizontal, and vertical.
Power Line Category (default value is "Conductor"): Set the category of power lines.
Crossing Category (default value is "Scissors Crossing Down"): Set cross category.

Result

Horizontal Distance: The horizontal distance between two points at the minimum crossing distance.
Vertical Distance: The vertical distance between two points with the minimum crossing distance.
Clearance Distance: The clearance distance between two points with the minimum crossing distance.

Steps

1. After enabling the tool for measuring minimum crossing distance, select the distance category, power line
category, and crossing category, and click calculate.

This function is used to measure the minimum distance between the power line category and the
crossing category in the current point cloud, as shown in the following figure.



Measure Phase Spacing Distance

Summary

Usage

Click Measurement > Phase Distance

Select any point on the power line, create a profile with this point, calculate the phase distance (the default profile
distance is 10m, that is, 5m to the left and right of the selected point), and display the result on the user interface
in real time.

Profile Thickness(meters)(default value is "5.0"): The thickness of the cross profile of the power line
which is used to extract the point cloud for calculating. The software can record the currently setting and
when the user open this function again, the setting will be kept.
Cluster Threshold(meters)(default value is "3.5"): The maximum spatial separation distance when the
point cloud data is clustered. Power line points smaller than the threshold will be clustered into a cluster. The
software can record the currently setting and when the user open this function again, the setting will be kept.
Default: Default value will be set when click this button;

This function is similar to the "Phase Spacing Analysis" function. Phase spacing analysis is used to
calculate the all the phase spacing of all the phases between each two transmission tower. While the
measure phase spacing distance function can measure the phase spacing at any position in between
each two transmission towers.



Note: To use this function, the classification of the power line is required.



Measure Sag

Summary

Usage

Click Measurement > Measure Sag

Parameters

This function is used to measure sag. Mainly used for measuring the sag of wires, ground wires, and
drainage wires.



Line Type: Default is power line, select the target line type for calculation (power line/wire, ground wire, drain
wire).
Profile Thickness(meters)(default value is "5.0"): The thickness of the cross-section of the line is used to
extract a single wire point cloud.
Cluster Threshold (meters)(default value is "3.5"): When clustering point cloud data, the maximum spatial
interval distance is used. Power line points below this threshold will be clustered together.
Hang Thickness(meters)(default value is "0.1"): The thickness of the point cloud cross-section near the
hanging point is used to extract the hanging point.
Height Threshold (meters)(default value is "0.5"): Measure the maximum height difference of the line
point cloud of the measured object. If the height difference of the slice is greater than this threshold, it is
considered that there are hanging points or other types of point clouds in the slice.
Measurement Method: Default to single point. When selecting a single point, simply select the
measurement point to automatically calculate the sag of the measurement point. When selecting three
points, you need to sequentially select the small side hanging point, the large side hanging point, and the
measurement point to calculate the sag of the measurement point.
Point Selection Mode: Default to manual. When selecting manual, calculate the sag of the manually
selected point. When selecting automatic, it is necessary to select the automatic calculation position (middle
point, lowest point, maximum sag point), and then calculate the sag of the selected position of the line
corresponding to the selected point.
Point Selection Position: The default is the midpoint. Select the location for automatic calculation.

Middle: The midpoint of the line.
Lowest: The lowest point of the line elevation.
Maximum: The maximum point of line sag.

Steps

1. After enabling the sag measurement tool, select the line type of the object to be measured, adjust the
parameters, and when the measurement method is single point, click on the point to be measured to
automatically calculate the sag of the measurement point. When the measurement method is three points,
click on and select the small side hanging point, large side hanging point, and measurement point in order to
calculate the sag of the measurement point.



Sag Analysis

Summary

Usage

Click Measurement> Sag

Analysis sag, line length etc based on vector file or simulation file input.The result data can be saved
as(*.csv *.xls) and generate report. Click to add data. Click to remove data selected. Click to
clear data list.



Parameters

Sag Analysis(check by default): Checked to calculate sag etc.
Adjust Sag With Point Cloud(unchecked by default): Adjust sag based on point cloud.
Distance to Ground(unchecked by default): Calculate distance to ground.
Sag Deviation(unchecked by default): Calculate Sag Deviation.
Observed Temperature: Temperature when scanning.
Observed Wind Speed(m/s): Wind speed when scanning.
Powerline File: Set input file for powerline sag analysis, file format:shp.
Shield Line File: Set input file for ground conductor sag analysis, file format:shp.
Conductor File: Set input file for conductor sag analysis, file format:shp.
Output Path: "cache/SagAnalysis/" by default.
Output Format(csv by default): Support csv and xls.

Generate Report(checked be default): Generate report.
Assessor Company: Assessor company.
Electrical Transmission Bureau/Company: Electrical transmission bureau/company.
Line Name: Line name.
Target Coordinate: Target Coordinate System.
Report Path: Path to store result files.

Threads Num(default value is "4"): Set the number of thread (1 to 32) to run this function. The software
can record the currently setting and when the user open this function again, the setting will be kept.

Note: Input data includes vector file and simulation file *.LiSim.And the vector file should be shape file(.shp)
created by vectorization, not simulation.



Measure Rotation Angle

Summary

Usage

Click Measurement > Rotation Angle

Steps

1. After starting the "Measure Rotation Angle" tool, select power line points on the left and right sides of the
tension tower and tower points, and the result will be displayed in the scene in real-time. Rotation angle will
be displayed in "degree" rather than "radian". The result is the angle less than 180 degrees.

2. Right-click to call the menu, and choose "Back One Point" in order to cancel the last point picking; choose
"Clear Measurement" to cancel the point picking of all the points; and choose "Quit" to quit the measurement.

This function is used to measure the rotation angle of the tension tower, as is shown below.



Measure Deflection

Summary

Usage

Click Measurement > Deflection

Steps

1. After the deflection tool is enabled, select three points P1, P2 and P3 on the point cloud in turn to complete
the deflection measurement. Double-click the last point to select. The deflection value is calculated as the
distance between p2 and P1p3.

This function is used to measure deflection and the effect is shown below. Mainly used for measuring
the bending degree of straight steel such as tower leg and tower body.



Measure Protect Angle

Summary

Usage

Click Measurement > Protect Angle

Steps

After the protection angle measurement tool is enabled, select the end of the shield wire cross arm and the end of
the wire cross arm in turn, and then double-click to complete the measurement.

Result List

Auto Calculate Protect Angle

This function is used to measure the protection angle. The protection angle is the angle between the
shield wire cross arm to the first wire cross arm and the vertical direction. The tower needs to be
classified before using this function. Results as shown below. It is mainly used to measure the bending
degree of straight steel such as tower legs and tower body.



Parameter

Profile Thickness(default value is "5.00m"): The width of the point cloud slice along the specified
direction.
Filter Width(default value is "2.00m"): Point cloud filtering width.

Note: Please classify the tower points in advance.
Add point file.

Save the tower tilt file, the output file path will be displayed in log.

Delete the selected results list.



Generate Report

Parameters

Please refer to Report Parameters for details.

Clear the result list record.



Measure Tower Diaphragm

Summary

Usage

Click Measurement > Tower Diaphragm

By selecting the four vertices of the transverse plane on the tower, calculate the length of the four sides
of the transverse plane and the angles of the four corners, and save the measurement results to the
specified directory.



Tower Points List

Compute

Compute the relevant parameters of the cross section of the tower based on the picked tower points, and display
the calculation results in the result list.

Result List

Add top tower points.

Delete the selected tower points.

Modify the selected tower points.

Empty the tower points.

Start calculating the cross section of the tower.

Open the tower cross section file.



Auto Calculate Tower Diaphragm

Summary

Open the tower cross section file.

Save the file of the cross section of the tower. By default, save it as the '. txt' file of the cross section of
the tower in the tower analysis folder in the working directory.

Delete the selected result list record.

Clear the result list record.

Automatically calculate the cross section of the tower.

Analyze and calculate the selected point cloud data of the tower, automatically obtain the parameters of
the cross section of the tower, and save them to the result list. The functional interface is shown in the
following figure, which can process multiple data simultaneously. Click to add pending data, click
to remove the selected data and click to clear the data list.



parameter

Tower Body Class(default value is "17m"): The category number of insulators in point cloud data.
Slice Thickness(default value is "0.50m"): The thickness of the cross-section along the two main
horizontal directions of the tower is used to extract the initial value of the cross-sectional height. When the
point cloud density is low, this value can be slightly increased. The software can record the user's current
settings and automatically restore them when opened again.
Extract Range(default value is "2.00m"): Extract the precise height range from the initial extracted cross-
sectional height. The software can record the user's current settings and automatically restore them when
opened again.

Tower Diaphragm Report
Save the tower cross section file and generate a tower cross section report.



Parameters

Please refer to Report Parameters for details.

Note: This function requires tower classification of point cloud data first.

Note: The cross section of the tower refers to the separation surface between the tower legs and the tower
body.



Curve Length

Summary

Usage

Click Measurement > Curve Length

Point List

Draw a curve by selecting points on the point cloud in the scene, calculate the length of the curve, and
save the curve information in the specified format.

Create a new curve.



Curve List

Parameter

Show Only Current Curve: Not checked by default. If checked, only the currently selected curve in the
curve list will be displayed in the scene.
Show Label: Not checked by default. If checked, the ID and length of the curve will be displayed.

Calculate Curve Length

Summary

Create a new curve.

Add points to the currently selected curve.

Delete the selected point.

Clear all points on the current curve.

Open curve file(.json).

Save the curve file (. json) as the CurveMeasurement (.json) file in the cache/CurveMeasurement folder
of the working directory by default.

Export the selected curve as a KML file.

Export the selected curve as a CSV file.

Delete the selected curve record.

Clear the curve list record.

Automatically calculate curve length.

Analyze and calculate the specified detection category of the selected point cloud data, automatically



Parameter

Minimum Cluster Radius(default value is "0.5m"): The radius value used for point cloud clustering.
Curve Width(default value is "0.5m"): Extract the width of the curve.
Detection Classification: The target category that participates in the calculation when automatically
extracting curves.
Select All: Not checked by default, if checked, all categories will be included in the detection category.

Analyze and calculate the specified detection category of the selected point cloud data, automatically
pick the curve and calculate the length, and save it to the result list. The functional interface is shown in
the following figure, which can process multiple data simultaneously. Click to add pending data, click

to remove the selected data, click to clear the data list.



Goto

Summary

Usage

Click Measurement > Goto

Set Parameter

Coordinate reference: The default is the projection coordinate system, which supports latitude and
longitude geographic coordinates. Select the coordinate reference type used for coordinate jump.
Size: After jumping to the target position, draw the radius size of the ball at that coordinate.
Show Points: Checked by default, the ball will be drawn at the coordinate position after jumping; Uncheck
and the ball will not be displayed.
Remain Points: Not checked by default. If checked, the previously drawn ball will be retained when jumping
coordinates continuously.
Clear: Click to clear the coordinate jump ball drawn in the scene.
Goto: After clicking, the scene jumps to the position corresponding to the input coordinates and draws a
small ball according to the specified size.

Steps

1. After enabling the jump tool, select the target coordinate reference system, enter the 3D coordinates, and
click "Jump" to jump to the corresponding position.

This function is used to redirect the current scene view to the input target coordinate position.



Toolbox
Toolbox contains point cloud processing, result finishing, and other tools, which is used to process and analyze
the point cloud data. The toolbox includes the following tools.

Point Cloud Processing

Strip Clip
Individual Tree Segmentation
Convert LiData To Las
Merge Point Cloud and Vector Data
Export Mixed Color Point Cloud
Classify Circuit by Tower Info
Automatic Shield Line Classification
Classify Noise by Vector Line
Copy And Adjust Point Cloud Position
Interactive Patch Line
Classify By Category And Restatistics
Smooth/Compress Point Cloud Data

Result Finishing

Export Danger Points
Extract Danger Point Clouds
Extract Danger Trees
Tower Account
Section Map
Section Report
Merge Tower KML Files
Batch Rename Section Data Files

Other Tools

Open Working Directory



Strip Clip

Summary

Usage

Click Toolbox > Point Cloud Processing > Strip Clip

Settings

Channel Width (meter) (default is "60"): Width extending to both sides of the power line. The software can
record the user's current settings and automatically restore the settings when opened again.
Segment Buffer (meter) (default value is "10"): Extension distance at both ends of the transmission tower.
Start Tower Index: Towers with index numbers smaller than this value are not involved in the calculation.
The default value is the minimum Index in the tower file.
End Tower Index: Towers with index numbers larger than this value are not involved in the calculation. The

Input a point cloud has not been segmented and the tower information, and this tool will clip the point
cloud data into several parts along the power line. The function interface is shown in the figure below.
This function can process multiple data at the same time. Click to add the data to be processed.
Click to remove the selected data. Click to clear the data list.



default value is the maximum Index in the tower file.
Resample: If checked, input point cloud will be compressed.
Sampling Radius (meter) (default value is "0.01"): Minimum interval for point cloud sampling.
Output File: The output path of the result file.



Individual Tree Segmentation

Summary

Usage

Click Toolbox > Point Cloud Processing > Individual Tree Segmentation

Settings

Sigma (default value is "1.5"): Individual tree segmentation smoothing coefficient. If there are too many
trees, increase the smoothing factor, otherwise, decrease the smoothing factor.
Height Above Ground (meter) (default value is "1.0"): Point clouds above ground by distances greater
than this value are used for individual tree segmentation, and less than this value will not be segmented.
Threads Number (default value is "4"): Set the number of thread (1 to 32) to run this function. The
software can record the currently setting and when the user open this function again, the setting will be kept.

Note: If the point cloud has been segmented, user must clear the result of individual tree segmentation
before redoing the segmentation.

Perform individual tree segmentation for the input point cloud data. The function interface is shown in
the figure below. This function can process multiple data at the same time. Click to add the data to
be processed. Click to remove the selected data. Click to clear the data list.



Convert Lidata To Las

Summary

Usage

Click Toolbox > Point cloud Processing > Convert Lidata To Las

Parameter Settings

Mode
Single Line (default mode):Once checked, this function is used to process single LiData file. You

The classify function can be used to convert Lidata files to las files. The noise categories can be
removed from the point cloud file. Meanwhile, the input data can be merged and output. The function
interface is shown in the following figure. This function can process multiple data simultaneously. Click 

 to add data to be processed, click  to remove selected data, and click  to clear the data list.



should add single LiData file to the Data File List.
Multiple Line:Once checked, this function is used to process multiple work directory. You should select
the base directory of multiple working directory, then the target LiData files will be added to Data File List
automatically.

Options
Remove Noise: Once checked, the noise categories will be removed.
Merge Point Cloud: Once checked, this function will export an additional las file that merges the input
point cloud.

Specify Output Directory: If this option is checked, the output file will be generated in the specified
directory. If it is not checked, output files will be generated in the peer directory of the input file.
Num of thread(4 by default):Set the number of running threads of the function, which can support 1-32
threads. The software can record the user's current setting and automatically restore the setting when it is
opened again.



Merge Point Cloud and Vector Data

Summary

Usage

Click Toolbox > Point Cloud Processing > Merge Point Cloud and Vector Data

Settings

Delete Original Points: Unchecked by default. If this option is checked, the newly generated point cloud will
not contain the power line class points in the original data; otherwise, the power line points in the original

Merge the input point cloud and vector data, and generate the point cloud in the specified format. This
function is used to improve the point cloud quality when the power line point cloud is thin or partially
missing. The function interface is shown in the figure below. This function can process multiple data
simultaneously. Click to add the data to be processed. Click to remove the selected data. Click 

to clear the data list.



data will be kept.
Line Width (millimeter) (default value is "30"): The width of the power line generated from the vector data.
Point Spacing (meter) (default value is "0.01"): The spacing of each two adjacent power line points
generated from the vector data.
Discrete Points Number (default value is "10"): The discrete points number generated for each point in
the vector data. The larger this value is, the more dense the result point cloud will be.
Use Specified Class: If checked, only the specified category is used for merging, and other categories are
output normally.
Vector File: Set the path of the vector file.
Output Path: Set the path of output file.
Output File Format: The output format of the result, supporting lidata and las format.
Threads Number (default value is "4"): Set the number of thread (1 to 32) to run this function. The
software can record the currently setting and when the user open this function again, the setting will be kept.



Export Mixed Color Point Cloud

Summary

Usage

Click Toolbox > Point Cloud Processing > Export Mixed Color Point Cloud

Settings

Output Path: Set the path of the output file.
Classification: The class(es) of the points that need to be export with the color of those class(es). In the
result, the points with selected class(es) will be displayed in the color of those classes, and the other points
will be displayed in RGB, when the data is set to Display by RGB.
Output File Format: The output format of the result, supporting lidata and las format.
Threads Number (default value is "4"): Set the number of thread (1 to 32) to run this function. The
software can record the currently setting and when the user open this function again, the setting will be kept.

Note: The input data must have attribute of RGB color.

This function is used to generate the point cloud with color mixed by class and RGB color information of
the ground objects. The function interface is shown in the figure below. This function can process
multiple data at the same time. Click to add the data to be processed. Click to remove the
selected data. Click to clear the data list.



Classify Circuit by Tower Info

Summary

Usage

Click Toolbox > Point Cloud Processing > Classify Circuit by Tower Info

Parameter

Left Circuit Class: Select the class index of left circuit.
Right Circuit Class: Select the class index of right circuit.
Num of thread(4 by default): Set the number of running threads of the function, which can support 1-32
threads. The software can record the user's current setting and automatically restore the setting when it is
opened again.

Divide the conductors into left and right loops respectively. Each loop forms a class. The function
interface is shown in the figure below. This function can process multiple data at the same time. Click

to add data. Click to remove selected data. Click to remove data list.



Automatic Shield Line Classification

Summary

Usage

Click Toolbox > Point cloud Processing > Automatic Shield Line Classification

Parameters

Layer Number: The number of layers of lines before classification.
Slice thickness: The slice thickness of the wire cut along the transverse direction.
Cluster Threshold(m)(3.5 by default): When the point cloud data is clustered, the maximum spatial
separation distance, the power line points smaller than the threshold will be clustered into a cluster.
Middle Phase width(m)(2 by default): The width of the mid-phase area.
Num of thread(4 by default): Set the number of running threads of the function, which can support 1-32
threads. The software can record the user's current setting and automatically restore the setting when it is
opened again.

This function needs to divide the shield lines into conductors in advance; after this function, the shield
lines will be automatically separated. The function interface is shown in the figure below. This function
can process multiple data at the same time.Click to add data. Click to remove selected data. Click

to remove data list.



Classify Noise by Vector Line

Summary

Usage

Click Toolbox > Point cloud Processing > Classify Noise by Vector Line

Parameters

This function can divide unclassified points into noise and conductors by vector lines. The function
interface is shown in the figure below. This function can process multiple data at the same time.Click
to add data. Click to remove data selected. Click to remove data list.



Vector File Path:: The path of the vector line. The vector line is in shp format, including all the conductors of
all cuts.
From Class: Select the point cloud category that matches the vector file.
Powerline Diameter (m) (default is 0.75): The cross-sectional radius of the conductor can be input after
measuring with a tool. The default is 0.75 meters.
Filter range (m) (default value is "3.0"): The range for denoising the point cloud. Indicates how much noise
is removed around the conductor.
Remove Higher Noise: If checked, high-altitude noise points will be removed.
Num of thread(4 by default): Set the number of running threads of the function, which can support 1-32
threads. The software can record the user's current setting and automatically restore the setting when it is
opened again.



Copy and Adjust Point Cloud Position

Summary

Usage

Click Toolbox > Point cloud Processing > Copy and Adjust Point Cloud Position.

Save File

Copy Model File

This function requires the input of the point cloud to be copied. The function interface is shown in the
figure below, and it can copy at the same time in multiple locations.

Save the copied file.

Copy the model file.



Remove Data

Clear List

Parameter Settings

Translation: Perform translation on the copied point cloud.
Rotation: Perform rotation on the copied point cloud.
Model Point Cloud File: The model point cloud file to be copied.

Steps

1. Click on the model point cloud file to add the model point cloud file to be copied;
2. Click on an initial position point in the view, click on "Start Copy" to copy a data and add it to the list;
3. Adjust to the desired position through translation and rotation.

Remove the selected data.

Clear the data list.



Interactive Patch Line

Summary

Usage

Click Toolbox > Point cloud Processing > Interactive Patch Line

This feature is mainly used to fill in partially sparse or broken power lines. Click  to remove the
selected fitting result, click  to clear the fitting result list, click  to clear the fitting result list.



Fitting Result List

Parameter Settings

Line Type: The type of line to fit the selected area, which can be "Straight Line" or "Parabola" according to
the actual power line.
Target Category: The category of power line to be filled, default is conductor.
Line Width: The width of the power line to be fit in the selected area, default is 30mm.
Point Spacing: The spacing between discrete points for fitting the selected area, default is 0.01m.
Discrete Point Number: The number of discrete points for fitting the selected area, default is 2.
Translation: Translation parameters for the fitted result along the X/Y/Z coordinate axes.
Rotation: Rotation parameters for the fitted result around the X/Y/Z coordinate axes.

Steps

1. Move the scene to the area needing patch line and select a closed polygon.

2. Select the suitable target category and fitting parameters, click Calculate .

3. Adjust the position of the discrete fitted result through translation and rotation, then merge .

Fit and fill the selected area based on calculation, and preview the discrete point effect in the scene after
calculation is complete.

Clear the selected area.

Merge the point cloud and discrete points, and generate a point cloud file with the same name in the
output directory.



Classify By Category And Restatistics

Summary

Usage

Click Toolbox > Point cloud Processing > Classify By Category And Restatistics

Parameter Settings

Function Options
Classify (checked by default):Convert the target classes to the specified class.
Restatistics (checked by default):Recalculate the mean elevation and standard deviation, mean

The classify function can be used to convert the target classes to the specified class.The restatistics
function can be used to recalculate the mean elevation and standard deviation, intensity mean and
standard deviation of the point cloud data. The function interface is shown in the following figure. This
function can process multiple data simultaneously. Click  to add data to be processed, click  to
remove selected data, and click  to clear the data list.



intensity and standard deviation of the point cloud data.
Classification Parameters

From Class: Target classes to be converted.
Select All: Once checked, all existing classes will be selected as the target classes.
To Class: Specified class that target classes will be converted to.

Num of thread(4 by default):Set the number of running threads of the function, which can support 1-32
threads. The software can record the user's current setting and automatically restore the setting when it is
opened again.



Smooth/Compress Point Cloud Data

Summary

Usage

Click Toolbox > Point cloud Processing > Smooth/Compress Point Cloud Data

This function smooths and compresses input point cloud data, removing noise such as spikes while
reducing redundant data. It makes the point cloud data more uniform while maintaining the continuity of
its shape. The function interface is shown in the following figure. This function can process multiple data
simultaneously. Click  to add data to be processed, click  to remove selected data, and click 
to clear the data list.



Parameter Settings

Function Options
Smooth (checked by default): Smooth the point cloud data to remove noise and make it more uniform.
Compress (checked by default): Compress the point cloud data to reduce redundancy.

Parameters
Same as Source File Name (unchecked by default): If checked, the output file after
smoothing/compression will use the same name as the source file. Otherwise, a suffix "-
SmoothAndCompress" will be added to the file name.
Process by Category (checked by default): If checked, only the selected categories will be processed.
Otherwise, all points will be processed.

Smoothing Parameters

Line (checked by default): If checked, points in the categories of conductor, ground wire, shield wire,
and crossing wire will be smoothed/compressed. Otherwise, they will not be processed.
Tower (checked by default): If checked, points in the tower category will be smoothed/compressed.
Otherwise, they will not be processed.
Search Radius (default 0.50m for line categories, 0.3m for tower category): The distance threshold
for searching neighboring points during point cloud smoothing. The larger the value, the more significant
the smoothing effect, but if the value is too large, it may cause distortion.
Smoothing Factor (default 0.3 for line categories, 0.1 for tower category): The larger the value, the
more significant the smoothing effect, but if the value is too large, it may cause distortion.

Compression Parameters

Minimum Point Spacing (default 0.03m for line and tower categories, 0.10m for other categories):
The minimum spacing between laser points during point cloud compression. The smaller the value, the
weaker the compression effect; the larger the value, the stronger the compression effect.

Number of Threads (default value is "4"): Set the number of threads for the function to run, supporting 1-
32 threads. The software can record the user's current setting and automatically restore it the next time it is
opened.



Export Danger Points

Summary

Usage

Click Toolbox > Result Finishing > Export Danger Points

Settings

Clearance Data Type: Select the data type to be processed. The data type includes point cloud based data,
vector based data, and data based on working conditions simulation. The software can record the user's
current settings and automatically restore the settings when opened again.

Based on Point Cloud: Extract the power line data from the original point cloud data.
Based on Vector Data: Extract the power line data from the vector file, and other classes objects from
original point cloud data.
Based on Simulation Data: Extract the power line data from the simulation file, and other classes
objects from original point cloud data.

Output File: The output path of the kml file.

Export the clearance danger points into kml file, which can be viewed in Google Earth.



Extract Danger Point Clouds

Summary

Usage

Click Toolbox > Result Finishing > Extract Danger Point Clouds

Settings

Output Path: Set the output path of the result file.
Output File Format: The output format of the result, supporting lidata and las format.

Note: The new point cloud will only be generated when the original point cloud contains danger points;
otherwise, no point cloud will be generated.

After the clearance danger point detection, extract the points marked as "dangerous point" and generate
a new point cloud file. The function interface is shown in the figure below. This function can process
multiple data simultaneously. Click to add the data to be processed. Click to remove the selected
data. Click to clear the data list.



Extract Danger Trees

Summary

Usage

Click Toolbox > Result Finishing > Extract Danger Trees

Settings

Output Path: Set the output path of the result file.
Threads Number (default value is "4"): Set the number of thread (1 to 32) to run this function. The
software can record the currently setting and when the user open this function again, the setting will be kept.

Note: It is required to perform clearance danger point detection and individual tree segmentation before
executing this function.

Based on the result of clearance danger point detection and individual tree segmentation, extract all the
trees with danger points as parts of them. The function interface is shown in the figure below. This
function can process multiple data simultaneously. Click to add the data to be processed. Click 
to remove the selected data. Click to clear the data list.



Tower Account

Summary

Usage

Click Toolbox > Result Finishing > Tower Account

Settings

Power Line Name: Set the name of transmission line.
Based on Unsection Data: Check this option if input file is unsection point cloud.
Channel Width(Default value is "60.00m"): Width extending along both sides of the power line. The

Generate the tower account (xls file) based on the point cloud data and the tower file (LiTower file). The
function interface is shown in the figure below. This function can process multiple data simultaneously.
Click to add the data to be processed. Click to remove the selected data. Click to clear the
data list.



software can record the user's current settings and automatically restore the settings when opened again.
Extension Length(Default value is "10.00m"): Extension distance at both ends of the transmission tower.
Output File: Set the output path of the tower account.

Note: The input point cloud must contain the point in transmission tower class. The tower file (LiTower file)
corresponding to the transmission line must be in the project folder (working directory).



Section Map

Summary

Usage

Click Toolbox > Result Finishing > Section Map

Generate the power line section map based on the point cloud data. The function interface is shown in
the figure below. This function can process multiple data simultaneously. Click to add the data to be
processed. Click to remove the selected data. Click to clear the data list.



Settings

Power Line Name: Set the name of transmission line. The software can record the user's current settings
and automatically restore the settings when opened again.
Start Tower Index: Towers with index numbers smaller than this value are not involved in the calculation.
The default value is the minimum Index in the tower file.
End Tower Index: Towers with index numbers larger than this value are not involved in the calculation. The
default value is the maximum Index in the tower file.
Top View Zoom Ratio (default value is "1"): Set the top view zoom ratio.
Side View Zoom Ratio (default value is "1"): Set the side view zoom ratio.
Top View Font Size (default value is "15"): Set the top view font size.
Side View Font Size (default value is "20"): Set the side view font size.
Grid Row Spacing (meters) (default value is "30"): Set the grid row spacing.
Grid Column Spacing (meters) (default value is "30"): Set the grid column spacing.
Horizontal Scale (default value is "1/2000"): Set the horizontal scale.
Vertical Scale (default is "1/2000"): Set the vertical scale.
Left Line Color: Set the color of the left line.
Middle Line Color: Set the color of the middle line.
Right Line Color: Set the color of the right side line.
True Color: Whether to display in true color.
Generate Merged Image: Whether to generate merged image.
Output Path: Set the output path of the section maps.
Logo File: Set the logo file path.
Threads Number (default value is "4"): Set the number of thread (1 to 32) to run this function. The
software can record the currently setting and when the user open this function again, the setting will be kept.



Section Report

Summary

Usage

Click Toolbox > Result Finishing > Section Report

Report Parameters: Parameters related to report generation.
Assessor Company: The unit for report generation.
Electrical Transmission Bureau/Company: Name of power supply bureau.
Power Line Name: Name of power line.
Target Coordinate System: Coordinate system used in the report.
Report Path: Output path of the report.

Generate a plan and section report using a plan and section drawing. The function interface is shown in
the following figure. This function can process multiple data simultaneously. Click  to add data to be
processed, click  to remove selected data, and click  to clear the data list.



Merge Tower KML Files

Summary

Merge tower KML files, which is the reverse operation of Split Tower KML Files. The function interface is shown
below. This function can process multiple data at the same time. Click  to add data to be processed, click 
to remove selected data, click  to clear the data list.

Usage

Click Toolbox > Result Finishing > Merge Tower KML Files

Parameter Settings

Output Files: Set the path for the merged tower KML file.



Batch Rename Section Data Files

Summary

Usage

Click Toolbox > Result Finishing >Batch Rename Section Data Files

Parameter Settings

Rename section data files in batch based on tower files.The function interface is shown below,click to
add selected data,click to remove selected data,click to clear the file list.



Tower File: Select the tower information file.
Original Starting Tower Number: The smallest tower number in the data files to be added.
Modified Starting Tower Number: The number after modifying the original starting tower number,
subsequent tower numbers are changed based on the difference with the original starting tower number.



Detection Result List
Detection result lists include clearance danger point list, crossing analysis list, tree growth analysis list, tree
growth warning analysis list, tree fall analysis list, allowable stress analysis list, drainage thread clearance
analysis list, phase spacing analysis list, sag analysis list, power line and shield line distance analysis list and
nearest distance analysis list. The user can choose these tools to view the results of detection and check the
accuracy of the results.

Clearance Danger Points List

Scissors Crossing Analysis List

Tree Growth Analysis List

Tree Growth Warning Analysis List

Tree Fall Analysis List

Allowable Stress Analysis List

Drainage Thread Clearance Analysis List

Phase Spacing Analysis List

Sag Analysis List

Power Line And Shield Line Distance Analysis List

Nearest Distance Analysis List



Clearance Danger Points List

Summary

Clearance danger points list contains the result of the clearance danger points analysis. The interface of this tool
is shown as follow. Double-click the row of the danger point record to zoom to that point in the 3D scene.



Settings

Suspected Distance (meter) (default value is "2"): Suspected danger point distance. The danger points
with clearance distance less than this threshold will be marked as red in the danger points list. This
parameter is used to filter out the invalid danger points which is misclassified because of the error in the
classification process of the point cloud.

Data Type

Choose the data type, and the software will list the detection result of the corresponding data type.

Load Data

Note: Click the header of the detection result table to switch between ascending and descending display by
the selected attribute values in the table.

Note: After the detection, view details in the detection result list. Double-click the row of the danger point
record to zoom to that point in the 3D scene and display the distance between the danger point and the
power line. And judge if the danger point is misclassified due to the error in the classification of the point

Load or renew the detection result list.



cloud. If so, user can use Profile Tools to modify the classification result first, then Clear the detection
results. Finally redo the detection to correct the error.



Scissors Crossing Analysis List

Summary

Scissors crossing analysis list contains the result of the scissors crossing analysis. The interface of this tool is
shown as follow. Double-click the row of the crossing point record to zoom to that point in the 3D scene.



Settings

Suspected Distance (meter) (default value is "2"): Suspected danger point distance. The danger points
with clearance distance less than this threshold will be marked as red in the danger points list. This
parameter is used to filter out the invalid danger points which is misclassified because of the error in the
classification process of the point cloud.

Load Data

Note: Click the header of the detection result table to switch between ascending and descending display by
the selected attribute values in the table.

Note: After the detection, view details in the detection result list. Double-click the row of the danger point
record to zoom to that point in the 3D scene and display the distance between the danger point and the
power line. And judge if the danger point is misclassified due to the error in the classification of the point
cloud. If so, user can use Profile Tools to modify the classification result first, then Clear the detection
results. Finally redo the detection to correct the error.

Load or renew the detection result list.



Tree Growth Analysis List

Summary

Tree growth analysis list records the result of tree growth analysis, as is shown below. Each row contains the
coordinates of the danger treetop point and coordinates of the point on the power line which is closest to the
treetop.You can zoom to a specific danger tree in 3D viewer by double clicking the row.



Settings

Suspected Distance (meter) (default value is "2"): Suspected danger point distance. The danger points
with clearance distance less than this threshold will be marked as red in the danger points list. This
parameter is used to filter out the invalid danger points which is misclassified because of the error in the
classification process of the point cloud.

Load Data

Note: When the option "Customize the growth rates of different tree species" is checked, tree growth
analysis tool will not be applicable to those tree with unknown species information. But those trees which is
tall enough to be the "danger tree" will be marked as "danger tree" anyway.

Note: Click the header of the detection result table to switch between ascending and descending display by
the selected attribute values in the table.

Note: After the detection, view details in the detection result list. Double-click the row of the danger point
record to zoom to that point in the 3D scene and display the distance between the danger point and the
power line. And judge if the danger point is misclassified due to the error in the classification of the point
cloud. If so, user can use Profile Tools to modify the classification result first, then Clear the detection
results. Finally redo the detection to correct the error.

Load or renew the detection result list.



Tree Growth Warning Analysis List

Summary

Tree growth warning analysis list records the result of tree growth warning analysis, as is shown below. Each row
contains the clearance distance and growth year etc.You can zoom to a specific danger tree in 3D viewer by
double clicking the row.



Settings

Critical Time (year) (default value is "2"): Set the critical time. When the warning time is less than the
critical time, the record will be marked as red. This function is used to quickly view the distribution of danger
treetops.

Load Data

Note: Click the header of the detection result table to switch between ascending and descending display by
the selected attribute values in the table.

Note: After the detection, view details in the detection result list. Double-click the row of the danger point
record to zoom to that point in the 3D scene and display the distance between the danger point and the
power line. And judge if the danger point is misclassified due to the error in the classification of the point
cloud. If so, user can use Profile Tools to modify the classification result first, then Clear the detection
results. Finally redo the detection to correct the error.

Load or renew the detection result list.



Tree Fall Analysis List

Summary

Tree fall analysis list records the result of the tree fall analysis. The interface of this tool is shown as follow.
Double-click the row of the tree-fall danger point record to zoom to that point in the 3D scene.



Settings

Suspected Distance (meter) (default value is "2"): Suspected danger point distance. The danger points
with clearance distance less than this threshold will be marked as red in the danger points list. This
parameter is used to filter out the invalid danger points which is misclassified because of the error in the
classification process of the point cloud.

Load Data

Note: Click the header of the detection result table to switch between ascending and descending display by
the selected attribute values in the table.

Note: After the detection, view details in the detection result list. Double-click the row of the danger point
record to zoom to that point in the 3D scene and display the distance between the danger point and the
power line. And judge if the danger point is misclassified due to the error in the classification of the point
cloud. If so, user can use Profile Tools to modify the classification result first, then Clear the detection
results. Finally redo the detection to correct the error.

Load or renew the detection result list.



Allowable Stress Analysis List

Summary

Allowable stress analysis list records the result of allowable stress analysis, as is shown below. Double-click the
row to zoom to that power line in the 3D scene.



Load Data
Load or renew the analysis result list.



Drainage Thread Clearance Analysis List

Summary

Drainage thread clearance analysis list records the result of drainage thread clearance analysis, as is shown
below. Each row records the coordinates of the closest point on a single drainage line to the tower and the
coordinates of the corresponding point on the tower.



Settings

Suspected Distance (meters) (default value is "2"): Suspected danger point distance. The danger points
with clearance distance less than this threshold will be marked as red in the danger points list. This
parameter is used to filter out the invalid danger points which is misclassified because of the error in the
classification process of the point cloud.

Load Data

Note: Click the header of the detection result table to switch between ascending and descending display by
the selected attribute values in the table.

Load or renew the detection result list.



Phase Spacing Analysis List

Summary

Phase spacing analysis list records the result of phase spacing analysis, as is shown below. You can zoom to a
specific place in 3D viewer by double clicking the row.



Load Data

Note: Click the header of the detection result table to switch between ascending and descending display by
the selected attribute values in the table.

Note: After the detection, the details can be viewed in the phase spacing analysis list. Double-click the
detection record to zoom to that phase spacing location and the phase spacing will be highlighted
simultaneously.

Load or renew the detection result list.



Sag Analysis List

Summary

Sag analysis list records the result of sag analysis, as is shown below. Double-click the row of any record to
zoom to that point in the 3D scene.



Sag Analysis File List



Select the sag analysis file, and renew the detection result list. Sag analysis file list is loaded from the csv file in
the path of the sag analysis. The default path of the sag analysis is the working directory of the sag analysis
folder.

Load Data

Set Sag Analysis Directory

Note: Click the header of the detection result table to switch between ascending and descending display by
the selected attribute values in the table.

Note: If there is no angle of wind deflection, the angle of wind deflection records will not be displayed in the
list and scene.

Load or renew the detection result list.

Set the directory of the sag analysis and renew the sag analysis file list.



Nearest Distance Analysis List

Summary

The Nearest Distance Analysis List records the results of the nearest distance analysis. The interface is shown in
the following figure. Double-clicking on a row will navigate to the location of the point in the 3D scene.



Settings

Suspected Distance (meters) (default value is "2"): Suspected danger point distance. The danger points
with clearance distance less than this threshold will be marked as red in the danger points list. This
parameter is used to filter out the invalid danger points which is misclassified because of the error in the
classification process of the point cloud.

Load Data

Note: Click the header of the detection result table to switch between ascending and descending display by
the selected attribute values in the table.

Note: When merging the records, at least two records need to be selected. The operation of merging or
deleting will change the records in the corresponding danger points text file in the cache folder.

Note: After the detection, view details in the detection result list. Double-click the row of the danger point
record to zoom to that point in the 3D scene and display the distance between the danger point and the
powerline. And judge if the danger point is misclassified due to the error in the classification of the point
cloud. If so, user can use Profile Tool to modify the classification result first, then Clear the detection
results. Finally redo the detection to correct the error.

Load or renew the detection result list.



Tutorials
Realtime Working Analysis

Early Warning Analysis



Realtime Working Analysis
This tutorial introduces the standard workflow of realtime working analysis.

Steps

The main process for using the power line module to process point cloud data, detect dangerous points, and
generate dangerous point detection reports is as follows:

1. Click File > Data > Add Data to open data.
2. Click Power Line > Power Line Parameter Setting to set parameters of power line module.
3. Click Power Line > Mark Tower to mark position of towers and edit properties of towers.
4. Click Power Line > Train to generate training model for automatic classification.
5. Click Power Line > Clip and Classify to clip and classify point cloud data into tower, power line, ground

points, noise and unclassified data automatically. It is necessary to manually check the classification results
after automatic classification.

6. Click Power Line > Realtime Working Analysis to perform dangerous points detection, tree segmentation,
image rendering and report generation.

7. Click Power Line > Render Image to render images based on the results of danger points detection.
8. Click Power Line > Generate Report to generate an report based on the dangerous points detection result.

Tutorial Videos

1. LiPowerline Realtime Working Analysis

https://youtu.be/gwBy6RMkHzg


Early Warning Analysis
This tutorial introduces the standard workflow of comprehensive working simulation.

Steps

The main process for using the power line module to process point cloud data, detect dangerous points, and
generate dangerous point detection reports is as follows:

1. Click File > Data > Add Data to open data.
2. Click Power Line > Power Line Parameter Setting to set parameters of power line module.
3. Click Power Line > Mark Tower to mark position of towers and edit properties of towers.
4. Click Power Line > Train to generate training model for automatic classification.
5. Click Power Line > Clip and Classify to clip and classify point cloud data into tower, power line, ground

points, noise and unclassified data automatically. It is necessary to manually check the classification results
after automatic classification.

6. Click Power Line > Vectorization to semi-automatically vectorize insulators and power lines.
7. Click Power Line > Comprehensive Working Simulation to perform dangerous points detection, tree

segmentation, image rendering and report generation.
8. Click Power Line > Render Image to render images based on the results of danger points detection.
9. Click Power Line > Generate Report to generate an report based on the dangerous points detection result.

Tutorial Videos

1. LiPowerline Early Warning Analysis

https://youtu.be/gwBy6RMkHzg


Appendix
This chapter introduces some key terms, file formats and ways of high-performance graphics mode adjustment.

Key Terms

File Formats

LiData

LAS

LiModel

LiTin

Clipping Point Cloud File Format

Clip by Circle File Format

Clip by Rectangle File Format

Extract by Time File Format

POS File

OUT File

Control Point File Format

Notes Elevation Points File

Sample Data File

Seed Points File

Tower File

Simulation File

Homologous Points File Format

Individual Tree Segmentation Result File

Shortcut Keys

Menu Shortcut Keys

Viewer Shortcut Keys

Point Editing Shortcut Keys in Profile Window

High-Performance Graphics Mode Adjustment



Key Terms
Workflow – A sequence of steps to produce the final products.
Clipping – Extracting a subset of points from point cloud using an extent.
Extracting – Extracting a subset of points from point cloud using a specific point attribute.
Return Number – The Return Number is the pulse return number for a given output pulse. A given output
laser pulse can have many returns, and they must be marked in sequence of return. The first return will have
a Return Number of one, the second a Return Number of two, and so on up to five returns.
Intensity – The intensity value is the integer representation of the pulse return magnitude. This value is
optional and system specific. However, it should always be included if available.
Outlier – A point or group of points isolated from other points of interest that are considered noise or
extraneous objects.



File Formats
This section introduces the data formats supported by LiPowerline and the specific file formats involved in various
functional modules, such as POS file, control point file, seed point file and so on.

LiData

LAS

LiModel

LiTin

Clipping Point Cloud File Format

Clip by Circle File Format

Clip by Rectangle File Format

Extract by Time File Format

POS File

OUT File

Control Point File Format

Notes Elevation Points File

Sample Data File

Seed Points File

Tower File

Simulation File

Homologous Points File Format



LiData
LiData is a point cloud data file format defined by LiPowerline. It consists of a public header block, variable length
records, and point data records.

This format can be exchanged with other common point cloud data format files, including LAS, LAZ, PLY, ASCII,
etc.

When loading common point cloud data formats (including: LAS, LAZ, PLY, ASCII, etc.) into LiPowerline, a
LiData file named after the same name will be generated, and the subsequent operations are based on LiData.



LAS
The LAS file format is a public file format for point cloud data.

To download LAS specifications please go to:

LAS 1.1

LAS 1.2

LAS 1.3

LAS 1.4

https://www.asprs.org/committee-general/laser-las-file-format-exchange-activities.html
http://www.asprs.org/wp-content/uploads/2010/12/asprs_las_format_v11.pdf
http://www.asprs.org/wp-content/uploads/2010/12/asprs_las_format_v12.pdf
http://www.asprs.org/wp-content/uploads/2010/12/LAS_1_3_r11.pdf
http://www.asprs.org/wp-content/uploads/2010/12/LAS_1_4_r13.pdf


LiModel
LiModel file stores triangulated regular network models generated by DEM or DSM. It saves regular grid nodes
and block-organized triangulated regular network models according to quadtree. DOM texture information can be
superimposed on the model. LiModel could be transformed from massive data of DEM or DSM. It supports
editing operations including flatten height, smooth height, noise points removal and so on. After editing, it can be
exported to Tiff file for generating contours.



LiTin
The LiTin file is generated by the irregular 2.5D triangulation model based on the point cloud. It can improve
quality of contour lines by editing operations including flatten height, smooth height, vertex addition and removal,
etc. It organizes data in full memory mode, which takes up large memory and causes low rendering efficiency. So
it is suggested to generate LiTin file into tiles.



Clipping Point Cloud File Format

Brief

The file is a text file that contains a list of scopes used to load multiple circles or rectangles.

Clip by Circle File Format

Each circle consists of three values separated by commas: the X coordinate, the Y coordinate and the radius of
the center.

The following table is an example of a circular extent file:

322610.51, 4102305.22, 50

322685.86, 4102400.5, 50

322820.45, 4102510.21, 100

322850.35, 4102655.33, 100

323000.00, 4103000.00, 60

The above values can be stored in a text file (such as "extents.txt") and loaded into the LiPowerline software.

Clip by Rectangle File Format

Each rectangle consists of four values separated by commas: X minimum, X maximum, Y minimum and Y
maximum.

The following table is an example of a rectangular extent file:

322601.255, 322801.255, 4102309.655, 4102409.655

322548.966, 322600.110, 4102310.180, 4102360.180

322539.155, 322600.255, 4102309.655, 4102359.655

322745.950, 322780.110, 4102204.660, 4102250.180

322875.224, 322975.224, 4102028.660, 4102128.660

The above values can be stored in a text file (such as "extents.txt ") and loaded into the LiPowerline software.



Extract by Time File Format
Each extraction range consists of two values separated by commas: starting GPS time and ending GPS time.

The following table is an example of extracting range files by GPS time:

526494.500,527494.500

527494.500, 528494.500

527494.500, 528494.500

528494.500, 529494.500

529494.500, 530494.500

The above values can be stored in a text file (such as "extents.txt ") and loaded into the LiPowerline software.



Homologous Points File Format
Homologous points file is a comma separated text file. The first row is a file header. Each row consists of 9
columns: ID, reference coordinate (X,Y,Z), reference source file, alignment coordinate(X,Y,Z) and alignment
source file.

 ID     ref_X        ref_Y        ref_Z           file                align_X       align_Y    align_Z  file
P01, 322500.1100, 4102499.9600, 2613.1400, E:/data/LiForest.LiData, 322500.0089, 4102499.9856, 0.0000, null
P02, 322999.8400, 4102499.7900, 2614.3400, E:/data/LiForest.LiData, 322999.9283, 4102499.9585, 0.0000, null
P03, 322999.8300, 4102000.3200, 2554.4100, E:/data/LiForest.LiData, 322999.8738, 4102000.1457, 0.0000, null
P04, 322500.3700, 4102000.1600, 2490.7400, E:/data/LiForest.LiData, 322500.1140, 4102000.0595, 0.0000, null



POS File
The POS File contains information such as GPS time, longitude, latitude, height, roll, pitch, heading, GridX and
GridY. GPS time, longitude, latitude, height, roll, pitch and heading must be necessary, while GridX and GridY
are optional. If POS file doesn't include GridX and GridY, we need to set projection coordinate system when we
input trajectory files. GridX and GridY can be calculated according to projection coordinate system, longitude and
latitude in strip alignment module.

The trajectory information stored in its file is structured as follows:

Data Units Type

GPS time seconds double

longitude degree double

latitude degree double

height meters double

roll degree double

pitch degree double

heading degree double

GridX(Optional) meters double

GridY(Optional) meters double

The examples the POS file is shown below. Example 1(not including GridX, GridY):

 380954.000,112.5311950876, 26.8969520123,378.543,  7.1701230000,  3.0890110000,-39.4065340000
 380954.008,112.5311938923, 26.8969533249,378.537,  7.2001860000,  3.0914780000,-39.4034150000
 380954.016,112.5311926975, 26.8969546376,378.531,  7.2368710000,  3.0936380000,-39.4011190000
 380954.024,112.5311915034, 26.8969559507,378.525,  7.2683090000,  3.1015050000,-39.3975470000
 380954.032,112.5311903098, 26.8969572641,378.518,  7.3007560000,  3.1115160000,-39.3929590000
 380954.040,112.5311891169, 26.8969585779,378.512,  7.3269790000,  3.1179720000,-39.3878260000
 380954.048,112.5311879247, 26.8969598920,378.506,  7.3525870000,  3.1180460000,-39.3804020000
 380954.056,112.5311867331, 26.8969612065,378.500,  7.3745730000,  3.1151630000,-39.3713830000

Example 2(including GridX, GridY):

383207.336,112.5421590662,26.9034172036,313.865,3.538615,2.660518,-67.848653,653147.099716932,2976670.62354689
383207.344,112.5421572108,26.9034177865,313.861,3.533299,2.659177,-67.840828,653146.914649722,2976670.68587654
383207.352,112.5421553554,26.9034183697,313.857,3.522385,2.658042,-67.828619,653146.729582108,2976670.74823943
383207.36,112.5421535001,26.9034189529,313.854,3.512757,2.659231,-67.816251,653146.544524429,2976670.81060244
383207.368,112.5421516447,26.9034195363,313.85,3.502656,2.662677,-67.807435,653146.35945655,2976670.87298749
383207.376,112.5421497892,26.9034201198,313.846,3.502243,2.664987,-67.803265,653146.174378605,2976670.9353835
383207.384,112.5421479336,26.9034207035,313.843,3.500293,2.668456,-67.80232,653145.989290462,2976670.99780155
383207.392,112.5421460783,26.9034212874,313.839,3.501546,2.671267,-67.797563,653145.804231844,2976671.06024212
383207.4,112.5421442231,26.9034218713,313.835,3.496569,2.674773,-67.789195,653145.619183163,2976671.12268281
383207.408,112.542142368,26.9034224554,313.832,3.483849,2.676885,-67.774991,653145.434144147,2976671.18514579
383207.416,112.5421405129,26.9034230395,313.828,3.471533,2.676137,-67.765536,653145.24910513,2976671.24760876
383207.424,112.5421386577,26.9034236237,313.824,3.47028,2.675779,-67.760612,653145.064056049,2976671.3100827
383207.432,112.5421368024,26.9034242079,313.82,3.475101,2.677064,-67.761833,653144.878997039,2976671.37255652
383207.44,112.5421349471,26.9034247923,313.817,3.476053,2.681571,-67.761664,653144.69393776,2976671.43505249



OUT File
Out file is a binary file that stores trajectory information. The following table shows the format of the POSPac
SBET file provided by Applanix. For details, refer to the PosPac quick start guide.

The trajectory information stored in its file is structured as follows:

Data Units Type

time seconds double

latitude radians double

longitude radians double

altitude meters double

x velocity meters/second double

y velocity meters/second double

z velocity meters/second double

roll radians double

pitch radians double

platform heading radians double

wander angle radians double

x body acceleration meters/second² double

y body acceleration meters/second² double

z body acceleration meters/second² double

x body angular rate radians/second double

y body angular rate radians/second double

z body angular rate radians/second double

https://www.applanix.com


Control Point File Format
The control point file contains a list of control points in TXT format. The first row is the file header, while other
rows store comma separated X, Y, Z coordinates of control points. The following table is an example of a control
point file:

X, Y, Z
473575.563, 291005.332, 127.244
473576.899, 291004.245, 126.328
473576.899, 291004.243, 126.317
473576.899, 291004.245, 126.328
473576.899, 291004.243, 126.317



Notes Elevation Points File
The notes elevation points file is a comma-delimited CSV file. The first row is the file header, while other rows
store X, Y, Z and Label (separated by comma).

The following figure shows an example of notes elevation points file:

X, Y, Z, Label
322539.46, 4102000.01, 2489.21, 2489.21
322551.33, 4102009.72, 2489.55, 2489.55
322562.85, 4102000.03, 2489.74, 2489.74
322563.16, 4102019.38, 2489.98, 2489.98 
322511.58, 4102056.04, 2492.86, 2492.86



Sample Data File
The sample data file is a text file (*.txt) delimited by commas that contains a file header in the first row. The first
two columns of each row are the X and Y coordinates, followed by a number of dependent variables. Multiple
dependent variables can be stored, but only one is used for each regression analysis.

The dependent variable is tree height in the following example of a sample data file:

X,Y,Height
322859.25,4102463.86,33
322862.25,4102459.35,31.5
322864.56,4102462.49,32
322874.58,4102463.50,35
322655.52,4102192.25,21.1



Seed Points File
Seed points file is a comma-separated CSV file. The first row is the file header, while other rows contain a
number of seed points. Each row contains four columns: tree ID, tree location X coordinate, tree location Y
coordinate and tree location Z coordinate.

The following table shows an example of a seed points file:

TreeID,TreeLocationX,TreeLocationY,TreeLocationZ    
1,322971.5,4102497.5,47.387
2,322549.5,4102496.5,49.42    
3,322678.5,4102495.5,48.456    
4,322716.5,4102494.5,34.366    
5,322516.5,4102489.5,23.726



Tower File
Tower file is a customized text format file (*.LiTower). The first row is the file header, while other rows store X, Y,
Z, type, and name of each tower (separated by comma). The index is assigned automatically by the software,
while the name is set the same as the index by default. Type "N" represents the tension tower, type "Z"
represents the straight line tower.

Here is an example of part of tower file:

Index,X,Y,Z,Type,Name
11,740662.360000,2688164.090000,79.850000,N,1
12,740750.560000,2688525.920000,82.040000,Z,2



Simulation File
The working condition simulation file is in text format (*.LiSim), and contains working condition information and
power line coordinate information. The first line indicates the power line type, the second line indicates the
detected line voltage level, and the third and fourth lines indicate power line temperature, ice thickness, and wind
speed information (separated by "\t") for scanning and simulated conditions. The fifth line indicates the number of
power lines, and the sixth row to the last row indicate the power line coordinate information. The coordinate
information includes 17 columns (separated by "\t"), 1-3 columns indicate the X, Y, and Z coordinates of the start
point of the power line , 4-6 columns indicate the X, Y, and Z coordinates of the end point of the power line , and
columns 7-9 indicate the X, Y, and Z coordinates of the middle point of the power line , the columns 10-12
indicate the X, Y, and Z coordinates of the intersection of the start insulator and the tower body, and the columns
13-15 indicate the X, Y, and Z coordinates of the intersection of the end insulator and the tower body, 16-17
indicates whether the start and end insulators are offset under simulated conditions (0 means no offset, 1 means
offset).

Here is an example of part of simulation file:

LGJ-240/30
500
0.0000    0.0000    0.0000
0.0000    0.0000    15.0000
5
666863.9100    2716344.4400    269.0700    667120.0300    2716612.3100    184.3700    666991.9700    2716478.3750    
212.5901    666863.9100    2716344.4400    269.0700    667120.0300    2716612.3100    184.3700    0    0
664593.8598    2712726.3097    200.0400    664939.7626    2712980.7251    273.4400    664766.8112    2712853.5174    
219.8623    664593.8598    2712726.3097    200.0400    664939.1500    2712981.5597    276.4400    0    1
664939.7626    2712980.7251    273.4400    665273.5201    2713225.1898    279.0200    665106.6413    2713102.9574    
260.7851    664939.1500    2712981.5597    276.4400    665273.5201    2713225.1898    279.0200    1    0
665281.4701    2713230.9998    279.7300    665553.3276    2713435.1702    357.2400    665417.3988    2713333.0850    
305.7610    665281.4701    2713230.9998    279.7300    665552.7100    2713436.0000    360.2400    0    1
665553.3276    2713435.1702    357.2400    665680.6977    2713530.4203    382.0800    665617.0127    2713482.7952    
366.9125    665552.7100    2713436.0000    360.2400    665680.0801    2713531.2501    385.0800    1    1



CHM Segmentation Result
The CHM segmentation result contains a comma-separated CSV table file and a polygon-type shp vector file.

The CSV table contains the attributes of tree ID, x, y coordinate position, tree height, crown diameter and crown
area.

The following table shows an example of the segmentation result of CHM:

TreeID, TreeLocationX, TreeLocationY, TreeHeight, CrownDiameter, CrownArea
1, 322716.24, 4102494.69, 36.165, 8.982, 63.36
2, 322751.21, 4102499.9, 41.282, 4.491, 15.84
3, 322519.35, 4102499.3, 32.008, 4.708, 16.64
4, 322742.15, 4102497.7, 26.956, 8.347, 54.72
5, 322892.26, 4102499.5, 45.493, 7.792, 47.68

The SHP file contains the boundary range of each tree. The attribute table contains the ID, x, y coordinate
position, tree height, crown diameter and crown area attributes of each tree.



ALS Forest results of point cloud segmentation & PCS
with Seeds
The ALS Forest results of point cloud segmentation and PCS with seeds are comma-separated CSV table files
containing the attributes of tree ID, x, y coordinate position, tree height, crown diameter, crown area and crown
volume.

The following table shows an example of the results of the ALS individual tree segmentation:

TreeID, TreeLocationX, TreeLocationY, TreeHeight, CrownDiameter, CrownArea, CrownVolume
1, 322511.52, 4102089.78, 60.606, 10.85, 92.04, 3240.171
2, 322511.81, 4102015.14, 53.785, 13.15, 135.09,4358.651 
3, 322537.43, 4102062.51, 46.667, 12.45, 126.76, 3272.472
4, 322529.42, 4102073.12, 45.197, 4.071, 13.019, 342.992 
5, 322525.07, 4102101.07, 43.861, 3.105, 7.57, 107.672

TLS Forest results of point cloud segmentation & PCS
with Seeds
The TLS Forest results of point cloud segmentation and PCS with seeds are comma-separated CSV table files
containing the attributes of tree ID, x, y coordinate position, tree height and DBH.

The following table shows an example of the results of the TLS individual tree segmentation:

TreeID, TreeLocationX, TreeLocationY, TreeHeight, DBH
1, 136547.147, 289995.532, 6.498, 0.081
2, 136562.037, 289985.496, 5.652, 0.112
3, 136543.853, 290001.586, 6.115, 0.078
4, 136547.766, 289997.909, 5.868, 0.081
5, 136547.127, 289980.102, 5.217, 0.097



Working Condition Parameter File
The segmented working condition parameter file is in text format and is saved by default as a segmented working
condition parameter. csv file in the line information folder under the working directory, storing segmented working
condition parameter information. The file is divided into six columns, separated by "," with the first column
indicating the serial number; The second column represents the starting tower number; The third column
represents the end tower number; The fourth column represents the name of the starting tower; The fifth column
represents the end tower name; The sixth to eleventh columns represent the operating conditions parameters.

The following is an example of the segmented working condition parameter file section:

Index,StartTowerIndex,EndTowerIndex,StartTowerName,EndTowerName,ScanningConditionWireTemperature(℃),ScanningConditio
nIceThickness(mm),ScanningConditionWindSpeed(m/s),SimulationConditionWireTemperature(℃),SimulationConditionIceThickn
ess(mm),SimulationConditionWindSpeed(m/s)
1,0,7,#0,#7,0,10,0,20,0,10



Shortcut Keys
This section introduces the shortcut keys associated with menus, viewers and point editing in profile windows.

Menu Shortcut Keys

Viewer Shortcut Keys

Point Editing Shortcut Keys in Profile Window



Menu Shortcut Keys

Shortcut Key Meaning

Ctrl+Shift+O Open files supported by LiPowerline

Alt+F4 Exit LiPowerline

Ctrl+F3 Add New window

Ctrl+F4 Close Current Window

F11 Full Screen

F3 Orthogonal/ Perspective Projection

F1 Help



Viewer Shortcut Keys

Shortcut Key Meaning

A Anticlockwise Rotation

G Clockwise Rotation

C Front Rotation

E Back Rotation

T Tips

W Show Model/Triangle/Points

P Adjust lighting (improve the display effect of LiModel, LiTin, OSGB and other model files)

↑ Up

↓ Down

← Left

→ Right

+ Zoom in

- Zoom out

Left Button Rotation

Right Button Pan

Middle Wheel Zoom

Space Default

Delete Delete Label/Delete Seed Points



Point Editing Shortcut Keys in Profile Window

Shortcut
Key Meaning

0-9 Modify the currently selected points to the new classification indicated by the number key
pressed

L Activate the "Line Above Selection" tool

Shift+L Activate the "Line Below Selection" tool

Shift+R Activate the "Rectangle Selection" too

Shift+P Activate the "Polygon Selection" tool

Shift+C Activate the "Circle Selection" tool

Q Switch between different selection tools in order

R Activate / deactivate rotation tool

Ctrl+Shift+Z Clear Selection

Ctrl+Shift+S Save

↑ Move the cross-section/profiling area forward

↓ Move the cross-section/profiling area backward

→ Rotate the cross-section/profiling area clockwise

← Rotate the cross-section/profiling area counter-clockwise



High-Performance Graphics Mode Adjustment
Follow the procedure below to optimize graphics for LiPowerline (for NVIDIA graphic cards).

1. Right click on desktop and select NVIDIA Control Panel.

2. Select Manage 3D settings > Program Settings > Add to add LiPowerline.exe to high-performance
graphics mode list.





FAQ
This chapter introduces the frequently asked questions and solutions in the use of LiPowerline. It contains
Installation and License Activation FAQ, Platform FAQ, Strip Alignment FAQ, Terrain FAQ, Forestry FAQ and
Power Line FAQ.

Installation and License Activation FAQ

Platform FAQ

Power Line FAQ



Hardware requirements and supported operating
systems

RAM: at least 8G or more.
CPU: Intel® Core™ i5/i7; Dual-core processor.
Display Adapter: NVIDIA graphics above GTX 970, video memory no less than 4GB.
Operating Systems: Microsoft Windows 7 (64-bit), Microsoft Windows 8 (64-bit), Microsoft Windows 10 (64-
bit), Microsoft Windows 11 (64-bit), Microsoft Windows Server 2012 and higher.

After successful installation on my computer, why does
the software crash when I try to open or load data?

Please check whether the software installation environment satisfies the recommended hardware
configuration. If yes, please check the following two things. (1) Whether the graphic card is working properly.
Right click on My Computer, select the device manager, find the corresponding graphic card in the Display
Adapter, and view the graphic card properties status. If it shows "this device is working normally", it means
that the graphic card device is running properly. (2) Update the graphic card driver to the latest version, and
then use the high-performance graphic mode to run the software. For the operating procedure, see adjust
the graphics mode to high performance.
Please contact us by email info@greenvalleyintl.com to check the reason remotely if you still get an error.

How to activate LiPowerline?
Send Activation Information: Run the software as administrator, click Help > Activate License in the
menubar, or double-click the License.exe in the installation directory.

mailto:info@greenvalleyintl.com


Fill in Name (Mandatory);
Fill in Company (Mandatory);
Select the appropriate module(s);
Click Copy;
Send an email with the copied content to info@greenvalleyintl.com.

Activate License:
Copy the license code to your local drive. Pleaser refer to the License Manager for license activation.

Does LiPowerline support Windows Server System?
Windows Server is supported.

Please install and activate LiPowerline using the administrator account. The software must be installed
in the folder to which all users have access.

mailto:info@greenvalleyintl.com


How to check the version information of LiPowerline
software?

You can check the version information of LiPowerline in Help > About.

How to change the menu language?
Click Display > Language in the menubar. Currently the supported language is English.

Why does the software exit abnormally?
Based on our experience, the major two reasons of abnormal exits are the insufficient disk space or memory
space in your computer and the existence of opened instance of screen word capturing software. If you meet
any other scenarios that lead to abnormal exits, please contact us info@greenvalleyintl.com.

What are the supported data formats in LiPowerline?
LiPowerline can import the following data formats:

Point Cloud: Proprietary LiData File(*.LiData), LAS File(*.las,*.laz), ASCII File(*.txt, *.asc, *.neu, *.xyz,
*.pts, *.csv), PLY File(*.ply).
Raster: Image File(*.tif,*.jpg).
Vector: Vector File(*.shp).
Table: Table File(*.csv)
Model: Proprietary Model File(*.LiModel), Proprietary TIN File*.LiTin), OSG Model File(*.osgb, *.ive,
*.desc, *.obj).

LiPowerline can export the following data formats:

mailto:info@greenvalleyintl.com


Point Cloud: Proprietary LiData File(*.LiData), LAS File(*.las,*.laz), ASCII File(*.txt, *.asc, *.neu, *.xyz,
*.pts, *.csv), PLY File(*.ply).
Raster: Image File(*.tif,*.jpg).
Vector: Vector File(*.shp, *.dxf)
Table: Table File(*.csv)
Model: Proprietary Model File(*.LiModel), Proprietary TIN File(*.LiTin).

If the color scheme of the data displayed in the viewer
window is not correct, how can I correct this?

First, right click on the desktop. Select NVIDIA Control Panel.
Second, select manage 3D settings > program settings > add to add LiPowerline software to the list of
high-performance graphics mode. Refer to adjust high-performance graphics mode.

How to fix drag and drop in windows 8 and windows 10?
Go to RUN, or search "regedit.exe" then run as administrator. On Registry Editor go to:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System, double click
"EnableLUA", and change the value from 1 to 0. Restart windows, and the problem will be solved.
Reference.

Why is the EDL visual effect not obvious if multiple data
are added in the same window?

It's recommended to show distant multiple data in separate windows with EDL effect. Or remove unwanted
data in the current window.

What is the unit of point cloud data in LiPowerline?
The unit is meter. If users have point clouds with foot or other units, they can be converted by Data
Management > Point Cloud Tools > Transformation. An example is shown in the following figure. X, Y, Z
coordinates are multiplied by 0.3048 to be converted from foot to meter.

https://answers.microsoft.com/en-us/windows/forum/windows_10-files/how-to-fix-drag-and-drop-in-windows-10/0ea16377-dfcf-4a28-9e38-c35f4113202b?page=13&auth=1


Is LiPowerline capable to handle the point cloud
generated by photogrammetry software?

Yes, it is.

How does LiPowerline perform seven parameter
transformations?

Click Data Management > Point Cloud Tools > Reproject.
Check Use Seven Parameters.
Input seven parameters: translations X, Y, Z; rotations Rx, Ry, Rz; and scale λ.
Select target coordinate reference system. (You have to define projection for the point cloud if it doesn't have
source coordinate reference system)



How to subsample the point cloud uniformly?



LiPowerline provides subsampling methods by Minimum Points Spacing, Sampling Rate, or Octree. The
subsampling by Octree is an uniform method.

Click Data Management > Point Cloud Tools > Subsampling, then select the sampling type Octree.

How to Pick Rotation Center while using the Pick Multi-
Point tool?

Hold the Ctrl key and pick rotation center by left-click.

Why are point cloud transformation results incorrect in
LiPowerline?

This is because different units are used in each program. In LiPowerline degree units are used. In order to
carry out a correct transformation, the units must be degrees.



Can I modify the name of a point cloud file generated by
clip?

No, the point cloud file name is associated with the tower file.

After completing clip, can you edit the tower file?
No, this may cause that the point cloud file did not match with the tower file.



LiPowerline Version Release Notes

v1.0 - 16/10/2016
First version release of LiPowerline



End User License Agreement
PLEASE READ CAREFULLY BEFORE USING THIS SOFTWARE PRODUCT: This End-User License
Agreement ("EULA") is a contract between (a) you (either an individual or the entity you represent) and (b)
GreenValley International Inc ("GVI") that governs your use of the software product ("Software"). This EULA
does not apply if there is a separate license agreement between you and GVI or its suppliers for the Software,
including a license agreement in online documentation. The term "Software" may include (i) associated media, (ii)
a user guide and other printed materials, and (iii) "online" or electronic documentation (collectively "User
Documentation").

RIGHTS IN THE SOFTWARE ARE OFFERED ONLY ON THE CONDITION THAT YOU AGREE TO ALL
TERMS AND CONDITIONS OF THIS EULA. BY INSTALLING, COPYING, DOWNLOADING, OR OTHERWISE
USING THE SOFTWARE, YOU AGREE TO BE BOUND BY THIS EULA. IF YOU DO NOT ACCEPT THIS
EULA, DO NOT INSTALL, DOWNLOAD, OR OTHERWISE USE THE SOFTWARE. IF YOU PURCHASED THE
SOFTWARE BUT DO NOT AGREE TO THIS EULA, PLEASE RETURN THE SOFTWARE TO YOUR PLACE OF
PURCHASE WITHIN FOURTEEN DAYS FOR A REFUND OF THE PURCHASE PRICE; IF THE SOFTWARE IS
INSTALLED ON OR MADE AVAILABLE WITH ANOTHER GVI PRODUCT, YOU MAY RETURN THE ENTIRE
UNUSED PRODUCT.

1. THIRD PARTY SOFTWARE. The Software may include, in addition to GVI proprietary software ("GVI
Software"), software under licenses from third parties ("Third Party Software" and "Third Party License"). Any
Third-Party Software is licensed to you subject to the terms and conditions of the corresponding Third-Party
License. Generally, the Third-Party License is in a file such as "license.txt" or a "readme" file. You should
contact GVI support if you cannot find a Third-Party License.

2. LICENSE RIGHTS. You will have the following rights provided you comply with all terms and conditions of
this EULA:

a. Use. GVI grants you a license to Use one copy of the GVI Software. "Use" means installing, copying,
storing, loading, executing, displaying, or otherwise using the GVI Software. You may not modify the GVI
Software or disable any licensing or control feature of the GVI Software. If this Software is provided by GVI
for Use with an imaging or printing product (for example, if the Software is a printer driver, firmware, or add-
on), the GVI Software may only be used with such product ("GVI Product"). Additional restrictions on Use
may appear in the User Documentation. You may not separate component parts of the GVI Software for
Use. You do not have the right to distribute the GVI Software.

b. Copying. Your right to copy means you may make archival or back-up copies of the GVI Software,
provided each copy contains all the original GVI Software's proprietary notices and is used only for back-up
purposes.

3. UPGRADES. To Use GVI Software provided by GVI as an upgrade, update, or supplement (collectively
"Upgrade"), you must first be licensed for the original GVI Software identified by GVI as eligible for the
Upgrade. To the extent the Upgrade supersedes the original GVI Software, you may no longer use such GVI
Software. This EULA applies to each Upgrade unless GVI provides other terms with the Upgrade. In case of
a conflict between this EULA and such other terms, the other terms will prevail.

4. TRANSFER. You may not rent, lease or lend the GVI Software or Use the GVI Software for commercial
timesharing or bureau use. You may not sublicense, assign or otherwise transfer the GVI Software except as
expressly provided in this EULA.



5. PROPRIETARY RIGHTS. All intellectual property rights in the Software and User Documentation are owned
by GVI or its suppliers and are protected by law, including applicable copyright, trade secret, patent, and
trademark laws. You will not remove any product identification, copyright notice, or proprietary restriction
from the Software.

6. LIMITATION ON REVERSE ENGINEERING. You may not reverse engineer, decompile, or disassemble the
GVI Software, except and only to the extent that the right to do so is allowed under applicable law.

7. CONSENT TO USE OF DATA. GVI and its affiliates may collect and use technical information you provide in
relation to (i) your Use of the Software or the GVI Product, or (ii) the provision of support services related to
the Software or the GVI Product. All such information will be subject to GVI's privacy policy. GVI will not use
such information in a form that personally identifies you except to the extent necessary to enhance your Use
or provide support services.

8. LIMITATION OF LIABILITY. Notwithstanding any damages that you might incur, the entire liability of GVI and
its suppliers under this EULA and your exclusive remedy under this EULA will be limited to the amount
actually paid by you for the Product. TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, IN
NO EVENT WILL GVI OR ITS SUPPLIERS BE LIABLE FOR ANY SPECIAL, INCIDENTAL, INDIRECT, OR
CONSEQUENTIAL DAMAGES (INCLUDING DAMAGES FOR LOST PROFITS, LOST DATA, BUSINESS
INTERRUPTION, PERSONAL INJURY, OR LOSS OF PRIVACY) RELATED IN ANY WAY TO THE USE OF
OR INABILITY TO USE THE SOFTWARE, EVEN IF GVI OR ANY SUPPLIER HAS BEEN ADVISED OF
THE POSSIBILITY OF SUCH DAMAGES AND EVEN IF THE ABOVE REMEDY FAILS OF ITS ESSENTIAL
PURPOSE. Some states or other jurisdictions do not allow the exclusion or limitation of incidental or
consequential damages, so the above limitation or exclusion may not apply to you.

9. U.S. GOVERNMENT CUSTOMERS. Software was developed entirely at private expense. All Software is
commercial computer software within the meaning of the applicable acquisition regulations. Accordingly,
pursuant to US FAR 48 CFR 12.212 and DFAR 48 CFR 227.7202, use, duplication and disclosure of the
Software by or for the U.S. Government or a U.S. Government subcontractor is subject solely to the terms
and conditions set forth in this End User License Agreement, except for provisions which are contrary to
applicable mandatory federal laws.

10. COMPLIANCE WITH EXPORT LAWS. You will comply with all laws, rules, and regulations (i) applicable to
the export or import of the Software, or (ii) restricting the Use of the Software, including any restrictions on
nuclear, chemical, or biological weapons proliferation.

11. RESERVATION OF RIGHTS. GVI and its suppliers reserve all rights not expressly granted to you in this
EULA.
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